Installation Instructions for Hot Fix K02001 
Windows for x64 
K02001 is a "container" hot fix that contains the following "member" hot fixes which will update the software components as indicated.
J71002 updates SAS Detail Data Store for Insurance 5.5
J98001 updates SAS Firmwide Risk Management for Insurance Server 2.12
J99001 updates SAS Market Risk Management for Insurance Server 2.12
K26001 updates SAS Risk Management for Insurance Mid-Tier 2.12
J97001 updates SAS Risk Management for Insurance Server 2.12
K22001 updates SAS Risk Reporting Repository for Insurance 2.12
K01001 updates SAS Underwriting Risk Management for Life Insurance Server 2.12
K21001 updates SAS Underwriting Risk Management for P&C Insurance Server 2.12

Before applying this hot fix, follow the instructions in SAS Note 35968 to generate a SAS Deployment Registry report, and then verify that the appropriate product releases are installed on your system. The software components and release numbers should match the list of software components updated by the individual hot fix installers.
The hot fix downloaded, K02001pt.zip, includes the updates required for all components listed above on all applicable operating systems. To apply this hot fix on multiple machines, you can either save K02001pt.zip on each machine or save it in a network location that is accessible to all machines. 
Do NOT extract the contents of K02001pt.zip. The hot fix installation process will extract the contents as needed. 
IMPORTANT NOTES
1.  Files delivered in this hot fix will be backed up during the installation process. However, it is good general practice to back up your system before applying updates to software.
2. Take backups of all .spk files prior to importing newer versions or making any updates to the contents of an existing .spk file. This can be done by first logging into the SAS Management Console (SMC) using the Administrator (sasadm) user, navigating to the appropriate folder containing metadata and exporting the folder contents to a uniquely named .spk file. 
3. Configurations and related uncompiled macro files for the following reports will be updated in this install.  The reports have been migrated to the EIOPA provided CP 11 Final QRT templates:
Country-K1
Cover-A1A
Cover-A1Q
OF-B1Q
RC
RE-J1 Basic
RE-J1 Shares
RE-J2 Basic
RE-J2 Shares
RE-J2 Group
RE-J3
RE-SPV
SCR-B2A
SCR-B2B
SCR-B2C
SCR-B3C
SCR-B3G
TP-E2
TP-E3
TP-E4
TP-E7A
TP-E7B
TP-F3

4. Stored Process (STP) names and descriptions have been updated in the metadata for a few reports to align with changes per CP 9 and CP 11 Final EIOPA templates. These updates can be applied to the system by importing reports.spk.  Details of the import process are available in the section Import updated .spk files.
5. If you need to retain previous versions of these files, they can be retrieved from backup locations as needed. 
6. You must have Administrator Privileges on your CLIENT or SERVER machine. 
7. All currently active SAS sessions, daemons, spawners and servers must be terminated before applying this hot fix. 
8. This hot fix should be installed using the same userid that performed the initial software installation. 
9. On UNIX systems, you may need to adjust file permissions on all new and updated files to meet with your sites security guidelines. 





INSTALLATION
Hot Fix K02001 must be installed on each machine where the updated components of the product, listed above, are installed. During the installation process you may see references to all operating systems for which updates are provided in the hot fix. The installation process will determine the operating system and which component(s) of Risk Management for Insurance 2.12 require updating on the machine. See SAS Note 44810 for more details. 
The hot fix will be applied using the SAS Deployment Manager (SDM). By default, the SDM will search in the <SASHOME>\InstallMisc\HotFixes\New directory for hot fixes to be applied, but will also prompt for a location if you have downloaded hot fixes to a different directory. 
After downloading K02001pt.zip, follow the instructions for applying hot fixes in the SAS Deployment Wizard and SAS Deployment Manager 9.3: User’s Guide. 
The hot fix installation process generates the log file 
<SASHOME>\InstallMisc\InstallLogs\IT_date-and-time-stamp.log 
for example, IT_2011-10-31-13.18.21.log. Each attempt to apply a hot fix results in the creation of a new log file giving detailed information regarding the installation process. 
Postexec log files are created after the installation is completed and identifies the files that were added, backed up, changed and removed. These log files include the ‘member’ hot fix id in the name of the file and are also written to the <SASHOME>\InstallMisc\InstallLogs directory. There is one postexec log for each ‘member’ hot fix applied (member hot fixes are listed at the top of these instructions). 
The content of this hot fix is listed in the hot fix manifest. This completes the installation of K02001. You must perform any "Post-Installation Instructions" documented below to successfully complete the deployment of this hot fix.
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POST-INSTALLATION INSTRUCTIONS
I.
The hotfix provides script files, copy_files.bat and copy_files.sh for Windows and Unix-based operating systems respectively to enable versioning at the SAS product configuration level. The files are located at:
WIN: 
<SASHOME>\SASFoundation\9.3\rmicomnsvr\misc\batch\hfscripts

UNIX: 
<SASHOME>/SASFoundation/9.3/misc/rmicomnsvr/batch/hfscripts
Depending upon the operating system where the hotfix is installed, use a command prompt to change directory to the location of the appropriate script file above. Next, invoke the script file at the location and pass paths to the SASFoundation and SASCONFIG locations at the command line:
Note: Enclose within double quotes any path that contains spaces.
WIN:  copy_files.bat <SASROOT> <SASCONFIG>
  e.g: copy_files.bat “C:\Program Files\SASHome\SASFoundation\9.3” “C:\SAS\Config\Lev1”

UNIX: 
copy_files.sh <SASROOT> <SASCONFIG>
  e.g. copy_files.sh /install/SASHome/SASFoundation/9.3 /install/sas/Config/Lev1
Successful script execution will result in copying of all files from SASFoundation under rmicomnsvr, rmifirmmva, rmilifemva, rmimktmva and rmipcmva to their respective folders under <SASCONFIG>. Prior to copying, the script will move the existing source folders and their contents to a new folder named source-pre-hf-K26001 on Windows and source-hf-K26001 on UNIX.
Note: On UNIX systems, the script will actually copy files from SASFoundation to a directory, source-K26001 and create a ‘source’ symbolic link to point to that directory. 


II.
For each product installed, click the link to be redirected to post-installation instructions.
J71002 updates SAS Detail Data Store for Insurance 5.5
J98001 updates SAS Firmwide Risk Management for Insurance Server 2,12
J99001 updates SAS Market Risk Management for Insurance Server 2.12
K26001 updates SAS Risk Management for Insurance Mid-Tier 2.12
J97001 updates SAS Risk Management for Insurance Server 2.12
K22001 updates SAS Risk Reporting Repository for Insurance 2.12
K01001 updates SAS Underwriting Risk Management for Life Insurance Server 2.12
K21001 updates SAS Underwriting Risk Management for P&C Insurance Server 2.12

[bookmark: G55]J71002 for SAS Detail Data Store for Insurance 5.5
1. If you have existing DDS physical tables, take a backup of the data in a different location.
2. Following is the summary of the changes in this hot fix: 
Newly added tables: 
BUSINESS_ENTITY
Updated tables: 
CONTRACT_SECTION_X_RI_CARRIER
FINANCIAL_FUND

Newly added columns: 
Table Name				Column Name

BOND_INSTRUMENT                                      PRINCIPAL_EXCHANGE_FLG
                                                                             CONVERTIBLE_FLG

CEDED_LOSS                                                    CEDED_LOSS_STATUS_CD
                                                                             CEDED_LOSS_STATUS_REASON_CD
                                                                             CEDED_LOSS_STATUS_CHANGE_DT
                                                                             CEDED_LOSS_AMT_CHANGE_DTTM

COUNTERPARTY                                             MIN_CAPITAL_REQ_FLG     
                           
FINANCIAL_ACCOUNT                                  PREPMT_PSA_SPEED_RT

FINANCIAL_POSITION                                   CUSTODIAN_COUNTERPARTY_RK

SECURITIZATION_POOL                               RESECURITIZATION_FLG

CONTRACT_SECTION_X_RI_CARRIER      ANNOTATION_TXT	

FINANCIAL_FUND                                          PROFIT_PARTICIPATION_PCT


Columns with changed attributes: 
Table Name				Column Name

ACCOUNT_PERIOD_ASSOC                           ORDER_NO
                                                                             
CURRENCY_CONVERSION_RATE  	      CONVERSION_RT

FINANCIAL_INSTRUMENT 		      FINANCIAL_INSTRUMENT_NM

FINANCIAL_INSTRUMENT 		     FINANCIAL_INSTRUMENT_NM

FUND_INSTRUMENT  			     LEVEL_OF_LOOKTHROUGH_CD

MARKET_DATA 			     DATA_DTTM

REINSURANCE_CONTRACT  		     CEDENTS_CONTRACT_ID
 
REINSURANCE_CONTRACT_SECTION       MAX_COVER_PER_RISK_EVENT

UNIT_OF_MEASURE  	                                  UOM_TYPE_DESC

3. If you already have existing DDS physical tables, execute the ddls of the tables that have undergone changes as mentioned in point 2 above from the <SASHOME>\SASFoundation\9.3\insurancedds\sasmisc\insurancedds_5.5\ddl\sas folder.
4. If you do not have existing DDS physical tables, execute the ddlgen.sas file present in <SASHOME>\SASFoundation\9.3\insurancedds\sasmisc\insurancedds_5.5\ddl\sas folder. 
5. If you already have existing DDS physical tables, migrate data for those tables that are updated in this hot fix. 
6. Copy the files present in <SASHOME>\SASFoundation\9.3\insurancedds\sasmisc\insurancedds_5.5\metadata folder to a location that can be accessed by DI studio client. 
7. Open DI studio and logon as unrestricted user. 
8. If you have existing metadata for DDS, backup the same. 
9. If you do not have existing metadata for DDS 5.5, import insurancedds_55_sas.spk, and insurancedds_55_hf1_sas.spk followed by insurancedds_55_hf2_sas.spk.

10. If you have existing metadata for DDS 5.5 and hot fix 1, import insurancedds_55_hf2_sas.spk.

11. For third party databases, the corresponding ddl and SAS package files can be used for applying the hot fix.

· Ddls for third party databases are available at <SASHOME>\SASFoundation\9.3\insurancedds\sasmisc\insurancedds_5.5\ddl\<database name>\
Db2: d2ddl.sas
Oracle:orddlgen.sas
Teradata:teradata\trddl.sas



· SAS package files for third party databases are available at <SASHOME>\SASFoundation\9.3\insurancedds\sasmisc\insurancedds_5.5\metadata\
Db2: 		IAA55: insurancedds_55_db2.spk
           		IAA55 hf1: insurancedds_55_hf1_db2.spk
		IAA55 hf2: insurancedds_55_hf2_db2.spk

Oracle: 	IAA55: insurancedds_55_oracle.spk
             	IAA55hf1: insurancedds_55_hf1_oracle.spk
		IAA55 hf2: insurancedds_55_hf2_oracle.spk

Teradata: 	IAA55: insurancedds_55_teradata.spk
                 	IAA55hf1: insurancedds_55_hf1_teradata.spk
   		IAA55hf2: insurancedds_55_hf2_teradata.spk
For detailed instructions on creating physical table and importing metadata, please refer to SAS® Detail Data Store for Insurance 5.5. 
[bookmark: F88]Notes:
a. For third party databases, if DDS physical tables already exist, then 
· Backup the data from tables which have undergone changes as mentioned in point 2 above.
· Drop the physical tables.
· Execute the macro of table creation (d2ddl.sas / orddlgen.sas / trddl.sas based on database) with keeping list of only the tables mentioned in point 2.
J98001 for SAS Firmwide Risk Management for Insurance Server 2.12 

NONE 
[bookmark: F89]J99001 for SAS Market Risk Management for Insurance Server 2.12 

NONE 
[bookmark: F12]J97001 for SAS Risk Management for Insurance Server 2.12 

Import updated .spk files: 
1.      Backup existing metadata. 
2.      Import delivered SPK files using SAS MC Import/Export SAS Package wizard 
a. Import updated analysis.spk for Firmwide Risk Server 2.12 
i. Login to SAS Management Console (SMC) as the Administrator (sasadm) user 
ii. Click on the Folders tab 
iii. Navigate to the folder Analysis under System -> Applications -> SAS Risk Management for Insurance -> Firmwide Risk Server 2.12 
iv. Select all the STPs, right-click and select Delete. Ensure that all STPs have been deleted from the Analysis folder. The reason these STPs need to be deleted is that a parameter, RR_INPUTS has been added to most of the STPs. The parameter can be seen by expanding the System parameter group on the Parameters tab. 
v. Next, right-click on the Analysis folder and select Import SAS Package from the menu 
vi. Browse to <SASHOME>\SASFoundation\9.3\rmifirmmva\sasmisc\Config\Deployment\Packages and select the analysis.spk file. 
vii. Select the radio button for All Objects and click Next. 
viii. You should see a list of STPs in the window. Click Next and then Next again.
ix. Ensure that you have the correct mappings for the SAS Application Servers. Click Next. 
x. On this screen, map source code repositories between original and target application servers. Choose the path to the <SASCONFIG>\Applications\SASRiskManagementForInsurance\2.12\source\firmwide\sasstp folder. Click Next. 
xi. Review the Summary information and click Next if correct. Otherwise, click on the Back buttons to make necessary corrections in earlier steps. 
xii. The next screen should show that the import was completed. Click the View Log button and scan the log for any errors. If the import was successful, you should see messages such as “The import process completed successfully” in the log.
xiii. Click Ok and then Finish. 


b. Import updated analysis.spk for Life Risk Server 2.12 
i. Login to SAS Management Console (SMC) as the Administrator (sasadm) user 
ii. Click on the Folders tab 
iii. Navigate to the folder Analysis under System -> Applications -> SAS Risk Management for Insurance -> Life Risk Server 2.12 
iv. Select all the STPs, right-click and select Delete. Ensure that all STPs have been deleted from the Analysis folder. The reason these STPs need to be deleted is that a parameter, RR_INPUTS has been added to most of the STPs. The parameter can be seen by expanding the System parameter group on the Parameters tab. 
v. Next, right-click on the Analysis folder and select Import SAS Package from the menu
vi. Browse to <SASHOME>\SASFoundation\9.3\rmilifemva\sasmisc\Config\Deployment\Packages and select the analysis.spk file.
vii. Select the radio button for All Objects and click Next 
viii. You should see a list of STPs in the window. Click Next and then Next again.
ix. Ensure that you have the correct mappings for the SAS Application Servers. Click Next. 
x. On this screen, map source code repositories between original and target application servers. Choose the path to the                                 <SASCONFIG>\Applications\SASRiskManagementForInsurance\2.12\source\life\sasstp folder. Click Next. 
xi. Review the Summary information and click Next if correct. Otherwise, click on the Back buttons to make necessary corrections in earlier steps. 
xii. The next screen should show that the import was completed. Click the View Log button and scan the log for any errors. If the import was successful, you should see messages such as “The import process completed successfully” in the log. 
xiii. Click Ok and then Finish. 
c. Import updated analysis.spk for Market Risk Server 2.12 
i. Login to SAS Management Console (SMC) as the Administrator (sasadm) user 
ii. Click on the Folders tab 
iii. Navigate to the folder Analysis under System -> Applications -> SAS Risk Management for Insurance -> Market Risk Server 2.12 
iv. Select all the STPs, right-click and select Delete. Ensure that all STPs have been deleted from the Analysis folder. The reason these STPs need to be deleted is that a parameter, RR_INPUTS has been added to most of the STPs. The parameter can be seen by expanding the System parameter group on the Parameters tab.
v. Next, right-click on the Analysis folder and select Import SAS Package from the menu
vi. Browse to <SASHOME>\SASFoundation\9.3\rmimktmva\sasmisc\Config\Deployment\Packages and select the analysis.spk file.
vii. Select the radio button for All Objects and click Next 
viii. You should see a list of STPs in the window. Click Next and then Next again.
ix. Ensure that you have the correct mappings for the SAS Application Servers. Click Next. 
x. On this screen, map source code repositories between original and target application servers. Choose the path to the <SASCONFIG>\Applications\SASRiskManagementForInsurance\2.12\source\market\sasstp folder. Click Next. 
xi. Review the Summary information and click Next if correct. Otherwise, click on the Back buttons to make necessary corrections in earlier steps. 
xii. The next screen should show that the import was completed. Click the View Log button and scan the log for any errors. If the import was successful, you should see messages such as “The import process completed successfully” in the log. 
xiii. Click Ok and then Finish. 
d. Import updated analysis.spk for Property Casual Risk Server 2.12
i. Login to SAS Management Console (SMC) as the Administrator (sasadm) user 
ii. Click on the Folders tab 
iii. Navigate to the folder Analysis under System -> Applications -> SAS Risk Management for Insurance -> Property Casual Risk Server 2.12 
iv. Select all the STPs, right-click and select Delete. Ensure that all STPs have been deleted from the Analysis folder. The reason these STPs need to be deleted is that a parameter, RR_INPUTS has been added to most of the STPs. The parameter can be seen by expanding the System parameter group on the Parameters tab. 
v. Next, right-click on the Analysis folder and select Import SAS Package from the menu.
vi. Browse to <SASHOME>\SASFoundation\9.3\rmipcmva\sasmisc\Config\Deployment\Packages and select the analysis.spk file.
vii. Select the radio button for All Objects and click Next.
viii. You should see a list of STPs in the window. Click Next and then Next again. 
ix. Ensure that you have the correct mappings for the SAS Application Servers. Click Next. 
x. On this screen, map source code repositories between original and target application servers. Choose the path to the <SASCONFIG>\Applications\SASRiskManagementForInsurance\2.12\source\nonlife\sasstp folder. Click Next. 
xi. Review the Summary information and click Next if correct. Otherwise, click on the Back buttons to make necessary corrections in earlier steps. 
xii. The next screen should show that the import was completed. Click the View Log button and scan the log for any errors. If the import was successful, you should see messages such as “The import process completed successfully” in the log.
xiii. Click Ok and then Finish. 
e. Import updated reports.spk for the RMI Common Server component
i. Login to SAS Management Console (SMC) as the Administrator (sasadm) user 
ii. Click on the Folders tab 
iii. Navigate to the folder Reports under System -> Applications -> SAS Risk Management for Insurance -> Risk Management for Insurance Server 2.12 
iv. Select all the Reports, right-click and select Delete. Ensure that all Reports have been deleted from the Reports folder. 
v. Next, right-click on the Reports folder and select Import SAS Package from the menu 
vi. Browse to <SASHOME>\SASFoundation\9.3\rmicomnsvr\sasmisc\Config\Deployment\Packages and select the reports.spk file. 
vii. Select the radio button for All Objects and click Next 
viii. You should see a list of Reports in the window. Click Next and then Next again. 
ix. Ensure that you have the correct mappings for the SAS Application Servers. Click Next. 
x. On this screen, map source code repositories between original and target application servers. Choose the path to the <SASCONFIG>\Applications\SASRiskManagementForInsurance\2.12\source\common\sasstp folder. Click Next. 
xi. Review the Summary information and click Next if correct. Otherwise, click on the Back buttons to make necessary corrections in earlier steps. 
xii. The next screen should show that the import was completed. Click the View Log button and scan the log for any errors. If the import was successful, you should see a message such as "The import process completed successfully" in the log. 
xiii. Click Ok and then Finish. 
xiv. If required, selectively import metadata from the backup SPK (refer to Step 1) for only those QRTs that were customized earlier and are not delivered in the hot fix.
 
f. Import updated rmi_etl_bridge_212_hf1.spk for the RMI Solution Data Mart (SDM) ETL jobs
i. Following is the summary of modified jobs in this hot fix: 
Modified Jobs: 
· RMI_INT_100_I_COUNTERPARTY_CREDIT_ASSESSMENT
· RMI_STG_210_COVERED_PERILS
· RMI_STG_210_FINANCIAL_FUND 
· RMI_STG_210_RI_CARRIER_X_RI_CONTRACT_SECTN
· RMI_STG_230_CDO_INSTRUMENT
· RMI_STG_230_COUNTERPARTY_RATINGS
· RMI_STG_230_DISCRETE_CARRYING_COST
ii. If you already have existing RMI 2.12 ETL jobs, then import the 
rmi_etl_bridge_212_hf1.spk file from <SASHOME>\SASRiskManagementForInsuranceMidTier\2.12\ETL folder as explained below. 
Note: If RMI 2.12 ETL is not existing then first import rmi_etl_bridge.spk from the same location. 
A. Login to SAS DI Studio as the Administrator (sasadm) user 
B. Click on the Folders tab 
C. Navigate to the folder Products 
D. Right-click on the Products folder and select Import SAS Package from the menu
E. Browse to /SASRiskManagementForInsuranceMidTier/2.12/ETL and select the rmi_etl_bridge_212_hf1.spk file. 
F. Select the radio button for All Objects and click Next.
G. Select the objects to Import and click Next 
H. Click Next on ‘About metadata connections’ Screen
I. Select the target libraries that correspond to original libraries. Click  Next
J. Select the target tables that correspond to original tables. Click Next.
K. Ensure that you have the correct mappings for the SAS Application Servers. Click Next. 
L. Review the Summary information and click Next. 
M. The next screen should show that the import was completed. Click the View Log button and scan the log for any errors. If the import was successful, you should see a message such as "The import process completed successfully" in the log 
N. Click Ok and then Finish. 
O. Open the Job ‘RMI_STG_210_INTERNAL_ORG_ASSOC’ present under ProductsSAS Risk Management for InsuranceRMI 2.12Staging Data MartJobs
P. In the RMI_STG_210_INTERNAL_ORG_ASSOC job diagram, right click the work table of Extract 1.
Q. Click Properties.
R. Click Physical Storage tab.
S. Change the Location from ‘Job’s default library for temporary tables’ to ‘Standard temporary library (SAS Work)’.
T. Click Ok.
U. Go to File menu, click ‘Save’ to save the changes.
V. Close the job ‘RMI_STG_210_INTERNAL_ORG_ASSOC’.
W. Execute the below code in DI Studio to delete the metadata for physically removed tables/ columns. 
The code below will synchronize table/ column metadata as per physical structures.
(Assumption: All DDLs for current hot fix have been executed.)
In DI Studio start the code editor from “Tools” menu and execute below code with appropriate values of parameters.
         Options 	metapass=”<password for metadata user>”
	  	metaport=<port number>
		metaprotocol=bridge
		metarepository=”foundation”
		metaserver=”<metadata server>”
		metauser=”<metadata user id>”;


proc metalib;
	omr (library=”RMI Staging” repname=”foundation”);
	update_rule (delete noadd);
	report;
run;

3. If required, selectively import metadata from the backup SPK (refer to Step 1) for only those QRTs that were customized earlier and are not delivered in the hot fix. 
Follow the steps below to regenerate the Solution Data Mart (SDM): 
1. Locate the create_solution_data_mart.sas file in your install: in a typical install, the macro resides under <SASCONFIG>\Applications\common\solution_data_mart 
2. Open the create_solution_data_mart.sas file in a BASE SAS session on the installation server (where the SAS code resides) 
3. Scroll to the bottom of the macro file and comment out the following line: 
%create_solution_data_mart(
soln_data_mart_dir=&sysparm,
fca_c_lib_nm=FINCAD_Suite_32_2011,
fea_c_lib_nm=intrlib, 
run_tps_fincad_flag=N, 
run_tps_fea_flag=N ); 
4. Compile the macro in the SAS session by clicking the Submit button on the menu 
5. After successful compilation, execute the following macro below: 
%create_solution_data_mart(soln_data_mart_dir=<complete path to indata directory in your install>); 
Example of indata path: <CONFIGDIR>/AppData/SASRiskManagementForInsurance/2.12/indata 
6. Check the SAS log for successful execution of the preceding macro.
In addition, complete the following to recreate any shared entity data marts and user directories. 
7. Delete all user folders found in
<SASCONFIG>/AppData/SASRiskManagementForInsurance/2.12/data/userdata 
8. Login to Risk Management for Insurance 2.12 
9. Select File > Select Entity, choose an entity from the list, and click OK. 
10. Re-create the shared data mart for that entity. 
Select File > Manage Shared Data Mart from the menu and click Delete, then click Create in the same Manage Shared Data Mart window. 
11. Repeat steps 8 and 9 for each Entity.
 
[bookmark: G54][bookmark: F92]K22001 for SAS Risk Reporting Repository for Insurance 2.12

Data model changes have been made to the SAS Risk Reporting Repository for Insurance. You must update the structures of the private RRR location and Shared location. 
There are different ways in which to apply the new structure. Please select one of the following methods that is applicable to your installation(s). 
NB: Some tables and/or columns have been removed from the model. The files for these structures may still exist on your installation due to the delivery mechanism; however, code has been added to ignore the pre-existing files when necessary.
NB: If the SDM has been recreated in the previous section, the structures of the Private locations will be automatically updated with the latest reportmart structure. If the SDM has not been recreated, then the following methods can be applied to both the private and shared locations depending on the state of your installation to update the reportmart to the latest structure.
 1. Updating via the provided sample data: 
If a given reportmart location has not been updated by another process, creating the shipped reportmart sample data in a given location will install the data model changes. 
The shipped sample data scripts already contain the updates in the RRR data model/formats. If you would like to utilize the shipped RMI sample data for the RRR without maintaining existing data, create the RRR sample data using the following steps. 
Note: The sample data creation script does not depend on the version of the original RRR that is being overwritten. This script will overwrite the existing data and data model. For example, if you are have the RRRI 212 version of the RRR and are installing the RRR hotfix, by creating the shipped sample data you do not need to install the "sample data for the previous release". The shipped sample data is a snapshot of the given version. 
Submit the following code with your installation specific information: 
options metauser="<username>" metapass="<password>" metaserver="<server_name>" metaport=<port_number> metarepository="Foundation";
%rmiinit;
%rmi_batch_create_rrr_sample_data(ENTITY=MAIN,USERNAME=<username>,SCOPE=P); 
* If you need to install the reportmart sample data to the Global RRR with the sample data script, you must submit the following code with the additional information and changes: 
%let rrr_user=<username>;
%let rrr_password=<Password>; 
options metauser="<username>" metapass="<password>" metaserver="<server_name>" metaport=<port_number> metarepository="Foundation";
%rmiinit;
%rmi_batch_create_rrr_sample_data(ENTITY=MAIN,USERNAME=<username>,SCOPE=S);
NOTE: It is not recommended that you use this process on the Global RRR unless you are absolutely certain of your specific installation needs. The script, as shown above, deletes the Global RRR and replaces the location with the new version of the RRR with the shipped sample data ONLY. All data in the Global location will be lost using this process. 
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2. Updating an existing install with alter/migration scripts: 
If you have existing data in your reportmart and wish to only apply the data model changes, execute the specific alter scripts for your given installations: 
A. If the reportmart is the RRRI212 version: execute %run_rrri21m2_to_rrr121m2hf1. Follow the instructions to execute this alter script in the PDF document m2rrri212_to_m2rrri212hf1_instructions.pdf that has been delivered with the alter scripts. These files will be typically located in the following directory: 
WIN: 
<SASHOME>\SASFoundation\9.3\rskrptmrtvrt\sasmisc\alterscripts\rrri21m2_to_rrri21m2hf1
UNIX: 
<SASHOME>/SASFoundation/9.3/misc/rskrptmrtvrt/alterscripts/rrri21m2_to_rrri21m2hf1
B. If the reportmart is the RRRI21version, you must first migrate that installation to the RRRI212 version using the provided migration scripts delivered in 212. After the migration has been completed, use the migration script from the RRRI212 to RRRI212HF1 script to bring the data forward to the current version. 
K01001 for SAS Underwriting Risk Management for Life Insurance Server 2.12 

NONE 
[bookmark: F91]K21001 for SAS Underwriting Risk Management for P&C Insurance Server 2.12 

NONE 
[bookmark: G61]K26001 for SAS Risk Management for Insurance Mid-Tier 2.12 

NONE

This completes the installation of hot fix K02001 on Windows for x64. 
