About SAS Custom Tasks

[image]

About SAS Custom Tasks

SAS custom tasks allow you to extend the capabilities of SAS Enterprise Guide and SAS Add-In for Microsoft Office. You can create your own tasks that work inside these applications just like the tasks that SAS provides. You can use the capabilities of Microsoft .NET, using Visual Basic .NET or C# as a programming language, to create rich user interfaces around your SAS processes.

Custom tasks straddle the gateway between two very powerful worlds: the world of your SAS session and the world of your Windows desktop. Your SAS session provides access to the most advanced analytics and reporting capabilities available in business intelligence applications today. And your Windows desktop, using Microsoft .NET as a framework, can provide a truly innovative and rich user experience, while accessing data from your desktop, network, or the internet.

Here are some example uses for custom tasks:

  • Create user interface as a front-end for a SAS procedure that you use all of the time, but that doesn't have a built-in task in SAS Enterprise Guide.

  • Connect to a web service to gather data from an external source and import the data into SAS.

  • Provide simple access to SAS macros programs used within your organization, making them more approachable to non-programmers.

  • Provide a sign-in prompt to a proprietary database or server resource without revealing the SAS program code required for this action.

What Is a Custom Task?

A custom task is a set of .NET classes that implement certain APIs, like a contract, to interact correctly with a SAS client application (such as SAS Enterprise Guide). These classes are built into a .NET assembly, or DLL file, which the SAS application can use to extend the menus that the end user sees in the product. When an end user selects one of these new items off of the product menu, the SAS application then interacts with the custom task classes to provide the particular feature that the task is designed to do.

Copyright 2008 SAS Institute Inc.


Deploying Custom Tasks

[image]

Deploying Custom Tasks

This topic describes how to deploy a custom task so that it appears in the application menus.

A custom add-in task "ships" within a .NET assembly (or DLL file). You may have multiple tasks within a single .NET assembly or simply organize them as one custom task per file, depending on your preferences. It is convenient to package several related tasks together into a single assembly, as it makes it easier to share code and implementations among the tasks.

Once the .NET assembly has been built, deploying and registering to target client machines is simple, using one of two methods. Once added, the add-in tasks will be available in from the Add-In menu in SAS Enterprise Guide, as well as in the task list. In the SAS Add-in for Microsoft Office, you will find the new entries when you select Manage SAS Favorites.

Method 1: "Drop-in" Deployment

You do not need to perform a separate registration step in order for SAS Enterprise Guide or SAS Add-In for Microsoft Office to recognize your custom task. Instead, you can simply copy the assembly (DLL file) to a special folder and the application will recognize it automatically the next time that you start.

With SAS Enterprise Guide 4.2 and SAS Add-In for Microsoft Office 4.2, there are multiple special folders that the application will scan for custom tasks. For SAS Enterprise Guide, the folders are:

  • %appdata%\SAS\EnterpriseGuide\4.2\Custom

  • C:\Program Files\SAS\EnterpriseGuide\4.2\Custom

For SAS Add-In for Microsoft Office, the folders are:

  • %appdata%\SAS\AddInForMicrosoftOffice\4.2\Custom

  • C:\Program Files\SAS\AddInForMicrosoftOffice\4.2\Custom

And finally, if you want to deploy a single copy of a custom task for use in both applications, you can copy it to this one special folder:

  • %appdata%\sas\SharedSettings\4.2\Custom

The "%appdata%" notation is a Microsoft Windows environment variable that maps to your personal profile area, which is specific to your user account on the machine. This allows you to add custom tasks to your installation without affecting any other users who might share your machine.

Note: if your custom task depends on other assemblies that ship with SAS Enterprise Guide or SAS Add-In for Microsoft Office, you do not need to copy those files to the Custom directory. If your custom task depends on assemblies that are not supplied by SAS (either 3rd party or that you developed), you do need to copy those to the Custom directory along with the task.

Example: Deploy a Task for Use in SAS Enterprise Guide

  1. Identify the .NET assembly (DLL) that implements the task. For example tasks, visit the SAS Enterprise Guide support site.

  2. Open a Windows Explorer view of "%appdata%\SAS\EnterpriseGuide\4.2".

  3. If a subfolder named "Custom" exists in this view, double-click on it to navigate to it. If the "Custom" subfolder does not yet exist, create a new subfolder named "Custom" and navigate to it.

  4. Copy the .NET assembly (DLL file) into the Custom folder.

  5. Restart SAS Enterprise Guide. The new task should appear under the Tools->Add-In menu.

Method 2: Using the Add-In Manager

The Add-In Manager window lets you select a custom task from any location and register it for use in your SAS applications.

Example: Registering a Task by using the Add-In Manager Dialog

  1. Copy the .NET assembly (and any dependent assemblies that your implementation might reference, excluding those provided with SAS Enterprise Guide or the SAS Add-in for Microsoft Office) to a location on the target machine. If you plan to deploy more than one assembly with add-in tasks, you might want to designate a single directory to group them together.

  2. Start the Add-In Manager.

    • In SAS Enterprise Guide 4.2, select Tools->Add-In->Add-In Manager…

    • In SAS Add-In for Microsoft Office 4.2, run "C:\Program Files\SAS\AddInForMicrosoftOffice\4.2\RegAddin.exe" (the actual location of this program might vary depending on your configuration).

    The Add-in Manager dialog allows you to register new add-in tasks by simply browsing to the .NET assembly.

  3. Click the Browse... button to navigate to where your add-in assembly is located and then click Open. The Add-in Manager shows the available tasks within the assembly that you selected.

    Click OK to accept the add-ins.


Custom Task API Reference

[image]

Custom Task API Reference

The SAS custom task APIs are spread over two main namespaces: SAS.Shared.AddIns and SAS.Tasks.Toolkit. This topic provides links to the main API classes of interest.

The SAS custom task APIs include these two main namespaces:

  • SAS.Shared.AddIns, which includes the main interfaces that interact with the SAS applications (SAS Enterprise Guide and SAS Add-In for Microsoft Office).

    These interfaces describe two sides of the contract between SAS-supplied applications and customer-supplied custom tasks. These interfaces are the common language that allow customers to extend SAS products such as SAS Enterprise Guide and the SAS Add-in for Microsoft Office.

  • SAS.Tasks.Toolkit, which includes several helper classes that implement much of the required interfaces for you, so that you can focus on creating content and behavior that is specific to your task without needing to complete a large list of boilerplate methods and properties.

    In particular, the SasTask class provides an almost-complete default implementation of the required task interfaces, allowing you to create a basic functioning task with just a few lines of code.

External Resources

[http://support.sas.com/eguide]


Namespaces

Namespaces

Namespace | Description
SAS.Shared.AddIns |
SAS.Tasks.Toolkit |
SAS.Tasks.Toolkit.Controls |
SAS.Tasks.Toolkit.Data |
SAS.Tasks.Toolkit.Helpers |


SAS.Shared.AddIns Namespace

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SAS.Shared.AddIns Namespace

Classes

Class | Description
AddInException | Exception class used by the application to communicate an exception from the application to the add-in.
ApplicationSupportedAttribute | Attribute to indicate which particular applications are supported
InputRequiredAttribute | Attribute to indicate whether a task requires input and what type.
SASMacroDependencyAttribute | Attribute to indicate whether a task depends on a particular macro. The application can supply certain SAS macros on behalf of the task. These are utility macros that perform simple work, but that you might want avoid defining during code generation so that the task code is more readable. Examples include "_eg_conditional_dropds", which deletes a data member (DATA or VIEW) to clear the way for a possible new version of the data. Another example is "_eg_whereParam", which helps to express a WHERE clause for use in a parameterized query.
SASMetadataRequiredAttribute | Attribute to indicate whether this task implementation requires access to a SAS Metadata Repository.
SASOdsSettings | Utility class to implement ISASOdsSettings
SASTaskCategoryAttribute | Attribute to indicate the top-level category for this task. This is a string value that is not localized (translated). The application can use this value to help decide which tasks to include in certain menus and toolbars. Current valid values include "Data", "Describe", "Graph", "Analysis", and "Tools".
SASTaskDataDescriptor | Implementation of ISASTaskDataDescriptor
SASTaskThreadSafeAttribute | Attribute to indicate whether certain methods of the ISASTask interface are guaranteed to be thread-safe. Set this attribute to True only when you can ensure that your task will function properly regardless of what thread is used when calling into it.
SupportsObsOptionsAttribute | Attribute to indicate whether this task supports the FIRSTOBS and OBS mechanisms to limit input and output processing. These values are settable on NObsSetting and FirstObsSetting.
TaskExecutionStatusEventArgs | Special EventArgs class for communicating status updates from tasks that implement ISASTaskExecution2.
TaskMigratorClassAttribute | Attribute to indicate TaskMigration classname. This class must implement the ITaskMigrator interface

Interfaces

Interface | Description
ISASApplicationOptions | Interface to surface values for global application options
ISASOdsSettings | Interface to surface a set of ODS options for one ODS target type.
ISASProject | Handle to the application project or document.
ISASProjectData | Handle to a project item that can be used as a data source You can cast this to ISASProjectItem to get basic information like Name, the icon, etc.
ISASProjectItem | Handle to an item within the project.
ISASProjectProcessFlow | Handle to a process flow within the current project.
ISASProjectTask | Handle to the task element within the current project. You can cast this to ISASProjectItem to get basic information like Name, the icon, etc.
ISASTask | Implemented by: Add-in task Add-ins are required to support this interface. This interface is used by the application to control the runtime state of the add-in.
ISASTask2 | Implemented by: Add-in task This interface provides features in addition to everything in ISASTask. Add-ins are required to support this interface or ISASTask. This interface is used by the application to control the runtime state of the add-in.
ISASTask3 | Implemented by: Add-in task This interface provides features in addition to everything in ISASTask2. Add-ins are required to support this interface or ISASTask or ISASTask2. This interface is used by the application to control the runtime state of the add-in.
ISASTaskAddIn | Implemented by: Add-in task Add-ins are required to support this interface. This interface is used by the application to connect to the add-in and retrieve some basic information from it.
ISASTaskConsumer | Implemented by: Host application (for example, SAS Enterprise Guide) All host applications are required to support this interface. These interfaces allow the task to get and set information about the environment in which it is executing.
ISASTaskConsumer2 | Implemented by: Host application (for example, SAS Enterprise Guide) Support for this extended interface provides more advanced features to the add-ins. This interface is an extension of ISASTaskConsumer. These interfaces allow the task to get and set information about the environment in which it is executing as well as provide some additional advanced functionality.
ISASTaskConsumer3 | Implemented by: Host application (for example, SAS Enterprise Guide) Support for this extended interface provides more advanced features to the add-ins. This interface is an extension of ISASTaskConsumer2. These interfaces allow the task to get and set information about the environment in which it is executing as well as provide some additional advanced functionality.
ISASTaskCubeData | Given an active OLAP data connection as the active data source, this interface surfaces information about that connection and OLAP view that might be used by tasks.
ISASTaskData | Implemented by: Host application (for example, SAS Enterprise Guide) These interfaces allow the task to obtain information about the active data. Different host applications might not be able to provide values for some of these methods.
ISASTaskData2 | Implemented by: Host application (for example, SAS Enterprise Guide) An extension of the ISASTaskData interface to surface some additional properties.
ISASTaskDataAccessor | Implemented by: Host application (for example, SAS Enterprise Guide) These methods allow the task to access the data values in a specific data object.
ISASTaskDataAccessorSink | Implemented by: Add-in task Allows the application to notify the add-in when calculation of statistics or discrete values is complete. You can request these calculations through ISASTaskDataAccessor
ISASTaskDataColumn | Implemented by: Host application (for example, SAS Enterprise Guide) Provides information about a single column in a data source.
ISASTaskDataColumn2 | Implemented by: Host application (for example, SAS Enterprise Guide) Provides information about a single column in a data source. This is an extension of ISASTaskDataColumn.
ISASTaskDataDescriptor | Implemented by: Host application (for example, SAS Enterprise Guide) These interfaces allow the add-in and application to exchange information about a code compatible data name to be used as either input or output data.
ISASTaskDataName | Implemented by: Host application (for example, SAS Enterprise Guide) These interfaces allow the add-in and application to exchange information about a code compatible data name to be used as either input or output data.
ISASTaskDataName2 | Additional methods and properties for the ISASTakDataName
ISASTaskDataSink | Implemented by: Add-in task Add-ins can optionally support this interface. Supplies notifications to the add-in that the input data has changed, or that it needs to take some action regarding output data that it intends to create.
ISASTaskDataSink2 | Implemented by: Add-in task Allows the application to notify the add-in when the input data for the task has been changed.
ISASTaskDescription | Implemented by: Add-in task Add-ins are required to support this interface. This interface is used by the application to determine basic task information which is not dependent on the task state.
ISASTaskDescription2 | Implemented by: Add-in task This interface provides features in addition to everything in ISASTaskDescription. This interface is used by the application to determine basic task descriptive metadata.
ISASTaskDisplay | This interface is for use by SAS applications and is not intended for use by SAS customers.
ISASTaskDisplay2 | This interface is for use by SAS applications and is not intended for use by SAS customers.
ISASTaskExecution | Implemented by: Add-in task Add-ins can optionally support this interface. This interface is used by the application to control the runtime execution of an add-in when the GeneratesSasCode property is false.
ISASTaskExecution2 | Implemented by: Add-in task Add-ins can optionally support this interface. This interface extends ISASTaskExecution to add support for a StatusChanged event. With the StatusChanged event, a task can update the status while running, and the status will be reflected in the application task status window.
ISASTaskMigrator | This interface is implemented by the task to allow the application to perform various migration tasks. It is intended to be a light-weight mechanism to change references to resources, such as libraries and servers, when the project or document is migrated from one environment to another. It may be implemented by the same class that implements the ISASTask and ISASTaskDescription interfaces, or by a separate class (which are encapsulated in the SAS.Tasks.Toolkit.SasTask class). The TaskMigratorClassAttribute class property is used to indicate the assembly and type of the class that implements this interface.
ISASTaskOptions | Interface to surface values for the output/processing options specified for the current task
ISASTaskParameter | This interface is for use by SAS applications and is not intended for use by SAS customers.
ISASTaskParameterSink | Implemented by: Add-in task Add-ins can optionally support this interface. Supplies an event to indicate that a parameter has been modifed or removed.
ISASTaskProperties | Interface to get metadata properties for an instance of a task within the application.
ISASTaskStream | This interface is used by custom add-ins that return their own results by implementing ISASTaskExecution.
ISASTaskSubmit | Implemented by: Host application (for example, SAS Enterprise Guide) This interfaces allow the task to submit SAS code from within the task.
ISASTaskSubmitSink | Implemented by: Add-in task Add-ins can optionally support this interface. Supplies an event to indicate that an SAS program (submitted asynchronously) has completed processing.
ISASTaskTemplate | This interface is used by tasks to provide support for "templated tasks". SAS Enterprise Guide and SAS Add-In for Microsoft Office allow you to create templates from tasks you've used in your project. These templates store the options you've selected so that you can reuse them in a future project, without having to reselect all of the options "from scratch".
ISASTaskTextWriter | Interface for writing to a text writer.
ISASTaskUtilities | Implemented by: Host application (for example, SAS Enterprise Guide) This interfaces allow the task to surface some utility functionality to the task.
ISupportRoleBased | Implement this interface when you want your task to respect administrative settings that are centrally configured. An administrator can control whether certain users or groups have read-only access to projects. If you choose to implement this interface, you can comply with the intent of the administrator.

Delegates

Delegate | Description
TaskExecutionStatusChangedHandler | Delegate for an event handler implemented by the application. Used in conjunction with StatusChanged.

Enumerations

Enumeration | Description
ApplicationName | Enumeration of applications
DataOption | Not documented for customer use.
DataPathType | Enumeration of the valid data types.
DataSelectionMode | Used with the ShowDataSelector method to control the selection mode of the selector dialog.
DataType | Enumeration for the type of data source surfaced by the host application. Subtypes are described in SourceType.
EnvironmentOption | Enumeration of options whose values are maintained in the host application.
ErrorType | Enumeration of error types that are provided in an AddinException.
eSasCodeOptions | Flags for SAS code options. Used with the GetAllSasCode(eSasCodeOptions) method.
FilterUnusedVariablesType | Possible values for the application option related to dropping unused variables -- variables from the input data that are not actually vital to the task analysis.
InputResourceType | Enumeration of input resources that might be used by a task
LibraryType | Used to retrieve a list of specific SAS libraries in a call to Libraries
ObsConstants | Constants for use with the ISASTaskOptions interface to get/set the values of FirstObs and NObs.
OdsDestination | The OdsDestination enum represents different ODS destinations.
OptionalName | Enumeration of features/properties/interfaces that might be supported by the host application.
OutputData | Enumeration of the valid output data types.
ParameterVariableGroup | Possible values for variable groups, which are a way to categorize possible parameter values.
PinnedResult | Possible values to pass to the ISASTaskConsumer2.ExecuteTask method.
RunStatus | Possible success codes for tasks that do no generate SAS code but instead perform work on their own. The application can use these codes to provide a visual indicator of success, error, or warnings.
SasGraphDevice | Graph devices supported by SAS applications
ServerAccessMode | Used with the ShowDataSelector method to control which servers the selector dialog will allow access to.
ShowResult | Possible values to return from the ISASTask.Show method.
ShowType | This enumeration is for SAS internal use only.
SortDirection | Enumeration of possible sort directions.
SourceType | Enumeration for the subtype of data surfaced by the host application. These are more specific subtypes of the data types described in DataType.
Statistics | Enumeration of available statistics that can be returned for a data column.
VariableGroup | Possible values for variable groups, which are a way to categorize variables based on type and format.
ViewType | Possible values for ViewType as used in the ISASTask2 interface.
WindowStartPosition | Possible values for how the position and geometry of the task window is to be displayed.


AddInException Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
AddInException Class
Members See Also

Exception class used by the application to communicate an exception from the application to the add-in.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Class AddInException _
    Inherits Exception
C#
public class AddInException : Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
SAS.Shared.AddIns..::.AddInException

See Also

AddInException Members
SAS.Shared.AddIns Namespace


AddInException Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
AddInException Members
AddInException Class Constructors Methods Properties See Also

The AddInException type exposes the following members.

Constructors

Name | Description
AddInException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Type | Gets the error type

See Also

AddInException Class
SAS.Shared.AddIns Namespace


AddInException Constructor

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
AddInException Constructor
AddInException Class See Also

Overload List

Name | Description
AddInException()()() | Default constructor, sets exception type to ErrorType.None
AddInException(String, ErrorType) | Constructor for this exception class
AddInException(String, Exception) | Constructor for this exception class
AddInException(String, ErrorType, Exception) | Constructor for this exception class

See Also

AddInException Class
AddInException Members
SAS.Shared.AddIns Namespace


AddInException Constructor

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
AddInException Constructor
AddInException Class See Also

Default constructor, sets exception type to ErrorType.None

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public AddInException()

See Also

AddInException Class
AddInException Overload
SAS.Shared.AddIns Namespace


AddInException Constructor (String, ErrorType)

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
AddInException Constructor (String, ErrorType)
AddInException Class See Also

Constructor for this exception class

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    type As ErrorType _
)
C#
public AddInException(
    string message,
    ErrorType type
)

Parameters

message
Type: System..::.String
Exception message
type
Type: SAS.Shared.AddIns..::.ErrorType
Enumerated type of exception

See Also

AddInException Class
AddInException Overload
SAS.Shared.AddIns Namespace


AddInException Constructor (String, Exception)

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
AddInException Constructor (String, Exception)
AddInException Class See Also

Constructor for this exception class

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
C#
public AddInException(
    string message,
    Exception inner
)

Parameters

message
Type: System..::.String
Exception message
inner
Type: System..::.Exception
Inner exception object wrapped by this exception

See Also

AddInException Class
AddInException Overload
SAS.Shared.AddIns Namespace


AddInException Constructor (String, ErrorType, Exception)

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
AddInException Constructor (String, ErrorType, Exception)
AddInException Class See Also

Constructor for this exception class

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    type As ErrorType, _
    inner As Exception _
)
C#
public AddInException(
    string message,
    ErrorType type,
    Exception inner
)

Parameters

message
Type: System..::.String
Exception message
type
Type: SAS.Shared.AddIns..::.ErrorType
Enumerated type of exception
inner
Type: System..::.Exception
Inner exception object wrapped by this exception

See Also

AddInException Class
AddInException Overload
SAS.Shared.AddIns Namespace


AddInException Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
AddInException Methods
AddInException Class See Also

The AddInException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

AddInException Class
SAS.Shared.AddIns Namespace


AddInException Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
AddInException Properties
AddInException Class See Also

The AddInException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Type | Gets the error type

See Also

AddInException Class
SAS.Shared.AddIns Namespace


Type Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
AddInException..::.Type Property
AddInException Class See Also

Gets the error type

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As ErrorType
C#
public ErrorType Type { get; }

See Also

AddInException Class
SAS.Shared.AddIns Namespace


ApplicationName Enumeration

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ApplicationName Enumeration
See Also

Enumeration of applications

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration ApplicationName
C#
public enum ApplicationName

Members

Member name | Description
All | All applications are supported
EGuide | Supports only SAS Enterprise Guide
SASAddIn | Supports only SAS AddIn for Microsoft Office

Remarks

Added in version 4.2

See Also

SAS.Shared.AddIns Namespace


ApplicationSupportedAttribute Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ApplicationSupportedAttribute Class
Members See Also

Attribute to indicate which particular applications are supported

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple := True)> _
Public Class ApplicationSupportedAttribute _
    Inherits Attribute
C#
[AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = true)]
public class ApplicationSupportedAttribute : Attribute

Remarks

Added in version 4.2

Inheritance Hierarchy

System..::.Object
System..::.Attribute
SAS.Shared.AddIns..::.ApplicationSupportedAttribute

See Also

ApplicationSupportedAttribute Members
SAS.Shared.AddIns Namespace


ApplicationSupportedAttribute Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ApplicationSupportedAttribute Members
ApplicationSupportedAttribute Class Constructors Methods Properties Explicit Interface Implementations See Also

The ApplicationSupportedAttribute type exposes the following members.

Constructors

Name | Description
ApplicationSupportedAttribute | Constructor for this attribute

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ApplicationSupported | Gets or sets the value of the application that this class supports.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

ApplicationSupportedAttribute Class
SAS.Shared.AddIns Namespace


ApplicationSupportedAttribute Constructor

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ApplicationSupportedAttribute Constructor
ApplicationSupportedAttribute Class See Also

Constructor for this attribute

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    sup As ApplicationName _
)
C#
public ApplicationSupportedAttribute(
    ApplicationName sup
)

Parameters

sup
Type: SAS.Shared.AddIns..::.ApplicationName
Value for supported application

See Also

ApplicationSupportedAttribute Class
SAS.Shared.AddIns Namespace


ApplicationSupportedAttribute Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ApplicationSupportedAttribute Methods
ApplicationSupportedAttribute Class See Also

The ApplicationSupportedAttribute type exposes the following members.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

ApplicationSupportedAttribute Class
SAS.Shared.AddIns Namespace


ApplicationSupportedAttribute Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ApplicationSupportedAttribute Properties
ApplicationSupportedAttribute Class See Also

The ApplicationSupportedAttribute type exposes the following members.

Properties

Name | Description
ApplicationSupported | Gets or sets the value of the application that this class supports.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

ApplicationSupportedAttribute Class
SAS.Shared.AddIns Namespace


ApplicationSupported Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ApplicationSupportedAttribute..::.ApplicationSupported Property
ApplicationSupportedAttribute Class See Also

Gets or sets the value of the application that this class supports.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Property ApplicationSupported As ApplicationName
C#
public ApplicationName ApplicationSupported { get; set; }

See Also

ApplicationSupportedAttribute Class
SAS.Shared.AddIns Namespace


DataOption Enumeration

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
DataOption Enumeration
See Also

Not documented for customer use.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration DataOption
C#
public enum DataOption

Members

Member name | Description
PasswordReadOnly | Not documented for customer use.
PasswordReadWrite | Not documented for customer use.
PasswordAlter | Not documented for customer use.
FirstObs | Not documented for customer use.
Obs | Not documented for customer use.

See Also

SAS.Shared.AddIns Namespace


DataPathType Enumeration

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
DataPathType Enumeration
See Also

Enumeration of the valid data types.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration DataPathType
C#
public enum DataPathType

Members

Member name | Description
Libref | Output data is a reference in a SAS library (for example, SASHELP.CLASS)
FilePath | Output data is a file path either local or on a server (for example, c:\data\sas7bdat)
Unknown | Output data is not a defined output type.

Remarks

The add-in supplies this information to the application in the ISASTaskDataDescriptor

See Also

SAS.Shared.AddIns Namespace
SAS.Shared.AddIns..::.ISASTaskDataDescriptor


DataSelectionMode Enumeration

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
DataSelectionMode Enumeration
See Also

Used with the ShowDataSelector method to control the selection mode of the selector dialog.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration DataSelectionMode
C#
public enum DataSelectionMode

Members

Member name | Description
MultipleInput | Display selection dialog for muliple input selection
SingleInput | Display selection dialog for single input selection
Output | Display selection dialog for single output selection
ReadOnlyMultipleInput | Display selection dialog for muliple input selection prompting the user to protect data before continuing.
ReadOnlySingleInput | Display selection dialog for single input selection prompting the user to protect data before continuing.

See Also

SAS.Shared.AddIns Namespace
ISASTaskConsumer2..::.ShowDataSelector(IWin32Window, DataSelectionMode, ServerAccessMode, String, String, String, String%)


DataType Enumeration

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
DataType Enumeration
See Also

Enumeration for the type of data source surfaced by the host application. Subtypes are described in SourceType.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration DataType
C#
public enum DataType

Members

Member name | Description
Unknown | Unknown data source
Sas | SAS data (such as libname.member)
Ado | An ADO data source, such as a Microsoft Excel file
Odbc | Data through an ODBC connection
Oledb | Data through an OLEDB provider
Mddb | Multidimensional, or OLAP, data

Remarks

The add-in can use this value when making use of input data that is supplied by the host application.

See Also

SAS.Shared.AddIns Namespace
ISASTaskData..::.Type
SAS.Shared.AddIns..::.SourceType


EnvironmentOption Enumeration

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
EnvironmentOption Enumeration
See Also

Enumeration of options whose values are maintained in the host application.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration EnvironmentOption
C#
public enum EnvironmentOption

Members

Member name | Description
DisplayColumnInAlphaOrder | Display column names in alphabetical order. Returned as boolean.
DisplayColumnUsingLabel | Display column labels instead of column names. Returned as boolean.
FilterUnusedVariables | Drop unused variables from analysis and results. Returned as boolean.
FilterUnusedVariablesState | Drop unused variables from analysis and results. Returned as FilterUnusedVariablesType
EmbeddedActiveXGraphData | Not supported or documented for customer use.
EnableAccessibilityFeatures | Enable any special accessibility features in the user interface. Returned as boolean.
SortUsingProcSQL | When sorting data as part of analysis, use PROC SQL instead of PROC SORT. Returned as boolean.
GraphTextureMapLocation | The installed location of the graph texture maps for use in charts. Returned as String.
HostApplicationName | The name (title) of the host application. Returned as String.
DefaultServer | The name of the default SAS server (user preference). Returned as String.
DefaultOutputLibrary | The name of the default output library to use for output data sets. Returned as String.
DefaultFootnote | The contents of the default footnote text (for use in a FOOTNOTE statement). Returned as String.
DefaultGraphHeight | The default height (in pixels) to use for graph output. Returned as Int32.
DefaultGraphWidth | The default width (in pixels) to use for graph output. Returned as Int32.
DefaultTitle | The contents of the default footnote text (for use in a TITLE statement). Returned as String.
SupportsRunPinnedMode | Whether the application supports running the add-in in "pinned" mode (with the add-in form still displayed while the task runs). Returned as boolean.
SupportsRunLaterMode | Whether the application supports saving the task state and executing it later (instead of running it immediately when the form is dismissed). SAS Enterprise Guide supports "run later" mode. Returned as boolean.
ImportLookAheadRows | Not supported or documented for customer use.
ScanForColumnWidth | Not supported or documented for customer use.

Remarks

An add-in can query these option values by using the Option(EnvironmentOption) method. Many of these correspond to settings you can control within SAS Enterprise Guide via Tools->Options. Use these option values if you want your add-in to conform to user-supplied preferences in the application.

See Also

SAS.Shared.AddIns Namespace


ErrorType Enumeration

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ErrorType Enumeration
See Also

Enumeration of error types that are provided in an AddinException.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration ErrorType
C#
public enum ErrorType

Members

Member name | Description
None | No specific type given.
InvalidParameter | Invalid parameter supplied to a method; perhaps an invalid member name for SAS data.
InvalidLibrary | Library supplied is not a valid SAS library.
InvalidServer | Server name supplied is not a valid SAS server.
CredentialsCanceled | The user has canceled from a required login prompt

Remarks

See Also

SAS.Shared.AddIns Namespace
SAS.Shared.AddIns..::.AddInException


eSasCodeOptions Enumeration

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
eSasCodeOptions Enumeration
See Also

Flags for SAS code options. Used with the GetAllSasCode(eSasCodeOptions) method.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration eSasCodeOptions
C#
[FlagsAttribute]
public enum eSasCodeOptions

Members

Member name | Description
IncludeHeaders | Include the comment headings generated by SAS Enterprise Guide.
IncludeGeneratedCode | Include code that is automatically generated by SAS Enterprise Guide (for example, ODS statements).
IncludeCustomCode | Include custom code that is specified in Tools->Options within the application.
IncludeLibraryCode | Include SAS library assignment code for SAS libraries that are used within the project but aren't preassigned in the environment.

See Also

SAS.Shared.AddIns Namespace


FilterUnusedVariablesType Enumeration

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
FilterUnusedVariablesType Enumeration
See Also

Possible values for the application option related to dropping unused variables -- variables from the input data that are not actually vital to the task analysis.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration FilterUnusedVariablesType
C#
public enum FilterUnusedVariablesType

Members

Member name | Description
Auto | Default behavior for filtering unused variables
Always | Always filter unused variables
Never | Never filter unused variables

See Also

SAS.Shared.AddIns Namespace
SAS.Shared.AddIns..::.EnvironmentOption
ISASTaskConsumer..::.Option(EnvironmentOption)


InputRequiredAttribute Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
InputRequiredAttribute Class
Members See Also

Attribute to indicate whether a task requires input and what type.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple := False)> _
Public Class InputRequiredAttribute _
    Inherits Attribute
C#
[AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = false)]
public class InputRequiredAttribute : Attribute

Remarks

Added in version 4.2. It supercedes the RequiresData attribute.

Inheritance Hierarchy

System..::.Object
System..::.Attribute
SAS.Shared.AddIns..::.InputRequiredAttribute

See Also

InputRequiredAttribute Members
SAS.Shared.AddIns Namespace


InputRequiredAttribute Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
InputRequiredAttribute Members
InputRequiredAttribute Class Constructors Methods Properties Explicit Interface Implementations See Also

The InputRequiredAttribute type exposes the following members.

Constructors

Name | Description
InputRequiredAttribute | Constructor for this attribute

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
InputRequired | Property for InputRequired value.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

InputRequiredAttribute Class
SAS.Shared.AddIns Namespace


InputRequiredAttribute Constructor

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
InputRequiredAttribute Constructor
InputRequiredAttribute Class See Also

Constructor for this attribute

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    val As InputResourceType _
)
C#
public InputRequiredAttribute(
    InputResourceType val
)

Parameters

val
Type: SAS.Shared.AddIns..::.InputResourceType
Value for input type

See Also

InputRequiredAttribute Class
SAS.Shared.AddIns Namespace


InputRequiredAttribute Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
InputRequiredAttribute Methods
InputRequiredAttribute Class See Also

The InputRequiredAttribute type exposes the following members.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

InputRequiredAttribute Class
SAS.Shared.AddIns Namespace


InputRequiredAttribute Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
InputRequiredAttribute Properties
InputRequiredAttribute Class See Also

The InputRequiredAttribute type exposes the following members.

Properties

Name | Description
InputRequired | Property for InputRequired value.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

InputRequiredAttribute Class
SAS.Shared.AddIns Namespace


InputRequired Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
InputRequiredAttribute..::.InputRequired Property
InputRequiredAttribute Class See Also

Property for InputRequired value.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Property InputRequired As InputResourceType
C#
public InputResourceType InputRequired { get; set; }

See Also

InputRequiredAttribute Class
SAS.Shared.AddIns Namespace


InputResourceType Enumeration

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
InputResourceType Enumeration
See Also

Enumeration of input resources that might be used by a task

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration InputResourceType
C#
public enum InputResourceType

Members

Member name | Description
None | No resource
Data | SAS data set or other defined relational data source
InformationMap | SAS information map
File | External file
Olap | OLAP data source

See Also

SAS.Shared.AddIns Namespace


ISASApplicationOptions Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASApplicationOptions Interface
Members See Also

Interface to surface values for global application options

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISASApplicationOptions
C#
public interface ISASApplicationOptions

See Also

ISASApplicationOptions Members
SAS.Shared.AddIns Namespace


ISASApplicationOptions Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASApplicationOptions Members
ISASApplicationOptions Interface Methods See Also

The ISASApplicationOptions type exposes the following members.

Methods

Name | Description
GetOutputLibraryPreferences | Gets the list of preferred output libraries, as registered in the Tools->Options->Tasks: Output Libraries option.
GetPreferredGraphAppletUrl | Gets the preferred URL location (codebase) for the Java applets required to render graphs generated using the Java graph device
GetPreferredGraphDevice | Gets the value of the preferred graph device
GetPreferredGraphSize | Gets the preferred graph output size in pixels
GetPreferredOdsSettings | Gets the collection of preferred ODS settings
GetTextureMapPath | Gets the texture maps location

See Also

ISASApplicationOptions Interface
SAS.Shared.AddIns Namespace


ISASApplicationOptions Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASApplicationOptions Methods
ISASApplicationOptions Interface See Also

The ISASApplicationOptions type exposes the following members.

Methods

Name | Description
GetOutputLibraryPreferences | Gets the list of preferred output libraries, as registered in the Tools->Options->Tasks: Output Libraries option.
GetPreferredGraphAppletUrl | Gets the preferred URL location (codebase) for the Java applets required to render graphs generated using the Java graph device
GetPreferredGraphDevice | Gets the value of the preferred graph device
GetPreferredGraphSize | Gets the preferred graph output size in pixels
GetPreferredOdsSettings | Gets the collection of preferred ODS settings
GetTextureMapPath | Gets the texture maps location

See Also

ISASApplicationOptions Interface
SAS.Shared.AddIns Namespace


GetOutputLibraryPreferences Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASApplicationOptions..::.GetOutputLibraryPreferences Method
ISASApplicationOptions Interface See Also

Gets the list of preferred output libraries, as registered in the Tools->Options->Tasks: Output Libraries option.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function GetOutputLibraryPreferences As String()
C#
string[] GetOutputLibraryPreferences()

Return Value

An array of strings with SAS library names (librefs).

See Also

ISASApplicationOptions Interface
SAS.Shared.AddIns Namespace


GetPreferredGraphAppletUrl Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASApplicationOptions..::.GetPreferredGraphAppletUrl Method
ISASApplicationOptions Interface See Also

Gets the preferred URL location (codebase) for the Java applets required to render graphs generated using the Java graph device

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function GetPreferredGraphAppletUrl As String
C#
string GetPreferredGraphAppletUrl()

Return Value

string with the URL

See Also

ISASApplicationOptions Interface
SAS.Shared.AddIns Namespace


GetPreferredGraphDevice Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASApplicationOptions..::.GetPreferredGraphDevice Method
ISASApplicationOptions Interface See Also

Gets the value of the preferred graph device

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function GetPreferredGraphDevice As SasGraphDevice
C#
SasGraphDevice GetPreferredGraphDevice()

Return Value

the current graph device selection

See Also

ISASApplicationOptions Interface
SAS.Shared.AddIns Namespace


GetPreferredGraphSize Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASApplicationOptions..::.GetPreferredGraphSize Method
ISASApplicationOptions Interface See Also

Gets the preferred graph output size in pixels

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function GetPreferredGraphSize As Integer()
C#
int[] GetPreferredGraphSize()

Return Value

int[0] is the X size (width), int[1] is the Y size (height)

See Also

ISASApplicationOptions Interface
SAS.Shared.AddIns Namespace


GetPreferredOdsSettings Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASApplicationOptions..::.GetPreferredOdsSettings Method
ISASApplicationOptions Interface See Also

Gets the collection of preferred ODS settings

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function GetPreferredOdsSettings As ISASOdsSettings()
C#
ISASOdsSettings[] GetPreferredOdsSettings()

Return Value

an array of ISASOdsSettings objects

See Also

ISASApplicationOptions Interface
SAS.Shared.AddIns Namespace


GetTextureMapPath Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASApplicationOptions..::.GetTextureMapPath Method
ISASApplicationOptions Interface See Also

Gets the texture maps location

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function GetTextureMapPath As String
C#
string GetTextureMapPath()

Return Value

path that contains the texture map image files

See Also

ISASApplicationOptions Interface
SAS.Shared.AddIns Namespace


ISASOdsSettings Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASOdsSettings Interface
Members See Also

Interface to surface a set of ODS options for one ODS target type.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISASOdsSettings
C#
public interface ISASOdsSettings

See Also

ISASOdsSettings Members
SAS.Shared.AddIns Namespace


ISASOdsSettings Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASOdsSettings Members
ISASOdsSettings Interface Properties See Also

The ISASOdsSettings type exposes the following members.

Properties

Name | Description
AdditionalOptions | Any additional ODS options to include
Destination | The ODS destination type
Encoding | The encoding to use for this destination
Style | The selected ODS style (or client style, CSS) for the ODS destination
Stylesheet | The selected CSS stylesheet to use for the ODS destination (HTML adn SAS Report only)

See Also

ISASOdsSettings Interface
SAS.Shared.AddIns Namespace


ISASOdsSettings Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASOdsSettings Properties
ISASOdsSettings Interface See Also

The ISASOdsSettings type exposes the following members.

Properties

Name | Description
AdditionalOptions | Any additional ODS options to include
Destination | The ODS destination type
Encoding | The encoding to use for this destination
Style | The selected ODS style (or client style, CSS) for the ODS destination
Stylesheet | The selected CSS stylesheet to use for the ODS destination (HTML adn SAS Report only)

See Also

ISASOdsSettings Interface
SAS.Shared.AddIns Namespace


AdditionalOptions Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASOdsSettings..::.AdditionalOptions Property
ISASOdsSettings Interface See Also

Any additional ODS options to include

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property AdditionalOptions As String
C#
string AdditionalOptions { get; }

See Also

ISASOdsSettings Interface
SAS.Shared.AddIns Namespace


Destination Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASOdsSettings..::.Destination Property
ISASOdsSettings Interface See Also

The ODS destination type

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Destination As OdsDestination
C#
OdsDestination Destination { get; }

See Also

ISASOdsSettings Interface
SAS.Shared.AddIns Namespace


Encoding Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASOdsSettings..::.Encoding Property
ISASOdsSettings Interface See Also

The encoding to use for this destination

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Encoding As String
C#
string Encoding { get; }

See Also

ISASOdsSettings Interface
SAS.Shared.AddIns Namespace


Style Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASOdsSettings..::.Style Property
ISASOdsSettings Interface See Also

The selected ODS style (or client style, CSS) for the ODS destination

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Style As String
C#
string Style { get; }

See Also

ISASOdsSettings Interface
SAS.Shared.AddIns Namespace


Stylesheet Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASOdsSettings..::.Stylesheet Property
ISASOdsSettings Interface See Also

The selected CSS stylesheet to use for the ODS destination (HTML adn SAS Report only)

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Stylesheet As String
C#
string Stylesheet { get; }

See Also

ISASOdsSettings Interface
SAS.Shared.AddIns Namespace


ISASProject Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProject Interface
Members See Also

Handle to the application project or document.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISASProject
C#
public interface ISASProject

See Also

ISASProject Members
SAS.Shared.AddIns Namespace


ISASProject Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProject Members
ISASProject Interface Properties See Also

The ISASProject type exposes the following members.

Properties

Name | Description
DateCreated | Date/Time the project was created.
DateModified | Date/Time the project was last modified.
ModifiedByUserId | Windows user ID of the person who last modified the project.
Name | Project name, if it has one.
ProcessFlows | A list of the Process Flow objects within the current project.

See Also

ISASProject Interface
SAS.Shared.AddIns Namespace


ISASProject Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProject Properties
ISASProject Interface See Also

The ISASProject type exposes the following members.

Properties

Name | Description
DateCreated | Date/Time the project was created.
DateModified | Date/Time the project was last modified.
ModifiedByUserId | Windows user ID of the person who last modified the project.
Name | Project name, if it has one.
ProcessFlows | A list of the Process Flow objects within the current project.

See Also

ISASProject Interface
SAS.Shared.AddIns Namespace


DateCreated Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProject..::.DateCreated Property
ISASProject Interface See Also

Date/Time the project was created.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property DateCreated As DateTime
C#
DateTime DateCreated { get; }

See Also

ISASProject Interface
SAS.Shared.AddIns Namespace


DateModified Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProject..::.DateModified Property
ISASProject Interface See Also

Date/Time the project was last modified.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property DateModified As DateTime
C#
DateTime DateModified { get; }

See Also

ISASProject Interface
SAS.Shared.AddIns Namespace


ModifiedByUserId Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProject..::.ModifiedByUserId Property
ISASProject Interface See Also

Windows user ID of the person who last modified the project.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ModifiedByUserId As String
C#
string ModifiedByUserId { get; }

See Also

ISASProject Interface
SAS.Shared.AddIns Namespace


Name Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProject..::.Name Property
ISASProject Interface See Also

Project name, if it has one.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Name As String
C#
string Name { get; }

See Also

ISASProject Interface
SAS.Shared.AddIns Namespace


ProcessFlows Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProject..::.ProcessFlows Property
ISASProject Interface See Also

A list of the Process Flow objects within the current project.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ProcessFlows As List(Of ISASProjectProcessFlow)
C#
List<ISASProjectProcessFlow> ProcessFlows { get; }

See Also

ISASProject Interface
SAS.Shared.AddIns Namespace


ISASProjectData Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProjectData Interface
Members See Also

Handle to a project item that can be used as a data source You can cast this to ISASProjectItem to get basic information like Name, the icon, etc.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISASProjectData
C#
public interface ISASProjectData

See Also

ISASProjectData Members
SAS.Shared.AddIns Namespace


ISASProjectData Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProjectData Members
ISASProjectData Interface Properties See Also

The ISASProjectData type exposes the following members.

Properties

Name | Description
InputType | The type of data resource. For example, it might be a dataset, information map, or external file
Name | Name of the data source
Path | Path to the data. This might be a libref.member, such as SASHELP.CLASS, or a file system path, or a path in SAS Folders in metadata.
Server | Name of the SAS server associated with this data source, if any.

See Also

ISASProjectData Interface
SAS.Shared.AddIns Namespace


ISASProjectData Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProjectData Properties
ISASProjectData Interface See Also

The ISASProjectData type exposes the following members.

Properties

Name | Description
InputType | The type of data resource. For example, it might be a dataset, information map, or external file
Name | Name of the data source
Path | Path to the data. This might be a libref.member, such as SASHELP.CLASS, or a file system path, or a path in SAS Folders in metadata.
Server | Name of the SAS server associated with this data source, if any.

See Also

ISASProjectData Interface
SAS.Shared.AddIns Namespace


InputType Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProjectData..::.InputType Property
ISASProjectData Interface See Also

The type of data resource. For example, it might be a dataset, information map, or external file

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property InputType As InputResourceType
C#
InputResourceType InputType { get; }

See Also

ISASProjectData Interface
SAS.Shared.AddIns Namespace


Name Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProjectData..::.Name Property
ISASProjectData Interface See Also

Name of the data source

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Name As String
C#
string Name { get; }

See Also

ISASProjectData Interface
SAS.Shared.AddIns Namespace


Path Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProjectData..::.Path Property
ISASProjectData Interface See Also

Path to the data. This might be a libref.member, such as SASHELP.CLASS, or a file system path, or a path in SAS Folders in metadata.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Path As String
C#
string Path { get; }

See Also

ISASProjectData Interface
SAS.Shared.AddIns Namespace


Server Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProjectData..::.Server Property
ISASProjectData Interface See Also

Name of the SAS server associated with this data source, if any.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Server As String
C#
string Server { get; }

See Also

ISASProjectData Interface
SAS.Shared.AddIns Namespace


ISASProjectItem Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProjectItem Interface
Members See Also

Handle to an item within the project.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISASProjectItem
C#
public interface ISASProjectItem

See Also

ISASProjectItem Members
SAS.Shared.AddIns Namespace


ISASProjectItem Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProjectItem Members
ISASProjectItem Interface Methods Properties See Also

The ISASProjectItem type exposes the following members.

Methods

Name | Description
GetIcon | Get a copy of the icon associated with this task, either the large size (32x32) or small size (16x16).

Properties

Name | Description
DateCreated | Date/Time the task was last created.
DateModified | Date/Time the task was last modified.
ModifiedByUserId | Windows user ID of the person who last modified the task.
Name | The item name within the project.

See Also

ISASProjectItem Interface
SAS.Shared.AddIns Namespace


ISASProjectItem Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProjectItem Methods
ISASProjectItem Interface See Also

The ISASProjectItem type exposes the following members.

Methods

Name | Description
GetIcon | Get a copy of the icon associated with this task, either the large size (32x32) or small size (16x16).

See Also

ISASProjectItem Interface
SAS.Shared.AddIns Namespace


GetIcon Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProjectItem..::.GetIcon Method
ISASProjectItem Interface See Also

Get a copy of the icon associated with this task, either the large size (32x32) or small size (16x16).

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function GetIcon ( _
    smallIconSize As Boolean _
) As Icon
C#
Icon GetIcon(
    bool smallIconSize
)

Parameters

smallIconSize
Type: System..::.Boolean
Whether to retrieve the small size icon.

Return Value

Icon object representing the icon for this task.

See Also

ISASProjectItem Interface
SAS.Shared.AddIns Namespace


ISASProjectItem Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProjectItem Properties
ISASProjectItem Interface See Also

The ISASProjectItem type exposes the following members.

Properties

Name | Description
DateCreated | Date/Time the task was last created.
DateModified | Date/Time the task was last modified.
ModifiedByUserId | Windows user ID of the person who last modified the task.
Name | The item name within the project.

See Also

ISASProjectItem Interface
SAS.Shared.AddIns Namespace


DateCreated Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProjectItem..::.DateCreated Property
ISASProjectItem Interface See Also

Date/Time the task was last created.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property DateCreated As DateTime
C#
DateTime DateCreated { get; }

See Also

ISASProjectItem Interface
SAS.Shared.AddIns Namespace


DateModified Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProjectItem..::.DateModified Property
ISASProjectItem Interface See Also

Date/Time the task was last modified.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property DateModified As DateTime
C#
DateTime DateModified { get; }

See Also

ISASProjectItem Interface
SAS.Shared.AddIns Namespace


ModifiedByUserId Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProjectItem..::.ModifiedByUserId Property
ISASProjectItem Interface See Also

Windows user ID of the person who last modified the task.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ModifiedByUserId As String
C#
string ModifiedByUserId { get; }

See Also

ISASProjectItem Interface
SAS.Shared.AddIns Namespace


Name Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProjectItem..::.Name Property
ISASProjectItem Interface See Also

The item name within the project.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Name As String
C#
string Name { get; }

See Also

ISASProjectItem Interface
SAS.Shared.AddIns Namespace


ISASProjectProcessFlow Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProjectProcessFlow Interface
Members See Also

Handle to a process flow within the current project.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISASProjectProcessFlow
C#
public interface ISASProjectProcessFlow

See Also

ISASProjectProcessFlow Members
SAS.Shared.AddIns Namespace


ISASProjectProcessFlow Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProjectProcessFlow Members
ISASProjectProcessFlow Interface Methods Properties See Also

The ISASProjectProcessFlow type exposes the following members.

Methods

Name | Description
AddLink | Add a process flow link to connect two items in the project.
AreLinked | Checks to see whether the two project items are directly connected with a user-specified link. The order of the parameters is unimportant; the method checks for links going in either direction.
CanLink | Checks to see whether it is possible to add a link between the two project items. The order of the parameters is unimportant. SAS Enterprise Guide does not allow circular links, so this method will return false if the "proposed" link results in a circular diagram. It also returns false if the items are already directly linked, or if one of the items is of a type that does not allow links (for example, a SAS log item).
GetAllSasCode | Retrieve all of the SAS program code that is contained (or is generated by tasks) within the current process flow.
GetSasCodeForThisPath | Retrieve all of the SAS program code that is contained (or is generated by tasks) within the current process flow -- up to the task that is passed in as endingWithTask, and NOT including sibling tasks, or ancestors of sibling tasks which are not also ancestors of endingWithTask.
GetSasCodeUpToHere | Retrieve all of the SAS program code that is contained (or is generated by tasks) within the current process flow -- up to the task that is passed in as endingWithTask.
GetTasks | Retrieve a list of all of the task items within the process flow. These tasks are returned in the order in which they would be run. Tasks include SAS tasks, queries, and SAS programs.
IsAncestor | Checks to see whether one ISASProjectItem is an ancestor to another ISASProjectItem in a process flow.
RemoveLink | Remove a process flow link that connects two items in the project.

Properties

Name | Description
Name | Name of the process flow.

See Also

ISASProjectProcessFlow Interface
SAS.Shared.AddIns Namespace


ISASProjectProcessFlow Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProjectProcessFlow Methods
ISASProjectProcessFlow Interface See Also

The ISASProjectProcessFlow type exposes the following members.

Methods

Name | Description
AddLink | Add a process flow link to connect two items in the project.
AreLinked | Checks to see whether the two project items are directly connected with a user-specified link. The order of the parameters is unimportant; the method checks for links going in either direction.
CanLink | Checks to see whether it is possible to add a link between the two project items. The order of the parameters is unimportant. SAS Enterprise Guide does not allow circular links, so this method will return false if the "proposed" link results in a circular diagram. It also returns false if the items are already directly linked, or if one of the items is of a type that does not allow links (for example, a SAS log item).
GetAllSasCode | Retrieve all of the SAS program code that is contained (or is generated by tasks) within the current process flow.
GetSasCodeForThisPath | Retrieve all of the SAS program code that is contained (or is generated by tasks) within the current process flow -- up to the task that is passed in as endingWithTask, and NOT including sibling tasks, or ancestors of sibling tasks which are not also ancestors of endingWithTask.
GetSasCodeUpToHere | Retrieve all of the SAS program code that is contained (or is generated by tasks) within the current process flow -- up to the task that is passed in as endingWithTask.
GetTasks | Retrieve a list of all of the task items within the process flow. These tasks are returned in the order in which they would be run. Tasks include SAS tasks, queries, and SAS programs.
IsAncestor | Checks to see whether one ISASProjectItem is an ancestor to another ISASProjectItem in a process flow.
RemoveLink | Remove a process flow link that connects two items in the project.

See Also

ISASProjectProcessFlow Interface
SAS.Shared.AddIns Namespace


AddLink Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProjectProcessFlow..::.AddLink Method
ISASProjectProcessFlow Interface See Also

Add a process flow link to connect two items in the project.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Sub AddLink ( _
    fromItem As ISASProjectItem, _
    toItem As ISASProjectItem _
)
C#
void AddLink(
    ISASProjectItem fromItem,
    ISASProjectItem toItem
)

Parameters

fromItem
Type: SAS.Shared.AddIns..::.ISASProjectItem
The item where the link should originate.
toItem
Type: SAS.Shared.AddIns..::.ISASProjectItem
The item where the link should end.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the two items cannot be linked, possibly because they are already linked in some way or would result in a circular link.

See Also

ISASProjectProcessFlow Interface
SAS.Shared.AddIns Namespace


AreLinked Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProjectProcessFlow..::.AreLinked Method
ISASProjectProcessFlow Interface See Also

Checks to see whether the two project items are directly connected with a user-specified link. The order of the parameters is unimportant; the method checks for links going in either direction.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function AreLinked ( _
    item1 As ISASProjectItem, _
    item2 As ISASProjectItem _
) As Boolean
C#
bool AreLinked(
    ISASProjectItem item1,
    ISASProjectItem item2
)

Parameters

item1
Type: SAS.Shared.AddIns..::.ISASProjectItem
One endpoint item to check
item2
Type: SAS.Shared.AddIns..::.ISASProjectItem
The second endpoint item to check

Return Value

true if the items are linked, else false

See Also

ISASProjectProcessFlow Interface
SAS.Shared.AddIns Namespace


CanLink Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProjectProcessFlow..::.CanLink Method
ISASProjectProcessFlow Interface See Also

Checks to see whether it is possible to add a link between the two project items. The order of the parameters is unimportant.

SAS Enterprise Guide does not allow circular links, so this method will return false if the "proposed" link results in a circular diagram. It also returns false if the items are already directly linked, or if one of the items is of a type that does not allow links (for example, a SAS log item).

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function CanLink ( _
    item1 As ISASProjectItem, _
    item2 As ISASProjectItem _
) As Boolean
C#
bool CanLink(
    ISASProjectItem item1,
    ISASProjectItem item2
)

Parameters

item1
Type: SAS.Shared.AddIns..::.ISASProjectItem
One endpoint item to check
item2
Type: SAS.Shared.AddIns..::.ISASProjectItem
The second endpoint item to check

Return Value

true if the items can be linked, else false

See Also

ISASProjectProcessFlow Interface
SAS.Shared.AddIns Namespace


GetAllSasCode Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProjectProcessFlow..::.GetAllSasCode Method
ISASProjectProcessFlow Interface Example See Also

Retrieve all of the SAS program code that is contained (or is generated by tasks) within the current process flow.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function GetAllSasCode ( _
    options As eSasCodeOptions _
) As String
C#
string GetAllSasCode(
    eSasCodeOptions options
)

Parameters

options
Type: SAS.Shared.AddIns..::.eSasCodeOptions
A set of flags that can be combined together to affect how much of the "generated" SAS code is included. For example, you can include the ODS statements that SAS Enterprise Guide would typically generate when running the code -- or you can exclude that.

Return Value

A string with all of the SAS program code.

Examples

For example, this C# code retrieves the SAS code for the current process flow, including the custom code specified in Tools->Options and SAS comment headings that are generated by SAS Enterprise Guide.
Copy Code
              // Consumer is a reference to the ISASTaskConsumer3 interface
              ISASProjectProcessFlow flow = Consumer.GetThisProcessFlow();
              string code = flow.GetAllSasCode(eSasCodeOptions.IncludeCustomCode | eSasCodeOptions.IncludeHeaders);

See Also

ISASProjectProcessFlow Interface
SAS.Shared.AddIns Namespace


GetSasCodeForThisPath Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProjectProcessFlow..::.GetSasCodeForThisPath Method
ISASProjectProcessFlow Interface See Also

Retrieve all of the SAS program code that is contained (or is generated by tasks) within the current process flow -- up to the task that is passed in as endingWithTask, and NOT including sibling tasks, or ancestors of sibling tasks which are not also ancestors of endingWithTask.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function GetSasCodeForThisPath ( _
    endingWithTask As ISASProjectTask, _
    bInclusive As Boolean, _
    options As eSasCodeOptions _
) As String
C#
string GetSasCodeForThisPath(
    ISASProjectTask endingWithTask,
    bool bInclusive,
    eSasCodeOptions options
)

Parameters

endingWithTask
Type: SAS.Shared.AddIns..::.ISASProjectTask
The end point task to use when gathering the SAS code.
bInclusive
Type: System..::.Boolean
Whether the SAS code should include the code generated by the endingWithTask task.
options
Type: SAS.Shared.AddIns..::.eSasCodeOptions
A set of flags that can be combined together to affect how much of the "generated" SAS code is included. For example, you can include the ODS statements that SAS Enterprise Guide would typically generate when running the code -- or you can exclude that.

Return Value

A string with all of the SAS program code.

Remarks

The endingWithTask item should be in the same flow represented by this ISASProjectProcessFlow object. If the task is not within the current process flow, then the result will include all of the SAS code for the current process flow (same result as GetAllSasCode(eSasCodeOptions)).

See Also

ISASProjectProcessFlow Interface
SAS.Shared.AddIns Namespace


GetSasCodeUpToHere Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProjectProcessFlow..::.GetSasCodeUpToHere Method
ISASProjectProcessFlow Interface See Also

Retrieve all of the SAS program code that is contained (or is generated by tasks) within the current process flow -- up to the task that is passed in as endingWithTask.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function GetSasCodeUpToHere ( _
    endingWithTask As ISASProjectTask, _
    bInclusive As Boolean, _
    options As eSasCodeOptions _
) As String
C#
string GetSasCodeUpToHere(
    ISASProjectTask endingWithTask,
    bool bInclusive,
    eSasCodeOptions options
)

Parameters

endingWithTask
Type: SAS.Shared.AddIns..::.ISASProjectTask
The end point task to use when gathering the SAS code.
bInclusive
Type: System..::.Boolean
Whether the SAS code should include the code generated by the endingWithTask task.
options
Type: SAS.Shared.AddIns..::.eSasCodeOptions
A set of flags that can be combined together to affect how much of the "generated" SAS code is included. For example, you can include the ODS statements that SAS Enterprise Guide would typically generate when running the code -- or you can exclude that.

Return Value

A string with all of the SAS program code.

Remarks

The endingWithTask item should be in the same flow represented by this ISASProjectProcessFlow object. If the task is not within the current process flow, then the result will include all of the SAS code for the current process flow (same result as GetAllSasCode(eSasCodeOptions)).

See Also

ISASProjectProcessFlow Interface
SAS.Shared.AddIns Namespace


GetTasks Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProjectProcessFlow..::.GetTasks Method
ISASProjectProcessFlow Interface See Also

Retrieve a list of all of the task items within the process flow. These tasks are returned in the order in which they would be run. Tasks include SAS tasks, queries, and SAS programs.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function GetTasks As List(Of ISASProjectTask)
C#
List<ISASProjectTask> GetTasks()

Return Value

A list of ISASProjectTask objects that represent the tasks within this process flow.

See Also

ISASProjectProcessFlow Interface
SAS.Shared.AddIns Namespace


IsAncestor Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProjectProcessFlow..::.IsAncestor Method
ISASProjectProcessFlow Interface See Also

Checks to see whether one ISASProjectItem is an ancestor to another ISASProjectItem in a process flow.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function IsAncestor ( _
    currentItem As ISASProjectItem, _
    ancestorItem As ISASProjectItem _
) As Boolean
C#
bool IsAncestor(
    ISASProjectItem currentItem,
    ISASProjectItem ancestorItem
)

Parameters

currentItem
Type: SAS.Shared.AddIns..::.ISASProjectItem
The item being tested to see if it HAS a specific ancestor
ancestorItem
Type: SAS.Shared.AddIns..::.ISASProjectItem
The item being tested to see if it IS an ancestor to another item

Return Value

true if ancestorItem is an ancestor to currentItem

See Also

ISASProjectProcessFlow Interface
SAS.Shared.AddIns Namespace


RemoveLink Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProjectProcessFlow..::.RemoveLink Method
ISASProjectProcessFlow Interface See Also

Remove a process flow link that connects two items in the project.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Sub RemoveLink ( _
    fromItem As ISASProjectItem, _
    toItem As ISASProjectItem _
)
C#
void RemoveLink(
    ISASProjectItem fromItem,
    ISASProjectItem toItem
)

Parameters

fromItem
Type: SAS.Shared.AddIns..::.ISASProjectItem
The item where the link originates.
toItem
Type: SAS.Shared.AddIns..::.ISASProjectItem
The item where the link ends.

Exceptions

Exception | Condition
System..::.InvalidOperationException | Thrown when the two items are not currently linked.

See Also

ISASProjectProcessFlow Interface
SAS.Shared.AddIns Namespace


ISASProjectProcessFlow Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProjectProcessFlow Properties
ISASProjectProcessFlow Interface See Also

The ISASProjectProcessFlow type exposes the following members.

Properties

Name | Description
Name | Name of the process flow.

See Also

ISASProjectProcessFlow Interface
SAS.Shared.AddIns Namespace


Name Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProjectProcessFlow..::.Name Property
ISASProjectProcessFlow Interface See Also

Name of the process flow.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Name As String
C#
string Name { get; }

See Also

ISASProjectProcessFlow Interface
SAS.Shared.AddIns Namespace


ISASProjectTask Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProjectTask Interface
Members See Also

Handle to the task element within the current project. You can cast this to ISASProjectItem to get basic information like Name, the icon, etc.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISASProjectTask
C#
public interface ISASProjectTask

See Also

ISASProjectTask Members
SAS.Shared.AddIns Namespace


ISASProjectTask Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProjectTask Members
ISASProjectTask Interface Methods Properties See Also

The ISASProjectTask type exposes the following members.

Methods

Name | Description
GetInputDataList | Get a list of project data items that are linked as input into this task.

Properties

Name | Description
InternalState | The internal state of this task as it is stored within the project. In order to interpret this information, you must have proprietary knowledge about the internals of the particular task.
TaskType | The type of task as tracked by the project. Is it a SAS program, query, or SAS task?

See Also

ISASProjectTask Interface
SAS.Shared.AddIns Namespace


ISASProjectTask Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProjectTask Methods
ISASProjectTask Interface See Also

The ISASProjectTask type exposes the following members.

Methods

Name | Description
GetInputDataList | Get a list of project data items that are linked as input into this task.

See Also

ISASProjectTask Interface
SAS.Shared.AddIns Namespace


GetInputDataList Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProjectTask..::.GetInputDataList Method
ISASProjectTask Interface See Also

Get a list of project data items that are linked as input into this task.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function GetInputDataList As List(Of ISASProjectData)
C#
List<ISASProjectData> GetInputDataList()

Return Value

A list of ISASProjectData items, which can be used to determine information about the data sources.

See Also

ISASProjectTask Interface
SAS.Shared.AddIns Namespace


ISASProjectTask Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProjectTask Properties
ISASProjectTask Interface See Also

The ISASProjectTask type exposes the following members.

Properties

Name | Description
InternalState | The internal state of this task as it is stored within the project. In order to interpret this information, you must have proprietary knowledge about the internals of the particular task.
TaskType | The type of task as tracked by the project. Is it a SAS program, query, or SAS task?

See Also

ISASProjectTask Interface
SAS.Shared.AddIns Namespace


InternalState Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProjectTask..::.InternalState Property
ISASProjectTask Interface See Also

The internal state of this task as it is stored within the project. In order to interpret this information, you must have proprietary knowledge about the internals of the particular task.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property InternalState As String
C#
string InternalState { get; }

See Also

ISASProjectTask Interface
SAS.Shared.AddIns Namespace


TaskType Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASProjectTask..::.TaskType Property
ISASProjectTask Interface See Also

The type of task as tracked by the project. Is it a SAS program, query, or SAS task?

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property TaskType As String
C#
string TaskType { get; }

See Also

ISASProjectTask Interface
SAS.Shared.AddIns Namespace


ISASTask Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTask Interface
Members See Also

Implemented by: Add-in task

Add-ins are required to support this interface.

This interface is used by the application to control the runtime state of the add-in.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
<GuidAttribute("F0A35D5D-8A0E-449b-B880-2F9E4645A001")> _
Public Interface ISASTask
C#
[GuidAttribute("F0A35D5D-8A0E-449b-B880-2F9E4645A001")]
public interface ISASTask

Remarks

This interface is required. An add-in must implement this interface in order for the application to recognize it as a valid add-in.

See Also

ISASTask Members
SAS.Shared.AddIns Namespace
SAS.Shared.AddIns..::.ISASTask2
SAS.Shared.AddIns..::.ISASTaskDescription
SAS.Shared.AddIns..::.ISASTaskAddIn


ISASTask Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTask Members
ISASTask Interface Methods Properties See Also

The ISASTask type exposes the following members.

Methods

Name | Description
Initialize | Called by the application when the task is about to be used.
OutputDataInfo | Provides information about the output data that this add-in expects to create or modify.
Show | Show the task form.
Terminate | This routine is called at the end of each task session. It signals to the add-in it can perform any necessary post-processing cleanup.

Properties

Name | Description
Label | The label of an instance of the task as it appears in the project.
OutputDataCount | Indicates how many output datasets will be generated.
RunLog | The text to display as the run log when no SAS code is used.
SasCode | The SAS code associated with the task.
XmlState | An XML description of the task state so that it can be persisted from run to run, and within the projects that contain the task.

See Also

ISASTask Interface
SAS.Shared.AddIns Namespace


ISASTask Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTask Methods
ISASTask Interface See Also

The ISASTask type exposes the following members.

Methods

Name | Description
Initialize | Called by the application when the task is about to be used.
OutputDataInfo | Provides information about the output data that this add-in expects to create or modify.
Show | Show the task form.
Terminate | This routine is called at the end of each task session. It signals to the add-in it can perform any necessary post-processing cleanup.

See Also

ISASTask Interface
SAS.Shared.AddIns Namespace


Initialize Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTask..::.Initialize Method
ISASTask Interface See Also

Called by the application when the task is about to be used.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function Initialize As Boolean
C#
bool Initialize()

Return Value

Returns a flag that tells the application framework the add-in succeeded or failed to initialize.

Remarks

Use the Initialize routine to initialize any items that the task will need in order to process requests for any of the other properties/methods in the ISASTask interface.

See Also

ISASTask Interface
SAS.Shared.AddIns Namespace
ISASTask..::.Terminate()()()


OutputDataInfo Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTask..::.OutputDataInfo Method
ISASTask Interface See Also

Provides information about the output data that this add-in expects to create or modify.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function OutputDataInfo ( _
    Index As Integer, _
    <OutAttribute> ByRef Source As String, _
    <OutAttribute> ByRef Label As String _
) As OutputData
C#
OutputData OutputDataInfo(
    int Index,
    out string Source,
    out string Label
)

Parameters

Index
Type: System..::.Int32
The Index is a zero-based index of the output data information.
Source
Type: System..::.String %
The Source string represents the output data. The Source represents a fully qualified SAS data set (<library>.<data set>) or a local file system name (<drive>|<unc>\<directory>\ <file name>).
Label
Type: System..::.String %
The Label is the display name for the output data (for use in the project view, for example).

Return Value

Returns the type of data source name in the Source parameter. If this value is equal to OutputData.Libref then the Source (<library>.<data set>) should be used. If this value is equal to OutputData.FilePath then the Source (<drive>|<unc>\<directory>\<file name>) should be used.

See Also

ISASTask Interface
SAS.Shared.AddIns Namespace


Show Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTask..::.Show Method
ISASTask Interface See Also

Show the task form.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function Show ( _
    Owner As IWin32Window _
) As ShowResult
C#
ShowResult Show(
    IWin32Window Owner
)

Parameters

Owner
Type: System.Windows.Forms..::.IWin32Window
The form that owns the task form.

Return Value

The method returns one of the ShowResult enumerated types indicating the status of the task dialog.

See Also

ISASTask Interface
SAS.Shared.AddIns Namespace


Terminate Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTask..::.Terminate Method
ISASTask Interface See Also

This routine is called at the end of each task session. It signals to the add-in it can perform any necessary post-processing cleanup.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Sub Terminate
C#
void Terminate()

Remarks

After this routine is called, the application framework should call Initialize before attempting to make any additional calls to the ISASTask interface. Note that this does not unload your add-in from the application -- that is done in the ISASTaskAddIn.Disconnect call.

See Also

ISASTask Interface
SAS.Shared.AddIns Namespace
ISASTask..::.Initialize()()()
ISASTaskAddIn..::.Disconnect()()()


ISASTask Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTask Properties
ISASTask Interface See Also

The ISASTask type exposes the following members.

Properties

Name | Description
Label | The label of an instance of the task as it appears in the project.
OutputDataCount | Indicates how many output datasets will be generated.
RunLog | The text to display as the run log when no SAS code is used.
SasCode | The SAS code associated with the task.
XmlState | An XML description of the task state so that it can be persisted from run to run, and within the projects that contain the task.

See Also

ISASTask Interface
SAS.Shared.AddIns Namespace


Label Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTask..::.Label Property
ISASTask Interface See Also

The label of an instance of the task as it appears in the project.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Property Label As String
C#
string Label { get; set; }

Field Value

The label as maintained by the task. The application allows the end user to change the label, if desired.

Remarks

The label is useful for organizing projects. The task should generate an appropriate label as a default. The end user might change the label within the project as needed.

See Also

ISASTask Interface
SAS.Shared.AddIns Namespace


OutputDataCount Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTask..::.OutputDataCount Property
ISASTask Interface See Also

Indicates how many output datasets will be generated.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputDataCount As Integer
C#
int OutputDataCount { get; }

Field Value

The number of output datasets the task expects to create.

Remarks

This property is used in conjunction with the OutputDataInfo method, which retrieves information about each dataset.

See Also

ISASTask Interface
SAS.Shared.AddIns Namespace
ISASTask..::.OutputDataInfo(Int32, String%, String%)


RunLog Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTask..::.RunLog Property
ISASTask Interface See Also

The text to display as the run log when no SAS code is used.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property RunLog As String
C#
string RunLog { get; }

Field Value

The text summarizes the log output of this task when run.

Remarks

For tasks that do not generate SAS code but instead perform some other work, this property allows you to provide a text summary of the work performed.

See Also

ISASTask Interface
SAS.Shared.AddIns Namespace
SAS.Shared.AddIns..::.ISASTaskExecution


SasCode Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTask..::.SasCode Property
ISASTask Interface See Also

The SAS code associated with the task.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SasCode As String
C#
string SasCode { get; }

Field Value

The SAS program code that the application will submit when this task is run.

Remarks

This property is called only if the ISASTaskDescription.GeneratesSasCode property is true.

See Also

ISASTask Interface
SAS.Shared.AddIns Namespace
ISASTaskDescription..::.GeneratesSasCode


XmlState Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTask..::.XmlState Property
ISASTask Interface See Also

An XML description of the task state so that it can be persisted from run to run, and within the projects that contain the task.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Property XmlState As String
C#
string XmlState { get; set; }

Field Value

The XML-formatted text that the task can read and write.

Remarks

Using XML as a format convention, you can store the state of your task within the application's project. The contents and schema of the XML are not important to the application, as long as the task can create the XML and then interpret the same XML when the application supplies it, resetting the task state.

See Also

ISASTask Interface
SAS.Shared.AddIns Namespace


ISASTask2 Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTask2 Interface
Members See Also

Implemented by: Add-in task

This interface provides features in addition to everything in ISASTask. Add-ins are required to support this interface or ISASTask.

This interface is used by the application to control the runtime state of the add-in.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISASTask2 _
    Implements ISASTask
C#
public interface ISASTask2 : ISASTask

Remarks

This interface or ISASTask is required. An add-in must implement this interface or ISASTaskin order for the application to recognize it as a valid add-in.

See Also

ISASTask2 Members
SAS.Shared.AddIns Namespace
SAS.Shared.AddIns..::.ISASTask
SAS.Shared.AddIns..::.ISASTaskDescription
SAS.Shared.AddIns..::.ISASTaskAddIn


ISASTask2 Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTask2 Members
ISASTask2 Interface Methods Properties See Also

The ISASTask2 type exposes the following members.

Methods

Name | Description
Activate | Activates the form and gives it focus.
ActiveStateChanged | Notifies the task state values have changed. This can include the Label, Obs, FirstObs. This is useful for updating the code preview window and the visible view if running in a modeless state.
Close | Closes the form.
Initialize | Called by the application when the task is about to be used. (Inherited from ISASTask.)
OutputDataInfo | Provides information about the output data that this add-in expects to create or modify. (Inherited from ISASTask.)
Show | Overloaded.
ShowDialog | Show a modal task form. When viewed as modal, the end user cannot interact with the host application until the task form is dismissed.
Terminate | This routine is called at the end of each task session. It signals to the add-in it can perform any necessary post-processing cleanup. (Inherited from ISASTask.)

Properties

Name | Description
Label | The label of an instance of the task as it appears in the project. (Inherited from ISASTask.)
Modal | Gets a value indicating whether this form is displayed modally.
OutputDataCount | Indicates how many output datasets will be generated. (Inherited from ISASTask.)
ParameterNames | Get a list of parameter names used by the task in its generated sas code. If the task does not use any parameters then it should return null or an empty array.
RunLog | The text to display as the run log when no SAS code is used. (Inherited from ISASTask.)
SasCode | The SAS code associated with the task. (Inherited from ISASTask.)
Visible | True if the control is displayed; otherwise, false. The default is true.
XmlResult | Get the XML result for a given task which does not generate SasCode.
XmlState | An XML description of the task state so that it can be persisted from run to run, and within the projects that contain the task. (Inherited from ISASTask.)

See Also

ISASTask2 Interface
SAS.Shared.AddIns Namespace


ISASTask2 Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTask2 Methods
ISASTask2 Interface See Also

The ISASTask2 type exposes the following members.

Methods

Name | Description
Activate | Activates the form and gives it focus.
ActiveStateChanged | Notifies the task state values have changed. This can include the Label, Obs, FirstObs. This is useful for updating the code preview window and the visible view if running in a modeless state.
Close | Closes the form.
Initialize | Called by the application when the task is about to be used. (Inherited from ISASTask.)
OutputDataInfo | Provides information about the output data that this add-in expects to create or modify. (Inherited from ISASTask.)
Show | Overloaded.
ShowDialog | Show a modal task form. When viewed as modal, the end user cannot interact with the host application until the task form is dismissed.
Terminate | This routine is called at the end of each task session. It signals to the add-in it can perform any necessary post-processing cleanup. (Inherited from ISASTask.)

See Also

ISASTask2 Interface
SAS.Shared.AddIns Namespace


Activate Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTask2..::.Activate Method
ISASTask2 Interface See Also

Activates the form and gives it focus.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Sub Activate
C#
void Activate()

See Also

ISASTask2 Interface
SAS.Shared.AddIns Namespace


ActiveStateChanged Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTask2..::.ActiveStateChanged Method
ISASTask2 Interface See Also

Notifies the task state values have changed. This can include the Label, Obs, FirstObs. This is useful for updating the code preview window and the visible view if running in a modeless state.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Sub ActiveStateChanged
C#
void ActiveStateChanged()

See Also

ISASTask2 Interface
SAS.Shared.AddIns Namespace


Close Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTask2..::.Close Method
ISASTask2 Interface See Also

Closes the form.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Sub Close
C#
void Close()

See Also

ISASTask2 Interface
SAS.Shared.AddIns Namespace


Show Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTask2..::.Show Method
ISASTask2 Interface See Also

Overload List

Name | Description
Show(IWin32Window) | Show the task form. (Inherited from ISASTask.)
Show(IWin32Window, ViewType) | Show a modeless task form. When viewed as modeless, the end user can interact with the host application while the task form is displayed.

See Also

ISASTask2 Interface
ISASTask2 Members
SAS.Shared.AddIns Namespace


Show Method (IWin32Window, ViewType)

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTask2..::.Show Method (IWin32Window, ViewType)
ISASTask2 Interface See Also

Show a modeless task form. When viewed as modeless, the end user can interact with the host application while the task form is displayed.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function Show ( _
    Owner As IWin32Window, _
    PreferredView As ViewType _
) As ShowResult
C#
ShowResult Show(
    IWin32Window Owner,
    ViewType PreferredView
)

Parameters

Owner
Type: System.Windows.Forms..::.IWin32Window
The form that owns the task form.
PreferredView
Type: SAS.Shared.AddIns..::.ViewType
The preferred ViewType for the task to show.

Return Value

The method returns one of the ShowResult enumerated types indicating the status of the task dialog.

See Also

ISASTask2 Interface
Show Overload
SAS.Shared.AddIns Namespace


ShowDialog Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTask2..::.ShowDialog Method
ISASTask2 Interface See Also

Show a modal task form. When viewed as modal, the end user cannot interact with the host application until the task form is dismissed.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function ShowDialog ( _
    Owner As IWin32Window, _
    PreferredView As ViewType _
) As ShowResult
C#
ShowResult ShowDialog(
    IWin32Window Owner,
    ViewType PreferredView
)

Parameters

Owner
Type: System.Windows.Forms..::.IWin32Window
The form that owns the task form.
PreferredView
Type: SAS.Shared.AddIns..::.ViewType
The preferred ViewType for the task to show.

Return Value

The method returns one of the ShowResult enumerated types indicating the status of the task dialog.

See Also

ISASTask2 Interface
SAS.Shared.AddIns Namespace


ISASTask2 Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTask2 Properties
ISASTask2 Interface See Also

The ISASTask2 type exposes the following members.

Properties

Name | Description
Label | The label of an instance of the task as it appears in the project. (Inherited from ISASTask.)
Modal | Gets a value indicating whether this form is displayed modally.
OutputDataCount | Indicates how many output datasets will be generated. (Inherited from ISASTask.)
ParameterNames | Get a list of parameter names used by the task in its generated sas code. If the task does not use any parameters then it should return null or an empty array.
RunLog | The text to display as the run log when no SAS code is used. (Inherited from ISASTask.)
SasCode | The SAS code associated with the task. (Inherited from ISASTask.)
Visible | True if the control is displayed; otherwise, false. The default is true.
XmlResult | Get the XML result for a given task which does not generate SasCode.
XmlState | An XML description of the task state so that it can be persisted from run to run, and within the projects that contain the task. (Inherited from ISASTask.)

See Also

ISASTask2 Interface
SAS.Shared.AddIns Namespace


Modal Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTask2..::.Modal Property
ISASTask2 Interface See Also

Gets a value indicating whether this form is displayed modally.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Modal As Boolean
C#
bool Modal { get; }

See Also

ISASTask2 Interface
SAS.Shared.AddIns Namespace


ParameterNames Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTask2..::.ParameterNames Property
ISASTask2 Interface See Also

Get a list of parameter names used by the task in its generated sas code. If the task does not use any parameters then it should return null or an empty array.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ParameterNames As String()
C#
string[] ParameterNames { get; }

See Also

ISASTask2 Interface
SAS.Shared.AddIns Namespace


Visible Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTask2..::.Visible Property
ISASTask2 Interface See Also

True if the control is displayed; otherwise, false. The default is true.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Visible As Boolean
C#
bool Visible { get; }

See Also

ISASTask2 Interface
SAS.Shared.AddIns Namespace


XmlResult Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTask2..::.XmlResult Property
ISASTask2 Interface See Also

Get the XML result for a given task which does not generate SasCode.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property XmlResult As String
C#
string XmlResult { get; }

See Also

ISASTask2 Interface
SAS.Shared.AddIns Namespace


ISASTask3 Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTask3 Interface
Members See Also

Implemented by: Add-in task

This interface provides features in addition to everything in ISASTask2. Add-ins are required to support this interface or ISASTask or ISASTask2.

This interface is used by the application to control the runtime state of the add-in.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISASTask3 _
    Implements ISASTask2, ISASTask
C#
public interface ISASTask3 : ISASTask2,
    ISASTask

Remarks

This interface or ISASTask or ISASTask2 is required. An add-in must implement this interface or ISASTask or ISASTask2 in order for the application to recognize it as a valid add-in.

See Also

ISASTask3 Members
SAS.Shared.AddIns Namespace
SAS.Shared.AddIns..::.ISASTask
SAS.Shared.AddIns..::.ISASTask2
SAS.Shared.AddIns..::.ISASTaskDescription
SAS.Shared.AddIns..::.ISASTaskAddIn


ISASTask3 Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTask3 Members
ISASTask3 Interface Methods Properties See Also

The ISASTask3 type exposes the following members.

Methods

Name | Description
Activate | Activates the form and gives it focus. (Inherited from ISASTask2.)
ActiveStateChanged | Notifies the task state values have changed. This can include the Label, Obs, FirstObs. This is useful for updating the code preview window and the visible view if running in a modeless state. (Inherited from ISASTask2.)
Close | Closes the form. (Inherited from ISASTask2.)
Initialize | Called by the application when the task is about to be used. (Inherited from ISASTask.)
OutputDataInfo | Provides information about the output data that this add-in expects to create or modify. (Inherited from ISASTask.)
Show | Overloaded.
ShowDialog | Show a modal task form. When viewed as modal, the end user cannot interact with the host application until the task form is dismissed. (Inherited from ISASTask2.)
Terminate | This routine is called at the end of each task session. It signals to the add-in it can perform any necessary post-processing cleanup. (Inherited from ISASTask.)

Properties

Name | Description
Label | The label of an instance of the task as it appears in the project. (Inherited from ISASTask.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from ISASTask2.)
OutputDataCount | Indicates how many output datasets will be generated. (Inherited from ISASTask.)
OutputDataDescriptorList | Get a list of output data described as ISASTaskDAtaDescriptors that the task is expecting to output. If the task does not have any output data it should return null.
ParameterNames | Get a list of parameter names used by the task in its generated sas code. If the task does not use any parameters then it should return null or an empty array. (Inherited from ISASTask2.)
RunLog | The text to display as the run log when no SAS code is used. (Inherited from ISASTask.)
SasCode | The SAS code associated with the task. (Inherited from ISASTask.)
Visible | True if the control is displayed; otherwise, false. The default is true. (Inherited from ISASTask2.)
XmlResult | Get the XML result for a given task which does not generate SasCode. (Inherited from ISASTask2.)
XmlState | An XML description of the task state so that it can be persisted from run to run, and within the projects that contain the task. (Inherited from ISASTask.)

See Also

ISASTask3 Interface
SAS.Shared.AddIns Namespace


ISASTask3 Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTask3 Methods
ISASTask3 Interface See Also

The ISASTask3 type exposes the following members.

Methods

Name | Description
Activate | Activates the form and gives it focus. (Inherited from ISASTask2.)
ActiveStateChanged | Notifies the task state values have changed. This can include the Label, Obs, FirstObs. This is useful for updating the code preview window and the visible view if running in a modeless state. (Inherited from ISASTask2.)
Close | Closes the form. (Inherited from ISASTask2.)
Initialize | Called by the application when the task is about to be used. (Inherited from ISASTask.)
OutputDataInfo | Provides information about the output data that this add-in expects to create or modify. (Inherited from ISASTask.)
Show | Overloaded.
ShowDialog | Show a modal task form. When viewed as modal, the end user cannot interact with the host application until the task form is dismissed. (Inherited from ISASTask2.)
Terminate | This routine is called at the end of each task session. It signals to the add-in it can perform any necessary post-processing cleanup. (Inherited from ISASTask.)

See Also

ISASTask3 Interface
SAS.Shared.AddIns Namespace


Show Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTask3..::.Show Method
ISASTask3 Interface See Also

Overload List

Name | Description
Show(IWin32Window) | Show the task form. (Inherited from ISASTask.)
Show(IWin32Window, ViewType) | Show a modeless task form. When viewed as modeless, the end user can interact with the host application while the task form is displayed. (Inherited from ISASTask2.)

See Also

ISASTask3 Interface
ISASTask3 Members
SAS.Shared.AddIns Namespace


ISASTask3 Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTask3 Properties
ISASTask3 Interface See Also

The ISASTask3 type exposes the following members.

Properties

Name | Description
Label | The label of an instance of the task as it appears in the project. (Inherited from ISASTask.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from ISASTask2.)
OutputDataCount | Indicates how many output datasets will be generated. (Inherited from ISASTask.)
OutputDataDescriptorList | Get a list of output data described as ISASTaskDAtaDescriptors that the task is expecting to output. If the task does not have any output data it should return null.
ParameterNames | Get a list of parameter names used by the task in its generated sas code. If the task does not use any parameters then it should return null or an empty array. (Inherited from ISASTask2.)
RunLog | The text to display as the run log when no SAS code is used. (Inherited from ISASTask.)
SasCode | The SAS code associated with the task. (Inherited from ISASTask.)
Visible | True if the control is displayed; otherwise, false. The default is true. (Inherited from ISASTask2.)
XmlResult | Get the XML result for a given task which does not generate SasCode. (Inherited from ISASTask2.)
XmlState | An XML description of the task state so that it can be persisted from run to run, and within the projects that contain the task. (Inherited from ISASTask.)

See Also

ISASTask3 Interface
SAS.Shared.AddIns Namespace


OutputDataDescriptorList Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTask3..::.OutputDataDescriptorList Property
ISASTask3 Interface See Also

Get a list of output data described as ISASTaskDAtaDescriptors that the task is expecting to output. If the task does not have any output data it should return null.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputDataDescriptorList As List(Of ISASTaskDataDescriptor)
C#
List<ISASTaskDataDescriptor> OutputDataDescriptorList { get; }

See Also

ISASTask3 Interface
SAS.Shared.AddIns Namespace


ISASTaskAddIn Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskAddIn Interface
Members See Also

Implemented by: Add-in task

Add-ins are required to support this interface.

This interface is used by the application to connect to the add-in and retrieve some basic information from it.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
<GuidAttribute("F0A35D5D-8A0E-449b-B880-2F9E4645A000")> _
Public Interface ISASTaskAddIn
C#
[GuidAttribute("F0A35D5D-8A0E-449b-B880-2F9E4645A000")]
public interface ISASTaskAddIn

Remarks

This interface is required. An add-in must implement this interface in order for the application to recognize it as a valid add-in.

See Also

ISASTaskAddIn Members
SAS.Shared.AddIns Namespace
SAS.Shared.AddIns..::.ISASTask
SAS.Shared.AddIns..::.ISASTaskDescription


ISASTaskAddIn Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskAddIn Members
ISASTaskAddIn Interface Methods Properties See Also

The ISASTaskAddIn type exposes the following members.

Methods

Name | Description
Connect | Connects, or loads, the add-in for use by the host application.
Disconnect | Disconnects, or unloads, the add-in from the host application.
Languages | Returns a list of culture codes that represent the languages/cultures that this add-in can support.

Properties

Name | Description
AddInDescription | Returns the description of the add-in. This value is shown in the Add-In Manager and might be shown within the host application.
AddInName | Returns the name of the add-in. This value is shown in the Add-In Manager and might be shown within the host application.
Language | Current language (culture) that the add-in should operate in.
VisibleInManager | This property is not currently used by the add-in mechanism.

See Also

ISASTaskAddIn Interface
SAS.Shared.AddIns Namespace


ISASTaskAddIn Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskAddIn Methods
ISASTaskAddIn Interface See Also

The ISASTaskAddIn type exposes the following members.

Methods

Name | Description
Connect | Connects, or loads, the add-in for use by the host application.
Disconnect | Disconnects, or unloads, the add-in from the host application.
Languages | Returns a list of culture codes that represent the languages/cultures that this add-in can support.

See Also

ISASTaskAddIn Interface
SAS.Shared.AddIns Namespace


Connect Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskAddIn..::.Connect Method
ISASTaskAddIn Interface See Also

Connects, or loads, the add-in for use by the host application.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function Connect ( _
    Consumer As ISASTaskConsumer _
) As Boolean
C#
bool Connect(
    ISASTaskConsumer Consumer
)

Parameters

Consumer
Type: SAS.Shared.AddIns..::.ISASTaskConsumer
The Consumer is a reference to an ISASTaskConsumer framework object, implemented by the host application. This object provides a set of routines for obtaining information from the application framework.

Return Value

Returns a boolean that tells the application that the connection succeeded or failed.

Remarks

If the add-in will require use of the services provided by ISASTaskConsumer, then the add-in implementation should store a reference to the Consumer parameter that is passed in with this call.

See Also

ISASTaskAddIn Interface
SAS.Shared.AddIns Namespace
SAS.Shared.AddIns..::.ISASTaskConsumer
ISASTaskAddIn..::.Disconnect()()()


Disconnect Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskAddIn..::.Disconnect Method
ISASTaskAddIn Interface See Also

Disconnects, or unloads, the add-in from the host application.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Sub Disconnect
C#
void Disconnect()

Remarks

This routine is called when the instance of the task is about to be unloaded from memory. This method is called when the task is deleted from the project collection or when the user closes the application.

See Also

ISASTaskAddIn Interface
SAS.Shared.AddIns Namespace
ISASTaskAddIn..::.Connect(ISASTaskConsumer)


Languages Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskAddIn..::.Languages Method
ISASTaskAddIn Interface See Also

Returns a list of culture codes that represent the languages/cultures that this add-in can support.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function Languages ( _
    <OutAttribute> ByRef Items As String() _
) As Integer
C#
int Languages(
    out string[] Items
)

Parameters

Items
Type: array< System..::.String >[]()[] %
Array of String objects, where each element in the array represents a supported culture.

Return Value

The number of supported cultures (length of Items array).

Remarks

The CultureInfo class specifies a unique name for each culture based on the RFC 1766 standard. The name is a combination of a two-letter lowercase culture code associated with a language and, if required, a two-letter uppercase subculture code associated with a country or region. The subculture code follows the culture code, separated by a dash (-). Examples include "ja-JP" for Japanese in Japan, "en-US" for U.S. English, or "de-DE" for German in Germany (as opposed to an alternate such as "de-AT" for German in Austria).

See Also

ISASTaskAddIn Interface
SAS.Shared.AddIns Namespace
ISASTaskAddIn..::.Language


ISASTaskAddIn Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskAddIn Properties
ISASTaskAddIn Interface See Also

The ISASTaskAddIn type exposes the following members.

Properties

Name | Description
AddInDescription | Returns the description of the add-in. This value is shown in the Add-In Manager and might be shown within the host application.
AddInName | Returns the name of the add-in. This value is shown in the Add-In Manager and might be shown within the host application.
Language | Current language (culture) that the add-in should operate in.
VisibleInManager | This property is not currently used by the add-in mechanism.

See Also

ISASTaskAddIn Interface
SAS.Shared.AddIns Namespace


AddInDescription Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskAddIn..::.AddInDescription Property
ISASTaskAddIn Interface See Also

Returns the description of the add-in. This value is shown in the Add-In Manager and might be shown within the host application.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property AddInDescription As String
C#
string AddInDescription { get; }

Field Value

Text string that describes the add-in.

See Also

ISASTaskAddIn Interface
SAS.Shared.AddIns Namespace


AddInName Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskAddIn..::.AddInName Property
ISASTaskAddIn Interface See Also

Returns the name of the add-in. This value is shown in the Add-In Manager and might be shown within the host application.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property AddInName As String
C#
string AddInName { get; }

Field Value

Text string for the add-in name.

See Also

ISASTaskAddIn Interface
SAS.Shared.AddIns Namespace


Language Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskAddIn..::.Language Property
ISASTaskAddIn Interface See Also

Current language (culture) that the add-in should operate in.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
WriteOnly Property Language As String
C#
string Language { set; }

Field Value

A culture string based on the RFC 1766 standard.

Remarks

See Also

ISASTaskAddIn Interface
SAS.Shared.AddIns Namespace
ISASTaskAddIn..::.Languages(array<String>[]()[]%)


VisibleInManager Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskAddIn..::.VisibleInManager Property
ISASTaskAddIn Interface See Also

This property is not currently used by the add-in mechanism.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property VisibleInManager As Boolean
C#
bool VisibleInManager { get; }

Field Value

Not currently used.

Remarks

Reserved for future use.

See Also

ISASTaskAddIn Interface
SAS.Shared.AddIns Namespace


ISASTaskConsumer Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer Interface
Members See Also

Implemented by: Host application (for example, SAS Enterprise Guide)

All host applications are required to support this interface.

These interfaces allow the task to get and set information about the environment in which it is executing.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISASTaskConsumer
C#
public interface ISASTaskConsumer

Remarks

The implementation of this interface by a host application is required, although not all properties and methods are required to be supported.

See Also

ISASTaskConsumer Members
SAS.Shared.AddIns Namespace


ISASTaskConsumer Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer Members
ISASTaskConsumer Interface Methods Properties See Also

The ISASTaskConsumer type exposes the following members.

Methods

Name | Description
DataName | Invokes the data selector dialog from the host application, allowing the end user to select a data source (for input) or location (for output).
ExecuteTask | The RunNow value indicates whether the SAS code should be run immediately or later.
FilerefData | Returns an ISASTaskData interface to the specified data source (host file system).
Libraries | Supplies a list of available libraries for the specified server.
LibrefData | Returns an ISASTaskData interface to the specified data source (LIBRARY.MEMBER).
MemberName | Generates a unique member name to use for output data.
Option | Retrieves an option value (usually a user preference) that is maintained in the host application.
ParameterizedCodeChanged | Not documented for customer use.
Servers | Supplies a list of available servers.
Supported | Checks whether the supplied option specified by OptionalName is supported by the host application.
ValidStateChanged | Not documented for customer use.
VerifyTaskClosing | Not documented for customer use.
Version | Version of the SAS server
Workspace | Returns an interface to the SAS workspace object.

Properties

Name | Description
ActiveData | Returns an ISASTaskData object for the active data
AssignedServer | Get or set the server associated with the instance of the add-in (where the SAS code will be run).
Display | This method is for use by SAS applications and is not intended for use by SAS customers.
Submit | Retrieve the ISASTaskSubmit interface from the host application.
Utilities | Retrieve the ISASTaskUtilities interface from the host application.

See Also

ISASTaskConsumer Interface
SAS.Shared.AddIns Namespace


ISASTaskConsumer Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer Methods
ISASTaskConsumer Interface See Also

The ISASTaskConsumer type exposes the following members.

Methods

Name | Description
DataName | Invokes the data selector dialog from the host application, allowing the end user to select a data source (for input) or location (for output).
ExecuteTask | The RunNow value indicates whether the SAS code should be run immediately or later.
FilerefData | Returns an ISASTaskData interface to the specified data source (host file system).
Libraries | Supplies a list of available libraries for the specified server.
LibrefData | Returns an ISASTaskData interface to the specified data source (LIBRARY.MEMBER).
MemberName | Generates a unique member name to use for output data.
Option | Retrieves an option value (usually a user preference) that is maintained in the host application.
ParameterizedCodeChanged | Not documented for customer use.
Servers | Supplies a list of available servers.
Supported | Checks whether the supplied option specified by OptionalName is supported by the host application.
ValidStateChanged | Not documented for customer use.
VerifyTaskClosing | Not documented for customer use.
Version | Version of the SAS server
Workspace | Returns an interface to the SAS workspace object.

See Also

ISASTaskConsumer Interface
SAS.Shared.AddIns Namespace


DataName Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer..::.DataName Method
ISASTaskConsumer Interface See Also

Invokes the data selector dialog from the host application, allowing the end user to select a data source (for input) or location (for output).

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function DataName ( _
    Owner As IWin32Window, _
    Cookie As String, _
    Member As String, _
    Output As Boolean _
) As ISASTaskDataName
C#
ISASTaskDataName DataName(
    IWin32Window Owner,
    string Cookie,
    string Member,
    bool Output
)

Parameters

Owner
Type: System.Windows.Forms..::.IWin32Window
The add-in form that owns the dialog when it displays.
Cookie
Type: System..::.String
Not documented for customer use.
Member
Type: System..::.String
A library.member or library name that seeds the starting location for the file dialog.
Output
Type: System..::.Boolean
Whether the dialog is to be used in Save (true) or Open (false) mode.

Return Value

An ISASTaskDataName interface to the selected data source name. null if the dialog is cancelled.

See Also

ISASTaskConsumer Interface
SAS.Shared.AddIns Namespace


ExecuteTask Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer..::.ExecuteTask Method
ISASTaskConsumer Interface See Also

The RunNow value indicates whether the SAS code should be run immediately or later.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Sub ExecuteTask ( _
    RunNow As Boolean _
)
C#
void ExecuteTask(
    bool RunNow
)

Parameters

RunNow
Type: System..::.Boolean
Whether the SAS code should be run immediately.

Remarks

The method provides a way for the task to tell the application that it is done processing. The method is useful when the Show method returns a RunPinned value.

See Also

ISASTaskConsumer Interface
SAS.Shared.AddIns Namespace


FilerefData Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer..::.FilerefData Method
ISASTaskConsumer Interface See Also

Returns an ISASTaskData interface to the specified data source (host file system).

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function FilerefData ( _
    Server As String, _
    Source As String _
) As ISASTaskData
C#
ISASTaskData FilerefData(
    string Server,
    string Source
)

Parameters

Server
Type: System..::.String
The name of the logical SAS server that hosts the data.
Source
Type: System..::.String
The file path of the data on the server's host file system

Return Value

Not currently implemented

Remarks

This property is not currently implemented in SAS Enterprise Guide. Reserved for future use.

See Also

ISASTaskConsumer Interface
SAS.Shared.AddIns Namespace


Libraries Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer..::.Libraries Method
ISASTaskConsumer Interface See Also

Supplies a list of available libraries for the specified server.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function Libraries ( _
    Server As String, _
    <OutAttribute> ByRef Items As String() _
) As Integer
C#
int Libraries(
    string Server,
    out string[] Items
)

Parameters

Server
Type: System..::.String
The server is the logical name of a SAS server.
Items
Type: array< System..::.String >[]()[] %
The Items parameter receives an array of SAS library names associated with the SAS Server.

Return Value

Number of libraries

See Also

ISASTaskConsumer Interface
SAS.Shared.AddIns Namespace


LibrefData Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer..::.LibrefData Method
ISASTaskConsumer Interface See Also

Returns an ISASTaskData interface to the specified data source (LIBRARY.MEMBER).

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function LibrefData ( _
    Server As String, _
    Library As String, _
    Member As String _
) As ISASTaskData
C#
ISASTaskData LibrefData(
    string Server,
    string Library,
    string Member
)

Parameters

Server
Type: System..::.String
The name of the logical SAS server that hosts the data.
Library
Type: System..::.String
The SAS library where the data resides.
Member
Type: System..::.String
The member name of the data within the library.

Return Value

An ISASTaskData reference to the data source that was requested.

See Also

ISASTaskConsumer Interface
SAS.Shared.AddIns Namespace


MemberName Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer..::.MemberName Method
ISASTaskConsumer Interface See Also

Generates a unique member name to use for output data.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function MemberName ( _
    Server As String, _
    Library As String, _
    Root As String _
) As String
C#
string MemberName(
    string Server,
    string Library,
    string Root
)

Parameters

Server
Type: System..::.String
Server where the data will be stored.
Library
Type: System..::.String
Library on the server where the data will be stored.
Root
Type: System..::.String
A prefix to use for the member name.

Return Value

A unique member name

See Also

ISASTaskConsumer Interface
SAS.Shared.AddIns Namespace


Option Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer..::.Option Method
ISASTaskConsumer Interface See Also

Retrieves an option value (usually a user preference) that is maintained in the host application.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function Option ( _
    Option As EnvironmentOption _
) As Object
C#
Object Option(
    EnvironmentOption Option
)

Parameters

Option
Type: SAS.Shared.AddIns..::.EnvironmentOption
The Option parameter represents one of the various environment values. Values returned can be boolean, String, or Int32 types. See EnvironmentOption for information about how the values are represented.

Return Value

Object that represents the option value

See Also

ISASTaskConsumer Interface
SAS.Shared.AddIns Namespace


ParameterizedCodeChanged Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer..::.ParameterizedCodeChanged Method
ISASTaskConsumer Interface See Also

Not documented for customer use.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Sub ParameterizedCodeChanged
C#
void ParameterizedCodeChanged()

See Also

ISASTaskConsumer Interface
SAS.Shared.AddIns Namespace


Servers Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer..::.Servers Method
ISASTaskConsumer Interface See Also

Supplies a list of available servers.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function Servers ( _
    <OutAttribute> ByRef Items As String() _
) As Integer
C#
int Servers(
    out string[] Items
)

Parameters

Items
Type: array< System..::.String >[]()[] %
The Items parameter receives an array of SAS server names available for code submission.

Return Value

Number of servers

See Also

ISASTaskConsumer Interface
SAS.Shared.AddIns Namespace


Supported Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer..::.Supported Method
ISASTaskConsumer Interface See Also

Checks whether the supplied option specified by OptionalName is supported by the host application.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function Supported ( _
    Name As OptionalName _
) As Boolean
C#
bool Supported(
    OptionalName Name
)

Parameters

Name
Type: SAS.Shared.AddIns..::.OptionalName
Name of the option

Return Value

true if supported, else false

See Also

ISASTaskConsumer Interface
SAS.Shared.AddIns Namespace


ValidStateChanged Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer..::.ValidStateChanged Method
ISASTaskConsumer Interface See Also

Not documented for customer use.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Sub ValidStateChanged ( _
    valid As Boolean _
)
C#
void ValidStateChanged(
    bool valid
)

Parameters

valid
Type: System..::.Boolean
Not documented for customer use.

See Also

ISASTaskConsumer Interface
SAS.Shared.AddIns Namespace


VerifyTaskClosing Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer..::.VerifyTaskClosing Method
ISASTaskConsumer Interface See Also

Not documented for customer use.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function VerifyTaskClosing ( _
    Owner As IWin32Window _
) As Boolean
C#
bool VerifyTaskClosing(
    IWin32Window Owner
)

Parameters

Owner
Type: System.Windows.Forms..::.IWin32Window
Not documented for customer use.

Return Value

Not documented for customer use.

See Also

ISASTaskConsumer Interface
SAS.Shared.AddIns Namespace


Version Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer..::.Version Method
ISASTaskConsumer Interface See Also

Version of the SAS server

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function Version ( _
    Server As String _
) As String
C#
string Version(
    string Server
)

Parameters

Server
Type: System..::.String
Name of the SAS server

Return Value

A string with the server version

Remarks

Here is an alternative way to get the server version directly from the SAS workspace.
Copy Code
            SAS.Workspace ws = null;
            ws = consumer.Workspace(currentServer) as SAS.Workspace;
            SAS.IHostSystem ihs = ws.Utilities.HostSystem;
            Array softwareInfo, hardwareInfo;
            ihs.GetInfo(out softwareInfo, out hardwareInfo);
            string sasVersion=(string) softwareInfo.GetValue((int)SAS.HostSystemSoftwareInfoIndex.HostSystemSoftwareInfoIndexSASVersion);

See Also

ISASTaskConsumer Interface
SAS.Shared.AddIns Namespace


Workspace Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer..::.Workspace Method
ISASTaskConsumer Interface See Also

Returns an interface to the SAS workspace object.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function Workspace ( _
    Server As String _
) As Object
C#
Object Workspace(
    string Server
)

Parameters

Server
Type: System..::.String
The server is the logical name of a SAS server.

Return Value

The Workspace method returns the SAS® Workspace (IWorkspace) object. This object provides access to the SAS® Integration Technologies core set of interfaces.

See Also

ISASTaskConsumer Interface
SAS.Shared.AddIns Namespace


ISASTaskConsumer Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer Properties
ISASTaskConsumer Interface See Also

The ISASTaskConsumer type exposes the following members.

Properties

Name | Description
ActiveData | Returns an ISASTaskData object for the active data
AssignedServer | Get or set the server associated with the instance of the add-in (where the SAS code will be run).
Display | This method is for use by SAS applications and is not intended for use by SAS customers.
Submit | Retrieve the ISASTaskSubmit interface from the host application.
Utilities | Retrieve the ISASTaskUtilities interface from the host application.

See Also

ISASTaskConsumer Interface
SAS.Shared.AddIns Namespace


ActiveData Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer..::.ActiveData Property
ISASTaskConsumer Interface See Also

Returns an ISASTaskData object for the active data

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ActiveData As ISASTaskData
C#
ISASTaskData ActiveData { get; }

Remarks

The host application is required to implement this.

See Also

ISASTaskConsumer Interface
SAS.Shared.AddIns Namespace


AssignedServer Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer..::.AssignedServer Property
ISASTaskConsumer Interface See Also

Get or set the server associated with the instance of the add-in (where the SAS code will be run).

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Property AssignedServer As String
C#
string AssignedServer { get; set; }

Remarks

The server is the logical name of a SAS server. By default the SAS code is submitted to the same server where the active data resides. This property allows the add-in to choose were the SAS code will be submitted, which is especially important in cases where SAS code does not rely on an input data source.

See Also

ISASTaskConsumer Interface
SAS.Shared.AddIns Namespace


Display Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer..::.Display Property
ISASTaskConsumer Interface See Also

This method is for use by SAS applications and is not intended for use by SAS customers.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Display As ISASTaskDisplay
C#
ISASTaskDisplay Display { get; }

See Also

ISASTaskConsumer Interface
SAS.Shared.AddIns Namespace


Submit Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer..::.Submit Property
ISASTaskConsumer Interface See Also

Retrieve the ISASTaskSubmit interface from the host application.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Submit As ISASTaskSubmit
C#
ISASTaskSubmit Submit { get; }

See Also

ISASTaskConsumer Interface
SAS.Shared.AddIns Namespace


Utilities Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer..::.Utilities Property
ISASTaskConsumer Interface See Also

Retrieve the ISASTaskUtilities interface from the host application.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Utilities As ISASTaskUtilities
C#
ISASTaskUtilities Utilities { get; }

See Also

ISASTaskConsumer Interface
SAS.Shared.AddIns Namespace


ISASTaskConsumer2 Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer2 Interface
Members See Also

Implemented by: Host application (for example, SAS Enterprise Guide)

Support for this extended interface provides more advanced features to the add-ins. This interface is an extension of ISASTaskConsumer.

These interfaces allow the task to get and set information about the environment in which it is executing as well as provide some additional advanced functionality.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISASTaskConsumer2 _
    Implements ISASTaskConsumer
C#
public interface ISASTaskConsumer2 : ISASTaskConsumer

Remarks

The implementation of this interface by a host application is optional. Host applications must implement ISASTaskConsumer.

See Also

ISASTaskConsumer2 Members
SAS.Shared.AddIns Namespace


ISASTaskConsumer2 Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer2 Members
ISASTaskConsumer2 Interface Methods Properties See Also

The ISASTaskConsumer2 type exposes the following members.

Methods

Name | Description
AddInputData | Adds a new ISASTaskData object to the InputData array. The Library and Member must exist on the AssignedServer to successfully add to the InputData array. The task is responsible for updating any views or models which use the input data.
ClearInputData | Removes all ISASTaskData objects in the InputData array. The task is responsible for updating any views or models which use the input data.
DataName | Invokes the data selector dialog from the host application, allowing the end user to select a data source (for input) or location (for output). (Inherited from ISASTaskConsumer.)
ExecuteTask | Overloaded.
FilerefData | Returns an ISASTaskData interface to the specified data source (host file system). (Inherited from ISASTaskConsumer.)
GetWebServiceProxy | Allows the task to get an instance of the desired Web Service proxy class from the application.
Libraries | Overloaded.
LibrefData | Returns an ISASTaskData interface to the specified data source (LIBRARY.MEMBER). (Inherited from ISASTaskConsumer.)
MemberName | Generates a unique member name to use for output data. (Inherited from ISASTaskConsumer.)
Metadata | An IOMI interface for the Open Metadata Interface
Option | Retrieves an option value (usually a user preference) that is maintained in the host application. (Inherited from ISASTaskConsumer.)
ParameterizedCodeChanged | Not documented for customer use. (Inherited from ISASTaskConsumer.)
RemoveInputData | Removes an ISASTaskData object in the InputData array. The task is responsible for updating any views or models which use the input data.
Servers | Supplies a list of available servers. (Inherited from ISASTaskConsumer.)
ShowDataSelector | Invokes the data selector dialog from the host application, allowing the end user to select a data source (for input) or location (for output).
ShowInputDataSelector | Invokes the data selector dialog from the host application, allowing the end user to select a data source (for input) or location (for output).
ShowOutputDataSelector | Invokes the data selector dialog from the host application, allowing the end user to select a data source (for input) or location (for output).
Supported | Checks whether the supplied option specified by OptionalName is supported by the host application. (Inherited from ISASTaskConsumer.)
ValidStateChanged | Not documented for customer use. (Inherited from ISASTaskConsumer.)
VerifyTaskClosing | Not documented for customer use. (Inherited from ISASTaskConsumer.)
Version | Version of the SAS server (Inherited from ISASTaskConsumer.)
Workspace | Returns an interface to the SAS workspace object. (Inherited from ISASTaskConsumer.)

Properties

Name | Description
ActiveData | Returns an ISASTaskData object for the active data (Inherited from ISASTaskConsumer.)
AssignedServer | Get or set the server associated with the instance of the add-in (where the SAS code will be run). (Inherited from ISASTaskConsumer.)
Display | This method is for use by SAS applications and is not intended for use by SAS customers. (Inherited from ISASTaskConsumer.)
ForecastProjectName | The name of a SAS Forecast Studio project that the application wants the task to use. This property is not documented or supported for SAS customer use.
InputData | Returns an array of ISASTaskData objects; one for each inut data source.
Parameters | Get a list of ISASTaskParameter objects used by the task in its generated SAS program code. If the application does not have any parameters then it should return null or and empty array.
Submit | Retrieve the ISASTaskSubmit interface from the host application. (Inherited from ISASTaskConsumer.)
Utilities | Retrieve the ISASTaskUtilities interface from the host application. (Inherited from ISASTaskConsumer.)

See Also

ISASTaskConsumer2 Interface
SAS.Shared.AddIns Namespace


ISASTaskConsumer2 Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer2 Methods
ISASTaskConsumer2 Interface See Also

The ISASTaskConsumer2 type exposes the following members.

Methods

Name | Description
AddInputData | Adds a new ISASTaskData object to the InputData array. The Library and Member must exist on the AssignedServer to successfully add to the InputData array. The task is responsible for updating any views or models which use the input data.
ClearInputData | Removes all ISASTaskData objects in the InputData array. The task is responsible for updating any views or models which use the input data.
DataName | Invokes the data selector dialog from the host application, allowing the end user to select a data source (for input) or location (for output). (Inherited from ISASTaskConsumer.)
ExecuteTask | Overloaded.
FilerefData | Returns an ISASTaskData interface to the specified data source (host file system). (Inherited from ISASTaskConsumer.)
GetWebServiceProxy | Allows the task to get an instance of the desired Web Service proxy class from the application.
Libraries | Overloaded.
LibrefData | Returns an ISASTaskData interface to the specified data source (LIBRARY.MEMBER). (Inherited from ISASTaskConsumer.)
MemberName | Generates a unique member name to use for output data. (Inherited from ISASTaskConsumer.)
Metadata | An IOMI interface for the Open Metadata Interface
Option | Retrieves an option value (usually a user preference) that is maintained in the host application. (Inherited from ISASTaskConsumer.)
ParameterizedCodeChanged | Not documented for customer use. (Inherited from ISASTaskConsumer.)
RemoveInputData | Removes an ISASTaskData object in the InputData array. The task is responsible for updating any views or models which use the input data.
Servers | Supplies a list of available servers. (Inherited from ISASTaskConsumer.)
ShowDataSelector | Invokes the data selector dialog from the host application, allowing the end user to select a data source (for input) or location (for output).
ShowInputDataSelector | Invokes the data selector dialog from the host application, allowing the end user to select a data source (for input) or location (for output).
ShowOutputDataSelector | Invokes the data selector dialog from the host application, allowing the end user to select a data source (for input) or location (for output).
Supported | Checks whether the supplied option specified by OptionalName is supported by the host application. (Inherited from ISASTaskConsumer.)
ValidStateChanged | Not documented for customer use. (Inherited from ISASTaskConsumer.)
VerifyTaskClosing | Not documented for customer use. (Inherited from ISASTaskConsumer.)
Version | Version of the SAS server (Inherited from ISASTaskConsumer.)
Workspace | Returns an interface to the SAS workspace object. (Inherited from ISASTaskConsumer.)

See Also

ISASTaskConsumer2 Interface
SAS.Shared.AddIns Namespace


AddInputData Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer2..::.AddInputData Method
ISASTaskConsumer2 Interface See Also

Adds a new ISASTaskData object to the InputData array. The Library and Member must exist on the AssignedServer to successfully add to the InputData array. The task is responsible for updating any views or models which use the input data.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function AddInputData ( _
    Data As ISASTaskData _
) As Boolean
C#
bool AddInputData(
    ISASTaskData Data
)

Parameters

Data
Type: SAS.Shared.AddIns..::.ISASTaskData
An ISASTaskData reference to the data source.

Return Value

True if successfully added to InputData array otherwise false because it doesn't exist or the data is already present in the list

See Also

ISASTaskConsumer2 Interface
SAS.Shared.AddIns Namespace


ClearInputData Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer2..::.ClearInputData Method
ISASTaskConsumer2 Interface See Also

Removes all ISASTaskData objects in the InputData array. The task is responsible for updating any views or models which use the input data.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function ClearInputData As Boolean
C#
bool ClearInputData()

Return Value

True if successfully removed all objects from InputData array otherwise false

See Also

ISASTaskConsumer2 Interface
SAS.Shared.AddIns Namespace


ExecuteTask Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer2..::.ExecuteTask Method
ISASTaskConsumer2 Interface See Also

Overload List

Name | Description
ExecuteTask(Boolean) | The RunNow value indicates whether the SAS code should be run immediately or later. (Inherited from ISASTaskConsumer.)
ExecuteTask(PinnedResult) | The Flag value indicates an action for the application

See Also

ISASTaskConsumer2 Interface
ISASTaskConsumer2 Members
SAS.Shared.AddIns Namespace


ExecuteTask Method (PinnedResult)

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer2..::.ExecuteTask Method (PinnedResult)
ISASTaskConsumer2 Interface See Also

The Flag value indicates an action for the application

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Sub ExecuteTask ( _
    Flag As PinnedResult _
)
C#
void ExecuteTask(
    PinnedResult Flag
)

Parameters

Flag
Type: SAS.Shared.AddIns..::.PinnedResult
Tells the application how to execute this task, related to the task window.

Remarks

The method provides a way for the task to tell the application that it needs to peform some processing. The method is useful when the Show method returns a RunPinned value.

See Also

ISASTaskConsumer2 Interface
ExecuteTask Overload
SAS.Shared.AddIns Namespace


GetWebServiceProxy Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer2..::.GetWebServiceProxy Method
ISASTaskConsumer2 Interface See Also

Allows the task to get an instance of the desired Web Service proxy class from the application.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function GetWebServiceProxy ( _
    proxyClassName As String, _
    <OutAttribute> ByRef sessionKey As String _
) As Object
C#
Object GetWebServiceProxy(
    string proxyClassName,
    out string sessionKey
)

Parameters

proxyClassName
Type: System..::.String
The name of the Web Service proxy class requested
sessionKey
Type: System..::.String %
If required for the particular Web Service proxy, a session key for the task to pass to Web Service methods

Return Value

A Web Service proxy of the desired class, or null if the application cannot create the requested Web Service proxy class. This is a type System.Web.Services.Protocols.WebClientProtocol

See Also

ISASTaskConsumer2 Interface
SAS.Shared.AddIns Namespace


Libraries Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer2..::.Libraries Method
ISASTaskConsumer2 Interface See Also

Overload List

Name | Description
Libraries(String, array<String>[]()[]%) | Supplies a list of available libraries for the specified server. (Inherited from ISASTaskConsumer.)
Libraries(String, LibraryType, array<String>[]()[]%) | Supplies a list of available libraries for the specified server.

See Also

ISASTaskConsumer2 Interface
ISASTaskConsumer2 Members
SAS.Shared.AddIns Namespace


Libraries Method (String, LibraryType, String[])

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer2..::.Libraries Method (String, LibraryType, array<String>[]()[]%)
ISASTaskConsumer2 Interface See Also

Supplies a list of available libraries for the specified server.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function Libraries ( _
    Server As String, _
    Type As LibraryType, _
    <OutAttribute> ByRef Items As String() _
) As Integer
C#
int Libraries(
    string Server,
    LibraryType Type,
    out string[] Items
)

Parameters

Server
Type: System..::.String
The server is the logical name of a SAS server.
Type
Type: SAS.Shared.AddIns..::.LibraryType
Which type of libraries to include in the list.
Items
Type: array< System..::.String >[]()[] %
The Items parameter receives an array of SAS library names associated with the SAS server.

Return Value

Count of the number of library names returned.

See Also

ISASTaskConsumer2 Interface
Libraries Overload
SAS.Shared.AddIns Namespace


Metadata Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer2..::.Metadata Method
ISASTaskConsumer2 Interface See Also

An IOMI interface for the Open Metadata Interface

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function Metadata ( _
    ByRef Reposid As String _
) As Object
C#
Object Metadata(
    ref string Reposid
)

Parameters

Reposid
Type: System..::.String %
The id of the repository.

Return Value

The Metadata method returns the SAS® Open Metadata Interface (IOMI) object. This object provides access to the SAS® Open Metadata functionality.

See Also

ISASTaskConsumer2 Interface
SAS.Shared.AddIns Namespace


RemoveInputData Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer2..::.RemoveInputData Method
ISASTaskConsumer2 Interface See Also

Removes an ISASTaskData object in the InputData array. The task is responsible for updating any views or models which use the input data.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function RemoveInputData ( _
    Data As ISASTaskData _
) As Boolean
C#
bool RemoveInputData(
    ISASTaskData Data
)

Parameters

Data
Type: SAS.Shared.AddIns..::.ISASTaskData
An ISASTaskData reference to the data source.

Return Value

True if successfully removed from InputData array otherwise false because it doesn't exist or the data is already present in the list

See Also

ISASTaskConsumer2 Interface
SAS.Shared.AddIns Namespace


ShowDataSelector Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer2..::.ShowDataSelector Method
ISASTaskConsumer2 Interface See Also

Invokes the data selector dialog from the host application, allowing the end user to select a data source (for input) or location (for output).

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function ShowDataSelector ( _
    Owner As IWin32Window, _
    SelectionMode As DataSelectionMode, _
    ServerAccess As ServerAccessMode, _
    Server As String, _
    Library As String, _
    Member As String, _
    ByRef Cookie As String _
) As ISASTaskDataName()
C#
ISASTaskDataName[] ShowDataSelector(
    IWin32Window Owner,
    DataSelectionMode SelectionMode,
    ServerAccessMode ServerAccess,
    string Server,
    string Library,
    string Member,
    ref string Cookie
)

Parameters

Owner
Type: System.Windows.Forms..::.IWin32Window
The window that owns the data selector dialog when it is displayed.
SelectionMode
Type: SAS.Shared.AddIns..::.DataSelectionMode
The mode in which the data selector will operate. If set to MultipleInput, the data selector will allow multiple input data sources to be selected at one time. If set to SingleInput, the data selector will only allow one input data source to be selected at a time. If set to Output, the data selector will allow you to specify a save location.
ServerAccess
Type: SAS.Shared.AddIns..::.ServerAccessMode
The server access mode. If set to AnyServer, allow the user to select or save data on any server. If set to OneServer, only allow the user to select or save data on the server specified by the Server parameter.
Server
Type: System..::.String
If ServerAccess is set to OneServer, this parameter specifies the only server which can be accessed. If ServerAccess is set to AnyServer, optionally specify this parameter to set the initial server location of the data selector.
Library
Type: System..::.String
Optionally specify this parameter to set the initial library location of the data selector.
Member
Type: System..::.String
Optionally specify this parameter to set the initially selected member in the data selector.
Cookie
Type: System..::.String %
A string representing the navigated location of the data selector. If specified, this parameter should take precendence over Server and Library in setting the initial location. The purpose of this parameter is to allow the user to specify the initial location of the data selector when the Server and Library parameters do not suffice. For example, if the consumer allows datasets to be selected from binders or from file locations on servers, this parameter would be needed to initialize the data selector to one of these locations.

Return Value

Returns an array of ISASTaskDataName which contains an ISASTaskDataName for each of the selected data sources. When the SelectionMode is set to SingleInput or Output, the returned array should only contain one item. If the user cancels the data selector, returns an array with no items in it.

See Also

ISASTaskConsumer2 Interface
SAS.Shared.AddIns Namespace


ShowInputDataSelector Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer2..::.ShowInputDataSelector Method
ISASTaskConsumer2 Interface See Also

Invokes the data selector dialog from the host application, allowing the end user to select a data source (for input) or location (for output).

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function ShowInputDataSelector ( _
    Owner As IWin32Window, _
    SelectionMode As DataSelectionMode, _
    ServerAccess As ServerAccessMode, _
    Server As String, _
    Library As String, _
    Member As String, _
    ByRef Cookie As String _
) As ISASTaskData()
C#
ISASTaskData[] ShowInputDataSelector(
    IWin32Window Owner,
    DataSelectionMode SelectionMode,
    ServerAccessMode ServerAccess,
    string Server,
    string Library,
    string Member,
    ref string Cookie
)

Parameters

Owner
Type: System.Windows.Forms..::.IWin32Window
The window that owns the data selector dialog when it is displayed.
SelectionMode
Type: SAS.Shared.AddIns..::.DataSelectionMode
The mode in which the data selector will operate. If set to MultipleInput, the data selector will allow multiple input data sources to be selected at one time. If set to SingleInput, the data selector will only allow one input data source to be selected at a time. If set to Output, the data selector will allow you to specify a save location.
ServerAccess
Type: SAS.Shared.AddIns..::.ServerAccessMode
The server access mode. If set to AnyServer, allow the user to select or save data on any server. If set to OneServer, only allow the user to select or save data on the server specified by the Server parameter.
Server
Type: System..::.String
If ServerAccess is set to OneServer, this parameter specifies the only server which can be accessed. If ServerAccess is set to AnyServer, optionally specify this parameter to set the initial server location of the data selector.
Library
Type: System..::.String
Optionally specify this parameter to set the initial library location of the data selector.
Member
Type: System..::.String
Optionally specify this parameter to set the initially selected member in the data selector.
Cookie
Type: System..::.String %
A string representing the navigated location of the data selector. If specified, this parameter should take precendence over Server and Library in setting the initial location. The purpose of this parameter is to allow the user to specify the initial location of the data selector when the Server and Library parameters do not suffice. For example, if the consumer allows datasets to be selected from binders or from file locations on servers, this parameter would be needed to initialize the data selector to one of these locations.

Return Value

Returns an array of ISASTaskData which contains an ISASTaskData for each of the selected data sources. If the user cancels the data selector or there is a catastrophic problem, then the method should return a null value. However, if the user has multiselected a list of items and only a subset is valid to return then only return the valid items and ignore the invalid items such is the case when the user has requested that all input needs to be available in a readonly data selection mode.

See Also

ISASTaskConsumer2 Interface
SAS.Shared.AddIns Namespace


ShowOutputDataSelector Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer2..::.ShowOutputDataSelector Method
ISASTaskConsumer2 Interface See Also

Invokes the data selector dialog from the host application, allowing the end user to select a data source (for input) or location (for output).

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function ShowOutputDataSelector ( _
    Owner As IWin32Window, _
    ServerAccess As ServerAccessMode, _
    Server As String, _
    Library As String, _
    Member As String, _
    ByRef Cookie As String _
) As ISASTaskDataName
C#
ISASTaskDataName ShowOutputDataSelector(
    IWin32Window Owner,
    ServerAccessMode ServerAccess,
    string Server,
    string Library,
    string Member,
    ref string Cookie
)

Parameters

Owner
Type: System.Windows.Forms..::.IWin32Window
The window that owns the data selector dialog when it is displayed.
ServerAccess
Type: SAS.Shared.AddIns..::.ServerAccessMode
The server access mode. If set to AnyServer, allow the user to select or save data on any server. If set to OneServer, only allow the user to select or save data on the server specified by the Server parameter.
Server
Type: System..::.String
If ServerAccess is set to OneServer, this parameter specifies the only server which can be accessed. If ServerAccess is set to AnyServer, optionally specify this parameter to set the initial server location of the data selector.
Library
Type: System..::.String
Optionally specify this parameter to set the initial library location of the data selector.
Member
Type: System..::.String
Optionally specify this parameter to set the initially selected member in the data selector.
Cookie
Type: System..::.String %
A string representing the navigated location of the data selector. If specified, this parameter should take precendence over Server and Library in setting the initial location. The purpose of this parameter is to allow the user to specify the initial location of the data selector when the Server and Library parameters do not suffice. For example, if the consumer allows datasets to be selected from binders or from file locations on servers, this parameter would be needed to initialize the data selector to one of these locations.

Return Value

Returns a ISASTaskDataName. If the user cancels the data selector or there is a catastrophic problem, then the method should return a null value.

See Also

ISASTaskConsumer2 Interface
SAS.Shared.AddIns Namespace


ISASTaskConsumer2 Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer2 Properties
ISASTaskConsumer2 Interface See Also

The ISASTaskConsumer2 type exposes the following members.

Properties

Name | Description
ActiveData | Returns an ISASTaskData object for the active data (Inherited from ISASTaskConsumer.)
AssignedServer | Get or set the server associated with the instance of the add-in (where the SAS code will be run). (Inherited from ISASTaskConsumer.)
Display | This method is for use by SAS applications and is not intended for use by SAS customers. (Inherited from ISASTaskConsumer.)
ForecastProjectName | The name of a SAS Forecast Studio project that the application wants the task to use. This property is not documented or supported for SAS customer use.
InputData | Returns an array of ISASTaskData objects; one for each inut data source.
Parameters | Get a list of ISASTaskParameter objects used by the task in its generated SAS program code. If the application does not have any parameters then it should return null or and empty array.
Submit | Retrieve the ISASTaskSubmit interface from the host application. (Inherited from ISASTaskConsumer.)
Utilities | Retrieve the ISASTaskUtilities interface from the host application. (Inherited from ISASTaskConsumer.)

See Also

ISASTaskConsumer2 Interface
SAS.Shared.AddIns Namespace


ForecastProjectName Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer2..::.ForecastProjectName Property
ISASTaskConsumer2 Interface See Also

The name of a SAS Forecast Studio project that the application wants the task to use. This property is not documented or supported for SAS customer use.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ForecastProjectName As String
C#
string ForecastProjectName { get; }

See Also

ISASTaskConsumer2 Interface
SAS.Shared.AddIns Namespace


InputData Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer2..::.InputData Property
ISASTaskConsumer2 Interface See Also

Returns an array of ISASTaskData objects; one for each inut data source.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property InputData As ISASTaskData()
C#
ISASTaskData[] InputData { get; }

Remarks

The host application is required to implement this in order to support ISASTaskConsumer2.

See Also

ISASTaskConsumer2 Interface
SAS.Shared.AddIns Namespace


Parameters Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer2..::.Parameters Property
ISASTaskConsumer2 Interface See Also

Get a list of ISASTaskParameter objects used by the task in its generated SAS program code. If the application does not have any parameters then it should return null or and empty array.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Parameters As ISASTaskParameter()
C#
ISASTaskParameter[] Parameters { get; }

Remarks

In SAS Enterprise Guide, these parameter definitions are supported in the Parameter (Macro Variable) Manager (on the Tools menu).

The host application is required to implement this in order to support ISASTaskConsumer2.

See Also

ISASTaskConsumer2 Interface
SAS.Shared.AddIns Namespace


ISASTaskConsumer3 Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer3 Interface
Members See Also

Implemented by: Host application (for example, SAS Enterprise Guide)

Support for this extended interface provides more advanced features to the add-ins. This interface is an extension of ISASTaskConsumer2.

These interfaces allow the task to get and set information about the environment in which it is executing as well as provide some additional advanced functionality.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISASTaskConsumer3 _
    Implements ISASTaskConsumer2, ISASTaskConsumer
C#
public interface ISASTaskConsumer3 : ISASTaskConsumer2,
    ISASTaskConsumer

Remarks

The implementation of this interface by a host application is optional. Host applications must implement ISASTaskConsumer.

See Also

ISASTaskConsumer3 Members
SAS.Shared.AddIns Namespace


ISASTaskConsumer3 Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer3 Members
ISASTaskConsumer3 Interface Methods Properties See Also

The ISASTaskConsumer3 type exposes the following members.

Methods

Name | Description
AddInputData
Adds a new ISASTaskData object to the InputData array. The Library and Member must exist on the AssignedServer to successfully add to the InputData array. The task is responsible for updating any views or models which use the input data.
(Inherited from ISASTaskConsumer2.)
ClearInputData
Removes all ISASTaskData objects in the InputData array. The task is responsible for updating any views or models which use the input data.
(Inherited from ISASTaskConsumer2.)
DataName
Invokes the data selector dialog from the host application, allowing the end user to select a data source (for input) or location (for output).
(Inherited from ISASTaskConsumer.)
ExecuteTask | Overloaded.
FilerefData
Returns an ISASTaskData interface to the specified data source (host file system).
(Inherited from ISASTaskConsumer.)
GetApplicationOptions
Gets the ISASApplicationOptions interface from the application. Use this interface to discover current preferences for ODS results and other settings.
GetProject
Gets the ISASProject interface from the application. This interface provides access to portions of the SAS Enterprise Guide project document.

Remarks

This is not supported for SAS Add-In for Microsoft Office. When used within that environment, the method returns null.
GetTaskOptions
Gets the ISASTaskOptions interface from the application. Use this interface to discover and change settings for ODS results and other options; these settings apply only to the current task.
GetTaskProperties
Gets the ISASTaskProperties interface from the application. Use this interface to discover values for general information about this instance of the current task. For example, you can find the last modified data/time or the user ID of the person who last modified this task.
GetThisProcessFlow
Gets the ISASProjectProcessFlow interface from the application. This interface provides a handle to the current process flow -- the process flow that contains this task.

Remarks

This is not supported for SAS Add-In for Microsoft Office. When used within that environment, the method returns null.
GetThisTask
Gets the ISASProjectTask interface from the application. This interface provides a handle to the current task within the project. With this interface, you can discover and manipulate information about the task and its associations with other elements within the project.
GetWebServiceProxy
Allows the task to get an instance of the desired Web Service proxy class from the application.
(Inherited from ISASTaskConsumer2.)
Libraries | Overloaded.
LibrefData
Returns an ISASTaskData interface to the specified data source (LIBRARY.MEMBER).
(Inherited from ISASTaskConsumer.)
MemberName
Generates a unique member name to use for output data.
(Inherited from ISASTaskConsumer.)
Metadata
An IOMI interface for the Open Metadata Interface
(Inherited from ISASTaskConsumer2.)
Option
Retrieves an option value (usually a user preference) that is maintained in the host application.
(Inherited from ISASTaskConsumer.)
ParameterizedCodeChanged
Not documented for customer use.
(Inherited from ISASTaskConsumer.)
RemoveInputData
Removes an ISASTaskData object in the InputData array. The task is responsible for updating any views or models which use the input data.
(Inherited from ISASTaskConsumer2.)
Servers
Supplies a list of available servers.
(Inherited from ISASTaskConsumer.)
ShowDataSelector
Invokes the data selector dialog from the host application, allowing the end user to select a data source (for input) or location (for output).
(Inherited from ISASTaskConsumer2.)
ShowEditInputDataDialog
Allows task to cause EditInputData dialog to appear, which allows a user to change the input data source and add a filter
ShowInputDataSelector
Invokes the data selector dialog from the host application, allowing the end user to select a data source (for input) or location (for output).
(Inherited from ISASTaskConsumer2.)
ShowOutputDataSelector
Invokes the data selector dialog from the host application, allowing the end user to select a data source (for input) or location (for output).
(Inherited from ISASTaskConsumer2.)
Supported
Checks whether the supplied option specified by OptionalName is supported by the host application.
(Inherited from ISASTaskConsumer.)
ValidStateChanged
Not documented for customer use.
(Inherited from ISASTaskConsumer.)
VerifyTaskClosing
Not documented for customer use.
(Inherited from ISASTaskConsumer.)
Version
Version of the SAS server
(Inherited from ISASTaskConsumer.)
Workspace
Returns an interface to the SAS workspace object.
(Inherited from ISASTaskConsumer.)

Properties

Name | Description
ActiveData | Returns an ISASTaskData object for the active data (Inherited from ISASTaskConsumer.)
AssignedServer | Get or set the server associated with the instance of the add-in (where the SAS code will be run). (Inherited from ISASTaskConsumer.)
Display | This method is for use by SAS applications and is not intended for use by SAS customers. (Inherited from ISASTaskConsumer.)
ForecastProjectName | The name of a SAS Forecast Studio project that the application wants the task to use. This property is not documented or supported for SAS customer use. (Inherited from ISASTaskConsumer2.)
InputData | Returns an array of ISASTaskData objects; one for each inut data source. (Inherited from ISASTaskConsumer2.)
InputResourcesDna | Collection of DNA strings that represent the input resources.
Parameters | Get a list of ISASTaskParameter objects used by the task in its generated SAS program code. If the application does not have any parameters then it should return null or and empty array. (Inherited from ISASTaskConsumer2.)
Submit | Retrieve the ISASTaskSubmit interface from the host application. (Inherited from ISASTaskConsumer.)
Utilities | Retrieve the ISASTaskUtilities interface from the host application. (Inherited from ISASTaskConsumer.)

See Also

ISASTaskConsumer3 Interface
SAS.Shared.AddIns Namespace


ISASTaskConsumer3 Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer3 Methods
ISASTaskConsumer3 Interface See Also

The ISASTaskConsumer3 type exposes the following members.

Methods

Name | Description
AddInputData
Adds a new ISASTaskData object to the InputData array. The Library and Member must exist on the AssignedServer to successfully add to the InputData array. The task is responsible for updating any views or models which use the input data.
(Inherited from ISASTaskConsumer2.)
ClearInputData
Removes all ISASTaskData objects in the InputData array. The task is responsible for updating any views or models which use the input data.
(Inherited from ISASTaskConsumer2.)
DataName
Invokes the data selector dialog from the host application, allowing the end user to select a data source (for input) or location (for output).
(Inherited from ISASTaskConsumer.)
ExecuteTask | Overloaded.
FilerefData
Returns an ISASTaskData interface to the specified data source (host file system).
(Inherited from ISASTaskConsumer.)
GetApplicationOptions
Gets the ISASApplicationOptions interface from the application. Use this interface to discover current preferences for ODS results and other settings.
GetProject
Gets the ISASProject interface from the application. This interface provides access to portions of the SAS Enterprise Guide project document.

Remarks

This is not supported for SAS Add-In for Microsoft Office. When used within that environment, the method returns null.
GetTaskOptions
Gets the ISASTaskOptions interface from the application. Use this interface to discover and change settings for ODS results and other options; these settings apply only to the current task.
GetTaskProperties
Gets the ISASTaskProperties interface from the application. Use this interface to discover values for general information about this instance of the current task. For example, you can find the last modified data/time or the user ID of the person who last modified this task.
GetThisProcessFlow
Gets the ISASProjectProcessFlow interface from the application. This interface provides a handle to the current process flow -- the process flow that contains this task.

Remarks

This is not supported for SAS Add-In for Microsoft Office. When used within that environment, the method returns null.
GetThisTask
Gets the ISASProjectTask interface from the application. This interface provides a handle to the current task within the project. With this interface, you can discover and manipulate information about the task and its associations with other elements within the project.
GetWebServiceProxy
Allows the task to get an instance of the desired Web Service proxy class from the application.
(Inherited from ISASTaskConsumer2.)
Libraries | Overloaded.
LibrefData
Returns an ISASTaskData interface to the specified data source (LIBRARY.MEMBER).
(Inherited from ISASTaskConsumer.)
MemberName
Generates a unique member name to use for output data.
(Inherited from ISASTaskConsumer.)
Metadata
An IOMI interface for the Open Metadata Interface
(Inherited from ISASTaskConsumer2.)
Option
Retrieves an option value (usually a user preference) that is maintained in the host application.
(Inherited from ISASTaskConsumer.)
ParameterizedCodeChanged
Not documented for customer use.
(Inherited from ISASTaskConsumer.)
RemoveInputData
Removes an ISASTaskData object in the InputData array. The task is responsible for updating any views or models which use the input data.
(Inherited from ISASTaskConsumer2.)
Servers
Supplies a list of available servers.
(Inherited from ISASTaskConsumer.)
ShowDataSelector
Invokes the data selector dialog from the host application, allowing the end user to select a data source (for input) or location (for output).
(Inherited from ISASTaskConsumer2.)
ShowEditInputDataDialog
Allows task to cause EditInputData dialog to appear, which allows a user to change the input data source and add a filter
ShowInputDataSelector
Invokes the data selector dialog from the host application, allowing the end user to select a data source (for input) or location (for output).
(Inherited from ISASTaskConsumer2.)
ShowOutputDataSelector
Invokes the data selector dialog from the host application, allowing the end user to select a data source (for input) or location (for output).
(Inherited from ISASTaskConsumer2.)
Supported
Checks whether the supplied option specified by OptionalName is supported by the host application.
(Inherited from ISASTaskConsumer.)
ValidStateChanged
Not documented for customer use.
(Inherited from ISASTaskConsumer.)
VerifyTaskClosing
Not documented for customer use.
(Inherited from ISASTaskConsumer.)
Version
Version of the SAS server
(Inherited from ISASTaskConsumer.)
Workspace
Returns an interface to the SAS workspace object.
(Inherited from ISASTaskConsumer.)

See Also

ISASTaskConsumer3 Interface
SAS.Shared.AddIns Namespace


ExecuteTask Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer3..::.ExecuteTask Method
ISASTaskConsumer3 Interface See Also

Overload List

Name | Description
ExecuteTask(Boolean) | The RunNow value indicates whether the SAS code should be run immediately or later. (Inherited from ISASTaskConsumer.)
ExecuteTask(PinnedResult) | The Flag value indicates an action for the application (Inherited from ISASTaskConsumer2.)

See Also

ISASTaskConsumer3 Interface
ISASTaskConsumer3 Members
SAS.Shared.AddIns Namespace


GetApplicationOptions Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer3..::.GetApplicationOptions Method
ISASTaskConsumer3 Interface See Also

Gets the ISASApplicationOptions interface from the application. Use this interface to discover current preferences for ODS results and other settings.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function GetApplicationOptions As ISASApplicationOptions
C#
ISASApplicationOptions GetApplicationOptions()

Return Value

an ISASApplicationOptions interface

See Also

ISASTaskConsumer3 Interface
SAS.Shared.AddIns Namespace


GetProject Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer3..::.GetProject Method
ISASTaskConsumer3 Interface See Also

Gets the ISASProject interface from the application. This interface provides access to portions of the SAS Enterprise Guide project document.

Remarks

This is not supported for SAS Add-In for Microsoft Office. When used within that environment, the method returns null.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function GetProject As ISASProject
C#
ISASProject GetProject()

Return Value

A handle to the project interface.

See Also

ISASTaskConsumer3 Interface
SAS.Shared.AddIns Namespace


GetTaskOptions Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer3..::.GetTaskOptions Method
ISASTaskConsumer3 Interface See Also

Gets the ISASTaskOptions interface from the application. Use this interface to discover and change settings for ODS results and other options; these settings apply only to the current task.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function GetTaskOptions As ISASTaskOptions
C#
ISASTaskOptions GetTaskOptions()

Return Value

the ISASTaskOptions interface for the current task

See Also

ISASTaskConsumer3 Interface
SAS.Shared.AddIns Namespace


GetTaskProperties Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer3..::.GetTaskProperties Method
ISASTaskConsumer3 Interface See Also

Gets the ISASTaskProperties interface from the application. Use this interface to discover values for general information about this instance of the current task. For example, you can find the last modified data/time or the user ID of the person who last modified this task.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function GetTaskProperties As ISASTaskProperties
C#
ISASTaskProperties GetTaskProperties()

Return Value

the ISASTaskProperties for the current task

See Also

ISASTaskConsumer3 Interface
SAS.Shared.AddIns Namespace


GetThisProcessFlow Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer3..::.GetThisProcessFlow Method
ISASTaskConsumer3 Interface See Also

Gets the ISASProjectProcessFlow interface from the application. This interface provides a handle to the current process flow -- the process flow that contains this task.

Remarks

This is not supported for SAS Add-In for Microsoft Office. When used within that environment, the method returns null.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function GetThisProcessFlow As ISASProjectProcessFlow
C#
ISASProjectProcessFlow GetThisProcessFlow()

Return Value

A handle to the process flow within the project.

See Also

ISASTaskConsumer3 Interface
SAS.Shared.AddIns Namespace


GetThisTask Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer3..::.GetThisTask Method
ISASTaskConsumer3 Interface See Also

Gets the ISASProjectTask interface from the application. This interface provides a handle to the current task within the project. With this interface, you can discover and manipulate information about the task and its associations with other elements within the project.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function GetThisTask As ISASProjectTask
C#
ISASProjectTask GetThisTask()

Return Value

A handle to the task within the project.

See Also

ISASTaskConsumer3 Interface
SAS.Shared.AddIns Namespace


Libraries Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer3..::.Libraries Method
ISASTaskConsumer3 Interface See Also

Overload List

Name | Description
Libraries(String, array<String>[]()[]%) | Supplies a list of available libraries for the specified server. (Inherited from ISASTaskConsumer.)
Libraries(String, LibraryType, array<String>[]()[]%) | Supplies a list of available libraries for the specified server. (Inherited from ISASTaskConsumer2.)

See Also

ISASTaskConsumer3 Interface
ISASTaskConsumer3 Members
SAS.Shared.AddIns Namespace


ShowEditInputDataDialog Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer3..::.ShowEditInputDataDialog Method
ISASTaskConsumer3 Interface See Also

Allows task to cause EditInputData dialog to appear, which allows a user to change the input data source and add a filter

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function ShowEditInputDataDialog ( _
    owner As IWin32Window, _
    serverAccess As ServerAccessMode, _
    server As String, _
    library As String, _
    member As String, _
    useLabelsForVarNames As Boolean, _
    ByRef filterXml As String, _
    ByRef cookie As String, _
    <OutAttribute> ByRef data As ISASTaskData2, _
    <OutAttribute> ByRef filter As String _
) As DialogResult
C#
DialogResult ShowEditInputDataDialog(
    IWin32Window owner,
    ServerAccessMode serverAccess,
    string server,
    string library,
    string member,
    bool useLabelsForVarNames,
    ref string filterXml,
    ref string cookie,
    out ISASTaskData2 data,
    out string filter
)

Parameters

owner
Type: System.Windows.Forms..::.IWin32Window
The window that owns the data selector dialog when it is displayed.
serverAccess
Type: SAS.Shared.AddIns..::.ServerAccessMode
The server access mode. If set to AnyServer, allow the user to select or save data on any server. If set to OneServer, only allow the user to select or save data on the server specified by the Server parameter.
server
Type: System..::.String
If ServerAccess is set to OneServer, this parameter specifies the only server which can be accessed. If ServerAccess is set to AnyServer, optionally specify this parameter to set the initial server location of the data selector.
library
Type: System..::.String
Optionally specify this parameter to set the initial library location of the data selector.
member
Type: System..::.String
Optionally specify this parameter to set the initially selected member in the data selector.
useLabelsForVarNames
Type: System..::.Boolean
Determines whether the column labels or names are displayed in the query builder.
filterXml
Type: System..::.String %
A string representing the serialized form of the filter. On initial call, this parameter is an empty string. On return, this string represents a serialized form of the filter and should be serialized by the task. On subsequent calls, the task should pass the XmlFilter previously returned.
cookie
Type: System..::.String %
A string representing the navigated location of the data selector. If specified, this parameter should take precendence over Server and Library in setting the initial location. The purpose of this parameter is to allow the user to specify the initial location of the data selector when the Server and Library parameters do not suffice. For example, if the consumer allows datasets to be selected from binders or from file locations on servers, this parameter would be needed to initialize the data selector to one of these locations.
data
Type: SAS.Shared.AddIns..::.ISASTaskData2 %
An ISASTaskData2 object. If the user cancels the data selector or there is a catastrophic problem, then this value remains null on return.
filter
Type: System..::.String %
A string representing the filter as created by the user. It is the task's responsibility to use this string as appropriate in the subsequently generated SAS Code. It is also the task's reponsibility to serialize/deserialize this filter as needed for subsequent code generation.

Return Value

Returns a DialogResult, indicating whether the user selected OK or Cancel.

See Also

ISASTaskConsumer3 Interface
SAS.Shared.AddIns Namespace


ISASTaskConsumer3 Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer3 Properties
ISASTaskConsumer3 Interface See Also

The ISASTaskConsumer3 type exposes the following members.

Properties

Name | Description
ActiveData | Returns an ISASTaskData object for the active data (Inherited from ISASTaskConsumer.)
AssignedServer | Get or set the server associated with the instance of the add-in (where the SAS code will be run). (Inherited from ISASTaskConsumer.)
Display | This method is for use by SAS applications and is not intended for use by SAS customers. (Inherited from ISASTaskConsumer.)
ForecastProjectName | The name of a SAS Forecast Studio project that the application wants the task to use. This property is not documented or supported for SAS customer use. (Inherited from ISASTaskConsumer2.)
InputData | Returns an array of ISASTaskData objects; one for each inut data source. (Inherited from ISASTaskConsumer2.)
InputResourcesDna | Collection of DNA strings that represent the input resources.
Parameters | Get a list of ISASTaskParameter objects used by the task in its generated SAS program code. If the application does not have any parameters then it should return null or and empty array. (Inherited from ISASTaskConsumer2.)
Submit | Retrieve the ISASTaskSubmit interface from the host application. (Inherited from ISASTaskConsumer.)
Utilities | Retrieve the ISASTaskUtilities interface from the host application. (Inherited from ISASTaskConsumer.)

See Also

ISASTaskConsumer3 Interface
SAS.Shared.AddIns Namespace


InputResourcesDna Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskConsumer3..::.InputResourcesDna Property
ISASTaskConsumer3 Interface See Also

Collection of DNA strings that represent the input resources.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Property InputResourcesDna As StringCollection
C#
StringCollection InputResourcesDna { get; set; }

Remarks

DNA strings are a text representation of proprietary SAS objects. Customers should not manipulate these strings directly, but instead use supplied helper classes to create/use them.

See Also

ISASTaskConsumer3 Interface
SAS.Shared.AddIns Namespace


ISASTaskCubeData Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskCubeData Interface
Members See Also

Given an active OLAP data connection as the active data source, this interface surfaces information about that connection and OLAP view that might be used by tasks.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISASTaskCubeData _
    Implements ISASTaskData
C#
public interface ISASTaskCubeData : ISASTaskData

Remarks

This interface is not supported for SAS customer use.

See Also

ISASTaskCubeData Members
SAS.Shared.AddIns Namespace


ISASTaskCubeData Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskCubeData Members
ISASTaskCubeData Interface Methods Properties See Also

The ISASTaskCubeData type exposes the following members.

Methods

Name | Description
Option | Not documented for customer use. (Inherited from ISASTaskData.)
Supported | Checks whether the supplied option specified by OptionalName is supported by the host application. (Inherited from ISASTaskData.)

Properties

Name | Description
Accessor | The ISASTaskDataAccessor for the data object. (Inherited from ISASTaskData.)
ConnectionString | A connection string for connecting to an OLAP server.
File | Returns the location of the data set (either as file system path or libref.member) (Inherited from ISASTaskData.)
Label | Label description of the data (Inherited from ISASTaskData.)
Library | The SAS library (libref) of the data object (Inherited from ISASTaskData.)
Member | The name of the data set in the library; this may be a temporary member is some cases. (Inherited from ISASTaskData.)
Server | The name of the server associated with the data object. (Inherited from ISASTaskData.)
SliceMDX | An MDX-based query string used to generate the data slice.
Source | Returns the SourceType of the data source (Inherited from ISASTaskData.)
Statistics | SAS data set type (CORR, UCORR, etc.) (Inherited from ISASTaskData.)
Table | The name of the data source associated with the data object. (Inherited from ISASTaskData.)
Type | The DataType of the data (SAS, ADO, ODBC, MDDB, OLEDB) (Inherited from ISASTaskData.)

See Also

ISASTaskCubeData Interface
SAS.Shared.AddIns Namespace


ISASTaskCubeData Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskCubeData Methods
ISASTaskCubeData Interface See Also

The ISASTaskCubeData type exposes the following members.

Methods

Name | Description
Option | Not documented for customer use. (Inherited from ISASTaskData.)
Supported | Checks whether the supplied option specified by OptionalName is supported by the host application. (Inherited from ISASTaskData.)

See Also

ISASTaskCubeData Interface
SAS.Shared.AddIns Namespace


ISASTaskCubeData Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskCubeData Properties
ISASTaskCubeData Interface See Also

The ISASTaskCubeData type exposes the following members.

Properties

Name | Description
Accessor | The ISASTaskDataAccessor for the data object. (Inherited from ISASTaskData.)
ConnectionString | A connection string for connecting to an OLAP server.
File | Returns the location of the data set (either as file system path or libref.member) (Inherited from ISASTaskData.)
Label | Label description of the data (Inherited from ISASTaskData.)
Library | The SAS library (libref) of the data object (Inherited from ISASTaskData.)
Member | The name of the data set in the library; this may be a temporary member is some cases. (Inherited from ISASTaskData.)
Server | The name of the server associated with the data object. (Inherited from ISASTaskData.)
SliceMDX | An MDX-based query string used to generate the data slice.
Source | Returns the SourceType of the data source (Inherited from ISASTaskData.)
Statistics | SAS data set type (CORR, UCORR, etc.) (Inherited from ISASTaskData.)
Table | The name of the data source associated with the data object. (Inherited from ISASTaskData.)
Type | The DataType of the data (SAS, ADO, ODBC, MDDB, OLEDB) (Inherited from ISASTaskData.)

See Also

ISASTaskCubeData Interface
SAS.Shared.AddIns Namespace


ConnectionString Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskCubeData..::.ConnectionString Property
ISASTaskCubeData Interface See Also

A connection string for connecting to an OLAP server.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ConnectionString As String
C#
string ConnectionString { get; }

Remarks

This interface is not supported for SAS customer use.

See Also

ISASTaskCubeData Interface
SAS.Shared.AddIns Namespace


SliceMDX Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskCubeData..::.SliceMDX Property
ISASTaskCubeData Interface See Also

An MDX-based query string used to generate the data slice.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SliceMDX As String
C#
string SliceMDX { get; }

Remarks

This interface is not supported for SAS customer use.

See Also

ISASTaskCubeData Interface
SAS.Shared.AddIns Namespace


ISASTaskData Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskData Interface
Members See Also

Implemented by: Host application (for example, SAS Enterprise Guide)

These interfaces allow the task to obtain information about the active data. Different host applications might not be able to provide values for some of these methods.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISASTaskData
C#
public interface ISASTaskData

Remarks

All host applications implement this interface. But not all methods and properties within the interface are necessarily implemented. Use the Supported(OptionalName) property to check whether a particular member is supported.

See Also

ISASTaskData Members
SAS.Shared.AddIns Namespace


ISASTaskData Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskData Members
ISASTaskData Interface Methods Properties See Also

The ISASTaskData type exposes the following members.

Methods

Name | Description
Option | Not documented for customer use.
Supported | Checks whether the supplied option specified by OptionalName is supported by the host application.

Properties

Name | Description
Accessor | The ISASTaskDataAccessor for the data object.
File | Returns the location of the data set (either as file system path or libref.member)
Label | Label description of the data
Library | The SAS library (libref) of the data object
Member | The name of the data set in the library; this may be a temporary member is some cases.
Server | The name of the server associated with the data object.
Source | Returns the SourceType of the data source
Statistics | SAS data set type (CORR, UCORR, etc.)
Table | The name of the data source associated with the data object.
Type | The DataType of the data (SAS, ADO, ODBC, MDDB, OLEDB)

See Also

ISASTaskData Interface
SAS.Shared.AddIns Namespace


ISASTaskData Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskData Methods
ISASTaskData Interface See Also

The ISASTaskData type exposes the following members.

Methods

Name | Description
Option | Not documented for customer use.
Supported | Checks whether the supplied option specified by OptionalName is supported by the host application.

See Also

ISASTaskData Interface
SAS.Shared.AddIns Namespace


Option Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskData..::.Option Method
ISASTaskData Interface See Also

Not documented for customer use.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function Option ( _
    Option As DataOption _
) As Object
C#
Object Option(
    DataOption Option
)

Parameters

Option
Type: SAS.Shared.AddIns..::.DataOption
Not documented for customer use.

Return Value

Not documented for customer use.

See Also

ISASTaskData Interface
SAS.Shared.AddIns Namespace


Supported Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskData..::.Supported Method
ISASTaskData Interface See Also

Checks whether the supplied option specified by OptionalName is supported by the host application.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function Supported ( _
    Name As OptionalName _
) As Boolean
C#
bool Supported(
    OptionalName Name
)

Parameters

Name
Type: SAS.Shared.AddIns..::.OptionalName
Name of the option

Return Value

true if supported, else false

See Also

ISASTaskData Interface
SAS.Shared.AddIns Namespace


ISASTaskData Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskData Properties
ISASTaskData Interface See Also

The ISASTaskData type exposes the following members.

Properties

Name | Description
Accessor | The ISASTaskDataAccessor for the data object.
File | Returns the location of the data set (either as file system path or libref.member)
Label | Label description of the data
Library | The SAS library (libref) of the data object
Member | The name of the data set in the library; this may be a temporary member is some cases.
Server | The name of the server associated with the data object.
Source | Returns the SourceType of the data source
Statistics | SAS data set type (CORR, UCORR, etc.)
Table | The name of the data source associated with the data object.
Type | The DataType of the data (SAS, ADO, ODBC, MDDB, OLEDB)

See Also

ISASTaskData Interface
SAS.Shared.AddIns Namespace


Accessor Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskData..::.Accessor Property
ISASTaskData Interface See Also

The ISASTaskDataAccessor for the data object.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Accessor As ISASTaskDataAccessor
C#
ISASTaskDataAccessor Accessor { get; }

Field Value

The ISASTaskDataAccessor for the data object.

See Also

ISASTaskData Interface
SAS.Shared.AddIns Namespace


File Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskData..::.File Property
ISASTaskData Interface See Also

Returns the location of the data set (either as file system path or libref.member)

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property File As String
C#
string File { get; }

Field Value

Returns the location of the data set (either as file system path or libref.member)

See Also

ISASTaskData Interface
SAS.Shared.AddIns Namespace


Label Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskData..::.Label Property
ISASTaskData Interface See Also

Label description of the data

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Label As String
C#
string Label { get; }

Field Value

Label description of the data

See Also

ISASTaskData Interface
SAS.Shared.AddIns Namespace


Library Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskData..::.Library Property
ISASTaskData Interface See Also

The SAS library (libref) of the data object

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Library As String
C#
string Library { get; }

Field Value

The SAS library (libref) of the data object

See Also

ISASTaskData Interface
SAS.Shared.AddIns Namespace


Member Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskData..::.Member Property
ISASTaskData Interface See Also

The name of the data set in the library; this may be a temporary member is some cases.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Member As String
C#
string Member { get; }

Field Value

The name of the data set in the library; this may be a temporary member is some cases.

See Also

ISASTaskData Interface
SAS.Shared.AddIns Namespace


Server Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskData..::.Server Property
ISASTaskData Interface See Also

The name of the server associated with the data object.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Server As String
C#
string Server { get; }

Field Value

The name of the server associated with the data object.

See Also

ISASTaskData Interface
SAS.Shared.AddIns Namespace


Source Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskData..::.Source Property
ISASTaskData Interface See Also

Returns the SourceType of the data source

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Source As SourceType
C#
SourceType Source { get; }

Field Value

Returns the SourceType of the data source

See Also

ISASTaskData Interface
SAS.Shared.AddIns Namespace


Statistics Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskData..::.Statistics Property
ISASTaskData Interface See Also

SAS data set type (CORR, UCORR, etc.)

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Statistics As String
C#
string Statistics { get; }

See Also

ISASTaskData Interface
SAS.Shared.AddIns Namespace


Table Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskData..::.Table Property
ISASTaskData Interface See Also

The name of the data source associated with the data object.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Table As String
C#
string Table { get; }

Field Value

The name of the data source associated with the data object.

See Also

ISASTaskData Interface
SAS.Shared.AddIns Namespace


Type Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskData..::.Type Property
ISASTaskData Interface See Also

The DataType of the data (SAS, ADO, ODBC, MDDB, OLEDB)

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Type As DataType
C#
DataType Type { get; }

Field Value

Returns the DataType of the data (SAS, ADO, ODBC, MDDB, OLEDB)

See Also

ISASTaskData Interface
SAS.Shared.AddIns Namespace


ISASTaskData2 Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskData2 Interface
Members Example See Also

Implemented by: Host application (for example, SAS Enterprise Guide)

An extension of the ISASTaskData interface to surface some additional properties.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISASTaskData2 _
    Implements ISASTaskData
C#
public interface ISASTaskData2 : ISASTaskData

Examples

C# Example
Copy Code
            // _consumer is the ISASTaskConsumer value passed in the Connect() call
            ISASTaskData2 td2 = _consumer.ActiveData as ISASTaskData2;
            string displayName="";
            if (td2 != null)
            {
                displayName = td2.DisplayName;
            }

See Also

ISASTaskData2 Members
SAS.Shared.AddIns Namespace


ISASTaskData2 Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskData2 Members
ISASTaskData2 Interface Methods Properties See Also

The ISASTaskData2 type exposes the following members.

Methods

Name | Description
Option | Not documented for customer use. (Inherited from ISASTaskData.)
Supported | Checks whether the supplied option specified by OptionalName is supported by the host application. (Inherited from ISASTaskData.)

Properties

Name | Description
Accessor | The ISASTaskDataAccessor for the data object. (Inherited from ISASTaskData.)
DelimitedDisplayName | A tab delimited display name provided for display purpose only. The delimited name is in the form of [label]\[value]\t[label]\t[value]...\n
DisplayName | Alias name used represent the underlying file; used for display purpose only.
DisplayNameWithFilter | Alias name used represent the underlying file and filter; used for display purpose only.
DNA | Get the DNA for this data source.
File | Returns the location of the data set (either as file system path or libref.member) (Inherited from ISASTaskData.)
HasGeneratedLibref | Whether this data source has a generated libref that is maintained by the application. When this is true, the value returned by Library should be used as the libref in any generated code. When this is false, it is possible to try and determine the libref by looking up the value given the LibraryName. In rare cases, the libref maintained in metadata may get out of sync with the libref known to the application.
Label | Label description of the data (Inherited from ISASTaskData.)
Library | The SAS library (libref) of the data object (Inherited from ISASTaskData.)
LibraryName | Library name used to represent the underlying file; used for display purpose only.
Member | The name of the data set in the library; this may be a temporary member is some cases. (Inherited from ISASTaskData.)
RestrictedToServer | Whether this data has to reside on the same server as other data sources used by the task.
Server | The name of the server associated with the data object. (Inherited from ISASTaskData.)
Source | Returns the SourceType of the data source (Inherited from ISASTaskData.)
Statistics | SAS data set type (CORR, UCORR, etc.) (Inherited from ISASTaskData.)
SupportsEditingAndFiltering | Whether or not this data source supports editing and filtering. A call to ISASTaskConsumer3.ShowEditInputDataDialog() is valid only if this method returns true.
Table | The name of the data source associated with the data object. (Inherited from ISASTaskData.)
Type | The DataType of the data (SAS, ADO, ODBC, MDDB, OLEDB) (Inherited from ISASTaskData.)

See Also

ISASTaskData2 Interface
SAS.Shared.AddIns Namespace


ISASTaskData2 Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskData2 Methods
ISASTaskData2 Interface See Also

The ISASTaskData2 type exposes the following members.

Methods

Name | Description
Option | Not documented for customer use. (Inherited from ISASTaskData.)
Supported | Checks whether the supplied option specified by OptionalName is supported by the host application. (Inherited from ISASTaskData.)

See Also

ISASTaskData2 Interface
SAS.Shared.AddIns Namespace


ISASTaskData2 Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskData2 Properties
ISASTaskData2 Interface See Also

The ISASTaskData2 type exposes the following members.

Properties

Name | Description
Accessor | The ISASTaskDataAccessor for the data object. (Inherited from ISASTaskData.)
DelimitedDisplayName | A tab delimited display name provided for display purpose only. The delimited name is in the form of [label]\[value]\t[label]\t[value]...\n
DisplayName | Alias name used represent the underlying file; used for display purpose only.
DisplayNameWithFilter | Alias name used represent the underlying file and filter; used for display purpose only.
DNA | Get the DNA for this data source.
File | Returns the location of the data set (either as file system path or libref.member) (Inherited from ISASTaskData.)
HasGeneratedLibref | Whether this data source has a generated libref that is maintained by the application. When this is true, the value returned by Library should be used as the libref in any generated code. When this is false, it is possible to try and determine the libref by looking up the value given the LibraryName. In rare cases, the libref maintained in metadata may get out of sync with the libref known to the application.
Label | Label description of the data (Inherited from ISASTaskData.)
Library | The SAS library (libref) of the data object (Inherited from ISASTaskData.)
LibraryName | Library name used to represent the underlying file; used for display purpose only.
Member | The name of the data set in the library; this may be a temporary member is some cases. (Inherited from ISASTaskData.)
RestrictedToServer | Whether this data has to reside on the same server as other data sources used by the task.
Server | The name of the server associated with the data object. (Inherited from ISASTaskData.)
Source | Returns the SourceType of the data source (Inherited from ISASTaskData.)
Statistics | SAS data set type (CORR, UCORR, etc.) (Inherited from ISASTaskData.)
SupportsEditingAndFiltering | Whether or not this data source supports editing and filtering. A call to ISASTaskConsumer3.ShowEditInputDataDialog() is valid only if this method returns true.
Table | The name of the data source associated with the data object. (Inherited from ISASTaskData.)
Type | The DataType of the data (SAS, ADO, ODBC, MDDB, OLEDB) (Inherited from ISASTaskData.)

See Also

ISASTaskData2 Interface
SAS.Shared.AddIns Namespace


DelimitedDisplayName Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskData2..::.DelimitedDisplayName Property
ISASTaskData2 Interface See Also

A tab delimited display name provided for display purpose only. The delimited name is in the form of [label]\[value]\t[label]\t[value]...\n

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property DelimitedDisplayName As String
C#
string DelimitedDisplayName { get; }

See Also

ISASTaskData2 Interface
SAS.Shared.AddIns Namespace


DisplayName Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskData2..::.DisplayName Property
ISASTaskData2 Interface See Also

Alias name used represent the underlying file; used for display purpose only.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Property DisplayName As String
C#
string DisplayName { get; set; }

See Also

ISASTaskData2 Interface
SAS.Shared.AddIns Namespace


DisplayNameWithFilter Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskData2..::.DisplayNameWithFilter Property
ISASTaskData2 Interface See Also

Alias name used represent the underlying file and filter; used for display purpose only.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property DisplayNameWithFilter As String
C#
string DisplayNameWithFilter { get; }

See Also

ISASTaskData2 Interface
SAS.Shared.AddIns Namespace


DNA Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskData2..::.DNA Property
ISASTaskData2 Interface See Also

Get the DNA for this data source.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property DNA As String
C#
string DNA { get; }

Field Value

The DNA moniker for this data source. The format of this moniker is not documented for customer use. It may differ from one application to another and may change format in future releases.

See Also

ISASTaskData2 Interface
SAS.Shared.AddIns Namespace


HasGeneratedLibref Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskData2..::.HasGeneratedLibref Property
ISASTaskData2 Interface See Also

Whether this data source has a generated libref that is maintained by the application. When this is true, the value returned by Library should be used as the libref in any generated code. When this is false, it is possible to try and determine the libref by looking up the value given the LibraryName. In rare cases, the libref maintained in metadata may get out of sync with the libref known to the application.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property HasGeneratedLibref As Boolean
C#
bool HasGeneratedLibref { get; }

See Also

ISASTaskData2 Interface
SAS.Shared.AddIns Namespace


LibraryName Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskData2..::.LibraryName Property
ISASTaskData2 Interface See Also

Library name used to represent the underlying file; used for display purpose only.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property LibraryName As String
C#
string LibraryName { get; }

See Also

ISASTaskData2 Interface
SAS.Shared.AddIns Namespace


RestrictedToServer Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskData2..::.RestrictedToServer Property
ISASTaskData2 Interface See Also

Whether this data has to reside on the same server as other data sources used by the task.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property RestrictedToServer As Boolean
C#
bool RestrictedToServer { get; }

See Also

ISASTaskData2 Interface
SAS.Shared.AddIns Namespace


SupportsEditingAndFiltering Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskData2..::.SupportsEditingAndFiltering Property
ISASTaskData2 Interface See Also

Whether or not this data source supports editing and filtering. A call to ISASTaskConsumer3.ShowEditInputDataDialog() is valid only if this method returns true.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsEditingAndFiltering As Boolean
C#
bool SupportsEditingAndFiltering { get; }

See Also

ISASTaskData2 Interface
SAS.Shared.AddIns Namespace


ISASTaskDataAccessor Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataAccessor Interface
Members See Also

Implemented by: Host application (for example, SAS Enterprise Guide)

These methods allow the task to access the data values in a specific data object.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISASTaskDataAccessor
C#
public interface ISASTaskDataAccessor

Remarks

The implementation of this interface by a host application is required.

See Also

ISASTaskDataAccessor Members
SAS.Shared.AddIns Namespace


ISASTaskDataAccessor Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataAccessor Members
ISASTaskDataAccessor Interface Methods Properties See Also

The ISASTaskDataAccessor type exposes the following members.

Methods

Name | Description
Close | Closes the Accessor object.
ColumnInfoByIndex | Use this routine to get an instance of the ISASTaskColumnInfo object.
ColumnInfoByName | Use this routine to get an instance of the ISASTaskColumnInfo object.
ColumnNames | Returns a list of column names in the data source.
GenerateDiscrete | Generate a list of discrete (unique) values for the given column name.
GenerateStatistic | Cause the application to generate basic statistics for the data.
Open | Opens the Accessor object for reading.
Supported | Checks whether the supplied option specified by OptionalName is supported by the host application.
Value | Retrieve the value for a particular data cell.

Properties

Name | Description
ColumnCount | The number of columns in the data object.
RowCount | The number of rows in the data object.

See Also

ISASTaskDataAccessor Interface
SAS.Shared.AddIns Namespace


ISASTaskDataAccessor Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataAccessor Methods
ISASTaskDataAccessor Interface See Also

The ISASTaskDataAccessor type exposes the following members.

Methods

Name | Description
Close | Closes the Accessor object.
ColumnInfoByIndex | Use this routine to get an instance of the ISASTaskColumnInfo object.
ColumnInfoByName | Use this routine to get an instance of the ISASTaskColumnInfo object.
ColumnNames | Returns a list of column names in the data source.
GenerateDiscrete | Generate a list of discrete (unique) values for the given column name.
GenerateStatistic | Cause the application to generate basic statistics for the data.
Open | Opens the Accessor object for reading.
Supported | Checks whether the supplied option specified by OptionalName is supported by the host application.
Value | Retrieve the value for a particular data cell.

See Also

ISASTaskDataAccessor Interface
SAS.Shared.AddIns Namespace


Close Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataAccessor..::.Close Method
ISASTaskDataAccessor Interface See Also

Closes the Accessor object.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Sub Close
C#
void Close()

See Also

ISASTaskDataAccessor Interface
SAS.Shared.AddIns Namespace


ColumnInfoByIndex Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataAccessor..::.ColumnInfoByIndex Method
ISASTaskDataAccessor Interface See Also

Use this routine to get an instance of the ISASTaskColumnInfo object.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function ColumnInfoByIndex ( _
    Index As Integer _
) As ISASTaskDataColumn
C#
ISASTaskDataColumn ColumnInfoByIndex(
    int Index
)

Parameters

Index
Type: System..::.Int32
The Index parameter is a zero based index or the variable name for the column.

Return Value

The ColumnInfobyIndex method returns a ISASTaskColumnInfo object.

See Also

ISASTaskDataAccessor Interface
SAS.Shared.AddIns Namespace


ColumnInfoByName Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataAccessor..::.ColumnInfoByName Method
ISASTaskDataAccessor Interface See Also

Use this routine to get an instance of the ISASTaskColumnInfo object.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function ColumnInfoByName ( _
    Name As String _
) As ISASTaskDataColumn
C#
ISASTaskDataColumn ColumnInfoByName(
    string Name
)

Parameters

Name
Type: System..::.String
The Name parameter is the variable name for the column.

Return Value

The ColumnInfobyIndex method returns a ISASTaskColumnInfo object.

See Also

ISASTaskDataAccessor Interface
SAS.Shared.AddIns Namespace


ColumnNames Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataAccessor..::.ColumnNames Method
ISASTaskDataAccessor Interface See Also

Returns a list of column names in the data source.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function ColumnNames ( _
    <OutAttribute> ByRef Names As String() _
) As Integer
C#
int ColumnNames(
    out string[] Names
)

Parameters

Names
Type: array< System..::.String >[]()[] %
Array of column names.

Return Value

Number of columns in the data source.

See Also

ISASTaskDataAccessor Interface
SAS.Shared.AddIns Namespace


GenerateDiscrete Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataAccessor..::.GenerateDiscrete Method
ISASTaskDataAccessor Interface See Also

Generate a list of discrete (unique) values for the given column name.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Sub GenerateDiscrete ( _
    Name As String, _
    MissingAreDiscrete As Boolean _
)
C#
void GenerateDiscrete(
    string Name,
    bool MissingAreDiscrete
)

Parameters

Name
Type: System..::.String
Name of the column to examine
MissingAreDiscrete
Type: System..::.Boolean
Whether to treat missing values as discrete

See Also

ISASTaskDataAccessor Interface
SAS.Shared.AddIns Namespace


GenerateStatistic Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataAccessor..::.GenerateStatistic Method
ISASTaskDataAccessor Interface See Also

Cause the application to generate basic statistics for the data.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Sub GenerateStatistic
C#
void GenerateStatistic()

See Also

ISASTaskDataAccessor Interface
SAS.Shared.AddIns Namespace


Open Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataAccessor..::.Open Method
ISASTaskDataAccessor Interface See Also

Opens the Accessor object for reading.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function Open As Boolean
C#
bool Open()

Return Value

true if Open operation succeeded.

See Also

ISASTaskDataAccessor Interface
SAS.Shared.AddIns Namespace


Supported Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataAccessor..::.Supported Method
ISASTaskDataAccessor Interface See Also

Checks whether the supplied option specified by OptionalName is supported by the host application.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function Supported ( _
    Name As OptionalName _
) As Boolean
C#
bool Supported(
    OptionalName Name
)

Parameters

Name
Type: SAS.Shared.AddIns..::.OptionalName
Name of the option

Return Value

true if supported, else false

See Also

ISASTaskDataAccessor Interface
SAS.Shared.AddIns Namespace


Value Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataAccessor..::.Value Method
ISASTaskDataAccessor Interface See Also

Retrieve the value for a particular data cell.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function Value ( _
    Column As Integer, _
    Row As Integer, _
    <OutAttribute> ByRef Formatted As String, _
    <OutAttribute> ByRef Raw As Object _
) As Boolean
C#
bool Value(
    int Column,
    int Row,
    out string Formatted,
    out Object Raw
)

Parameters

Column
Type: System..::.Int32
The Column value is the zero based index of the column.
Row
Type: System..::.Int32
The row value is a zero based index that represents the row offset.
Formatted
Type: System..::.String %
The formatted value as a string.
Raw
Type: System..::.Object %
The raw unformatted value.

Return Value

true if operation succeeded.

See Also

ISASTaskDataAccessor Interface
SAS.Shared.AddIns Namespace


ISASTaskDataAccessor Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataAccessor Properties
ISASTaskDataAccessor Interface See Also

The ISASTaskDataAccessor type exposes the following members.

Properties

Name | Description
ColumnCount | The number of columns in the data object.
RowCount | The number of rows in the data object.

See Also

ISASTaskDataAccessor Interface
SAS.Shared.AddIns Namespace


ColumnCount Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataAccessor..::.ColumnCount Property
ISASTaskDataAccessor Interface See Also

The number of columns in the data object.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ColumnCount As Integer
C#
int ColumnCount { get; }

See Also

ISASTaskDataAccessor Interface
SAS.Shared.AddIns Namespace


RowCount Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataAccessor..::.RowCount Property
ISASTaskDataAccessor Interface See Also

The number of rows in the data object.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property RowCount As Integer
C#
int RowCount { get; }

See Also

ISASTaskDataAccessor Interface
SAS.Shared.AddIns Namespace


ISASTaskDataAccessorSink Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataAccessorSink Interface
Members See Also

Implemented by: Add-in task

Allows the application to notify the add-in when calculation of statistics or discrete values is complete. You can request these calculations through ISASTaskDataAccessor

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISASTaskDataAccessorSink
C#
public interface ISASTaskDataAccessorSink

Remarks

This is an optional interface for add-in tasks.

See Also

ISASTaskDataAccessorSink Members
SAS.Shared.AddIns Namespace
ISASTaskDataAccessor..::.GenerateStatistic()()()
ISASTaskDataAccessor..::.GenerateDiscrete(String, Boolean)


ISASTaskDataAccessorSink Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataAccessorSink Members
ISASTaskDataAccessorSink Interface Methods See Also

The ISASTaskDataAccessorSink type exposes the following members.

Methods

Name | Description
DiscreteComplete | Event fired when calculation of discrete values is complete.
StatisticComplete | Event fired when calculation of statistics is complete.

See Also

ISASTaskDataAccessorSink Interface
SAS.Shared.AddIns Namespace


ISASTaskDataAccessorSink Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataAccessorSink Methods
ISASTaskDataAccessorSink Interface See Also

The ISASTaskDataAccessorSink type exposes the following members.

Methods

Name | Description
DiscreteComplete | Event fired when calculation of discrete values is complete.
StatisticComplete | Event fired when calculation of statistics is complete.

See Also

ISASTaskDataAccessorSink Interface
SAS.Shared.AddIns Namespace


DiscreteComplete Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataAccessorSink..::.DiscreteComplete Method
ISASTaskDataAccessorSink Interface See Also

Event fired when calculation of discrete values is complete.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Sub DiscreteComplete ( _
    Name As String _
)
C#
void DiscreteComplete(
    string Name
)

Parameters

Name
Type: System..::.String
Name of the column that contains these discrete values.

See Also

ISASTaskDataAccessorSink Interface
SAS.Shared.AddIns Namespace


StatisticComplete Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataAccessorSink..::.StatisticComplete Method
ISASTaskDataAccessorSink Interface See Also

Event fired when calculation of statistics is complete.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Sub StatisticComplete
C#
void StatisticComplete()

See Also

ISASTaskDataAccessorSink Interface
SAS.Shared.AddIns Namespace


ISASTaskDataColumn Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataColumn Interface
Members See Also

Implemented by: Host application (for example, SAS Enterprise Guide)

Provides information about a single column in a data source.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISASTaskDataColumn
C#
public interface ISASTaskDataColumn

Remarks

The implementation of this interface by a host application is required.

See Also

ISASTaskDataColumn Members
SAS.Shared.AddIns Namespace


ISASTaskDataColumn Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataColumn Members
ISASTaskDataColumn Interface Methods Properties See Also

The ISASTaskDataColumn type exposes the following members.

Methods

Name | Description
Discrete | Retrieves list of discrete (unique) values for this column.
Statistic | Invoke the application services to calculate basic statistics on this column.

Properties

Name | Description
Format | The SAS Format associated with the column.
Group | The column group (Numeric, Character, Date, ...).
Index | Zero based index of the column.
Informat | The SAS Informat associated with the column.
Label | The column label (display name).
Length | The length of the column.
Name | The column name.
Sorted | Indicates whether the data is sorted by this column
SortPosition | The column sort position

See Also

ISASTaskDataColumn Interface
SAS.Shared.AddIns Namespace


ISASTaskDataColumn Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataColumn Methods
ISASTaskDataColumn Interface See Also

The ISASTaskDataColumn type exposes the following members.

Methods

Name | Description
Discrete | Retrieves list of discrete (unique) values for this column.
Statistic | Invoke the application services to calculate basic statistics on this column.

See Also

ISASTaskDataColumn Interface
SAS.Shared.AddIns Namespace


Discrete Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataColumn..::.Discrete Method
ISASTaskDataColumn Interface See Also

Retrieves list of discrete (unique) values for this column.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function Discrete ( _
    <OutAttribute> ByRef Values As Object() _
) As Boolean
C#
bool Discrete(
    out Object[] Values
)

Parameters

Values
Type: array< System..::.Object >[]()[] %
Array of values

Return Value

true if success

See Also

ISASTaskDataColumn Interface
SAS.Shared.AddIns Namespace


Statistic Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataColumn..::.Statistic Method
ISASTaskDataColumn Interface See Also

Invoke the application services to calculate basic statistics on this column.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function Statistic ( _
    Stat As Statistics _
) As Double
C#
double Statistic(
    Statistics Stat
)

Parameters

Stat
Type: SAS.Shared.AddIns..::.Statistics
Name of the statistic to retrieve.

Return Value

The resulting statistic value.

See Also

ISASTaskDataColumn Interface
SAS.Shared.AddIns Namespace


ISASTaskDataColumn Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataColumn Properties
ISASTaskDataColumn Interface See Also

The ISASTaskDataColumn type exposes the following members.

Properties

Name | Description
Format | The SAS Format associated with the column.
Group | The column group (Numeric, Character, Date, ...).
Index | Zero based index of the column.
Informat | The SAS Informat associated with the column.
Label | The column label (display name).
Length | The length of the column.
Name | The column name.
Sorted | Indicates whether the data is sorted by this column
SortPosition | The column sort position

See Also

ISASTaskDataColumn Interface
SAS.Shared.AddIns Namespace


Format Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataColumn..::.Format Property
ISASTaskDataColumn Interface See Also

The SAS Format associated with the column.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Format As String
C#
string Format { get; }

See Also

ISASTaskDataColumn Interface
SAS.Shared.AddIns Namespace


Group Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataColumn..::.Group Property
ISASTaskDataColumn Interface See Also

The column group (Numeric, Character, Date, ...).

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Group As VariableGroup
C#
VariableGroup Group { get; }

See Also

ISASTaskDataColumn Interface
SAS.Shared.AddIns Namespace


Index Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataColumn..::.Index Property
ISASTaskDataColumn Interface See Also

Zero based index of the column.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Index As Integer
C#
int Index { get; }

See Also

ISASTaskDataColumn Interface
SAS.Shared.AddIns Namespace


Informat Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataColumn..::.Informat Property
ISASTaskDataColumn Interface See Also

The SAS Informat associated with the column.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Informat As String
C#
string Informat { get; }

See Also

ISASTaskDataColumn Interface
SAS.Shared.AddIns Namespace


Label Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataColumn..::.Label Property
ISASTaskDataColumn Interface See Also

The column label (display name).

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Label As String
C#
string Label { get; }

See Also

ISASTaskDataColumn Interface
SAS.Shared.AddIns Namespace


Length Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataColumn..::.Length Property
ISASTaskDataColumn Interface See Also

The length of the column.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Length As Integer
C#
int Length { get; }

See Also

ISASTaskDataColumn Interface
SAS.Shared.AddIns Namespace


Name Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataColumn..::.Name Property
ISASTaskDataColumn Interface See Also

The column name.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Name As String
C#
string Name { get; }

See Also

ISASTaskDataColumn Interface
SAS.Shared.AddIns Namespace


Sorted Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataColumn..::.Sorted Property
ISASTaskDataColumn Interface See Also

Indicates whether the data is sorted by this column

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Sorted As SortDirection
C#
SortDirection Sorted { get; }

See Also

ISASTaskDataColumn Interface
SAS.Shared.AddIns Namespace


SortPosition Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataColumn..::.SortPosition Property
ISASTaskDataColumn Interface See Also

The column sort position

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SortPosition As Integer
C#
int SortPosition { get; }

See Also

ISASTaskDataColumn Interface
SAS.Shared.AddIns Namespace


ISASTaskDataColumn2 Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataColumn2 Interface
Members See Also

Implemented by: Host application (for example, SAS Enterprise Guide)

Provides information about a single column in a data source. This is an extension of ISASTaskDataColumn.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISASTaskDataColumn2 _
    Implements ISASTaskDataColumn
C#
public interface ISASTaskDataColumn2 : ISASTaskDataColumn

See Also

ISASTaskDataColumn2 Members
SAS.Shared.AddIns Namespace


ISASTaskDataColumn2 Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataColumn2 Members
ISASTaskDataColumn2 Interface Methods Properties See Also

The ISASTaskDataColumn2 type exposes the following members.

Methods

Name | Description
Discrete | Retrieves list of discrete (unique) values for this column. (Inherited from ISASTaskDataColumn.)
DiscreteFormatted | Retrieves list of discrete (unique) values for this column.
Statistic | Invoke the application services to calculate basic statistics on this column. (Inherited from ISASTaskDataColumn.)

Properties

Name | Description
Format | The SAS Format associated with the column. (Inherited from ISASTaskDataColumn.)
Group | The column group (Numeric, Character, Date, ...). (Inherited from ISASTaskDataColumn.)
Index | Zero based index of the column. (Inherited from ISASTaskDataColumn.)
Informat | The SAS Informat associated with the column. (Inherited from ISASTaskDataColumn.)
Label | The column label (display name). (Inherited from ISASTaskDataColumn.)
Length | The length of the column. (Inherited from ISASTaskDataColumn.)
Name | The column name. (Inherited from ISASTaskDataColumn.)
Sorted | Indicates whether the data is sorted by this column (Inherited from ISASTaskDataColumn.)
SortPosition | The column sort position (Inherited from ISASTaskDataColumn.)

See Also

ISASTaskDataColumn2 Interface
SAS.Shared.AddIns Namespace


ISASTaskDataColumn2 Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataColumn2 Methods
ISASTaskDataColumn2 Interface See Also

The ISASTaskDataColumn2 type exposes the following members.

Methods

Name | Description
Discrete | Retrieves list of discrete (unique) values for this column. (Inherited from ISASTaskDataColumn.)
DiscreteFormatted | Retrieves list of discrete (unique) values for this column.
Statistic | Invoke the application services to calculate basic statistics on this column. (Inherited from ISASTaskDataColumn.)

See Also

ISASTaskDataColumn2 Interface
SAS.Shared.AddIns Namespace


DiscreteFormatted Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataColumn2..::.DiscreteFormatted Method
ISASTaskDataColumn2 Interface See Also

Retrieves list of discrete (unique) values for this column.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function DiscreteFormatted ( _
    <OutAttribute> ByRef Values As String() _
) As Boolean
C#
bool DiscreteFormatted(
    out string[] Values
)

Parameters

Values
Type: array< System..::.String >[]()[] %
Array of values

Return Value

true if success

Remarks

This operation might take considerable time depending on the size of the data source and number of unique values.

See Also

ISASTaskDataColumn2 Interface
SAS.Shared.AddIns Namespace


ISASTaskDataColumn2 Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataColumn2 Properties
ISASTaskDataColumn2 Interface See Also

The ISASTaskDataColumn2 type exposes the following members.

Properties

Name | Description
Format | The SAS Format associated with the column. (Inherited from ISASTaskDataColumn.)
Group | The column group (Numeric, Character, Date, ...). (Inherited from ISASTaskDataColumn.)
Index | Zero based index of the column. (Inherited from ISASTaskDataColumn.)
Informat | The SAS Informat associated with the column. (Inherited from ISASTaskDataColumn.)
Label | The column label (display name). (Inherited from ISASTaskDataColumn.)
Length | The length of the column. (Inherited from ISASTaskDataColumn.)
Name | The column name. (Inherited from ISASTaskDataColumn.)
Sorted | Indicates whether the data is sorted by this column (Inherited from ISASTaskDataColumn.)
SortPosition | The column sort position (Inherited from ISASTaskDataColumn.)

See Also

ISASTaskDataColumn2 Interface
SAS.Shared.AddIns Namespace


ISASTaskDataDescriptor Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataDescriptor Interface
Members See Also

Implemented by: Host application (for example, SAS Enterprise Guide)

These interfaces allow the add-in and application to exchange information about a code compatible data name to be used as either input or output data.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISASTaskDataDescriptor
C#
public interface ISASTaskDataDescriptor

Remarks

Not all host applications necessarily implement this interface.

The application typically supplies a navigational dialog to provide the user of the task the ability to select or specify a dataset name.

See Also

ISASTaskDataDescriptor Members
SAS.Shared.AddIns Namespace


ISASTaskDataDescriptor Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataDescriptor Members
ISASTaskDataDescriptor Interface Methods Properties See Also

The ISASTaskDataDescriptor type exposes the following members.

Methods

Name | Description
IsSameData | Does this data descriptor point to same location as that passed in?

Properties

Name | Description
DelimitedDisplayName | A tab delimited display name provided for display purpose only. The delimited name is in the form of [label]\[value]\t[label]\t[value]...\n
FilePath | File Path to data
Label | Descriptive label for the data source.
LibraryName | SAS library name for the data source. This string is used for display purposes only and corresponds to the libref.
Libref | SAS library name (libref) for the data source.
Member | SAS member name for the data source.
Server | SAS server where the data source resides.
Type | data path type.

See Also

ISASTaskDataDescriptor Interface
SAS.Shared.AddIns Namespace


ISASTaskDataDescriptor Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataDescriptor Methods
ISASTaskDataDescriptor Interface See Also

The ISASTaskDataDescriptor type exposes the following members.

Methods

Name | Description
IsSameData | Does this data descriptor point to same location as that passed in?

See Also

ISASTaskDataDescriptor Interface
SAS.Shared.AddIns Namespace


IsSameData Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataDescriptor..::.IsSameData Method
ISASTaskDataDescriptor Interface See Also

Does this data descriptor point to same location as that passed in?

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function IsSameData ( _
    serverName As String, _
    LibraryName As String, _
    memberName As String _
) As Boolean
C#
bool IsSameData(
    string serverName,
    string LibraryName,
    string memberName
)

Parameters

serverName
Type: System..::.String
Server data resides on
LibraryName
Type: System..::.String
Library Name (metadata name ) that data resides in
memberName
Type: System..::.String
Table Name of dataset

Return Value

true if Server, library and member are the same

See Also

ISASTaskDataDescriptor Interface
SAS.Shared.AddIns Namespace


ISASTaskDataDescriptor Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataDescriptor Properties
ISASTaskDataDescriptor Interface See Also

The ISASTaskDataDescriptor type exposes the following members.

Properties

Name | Description
DelimitedDisplayName | A tab delimited display name provided for display purpose only. The delimited name is in the form of [label]\[value]\t[label]\t[value]...\n
FilePath | File Path to data
Label | Descriptive label for the data source.
LibraryName | SAS library name for the data source. This string is used for display purposes only and corresponds to the libref.
Libref | SAS library name (libref) for the data source.
Member | SAS member name for the data source.
Server | SAS server where the data source resides.
Type | data path type.

See Also

ISASTaskDataDescriptor Interface
SAS.Shared.AddIns Namespace


DelimitedDisplayName Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataDescriptor..::.DelimitedDisplayName Property
ISASTaskDataDescriptor Interface See Also

A tab delimited display name provided for display purpose only. The delimited name is in the form of [label]\[value]\t[label]\t[value]...\n

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property DelimitedDisplayName As String
C#
string DelimitedDisplayName { get; }

See Also

ISASTaskDataDescriptor Interface
SAS.Shared.AddIns Namespace


FilePath Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataDescriptor..::.FilePath Property
ISASTaskDataDescriptor Interface See Also

File Path to data

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property FilePath As String
C#
string FilePath { get; }

See Also

ISASTaskDataDescriptor Interface
SAS.Shared.AddIns Namespace


Label Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataDescriptor..::.Label Property
ISASTaskDataDescriptor Interface See Also

Descriptive label for the data source.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Label As String
C#
string Label { get; }

See Also

ISASTaskDataDescriptor Interface
SAS.Shared.AddIns Namespace


LibraryName Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataDescriptor..::.LibraryName Property
ISASTaskDataDescriptor Interface See Also

SAS library name for the data source. This string is used for display purposes only and corresponds to the libref.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property LibraryName As String
C#
string LibraryName { get; }

See Also

ISASTaskDataDescriptor Interface
SAS.Shared.AddIns Namespace


Libref Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataDescriptor..::.Libref Property
ISASTaskDataDescriptor Interface See Also

SAS library name (libref) for the data source.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Libref As String
C#
string Libref { get; }

See Also

ISASTaskDataDescriptor Interface
SAS.Shared.AddIns Namespace


Member Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataDescriptor..::.Member Property
ISASTaskDataDescriptor Interface See Also

SAS member name for the data source.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Member As String
C#
string Member { get; }

See Also

ISASTaskDataDescriptor Interface
SAS.Shared.AddIns Namespace


Server Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataDescriptor..::.Server Property
ISASTaskDataDescriptor Interface See Also

SAS server where the data source resides.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Server As String
C#
string Server { get; }

See Also

ISASTaskDataDescriptor Interface
SAS.Shared.AddIns Namespace


Type Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataDescriptor..::.Type Property
ISASTaskDataDescriptor Interface See Also

data path type.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Type As DataPathType
C#
DataPathType Type { get; }

See Also

ISASTaskDataDescriptor Interface
SAS.Shared.AddIns Namespace


ISASTaskDataName Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataName Interface
Members See Also

Implemented by: Host application (for example, SAS Enterprise Guide)

These interfaces allow the add-in and application to exchange information about a code compatible data name to be used as either input or output data.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISASTaskDataName
C#
public interface ISASTaskDataName

Remarks

Not all host applications necessarily implement this interface.

The application typically supplies a navigational dialog to provide the user of the task the ability to select or specify a dataset name.

See Also

ISASTaskDataName Members
SAS.Shared.AddIns Namespace


ISASTaskDataName Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataName Members
ISASTaskDataName Interface Properties See Also

The ISASTaskDataName type exposes the following members.

Properties

Name | Description
Cookie | A token that you can use to navigate back to this same data source again.
Label | Descriptive label for the data source.
Library | SAS library name (libref) for the data source.
Member | SAS member name for the data source.
Server | SAS server where the data source resides.
Source | Name of the data source.
Type | Output data type.

See Also

ISASTaskDataName Interface
SAS.Shared.AddIns Namespace


ISASTaskDataName Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataName Properties
ISASTaskDataName Interface See Also

The ISASTaskDataName type exposes the following members.

Properties

Name | Description
Cookie | A token that you can use to navigate back to this same data source again.
Label | Descriptive label for the data source.
Library | SAS library name (libref) for the data source.
Member | SAS member name for the data source.
Server | SAS server where the data source resides.
Source | Name of the data source.
Type | Output data type.

See Also

ISASTaskDataName Interface
SAS.Shared.AddIns Namespace


Cookie Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataName..::.Cookie Property
ISASTaskDataName Interface See Also

A token that you can use to navigate back to this same data source again.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Cookie As String
C#
string Cookie { get; }

See Also

ISASTaskDataName Interface
SAS.Shared.AddIns Namespace


Label Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataName..::.Label Property
ISASTaskDataName Interface See Also

Descriptive label for the data source.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Label As String
C#
string Label { get; }

See Also

ISASTaskDataName Interface
SAS.Shared.AddIns Namespace


Library Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataName..::.Library Property
ISASTaskDataName Interface See Also

SAS library name (libref) for the data source.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Library As String
C#
string Library { get; }

See Also

ISASTaskDataName Interface
SAS.Shared.AddIns Namespace


Member Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataName..::.Member Property
ISASTaskDataName Interface See Also

SAS member name for the data source.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Member As String
C#
string Member { get; }

See Also

ISASTaskDataName Interface
SAS.Shared.AddIns Namespace


Server Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataName..::.Server Property
ISASTaskDataName Interface See Also

SAS server where the data source resides.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Server As String
C#
string Server { get; }

See Also

ISASTaskDataName Interface
SAS.Shared.AddIns Namespace


Source Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataName..::.Source Property
ISASTaskDataName Interface See Also

Name of the data source.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Source As String
C#
string Source { get; }

See Also

ISASTaskDataName Interface
SAS.Shared.AddIns Namespace


Type Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataName..::.Type Property
ISASTaskDataName Interface See Also

Output data type.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Type As OutputData
C#
OutputData Type { get; }

See Also

ISASTaskDataName Interface
SAS.Shared.AddIns Namespace


ISASTaskDataName2 Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataName2 Interface
Members See Also

Additional methods and properties for the ISASTakDataName

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISASTaskDataName2 _
    Implements ISASTaskDataName
C#
public interface ISASTaskDataName2 : ISASTaskDataName

See Also

ISASTaskDataName2 Members
SAS.Shared.AddIns Namespace


ISASTaskDataName2 Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataName2 Members
ISASTaskDataName2 Interface Properties See Also

The ISASTaskDataName2 type exposes the following members.

Properties

Name | Description
Cookie | A token that you can use to navigate back to this same data source again. (Inherited from ISASTaskDataName.)
DelimitedDisplayName | A tab delimited display name provided for display purpose only. The delimited name is in the form of [label]\[value]\t[label]\t[value]...\n
Label | Descriptive label for the data source. (Inherited from ISASTaskDataName.)
Library | SAS library name (libref) for the data source. (Inherited from ISASTaskDataName.)
LibraryName | SAS library name for the data source. This string is used for display purposes only and corresponds to a Library (libref).
Member | SAS member name for the data source. (Inherited from ISASTaskDataName.)
Server | SAS server where the data source resides. (Inherited from ISASTaskDataName.)
Source | Name of the data source. (Inherited from ISASTaskDataName.)
Type | Output data type. (Inherited from ISASTaskDataName.)

See Also

ISASTaskDataName2 Interface
SAS.Shared.AddIns Namespace


ISASTaskDataName2 Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataName2 Properties
ISASTaskDataName2 Interface See Also

The ISASTaskDataName2 type exposes the following members.

Properties

Name | Description
Cookie | A token that you can use to navigate back to this same data source again. (Inherited from ISASTaskDataName.)
DelimitedDisplayName | A tab delimited display name provided for display purpose only. The delimited name is in the form of [label]\[value]\t[label]\t[value]...\n
Label | Descriptive label for the data source. (Inherited from ISASTaskDataName.)
Library | SAS library name (libref) for the data source. (Inherited from ISASTaskDataName.)
LibraryName | SAS library name for the data source. This string is used for display purposes only and corresponds to a Library (libref).
Member | SAS member name for the data source. (Inherited from ISASTaskDataName.)
Server | SAS server where the data source resides. (Inherited from ISASTaskDataName.)
Source | Name of the data source. (Inherited from ISASTaskDataName.)
Type | Output data type. (Inherited from ISASTaskDataName.)

See Also

ISASTaskDataName2 Interface
SAS.Shared.AddIns Namespace


DelimitedDisplayName Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataName2..::.DelimitedDisplayName Property
ISASTaskDataName2 Interface See Also

A tab delimited display name provided for display purpose only. The delimited name is in the form of [label]\[value]\t[label]\t[value]...\n

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property DelimitedDisplayName As String
C#
string DelimitedDisplayName { get; }

See Also

ISASTaskDataName2 Interface
SAS.Shared.AddIns Namespace


LibraryName Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataName2..::.LibraryName Property
ISASTaskDataName2 Interface See Also

SAS library name for the data source. This string is used for display purposes only and corresponds to a Library (libref).

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property LibraryName As String
C#
string LibraryName { get; }

See Also

ISASTaskDataName2 Interface
SAS.Shared.AddIns Namespace


ISASTaskDataSink Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataSink Interface
Members See Also

Implemented by: Add-in task

Add-ins can optionally support this interface.

Supplies notifications to the add-in that the input data has changed, or that it needs to take some action regarding output data that it intends to create.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISASTaskDataSink
C#
public interface ISASTaskDataSink

Remarks

This is an optional interface for add-ins to implement.

See Also

ISASTaskDataSink Members
SAS.Shared.AddIns Namespace


ISASTaskDataSink Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataSink Members
ISASTaskDataSink Interface Methods See Also

The ISASTaskDataSink type exposes the following members.

Methods

Name | Description
ActiveDataChanged | Notifies the add-in that the active data (used as input to the add-in) has changed.
GenerateOutputData | Notifies the add-in it can generate output data.
GenerateOutputDataNames | Notifies the add-in that it needs to generate a new unique names for output data that it will create.

See Also

ISASTaskDataSink Interface
SAS.Shared.AddIns Namespace


ISASTaskDataSink Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataSink Methods
ISASTaskDataSink Interface See Also

The ISASTaskDataSink type exposes the following members.

Methods

Name | Description
ActiveDataChanged | Notifies the add-in that the active data (used as input to the add-in) has changed.
GenerateOutputData | Notifies the add-in it can generate output data.
GenerateOutputDataNames | Notifies the add-in that it needs to generate a new unique names for output data that it will create.

See Also

ISASTaskDataSink Interface
SAS.Shared.AddIns Namespace


ActiveDataChanged Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataSink..::.ActiveDataChanged Method
ISASTaskDataSink Interface See Also

Notifies the add-in that the active data (used as input to the add-in) has changed.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Sub ActiveDataChanged
C#
void ActiveDataChanged()

Remarks

ActiveDataChanged is called the very first time an instance of the add-in is invoked. If the add-in is invoked again, the ActiveDataChanged method is only called if the data associated with the task has changed.

When the active (input) data is changed, the add-in may need to adjust its behavior or SAS code generation to adjust for the characteristics of the new input data. This method provides the add-in with an opportunity to do that.

See Also

ISASTaskDataSink Interface
SAS.Shared.AddIns Namespace


GenerateOutputData Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataSink..::.GenerateOutputData Method
ISASTaskDataSink Interface See Also

Notifies the add-in it can generate output data.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function GenerateOutputData As Boolean
C#
bool GenerateOutputData()

Return Value

If GenerateOutputData returns false then OutputDataInfo is not called.

Remarks

In most cases the add-in will not need to generate its own output data results -- provided it is generating SAS code for processing, and the output data is a result of that code.

If the add-in does not utilize SAS code to generate output data, this routine is the proper place to create the data. The OutputDataInfo method is called immediately after this method.

See Also

ISASTaskDataSink Interface
SAS.Shared.AddIns Namespace
ISASTask..::.OutputDataInfo(Int32, String%, String%)


GenerateOutputDataNames Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataSink..::.GenerateOutputDataNames Method
ISASTaskDataSink Interface See Also

Notifies the add-in that it needs to generate a new unique names for output data that it will create.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Sub GenerateOutputDataNames ( _
    Index As Integer() _
)
C#
void GenerateOutputDataNames(
    int[] Index
)

Parameters

Index
Type: array< System..::.Int32 >[]()[]
The indices of the output data sets that should be affected. These indices map to the count and values returned in OutputDataCount and OutputDataInfo(Int32, String%, String%).

Remarks

GenerateOutputDataNames is only called when the task is invoked a second time and the user chooses not to replace results.

See Also

ISASTaskDataSink Interface
SAS.Shared.AddIns Namespace


ISASTaskDataSink2 Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataSink2 Interface
Members See Also

Implemented by: Add-in task

Allows the application to notify the add-in when the input data for the task has been changed.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISASTaskDataSink2 _
    Implements ISASTaskDataSink
C#
public interface ISASTaskDataSink2 : ISASTaskDataSink

Remarks

This is an optional interface for add-in tasks.

See Also

ISASTaskDataSink2 Members
SAS.Shared.AddIns Namespace


ISASTaskDataSink2 Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataSink2 Members
ISASTaskDataSink2 Interface Methods See Also

The ISASTaskDataSink2 type exposes the following members.

Methods

Name | Description
ActiveDataChanged | Notifies the add-in that the active data (used as input to the add-in) has changed. (Inherited from ISASTaskDataSink.)
GenerateOutputData | Notifies the add-in it can generate output data. (Inherited from ISASTaskDataSink.)
GenerateOutputDataNames | Notifies the add-in that it needs to generate a new unique names for output data that it will create. (Inherited from ISASTaskDataSink.)
InputDataChanged | Notifies the add-in that the input data (used as input to the add-in) has changed.

See Also

ISASTaskDataSink2 Interface
SAS.Shared.AddIns Namespace


ISASTaskDataSink2 Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataSink2 Methods
ISASTaskDataSink2 Interface See Also

The ISASTaskDataSink2 type exposes the following members.

Methods

Name | Description
ActiveDataChanged | Notifies the add-in that the active data (used as input to the add-in) has changed. (Inherited from ISASTaskDataSink.)
GenerateOutputData | Notifies the add-in it can generate output data. (Inherited from ISASTaskDataSink.)
GenerateOutputDataNames | Notifies the add-in that it needs to generate a new unique names for output data that it will create. (Inherited from ISASTaskDataSink.)
InputDataChanged | Notifies the add-in that the input data (used as input to the add-in) has changed.

See Also

ISASTaskDataSink2 Interface
SAS.Shared.AddIns Namespace


InputDataChanged Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDataSink2..::.InputDataChanged Method
ISASTaskDataSink2 Interface See Also

Notifies the add-in that the input data (used as input to the add-in) has changed.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Sub InputDataChanged
C#
void InputDataChanged()

Remarks

InputDataChanged is called the very first time an instance of the add-in is invoked. If the add-in is invoked again, the InputDataChanged method is only called if any of the data associated with the task has changed.

When the active (input collection) data is changed, the add-in may need to adjust its behavior or SAS code generation to adjust for the characteristics of the new input data. This method provides the add-in with an opportunity to do that.

See Also

ISASTaskDataSink2 Interface
SAS.Shared.AddIns Namespace


ISASTaskDescription Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDescription Interface
Members See Also

Implemented by: Add-in task

Add-ins are required to support this interface.

This interface is used by the application to determine basic task information which is not dependent on the task state.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
<GuidAttribute("F0A35D5D-8A0E-449b-B880-2F9E4645A002")> _
Public Interface ISASTaskDescription
C#
[GuidAttribute("F0A35D5D-8A0E-449b-B880-2F9E4645A002")]
public interface ISASTaskDescription

Remarks

This interface or ISASTaskDescription2 is required. An add-in must implement either this interface or ISASTaskDescription2 in order for the application to recognize it as a valid add-in.

See Also

ISASTaskDescription Members
SAS.Shared.AddIns Namespace
SAS.Shared.AddIns..::.ISASTask
SAS.Shared.AddIns..::.ISASTaskAddIn


ISASTaskDescription Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDescription Members
ISASTaskDescription Interface Properties See Also

The ISASTaskDescription type exposes the following members.

Properties

Name | Description
Clsid | A unique identifier in GUID format. Each add-in must supply a unique Clsid.
FriendlyName | Name used when constructing an instance of the add-in.
GeneratesListOutput | Indicates whether this add-in creates SAS ODS results.
GeneratesSasCode | Whether this add-in generates SAS program code.
IconAssembly | The name of the .NET assembly that contains the add-in icon.
IconName | The name of the add-in icon resource.
MajorVersion | The major version number for this add-in. This is shown in the Task by Name window within SAS Enterprise Guide.
MinorVersion | The minor version number for this add-in. This is shown in the Task by Name window within SAS Enterprise Guide.
NumericColsRequired | Indicates how many analysis variables (numeric) are required in the input data for the add-in to run.
ProcsUsed | List of SAS procedures used by this add-in.
ProductsOptional | SAS products that are optional on the server to use this add-in.
ProductsRequired | SAS products that required on the server to use this add-in.
RequiresData | Indicates whether the add-in requires one or more input data sets to operate.
StandardCategory | Indicates whether the category is a standard SAS-supplied category
TaskCategory | The name of the category for this add-in.
TaskDescription | A short description of the add-in's function or purpose.
TaskName | The add-in name as shown in the application menus and task list.
TaskType | This property is reserved for future use.
Validation | The validation status associated with this add-in.
WhatIsDescription | A detailed description of the function and role of the add-in.

See Also

ISASTaskDescription Interface
SAS.Shared.AddIns Namespace


ISASTaskDescription Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDescription Properties
ISASTaskDescription Interface See Also

The ISASTaskDescription type exposes the following members.

Properties

Name | Description
Clsid | A unique identifier in GUID format. Each add-in must supply a unique Clsid.
FriendlyName | Name used when constructing an instance of the add-in.
GeneratesListOutput | Indicates whether this add-in creates SAS ODS results.
GeneratesSasCode | Whether this add-in generates SAS program code.
IconAssembly | The name of the .NET assembly that contains the add-in icon.
IconName | The name of the add-in icon resource.
MajorVersion | The major version number for this add-in. This is shown in the Task by Name window within SAS Enterprise Guide.
MinorVersion | The minor version number for this add-in. This is shown in the Task by Name window within SAS Enterprise Guide.
NumericColsRequired | Indicates how many analysis variables (numeric) are required in the input data for the add-in to run.
ProcsUsed | List of SAS procedures used by this add-in.
ProductsOptional | SAS products that are optional on the server to use this add-in.
ProductsRequired | SAS products that required on the server to use this add-in.
RequiresData | Indicates whether the add-in requires one or more input data sets to operate.
StandardCategory | Indicates whether the category is a standard SAS-supplied category
TaskCategory | The name of the category for this add-in.
TaskDescription | A short description of the add-in's function or purpose.
TaskName | The add-in name as shown in the application menus and task list.
TaskType | This property is reserved for future use.
Validation | The validation status associated with this add-in.
WhatIsDescription | A detailed description of the function and role of the add-in.

See Also

ISASTaskDescription Interface
SAS.Shared.AddIns Namespace


Clsid Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDescription..::.Clsid Property
ISASTaskDescription Interface Example See Also

A unique identifier in GUID format. Each add-in must supply a unique Clsid.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Clsid As String
C#
string Clsid { get; }

Field Value

The GUID value.

Remarks

You can use the Microsoft SDK tool uuidgen to generate a GUID for your add-in.

Examples

The following is an example of using the uuidgen tool to create a GUID, which you can then copy and paste into your add-in code.
Copy Code
            C:\>uuidgen
            373e7b08-891f-4aa9-bd34-da00521a8302

Here is an example implementation using the above GUID.

Copy Code
            public string Clsid
            {
                get
                {
                    return "373e7b08-891f-4aa9-bd34-da00521a830";
                }
            }

See Also

ISASTaskDescription Interface
SAS.Shared.AddIns Namespace


FriendlyName Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDescription..::.FriendlyName Property
ISASTaskDescription Interface Example See Also

Name used when constructing an instance of the add-in.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property FriendlyName As String
C#
string FriendlyName { get; }

Field Value

Text of the friendly name.

Remarks

The friendly name used as part of the default label for the add-in in a project. The application might use the friendly name to construct a meaningful label for an instance of a task that the end user runs.

Examples

If you have an add-in that creates a sales report, you might use Sales Report as the FriendlyName. When the end user uses this add-in in a project against a particular data set, the application will create a label that incorporates the data set name. For example: Sales Report for June2004.

See Also

ISASTaskDescription Interface
SAS.Shared.AddIns Namespace


GeneratesListOutput Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDescription..::.GeneratesListOutput Property
ISASTaskDescription Interface See Also

Indicates whether this add-in creates SAS ODS results.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property GeneratesListOutput As Boolean
C#
bool GeneratesListOutput { get; }

Remarks

If your add-in generates SAS code that will result in SAS ODS output (for example, PROC PRINT or PROC REPORT), return true for this property. This allows the application to retrieve the generated results as appropriate.

See Also

ISASTaskDescription Interface
SAS.Shared.AddIns Namespace


GeneratesSasCode Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDescription..::.GeneratesSasCode Property
ISASTaskDescription Interface See Also

Whether this add-in generates SAS program code.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property GeneratesSasCode As Boolean
C#
bool GeneratesSasCode { get; }

Field Value

true if the add-in generates SAS program code, else false.

Remarks

Return true if the purpose of this add-in is to generate SAS program code that the application will then submit to a SAS server.

See Also

ISASTaskDescription Interface
SAS.Shared.AddIns Namespace


IconAssembly Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDescription..::.IconAssembly Property
ISASTaskDescription Interface Example See Also

The name of the .NET assembly that contains the add-in icon.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IconAssembly As String
C#
string IconAssembly { get; }

Field Value

The name of the .NET assembly that contains the icon. This assembly should be located in the same directory path as the add-in assembly.

Remarks

Examples

The following is an example of how to return the name of the current assembly -- that is, the assembly that actually implements the add-in interfaces.
Copy Code
            public string IconAssembly
            {
                get
                {
                    // return the full path/name of this assembly
                    return System.Reflection.Assembly.GetExecutingAssembly().Location;
                }
            }

See Also

ISASTaskDescription Interface
SAS.Shared.AddIns Namespace
ISASTaskDescription..::.IconName


IconName Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDescription..::.IconName Property
ISASTaskDescription Interface See Also

The name of the add-in icon resource.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IconName As String
C#
string IconName { get; }

Field Value

The name of the icon resource within the specified IconAssembly.

Remarks

See Also

ISASTaskDescription Interface
SAS.Shared.AddIns Namespace
ISASTaskDescription..::.IconAssembly


MajorVersion Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDescription..::.MajorVersion Property
ISASTaskDescription Interface See Also

The major version number for this add-in. This is shown in the Task by Name window within SAS Enterprise Guide.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property MajorVersion As Integer
C#
int MajorVersion { get; }

Field Value

The major version number.

Remarks

Use this in conjunction with the ISASTaskDescription.MinorVersion property.

See Also

ISASTaskDescription Interface
SAS.Shared.AddIns Namespace
ISASTaskDescription..::.MinorVersion


MinorVersion Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDescription..::.MinorVersion Property
ISASTaskDescription Interface See Also

The minor version number for this add-in. This is shown in the Task by Name window within SAS Enterprise Guide.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property MinorVersion As Integer
C#
int MinorVersion { get; }

Field Value

The minor version number.

Remarks

Use this in conjunction with the ISASTaskDescription.MajorVersion property.

See Also

ISASTaskDescription Interface
SAS.Shared.AddIns Namespace
ISASTaskDescription..::.MajorVersion


NumericColsRequired Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDescription..::.NumericColsRequired Property
ISASTaskDescription Interface See Also

Indicates how many analysis variables (numeric) are required in the input data for the add-in to run.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property NumericColsRequired As Integer
C#
int NumericColsRequired { get; }

Field Value

The number of numeric variables required.

Remarks

Some add-ins that perform analysis tasks may require one or more numeric variables within the input data in order to work correctly. The application may use this property to prequalify the input data (before invoking the add-in) to make sure the data meets the requirements.

See Also

ISASTaskDescription Interface
SAS.Shared.AddIns Namespace
ISASTaskDescription..::.RequiresData


ProcsUsed Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDescription..::.ProcsUsed Property
ISASTaskDescription Interface Example See Also

List of SAS procedures used by this add-in.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ProcsUsed As String
C#
string ProcsUsed { get; }

Field Value

A list of SAS procedures separated by semicolons.

Remarks

If this add-in generates SAS program code, you can use this property to surface metadata about which SAS procedures are used within that code. The application may show this information in the list of tasks and add-ins that are available.

Examples

Copy Code
            REPORT;GPLOT

See Also

ISASTaskDescription Interface
SAS.Shared.AddIns Namespace


ProductsOptional Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDescription..::.ProductsOptional Property
ISASTaskDescription Interface Example See Also

SAS products that are optional on the server to use this add-in.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ProductsOptional As String
C#
string ProductsOptional { get; }

Field Value

A list of optional SAS products separated by semicolons.

Remarks

If this add-in generates SAS program code, you can use this property to surface metadata about which SAS products are optional for that code to work properly. The application may show this information in the list of tasks and add-ins that are available.

Examples

Copy Code
            QC; ETS

See Also

ISASTaskDescription Interface
SAS.Shared.AddIns Namespace
ISASTaskDescription..::.ProductsRequired


ProductsRequired Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDescription..::.ProductsRequired Property
ISASTaskDescription Interface Example See Also

SAS products that required on the server to use this add-in.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ProductsRequired As String
C#
string ProductsRequired { get; }

Field Value

A list of required SAS products separated by semicolons.

Remarks

If this add-in generates SAS program code, you can use this property to surface metadata about which SAS products are required for that code to work properly. The application may show this information in the list of tasks and add-ins that are available.

Examples

Copy Code
            BASE; STAT; GRAPH

See Also

ISASTaskDescription Interface
SAS.Shared.AddIns Namespace
ISASTaskDescription..::.ProductsOptional


RequiresData Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDescription..::.RequiresData Property
ISASTaskDescription Interface See Also

Indicates whether the add-in requires one or more input data sets to operate.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property RequiresData As Boolean
C#
bool RequiresData { get; }

Field Value

true if the add-in requires data, else false.

Remarks

Beginning with the 4.2 release, this property is superceded by the InputRequiredAttribute. You can indicate whether your task requires input, and what type of input, using this attribute. If the attribute is not used, then this RequiresData property will be examined instead.

Usage: Return true if your add-in requires input data. The application can then ensure that input data is selected before the add-in is invoked. If the add-in requires a minimum number of numeric variables within the input data, return that number in ISASTaskDescription.NumericColsRequired.

See Also

ISASTaskDescription Interface
SAS.Shared.AddIns Namespace
ISASTaskDescription..::.NumericColsRequired


StandardCategory Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDescription..::.StandardCategory Property
ISASTaskDescription Interface See Also

Indicates whether the category is a standard SAS-supplied category

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property StandardCategory As Boolean
C#
bool StandardCategory { get; }

Remarks

This property is for SAS internal use only.

See Also

ISASTaskDescription Interface
SAS.Shared.AddIns Namespace


TaskCategory Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDescription..::.TaskCategory Property
ISASTaskDescription Interface See Also

The name of the category for this add-in.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property TaskCategory As String
C#
string TaskCategory { get; }

Field Value

The text category for this add-in.

Remarks

The application can use the supplied category to group the add-in and built-in tasks together, as appropriate.

See Also

ISASTaskDescription Interface
SAS.Shared.AddIns Namespace


TaskDescription Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDescription..::.TaskDescription Property
ISASTaskDescription Interface See Also

A short description of the add-in's function or purpose.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property TaskDescription As String
C#
string TaskDescription { get; }

Field Value

The text description of the add-in.

Remarks

The application can use this description in the status area when the end user selects the add-in from a menu.

See Also

ISASTaskDescription Interface
SAS.Shared.AddIns Namespace


TaskName Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDescription..::.TaskName Property
ISASTaskDescription Interface See Also

The add-in name as shown in the application menus and task list.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property TaskName As String
C#
string TaskName { get; }

Field Value

The name of the add-in.

See Also

ISASTaskDescription Interface
SAS.Shared.AddIns Namespace


TaskType Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDescription..::.TaskType Property
ISASTaskDescription Interface See Also

This property is reserved for future use.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property TaskType As ShowType
C#
ShowType TaskType { get; }

Field Value

Add-ins should return a value of ShowType.Wizard.

See Also

ISASTaskDescription Interface
SAS.Shared.AddIns Namespace


Validation Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDescription..::.Validation Property
ISASTaskDescription Interface See Also

The validation status associated with this add-in.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Validation As String
C#
string Validation { get; }

Field Value

Text to use for Validation status.

Remarks

The validation status is metadata that you can associate with your add-in to indicate its readiness for use by your end users. For example, you might supply a Validation value of "test" or "production". The host application can show this status within the list of available tasks and add-ins.

See Also

ISASTaskDescription Interface
SAS.Shared.AddIns Namespace


WhatIsDescription Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDescription..::.WhatIsDescription Property
ISASTaskDescription Interface See Also

A detailed description of the function and role of the add-in.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property WhatIsDescription As String
C#
string WhatIsDescription { get; }

Field Value

Text that contains the detailed description. You can use "\r\n" characters within the text to control line and paragraph breaks.

Remarks

The application may surface this information in a detailed help window (such as the What Is... window in SAS Enterprise Guide).

See Also

ISASTaskDescription Interface
SAS.Shared.AddIns Namespace


ISASTaskDescription2 Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDescription2 Interface
Members See Also

Implemented by: Add-in task

This interface provides features in addition to everything in ISASTaskDescription. This interface is used by the application to determine basic task descriptive metadata.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISASTaskDescription2 _
    Implements ISASTaskDescription
C#
public interface ISASTaskDescription2 : ISASTaskDescription

Remarks

This interface or ISASTaskDescription is required. An add-in must implement either this interface or ISASTaskDescriptionin order for the application to recognize it as a valid add-in.

See Also

ISASTaskDescription2 Members
SAS.Shared.AddIns Namespace
SAS.Shared.AddIns..::.ISASTask
SAS.Shared.AddIns..::.ISASTaskAddIn


ISASTaskDescription2 Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDescription2 Members
ISASTaskDescription2 Interface Properties See Also

The ISASTaskDescription2 type exposes the following members.

Properties

Name | Description
Clsid | A unique identifier in GUID format. Each add-in must supply a unique Clsid. (Inherited from ISASTaskDescription.)
FriendlyName | Name used when constructing an instance of the add-in. (Inherited from ISASTaskDescription.)
GeneratesListOutput | Indicates whether this add-in creates SAS ODS results. (Inherited from ISASTaskDescription.)
GeneratesSasCode | Whether this add-in generates SAS program code. (Inherited from ISASTaskDescription.)
IconAssembly | The name of the .NET assembly that contains the add-in icon. (Inherited from ISASTaskDescription.)
IconName | The name of the add-in icon resource. (Inherited from ISASTaskDescription.)
InitializeData | Indicates whether the add-in requests to be initialized with the active data but does not require active data to run. This is only important if the RequiresData property returns false, otherwise the add-in is always initialized with the active data.
MajorVersion | The major version number for this add-in. This is shown in the Task by Name window within SAS Enterprise Guide. (Inherited from ISASTaskDescription.)
MinorVersion | The minor version number for this add-in. This is shown in the Task by Name window within SAS Enterprise Guide. (Inherited from ISASTaskDescription.)
NumericColsRequired | Indicates how many analysis variables (numeric) are required in the input data for the add-in to run. (Inherited from ISASTaskDescription.)
ProcsUsed | List of SAS procedures used by this add-in. (Inherited from ISASTaskDescription.)
ProductsOptional | SAS products that are optional on the server to use this add-in. (Inherited from ISASTaskDescription.)
ProductsRequired | SAS products that required on the server to use this add-in. (Inherited from ISASTaskDescription.)
RequiresData | Indicates whether the add-in requires one or more input data sets to operate. (Inherited from ISASTaskDescription.)
StandardCategory | Indicates whether the category is a standard SAS-supplied category (Inherited from ISASTaskDescription.)
TaskCategory | The name of the category for this add-in. (Inherited from ISASTaskDescription.)
TaskDescription | A short description of the add-in's function or purpose. (Inherited from ISASTaskDescription.)
TaskName | The add-in name as shown in the application menus and task list. (Inherited from ISASTaskDescription.)
TaskType | This property is reserved for future use. (Inherited from ISASTaskDescription.)
Validation | The validation status associated with this add-in. (Inherited from ISASTaskDescription.)
ViewTypes | Gets a list of supported view types by the task.
WhatIsDescription | A detailed description of the function and role of the add-in. (Inherited from ISASTaskDescription.)
WizardName | The add-in name as shown in the application menus and task list.

See Also

ISASTaskDescription2 Interface
SAS.Shared.AddIns Namespace


ISASTaskDescription2 Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDescription2 Properties
ISASTaskDescription2 Interface See Also

The ISASTaskDescription2 type exposes the following members.

Properties

Name | Description
Clsid | A unique identifier in GUID format. Each add-in must supply a unique Clsid. (Inherited from ISASTaskDescription.)
FriendlyName | Name used when constructing an instance of the add-in. (Inherited from ISASTaskDescription.)
GeneratesListOutput | Indicates whether this add-in creates SAS ODS results. (Inherited from ISASTaskDescription.)
GeneratesSasCode | Whether this add-in generates SAS program code. (Inherited from ISASTaskDescription.)
IconAssembly | The name of the .NET assembly that contains the add-in icon. (Inherited from ISASTaskDescription.)
IconName | The name of the add-in icon resource. (Inherited from ISASTaskDescription.)
InitializeData | Indicates whether the add-in requests to be initialized with the active data but does not require active data to run. This is only important if the RequiresData property returns false, otherwise the add-in is always initialized with the active data.
MajorVersion | The major version number for this add-in. This is shown in the Task by Name window within SAS Enterprise Guide. (Inherited from ISASTaskDescription.)
MinorVersion | The minor version number for this add-in. This is shown in the Task by Name window within SAS Enterprise Guide. (Inherited from ISASTaskDescription.)
NumericColsRequired | Indicates how many analysis variables (numeric) are required in the input data for the add-in to run. (Inherited from ISASTaskDescription.)
ProcsUsed | List of SAS procedures used by this add-in. (Inherited from ISASTaskDescription.)
ProductsOptional | SAS products that are optional on the server to use this add-in. (Inherited from ISASTaskDescription.)
ProductsRequired | SAS products that required on the server to use this add-in. (Inherited from ISASTaskDescription.)
RequiresData | Indicates whether the add-in requires one or more input data sets to operate. (Inherited from ISASTaskDescription.)
StandardCategory | Indicates whether the category is a standard SAS-supplied category (Inherited from ISASTaskDescription.)
TaskCategory | The name of the category for this add-in. (Inherited from ISASTaskDescription.)
TaskDescription | A short description of the add-in's function or purpose. (Inherited from ISASTaskDescription.)
TaskName | The add-in name as shown in the application menus and task list. (Inherited from ISASTaskDescription.)
TaskType | This property is reserved for future use. (Inherited from ISASTaskDescription.)
Validation | The validation status associated with this add-in. (Inherited from ISASTaskDescription.)
ViewTypes | Gets a list of supported view types by the task.
WhatIsDescription | A detailed description of the function and role of the add-in. (Inherited from ISASTaskDescription.)
WizardName | The add-in name as shown in the application menus and task list.

See Also

ISASTaskDescription2 Interface
SAS.Shared.AddIns Namespace


InitializeData Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDescription2..::.InitializeData Property
ISASTaskDescription2 Interface See Also

Indicates whether the add-in requests to be initialized with the active data but does not require active data to run. This is only important if the RequiresData property returns false, otherwise the add-in is always initialized with the active data.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property InitializeData As Boolean
C#
bool InitializeData { get; }

Remarks

Return true if you want your add-in initialze with the current active data. The application will not prompt for input data. If there is not any input data currently in the project, the add-in should simply load without input data.

See Also

ISASTaskDescription2 Interface
SAS.Shared.AddIns Namespace


ViewTypes Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDescription2..::.ViewTypes Property
ISASTaskDescription2 Interface See Also

Gets a list of supported view types by the task.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ViewTypes As ViewType()
C#
ViewType[] ViewTypes { get; }

See Also

ISASTaskDescription2 Interface
SAS.Shared.AddIns Namespace


WizardName Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDescription2..::.WizardName Property
ISASTaskDescription2 Interface See Also

The add-in name as shown in the application menus and task list.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property WizardName As String
C#
string WizardName { get; }

Field Value

The name of the add-in wizard if the add-in supports the wizard view type.

See Also

ISASTaskDescription2 Interface
SAS.Shared.AddIns Namespace


ISASTaskDisplay Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDisplay Interface
Members See Also

This interface is for use by SAS applications and is not intended for use by SAS customers.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISASTaskDisplay
C#
public interface ISASTaskDisplay

Remarks

This interface is not documented for customer use.

See Also

ISASTaskDisplay Members
SAS.Shared.AddIns Namespace


ISASTaskDisplay Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDisplay Members
ISASTaskDisplay Interface Properties See Also

The ISASTaskDisplay type exposes the following members.

Properties

Name | Description
CodePreviewVisible | Not documented for customer use.
CodePreviewWindowHeight | Not documented for customer use.
CodePreviewWindowLeft | Not documented for customer use.
CodePreviewWindowTop | Not documented for customer use.
CodePreviewWindowWidth | Not documented for customer use.
TaskWindowHeight | Not documented for customer use.
TaskWindowLeft | Not documented for customer use.
TaskWindowTop | Not documented for customer use.
TaskWindowWidth | Not documented for customer use.

See Also

ISASTaskDisplay Interface
SAS.Shared.AddIns Namespace


ISASTaskDisplay Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDisplay Properties
ISASTaskDisplay Interface See Also

The ISASTaskDisplay type exposes the following members.

Properties

Name | Description
CodePreviewVisible | Not documented for customer use.
CodePreviewWindowHeight | Not documented for customer use.
CodePreviewWindowLeft | Not documented for customer use.
CodePreviewWindowTop | Not documented for customer use.
CodePreviewWindowWidth | Not documented for customer use.
TaskWindowHeight | Not documented for customer use.
TaskWindowLeft | Not documented for customer use.
TaskWindowTop | Not documented for customer use.
TaskWindowWidth | Not documented for customer use.

See Also

ISASTaskDisplay Interface
SAS.Shared.AddIns Namespace


CodePreviewVisible Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDisplay..::.CodePreviewVisible Property
ISASTaskDisplay Interface See Also

Not documented for customer use.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Property CodePreviewVisible As Boolean
C#
bool CodePreviewVisible { get; set; }

Field Value

Not documented for customer use.

See Also

ISASTaskDisplay Interface
SAS.Shared.AddIns Namespace


CodePreviewWindowHeight Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDisplay..::.CodePreviewWindowHeight Property
ISASTaskDisplay Interface See Also

Not documented for customer use.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Property CodePreviewWindowHeight As Integer
C#
int CodePreviewWindowHeight { get; set; }

Field Value

Not documented for customer use.

See Also

ISASTaskDisplay Interface
SAS.Shared.AddIns Namespace


CodePreviewWindowLeft Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDisplay..::.CodePreviewWindowLeft Property
ISASTaskDisplay Interface See Also

Not documented for customer use.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Property CodePreviewWindowLeft As Integer
C#
int CodePreviewWindowLeft { get; set; }

Field Value

Not documented for customer use.

See Also

ISASTaskDisplay Interface
SAS.Shared.AddIns Namespace


CodePreviewWindowTop Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDisplay..::.CodePreviewWindowTop Property
ISASTaskDisplay Interface See Also

Not documented for customer use.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Property CodePreviewWindowTop As Integer
C#
int CodePreviewWindowTop { get; set; }

Field Value

Not documented for customer use.

See Also

ISASTaskDisplay Interface
SAS.Shared.AddIns Namespace


CodePreviewWindowWidth Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDisplay..::.CodePreviewWindowWidth Property
ISASTaskDisplay Interface See Also

Not documented for customer use.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Property CodePreviewWindowWidth As Integer
C#
int CodePreviewWindowWidth { get; set; }

Field Value

Not documented for customer use.

See Also

ISASTaskDisplay Interface
SAS.Shared.AddIns Namespace


TaskWindowHeight Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDisplay..::.TaskWindowHeight Property
ISASTaskDisplay Interface See Also

Not documented for customer use.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Property TaskWindowHeight As Integer
C#
int TaskWindowHeight { get; set; }

Field Value

Not documented for customer use.

See Also

ISASTaskDisplay Interface
SAS.Shared.AddIns Namespace


TaskWindowLeft Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDisplay..::.TaskWindowLeft Property
ISASTaskDisplay Interface See Also

Not documented for customer use.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Property TaskWindowLeft As Integer
C#
int TaskWindowLeft { get; set; }

Field Value

Not documented for customer use.

See Also

ISASTaskDisplay Interface
SAS.Shared.AddIns Namespace


TaskWindowTop Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDisplay..::.TaskWindowTop Property
ISASTaskDisplay Interface See Also

Not documented for customer use.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Property TaskWindowTop As Integer
C#
int TaskWindowTop { get; set; }

Field Value

Not documented for customer use.

See Also

ISASTaskDisplay Interface
SAS.Shared.AddIns Namespace


TaskWindowWidth Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDisplay..::.TaskWindowWidth Property
ISASTaskDisplay Interface See Also

Not documented for customer use.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Property TaskWindowWidth As Integer
C#
int TaskWindowWidth { get; set; }

Field Value

Not documented for customer use.

See Also

ISASTaskDisplay Interface
SAS.Shared.AddIns Namespace


ISASTaskDisplay2 Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDisplay2 Interface
Members See Also

This interface is for use by SAS applications and is not intended for use by SAS customers.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISASTaskDisplay2 _
    Implements ISASTaskDisplay
C#
public interface ISASTaskDisplay2 : ISASTaskDisplay

Remarks

This interface is not documented for customer use.

See Also

ISASTaskDisplay2 Members
SAS.Shared.AddIns Namespace


ISASTaskDisplay2 Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDisplay2 Members
ISASTaskDisplay2 Interface Properties See Also

The ISASTaskDisplay2 type exposes the following members.

Properties

Name | Description
CodePreviewEnabled | Not documented for customer use.
CodePreviewVisible | Not documented for customer use. (Inherited from ISASTaskDisplay.)
CodePreviewWindowHeight | Not documented for customer use. (Inherited from ISASTaskDisplay.)
CodePreviewWindowLeft | Not documented for customer use. (Inherited from ISASTaskDisplay.)
CodePreviewWindowTop | Not documented for customer use. (Inherited from ISASTaskDisplay.)
CodePreviewWindowWidth | Not documented for customer use. (Inherited from ISASTaskDisplay.)
TaskWindowHeight | Not documented for customer use. (Inherited from ISASTaskDisplay.)
TaskWindowLeft | Not documented for customer use. (Inherited from ISASTaskDisplay.)
TaskWindowStartPosition | Not documented for customer use.
TaskWindowTop | Not documented for customer use. (Inherited from ISASTaskDisplay.)
TaskWindowWidth | Not documented for customer use. (Inherited from ISASTaskDisplay.)

See Also

ISASTaskDisplay2 Interface
SAS.Shared.AddIns Namespace


ISASTaskDisplay2 Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDisplay2 Properties
ISASTaskDisplay2 Interface See Also

The ISASTaskDisplay2 type exposes the following members.

Properties

Name | Description
CodePreviewEnabled | Not documented for customer use.
CodePreviewVisible | Not documented for customer use. (Inherited from ISASTaskDisplay.)
CodePreviewWindowHeight | Not documented for customer use. (Inherited from ISASTaskDisplay.)
CodePreviewWindowLeft | Not documented for customer use. (Inherited from ISASTaskDisplay.)
CodePreviewWindowTop | Not documented for customer use. (Inherited from ISASTaskDisplay.)
CodePreviewWindowWidth | Not documented for customer use. (Inherited from ISASTaskDisplay.)
TaskWindowHeight | Not documented for customer use. (Inherited from ISASTaskDisplay.)
TaskWindowLeft | Not documented for customer use. (Inherited from ISASTaskDisplay.)
TaskWindowStartPosition | Not documented for customer use.
TaskWindowTop | Not documented for customer use. (Inherited from ISASTaskDisplay.)
TaskWindowWidth | Not documented for customer use. (Inherited from ISASTaskDisplay.)

See Also

ISASTaskDisplay2 Interface
SAS.Shared.AddIns Namespace


CodePreviewEnabled Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDisplay2..::.CodePreviewEnabled Property
ISASTaskDisplay2 Interface See Also

Not documented for customer use.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property CodePreviewEnabled As Boolean
C#
bool CodePreviewEnabled { get; }

See Also

ISASTaskDisplay2 Interface
SAS.Shared.AddIns Namespace


TaskWindowStartPosition Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskDisplay2..::.TaskWindowStartPosition Property
ISASTaskDisplay2 Interface See Also

Not documented for customer use.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property TaskWindowStartPosition As WindowStartPosition
C#
WindowStartPosition TaskWindowStartPosition { get; }

See Also

ISASTaskDisplay2 Interface
SAS.Shared.AddIns Namespace


ISASTaskExecution Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskExecution Interface
Members See Also

Implemented by: Add-in task

Add-ins can optionally support this interface.

This interface is used by the application to control the runtime execution of an add-in when the GeneratesSasCode property is false.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISASTaskExecution
C#
public interface ISASTaskExecution

Remarks

An add-in can implement this interface if it returns false for GeneratesSasCode. The ISASTaskExecution2 interface extends this interface to add support for a StatusChanged event.

See Also

ISASTaskExecution Members
SAS.Shared.AddIns Namespace
SAS.Shared.AddIns..::.ISASTaskDescription
SAS.Shared.AddIns..::.ISASTaskExecution2


ISASTaskExecution Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskExecution Members
ISASTaskExecution Interface Methods Properties See Also

The ISASTaskExecution type exposes the following members.

Methods

Name | Description
Cancel | For tasks that do not generate SAS code but instead perform some other work, this method triggers cancel of the execution. The method is only called if the GeneratesSasCode property is false.
OpenResultStream | Open a result stream for reading.
Run | For tasks that do not generate SAS code but instead perform some other work, this method executes. The method is only called if the GeneratesSasCode property is false.

Properties

Name | Description
ResultCount | Get the number of results items created by the task.

See Also

ISASTaskExecution Interface
SAS.Shared.AddIns Namespace


ISASTaskExecution Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskExecution Methods
ISASTaskExecution Interface See Also

The ISASTaskExecution type exposes the following members.

Methods

Name | Description
Cancel | For tasks that do not generate SAS code but instead perform some other work, this method triggers cancel of the execution. The method is only called if the GeneratesSasCode property is false.
OpenResultStream | Open a result stream for reading.
Run | For tasks that do not generate SAS code but instead perform some other work, this method executes. The method is only called if the GeneratesSasCode property is false.

See Also

ISASTaskExecution Interface
SAS.Shared.AddIns Namespace


Cancel Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskExecution..::.Cancel Method
ISASTaskExecution Interface See Also

For tasks that do not generate SAS code but instead perform some other work, this method triggers cancel of the execution. The method is only called if the GeneratesSasCode property is false.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function Cancel As Boolean
C#
bool Cancel()

Return Value

true if successfully cancelled execution of work

See Also

ISASTaskExecution Interface
SAS.Shared.AddIns Namespace


OpenResultStream Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskExecution..::.OpenResultStream Method
ISASTaskExecution Interface See Also

Open a result stream for reading.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function OpenResultStream ( _
    Index As Integer _
) As ISASTaskStream
C#
ISASTaskStream OpenResultStream(
    int Index
)

Parameters

Index
Type: System..::.Int32
The Index is a zero-based index of the ISASTaskStream desired.

Return Value

An open ISASTaskStream to read the results from.

Remarks

For tasks that do not generate SAS code, but instead perform some other work, this property returns the number of custom results that were created. The method is only called if the GeneratesSasCode property is false.

See Also

ISASTaskExecution Interface
SAS.Shared.AddIns Namespace


Run Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskExecution..::.Run Method
ISASTaskExecution Interface See Also

For tasks that do not generate SAS code but instead perform some other work, this method executes. The method is only called if the GeneratesSasCode property is false.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function Run ( _
    LogWriter As ISASTaskTextWriter _
) As RunStatus
C#
RunStatus Run(
    ISASTaskTextWriter LogWriter
)

Parameters

LogWriter
Type: SAS.Shared.AddIns..::.ISASTaskTextWriter
A handle to the ISASTaskTextWriter object, used to populate the text of the log.

Return Value

true if successfully completed work

Remarks

When writing to the log, the implementor can write to the log as the task runs. When writing to the log, only complete lines should be written (no partial lines).

See Also

ISASTaskExecution Interface
SAS.Shared.AddIns Namespace


ISASTaskExecution Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskExecution Properties
ISASTaskExecution Interface See Also

The ISASTaskExecution type exposes the following members.

Properties

Name | Description
ResultCount | Get the number of results items created by the task.

See Also

ISASTaskExecution Interface
SAS.Shared.AddIns Namespace


ResultCount Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskExecution..::.ResultCount Property
ISASTaskExecution Interface See Also

Get the number of results items created by the task.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ResultCount As Integer
C#
int ResultCount { get; }

Field Value

The number of result streams actually available.

Remarks

For tasks that do not generate SAS code, but instead perform some other work, this property returns the number of custom results that were created. The method is only called if the GeneratesSasCode property is false.

See Also

ISASTaskExecution Interface
SAS.Shared.AddIns Namespace


ISASTaskExecution2 Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskExecution2 Interface
Members See Also

Implemented by: Add-in task

Add-ins can optionally support this interface.

This interface extends ISASTaskExecution to add support for a StatusChanged event. With the StatusChanged event, a task can update the status while running, and the status will be reflected in the application task status window.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISASTaskExecution2 _
    Implements ISASTaskExecution
C#
public interface ISASTaskExecution2 : ISASTaskExecution

Remarks

An add-in can implement this interface if it returns false for GeneratesSasCode.

See Also

ISASTaskExecution2 Members
SAS.Shared.AddIns Namespace
SAS.Shared.AddIns..::.ISASTaskDescription


ISASTaskExecution2 Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskExecution2 Members
ISASTaskExecution2 Interface Methods Properties Events See Also

The ISASTaskExecution2 type exposes the following members.

Methods

Name | Description
Cancel | For tasks that do not generate SAS code but instead perform some other work, this method triggers cancel of the execution. The method is only called if the GeneratesSasCode property is false. (Inherited from ISASTaskExecution.)
OpenResultStream | Open a result stream for reading. (Inherited from ISASTaskExecution.)
Run | For tasks that do not generate SAS code but instead perform some other work, this method executes. The method is only called if the GeneratesSasCode property is false. (Inherited from ISASTaskExecution.)

Properties

Name | Description
ResultCount | Get the number of results items created by the task. (Inherited from ISASTaskExecution.)

Events

Name | Description
StatusChanged | Event to raise when the task has a status message to convey to the application during runtime.

See Also

ISASTaskExecution2 Interface
SAS.Shared.AddIns Namespace


ISASTaskExecution2 Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskExecution2 Methods
ISASTaskExecution2 Interface See Also

The ISASTaskExecution2 type exposes the following members.

Methods

Name | Description
Cancel | For tasks that do not generate SAS code but instead perform some other work, this method triggers cancel of the execution. The method is only called if the GeneratesSasCode property is false. (Inherited from ISASTaskExecution.)
OpenResultStream | Open a result stream for reading. (Inherited from ISASTaskExecution.)
Run | For tasks that do not generate SAS code but instead perform some other work, this method executes. The method is only called if the GeneratesSasCode property is false. (Inherited from ISASTaskExecution.)

See Also

ISASTaskExecution2 Interface
SAS.Shared.AddIns Namespace


ISASTaskExecution2 Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskExecution2 Properties
ISASTaskExecution2 Interface See Also

The ISASTaskExecution2 type exposes the following members.

Properties

Name | Description
ResultCount | Get the number of results items created by the task. (Inherited from ISASTaskExecution.)

See Also

ISASTaskExecution2 Interface
SAS.Shared.AddIns Namespace


ISASTaskExecution2 Events

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskExecution2 Events
ISASTaskExecution2 Interface See Also

The ISASTaskExecution2 type exposes the following members.

Events

Name | Description
StatusChanged | Event to raise when the task has a status message to convey to the application during runtime.

See Also

ISASTaskExecution2 Interface
SAS.Shared.AddIns Namespace


StatusChanged Event

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskExecution2..::.StatusChanged Event
ISASTaskExecution2 Interface Example See Also

Event to raise when the task has a status message to convey to the application during runtime.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Event StatusChanged As TaskExecutionStatusChangedHandler
C#
event TaskExecutionStatusChangedHandler StatusChanged

Examples

Here is an example of how you might implement this interface within your task. Note that when implementing a .NET event, you must implement the add and remove access methods.
Copy Code
             // private member to hold the event
            private event TaskExecutionStatusChangedHandler _statusChanged = null;

             // public event property for the application to subscribe to.
            public event TaskExecutionStatusChangedHandler StatusChanged
            {
                add
                {
                    _statusChanged += value;
                }
                remove
                {
                    _statusChanged -= value;
                }
            }
In the implementation of your Run(ISASTaskTextWriter) method, when you want to raise a StatusChanged event to indicate progress, your code might look something like this:
Copy Code
              if (_statusChanged != null)
                _statusChanged(this, new TaskExecutionStatusEventArgs(string.Format("Reading data file {0}", dataFile)));
Note that you should check for null before raising the event in case the application has not subscribed to it.

See Also

ISASTaskExecution2 Interface
SAS.Shared.AddIns Namespace


ISASTaskMigrator Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskMigrator Interface
Members Example See Also

This interface is implemented by the task to allow the application to perform various migration tasks. It is intended to be a light-weight mechanism to change references to resources, such as libraries and servers, when the project or document is migrated from one environment to another. It may be implemented by the same class that implements the ISASTask and ISASTaskDescription interfaces, or by a separate class (which are encapsulated in the SAS.Tasks.Toolkit.SasTask class). The TaskMigratorClassAttribute class property is used to indicate the assembly and type of the class that implements this interface.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISASTaskMigrator
C#
public interface ISASTaskMigrator

Examples

For example, to declare that a special task migrator class implements these methods, use this attribute:
Copy Code
             [SAS.Shared.AddIns.TaskMigratorClass("MyCustomTasks.dll","MyCustomTasks.CustomTask.TaskMigrator")]
                 public class CustomTask : SAS.Tasks.Toolkit.SasTask
              {
                // followed by custom task implementation
              }
Here is an example implementation of a class that supports ISASTaskMigrator:
Copy Code
             public class TaskMigrator : SAS.Shared.AddIns.ISASTaskMigrator
             {
              // keep track of the XmlState so that this class can modify it if needed.
              string _xmlState = "";
              public void ReplaceServerByName(string OldServerName, string NewServerName)
              {
              // replace any server references in _xmlState
              }

              public void ReplaceLibraryByName(string OldLibraryName, string NewLibraryName, string NewLibraryReference)
              {
                // replace any library name references in _xmlState
              }

              public void ReplaceLibraryReference(string OldLibraryReference, string NewLibraryName, string NewLibraryReference)
              {
                // replace any libref references in _xmlState
              }

              public string XmlState
              {
                  get { return _xmlState; }
                  set { _xmlState = value; }
              }
             }

See Also

ISASTaskMigrator Members
SAS.Shared.AddIns Namespace


ISASTaskMigrator Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskMigrator Members
ISASTaskMigrator Interface Methods Properties See Also

The ISASTaskMigrator type exposes the following members.

Methods

Name | Description
ReplaceLibraryByName | Replaces the library by its descriptive name.
ReplaceLibraryReference | Replaces the library by its libref (SAS syntax name).
ReplaceServerByName | Replaces the server by name.

Properties

Name | Description
XmlState | Sets and gets the XmlState of the task. This is the same XmlState supplied by the task via the XmlState property.

See Also

ISASTaskMigrator Interface
SAS.Shared.AddIns Namespace


ISASTaskMigrator Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskMigrator Methods
ISASTaskMigrator Interface See Also

The ISASTaskMigrator type exposes the following members.

Methods

Name | Description
ReplaceLibraryByName | Replaces the library by its descriptive name.
ReplaceLibraryReference | Replaces the library by its libref (SAS syntax name).
ReplaceServerByName | Replaces the server by name.

See Also

ISASTaskMigrator Interface
SAS.Shared.AddIns Namespace


ReplaceLibraryByName Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskMigrator..::.ReplaceLibraryByName Method
ISASTaskMigrator Interface See Also

Replaces the library by its descriptive name.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Sub ReplaceLibraryByName ( _
    OldLibraryName As String, _
    NewLibraryName As String, _
    NewLibraryReference As String _
)
C#
void ReplaceLibraryByName(
    string OldLibraryName,
    string NewLibraryName,
    string NewLibraryReference
)

Parameters

OldLibraryName
Type: System..::.String
The old library name
NewLibraryName
Type: System..::.String
The new library name
NewLibraryReference
Type: System..::.String
The libref itself. This is the value used when generating SAS code.

See Also

ISASTaskMigrator Interface
SAS.Shared.AddIns Namespace


ReplaceLibraryReference Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskMigrator..::.ReplaceLibraryReference Method
ISASTaskMigrator Interface See Also

Replaces the library by its libref (SAS syntax name).

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Sub ReplaceLibraryReference ( _
    OldLibraryReference As String, _
    NewLibraryName As String, _
    NewLibraryReference As String _
)
C#
void ReplaceLibraryReference(
    string OldLibraryReference,
    string NewLibraryName,
    string NewLibraryReference
)

Parameters

OldLibraryReference
Type: System..::.String
The old library reference
NewLibraryName
Type: System..::.String
The new library name
NewLibraryReference
Type: System..::.String
The libref itself. This is the value used when generating SAS code.

See Also

ISASTaskMigrator Interface
SAS.Shared.AddIns Namespace


ReplaceServerByName Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskMigrator..::.ReplaceServerByName Method
ISASTaskMigrator Interface See Also

Replaces the server by name.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Sub ReplaceServerByName ( _
    OldServerName As String, _
    NewServerName As String _
)
C#
void ReplaceServerByName(
    string OldServerName,
    string NewServerName
)

Parameters

OldServerName
Type: System..::.String
Old name of the server.
NewServerName
Type: System..::.String
New name of the server.

See Also

ISASTaskMigrator Interface
SAS.Shared.AddIns Namespace


ISASTaskMigrator Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskMigrator Properties
ISASTaskMigrator Interface See Also

The ISASTaskMigrator type exposes the following members.

Properties

Name | Description
XmlState | Sets and gets the XmlState of the task. This is the same XmlState supplied by the task via the XmlState property.

See Also

ISASTaskMigrator Interface
SAS.Shared.AddIns Namespace


XmlState Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskMigrator..::.XmlState Property
ISASTaskMigrator Interface See Also

Sets and gets the XmlState of the task. This is the same XmlState supplied by the task via the XmlState property.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Property XmlState As String
C#
string XmlState { get; set; }

See Also

ISASTaskMigrator Interface
SAS.Shared.AddIns Namespace


ISASTaskOptions Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskOptions Interface
Members See Also

Interface to surface values for the output/processing options specified for the current task

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISASTaskOptions
C#
public interface ISASTaskOptions

See Also

ISASTaskOptions Members
SAS.Shared.AddIns Namespace


ISASTaskOptions Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskOptions Members
ISASTaskOptions Interface Methods Properties See Also

The ISASTaskOptions type exposes the following members.

Methods

Name | Description
GetOdsSettings | Gets the collection of preferred ODS settings
SetOdsSettings | Set a collection of ODS settings on the current task

Properties

Name | Description
FirstObsSetting | The value for which observation (record) to start with. MinObs equates to MIN.
NObsSetting | The value for how many observations to process. MaxObs equates to MAX, or all.
PreferredGraphDevice | The value of the preferred graph device
UseApplicationDefaults | Whether to use the application default values for ODS and graph settings

See Also

ISASTaskOptions Interface
SAS.Shared.AddIns Namespace


ISASTaskOptions Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskOptions Methods
ISASTaskOptions Interface See Also

The ISASTaskOptions type exposes the following members.

Methods

Name | Description
GetOdsSettings | Gets the collection of preferred ODS settings
SetOdsSettings | Set a collection of ODS settings on the current task

See Also

ISASTaskOptions Interface
SAS.Shared.AddIns Namespace


GetOdsSettings Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskOptions..::.GetOdsSettings Method
ISASTaskOptions Interface See Also

Gets the collection of preferred ODS settings

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function GetOdsSettings As ISASOdsSettings()
C#
ISASOdsSettings[] GetOdsSettings()

Return Value

an array of ISASOdsSettings objects

See Also

ISASTaskOptions Interface
SAS.Shared.AddIns Namespace


SetOdsSettings Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskOptions..::.SetOdsSettings Method
ISASTaskOptions Interface See Also

Set a collection of ODS settings on the current task

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Sub SetOdsSettings ( _
    arrayOdsSettings As ISASOdsSettings() _
)
C#
void SetOdsSettings(
    ISASOdsSettings[] arrayOdsSettings
)

Parameters

arrayOdsSettings
Type: array< SAS.Shared.AddIns..::.ISASOdsSettings >[]()[]
an array of ISASOdsSettings objects

See Also

ISASTaskOptions Interface
SAS.Shared.AddIns Namespace


ISASTaskOptions Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskOptions Properties
ISASTaskOptions Interface See Also

The ISASTaskOptions type exposes the following members.

Properties

Name | Description
FirstObsSetting | The value for which observation (record) to start with. MinObs equates to MIN.
NObsSetting | The value for how many observations to process. MaxObs equates to MAX, or all.
PreferredGraphDevice | The value of the preferred graph device
UseApplicationDefaults | Whether to use the application default values for ODS and graph settings

See Also

ISASTaskOptions Interface
SAS.Shared.AddIns Namespace


FirstObsSetting Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskOptions..::.FirstObsSetting Property
ISASTaskOptions Interface See Also

The value for which observation (record) to start with. MinObs equates to MIN.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Property FirstObsSetting As Integer
C#
int FirstObsSetting { get; set; }

See Also

ISASTaskOptions Interface
SAS.Shared.AddIns Namespace


NObsSetting Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskOptions..::.NObsSetting Property
ISASTaskOptions Interface See Also

The value for how many observations to process. MaxObs equates to MAX, or all.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Property NObsSetting As Integer
C#
int NObsSetting { get; set; }

See Also

ISASTaskOptions Interface
SAS.Shared.AddIns Namespace


PreferredGraphDevice Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskOptions..::.PreferredGraphDevice Property
ISASTaskOptions Interface See Also

The value of the preferred graph device

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Property PreferredGraphDevice As SasGraphDevice
C#
SasGraphDevice PreferredGraphDevice { get; set; }

See Also

ISASTaskOptions Interface
SAS.Shared.AddIns Namespace


UseApplicationDefaults Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskOptions..::.UseApplicationDefaults Property
ISASTaskOptions Interface See Also

Whether to use the application default values for ODS and graph settings

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Property UseApplicationDefaults As Boolean
C#
bool UseApplicationDefaults { get; set; }

See Also

ISASTaskOptions Interface
SAS.Shared.AddIns Namespace


ISASTaskParameter Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskParameter Interface
Members See Also

This interface is for use by SAS applications and is not intended for use by SAS customers.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISASTaskParameter
C#
public interface ISASTaskParameter

Remarks

Not documented for customer use.

See Also

ISASTaskParameter Members
SAS.Shared.AddIns Namespace


ISASTaskParameter Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskParameter Members
ISASTaskParameter Interface Properties See Also

The ISASTaskParameter type exposes the following members.

Properties

Name | Description
DefaultValue | The default value of the paramter
Description | The discription of the paramter
Label | The display name of the paramter
Name | The defined name of the paramter
Type | The parameter variable type

See Also

ISASTaskParameter Interface
SAS.Shared.AddIns Namespace


ISASTaskParameter Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskParameter Properties
ISASTaskParameter Interface See Also

The ISASTaskParameter type exposes the following members.

Properties

Name | Description
DefaultValue | The default value of the paramter
Description | The discription of the paramter
Label | The display name of the paramter
Name | The defined name of the paramter
Type | The parameter variable type

See Also

ISASTaskParameter Interface
SAS.Shared.AddIns Namespace


DefaultValue Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskParameter..::.DefaultValue Property
ISASTaskParameter Interface See Also

The default value of the paramter

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property DefaultValue As String
C#
string DefaultValue { get; }

See Also

ISASTaskParameter Interface
SAS.Shared.AddIns Namespace


Description Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskParameter..::.Description Property
ISASTaskParameter Interface See Also

The discription of the paramter

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Description As String
C#
string Description { get; }

See Also

ISASTaskParameter Interface
SAS.Shared.AddIns Namespace


Label Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskParameter..::.Label Property
ISASTaskParameter Interface See Also

The display name of the paramter

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Label As String
C#
string Label { get; }

See Also

ISASTaskParameter Interface
SAS.Shared.AddIns Namespace


Name Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskParameter..::.Name Property
ISASTaskParameter Interface See Also

The defined name of the paramter

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Name As String
C#
string Name { get; }

See Also

ISASTaskParameter Interface
SAS.Shared.AddIns Namespace


Type Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskParameter..::.Type Property
ISASTaskParameter Interface See Also

The parameter variable type

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Type As ParameterVariableGroup
C#
ParameterVariableGroup Type { get; }

See Also

ISASTaskParameter Interface
SAS.Shared.AddIns Namespace


ISASTaskParameterSink Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskParameterSink Interface
Members See Also

Implemented by: Add-in task

Add-ins can optionally support this interface.

Supplies an event to indicate that a parameter has been modifed or removed.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISASTaskParameterSink
C#
public interface ISASTaskParameterSink

Remarks

This interface is used only if the add-in supports returning a list of ParameterNames.

See Also

ISASTaskParameterSink Members
SAS.Shared.AddIns Namespace
SAS.Shared.AddIns..::.ISASTaskSubmit


ISASTaskParameterSink Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskParameterSink Members
ISASTaskParameterSink Interface Methods See Also

The ISASTaskParameterSink type exposes the following members.

Methods

Name | Description
ParameterChanged | Notification that a parameter has been removed
ParameterRemoved | Notification that a parameter has been removed

See Also

ISASTaskParameterSink Interface
SAS.Shared.AddIns Namespace


ISASTaskParameterSink Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskParameterSink Methods
ISASTaskParameterSink Interface See Also

The ISASTaskParameterSink type exposes the following members.

Methods

Name | Description
ParameterChanged | Notification that a parameter has been removed
ParameterRemoved | Notification that a parameter has been removed

See Also

ISASTaskParameterSink Interface
SAS.Shared.AddIns Namespace


ParameterChanged Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskParameterSink..::.ParameterChanged Method
ISASTaskParameterSink Interface See Also

Notification that a parameter has been removed

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Sub ParameterChanged ( _
    Parameter As ISASTaskParameter, _
    ParameterName As String _
)
C#
void ParameterChanged(
    ISASTaskParameter Parameter,
    string ParameterName
)

Parameters

Parameter
Type: SAS.Shared.AddIns..::.ISASTaskParameter
The parameter object that has been changed
ParameterName
Type: System..::.String
The name of the previous parameter which has changed.

See Also

ISASTaskParameterSink Interface
SAS.Shared.AddIns Namespace


ParameterRemoved Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskParameterSink..::.ParameterRemoved Method
ISASTaskParameterSink Interface See Also

Notification that a parameter has been removed

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Sub ParameterRemoved ( _
    ParameterName As String _
)
C#
void ParameterRemoved(
    string ParameterName
)

Parameters

ParameterName
Type: System..::.String
The name of the parameter which has been removed from the list of available parameters.

See Also

ISASTaskParameterSink Interface
SAS.Shared.AddIns Namespace


ISASTaskProperties Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskProperties Interface
Members See Also

Interface to get metadata properties for an instance of a task within the application.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISASTaskProperties
C#
public interface ISASTaskProperties

See Also

ISASTaskProperties Members
SAS.Shared.AddIns Namespace


ISASTaskProperties Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskProperties Members
ISASTaskProperties Interface Methods Properties See Also

The ISASTaskProperties type exposes the following members.

Methods

Name | Description
ShowPropertySheet | Shows the task's Property Sheet.

Properties

Name | Description
CreatedDate | Date/time when this task instance was added to the project/document.
Label | Label of the task as it appears in the application.
LastExecutionTime | Time duration that it took to completely run (execute) this task the last time that the task was submitted or run. This time span represents the duration for just this task, regardless of whether it was run by itself or as part of a flow. The value might be zero if the task has never been run.
LastModifiedByUserID | User ID of the Windows user that last modified this task.
LastModifiedByUserName | User name, as reported by Windows, of the user that last modified this task.
LastModifiedDate | Date/time when this task instance was last modified in the project/document.

See Also

ISASTaskProperties Interface
SAS.Shared.AddIns Namespace


ISASTaskProperties Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskProperties Methods
ISASTaskProperties Interface See Also

The ISASTaskProperties type exposes the following members.

Methods

Name | Description
ShowPropertySheet | Shows the task's Property Sheet.

See Also

ISASTaskProperties Interface
SAS.Shared.AddIns Namespace


ShowPropertySheet Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskProperties..::.ShowPropertySheet Method
ISASTaskProperties Interface See Also

Shows the task's Property Sheet.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function ShowPropertySheet ( _
    owner As IWin32Window _
) As DialogResult
C#
DialogResult ShowPropertySheet(
    IWin32Window owner
)

Parameters

owner
Type: System.Windows.Forms..::.IWin32Window
The window to which the PropertySheet should be parented

See Also

ISASTaskProperties Interface
SAS.Shared.AddIns Namespace


ISASTaskProperties Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskProperties Properties
ISASTaskProperties Interface See Also

The ISASTaskProperties type exposes the following members.

Properties

Name | Description
CreatedDate | Date/time when this task instance was added to the project/document.
Label | Label of the task as it appears in the application.
LastExecutionTime | Time duration that it took to completely run (execute) this task the last time that the task was submitted or run. This time span represents the duration for just this task, regardless of whether it was run by itself or as part of a flow. The value might be zero if the task has never been run.
LastModifiedByUserID | User ID of the Windows user that last modified this task.
LastModifiedByUserName | User name, as reported by Windows, of the user that last modified this task.
LastModifiedDate | Date/time when this task instance was last modified in the project/document.

See Also

ISASTaskProperties Interface
SAS.Shared.AddIns Namespace


CreatedDate Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskProperties..::.CreatedDate Property
ISASTaskProperties Interface See Also

Date/time when this task instance was added to the project/document.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property CreatedDate As DateTime
C#
DateTime CreatedDate { get; }

See Also

ISASTaskProperties Interface
SAS.Shared.AddIns Namespace


Label Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskProperties..::.Label Property
ISASTaskProperties Interface See Also

Label of the task as it appears in the application.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Label As String
C#
string Label { get; }

See Also

ISASTaskProperties Interface
SAS.Shared.AddIns Namespace


LastExecutionTime Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskProperties..::.LastExecutionTime Property
ISASTaskProperties Interface See Also

Time duration that it took to completely run (execute) this task the last time that the task was submitted or run. This time span represents the duration for just this task, regardless of whether it was run by itself or as part of a flow.

The value might be zero if the task has never been run.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property LastExecutionTime As TimeSpan
C#
TimeSpan LastExecutionTime { get; }

See Also

ISASTaskProperties Interface
SAS.Shared.AddIns Namespace


LastModifiedByUserID Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskProperties..::.LastModifiedByUserID Property
ISASTaskProperties Interface See Also

User ID of the Windows user that last modified this task.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property LastModifiedByUserID As String
C#
string LastModifiedByUserID { get; }

See Also

ISASTaskProperties Interface
SAS.Shared.AddIns Namespace


LastModifiedByUserName Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskProperties..::.LastModifiedByUserName Property
ISASTaskProperties Interface See Also

User name, as reported by Windows, of the user that last modified this task.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property LastModifiedByUserName As String
C#
string LastModifiedByUserName { get; }

See Also

ISASTaskProperties Interface
SAS.Shared.AddIns Namespace


LastModifiedDate Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskProperties..::.LastModifiedDate Property
ISASTaskProperties Interface See Also

Date/time when this task instance was last modified in the project/document.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property LastModifiedDate As DateTime
C#
DateTime LastModifiedDate { get; }

See Also

ISASTaskProperties Interface
SAS.Shared.AddIns Namespace


ISASTaskStream Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskStream Interface
Members See Also

This interface is used by custom add-ins that return their own results by implementing ISASTaskExecution.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISASTaskStream
C#
public interface ISASTaskStream

Remarks

See Also

ISASTaskStream Members
SAS.Shared.AddIns Namespace
SAS.Shared.AddIns..::.ISASTaskExecution


ISASTaskStream Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskStream Members
ISASTaskStream Interface Methods Properties See Also

The ISASTaskStream type exposes the following members.

Methods

Name | Description
Close | Close the stream.
Read | Read from the stream.

Properties

Name | Description
Length | The length of the stream in bytes.
MimeType | Get the mime type of the contents of the stream.
OriginalName | Get the original name of the file that might be read via this stream.

See Also

ISASTaskStream Interface
SAS.Shared.AddIns Namespace


ISASTaskStream Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskStream Methods
ISASTaskStream Interface See Also

The ISASTaskStream type exposes the following members.

Methods

Name | Description
Close | Close the stream.
Read | Read from the stream.

See Also

ISASTaskStream Interface
SAS.Shared.AddIns Namespace


Close Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskStream..::.Close Method
ISASTaskStream Interface See Also

Close the stream.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Sub Close
C#
void Close()

See Also

ISASTaskStream Interface
SAS.Shared.AddIns Namespace


Read Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskStream..::.Read Method
ISASTaskStream Interface See Also

Read from the stream.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function Read ( _
    <OutAttribute> buffer As Byte(), _
    count As Integer _
) As Integer
C#
int Read(
    byte[] buffer,
    int count
)

Parameters

buffer
Type: array< System..::.Byte >[]()[]
The buffer to write read-in bytes to.
count
Type: System..::.Int32
The number of bytes to read into buffer.

Return Value

The total number of bytes actually read into the buffer.

See Also

ISASTaskStream Interface
SAS.Shared.AddIns Namespace


ISASTaskStream Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskStream Properties
ISASTaskStream Interface See Also

The ISASTaskStream type exposes the following members.

Properties

Name | Description
Length | The length of the stream in bytes.
MimeType | Get the mime type of the contents of the stream.
OriginalName | Get the original name of the file that might be read via this stream.

See Also

ISASTaskStream Interface
SAS.Shared.AddIns Namespace


Length Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskStream..::.Length Property
ISASTaskStream Interface See Also

The length of the stream in bytes.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Length As Long
C#
long Length { get; }

See Also

ISASTaskStream Interface
SAS.Shared.AddIns Namespace


MimeType Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskStream..::.MimeType Property
ISASTaskStream Interface See Also

Get the mime type of the contents of the stream.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property MimeType As String
C#
string MimeType { get; }

See Also

ISASTaskStream Interface
SAS.Shared.AddIns Namespace


OriginalName Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskStream..::.OriginalName Property
ISASTaskStream Interface See Also

Get the original name of the file that might be read via this stream.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property OriginalName As String
C#
string OriginalName { get; }

Remarks

For example, this can be used if the collection of ISASTaskStream objects represent have an HTML result that references other images. The original name of the image files are important know because the HTML code will refer to them in IMG tags.

See Also

ISASTaskStream Interface
SAS.Shared.AddIns Namespace


ISASTaskSubmit Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskSubmit Interface
Members See Also

Implemented by: Host application (for example, SAS Enterprise Guide)

This interfaces allow the task to submit SAS code from within the task.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISASTaskSubmit
C#
public interface ISASTaskSubmit

Remarks

The implementation of this interface by a host application is optional.

Different applications may not be able to provide values for some of these methods.

See Also

ISASTaskSubmit Members
SAS.Shared.AddIns Namespace


ISASTaskSubmit Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskSubmit Members
ISASTaskSubmit Interface Methods Properties See Also

The ISASTaskSubmit type exposes the following members.

Methods

Name | Description
CancelSubmit | Cancel a SAS job that you submitted.
SubmitCode | Submit a SAS program for processing.
SubmitProcessingTime | Returns the time (in seconds) that the SAS job took to process.

Properties

Name | Description
SubmitPending | Checks whether the host application has a SAS job already pending.

See Also

ISASTaskSubmit Interface
SAS.Shared.AddIns Namespace


ISASTaskSubmit Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskSubmit Methods
ISASTaskSubmit Interface See Also

The ISASTaskSubmit type exposes the following members.

Methods

Name | Description
CancelSubmit | Cancel a SAS job that you submitted.
SubmitCode | Submit a SAS program for processing.
SubmitProcessingTime | Returns the time (in seconds) that the SAS job took to process.

See Also

ISASTaskSubmit Interface
SAS.Shared.AddIns Namespace


CancelSubmit Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskSubmit..::.CancelSubmit Method
ISASTaskSubmit Interface See Also

Cancel a SAS job that you submitted.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Sub CancelSubmit ( _
    Cookie As Integer _
)
C#
void CancelSubmit(
    int Cookie
)

Parameters

Cookie
Type: System..::.Int32
The "cookie" identifier that was returned from the SubmitCode(String, String, Boolean) call.

See Also

ISASTaskSubmit Interface
SAS.Shared.AddIns Namespace


SubmitCode Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskSubmit..::.SubmitCode Method
ISASTaskSubmit Interface See Also

Submit a SAS program for processing.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function SubmitCode ( _
    Code As String, _
    Server As String, _
    Async As Boolean _
) As Integer
C#
int SubmitCode(
    string Code,
    string Server,
    bool Async
)

Parameters

Code
Type: System..::.String
The SAS code to run.
Server
Type: System..::.String
The name of the server to run the program.
Async
Type: System..::.Boolean
Whether to wait while the program runs, or run the program asynchronously. If you select to run asynchronously, you must implement ISASTaskSubmitSink in your add-in.

Return Value

A "cookie" identifier for the job that is submitted.

See Also

ISASTaskSubmit Interface
SAS.Shared.AddIns Namespace


SubmitProcessingTime Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskSubmit..::.SubmitProcessingTime Method
ISASTaskSubmit Interface See Also

Returns the time (in seconds) that the SAS job took to process.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function SubmitProcessingTime ( _
    Cookie As Integer _
) As Integer
C#
int SubmitProcessingTime(
    int Cookie
)

Parameters

Cookie
Type: System..::.Int32
The "cookie" identifier that was returned from the SubmitCode(String, String, Boolean) call.

Return Value

The processing time in seconds.

See Also

ISASTaskSubmit Interface
SAS.Shared.AddIns Namespace


ISASTaskSubmit Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskSubmit Properties
ISASTaskSubmit Interface See Also

The ISASTaskSubmit type exposes the following members.

Properties

Name | Description
SubmitPending | Checks whether the host application has a SAS job already pending.

See Also

ISASTaskSubmit Interface
SAS.Shared.AddIns Namespace


SubmitPending Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskSubmit..::.SubmitPending Property
ISASTaskSubmit Interface See Also

Checks whether the host application has a SAS job already pending.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SubmitPending As Boolean
C#
bool SubmitPending { get; }

Field Value

true if a job is pending

See Also

ISASTaskSubmit Interface
SAS.Shared.AddIns Namespace


ISASTaskSubmitSink Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskSubmitSink Interface
Members See Also

Implemented by: Add-in task

Add-ins can optionally support this interface.

Supplies an event to indicate that an SAS program (submitted asynchronously) has completed processing.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISASTaskSubmitSink
C#
public interface ISASTaskSubmitSink

Remarks

This interface is used only if the add-in uses the ISASTaskSubmit interface on the host application to submit a SAS program asynchronously.

See Also

ISASTaskSubmitSink Members
SAS.Shared.AddIns Namespace
SAS.Shared.AddIns..::.ISASTaskSubmit


ISASTaskSubmitSink Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskSubmitSink Members
ISASTaskSubmitSink Interface Methods See Also

The ISASTaskSubmitSink type exposes the following members.

Methods

Name | Description
SubmitComplete | Notification that the submitted SAS program has completed.

See Also

ISASTaskSubmitSink Interface
SAS.Shared.AddIns Namespace


ISASTaskSubmitSink Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskSubmitSink Methods
ISASTaskSubmitSink Interface See Also

The ISASTaskSubmitSink type exposes the following members.

Methods

Name | Description
SubmitComplete | Notification that the submitted SAS program has completed.

See Also

ISASTaskSubmitSink Interface
SAS.Shared.AddIns Namespace


SubmitComplete Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskSubmitSink..::.SubmitComplete Method
ISASTaskSubmitSink Interface See Also

Notification that the submitted SAS program has completed.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Sub SubmitComplete ( _
    Cookie As Integer, _
    Success As Boolean, _
    Log As String _
)
C#
void SubmitComplete(
    int Cookie,
    bool Success,
    string Log
)

Parameters

Cookie
Type: System..::.Int32
A 32-bit unique value that represents the submitted SAS code session.
Success
Type: System..::.Boolean
A flag that represents the results for SAS code being processed.
Log
Type: System..::.String
The SAS log generated as a result of submitting the SAS program code.

See Also

ISASTaskSubmitSink Interface
SAS.Shared.AddIns Namespace


ISASTaskTemplate Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskTemplate Interface
Members See Also

This interface is used by tasks to provide support for "templated tasks". SAS Enterprise Guide and SAS Add-In for Microsoft Office allow you to create templates from tasks you've used in your project. These templates store the options you've selected so that you can reuse them in a future project, without having to reselect all of the options "from scratch".

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISASTaskTemplate
C#
public interface ISASTaskTemplate

See Also

ISASTaskTemplate Members
SAS.Shared.AddIns Namespace


ISASTaskTemplate Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskTemplate Members
ISASTaskTemplate Interface Methods Properties See Also

The ISASTaskTemplate type exposes the following members.

Methods

Name | Description
CreateTaskTemplate | Creates a new template from the current task. This method directs the task to create an XML-based file that represents the information that needs to be included in a template.
OpenTaskTemplate | Initialize the task using the XML-based state as saved within a template. Most tasks can implement this method simply as an empty stub.

Properties

Name | Description
SupportsTemplates | Whether this task supports the use of templates.

See Also

ISASTaskTemplate Interface
SAS.Shared.AddIns Namespace


ISASTaskTemplate Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskTemplate Methods
ISASTaskTemplate Interface See Also

The ISASTaskTemplate type exposes the following members.

Methods

Name | Description
CreateTaskTemplate | Creates a new template from the current task. This method directs the task to create an XML-based file that represents the information that needs to be included in a template.
OpenTaskTemplate | Initialize the task using the XML-based state as saved within a template. Most tasks can implement this method simply as an empty stub.

See Also

ISASTaskTemplate Interface
SAS.Shared.AddIns Namespace


CreateTaskTemplate Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskTemplate..::.CreateTaskTemplate Method
ISASTaskTemplate Interface See Also

Creates a new template from the current task. This method directs the task to create an XML-based file that represents the information that needs to be included in a template.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Sub CreateTaskTemplate ( _
    Name As String, _
    Desc As String, _
    Category As String, _
    ViewType As String _
)
C#
void CreateTaskTemplate(
    string Name,
    string Desc,
    string Category,
    string ViewType
)

Parameters

Name
Type: System..::.String
Name of the template
Desc
Type: System..::.String
A description of the template
Category
Type: System..::.String
The category, or folder, to organize the template
ViewType
Type: System..::.String
A text representation of the view type. This is used for some SAS-supplied tasks that can have wizard vs. advanced views, but typically will not apply to custom tasks.

See Also

ISASTaskTemplate Interface
SAS.Shared.AddIns Namespace


OpenTaskTemplate Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskTemplate..::.OpenTaskTemplate Method
ISASTaskTemplate Interface See Also

Initialize the task using the XML-based state as saved within a template. Most tasks can implement this method simply as an empty stub.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Sub OpenTaskTemplate ( _
    xml As String _
)
C#
void OpenTaskTemplate(
    string xml
)

Parameters

xml
Type: System..::.String
Template settings supplied in XML.

See Also

ISASTaskTemplate Interface
SAS.Shared.AddIns Namespace


ISASTaskTemplate Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskTemplate Properties
ISASTaskTemplate Interface See Also

The ISASTaskTemplate type exposes the following members.

Properties

Name | Description
SupportsTemplates | Whether this task supports the use of templates.

See Also

ISASTaskTemplate Interface
SAS.Shared.AddIns Namespace


SupportsTemplates Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskTemplate..::.SupportsTemplates Property
ISASTaskTemplate Interface See Also

Whether this task supports the use of templates.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SupportsTemplates As Boolean
C#
bool SupportsTemplates { get; }

Field Value

True if the task is meant to support templates; otherwise false.

See Also

ISASTaskTemplate Interface
SAS.Shared.AddIns Namespace


ISASTaskTextWriter Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskTextWriter Interface
Members See Also

Interface for writing to a text writer.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISASTaskTextWriter
C#
public interface ISASTaskTextWriter

Remarks

See Also

ISASTaskTextWriter Members
SAS.Shared.AddIns Namespace
SAS.Shared.AddIns..::.ISASTaskExecution


ISASTaskTextWriter Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskTextWriter Members
ISASTaskTextWriter Interface Methods See Also

The ISASTaskTextWriter type exposes the following members.

Methods

Name | Description
WriteText | Write text to the text writer.

See Also

ISASTaskTextWriter Interface
SAS.Shared.AddIns Namespace


ISASTaskTextWriter Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskTextWriter Methods
ISASTaskTextWriter Interface See Also

The ISASTaskTextWriter type exposes the following members.

Methods

Name | Description
WriteText | Write text to the text writer.

See Also

ISASTaskTextWriter Interface
SAS.Shared.AddIns Namespace


WriteText Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskTextWriter..::.WriteText Method
ISASTaskTextWriter Interface See Also

Write text to the text writer.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Sub WriteText ( _
    Text As String _
)
C#
void WriteText(
    string Text
)

Parameters

Text
Type: System..::.String
The text to write to the text writer.

See Also

ISASTaskTextWriter Interface
SAS.Shared.AddIns Namespace


ISASTaskUtilities Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskUtilities Interface
Members See Also

Implemented by: Host application (for example, SAS Enterprise Guide)

This interfaces allow the task to surface some utility functionality to the task.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISASTaskUtilities
C#
public interface ISASTaskUtilities

Remarks

The implementation of this interface by a host application is optional.

This interface will most likely be used by add-in writers or legacy Visual-Basic-based tasks. Different applications might not be able to provide values for some of these methods.

See Also

ISASTaskUtilities Members
SAS.Shared.AddIns Namespace


ISASTaskUtilities Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskUtilities Members
ISASTaskUtilities Interface Methods See Also

The ISASTaskUtilities type exposes the following members.

Methods

Name | Description
NextVariable | Returns the next variable from a literal-delimited buffer.
ValidLiteral | Returns valid SAS literal syntax for a variable name, given the name of a column.

See Also

ISASTaskUtilities Interface
SAS.Shared.AddIns Namespace


ISASTaskUtilities Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskUtilities Methods
ISASTaskUtilities Interface See Also

The ISASTaskUtilities type exposes the following members.

Methods

Name | Description
NextVariable | Returns the next variable from a literal-delimited buffer.
ValidLiteral | Returns valid SAS literal syntax for a variable name, given the name of a column.

See Also

ISASTaskUtilities Interface
SAS.Shared.AddIns Namespace


NextVariable Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskUtilities..::.NextVariable Method
ISASTaskUtilities Interface See Also

Returns the next variable from a literal-delimited buffer.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function NextVariable ( _
    InBuffer As String, _
    <OutAttribute> ByRef OutBuffer As String _
) As String
C#
string NextVariable(
    string InBuffer,
    out string OutBuffer
)

Parameters

InBuffer
Type: System..::.String
Input buffer to parse
OutBuffer
Type: System..::.String %
New output buffer

Return Value

Next variable from the buffer

See Also

ISASTaskUtilities Interface
SAS.Shared.AddIns Namespace


ValidLiteral Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISASTaskUtilities..::.ValidLiteral Method
ISASTaskUtilities Interface See Also

Returns valid SAS literal syntax for a variable name, given the name of a column.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Function ValidLiteral ( _
    Value As String _
) As String
C#
string ValidLiteral(
    string Value
)

Parameters

Value
Type: System..::.String
Name of the column (example: "My variable")

Return Value

Valid syntax for referencing the column (for example: 'My variable'n

See Also

ISASTaskUtilities Interface
SAS.Shared.AddIns Namespace


ISupportRoleBased Interface

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISupportRoleBased Interface
Members See Also

Implement this interface when you want your task to respect administrative settings that are centrally configured. An administrator can control whether certain users or groups have read-only access to projects. If you choose to implement this interface, you can comply with the intent of the administrator.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISupportRoleBased
C#
public interface ISupportRoleBased

See Also

ISupportRoleBased Members
SAS.Shared.AddIns Namespace


ISupportRoleBased Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISupportRoleBased Members
ISupportRoleBased Interface Properties See Also

The ISupportRoleBased type exposes the following members.

Properties

Name | Description
AllowModifyCustomCode | Whether this task should allow the user to insert custom SAS code within the task. This is an advanced feature of the SAS-provided tasks.
AllowModifyOutputData | Whether this task should allow the user to change the location of output data results. If false, you should disable any control over redirecting output data.
ReadOnlyMode | Whether this task should be treated as read-only. If true, then a user cannot commit changes made within the task and save them in a project.

See Also

ISupportRoleBased Interface
SAS.Shared.AddIns Namespace


ISupportRoleBased Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISupportRoleBased Properties
ISupportRoleBased Interface See Also

The ISupportRoleBased type exposes the following members.

Properties

Name | Description
AllowModifyCustomCode | Whether this task should allow the user to insert custom SAS code within the task. This is an advanced feature of the SAS-provided tasks.
AllowModifyOutputData | Whether this task should allow the user to change the location of output data results. If false, you should disable any control over redirecting output data.
ReadOnlyMode | Whether this task should be treated as read-only. If true, then a user cannot commit changes made within the task and save them in a project.

See Also

ISupportRoleBased Interface
SAS.Shared.AddIns Namespace


AllowModifyCustomCode Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISupportRoleBased..::.AllowModifyCustomCode Property
ISupportRoleBased Interface See Also

Whether this task should allow the user to insert custom SAS code within the task. This is an advanced feature of the SAS-provided tasks.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Property AllowModifyCustomCode As Boolean
C#
bool AllowModifyCustomCode { get; set; }

See Also

ISupportRoleBased Interface
SAS.Shared.AddIns Namespace


AllowModifyOutputData Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISupportRoleBased..::.AllowModifyOutputData Property
ISupportRoleBased Interface See Also

Whether this task should allow the user to change the location of output data results. If false, you should disable any control over redirecting output data.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Property AllowModifyOutputData As Boolean
C#
bool AllowModifyOutputData { get; set; }

See Also

ISupportRoleBased Interface
SAS.Shared.AddIns Namespace


ReadOnlyMode Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ISupportRoleBased..::.ReadOnlyMode Property
ISupportRoleBased Interface See Also

Whether this task should be treated as read-only. If true, then a user cannot commit changes made within the task and save them in a project.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Property ReadOnlyMode As Boolean
C#
bool ReadOnlyMode { get; set; }

See Also

ISupportRoleBased Interface
SAS.Shared.AddIns Namespace


LibraryType Enumeration

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
LibraryType Enumeration
See Also

Used to retrieve a list of specific SAS libraries in a call to Libraries

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration LibraryType
C#
public enum LibraryType

Members

Member name | Description
ReadOnly | Only those libraries that are read-only for this user.
ReadWrite | Only those libraries that are readable and writeable for this user.
All | All libraries, regardless of read/write access.

See Also

SAS.Shared.AddIns Namespace


ObsConstants Enumeration

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ObsConstants Enumeration
See Also

Constants for use with the ISASTaskOptions interface to get/set the values of FirstObs and NObs.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration ObsConstants
C#
public enum ObsConstants

Members

Member name | Description
MaxObs | Maximum number of observations (MAX)
MinObs | Minimum number of observations (MIN, interpreted as 0 for NObs, 1 for FirstObs)

See Also

SAS.Shared.AddIns Namespace


OdsDestination Enumeration

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
OdsDestination Enumeration
See Also

The OdsDestination enum represents different ODS destinations.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration OdsDestination
C#
public enum OdsDestination

Members

Member name | Description
Listing | Text/listing destination
Html | HTML destination
Rtf | Rich Text destination
Pdf | Portable Document Format destination
Report | SAS Report destination.

See Also

SAS.Shared.AddIns Namespace


OptionalName Enumeration

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
OptionalName Enumeration
See Also

Enumeration of features/properties/interfaces that might be supported by the host application.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration OptionalName
C#
public enum OptionalName

Members

Member name | Description
Submit | ISASTaskConsumer.Submit member
Display | ISASTaskConsumer.Display member
Version | ISASTaskConsumer.Version member
AssignServer | ISASTaskConsumer.AssignServer member
MemberName | ISASTaskConsumer.MemberName member
ExecuteTask | ISASTaskConsumer.ExecuteTask member
Libraries | ISASTaskConsumer.Libraries member
Servers | ISASTaskConsumer.Servers member
Workspace | ISASTaskConsumer.Workspace member
LibrefData | ISASTaskConsumer.LibrefData member
ValidStateChanged | ISASTaskConsumer.ValidStateChanged member
DataName | ISASTaskConsumer.DataName member
Utilities | ISASTaskConsumer.Utilities member
FilerefData | ISASTaskConsumer.FilerefData member
ParameterizedCodeChanged | ISASTaskConsumer.ParameterizedCodeChanged member
Server | ISASTaskData.Server member
Table | ISASTaskData.Table member
Source | ISASTaskData.Source member
Type | ISASTaskData.Type member
Statistics | ISASTaskData.Statistics member
Label | ISASTaskData.Label member
FlatFile | ISASTaskData.FlatFile member
FlatFileAt | ISASTaskData.FlatFileAt member
GenerateDiscrete | ISASTaskDataAccessor.GenerateDiscrete member
GenerateStatistic | ISASTaskDataAccessor.GenerateStatistic member
Value | ISASTaskDataAccessor.Value member
Statistic | ISASTaskColumn.Statistic member
Discrete | ISASTaskColumn.Discrete member

Remarks

Use these enumeration values to query whether a given feature is supported by the host application that is hosting your add-in.

See Also

SAS.Shared.AddIns Namespace
ISASTaskConsumer..::.Supported(OptionalName)
ISASTaskData..::.Supported(OptionalName)
ISASTaskDataAccessor..::.Supported(OptionalName)


OutputData Enumeration

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
OutputData Enumeration
See Also

Enumeration of the valid output data types.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration OutputData
C#
public enum OutputData

Members

Member name | Description
Libref | Output data is a reference in a SAS library (for example, SASHELP.CLASS)
FilePath | Output data is a local file path (for example, c:\data\sas7bdat)
SdsName | DEPRECATED
Unknown | Output data is not a defined output type.

Remarks

The add-in supplies this information to the application in the ISASTask.OutputDataInfo method.

See Also

SAS.Shared.AddIns Namespace
ISASTask..::.OutputDataInfo(Int32, String%, String%)


ParameterVariableGroup Enumeration

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ParameterVariableGroup Enumeration
See Also

Possible values for variable groups, which are a way to categorize possible parameter values.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration ParameterVariableGroup
C#
public enum ParameterVariableGroup

Members

Member name | Description
Unknown | Unknown variable type
Numeric | Numeric type
Character | Character type
Date | Date type (numeric with date format)
Time | Time type (numeric with time format)
Currency | Currency type (numeric with currency format)
Classification | Classification type
GeoRef | GeoRef type for use with GIS or mapping data

See Also

SAS.Shared.AddIns Namespace
SAS.Shared.AddIns..::.ISASTaskParameter


PinnedResult Enumeration

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
PinnedResult Enumeration
See Also

Possible values to pass to the ISASTaskConsumer2.ExecuteTask method.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration PinnedResult
C#
public enum PinnedResult

Members

Member name | Description
Canceled | Task is canceled -- discard changes and do not run.
RunNow | Run task now -- immediately.
RunLater | Save task state so that it can be run later.
Activate | Sets the task as the active object in application.

See Also

SAS.Shared.AddIns Namespace
ISASTaskConsumer2..::.ExecuteTask(PinnedResult)


RunStatus Enumeration

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
RunStatus Enumeration
See Also

Possible success codes for tasks that do no generate SAS code but instead perform work on their own. The application can use these codes to provide a visual indicator of success, error, or warnings.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration RunStatus
C#
public enum RunStatus

Members

Member name | Description
Success | Run was successful.
Warning | Run had warnings
Error | Run had errors.

Remarks

See Also

SAS.Shared.AddIns Namespace
SAS.Shared.AddIns..::.ISASTaskExecution


SasGraphDevice Enumeration

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasGraphDevice Enumeration
See Also

Graph devices supported by SAS applications

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration SasGraphDevice
C#
public enum SasGraphDevice

Members

Member name | Description
ActiveX | ActiveX
Java | Java applet
Gif | GIF image
Jpeg | JPEG image
ActiveXImage | ActiveX image (server side image generation).
JavaImage | Java image (server side image generation).
SasEmf | SAS enhanced metafile driver.
Png | Portable network graphics driver.

See Also

SAS.Shared.AddIns Namespace


SASMacroDependencyAttribute Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASMacroDependencyAttribute Class
Members See Also

Attribute to indicate whether a task depends on a particular macro.

The application can supply certain SAS macros on behalf of the task. These are utility macros that perform simple work, but that you might want avoid defining during code generation so that the task code is more readable.

Examples include "_eg_conditional_dropds", which deletes a data member (DATA or VIEW) to clear the way for a possible new version of the data. Another example is "_eg_whereParam", which helps to express a WHERE clause for use in a parameterized query.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple := True)> _
Public Class SASMacroDependencyAttribute _
    Inherits Attribute
C#
[AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = true)]
public class SASMacroDependencyAttribute : Attribute

Remarks

Added in version 4.2

Inheritance Hierarchy

System..::.Object
System..::.Attribute
SAS.Shared.AddIns..::.SASMacroDependencyAttribute

See Also

SASMacroDependencyAttribute Members
SAS.Shared.AddIns Namespace


SASMacroDependencyAttribute Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASMacroDependencyAttribute Members
SASMacroDependencyAttribute Class Constructors Methods Properties Explicit Interface Implementations See Also

The SASMacroDependencyAttribute type exposes the following members.

Constructors

Name | Description
SASMacroDependencyAttribute | Constructor for this attribute

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MacroDependency | Gets or sets the name of a macro that this task needs in order to run correctly.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

SASMacroDependencyAttribute Class
SAS.Shared.AddIns Namespace


SASMacroDependencyAttribute Constructor

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASMacroDependencyAttribute Constructor
SASMacroDependencyAttribute Class See Also

Constructor for this attribute

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    macroNeeded As String _
)
C#
public SASMacroDependencyAttribute(
    string macroNeeded
)

Parameters

macroNeeded
Type: System..::.String
Name of the macro that is needed

See Also

SASMacroDependencyAttribute Class
SAS.Shared.AddIns Namespace


SASMacroDependencyAttribute Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASMacroDependencyAttribute Methods
SASMacroDependencyAttribute Class See Also

The SASMacroDependencyAttribute type exposes the following members.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

SASMacroDependencyAttribute Class
SAS.Shared.AddIns Namespace


SASMacroDependencyAttribute Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASMacroDependencyAttribute Properties
SASMacroDependencyAttribute Class See Also

The SASMacroDependencyAttribute type exposes the following members.

Properties

Name | Description
MacroDependency | Gets or sets the name of a macro that this task needs in order to run correctly.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

SASMacroDependencyAttribute Class
SAS.Shared.AddIns Namespace


MacroDependency Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASMacroDependencyAttribute..::.MacroDependency Property
SASMacroDependencyAttribute Class See Also

Gets or sets the name of a macro that this task needs in order to run correctly.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Property MacroDependency As String
C#
public string MacroDependency { get; set; }

See Also

SASMacroDependencyAttribute Class
SAS.Shared.AddIns Namespace


SASMetadataRequiredAttribute Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASMetadataRequiredAttribute Class
Members See Also

Attribute to indicate whether this task implementation requires access to a SAS Metadata Repository.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Class)> _
Public Class SASMetadataRequiredAttribute _
    Inherits Attribute
C#
[AttributeUsageAttribute(AttributeTargets.Class)]
public class SASMetadataRequiredAttribute : Attribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
SAS.Shared.AddIns..::.SASMetadataRequiredAttribute

See Also

SASMetadataRequiredAttribute Members
SAS.Shared.AddIns Namespace


SASMetadataRequiredAttribute Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASMetadataRequiredAttribute Members
SASMetadataRequiredAttribute Class Constructors Methods Properties Explicit Interface Implementations See Also

The SASMetadataRequiredAttribute type exposes the following members.

Constructors

Name | Description
SASMetadataRequiredAttribute | Constructor

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsSASMetadataRequired | Sets or gets the value of the attribute.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

SASMetadataRequiredAttribute Class
SAS.Shared.AddIns Namespace


SASMetadataRequiredAttribute Constructor

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASMetadataRequiredAttribute Constructor
SASMetadataRequiredAttribute Class See Also

Constructor

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    bValue As Boolean _
)
C#
public SASMetadataRequiredAttribute(
    bool bValue
)

Parameters

bValue
Type: System..::.Boolean
Indicates whether the task class needs SAS metadata.

See Also

SASMetadataRequiredAttribute Class
SAS.Shared.AddIns Namespace


SASMetadataRequiredAttribute Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASMetadataRequiredAttribute Methods
SASMetadataRequiredAttribute Class See Also

The SASMetadataRequiredAttribute type exposes the following members.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

SASMetadataRequiredAttribute Class
SAS.Shared.AddIns Namespace


SASMetadataRequiredAttribute Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASMetadataRequiredAttribute Properties
SASMetadataRequiredAttribute Class See Also

The SASMetadataRequiredAttribute type exposes the following members.

Properties

Name | Description
IsSASMetadataRequired | Sets or gets the value of the attribute.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

SASMetadataRequiredAttribute Class
SAS.Shared.AddIns Namespace


IsSASMetadataRequired Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASMetadataRequiredAttribute..::.IsSASMetadataRequired Property
SASMetadataRequiredAttribute Class See Also

Sets or gets the value of the attribute.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSASMetadataRequired As Boolean
C#
public bool IsSASMetadataRequired { get; set; }

See Also

SASMetadataRequiredAttribute Class
SAS.Shared.AddIns Namespace


SASOdsSettings Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASOdsSettings Class
Members See Also

Utility class to implement ISASOdsSettings

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Class SASOdsSettings _
    Implements ISASOdsSettings
C#
public class SASOdsSettings : ISASOdsSettings

Inheritance Hierarchy

System..::.Object
SAS.Shared.AddIns..::.SASOdsSettings

See Also

SASOdsSettings Members
SAS.Shared.AddIns Namespace


SASOdsSettings Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASOdsSettings Members
SASOdsSettings Class Constructors Methods Properties See Also

The SASOdsSettings type exposes the following members.

Constructors

Name | Description
SASOdsSettings | Construct an object with a set of ODS settings for one target type

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AdditionalOptions |
Destination |
Encoding |
Style |
Stylesheet |

See Also

SASOdsSettings Class
SAS.Shared.AddIns Namespace


SASOdsSettings Constructor

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASOdsSettings Constructor
SASOdsSettings Class See Also

Construct an object with a set of ODS settings for one target type

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    destType As OdsDestination, _
    style As String, _
    stylesheet As String, _
    encoding As String, _
    options As String _
)
C#
public SASOdsSettings(
    OdsDestination destType,
    string style,
    string stylesheet,
    string encoding,
    string options
)

Parameters

destType
Type: SAS.Shared.AddIns..::.OdsDestination
style
Type: System..::.String
stylesheet
Type: System..::.String
encoding
Type: System..::.String
options
Type: System..::.String

See Also

SASOdsSettings Class
SAS.Shared.AddIns Namespace


SASOdsSettings Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASOdsSettings Methods
SASOdsSettings Class See Also

The SASOdsSettings type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SASOdsSettings Class
SAS.Shared.AddIns Namespace


SASOdsSettings Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASOdsSettings Properties
SASOdsSettings Class See Also

The SASOdsSettings type exposes the following members.

Properties

Name | Description
AdditionalOptions |
Destination |
Encoding |
Style |
Stylesheet |

See Also

SASOdsSettings Class
SAS.Shared.AddIns Namespace


AdditionalOptions Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASOdsSettings..::.AdditionalOptions Property
SASOdsSettings Class See Also

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AdditionalOptions As String
C#
public string AdditionalOptions { get; }

Implements

ISASOdsSettings..::.AdditionalOptions

See Also

SASOdsSettings Class
SAS.Shared.AddIns Namespace


Destination Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASOdsSettings..::.Destination Property
SASOdsSettings Class See Also

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Destination As OdsDestination
C#
public OdsDestination Destination { get; }

Implements

ISASOdsSettings..::.Destination

See Also

SASOdsSettings Class
SAS.Shared.AddIns Namespace


Encoding Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASOdsSettings..::.Encoding Property
SASOdsSettings Class See Also

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Encoding As String
C#
public string Encoding { get; }

Implements

ISASOdsSettings..::.Encoding

See Also

SASOdsSettings Class
SAS.Shared.AddIns Namespace


Style Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASOdsSettings..::.Style Property
SASOdsSettings Class See Also

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Style As String
C#
public string Style { get; }

Implements

ISASOdsSettings..::.Style

See Also

SASOdsSettings Class
SAS.Shared.AddIns Namespace


Stylesheet Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASOdsSettings..::.Stylesheet Property
SASOdsSettings Class See Also

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Stylesheet As String
C#
public string Stylesheet { get; }

Implements

ISASOdsSettings..::.Stylesheet

See Also

SASOdsSettings Class
SAS.Shared.AddIns Namespace


SASTaskCategoryAttribute Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTaskCategoryAttribute Class
Members See Also

Attribute to indicate the top-level category for this task. This is a string value that is not localized (translated). The application can use this value to help decide which tasks to include in certain menus and toolbars.

Current valid values include "Data", "Describe", "Graph", "Analysis", and "Tools".

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Class)> _
Public Class SASTaskCategoryAttribute _
    Inherits Attribute
C#
[AttributeUsageAttribute(AttributeTargets.Class)]
public class SASTaskCategoryAttribute : Attribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
SAS.Shared.AddIns..::.SASTaskCategoryAttribute

See Also

SASTaskCategoryAttribute Members
SAS.Shared.AddIns Namespace


SASTaskCategoryAttribute Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTaskCategoryAttribute Members
SASTaskCategoryAttribute Class Constructors Methods Properties Explicit Interface Implementations See Also

The SASTaskCategoryAttribute type exposes the following members.

Constructors

Name | Description
SASTaskCategoryAttribute | Constructor

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Category | Sets or gets the value of the category.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

SASTaskCategoryAttribute Class
SAS.Shared.AddIns Namespace


SASTaskCategoryAttribute Constructor

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTaskCategoryAttribute Constructor
SASTaskCategoryAttribute Class See Also

Constructor

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    category As String _
)
C#
public SASTaskCategoryAttribute(
    string category
)

Parameters

category
Type: System..::.String
The name of the task category.

See Also

SASTaskCategoryAttribute Class
SAS.Shared.AddIns Namespace


SASTaskCategoryAttribute Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTaskCategoryAttribute Methods
SASTaskCategoryAttribute Class See Also

The SASTaskCategoryAttribute type exposes the following members.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

SASTaskCategoryAttribute Class
SAS.Shared.AddIns Namespace


SASTaskCategoryAttribute Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTaskCategoryAttribute Properties
SASTaskCategoryAttribute Class See Also

The SASTaskCategoryAttribute type exposes the following members.

Properties

Name | Description
Category | Sets or gets the value of the category.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

SASTaskCategoryAttribute Class
SAS.Shared.AddIns Namespace


Category Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTaskCategoryAttribute..::.Category Property
SASTaskCategoryAttribute Class See Also

Sets or gets the value of the category.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Property Category As String
C#
public string Category { get; set; }

See Also

SASTaskCategoryAttribute Class
SAS.Shared.AddIns Namespace


SASTaskDataDescriptor Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTaskDataDescriptor Class
Members See Also

Implementation of ISASTaskDataDescriptor

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SASTaskDataDescriptor _
    Implements ISASTaskDataDescriptor
C#
public sealed class SASTaskDataDescriptor : ISASTaskDataDescriptor

Inheritance Hierarchy

System..::.Object
SAS.Shared.AddIns..::.SASTaskDataDescriptor

See Also

SASTaskDataDescriptor Members
SAS.Shared.AddIns Namespace


SASTaskDataDescriptor Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTaskDataDescriptor Members
SASTaskDataDescriptor Class Methods Properties See Also

The SASTaskDataDescriptor type exposes the following members.

Methods

Name | Description
CreateDescriptorFromDescriptor | Used to create an ISASTaskDataDescriptor from an existing one and a new server name
CreateDescriptorFromXml | Used to create an ISASTaskDataDescriptor from an XmlNode created via the WriteSerializationString method
CreateLibraryNameDataDescriptor | Used to create an ISASTaskDataDescriptor that describes a Data source in a SAS Library defined in metadata. Use this method if Library is defined in metadata
CreateLibrefDataDescriptor | Used to create an ISASTaskDataDescriptor that describes a Data source in a user assigned SAS Library. Use this method if Library is user assigned or not in metadata
CreateLocalDataDescriptor | Used to create an ISASTaskDataDescriptor that describes a local file path
CreateServerFileDataDescriptor | Used to create an ISASTaskDataDescriptor that describes a file path on a remote or local server
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsSameData | Does this data descriptor point to same location as that passed in?
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteSerializationString | Write serialization info to XmlTextWriter

Properties

Name | Description
DelimitedDisplayName | A tab delimited display name provided for display purpose only
FilePath | FileSystem path to the data source on a server or local machine null if DataPathType is Libref
Label | Descriptive label for the data source
LibraryName | Name of the SAS Library in Metadata, corresponds to Libref if null and DataPathType is Libref, will return Libref null if DataPathType is FilePath
Libref | SASLibraryName ( libref ) of the library the data source is in null if DataPathType is FilePath
Member | Table name of the data source null if DataPathType is FilePath
Server | Server the file resides on null if DataPathType is FilePath and data source is on users local machine can be null if DataPathType is Libref, and server is same server that the task runs on
Type | DataPathType of location where data source resides

See Also

SASTaskDataDescriptor Class
SAS.Shared.AddIns Namespace


SASTaskDataDescriptor Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTaskDataDescriptor Methods
SASTaskDataDescriptor Class See Also

The SASTaskDataDescriptor type exposes the following members.

Methods

Name | Description
CreateDescriptorFromDescriptor | Used to create an ISASTaskDataDescriptor from an existing one and a new server name
CreateDescriptorFromXml | Used to create an ISASTaskDataDescriptor from an XmlNode created via the WriteSerializationString method
CreateLibraryNameDataDescriptor | Used to create an ISASTaskDataDescriptor that describes a Data source in a SAS Library defined in metadata. Use this method if Library is defined in metadata
CreateLibrefDataDescriptor | Used to create an ISASTaskDataDescriptor that describes a Data source in a user assigned SAS Library. Use this method if Library is user assigned or not in metadata
CreateLocalDataDescriptor | Used to create an ISASTaskDataDescriptor that describes a local file path
CreateServerFileDataDescriptor | Used to create an ISASTaskDataDescriptor that describes a file path on a remote or local server
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsSameData | Does this data descriptor point to same location as that passed in?
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteSerializationString | Write serialization info to XmlTextWriter

See Also

SASTaskDataDescriptor Class
SAS.Shared.AddIns Namespace


CreateDescriptorFromDescriptor Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTaskDataDescriptor..::.CreateDescriptorFromDescriptor Method
SASTaskDataDescriptor Class See Also

Used to create an ISASTaskDataDescriptor from an existing one and a new server name

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateDescriptorFromDescriptor ( _
    dataD As ISASTaskDataDescriptor, _
    newServer As String _
) As ISASTaskDataDescriptor
C#
public static ISASTaskDataDescriptor CreateDescriptorFromDescriptor(
    ISASTaskDataDescriptor dataD,
    string newServer
)

Parameters

dataD
Type: SAS.Shared.AddIns..::.ISASTaskDataDescriptor
Data Descriptor to base new one on
newServer
Type: System..::.String
The new ServerName to use

Return Value

ISASTaskDataDescriptor

See Also

SASTaskDataDescriptor Class
SAS.Shared.AddIns Namespace


CreateDescriptorFromXml Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTaskDataDescriptor..::.CreateDescriptorFromXml Method
SASTaskDataDescriptor Class See Also

Used to create an ISASTaskDataDescriptor from an XmlNode created via the WriteSerializationString method

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateDescriptorFromXml ( _
    xNode As XmlNode _
) As ISASTaskDataDescriptor
C#
public static ISASTaskDataDescriptor CreateDescriptorFromXml(
    XmlNode xNode
)

Parameters

xNode
Type: System.Xml..::.XmlNode
XmlNode that contains required info

Return Value

ISASTaskDataDescriptor

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown if xNode is null
System..::.ArgumentException | Thrown if xNode is not set up correctly

See Also

SASTaskDataDescriptor Class
SAS.Shared.AddIns Namespace


CreateLibraryNameDataDescriptor Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTaskDataDescriptor..::.CreateLibraryNameDataDescriptor Method
SASTaskDataDescriptor Class See Also

Used to create an ISASTaskDataDescriptor that describes a Data source in a SAS Library defined in metadata. Use this method if Library is defined in metadata

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateLibraryNameDataDescriptor ( _
    serverName As String, _
    libraryName As String, _
    memberName As String, _
    label As String _
) As ISASTaskDataDescriptor
C#
public static ISASTaskDataDescriptor CreateLibraryNameDataDescriptor(
    string serverName,
    string libraryName,
    string memberName,
    string label
)

Parameters

serverName
Type: System..::.String
Name of server data source resides on
libraryName
Type: System..::.String
Metadata name of Library
memberName
Type: System..::.String
Table name of the data source
label
Type: System..::.String
Descriptive label for the data source.

Return Value

ISASTaskDataDescriptor

See Also

SASTaskDataDescriptor Class
SAS.Shared.AddIns Namespace


CreateLibrefDataDescriptor Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTaskDataDescriptor..::.CreateLibrefDataDescriptor Method
SASTaskDataDescriptor Class See Also

Used to create an ISASTaskDataDescriptor that describes a Data source in a user assigned SAS Library. Use this method if Library is user assigned or not in metadata

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateLibrefDataDescriptor ( _
    serverName As String, _
    libref As String, _
    memberName As String, _
    label As String _
) As ISASTaskDataDescriptor
C#
public static ISASTaskDataDescriptor CreateLibrefDataDescriptor(
    string serverName,
    string libref,
    string memberName,
    string label
)

Parameters

serverName
Type: System..::.String
Name of server data source resides on
libref
Type: System..::.String
SASLibraryName ( libref ) of the library the data source is in
memberName
Type: System..::.String
Table name of the data source
label
Type: System..::.String
Descriptive label for the data source.

Return Value

ISASTaskDataDescriptor

See Also

SASTaskDataDescriptor Class
SAS.Shared.AddIns Namespace


CreateLocalDataDescriptor Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTaskDataDescriptor..::.CreateLocalDataDescriptor Method
SASTaskDataDescriptor Class See Also

Used to create an ISASTaskDataDescriptor that describes a local file path

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateLocalDataDescriptor ( _
    filePath As String, _
    label As String _
) As ISASTaskDataDescriptor
C#
public static ISASTaskDataDescriptor CreateLocalDataDescriptor(
    string filePath,
    string label
)

Parameters

filePath
Type: System..::.String
Path to the file on the local machines file system
label
Type: System..::.String
Descriptive label for the data source.

Return Value

ISASTaskDataDescriptor

See Also

SASTaskDataDescriptor Class
SAS.Shared.AddIns Namespace


CreateServerFileDataDescriptor Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTaskDataDescriptor..::.CreateServerFileDataDescriptor Method
SASTaskDataDescriptor Class See Also

Used to create an ISASTaskDataDescriptor that describes a file path on a remote or local server

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateServerFileDataDescriptor ( _
    serverName As String, _
    filePath As String, _
    label As String _
) As ISASTaskDataDescriptor
C#
public static ISASTaskDataDescriptor CreateServerFileDataDescriptor(
    string serverName,
    string filePath,
    string label
)

Parameters

serverName
Type: System..::.String
Name of server data source resides on
filePath
Type: System..::.String
Path to the file on the local machines file system
label
Type: System..::.String
Descriptive label for the data source.

Return Value

ISASTaskDataDescriptor

See Also

SASTaskDataDescriptor Class
SAS.Shared.AddIns Namespace


IsSameData Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTaskDataDescriptor..::.IsSameData Method
SASTaskDataDescriptor Class See Also

Does this data descriptor point to same location as that passed in?

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Function IsSameData ( _
    serverName As String, _
    libraryName As String, _
    memberName As String _
) As Boolean
C#
public bool IsSameData(
    string serverName,
    string libraryName,
    string memberName
)

Parameters

serverName
Type: System..::.String
Server data resides on
libraryName
Type: System..::.String
Library Name (metadata name ) that data resides in
memberName
Type: System..::.String
Table Name of dataset

Return Value

true if Server, library and member are the same

Implements

ISASTaskDataDescriptor..::.IsSameData(String, String, String)

See Also

SASTaskDataDescriptor Class
SAS.Shared.AddIns Namespace


WriteSerializationString Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTaskDataDescriptor..::.WriteSerializationString Method
SASTaskDataDescriptor Class See Also

Write serialization info to XmlTextWriter

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteSerializationString ( _
    xWriter As XmlTextWriter _
)
C#
public void WriteSerializationString(
    XmlTextWriter xWriter
)

Parameters

xWriter
Type: System.Xml..::.XmlTextWriter
xmlTextWriter

See Also

SASTaskDataDescriptor Class
SAS.Shared.AddIns Namespace


SASTaskDataDescriptor Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTaskDataDescriptor Properties
SASTaskDataDescriptor Class See Also

The SASTaskDataDescriptor type exposes the following members.

Properties

Name | Description
DelimitedDisplayName | A tab delimited display name provided for display purpose only
FilePath | FileSystem path to the data source on a server or local machine null if DataPathType is Libref
Label | Descriptive label for the data source
LibraryName | Name of the SAS Library in Metadata, corresponds to Libref if null and DataPathType is Libref, will return Libref null if DataPathType is FilePath
Libref | SASLibraryName ( libref ) of the library the data source is in null if DataPathType is FilePath
Member | Table name of the data source null if DataPathType is FilePath
Server | Server the file resides on null if DataPathType is FilePath and data source is on users local machine can be null if DataPathType is Libref, and server is same server that the task runs on
Type | DataPathType of location where data source resides

See Also

SASTaskDataDescriptor Class
SAS.Shared.AddIns Namespace


DelimitedDisplayName Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTaskDataDescriptor..::.DelimitedDisplayName Property
SASTaskDataDescriptor Class See Also

A tab delimited display name provided for display purpose only

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DelimitedDisplayName As String
C#
public string DelimitedDisplayName { get; }

Implements

ISASTaskDataDescriptor..::.DelimitedDisplayName

See Also

SASTaskDataDescriptor Class
SAS.Shared.AddIns Namespace


FilePath Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTaskDataDescriptor..::.FilePath Property
SASTaskDataDescriptor Class See Also

FileSystem path to the data source on a server or local machine null if DataPathType is Libref

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Property FilePath As String
C#
public string FilePath { get; private set; }

Implements

ISASTaskDataDescriptor..::.FilePath

See Also

SASTaskDataDescriptor Class
SAS.Shared.AddIns Namespace


Label Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTaskDataDescriptor..::.Label Property
SASTaskDataDescriptor Class See Also

Descriptive label for the data source

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Property Label As String
C#
public string Label { get; private set; }

Implements

ISASTaskDataDescriptor..::.Label

See Also

SASTaskDataDescriptor Class
SAS.Shared.AddIns Namespace


LibraryName Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTaskDataDescriptor..::.LibraryName Property
SASTaskDataDescriptor Class See Also

Name of the SAS Library in Metadata, corresponds to Libref if null and DataPathType is Libref, will return Libref null if DataPathType is FilePath

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Property LibraryName As String
C#
public string LibraryName { get; private set; }

Implements

ISASTaskDataDescriptor..::.LibraryName

See Also

SASTaskDataDescriptor Class
SAS.Shared.AddIns Namespace


Libref Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTaskDataDescriptor..::.Libref Property
SASTaskDataDescriptor Class See Also

SASLibraryName ( libref ) of the library the data source is in null if DataPathType is FilePath

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Property Libref As String
C#
public string Libref { get; private set; }

Implements

ISASTaskDataDescriptor..::.Libref

See Also

SASTaskDataDescriptor Class
SAS.Shared.AddIns Namespace


Member Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTaskDataDescriptor..::.Member Property
SASTaskDataDescriptor Class See Also

Table name of the data source null if DataPathType is FilePath

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Property Member As String
C#
public string Member { get; private set; }

Implements

ISASTaskDataDescriptor..::.Member

See Also

SASTaskDataDescriptor Class
SAS.Shared.AddIns Namespace


Server Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTaskDataDescriptor..::.Server Property
SASTaskDataDescriptor Class See Also

Server the file resides on null if DataPathType is FilePath and data source is on users local machine can be null if DataPathType is Libref, and server is same server that the task runs on

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Property Server As String
C#
public string Server { get; private set; }

Implements

ISASTaskDataDescriptor..::.Server

See Also

SASTaskDataDescriptor Class
SAS.Shared.AddIns Namespace


Type Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTaskDataDescriptor..::.Type Property
SASTaskDataDescriptor Class See Also

DataPathType of location where data source resides

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As DataPathType
C#
public DataPathType Type { get; private set; }

Implements

ISASTaskDataDescriptor..::.Type

See Also

SASTaskDataDescriptor Class
SAS.Shared.AddIns Namespace


SASTaskThreadSafeAttribute Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTaskThreadSafeAttribute Class
Members See Also

Attribute to indicate whether certain methods of the ISASTask interface are guaranteed to be thread-safe. Set this attribute to True only when you can ensure that your task will function properly regardless of what thread is used when calling into it.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Class)> _
Public Class SASTaskThreadSafeAttribute _
    Inherits Attribute
C#
[AttributeUsageAttribute(AttributeTargets.Class)]
public class SASTaskThreadSafeAttribute : Attribute

Remarks

Remarks

Added in version 4.2.

A piece of code is thread-safe if it functions correctly during simultaneous execution by multiple threads. In particular, it must satisfy the need for multiple threads to access the same shared data, and the need for a shared piece of data to be accessed by only one thread at any given time.

In this context, the concern over thread-safety is that the following methods/properties must function correctly regardless of what thread they are called from. SAS applications that use these tasks might call into your task from a background, or worker, thread. When this occurs, your task cannot rely on calling into any code that involves querying or updating a user interface control or form.

Tasks that are marked as thread-safe might enjoy a slight performance boost when run by an application, as the application has greater flexibility for scheduling the task work on a background thread. Also, the user interface of the application will remain responsive during potentially long-running methods.

The thread-safe methods/properties must include:
  • SasCode
  • XmlState
  • ActiveDataChanged()()()
  • ISASTaskExecution (all members)

Inheritance Hierarchy

System..::.Object
System..::.Attribute
SAS.Shared.AddIns..::.SASTaskThreadSafeAttribute

See Also

SASTaskThreadSafeAttribute Members
SAS.Shared.AddIns Namespace


SASTaskThreadSafeAttribute Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTaskThreadSafeAttribute Members
SASTaskThreadSafeAttribute Class Constructors Methods Properties Explicit Interface Implementations See Also

The SASTaskThreadSafeAttribute type exposes the following members.

Constructors

Name | Description
SASTaskThreadSafeAttribute | Constructor

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsThreadSafe | Sets or gets the value of the attribute.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

SASTaskThreadSafeAttribute Class
SAS.Shared.AddIns Namespace


SASTaskThreadSafeAttribute Constructor

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTaskThreadSafeAttribute Constructor
SASTaskThreadSafeAttribute Class See Also

Constructor

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    bValue As Boolean _
)
C#
public SASTaskThreadSafeAttribute(
    bool bValue
)

Parameters

bValue
Type: System..::.Boolean
Indicates whether the task class is threadsafe.

See Also

SASTaskThreadSafeAttribute Class
SAS.Shared.AddIns Namespace


SASTaskThreadSafeAttribute Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTaskThreadSafeAttribute Methods
SASTaskThreadSafeAttribute Class See Also

The SASTaskThreadSafeAttribute type exposes the following members.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

SASTaskThreadSafeAttribute Class
SAS.Shared.AddIns Namespace


SASTaskThreadSafeAttribute Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTaskThreadSafeAttribute Properties
SASTaskThreadSafeAttribute Class See Also

The SASTaskThreadSafeAttribute type exposes the following members.

Properties

Name | Description
IsThreadSafe | Sets or gets the value of the attribute.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

SASTaskThreadSafeAttribute Class
SAS.Shared.AddIns Namespace


IsThreadSafe Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTaskThreadSafeAttribute..::.IsThreadSafe Property
SASTaskThreadSafeAttribute Class See Also

Sets or gets the value of the attribute.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Property IsThreadSafe As Boolean
C#
public bool IsThreadSafe { get; set; }

See Also

SASTaskThreadSafeAttribute Class
SAS.Shared.AddIns Namespace


ServerAccessMode Enumeration

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ServerAccessMode Enumeration
See Also

Used with the ShowDataSelector method to control which servers the selector dialog will allow access to.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration ServerAccessMode
C#
public enum ServerAccessMode

Members

Member name | Description
AnyServer | Allow access to any available SAS server.
OneServer | Allow access to just one SAS server, named in the Server argument.

See Also

SAS.Shared.AddIns Namespace
ISASTaskConsumer2..::.ShowDataSelector(IWin32Window, DataSelectionMode, ServerAccessMode, String, String, String, String%)


ShowResult Enumeration

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ShowResult Enumeration
See Also

Possible values to return from the ISASTask.Show method.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration ShowResult
C#
public enum ShowResult

Members

Member name | Description
Canceled | Task is canceled -- discard changes and do not run.
RunNow | Run task now -- immediately.
RunLater | Save task state so that it can be run later.
RunPinned | This value is not currently supported.

See Also

SAS.Shared.AddIns Namespace
ISASTask..::.Show(IWin32Window)


ShowType Enumeration

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ShowType Enumeration
See Also

This enumeration is for SAS internal use only.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration ShowType
C#
public enum ShowType

Members

Member name | Description
Code | SAS internal use
Wizard | SAS internal use
Interactive | SAS internal use

See Also

SAS.Shared.AddIns Namespace


SortDirection Enumeration

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SortDirection Enumeration
See Also

Enumeration of possible sort directions.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration SortDirection
C#
public enum SortDirection

Members

Member name | Description
None | Not sorted
Ascending | Sorted ascending
Descending | Sorted descending

See Also

SAS.Shared.AddIns Namespace
ISASTaskDataColumn..::.Sorted


SourceType Enumeration

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SourceType Enumeration
See Also

Enumeration for the subtype of data surfaced by the host application. These are more specific subtypes of the data types described in DataType.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration SourceType
C#
public enum SourceType

Members

Member name | Description
Unknown | Unknown subtype
SasDataset | SAS data set
SasQuery | SAS query (generated with PROC SQL)
ExcelSpreadSheet | A Microsoft Excel spreadsheet table
ExcelQuery | A Microsoft Excel spreadsheet query
AccessTable | A Microsoft Access table
AccessQuery | A Microsoft Access query
LotusSpreadSheet | A Lotus spreadsheet table
DbaseTable | A DBase table
AdoTable | A table accessed via ADO
OdbcData | A table accessed via ODBC
ParadoxTable | A Paradox table
TextTable | A flat-file text table
HtmlTable | An HTML table.
ExchangeTable | A table accessed via Microsoft Exchange
OledbTable | A table accessed via OLEDB
MddbCube | An OLAP table
InformationMap | An InformationMap

See Also

SAS.Shared.AddIns Namespace


Statistics Enumeration

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
Statistics Enumeration
See Also

Enumeration of available statistics that can be returned for a data column.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration Statistics
C#
public enum Statistics

Members

Member name | Description
MAX | Statistic - Maximum value
MEAN | Statistic - Arithmetic mean value
MIN | Statistic - Minimum value
N | Statistic - Number of non-missing values
STD | Statistic - Standard deviation value

See Also

SAS.Shared.AddIns Namespace
ISASTaskDataColumn..::.Statistic(Statistics)


SupportsObsOptionsAttribute Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SupportsObsOptionsAttribute Class
Members See Also

Attribute to indicate whether this task supports the FIRSTOBS and OBS mechanisms to limit input and output processing. These values are settable on NObsSetting and FirstObsSetting.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Class)> _
Public Class SupportsObsOptionsAttribute _
    Inherits Attribute
C#
[AttributeUsageAttribute(AttributeTargets.Class)]
public class SupportsObsOptionsAttribute : Attribute

Remarks

Set this attribute to false if your task does not support FIRSTOBS and OBS. This tells the application to disable these options for your task properties, thus reducing potential confusion. If you do not set this to false, and you don't support FIRSTOBS and OBS processing, these options will be enabled in the task properties dialog, and end users will find that the settings have no effect on your task.

Inheritance Hierarchy

System..::.Object
System..::.Attribute
SAS.Shared.AddIns..::.SupportsObsOptionsAttribute

See Also

SupportsObsOptionsAttribute Members
SAS.Shared.AddIns Namespace


SupportsObsOptionsAttribute Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SupportsObsOptionsAttribute Members
SupportsObsOptionsAttribute Class Constructors Methods Properties Explicit Interface Implementations See Also

The SupportsObsOptionsAttribute type exposes the following members.

Constructors

Name | Description
SupportsObsOptionsAttribute | Constructor

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsObsLimitationsSupported | Sets or gets the value of the attribute.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

SupportsObsOptionsAttribute Class
SAS.Shared.AddIns Namespace


SupportsObsOptionsAttribute Constructor

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SupportsObsOptionsAttribute Constructor
SupportsObsOptionsAttribute Class See Also

Constructor

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    bValue As Boolean _
)
C#
public SupportsObsOptionsAttribute(
    bool bValue
)

Parameters

bValue
Type: System..::.Boolean
Indicates whether the task supports the FIRSTOBS and OBS mechanisms. These values are settable on NObsSetting and FirstObsSetting.

See Also

SupportsObsOptionsAttribute Class
SAS.Shared.AddIns Namespace


SupportsObsOptionsAttribute Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SupportsObsOptionsAttribute Methods
SupportsObsOptionsAttribute Class See Also

The SupportsObsOptionsAttribute type exposes the following members.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

SupportsObsOptionsAttribute Class
SAS.Shared.AddIns Namespace


SupportsObsOptionsAttribute Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SupportsObsOptionsAttribute Properties
SupportsObsOptionsAttribute Class See Also

The SupportsObsOptionsAttribute type exposes the following members.

Properties

Name | Description
IsObsLimitationsSupported | Sets or gets the value of the attribute.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

SupportsObsOptionsAttribute Class
SAS.Shared.AddIns Namespace


IsObsLimitationsSupported Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SupportsObsOptionsAttribute..::.IsObsLimitationsSupported Property
SupportsObsOptionsAttribute Class See Also

Sets or gets the value of the attribute.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Property IsObsLimitationsSupported As Boolean
C#
public bool IsObsLimitationsSupported { get; set; }

See Also

SupportsObsOptionsAttribute Class
SAS.Shared.AddIns Namespace


TaskExecutionStatusChangedHandler Delegate

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskExecutionStatusChangedHandler Delegate
See Also

Delegate for an event handler implemented by the application. Used in conjunction with StatusChanged.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub TaskExecutionStatusChangedHandler ( _
    sender As Object, _
    args As TaskExecutionStatusEventArgs _
)
C#
public delegate void TaskExecutionStatusChangedHandler(
    Object sender,
    TaskExecutionStatusEventArgs args
)

Parameters

sender
Type: System..::.Object
The object (task) that raised the event
args
Type: SAS.Shared.AddIns..::.TaskExecutionStatusEventArgs
The event args with the status message.

See Also

SAS.Shared.AddIns Namespace


TaskExecutionStatusEventArgs Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskExecutionStatusEventArgs Class
Members See Also

Special EventArgs class for communicating status updates from tasks that implement ISASTaskExecution2.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Class TaskExecutionStatusEventArgs _
    Inherits EventArgs
C#
public class TaskExecutionStatusEventArgs : EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
SAS.Shared.AddIns..::.TaskExecutionStatusEventArgs

See Also

TaskExecutionStatusEventArgs Members
SAS.Shared.AddIns Namespace


TaskExecutionStatusEventArgs Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskExecutionStatusEventArgs Members
TaskExecutionStatusEventArgs Class Constructors Methods Properties See Also

The TaskExecutionStatusEventArgs type exposes the following members.

Constructors

Name | Description
TaskExecutionStatusEventArgs | Constructs the EventArgs with the status message.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
StatusMsg | Gets the status message.

See Also

TaskExecutionStatusEventArgs Class
SAS.Shared.AddIns Namespace


TaskExecutionStatusEventArgs Constructor

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskExecutionStatusEventArgs Constructor
TaskExecutionStatusEventArgs Class See Also

Constructs the EventArgs with the status message.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    statusMsg As String _
)
C#
public TaskExecutionStatusEventArgs(
    string statusMsg
)

Parameters

statusMsg
Type: System..::.String

See Also

TaskExecutionStatusEventArgs Class
SAS.Shared.AddIns Namespace


TaskExecutionStatusEventArgs Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskExecutionStatusEventArgs Methods
TaskExecutionStatusEventArgs Class See Also

The TaskExecutionStatusEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TaskExecutionStatusEventArgs Class
SAS.Shared.AddIns Namespace


TaskExecutionStatusEventArgs Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskExecutionStatusEventArgs Properties
TaskExecutionStatusEventArgs Class See Also

The TaskExecutionStatusEventArgs type exposes the following members.

Properties

Name | Description
StatusMsg | Gets the status message.

See Also

TaskExecutionStatusEventArgs Class
SAS.Shared.AddIns Namespace


StatusMsg Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskExecutionStatusEventArgs..::.StatusMsg Property
TaskExecutionStatusEventArgs Class See Also

Gets the status message.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StatusMsg As String
C#
public string StatusMsg { get; }

See Also

TaskExecutionStatusEventArgs Class
SAS.Shared.AddIns Namespace


TaskMigratorClassAttribute Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskMigratorClassAttribute Class
Members See Also

Attribute to indicate TaskMigration classname. This class must implement the ITaskMigrator interface

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple := False)> _
Public Class TaskMigratorClassAttribute _
    Inherits Attribute
C#
[AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = false)]
public class TaskMigratorClassAttribute : Attribute

Remarks

Added in version 4.2

Inheritance Hierarchy

System..::.Object
System..::.Attribute
SAS.Shared.AddIns..::.TaskMigratorClassAttribute

See Also

TaskMigratorClassAttribute Members
SAS.Shared.AddIns Namespace


TaskMigratorClassAttribute Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskMigratorClassAttribute Members
TaskMigratorClassAttribute Class Constructors Methods Properties Explicit Interface Implementations See Also

The TaskMigratorClassAttribute type exposes the following members.

Constructors

Name | Description
TaskMigratorClassAttribute | Constructor for this attribute

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAssemblyName | Gets the Assembly Name containing the TaskMigrator class
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeName | Gets the Type Name of the TaskMigrator class
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

TaskMigratorClassAttribute Class
SAS.Shared.AddIns Namespace


TaskMigratorClassAttribute Constructor

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskMigratorClassAttribute Constructor
TaskMigratorClassAttribute Class See Also

Constructor for this attribute

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    assemblyName As String, _
    typeName As String _
)
C#
public TaskMigratorClassAttribute(
    string assemblyName,
    string typeName
)

Parameters

assemblyName
Type: System..::.String
Name of the assembly containing the class
typeName
Type: System..::.String
TypeName of the class

See Also

TaskMigratorClassAttribute Class
SAS.Shared.AddIns Namespace


TaskMigratorClassAttribute Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskMigratorClassAttribute Methods
TaskMigratorClassAttribute Class See Also

The TaskMigratorClassAttribute type exposes the following members.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAssemblyName | Gets the Assembly Name containing the TaskMigrator class
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeName | Gets the Type Name of the TaskMigrator class
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

TaskMigratorClassAttribute Class
SAS.Shared.AddIns Namespace


GetAssemblyName Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskMigratorClassAttribute..::.GetAssemblyName Method
TaskMigratorClassAttribute Class See Also

Gets the Assembly Name containing the TaskMigrator class

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Function GetAssemblyName As String
C#
public string GetAssemblyName()

Return Value

AssemblyName

See Also

TaskMigratorClassAttribute Class
SAS.Shared.AddIns Namespace


GetTypeName Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskMigratorClassAttribute..::.GetTypeName Method
TaskMigratorClassAttribute Class See Also

Gets the Type Name of the TaskMigrator class

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Function GetTypeName As String
C#
public string GetTypeName()

Return Value

TypeName

See Also

TaskMigratorClassAttribute Class
SAS.Shared.AddIns Namespace


TaskMigratorClassAttribute Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskMigratorClassAttribute Properties
TaskMigratorClassAttribute Class See Also

The TaskMigratorClassAttribute type exposes the following members.

Properties

Name | Description
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

TaskMigratorClassAttribute Class
SAS.Shared.AddIns Namespace


VariableGroup Enumeration

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
VariableGroup Enumeration
See Also

Possible values for variable groups, which are a way to categorize variables based on type and format.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration VariableGroup
C#
public enum VariableGroup

Members

Member name | Description
Unknown | Unknown variable type
Numeric | Numeric type
Character | Character type
Date | Date type (numeric with date format)
Time | Time type (numeric with time format)
Currency | Currency type (numeric with currency format)
Other | Other type not defined here
OleData | Embedded OLE object type
GeoRef | GeoRef type for use with GIS or mapping data

See Also

SAS.Shared.AddIns Namespace
SAS.Shared.AddIns..::.ISASTaskDataColumn


ViewType Enumeration

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ViewType Enumeration
See Also

Possible values for ViewType as used in the ISASTask2 interface.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration ViewType
C#
public enum ViewType

Members

Member name | Description
Wizard | Task displayed as a wizard.
Advanced | Task displayed as advanced dialogs.
Interactive | Task displayed as window with main menu and toolbar.

See Also

SAS.Shared.AddIns Namespace
ISASTask2..::.Show(IWin32Window, ViewType)
ISASTask2..::.ShowDialog(IWin32Window, ViewType)


WindowStartPosition Enumeration

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WindowStartPosition Enumeration
See Also

Possible values for how the position and geometry of the task window is to be displayed.

Namespace: SAS.Shared.AddIns
Assembly: SAS.Shared.AddIns (in SAS.Shared.AddIns.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration WindowStartPosition
C#
public enum WindowStartPosition

Members

Member name | Description
CenterParent | The form is centered within the bounds of its parent form and has the dimensions specified in the ISASTaskDisplay properties.
CenterScreen | The form is centered on the current display and has the dimensions specified in the ISASTaskDisplay properties.
Manual | The position and size of the form is determined by the ISASTaskDisplay properties.
WindowsDefaultBounds | The form is positioned at the Windows default location and has the bounds determined by Windows default.
WindowsDefaultLocation | The form is positioned at the Windows default location and has the dimensions specified in the ISASTaskDisplay properties.
CenterParentTasksDefaultSize | The form is centered within the bounds of its parent form and is initially sized such that it can fully display all the panels without scrollbars.
CenterScreenTasksDefaultSize | The form is centered on the current display and is initially sized such that it can fully display all the panels without scrollbars.
ManualLocationTasksDefaultSize | The form position is determined by the ISASTaskDisplay properties and is initially sized such that it can fully display all the panels without scrollbars.
WindowsDefaultLocationTasksDefaultSize | The form is positioned at the Windows default location and is initially sized such that it can fully display all the panels without scrollbars.

See Also

SAS.Shared.AddIns Namespace
SAS.Shared.AddIns..::.ISASTaskDisplay


SAS.Tasks.Toolkit Namespace

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SAS.Tasks.Toolkit Namespace

Classes

Class | Description
ClassIdAttribute | Specifies a unique identifier for a SAS task class.
IconLocationAttribute |
SasServer | Provides details and services from a SAS workspace server.
SasTask | Base class to use for SAS custom tasks.
SubmitCompleteEventArgs | Class that carries the event details when a submitted SAS job is completed.
VersionAttribute |

Delegates

Delegate | Description
SubmitCompleteHandler | Delegate for event handler when a submitted SAS job is completed.


ClassIdAttribute Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ClassIdAttribute Class
Members See Also

Specifies a unique identifier for a SAS task class.

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Class)> _
Public NotInheritable Class ClassIdAttribute _
    Inherits Attribute
C#
[AttributeUsageAttribute(AttributeTargets.Class)]
public sealed class ClassIdAttribute : Attribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
SAS.Tasks.Toolkit..::.ClassIdAttribute

See Also

ClassIdAttribute Members
SAS.Tasks.Toolkit Namespace


ClassIdAttribute Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ClassIdAttribute Members
ClassIdAttribute Class Constructors Methods Properties Explicit Interface Implementations See Also

The ClassIdAttribute type exposes the following members.

Constructors

Name | Description
ClassIdAttribute |

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ClsId |
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

ClassIdAttribute Class
SAS.Tasks.Toolkit Namespace


ClassIdAttribute Constructor

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ClassIdAttribute Constructor
ClassIdAttribute Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    clsId As String _
)
C#
public ClassIdAttribute(
    string clsId
)

Parameters

clsId
Type: System..::.String

See Also

ClassIdAttribute Class
SAS.Tasks.Toolkit Namespace


ClassIdAttribute Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ClassIdAttribute Methods
ClassIdAttribute Class See Also

The ClassIdAttribute type exposes the following members.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

ClassIdAttribute Class
SAS.Tasks.Toolkit Namespace


ClassIdAttribute Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ClassIdAttribute Properties
ClassIdAttribute Class See Also

The ClassIdAttribute type exposes the following members.

Properties

Name | Description
ClsId |
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

ClassIdAttribute Class
SAS.Tasks.Toolkit Namespace


ClsId Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ClassIdAttribute..::.ClsId Property
ClassIdAttribute Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClsId As String
C#
public string ClsId { get; }

See Also

ClassIdAttribute Class
SAS.Tasks.Toolkit Namespace


IconLocationAttribute Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
IconLocationAttribute Class
Members See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Class)> _
Public NotInheritable Class IconLocationAttribute _
    Inherits Attribute
C#
[AttributeUsageAttribute(AttributeTargets.Class)]
public sealed class IconLocationAttribute : Attribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
SAS.Tasks.Toolkit..::.IconLocationAttribute

See Also

IconLocationAttribute Members
SAS.Tasks.Toolkit Namespace


IconLocationAttribute Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
IconLocationAttribute Members
IconLocationAttribute Class Constructors Methods Properties Explicit Interface Implementations See Also

The IconLocationAttribute type exposes the following members.

Constructors

Name | Description
IconLocationAttribute | Overloaded.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Assembly |
Name |
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

IconLocationAttribute Class
SAS.Tasks.Toolkit Namespace


IconLocationAttribute Constructor

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
IconLocationAttribute Constructor
IconLocationAttribute Class See Also

Overload List

Name | Description
IconLocationAttribute(String) |
IconLocationAttribute(String, String) |

See Also

IconLocationAttribute Class
IconLocationAttribute Members
SAS.Tasks.Toolkit Namespace


IconLocationAttribute Constructor (String)

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
IconLocationAttribute Constructor (String)
IconLocationAttribute Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)
C#
public IconLocationAttribute(
    string name
)

Parameters

name
Type: System..::.String

See Also

IconLocationAttribute Class
IconLocationAttribute Overload
SAS.Tasks.Toolkit Namespace


IconLocationAttribute Constructor (String, String)

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
IconLocationAttribute Constructor (String, String)
IconLocationAttribute Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    assembly As String _
)
C#
public IconLocationAttribute(
    string name,
    string assembly
)

Parameters

name
Type: System..::.String
assembly
Type: System..::.String

See Also

IconLocationAttribute Class
IconLocationAttribute Overload
SAS.Tasks.Toolkit Namespace


IconLocationAttribute Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
IconLocationAttribute Methods
IconLocationAttribute Class See Also

The IconLocationAttribute type exposes the following members.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

IconLocationAttribute Class
SAS.Tasks.Toolkit Namespace


IconLocationAttribute Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
IconLocationAttribute Properties
IconLocationAttribute Class See Also

The IconLocationAttribute type exposes the following members.

Properties

Name | Description
Assembly |
Name |
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

IconLocationAttribute Class
SAS.Tasks.Toolkit Namespace


Assembly Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
IconLocationAttribute..::.Assembly Property
IconLocationAttribute Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Assembly As String
C#
public string Assembly { get; }

See Also

IconLocationAttribute Class
SAS.Tasks.Toolkit Namespace


Name Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
IconLocationAttribute..::.Name Property
IconLocationAttribute Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name { get; }

See Also

IconLocationAttribute Class
SAS.Tasks.Toolkit Namespace


SasServer Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasServer Class
Members See Also

Provides details and services from a SAS workspace server.

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Class SasServer
C#
public class SasServer

Inheritance Hierarchy

System..::.Object
SAS.Tasks.Toolkit..::.SasServer

See Also

SasServer Members
SAS.Tasks.Toolkit Namespace


SasServer Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasServer Members
SasServer Class Constructors Methods Properties See Also

The SasServer type exposes the following members.

Constructors

Name | Description
SasServer | Creates a SasServer object, given the name of the SAS server (for example, "SASMain").

Methods

Name Description
CopyLocalFileToServer
Copy a local file to a temporary location on the SAS server. This method creates a TEMP SAS file reference (fileref), and transfers the contents of the local file into it. The file transfer is a binary transfer operation, so the contents of the file should be unaltered during the transfer. You can use then use the fileref within a SAS program to perform further operations with the file.
CopyServerFileToLocal
Copy a file from a remote server file system to a temporary location on your local PC. The file transfer is a binary transfer operation, so the contents of the file should be unaltered during the transfer.
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table.
(Inherited from Object.)
GetOleDbConnection
Create an OLE DB connection using the SAS IOM Provider to connect to the SAS workspace server.

Remarks

This method will force a connection to the SAS server, if the connection does not yet exist. The connection might cause a slight delay. It might also force a prompt for user ID and password, depending upon the configuration of the server and its metadata. You should wrap the use of this method in a try/catch/finally block to ensure that the resource is freed at the end of its use, even if an exception occurs.

Examples

The following is an example code snippet that shows how to use this method.
Copy Code
            System.Data.OleDb.OleDbConnection dbConnection;
            System.Data.OleDb.OleDbDataAdapter adapter;
            SAS.Tasks.Toolkit.SasServer server = new SAS.Tasks.Toolkit.SasServer(Consumer.AssignedServer);
            using (dbConnection = server.GetOleDbConnection())
            {
                using (adapter = new OleDbDataAdapter("select * from sashelp.class", dbConnection))
                {
                    try
                    {
                        dbConnection.Open()
                        // perform data actions with the OleDbAdapter -- for example, fill a data grid.
                    }
                    catch
                    {
                        // exception handling
                    }
                    finally
                    {
                        dbConnection.Close();
                    }
                }
            }
GetSasLibraries
Returns a list of SasLibrary objects associated with this server.
GetSasMacroValue
Retrieve the value of a SAS macro variable.
GetSasServers
Get a list of the SAS workspace servers that are available in the current environment.
GetSasSystemOptionValue
Retrieve the value of a SAS system option.
GetType
Gets the Type of the current instance.
(Inherited from Object.)
GetWorkspaceIdentifier
Get the unique workspace identifier. This value is often needed to seed another connection to the workspace -- for example, using the SAS IOM OLE DB Provider.

Remarks

This method will force a connection to the SAS server, if the connection does not yet exist. The connection might cause a slight delay. It might also force a prompt for user ID and password, depending upon the configuration of the server and its metadata.
IsServerBusy
Checks whether the SAS server is already busy processing a SAS program.
MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Properties

Name | Description
IsLocal | Indicates whether the SAS server is a local (COM) server.
Name | Name of this SAS server

See Also

SasServer Class
SAS.Tasks.Toolkit Namespace


SasServer Constructor

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasServer Constructor
SasServer Class See Also

Creates a SasServer object, given the name of the SAS server (for example, "SASMain").

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    serverName As String _
)
C#
public SasServer(
    string serverName
)

Parameters

serverName
Type: System..::.String

See Also

SasServer Class
SAS.Tasks.Toolkit Namespace


SasServer Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasServer Methods
SasServer Class See Also

The SasServer type exposes the following members.

Methods

Name Description
CopyLocalFileToServer
Copy a local file to a temporary location on the SAS server. This method creates a TEMP SAS file reference (fileref), and transfers the contents of the local file into it. The file transfer is a binary transfer operation, so the contents of the file should be unaltered during the transfer. You can use then use the fileref within a SAS program to perform further operations with the file.
CopyServerFileToLocal
Copy a file from a remote server file system to a temporary location on your local PC. The file transfer is a binary transfer operation, so the contents of the file should be unaltered during the transfer.
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
GetHashCode
Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table.
(Inherited from Object.)
GetOleDbConnection
Create an OLE DB connection using the SAS IOM Provider to connect to the SAS workspace server.

Remarks

This method will force a connection to the SAS server, if the connection does not yet exist. The connection might cause a slight delay. It might also force a prompt for user ID and password, depending upon the configuration of the server and its metadata. You should wrap the use of this method in a try/catch/finally block to ensure that the resource is freed at the end of its use, even if an exception occurs.

Examples

The following is an example code snippet that shows how to use this method.
Copy Code
            System.Data.OleDb.OleDbConnection dbConnection;
            System.Data.OleDb.OleDbDataAdapter adapter;
            SAS.Tasks.Toolkit.SasServer server = new SAS.Tasks.Toolkit.SasServer(Consumer.AssignedServer);
            using (dbConnection = server.GetOleDbConnection())
            {
                using (adapter = new OleDbDataAdapter("select * from sashelp.class", dbConnection))
                {
                    try
                    {
                        dbConnection.Open()
                        // perform data actions with the OleDbAdapter -- for example, fill a data grid.
                    }
                    catch
                    {
                        // exception handling
                    }
                    finally
                    {
                        dbConnection.Close();
                    }
                }
            }
GetSasLibraries
Returns a list of SasLibrary objects associated with this server.
GetSasMacroValue
Retrieve the value of a SAS macro variable.
GetSasServers
Get a list of the SAS workspace servers that are available in the current environment.
GetSasSystemOptionValue
Retrieve the value of a SAS system option.
GetType
Gets the Type of the current instance.
(Inherited from Object.)
GetWorkspaceIdentifier
Get the unique workspace identifier. This value is often needed to seed another connection to the workspace -- for example, using the SAS IOM OLE DB Provider.

Remarks

This method will force a connection to the SAS server, if the connection does not yet exist. The connection might cause a slight delay. It might also force a prompt for user ID and password, depending upon the configuration of the server and its metadata.
IsServerBusy
Checks whether the SAS server is already busy processing a SAS program.
MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

SasServer Class
SAS.Tasks.Toolkit Namespace


CopyLocalFileToServer Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasServer..::.CopyLocalFileToServer Method
SasServer Class See Also

Copy a local file to a temporary location on the SAS server. This method creates a TEMP SAS file reference (fileref), and transfers the contents of the local file into it. The file transfer is a binary transfer operation, so the contents of the file should be unaltered during the transfer. You can use then use the fileref within a SAS program to perform further operations with the file.

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Function CopyLocalFileToServer ( _
    localFileName As String _
) As String
C#
public string CopyLocalFileToServer(
    string localFileName
)

Parameters

localFileName
Type: System..::.String
The full path of the local file to copy to the server.

Return Value

The SAS fileref that points to the resulting file.

See Also

SasServer Class
SAS.Tasks.Toolkit Namespace


CopyServerFileToLocal Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasServer..::.CopyServerFileToLocal Method
SasServer Class See Also

Copy a file from a remote server file system to a temporary location on your local PC. The file transfer is a binary transfer operation, so the contents of the file should be unaltered during the transfer.

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Function CopyServerFileToLocal ( _
    remoteFile As String, _
    ext As String _
) As String
C#
public string CopyServerFileToLocal(
    string remoteFile,
    string ext
)

Parameters

remoteFile
Type: System..::.String
Path to the remote file on the SAS server
ext
Type: System..::.String
The file extension to use when creating the temporary file.

Return Value

The full path and name of the file as it is copied locally.

See Also

SasServer Class
SAS.Tasks.Toolkit Namespace


GetOleDbConnection Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasServer..::.GetOleDbConnection Method
SasServer Class See Also

Create an OLE DB connection using the SAS IOM Provider to connect to the SAS workspace server.

Remarks

This method will force a connection to the SAS server, if the connection does not yet exist. The connection might cause a slight delay. It might also force a prompt for user ID and password, depending upon the configuration of the server and its metadata. You should wrap the use of this method in a try/catch/finally block to ensure that the resource is freed at the end of its use, even if an exception occurs.

Examples

The following is an example code snippet that shows how to use this method.
Copy Code
            System.Data.OleDb.OleDbConnection dbConnection;
            System.Data.OleDb.OleDbDataAdapter adapter;
            SAS.Tasks.Toolkit.SasServer server = new SAS.Tasks.Toolkit.SasServer(Consumer.AssignedServer);
            using (dbConnection = server.GetOleDbConnection())
            {
                using (adapter = new OleDbDataAdapter("select * from sashelp.class", dbConnection))
                {
                    try
                    {
                        dbConnection.Open()
                        // perform data actions with the OleDbAdapter -- for example, fill a data grid.
                    }
                    catch
                    {
                        // exception handling
                    }
                    finally
                    {
                        dbConnection.Close();
                    }
                }
            }

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Function GetOleDbConnection As OleDbConnection
C#
public OleDbConnection GetOleDbConnection()

Return Value

A System.Data.OleDb.OleDbConnection object, ready to use with a data adapter or other object.

See Also

SasServer Class
SAS.Tasks.Toolkit Namespace


GetSasLibraries Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasServer..::.GetSasLibraries Method
SasServer Class See Also

Returns a list of SasLibrary objects associated with this server.

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSasLibraries As IList(Of SasLibrary)
C#
public IList<SasLibrary> GetSasLibraries()

Return Value

The list of SAS libraries. Note that some of the libraries might not be assigned.

See Also

SasServer Class
SAS.Tasks.Toolkit Namespace


GetSasMacroValue Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasServer..::.GetSasMacroValue Method
SasServer Class See Also

Retrieve the value of a SAS macro variable.

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSasMacroValue ( _
    macroVariable As String _
) As String
C#
public string GetSasMacroValue(
    string macroVariable
)

Parameters

macroVariable
Type: System..::.String
The name of the macro variable.

Return Value

The text value for the given macro variable.

See Also

SasServer Class
SAS.Tasks.Toolkit Namespace


GetSasServers Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasServer..::.GetSasServers Method
SasServer Class See Also

Get a list of the SAS workspace servers that are available in the current environment.

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetSasServers As List(Of SasServer)
C#
public static List<SasServer> GetSasServers()

Return Value

List of SasServer objects -- one SasServer object for each available SAS server.

See Also

SasServer Class
SAS.Tasks.Toolkit Namespace


GetSasSystemOptionValue Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasServer..::.GetSasSystemOptionValue Method
SasServer Class See Also

Retrieve the value of a SAS system option.

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSasSystemOptionValue ( _
    optionName As String _
) As String
C#
public string GetSasSystemOptionValue(
    string optionName
)

Parameters

optionName
Type: System..::.String
The name of the system option.

Return Value

The text value for the given system option.

See Also

SasServer Class
SAS.Tasks.Toolkit Namespace


GetWorkspaceIdentifier Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasServer..::.GetWorkspaceIdentifier Method
SasServer Class See Also

Get the unique workspace identifier. This value is often needed to seed another connection to the workspace -- for example, using the SAS IOM OLE DB Provider.

Remarks

This method will force a connection to the SAS server, if the connection does not yet exist. The connection might cause a slight delay. It might also force a prompt for user ID and password, depending upon the configuration of the server and its metadata.

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Function GetWorkspaceIdentifier As String
C#
public string GetWorkspaceIdentifier()

Return Value

A string with the unique identifier of the SAS session.

See Also

SasServer Class
SAS.Tasks.Toolkit Namespace


IsServerBusy Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasServer..::.IsServerBusy Method
SasServer Class See Also

Checks whether the SAS server is already busy processing a SAS program.

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Function IsServerBusy As Boolean
C#
public bool IsServerBusy()

Return Value

true if the server has SAS program jobs in its queue, else false.

See Also

SasServer Class
SAS.Tasks.Toolkit Namespace


SasServer Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasServer Properties
SasServer Class See Also

The SasServer type exposes the following members.

Properties

Name | Description
IsLocal | Indicates whether the SAS server is a local (COM) server.
Name | Name of this SAS server

See Also

SasServer Class
SAS.Tasks.Toolkit Namespace


IsLocal Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasServer..::.IsLocal Property
SasServer Class See Also

Indicates whether the SAS server is a local (COM) server.

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsLocal As Boolean
C#
public bool IsLocal { get; }

See Also

SasServer Class
SAS.Tasks.Toolkit Namespace


Name Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasServer..::.Name Property
SasServer Class See Also

Name of this SAS server

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name { get; }

See Also

SasServer Class
SAS.Tasks.Toolkit Namespace


SasTask Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask Class
Members See Also

Base class to use for SAS custom tasks.

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
<VersionAttribute()> _
Public Class SasTask _
    Inherits Component _
    Implements ISASTaskAddIn, ISASTaskDescription, ISASTask3, ISASTask2,  _
    ISASTask, ISASTaskSubmitSink, ISASTaskDataSink2, ISASTaskDataSink, ISASTaskTemplate,  _
    ISupportRoleBased
C#
[VersionAttribute()]
public class SasTask : Component, ISASTaskAddIn,
    ISASTaskDescription, ISASTask3, ISASTask2, ISASTask, ISASTaskSubmitSink,
    ISASTaskDataSink2, ISASTaskDataSink, ISASTaskTemplate, ISupportRoleBased

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
SAS.Tasks.Toolkit..::.SasTask

See Also

SasTask Members
SAS.Tasks.Toolkit Namespace


SasTask Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask Members
SasTask Class Constructors Methods Properties Events See Also

The SasTask type exposes the following members.

Constructors

Name | Description
SasTask | Overloaded.

Methods

Name | Description
Activate |
ActiveDataChanged |
ActiveStateChanged |
Close |
Connect |
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateTaskTemplate |
Disconnect |
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GenerateOutputData |
GenerateOutputDataNames |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetSasCode | Virtual method that is called when the application retrieves the SasCode property.
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlState | Overloaded.
Initialize |
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InputDataChanged |
Languages |
MemberwiseClone | Overloaded.
OnCreateNewOutputDataNames |
OpenTaskTemplate |
OutputDataInfo | This method is deprecated. Override OutputDataDescriptorList instead to build up a list of the output data items that you expect to create or modify as part of this task.
RestoreStateFromXml | Overloaded.
Show | Overloaded.
ShowDialog |
SubmitComplete | This method is called by the application when a submitted job is complete. Do not call this method directly from within your task.
SubmitSASProgram | Submit a SAS program to the assigned server. This method returns immediately after submitting the program. Subscribe to the SubmitSASProgramComplete event to receive notification when the job is complete.
SubmitSASProgramAndWait | Submit a SAS program to the assigned server and waits until processing is complete before returning. Subscribe to the SubmitSASProgramComplete event to receive notification of the job completion, success, and log.
Terminate |
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AddInDescription |
AddInName |
AllowModifyCustomCode | For tasks that support adding custom code, this property indicates whether an administrator decided to limit this function.
AllowModifyOutputData | For tasks that support specifying output data, this property indicates whether an administrator decided to limit this function. The limitation should be interpreted as "do not allow the end user to change the output data location."
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Clsid | Unique GUID-formatted identifier for this task. The value is set by using the [ClassId] attribute. See ClassIdAttribute.
Consumer |
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FriendlyName |
GeneratesListOutput |
GeneratesReportOutput | Does this task generate ODS or report output?
GeneratesSasCode |
IconAssembly |
IconName |
Label |
Language |
MajorVersion |
MinorVersion |
Modal |
NumericColsRequired |
NumericColumnsRequired | How many numberic columns (if any) are expected in the input data in order for this task to be useful.
OutputDataCount |
OutputDataDescriptorList |
ParameterNames |
ProcsUsed |
ProductsOptional |
ProductsRequired |
ReadOnlyMode | This property indicates whether an administrator has restricted the end user from modifying the contents of the project. In this case, the task should disable the OK or Finish button, and prevent the end user from making committing changes to the task options.
RequiresData |
RunLog |
SasCode |
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StandardCategory | Indicates whether this is a SAS task supplied with a SAS product. If false, then the application will not add the task to the Add-Ins menu automatically. Most custom tasks should not override this property, otherwise the task might not appear in the application menus.
SupportsTemplates | Whether this task supports task templates, allowing the end user to save a version of this task with the current settings for later use.
TaskCategory |
TaskDescription |
TaskName |
TaskType |
Validation |
Visible |
VisibleInManager |
WhatIsDescription |
XmlResult |
XmlState |

Events

Name | Description
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
SubmitSASProgramComplete | Event that is raised when a SAS program submitted using SubmitSASProgram(String) is complete.

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


SasTask Constructor

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask Constructor
SasTask Class See Also

Overload List

Name | Description
SasTask()()() | Constructor
SasTask(IContainer) | Constructor

See Also

SasTask Class
SasTask Members
SAS.Tasks.Toolkit Namespace


SasTask Constructor

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask Constructor
SasTask Class See Also

Constructor

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SasTask()

See Also

SasTask Class
SasTask Overload
SAS.Tasks.Toolkit Namespace


SasTask Constructor (IContainer)

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask Constructor (IContainer)
SasTask Class See Also

Constructor

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    container As IContainer _
)
C#
public SasTask(
    IContainer container
)

Parameters

container
Type: System.ComponentModel..::.IContainer

See Also

SasTask Class
SasTask Overload
SAS.Tasks.Toolkit Namespace


SasTask Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask Methods
SasTask Class See Also

The SasTask type exposes the following members.

Methods

Name | Description
Activate |
ActiveDataChanged |
ActiveStateChanged |
Close |
Connect |
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateTaskTemplate |
Disconnect |
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GenerateOutputData |
GenerateOutputDataNames |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetSasCode | Virtual method that is called when the application retrieves the SasCode property.
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlState | Overloaded.
Initialize |
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InputDataChanged |
Languages |
MemberwiseClone | Overloaded.
OnCreateNewOutputDataNames |
OpenTaskTemplate |
OutputDataInfo | This method is deprecated. Override OutputDataDescriptorList instead to build up a list of the output data items that you expect to create or modify as part of this task.
RestoreStateFromXml | Overloaded.
Show | Overloaded.
ShowDialog |
SubmitComplete | This method is called by the application when a submitted job is complete. Do not call this method directly from within your task.
SubmitSASProgram | Submit a SAS program to the assigned server. This method returns immediately after submitting the program. Subscribe to the SubmitSASProgramComplete event to receive notification when the job is complete.
SubmitSASProgramAndWait | Submit a SAS program to the assigned server and waits until processing is complete before returning. Subscribe to the SubmitSASProgramComplete event to receive notification of the job completion, success, and log.
Terminate |
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


Activate Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.Activate Method
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub Activate
C#
public void Activate()

Implements

ISASTask2..::.Activate()()()

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


ActiveDataChanged Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.ActiveDataChanged Method
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub ActiveDataChanged
C#
public virtual void ActiveDataChanged()

Implements

ISASTaskDataSink..::.ActiveDataChanged()()()

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


ActiveStateChanged Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.ActiveStateChanged Method
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub ActiveStateChanged
C#
public void ActiveStateChanged()

Implements

ISASTask2..::.ActiveStateChanged()()()

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


Close Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.Close Method
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub Close
C#
public void Close()

Implements

ISASTask2..::.Close()()()

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


Connect Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.Connect Method
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Connect ( _
    consumer As ISASTaskConsumer _
) As Boolean
C#
public virtual bool Connect(
    ISASTaskConsumer consumer
)

Parameters

consumer
Type: SAS.Shared.AddIns..::.ISASTaskConsumer

Return Value

Implements

ISASTaskAddIn..::.Connect(ISASTaskConsumer)

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


CreateTaskTemplate Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.CreateTaskTemplate Method
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub CreateTaskTemplate ( _
    Name As String, _
    Desc As String, _
    Category As String, _
    ViewType As String _
)
C#
public void CreateTaskTemplate(
    string Name,
    string Desc,
    string Category,
    string ViewType
)

Parameters

Name
Type: System..::.String
Desc
Type: System..::.String
Category
Type: System..::.String
ViewType
Type: System..::.String

Implements

ISASTaskTemplate..::.CreateTaskTemplate(String, String, String, String)

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


Disconnect Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.Disconnect Method
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Disconnect
C#
public virtual void Disconnect()

Implements

ISASTaskAddIn..::.Disconnect()()()

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


Dispose Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.Dispose Method
SasTask Class See Also

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Component..::.Dispose(Boolean).)

See Also

SasTask Class
SasTask Members
SAS.Tasks.Toolkit Namespace


Dispose Method (Boolean)

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.Dispose Method (Boolean)
SasTask Class See Also

Clean up any resources being used.

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

SasTask Class
Dispose Overload
SAS.Tasks.Toolkit Namespace


GenerateOutputData Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.GenerateOutputData Method
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GenerateOutputData As Boolean
C#
public virtual bool GenerateOutputData()

Return Value

Implements

ISASTaskDataSink..::.GenerateOutputData()()()

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


GenerateOutputDataNames Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.GenerateOutputDataNames Method
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub GenerateOutputDataNames ( _
    Index As Integer() _
)
C#
public void GenerateOutputDataNames(
    int[] Index
)

Parameters

Index
Type: array< System..::.Int32 >[]()[]

Implements

ISASTaskDataSink..::.GenerateOutputDataNames(array<Int32>[]()[])

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


GetSasCode Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.GetSasCode Method
SasTask Class See Also

Virtual method that is called when the application retrieves the SasCode property.

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetSasCode As String
C#
public virtual string GetSasCode()

Return Value

a string with the SAS program to run.

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


GetXmlState Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.GetXmlState Method
SasTask Class See Also

Overload List

Name | Description
GetXmlState()()() | Get the current state of this task in XML format.
GetXmlState(Boolean) | Get the current state of this task in XML format. If the task yields different XML when creating a template, the boolean flag indicates whether to do that. For example, some tasks might not save data-specific information with a templated version.

See Also

SasTask Class
SasTask Members
SAS.Tasks.Toolkit Namespace


GetXmlState Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.GetXmlState Method
SasTask Class See Also

Get the current state of this task in XML format.

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetXmlState As String
C#
public virtual string GetXmlState()

Return Value

a string with the XML

See Also

SasTask Class
GetXmlState Overload
SAS.Tasks.Toolkit Namespace


GetXmlState Method (Boolean)

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.GetXmlState Method (Boolean)
SasTask Class See Also

Get the current state of this task in XML format. If the task yields different XML when creating a template, the boolean flag indicates whether to do that. For example, some tasks might not save data-specific information with a templated version.

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetXmlState ( _
    forTemplate As Boolean _
) As String
C#
public virtual string GetXmlState(
    bool forTemplate
)

Parameters

forTemplate
Type: System..::.Boolean
whether this is for a task template

Return Value

a string with the XML

See Also

SasTask Class
GetXmlState Overload
SAS.Tasks.Toolkit Namespace


Initialize Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.Initialize Method
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Initialize As Boolean
C#
public virtual bool Initialize()

Implements

ISASTask..::.Initialize()()()

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


InputDataChanged Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.InputDataChanged Method
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub InputDataChanged
C#
public virtual void InputDataChanged()

Implements

ISASTaskDataSink2..::.InputDataChanged()()()

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


Languages Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.Languages Method
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Function Languages ( _
    <OutAttribute> ByRef Items As String() _
) As Integer
C#
public int Languages(
    out string[] Items
)

Parameters

Items
Type: array< System..::.String >[]()[] %

Return Value

Implements

ISASTaskAddIn..::.Languages(array<String>[]()[]%)

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


MemberwiseClone Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.MemberwiseClone Method
SasTask Class See Also

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

SasTask Class
SasTask Members
SAS.Tasks.Toolkit Namespace


OnCreateNewOutputDataNames Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.OnCreateNewOutputDataNames Method
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnCreateNewOutputDataNames
C#
public virtual void OnCreateNewOutputDataNames()

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


OpenTaskTemplate Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.OpenTaskTemplate Method
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub OpenTaskTemplate ( _
    xml As String _
)
C#
public void OpenTaskTemplate(
    string xml
)

Parameters

xml
Type: System..::.String

Implements

ISASTaskTemplate..::.OpenTaskTemplate(String)

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


OutputDataInfo Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.OutputDataInfo Method
SasTask Class See Also

This method is deprecated. Override OutputDataDescriptorList instead to build up a list of the output data items that you expect to create or modify as part of this task.

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Function OutputDataInfo ( _
    Index As Integer, _
    <OutAttribute> ByRef Source As String, _
    <OutAttribute> ByRef Label As String _
) As OutputData
C#
public OutputData OutputDataInfo(
    int Index,
    out string Source,
    out string Label
)

Parameters

Index
Type: System..::.Int32
Source
Type: System..::.String %
Label
Type: System..::.String %

Implements

ISASTask..::.OutputDataInfo(Int32, String%, String%)

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


RestoreStateFromXml Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.RestoreStateFromXml Method
SasTask Class See Also

Overload List

Name | Description
RestoreStateFromXml(String) | Restore a previous state of this task with XML data.
RestoreStateFromXml(String, Boolean) | Restore a previous state of this task with XML data, optionally from a task template.

See Also

SasTask Class
SasTask Members
SAS.Tasks.Toolkit Namespace


RestoreStateFromXml Method (String)

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.RestoreStateFromXml Method (String)
SasTask Class See Also

Restore a previous state of this task with XML data.

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RestoreStateFromXml ( _
    xmlState As String _
)
C#
public virtual void RestoreStateFromXml(
    string xmlState
)

Parameters

xmlState
Type: System..::.String
a string with the XML representation of the task state

See Also

SasTask Class
RestoreStateFromXml Overload
SAS.Tasks.Toolkit Namespace


RestoreStateFromXml Method (String, Boolean)

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.RestoreStateFromXml Method (String, Boolean)
SasTask Class See Also

Restore a previous state of this task with XML data, optionally from a task template.

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RestoreStateFromXml ( _
    xmlState As String, _
    fromTemplate As Boolean _
)
C#
public virtual void RestoreStateFromXml(
    string xmlState,
    bool fromTemplate
)

Parameters

xmlState
Type: System..::.String
a string with the XML representation of the task state
fromTemplate
Type: System..::.Boolean
whether this XML state is from a saved template, which might contain different information than a completed saved task

See Also

SasTask Class
RestoreStateFromXml Overload
SAS.Tasks.Toolkit Namespace


Show Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.Show Method
SasTask Class See Also

Overload List

Name | Description
Show(IWin32Window) |
Show(IWin32Window, ViewType) |

See Also

SasTask Class
SasTask Members
SAS.Tasks.Toolkit Namespace


Show Method (IWin32Window)

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.Show Method (IWin32Window)
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Show ( _
    Owner As IWin32Window _
) As ShowResult
C#
public virtual ShowResult Show(
    IWin32Window Owner
)

Parameters

Owner
Type: System.Windows.Forms..::.IWin32Window

Implements

ISASTask..::.Show(IWin32Window)

See Also

SasTask Class
Show Overload
SAS.Tasks.Toolkit Namespace


Show Method (IWin32Window, ViewType)

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.Show Method (IWin32Window, ViewType)
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Function Show ( _
    Owner As IWin32Window, _
    PreferredView As ViewType _
) As ShowResult
C#
public ShowResult Show(
    IWin32Window Owner,
    ViewType PreferredView
)

Parameters

Owner
Type: System.Windows.Forms..::.IWin32Window
PreferredView
Type: SAS.Shared.AddIns..::.ViewType

Implements

ISASTask2..::.Show(IWin32Window, ViewType)

See Also

SasTask Class
Show Overload
SAS.Tasks.Toolkit Namespace


ShowDialog Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.ShowDialog Method
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Function ShowDialog ( _
    Owner As IWin32Window, _
    PreferredView As ViewType _
) As ShowResult
C#
public ShowResult ShowDialog(
    IWin32Window Owner,
    ViewType PreferredView
)

Parameters

Owner
Type: System.Windows.Forms..::.IWin32Window
PreferredView
Type: SAS.Shared.AddIns..::.ViewType

Implements

ISASTask2..::.ShowDialog(IWin32Window, ViewType)

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


SubmitComplete Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.SubmitComplete Method
SasTask Class See Also

This method is called by the application when a submitted job is complete. Do not call this method directly from within your task.

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub SubmitComplete ( _
    Cookie As Integer, _
    Success As Boolean, _
    Log As String _
)
C#
public void SubmitComplete(
    int Cookie,
    bool Success,
    string Log
)

Parameters

Cookie
Type: System..::.Int32
Identifier for this job.
Success
Type: System..::.Boolean
Whether the job completed without errors.
Log
Type: System..::.String
The SAS log for the job.

Implements

ISASTaskSubmitSink..::.SubmitComplete(Int32, Boolean, String)

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


SubmitSASProgram Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.SubmitSASProgram Method
SasTask Class See Also

Submit a SAS program to the assigned server. This method returns immediately after submitting the program. Subscribe to the SubmitSASProgramComplete event to receive notification when the job is complete.

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Function SubmitSASProgram ( _
    program As String _
) As Integer
C#
public int SubmitSASProgram(
    string program
)

Parameters

program
Type: System..::.String
The SAS program to run.

Return Value

An integer that identifies the submitted job (a cookie).

Remarks

The SubmitSASProgramComplete event might be raised on a different thread than the one that called this method. If you need to perform some work on the UI thread (for example, to update a control or form) when the event is raised, be sure to call BeginInvoke to marshal the call back to the UI thread.

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


SubmitSASProgramAndWait Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.SubmitSASProgramAndWait Method
SasTask Class See Also

Submit a SAS program to the assigned server and waits until processing is complete before returning. Subscribe to the SubmitSASProgramComplete event to receive notification of the job completion, success, and log.

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub SubmitSASProgramAndWait ( _
    program As String _
)
C#
public void SubmitSASProgramAndWait(
    string program
)

Parameters

program
Type: System..::.String
The SAS program to run.

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


Terminate Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.Terminate Method
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Terminate
C#
public virtual void Terminate()

Implements

ISASTask..::.Terminate()()()

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


SasTask Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask Properties
SasTask Class See Also

The SasTask type exposes the following members.

Properties

Name | Description
AddInDescription |
AddInName |
AllowModifyCustomCode | For tasks that support adding custom code, this property indicates whether an administrator decided to limit this function.
AllowModifyOutputData | For tasks that support specifying output data, this property indicates whether an administrator decided to limit this function. The limitation should be interpreted as "do not allow the end user to change the output data location."
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Clsid | Unique GUID-formatted identifier for this task. The value is set by using the [ClassId] attribute. See ClassIdAttribute.
Consumer |
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FriendlyName |
GeneratesListOutput |
GeneratesReportOutput | Does this task generate ODS or report output?
GeneratesSasCode |
IconAssembly |
IconName |
Label |
Language |
MajorVersion |
MinorVersion |
Modal |
NumericColsRequired |
NumericColumnsRequired | How many numberic columns (if any) are expected in the input data in order for this task to be useful.
OutputDataCount |
OutputDataDescriptorList |
ParameterNames |
ProcsUsed |
ProductsOptional |
ProductsRequired |
ReadOnlyMode | This property indicates whether an administrator has restricted the end user from modifying the contents of the project. In this case, the task should disable the OK or Finish button, and prevent the end user from making committing changes to the task options.
RequiresData |
RunLog |
SasCode |
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StandardCategory | Indicates whether this is a SAS task supplied with a SAS product. If false, then the application will not add the task to the Add-Ins menu automatically. Most custom tasks should not override this property, otherwise the task might not appear in the application menus.
SupportsTemplates | Whether this task supports task templates, allowing the end user to save a version of this task with the current settings for later use.
TaskCategory |
TaskDescription |
TaskName |
TaskType |
Validation |
Visible |
VisibleInManager |
WhatIsDescription |
XmlResult |
XmlState |

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


AddInDescription Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.AddInDescription Property
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AddInDescription As String
C#
public string AddInDescription { get; }

Implements

ISASTaskAddIn..::.AddInDescription

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


AddInName Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.AddInName Property
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AddInName As String
C#
public string AddInName { get; }

Implements

ISASTaskAddIn..::.AddInName

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


AllowModifyCustomCode Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.AllowModifyCustomCode Property
SasTask Class See Also

For tasks that support adding custom code, this property indicates whether an administrator decided to limit this function.

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property AllowModifyCustomCode As Boolean
C#
public bool AllowModifyCustomCode { get; set; }

Implements

ISupportRoleBased..::.AllowModifyCustomCode

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


AllowModifyOutputData Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.AllowModifyOutputData Property
SasTask Class See Also

For tasks that support specifying output data, this property indicates whether an administrator decided to limit this function. The limitation should be interpreted as "do not allow the end user to change the output data location."

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property AllowModifyOutputData As Boolean
C#
public bool AllowModifyOutputData { get; set; }

Implements

ISupportRoleBased..::.AllowModifyOutputData

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


Clsid Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.Clsid Property
SasTask Class See Also

Unique GUID-formatted identifier for this task. The value is set by using the [ClassId] attribute. See ClassIdAttribute.

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Clsid As String
C#
public string Clsid { get; }

Implements

ISASTaskDescription..::.Clsid

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


Consumer Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.Consumer Property
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property Consumer As ISASTaskConsumer3
C#
public ISASTaskConsumer3 Consumer { get; set; }

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


FriendlyName Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.FriendlyName Property
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FriendlyName As String
C#
public string FriendlyName { get; }

Implements

ISASTaskDescription..::.FriendlyName

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


GeneratesListOutput Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.GeneratesListOutput Property
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property GeneratesListOutput As Boolean
C#
public bool GeneratesListOutput { get; }

Implements

ISASTaskDescription..::.GeneratesListOutput

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


GeneratesReportOutput Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.GeneratesReportOutput Property
SasTask Class See Also

Does this task generate ODS or report output?

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property GeneratesReportOutput As Boolean
C#
public bool GeneratesReportOutput { get; set; }

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


GeneratesSasCode Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.GeneratesSasCode Property
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property GeneratesSasCode As Boolean
C#
public bool GeneratesSasCode { get; set; }

Implements

ISASTaskDescription..::.GeneratesSasCode

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


IconAssembly Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.IconAssembly Property
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IconAssembly As String
C#
public string IconAssembly { get; }

Implements

ISASTaskDescription..::.IconAssembly

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


IconName Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.IconName Property
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IconName As String
C#
public string IconName { get; }

Implements

ISASTaskDescription..::.IconName

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


Label Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.Label Property
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Label As String
C#
public virtual string Label { get; set; }

Implements

ISASTask..::.Label

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


Language Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.Language Property
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property Language As String
C#
public string Language { set; }

Implements

ISASTaskAddIn..::.Language

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


MajorVersion Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.MajorVersion Property
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MajorVersion As Integer
C#
public int MajorVersion { get; }

Implements

ISASTaskDescription..::.MajorVersion

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


MinorVersion Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.MinorVersion Property
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MinorVersion As Integer
C#
public int MinorVersion { get; }

Implements

ISASTaskDescription..::.MinorVersion

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


Modal Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.Modal Property
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Modal As Boolean
C#
public bool Modal { get; }

Implements

ISASTask2..::.Modal

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


NumericColsRequired Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.NumericColsRequired Property
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NumericColsRequired As Integer
C#
public int NumericColsRequired { get; }

Implements

ISASTaskDescription..::.NumericColsRequired

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


NumericColumnsRequired Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.NumericColumnsRequired Property
SasTask Class See Also

How many numberic columns (if any) are expected in the input data in order for this task to be useful.

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property NumericColumnsRequired As Integer
C#
public int NumericColumnsRequired { get; set; }

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


OutputDataCount Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.OutputDataCount Property
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property OutputDataCount As Integer
C#
public virtual int OutputDataCount { get; }

Implements

ISASTask..::.OutputDataCount

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


OutputDataDescriptorList Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.OutputDataDescriptorList Property
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property OutputDataDescriptorList As List(Of ISASTaskDataDescriptor)
C#
public virtual List<ISASTaskDataDescriptor> OutputDataDescriptorList { get; }

Implements

ISASTask3..::.OutputDataDescriptorList

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


ParameterNames Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.ParameterNames Property
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ParameterNames As String()
C#
public string[] ParameterNames { get; }

Implements

ISASTask2..::.ParameterNames

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


ProcsUsed Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.ProcsUsed Property
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property ProcsUsed As String
C#
public string ProcsUsed { get; set; }

Implements

ISASTaskDescription..::.ProcsUsed

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


ProductsOptional Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.ProductsOptional Property
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property ProductsOptional As String
C#
public string ProductsOptional { get; set; }

Implements

ISASTaskDescription..::.ProductsOptional

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


ProductsRequired Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.ProductsRequired Property
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property ProductsRequired As String
C#
public string ProductsRequired { get; set; }

Implements

ISASTaskDescription..::.ProductsRequired

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


ReadOnlyMode Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.ReadOnlyMode Property
SasTask Class See Also

This property indicates whether an administrator has restricted the end user from modifying the contents of the project. In this case, the task should disable the OK or Finish button, and prevent the end user from making committing changes to the task options.

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property ReadOnlyMode As Boolean
C#
public bool ReadOnlyMode { get; set; }

Implements

ISupportRoleBased..::.ReadOnlyMode

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


RequiresData Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.RequiresData Property
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property RequiresData As Boolean
C#
public bool RequiresData { get; set; }

Implements

ISASTaskDescription..::.RequiresData

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


RunLog Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.RunLog Property
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RunLog As String
C#
public string RunLog { get; }

Implements

ISASTask..::.RunLog

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


SasCode Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.SasCode Property
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SasCode As String
C#
public string SasCode { get; }

Implements

ISASTask..::.SasCode

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


StandardCategory Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.StandardCategory Property
SasTask Class See Also

Indicates whether this is a SAS task supplied with a SAS product. If false, then the application will not add the task to the Add-Ins menu automatically. Most custom tasks should not override this property, otherwise the task might not appear in the application menus.

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StandardCategory As Boolean
C#
public virtual bool StandardCategory { get; }

Implements

ISASTaskDescription..::.StandardCategory

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


SupportsTemplates Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.SupportsTemplates Property
SasTask Class See Also

Whether this task supports task templates, allowing the end user to save a version of this task with the current settings for later use.

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property SupportsTemplates As Boolean
C#
public virtual bool SupportsTemplates { get; set; }

Implements

ISASTaskTemplate..::.SupportsTemplates

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


TaskCategory Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.TaskCategory Property
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property TaskCategory As String
C#
public string TaskCategory { get; set; }

Implements

ISASTaskDescription..::.TaskCategory

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


TaskDescription Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.TaskDescription Property
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property TaskDescription As String
C#
public string TaskDescription { get; set; }

Implements

ISASTaskDescription..::.TaskDescription

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


TaskName Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.TaskName Property
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property TaskName As String
C#
public string TaskName { get; set; }

Implements

ISASTaskDescription..::.TaskName

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


TaskType Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.TaskType Property
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TaskType As ShowType
C#
public ShowType TaskType { get; }

Implements

ISASTaskDescription..::.TaskType

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


Validation Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.Validation Property
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property Validation As String
C#
public string Validation { get; set; }

Implements

ISASTaskDescription..::.Validation

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


Visible Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.Visible Property
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Visible As Boolean
C#
public bool Visible { get; }

Implements

ISASTask2..::.Visible

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


VisibleInManager Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.VisibleInManager Property
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property VisibleInManager As Boolean
C#
public bool VisibleInManager { get; }

Implements

ISASTaskAddIn..::.VisibleInManager

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


WhatIsDescription Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.WhatIsDescription Property
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property WhatIsDescription As String
C#
public string WhatIsDescription { get; }

Implements

ISASTaskDescription..::.WhatIsDescription

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


XmlResult Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.XmlResult Property
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property XmlResult As String
C#
public string XmlResult { get; }

Implements

ISASTask2..::.XmlResult

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


XmlState Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.XmlState Property
SasTask Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property XmlState As String
C#
public string XmlState { get; set; }

Implements

ISASTask..::.XmlState

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


SasTask Events

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask Events
SasTask Class See Also

The SasTask type exposes the following members.

Events

Name | Description
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
SubmitSASProgramComplete | Event that is raised when a SAS program submitted using SubmitSASProgram(String) is complete.

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


SubmitSASProgramComplete Event

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasTask..::.SubmitSASProgramComplete Event
SasTask Class See Also

Event that is raised when a SAS program submitted using SubmitSASProgram(String) is complete.

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Event SubmitSASProgramComplete As SubmitCompleteHandler
C#
public event SubmitCompleteHandler SubmitSASProgramComplete

See Also

SasTask Class
SAS.Tasks.Toolkit Namespace


SubmitCompleteEventArgs Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SubmitCompleteEventArgs Class
Members See Also

Class that carries the event details when a submitted SAS job is completed.

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Class SubmitCompleteEventArgs _
    Inherits EventArgs
C#
public class SubmitCompleteEventArgs : EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
SAS.Tasks.Toolkit..::.SubmitCompleteEventArgs

See Also

SubmitCompleteEventArgs Members
SAS.Tasks.Toolkit Namespace


SubmitCompleteEventArgs Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SubmitCompleteEventArgs Members
SubmitCompleteEventArgs Class Constructors Methods Properties See Also

The SubmitCompleteEventArgs type exposes the following members.

Constructors

Name | Description
SubmitCompleteEventArgs | Constructor

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cookie | Identifier for the job.
Log | The SAS log from the job.
Success | Whether the job completed without errors.

See Also

SubmitCompleteEventArgs Class
SAS.Tasks.Toolkit Namespace


SubmitCompleteEventArgs Constructor

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SubmitCompleteEventArgs Constructor
SubmitCompleteEventArgs Class See Also

Constructor

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    cookie As Integer, _
    success As Boolean, _
    log As String _
)
C#
public SubmitCompleteEventArgs(
    int cookie,
    bool success,
    string log
)

Parameters

cookie
Type: System..::.Int32
Identifier for the job
success
Type: System..::.Boolean
Whether the job completed without errors
log
Type: System..::.String
The SAS log from the job.

See Also

SubmitCompleteEventArgs Class
SAS.Tasks.Toolkit Namespace


SubmitCompleteEventArgs Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SubmitCompleteEventArgs Methods
SubmitCompleteEventArgs Class See Also

The SubmitCompleteEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubmitCompleteEventArgs Class
SAS.Tasks.Toolkit Namespace


SubmitCompleteEventArgs Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SubmitCompleteEventArgs Properties
SubmitCompleteEventArgs Class See Also

The SubmitCompleteEventArgs type exposes the following members.

Properties

Name | Description
Cookie | Identifier for the job.
Log | The SAS log from the job.
Success | Whether the job completed without errors.

See Also

SubmitCompleteEventArgs Class
SAS.Tasks.Toolkit Namespace


Cookie Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SubmitCompleteEventArgs..::.Cookie Property
SubmitCompleteEventArgs Class See Also

Identifier for the job.

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Cookie As Integer
C#
public int Cookie { get; }

See Also

SubmitCompleteEventArgs Class
SAS.Tasks.Toolkit Namespace


Log Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SubmitCompleteEventArgs..::.Log Property
SubmitCompleteEventArgs Class See Also

The SAS log from the job.

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Log As String
C#
public string Log { get; }

See Also

SubmitCompleteEventArgs Class
SAS.Tasks.Toolkit Namespace


Success Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SubmitCompleteEventArgs..::.Success Property
SubmitCompleteEventArgs Class See Also

Whether the job completed without errors.

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Success As Boolean
C#
public bool Success { get; }

See Also

SubmitCompleteEventArgs Class
SAS.Tasks.Toolkit Namespace


SubmitCompleteHandler Delegate

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SubmitCompleteHandler Delegate
See Also

Delegate for event handler when a submitted SAS job is completed.

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub SubmitCompleteHandler ( _
    sender As Object, _
    args As SubmitCompleteEventArgs _
)
C#
public delegate void SubmitCompleteHandler(
    Object sender,
    SubmitCompleteEventArgs args
)

Parameters

sender
Type: System..::.Object
The SAS task that submitted the job
args
Type: SAS.Tasks.Toolkit..::.SubmitCompleteEventArgs
Event details including whether the job succeeeded and the SAS log.

See Also

SAS.Tasks.Toolkit Namespace


VersionAttribute Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
VersionAttribute Class
Members See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Class)> _
Public NotInheritable Class VersionAttribute _
    Inherits Attribute
C#
[AttributeUsageAttribute(AttributeTargets.Class)]
public sealed class VersionAttribute : Attribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
SAS.Tasks.Toolkit..::.VersionAttribute

See Also

VersionAttribute Members
SAS.Tasks.Toolkit Namespace


VersionAttribute Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
VersionAttribute Members
VersionAttribute Class Constructors Methods Properties Explicit Interface Implementations See Also

The VersionAttribute type exposes the following members.

Constructors

Name | Description
VersionAttribute |

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Version |

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

VersionAttribute Class
SAS.Tasks.Toolkit Namespace


VersionAttribute Constructor

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
VersionAttribute Constructor
VersionAttribute Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    version As Double _
)
C#
public VersionAttribute(
    double version
)

Parameters

version
Type: System..::.Double

See Also

VersionAttribute Class
SAS.Tasks.Toolkit Namespace


VersionAttribute Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
VersionAttribute Methods
VersionAttribute Class See Also

The VersionAttribute type exposes the following members.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

VersionAttribute Class
SAS.Tasks.Toolkit Namespace


VersionAttribute Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
VersionAttribute Properties
VersionAttribute Class See Also

The VersionAttribute type exposes the following members.

Properties

Name | Description
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Version |

See Also

VersionAttribute Class
SAS.Tasks.Toolkit Namespace


Version Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
VersionAttribute..::.Version Property
VersionAttribute Class See Also

Namespace: SAS.Tasks.Toolkit
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Version As Double
C#
public double Version { get; }

See Also

VersionAttribute Class
SAS.Tasks.Toolkit Namespace


SAS.Tasks.Toolkit.Controls Namespace

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SAS.Tasks.Toolkit.Controls Namespace

Classes

Class | Description
BaseSelectedDataControl | Base class for the data selection controls. Do not create an instance of BaseSelectedDataControl; instead, use WizardSelectedDataControl or TaskSelectedDataControl.
FilterSettings | Represents the filter settings used to modify a data source. This class is used as a property in WizardSelectedDataControl.
PanelStackForm | A simple task panels container form
SASCodeViewDialog | A dialog that can show the contents of a SAS program, color coded.
SASCodeViewDialog..::.CodeChangedEventArgs | Special EventArgs class to deal with the code-changed event.
SASLogViewDialog | A modal dialog that can show the contents of a SAS log, color coded.
SasServerDropListCtl | A Windows combobox (dropdown list style) that displays the available SAS workspace servers for the current environment.
SASTextEditorCtl | A text editor/viewer control that supports syntax coloring for SAS logs and SAS programs.
SelectServerDataCtl | A control to select a collection of data from a SAS server to use as input to a task.
ServerFoldersDialog | A dialog to allow the selection of a folder from the file system of a SAS server.
TaskForm | A base class for task dialogs/forms.
TaskPropertiesPanelControl | A panel to show/control the current properties of the task. The properties include information about the environment in which this task is run, including ODS styles, run time, last modified, etc.
TaskSelectedDataControl | Displays current selected data and filter for the task, and allows the user to change these with an Edit button. This control is meant for use on tasks with a dialog or panel form factor.
WizardForm | A simple wizard container form.
WizardSelectedDataControl | Displays current selected data and filter for the task, and allows the user to change these with an Edit button. This control is meant for use on tasks with a wizard form factor.

Delegates

Delegate | Description
BaseSelectedDataControl..::.EnterControlEventHandler | This delegate is not supported for outside consumers.
BaseSelectedDataControl..::.KeyUpControlEventHandler | This delegate is not supported for outside consumers.
BaseSelectedDataControl..::.LeaveControlEventHandler | This delegate is not supported for outside consumers.
BaseSelectedDataControl..::.MouseEnteredControlEventHandler | This delegate is not supported for outside consumers.
BaseSelectedDataControl..::.MouseLeftControlEventHandler | This delegate is not supported for outside consumers.
SASCodeViewDialog..::.CodeChangedEventHandler | Delegate for the Code-changed event

Enumerations

Enumeration | Description
SASTextEditorCtl..::.eContentType | Enumeration of the content types that this control supports: programs and logs.


BaseSelectedDataControl Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl Class
Members See Also

Base class for the data selection controls. Do not create an instance of BaseSelectedDataControl; instead, use WizardSelectedDataControl or TaskSelectedDataControl.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Class BaseSelectedDataControl _
    Inherits UserControl
C#
public class BaseSelectedDataControl : UserControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
SAS.Tasks.Toolkit.Controls..::.BaseSelectedDataControl
SAS.Tasks.Toolkit.Controls..::.TaskSelectedDataControl
SAS.Tasks.Toolkit.Controls..::.WizardSelectedDataControl

See Also

BaseSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


BaseSelectedDataControl Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl Members
BaseSelectedDataControl Class Constructors Methods Properties Events Explicit Interface Implementations See Also

The BaseSelectedDataControl type exposes the following members.

Constructors

Name | Description
BaseSelectedDataControl |

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FireEnterControl |
FireKeyUpControl |
FireLeaveControl |
FireMouseEnteredControl | This event is not supported for outside consumers.
FireMouseLeftControl |
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
HideEditButtonPropChanged | Handle this in a derived class by updating the label that shows the current filter.
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
ShowDataSelection | Shows the data and filter selection dialog.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDataLabels | Handle this in a derived class by updating the data label with the current data settings.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateFilterLabel | Handle this in a derived class by updating the label that shows the current filter.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowEditing | Indicates whether or not the Edit button should be shown.
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Consumer | The ISASTaskConsumer3 interface from the main application.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FilterSettings | Represents the current filter settings.
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HideEditButton | Hides Edit Button if user doesn't want edit button and filter to show.
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
TaskData | The ISASTaskData2 interface for the input data.
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseLabelsForVarNames | Indicates whether column names or labels should be shown in the query builder
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
DataSelectionChanged | Raised when the data selection or filter changes. Handle this event when you want your task to be able to react when the data source or filter definition is changed by the end user.
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
EnterControl | This event is not supported for outside consumers.
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
KeyUpControl | This event is not supported for outside consumers.
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LeaveControl | This event is not supported for outside consumers.
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseEnteredControl | This event is not supported for outside consumers.
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseLeftControl | This event is not supported for outside consumers.
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

BaseSelectedDataControl Class
SAS.Tasks.Toolkit.Controls Namespace


BaseSelectedDataControl Constructor

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl Constructor
BaseSelectedDataControl Class See Also

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BaseSelectedDataControl()

See Also

BaseSelectedDataControl Class
SAS.Tasks.Toolkit.Controls Namespace


BaseSelectedDataControl Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl Methods
BaseSelectedDataControl Class See Also

The BaseSelectedDataControl type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FireEnterControl |
FireKeyUpControl |
FireLeaveControl |
FireMouseEnteredControl | This event is not supported for outside consumers.
FireMouseLeftControl |
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
HideEditButtonPropChanged | Handle this in a derived class by updating the label that shows the current filter.
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
ShowDataSelection | Shows the data and filter selection dialog.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDataLabels | Handle this in a derived class by updating the data label with the current data settings.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateFilterLabel | Handle this in a derived class by updating the label that shows the current filter.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

BaseSelectedDataControl Class
SAS.Tasks.Toolkit.Controls Namespace


AccessibilityNotifyClients Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl..::.AccessibilityNotifyClients Method
BaseSelectedDataControl Class See Also

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

BaseSelectedDataControl Class
BaseSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


BeginInvoke Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl..::.BeginInvoke Method
BaseSelectedDataControl Class See Also

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

BaseSelectedDataControl Class
BaseSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


Dispose Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl..::.Dispose Method
BaseSelectedDataControl Class See Also

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | (Inherited from ContainerControl.)

See Also

BaseSelectedDataControl Class
BaseSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


FireEnterControl Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl..::.FireEnterControl Method
BaseSelectedDataControl Class See Also

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Protected Sub FireEnterControl
C#
protected void FireEnterControl()

See Also

BaseSelectedDataControl Class
SAS.Tasks.Toolkit.Controls Namespace


FireKeyUpControl Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl..::.FireKeyUpControl Method
BaseSelectedDataControl Class See Also

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Protected Sub FireKeyUpControl ( _
    e As KeyEventArgs _
)
C#
protected void FireKeyUpControl(
    KeyEventArgs e
)

Parameters

e
Type: System.Windows.Forms..::.KeyEventArgs

See Also

BaseSelectedDataControl Class
SAS.Tasks.Toolkit.Controls Namespace


FireLeaveControl Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl..::.FireLeaveControl Method
BaseSelectedDataControl Class See Also

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Protected Sub FireLeaveControl
C#
protected void FireLeaveControl()

See Also

BaseSelectedDataControl Class
SAS.Tasks.Toolkit.Controls Namespace


FireMouseEnteredControl Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl..::.FireMouseEnteredControl Method
BaseSelectedDataControl Class See Also

This event is not supported for outside consumers.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Protected Sub FireMouseEnteredControl
C#
protected void FireMouseEnteredControl()

See Also

BaseSelectedDataControl Class
SAS.Tasks.Toolkit.Controls Namespace


FireMouseLeftControl Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl..::.FireMouseLeftControl Method
BaseSelectedDataControl Class See Also

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Protected Sub FireMouseLeftControl
C#
protected void FireMouseLeftControl()

See Also

BaseSelectedDataControl Class
SAS.Tasks.Toolkit.Controls Namespace


GetChildAtPoint Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl..::.GetChildAtPoint Method
BaseSelectedDataControl Class See Also

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

BaseSelectedDataControl Class
BaseSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


HideEditButtonPropChanged Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl..::.HideEditButtonPropChanged Method
BaseSelectedDataControl Class See Also

Handle this in a derived class by updating the label that shows the current filter.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub HideEditButtonPropChanged
C#
protected virtual void HideEditButtonPropChanged()

See Also

BaseSelectedDataControl Class
SAS.Tasks.Toolkit.Controls Namespace


Invalidate Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl..::.Invalidate Method
BaseSelectedDataControl Class See Also

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

BaseSelectedDataControl Class
BaseSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


Invoke Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl..::.Invoke Method
BaseSelectedDataControl Class See Also

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

BaseSelectedDataControl Class
BaseSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


MemberwiseClone Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl..::.MemberwiseClone Method
BaseSelectedDataControl Class See Also

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

BaseSelectedDataControl Class
BaseSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


PerformLayout Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl..::.PerformLayout Method
BaseSelectedDataControl Class See Also

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

BaseSelectedDataControl Class
BaseSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


ResumeLayout Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl..::.ResumeLayout Method
BaseSelectedDataControl Class See Also

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

BaseSelectedDataControl Class
BaseSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


RtlTranslateAlignment Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl..::.RtlTranslateAlignment Method
BaseSelectedDataControl Class See Also

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

BaseSelectedDataControl Class
BaseSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


Scale Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl..::.Scale Method
BaseSelectedDataControl Class See Also

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

BaseSelectedDataControl Class
BaseSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


Select Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl..::.Select Method
BaseSelectedDataControl Class See Also

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

BaseSelectedDataControl Class
BaseSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


SetBounds Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl..::.SetBounds Method
BaseSelectedDataControl Class See Also

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

BaseSelectedDataControl Class
BaseSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


ShowDataSelection Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl..::.ShowDataSelection Method
BaseSelectedDataControl Class See Also

Shows the data and filter selection dialog.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Protected Function ShowDataSelection As DialogResult
C#
protected DialogResult ShowDataSelection()

See Also

BaseSelectedDataControl Class
SAS.Tasks.Toolkit.Controls Namespace


UpdateBounds Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl..::.UpdateBounds Method
BaseSelectedDataControl Class See Also

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

BaseSelectedDataControl Class
BaseSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


UpdateDataLabels Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl..::.UpdateDataLabels Method
BaseSelectedDataControl Class See Also

Handle this in a derived class by updating the data label with the current data settings.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub UpdateDataLabels
C#
protected virtual void UpdateDataLabels()

See Also

BaseSelectedDataControl Class
SAS.Tasks.Toolkit.Controls Namespace


UpdateFilterLabel Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl..::.UpdateFilterLabel Method
BaseSelectedDataControl Class See Also

Handle this in a derived class by updating the label that shows the current filter.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub UpdateFilterLabel
C#
protected virtual void UpdateFilterLabel()

See Also

BaseSelectedDataControl Class
SAS.Tasks.Toolkit.Controls Namespace


Validate Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl..::.Validate Method
BaseSelectedDataControl Class See Also

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

BaseSelectedDataControl Class
BaseSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


ValidateChildren Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl..::.ValidateChildren Method
BaseSelectedDataControl Class See Also

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

BaseSelectedDataControl Class
BaseSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


BaseSelectedDataControl Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl Properties
BaseSelectedDataControl Class See Also

The BaseSelectedDataControl type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowEditing | Indicates whether or not the Edit button should be shown.
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Consumer | The ISASTaskConsumer3 interface from the main application.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FilterSettings | Represents the current filter settings.
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HideEditButton | Hides Edit Button if user doesn't want edit button and filter to show.
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
TaskData | The ISASTaskData2 interface for the input data.
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseLabelsForVarNames | Indicates whether column names or labels should be shown in the query builder
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

BaseSelectedDataControl Class
SAS.Tasks.Toolkit.Controls Namespace


AllowEditing Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl..::.AllowEditing Property
BaseSelectedDataControl Class See Also

Indicates whether or not the Edit button should be shown.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property AllowEditing As Boolean
C#
protected bool AllowEditing { get; }

See Also

BaseSelectedDataControl Class
SAS.Tasks.Toolkit.Controls Namespace


Consumer Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl..::.Consumer Property
BaseSelectedDataControl Class See Also

The ISASTaskConsumer3 interface from the main application.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property Consumer As ISASTaskConsumer3
C#
public ISASTaskConsumer3 Consumer { get; set; }

See Also

BaseSelectedDataControl Class
SAS.Tasks.Toolkit.Controls Namespace


FilterSettings Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl..::.FilterSettings Property
BaseSelectedDataControl Class See Also

Represents the current filter settings.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property FilterSettings As FilterSettings
C#
public FilterSettings FilterSettings { get; set; }

See Also

BaseSelectedDataControl Class
SAS.Tasks.Toolkit.Controls Namespace


HideEditButton Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl..::.HideEditButton Property
BaseSelectedDataControl Class See Also

Hides Edit Button if user doesn't want edit button and filter to show.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property HideEditButton As Boolean
C#
public bool HideEditButton { get; set; }

See Also

BaseSelectedDataControl Class
SAS.Tasks.Toolkit.Controls Namespace


TaskData Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl..::.TaskData Property
BaseSelectedDataControl Class See Also

The ISASTaskData2 interface for the input data.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property TaskData As ISASTaskData2
C#
public ISASTaskData2 TaskData { get; set; }

See Also

BaseSelectedDataControl Class
SAS.Tasks.Toolkit.Controls Namespace


UseLabelsForVarNames Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl..::.UseLabelsForVarNames Property
BaseSelectedDataControl Class See Also

Indicates whether column names or labels should be shown in the query builder

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property UseLabelsForVarNames As Boolean
C#
public bool UseLabelsForVarNames { get; set; }

See Also

BaseSelectedDataControl Class
SAS.Tasks.Toolkit.Controls Namespace


BaseSelectedDataControl Events

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl Events
BaseSelectedDataControl Class See Also

The BaseSelectedDataControl type exposes the following members.

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
DataSelectionChanged | Raised when the data selection or filter changes. Handle this event when you want your task to be able to react when the data source or filter definition is changed by the end user.
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
EnterControl | This event is not supported for outside consumers.
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
KeyUpControl | This event is not supported for outside consumers.
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LeaveControl | This event is not supported for outside consumers.
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseEnteredControl | This event is not supported for outside consumers.
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseLeftControl | This event is not supported for outside consumers.
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

BaseSelectedDataControl Class
SAS.Tasks.Toolkit.Controls Namespace


DataSelectionChanged Event

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl..::.DataSelectionChanged Event
BaseSelectedDataControl Class See Also

Raised when the data selection or filter changes. Handle this event when you want your task to be able to react when the data source or filter definition is changed by the end user.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Event DataSelectionChanged As EventHandler
C#
public event EventHandler DataSelectionChanged

See Also

BaseSelectedDataControl Class
SAS.Tasks.Toolkit.Controls Namespace


EnterControl Event

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl..::.EnterControl Event
BaseSelectedDataControl Class See Also

This event is not supported for outside consumers.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Event EnterControl As BaseSelectedDataControl..::.EnterControlEventHandler
C#
public event BaseSelectedDataControl..::.EnterControlEventHandler EnterControl

See Also

BaseSelectedDataControl Class
SAS.Tasks.Toolkit.Controls Namespace


KeyUpControl Event

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl..::.KeyUpControl Event
BaseSelectedDataControl Class See Also

This event is not supported for outside consumers.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Event KeyUpControl As BaseSelectedDataControl..::.KeyUpControlEventHandler
C#
public event BaseSelectedDataControl..::.KeyUpControlEventHandler KeyUpControl

See Also

BaseSelectedDataControl Class
SAS.Tasks.Toolkit.Controls Namespace


LeaveControl Event

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl..::.LeaveControl Event
BaseSelectedDataControl Class See Also

This event is not supported for outside consumers.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Event LeaveControl As BaseSelectedDataControl..::.LeaveControlEventHandler
C#
public event BaseSelectedDataControl..::.LeaveControlEventHandler LeaveControl

See Also

BaseSelectedDataControl Class
SAS.Tasks.Toolkit.Controls Namespace


MouseEnteredControl Event

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl..::.MouseEnteredControl Event
BaseSelectedDataControl Class See Also

This event is not supported for outside consumers.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Event MouseEnteredControl As BaseSelectedDataControl..::.MouseEnteredControlEventHandler
C#
public event BaseSelectedDataControl..::.MouseEnteredControlEventHandler MouseEnteredControl

See Also

BaseSelectedDataControl Class
SAS.Tasks.Toolkit.Controls Namespace


MouseLeftControl Event

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl..::.MouseLeftControl Event
BaseSelectedDataControl Class See Also

This event is not supported for outside consumers.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Event MouseLeftControl As BaseSelectedDataControl..::.MouseLeftControlEventHandler
C#
public event BaseSelectedDataControl..::.MouseLeftControlEventHandler MouseLeftControl

See Also

BaseSelectedDataControl Class
SAS.Tasks.Toolkit.Controls Namespace


BaseSelectedDataControl.EnterControlEventHandler Delegate

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl..::.EnterControlEventHandler Delegate
BaseSelectedDataControl Class See Also

This delegate is not supported for outside consumers.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub EnterControlEventHandler
C#
public delegate void EnterControlEventHandler()

See Also

SAS.Tasks.Toolkit.Controls Namespace


BaseSelectedDataControl.KeyUpControlEventHandler Delegate

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl..::.KeyUpControlEventHandler Delegate
BaseSelectedDataControl Class See Also

This delegate is not supported for outside consumers.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub KeyUpControlEventHandler ( _
    e As KeyEventArgs _
)
C#
public delegate void KeyUpControlEventHandler(
    KeyEventArgs e
)

Parameters

e
Type: System.Windows.Forms..::.KeyEventArgs

See Also

SAS.Tasks.Toolkit.Controls Namespace


BaseSelectedDataControl.LeaveControlEventHandler Delegate

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl..::.LeaveControlEventHandler Delegate
BaseSelectedDataControl Class See Also

This delegate is not supported for outside consumers.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub LeaveControlEventHandler
C#
public delegate void LeaveControlEventHandler()

See Also

SAS.Tasks.Toolkit.Controls Namespace


BaseSelectedDataControl.MouseEnteredControlEventHandler Delegate

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl..::.MouseEnteredControlEventHandler Delegate
BaseSelectedDataControl Class See Also

This delegate is not supported for outside consumers.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub MouseEnteredControlEventHandler
C#
public delegate void MouseEnteredControlEventHandler()

See Also

SAS.Tasks.Toolkit.Controls Namespace


BaseSelectedDataControl.MouseLeftControlEventHandler Delegate

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
BaseSelectedDataControl..::.MouseLeftControlEventHandler Delegate
BaseSelectedDataControl Class See Also

This delegate is not supported for outside consumers.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub MouseLeftControlEventHandler
C#
public delegate void MouseLeftControlEventHandler()

See Also

SAS.Tasks.Toolkit.Controls Namespace


FilterSettings Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
FilterSettings Class
Members See Also

Represents the filter settings used to modify a data source. This class is used as a property in WizardSelectedDataControl.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class FilterSettings
C#
public sealed class FilterSettings

Inheritance Hierarchy

System..::.Object
SAS.Tasks.Toolkit.Controls..::.FilterSettings

See Also

FilterSettings Members
SAS.Tasks.Toolkit.Controls Namespace


FilterSettings Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
FilterSettings Members
FilterSettings Class Constructors Methods Properties See Also

The FilterSettings type exposes the following members.

Constructors

Name | Description
FilterSettings | Overloaded.

Methods

Name | Description
Clear | Clears the current settings.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetValue | Sets a new filter
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | Create an XML representation of these settings for easy serialization. You can deserialize with the FilterSettings(string fromXml) constructor.

Properties

Name | Description
FilterValue | The filter value suitable for display and for use within SAS syntax.
FilterVariables | The list of variables referenced in the filter
FilterXml | The XML representation of the filter definition, used for storing the definition and repopulating the filter selection user interface.

See Also

FilterSettings Class
SAS.Tasks.Toolkit.Controls Namespace


FilterSettings Constructor

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
FilterSettings Constructor
FilterSettings Class See Also

Overload List

Name | Description
FilterSettings()()() | Default constructor
FilterSettings(FilterSettings) | Copy constructor
FilterSettings(String) | Constructor a FilterSettings object from a serialized XML string that was created with the ToXml() method.
FilterSettings(String, String) | Construct a FilterSettings object with a filter value and its XML representation.

See Also

FilterSettings Class
FilterSettings Members
SAS.Tasks.Toolkit.Controls Namespace


FilterSettings Constructor

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
FilterSettings Constructor
FilterSettings Class See Also

Default constructor

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FilterSettings()

See Also

FilterSettings Class
FilterSettings Overload
SAS.Tasks.Toolkit.Controls Namespace


FilterSettings Constructor (FilterSettings)

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
FilterSettings Constructor (FilterSettings)
FilterSettings Class See Also

Copy constructor

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    filterSettings As FilterSettings _
)
C#
public FilterSettings(
    FilterSettings filterSettings
)

Parameters

filterSettings
Type: SAS.Tasks.Toolkit.Controls..::.FilterSettings
instance to copy

See Also

FilterSettings Class
FilterSettings Overload
SAS.Tasks.Toolkit.Controls Namespace


FilterSettings Constructor (String)

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
FilterSettings Constructor (String)
FilterSettings Class See Also

Constructor a FilterSettings object from a serialized XML string that was created with the ToXml() method.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    fromXml As String _
)
C#
public FilterSettings(
    string fromXml
)

Parameters

fromXml
Type: System..::.String
XML string created by ToXml()

See Also

FilterSettings Class
FilterSettings Overload
SAS.Tasks.Toolkit.Controls Namespace
FilterSettings..::.ToXml()()()


FilterSettings Constructor (String, String)

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
FilterSettings Constructor (String, String)
FilterSettings Class See Also

Construct a FilterSettings object with a filter value and its XML representation.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    value As String, _
    xml As String _
)
C#
public FilterSettings(
    string value,
    string xml
)

Parameters

value
Type: System..::.String
the display/syntax-friendly filter value
xml
Type: System..::.String
the XML representation of the filter selection

See Also

FilterSettings Class
FilterSettings Overload
SAS.Tasks.Toolkit.Controls Namespace


FilterSettings Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
FilterSettings Methods
FilterSettings Class See Also

The FilterSettings type exposes the following members.

Methods

Name | Description
Clear | Clears the current settings.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetValue | Sets a new filter
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | Create an XML representation of these settings for easy serialization. You can deserialize with the FilterSettings(string fromXml) constructor.

See Also

FilterSettings Class
SAS.Tasks.Toolkit.Controls Namespace


Clear Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
FilterSettings..::.Clear Method
FilterSettings Class See Also

Clears the current settings.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub Clear
C#
public void Clear()

See Also

FilterSettings Class
SAS.Tasks.Toolkit.Controls Namespace


SetValue Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
FilterSettings..::.SetValue Method
FilterSettings Class See Also

Sets a new filter

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetValue ( _
    value As String, _
    xml As String _
)
C#
public void SetValue(
    string value,
    string xml
)

Parameters

value
Type: System..::.String
xml
Type: System..::.String

See Also

FilterSettings Class
SAS.Tasks.Toolkit.Controls Namespace


ToXml Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
FilterSettings..::.ToXml Method
FilterSettings Class See Also

Create an XML representation of these settings for easy serialization. You can deserialize with the FilterSettings(string fromXml) constructor.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Function ToXml As String
C#
public string ToXml()

Return Value

a string with the XML

See Also

FilterSettings Class
SAS.Tasks.Toolkit.Controls Namespace
SAS.Tasks.Toolkit.Controls..::.FilterSettings


FilterSettings Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
FilterSettings Properties
FilterSettings Class See Also

The FilterSettings type exposes the following members.

Properties

Name | Description
FilterValue | The filter value suitable for display and for use within SAS syntax.
FilterVariables | The list of variables referenced in the filter
FilterXml | The XML representation of the filter definition, used for storing the definition and repopulating the filter selection user interface.

See Also

FilterSettings Class
SAS.Tasks.Toolkit.Controls Namespace


FilterValue Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
FilterSettings..::.FilterValue Property
FilterSettings Class See Also

The filter value suitable for display and for use within SAS syntax.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FilterValue As String
C#
public string FilterValue { get; }

See Also

FilterSettings Class
SAS.Tasks.Toolkit.Controls Namespace


FilterVariables Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
FilterSettings..::.FilterVariables Property
FilterSettings Class See Also

The list of variables referenced in the filter

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FilterVariables As ReadOnlyCollection(Of String)
C#
public ReadOnlyCollection<string> FilterVariables { get; }

See Also

FilterSettings Class
SAS.Tasks.Toolkit.Controls Namespace


FilterXml Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
FilterSettings..::.FilterXml Property
FilterSettings Class See Also

The XML representation of the filter definition, used for storing the definition and repopulating the filter selection user interface.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FilterXml As String
C#
public string FilterXml { get; }

Remarks

The XML representation is proprietary to the application and is subject to change. For this reason, you should use this value only to save/retrieve the filter state within your task. You should not rely on the XML schema or content of this filter value string.

See Also

FilterSettings Class
SAS.Tasks.Toolkit.Controls Namespace


PanelStackForm Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
PanelStackForm Class
Members See Also

A simple task panels container form

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
<CLSCompliantAttribute(False)> _
Public Class PanelStackForm _
    Inherits SASPanelStack2
C#
[CLSCompliantAttribute(false)]
public class PanelStackForm : SASPanelStack2

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
SASPanelStack2
SAS.Tasks.Toolkit.Controls..::.PanelStackForm

See Also

PanelStackForm Members
SAS.Tasks.Toolkit.Controls Namespace


PanelStackForm Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
PanelStackForm Members
PanelStackForm Class Constructors Methods Properties Events Explicit Interface Implementations See Also

The PanelStackForm type exposes the following members.

Constructors

Name | Description
PanelStackForm |

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddControlToButtonPanel | (Inherited from SASPanelStack2.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AddPanel | Overloaded.
AddToTree_Recursive | (Inherited from SASPanelStack2.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
HideActivePanel | (Inherited from SASPanelStack2.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitializePanel | (Inherited from SASPanelStack2.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
InternalSelectPanel | (Inherited from SASPanelStack2.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnActivePanelChanged | (Inherited from SASPanelStack2.)
OnActivePanelChanging | (Inherited from SASPanelStack2.)
OnApply | (Inherited from SASPanelStack2.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCancel | (Inherited from SASPanelStack2.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | (Inherited from SASPanelStack2.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCreateTemplate | (Inherited from SASPanelStack2.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from SASPanelStack2.)
OnHandleDestroyed | (Inherited from SASPanelStack2.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | (Inherited from SASPanelStack2.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | (Inherited from SASPanelStack2.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnOK | Handling for OnOK to call back to the application and verify that the task should close at this time, replacing existing results in the project. The end user can cancel this operation. (Overrides SASPanelStack2OnOK(Object, EventArgs).)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPageStateChanged | (Inherited from SASPanelStack2.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnPanelStackContextChange | (Inherited from SASPanelStack2.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from SASPanelStack2.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveFromTree | Overloaded.
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetContextHelpPageKey | (Inherited from SASPanelStack2.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
StateChangedHandler | (Inherited from SASPanelStack2.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoMinSize | (Inherited from SASPanelStack2.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from SASPanelStack2.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
ButtonApply | (Inherited from SASPanelStack2.)
ButtonCancel | (Inherited from SASPanelStack2.)
ButtonOK | (Inherited from SASPanelStack2.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CancelButtonHasFocus | (Inherited from SASPanelStack2.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Consumer | The handle to the consumer application
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextHelp | (Inherited from SASPanelStack2.)
ContextHelpControl | (Inherited from SASPanelStack2.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
CurrentPanel | (Inherited from SASPanelStack2.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
EnableCancel | (Inherited from SASPanelStack2.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
EnableSplitter | (Inherited from SASPanelStack2.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Panels | (Inherited from SASPanelStack2.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowApply | (Inherited from SASPanelStack2.)
ShowCancel | (Inherited from SASPanelStack2.)
ShowContextHelp | (Inherited from SASPanelStack2.)
ShowDropApplyButton | (Inherited from SASPanelStack2.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowOK | (Inherited from SASPanelStack2.)
ShowPlusMinus | (Inherited from SASPanelStack2.)
ShowStatusBar | (Inherited from SASPanelStack2.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
SplitterPosition | (Inherited from SASPanelStack2.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
StatusMessage | (Inherited from SASPanelStack2.)
SuppressValidationErrorMessages | (Inherited from SASPanelStack2.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
TextApply | (Inherited from SASPanelStack2.)
TextCancel | (Inherited from SASPanelStack2.)
TextOK | (Inherited from SASPanelStack2.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
ActivePanelChanged | (Inherited from SASPanelStack2.)
ActivePanelChanging | (Inherited from SASPanelStack2.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CreateTemplate | (Inherited from SASPanelStack2.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
PanelStackContextChange | (Inherited from SASPanelStack2.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

PanelStackForm Class
SAS.Tasks.Toolkit.Controls Namespace


PanelStackForm Constructor

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
PanelStackForm Constructor
PanelStackForm Class See Also

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PanelStackForm()

See Also

PanelStackForm Class
SAS.Tasks.Toolkit.Controls Namespace


PanelStackForm Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
PanelStackForm Methods
PanelStackForm Class See Also

The PanelStackForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddControlToButtonPanel | (Inherited from SASPanelStack2.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AddPanel | Overloaded.
AddToTree_Recursive | (Inherited from SASPanelStack2.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
HideActivePanel | (Inherited from SASPanelStack2.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitializePanel | (Inherited from SASPanelStack2.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
InternalSelectPanel | (Inherited from SASPanelStack2.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnActivePanelChanged | (Inherited from SASPanelStack2.)
OnActivePanelChanging | (Inherited from SASPanelStack2.)
OnApply | (Inherited from SASPanelStack2.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCancel | (Inherited from SASPanelStack2.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | (Inherited from SASPanelStack2.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCreateTemplate | (Inherited from SASPanelStack2.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from SASPanelStack2.)
OnHandleDestroyed | (Inherited from SASPanelStack2.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | (Inherited from SASPanelStack2.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | (Inherited from SASPanelStack2.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnOK | Handling for OnOK to call back to the application and verify that the task should close at this time, replacing existing results in the project. The end user can cancel this operation. (Overrides SASPanelStack2OnOK(Object, EventArgs).)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPageStateChanged | (Inherited from SASPanelStack2.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnPanelStackContextChange | (Inherited from SASPanelStack2.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from SASPanelStack2.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveFromTree | Overloaded.
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetContextHelpPageKey | (Inherited from SASPanelStack2.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
StateChangedHandler | (Inherited from SASPanelStack2.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

PanelStackForm Class
SAS.Tasks.Toolkit.Controls Namespace


AccessibilityNotifyClients Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
PanelStackForm..::.AccessibilityNotifyClients Method
PanelStackForm Class See Also

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

PanelStackForm Class
PanelStackForm Members
SAS.Tasks.Toolkit.Controls Namespace


AddPanel Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
PanelStackForm..::.AddPanel Method
PanelStackForm Class See Also

Overload List

Name | Description
AddPanel(IPage) | (Inherited from SASPanelStack2.)
AddPanel(IPage, IPage) | (Inherited from SASPanelStack2.)

See Also

PanelStackForm Class
PanelStackForm Members
SAS.Tasks.Toolkit.Controls Namespace


BeginInvoke Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
PanelStackForm..::.BeginInvoke Method
PanelStackForm Class See Also

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

PanelStackForm Class
PanelStackForm Members
SAS.Tasks.Toolkit.Controls Namespace


Dispose Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
PanelStackForm..::.Dispose Method
PanelStackForm Class See Also

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | (Inherited from SASPanelStack2.)

See Also

PanelStackForm Class
PanelStackForm Members
SAS.Tasks.Toolkit.Controls Namespace


GetChildAtPoint Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
PanelStackForm..::.GetChildAtPoint Method
PanelStackForm Class See Also

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

PanelStackForm Class
PanelStackForm Members
SAS.Tasks.Toolkit.Controls Namespace


Invalidate Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
PanelStackForm..::.Invalidate Method
PanelStackForm Class See Also

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

PanelStackForm Class
PanelStackForm Members
SAS.Tasks.Toolkit.Controls Namespace


Invoke Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
PanelStackForm..::.Invoke Method
PanelStackForm Class See Also

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

PanelStackForm Class
PanelStackForm Members
SAS.Tasks.Toolkit.Controls Namespace


MemberwiseClone Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
PanelStackForm..::.MemberwiseClone Method
PanelStackForm Class See Also

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

PanelStackForm Class
PanelStackForm Members
SAS.Tasks.Toolkit.Controls Namespace


OnOK Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
PanelStackForm..::.OnOK Method
PanelStackForm Class See Also

Handling for OnOK to call back to the application and verify that the task should close at this time, replacing existing results in the project. The end user can cancel this operation.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub OnOK ( _
    sender As Object, _
    e As EventArgs _
)
C#
public override void OnOK(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
e
Type: System..::.EventArgs

See Also

PanelStackForm Class
SAS.Tasks.Toolkit.Controls Namespace


PerformLayout Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
PanelStackForm..::.PerformLayout Method
PanelStackForm Class See Also

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

PanelStackForm Class
PanelStackForm Members
SAS.Tasks.Toolkit.Controls Namespace


RemoveFromTree Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
PanelStackForm..::.RemoveFromTree Method
PanelStackForm Class See Also

Overload List

Name | Description
RemoveFromTree(IPage) | (Inherited from SASPanelStack2.)
RemoveFromTree(IPage, IPage) | (Inherited from SASPanelStack2.)

See Also

PanelStackForm Class
PanelStackForm Members
SAS.Tasks.Toolkit.Controls Namespace


ResumeLayout Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
PanelStackForm..::.ResumeLayout Method
PanelStackForm Class See Also

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

PanelStackForm Class
PanelStackForm Members
SAS.Tasks.Toolkit.Controls Namespace


RtlTranslateAlignment Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
PanelStackForm..::.RtlTranslateAlignment Method
PanelStackForm Class See Also

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

PanelStackForm Class
PanelStackForm Members
SAS.Tasks.Toolkit.Controls Namespace


Scale Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
PanelStackForm..::.Scale Method
PanelStackForm Class See Also

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

PanelStackForm Class
PanelStackForm Members
SAS.Tasks.Toolkit.Controls Namespace


Select Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
PanelStackForm..::.Select Method
PanelStackForm Class See Also

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next/previous control. (Inherited from Form.)

See Also

PanelStackForm Class
PanelStackForm Members
SAS.Tasks.Toolkit.Controls Namespace


SetBounds Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
PanelStackForm..::.SetBounds Method
PanelStackForm Class See Also

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

PanelStackForm Class
PanelStackForm Members
SAS.Tasks.Toolkit.Controls Namespace


Show Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
PanelStackForm..::.Show Method
PanelStackForm Class See Also

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

PanelStackForm Class
PanelStackForm Members
SAS.Tasks.Toolkit.Controls Namespace


ShowDialog Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
PanelStackForm..::.ShowDialog Method
PanelStackForm Class See Also

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner. (Inherited from Form.)

See Also

PanelStackForm Class
PanelStackForm Members
SAS.Tasks.Toolkit.Controls Namespace


UpdateBounds Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
PanelStackForm..::.UpdateBounds Method
PanelStackForm Class See Also

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

PanelStackForm Class
PanelStackForm Members
SAS.Tasks.Toolkit.Controls Namespace


Validate Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
PanelStackForm..::.Validate Method
PanelStackForm Class See Also

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

PanelStackForm Class
PanelStackForm Members
SAS.Tasks.Toolkit.Controls Namespace


ValidateChildren Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
PanelStackForm..::.ValidateChildren Method
PanelStackForm Class See Also

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

PanelStackForm Class
PanelStackForm Members
SAS.Tasks.Toolkit.Controls Namespace


PanelStackForm Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
PanelStackForm Properties
PanelStackForm Class See Also

The PanelStackForm type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoMinSize | (Inherited from SASPanelStack2.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from SASPanelStack2.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
ButtonApply | (Inherited from SASPanelStack2.)
ButtonCancel | (Inherited from SASPanelStack2.)
ButtonOK | (Inherited from SASPanelStack2.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CancelButtonHasFocus | (Inherited from SASPanelStack2.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Consumer | The handle to the consumer application
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextHelp | (Inherited from SASPanelStack2.)
ContextHelpControl | (Inherited from SASPanelStack2.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
CurrentPanel | (Inherited from SASPanelStack2.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
EnableCancel | (Inherited from SASPanelStack2.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
EnableSplitter | (Inherited from SASPanelStack2.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Panels | (Inherited from SASPanelStack2.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowApply | (Inherited from SASPanelStack2.)
ShowCancel | (Inherited from SASPanelStack2.)
ShowContextHelp | (Inherited from SASPanelStack2.)
ShowDropApplyButton | (Inherited from SASPanelStack2.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowOK | (Inherited from SASPanelStack2.)
ShowPlusMinus | (Inherited from SASPanelStack2.)
ShowStatusBar | (Inherited from SASPanelStack2.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
SplitterPosition | (Inherited from SASPanelStack2.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
StatusMessage | (Inherited from SASPanelStack2.)
SuppressValidationErrorMessages | (Inherited from SASPanelStack2.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
TextApply | (Inherited from SASPanelStack2.)
TextCancel | (Inherited from SASPanelStack2.)
TextOK | (Inherited from SASPanelStack2.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

See Also

PanelStackForm Class
SAS.Tasks.Toolkit.Controls Namespace


Consumer Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
PanelStackForm..::.Consumer Property
PanelStackForm Class See Also

The handle to the consumer application

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property Consumer As ISASTaskConsumer3
C#
public ISASTaskConsumer3 Consumer { get; set; }

See Also

PanelStackForm Class
SAS.Tasks.Toolkit.Controls Namespace


PanelStackForm Events

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
PanelStackForm Events
PanelStackForm Class See Also

The PanelStackForm type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
ActivePanelChanged | (Inherited from SASPanelStack2.)
ActivePanelChanging | (Inherited from SASPanelStack2.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CreateTemplate | (Inherited from SASPanelStack2.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
PanelStackContextChange | (Inherited from SASPanelStack2.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

PanelStackForm Class
SAS.Tasks.Toolkit.Controls Namespace


SASCodeViewDialog Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASCodeViewDialog Class
Members See Also

A dialog that can show the contents of a SAS program, color coded.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SASCodeViewDialog _
    Inherits Form
C#
public sealed class SASCodeViewDialog : Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
SAS.Tasks.Toolkit.Controls..::.SASCodeViewDialog

See Also

SASCodeViewDialog Members
SAS.Tasks.Toolkit.Controls Namespace


SASCodeViewDialog Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASCodeViewDialog Members
SASCodeViewDialog Class Constructors Methods Properties Events Explicit Interface Implementations See Also

The SASCodeViewDialog type exposes the following members.

Constructors

Name | Description
SASCodeViewDialog | Create the dialog with the text of a SAS program.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnCodeChanged | The handler for the Code-changed event.
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

SASCodeViewDialog Class
SAS.Tasks.Toolkit.Controls Namespace


SASCodeViewDialog Constructor

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASCodeViewDialog Constructor
SASCodeViewDialog Class See Also

Create the dialog with the text of a SAS program.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    parent As IWin32Window, _
    windowTitle As String, _
    initialCode As String _
)
C#
public SASCodeViewDialog(
    IWin32Window parent,
    string windowTitle,
    string initialCode
)

Parameters

parent
Type: System.Windows.Forms..::.IWin32Window
Parent window (task form) for this preview window.
windowTitle
Type: System..::.String
Title of the dialog
initialCode
Type: System..::.String
Initial SAS program code to show in the program window.

See Also

SASCodeViewDialog Class
SAS.Tasks.Toolkit.Controls Namespace


SASCodeViewDialog Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASCodeViewDialog Methods
SASCodeViewDialog Class See Also

The SASCodeViewDialog type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnCodeChanged | The handler for the Code-changed event.
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

SASCodeViewDialog Class
SAS.Tasks.Toolkit.Controls Namespace


AccessibilityNotifyClients Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASCodeViewDialog..::.AccessibilityNotifyClients Method
SASCodeViewDialog Class See Also

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

SASCodeViewDialog Class
SASCodeViewDialog Members
SAS.Tasks.Toolkit.Controls Namespace


BeginInvoke Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASCodeViewDialog..::.BeginInvoke Method
SASCodeViewDialog Class See Also

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

SASCodeViewDialog Class
SASCodeViewDialog Members
SAS.Tasks.Toolkit.Controls Namespace


Dispose Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASCodeViewDialog..::.Dispose Method
SASCodeViewDialog Class See Also

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Disposes of the resources (other than memory) used by the Form. (Inherited from Form.)

See Also

SASCodeViewDialog Class
SASCodeViewDialog Members
SAS.Tasks.Toolkit.Controls Namespace


GetChildAtPoint Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASCodeViewDialog..::.GetChildAtPoint Method
SASCodeViewDialog Class See Also

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

SASCodeViewDialog Class
SASCodeViewDialog Members
SAS.Tasks.Toolkit.Controls Namespace


Invalidate Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASCodeViewDialog..::.Invalidate Method
SASCodeViewDialog Class See Also

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

SASCodeViewDialog Class
SASCodeViewDialog Members
SAS.Tasks.Toolkit.Controls Namespace


Invoke Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASCodeViewDialog..::.Invoke Method
SASCodeViewDialog Class See Also

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

SASCodeViewDialog Class
SASCodeViewDialog Members
SAS.Tasks.Toolkit.Controls Namespace


MemberwiseClone Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASCodeViewDialog..::.MemberwiseClone Method
SASCodeViewDialog Class See Also

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

SASCodeViewDialog Class
SASCodeViewDialog Members
SAS.Tasks.Toolkit.Controls Namespace


OnCodeChanged Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASCodeViewDialog..::.OnCodeChanged Method
SASCodeViewDialog Class See Also

The handler for the Code-changed event.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub OnCodeChanged ( _
    sender As Object, _
    ea As SASCodeViewDialog..::.CodeChangedEventArgs _
)
C#
public void OnCodeChanged(
    Object sender,
    SASCodeViewDialog..::.CodeChangedEventArgs ea
)

Parameters

sender
Type: System..::.Object
object that raised the event
ea
Type: SAS.Tasks.Toolkit.Controls..::.SASCodeViewDialog..::.CodeChangedEventArgs
Event args that contains the new code.

See Also

SASCodeViewDialog Class
SAS.Tasks.Toolkit.Controls Namespace


PerformLayout Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASCodeViewDialog..::.PerformLayout Method
SASCodeViewDialog Class See Also

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

SASCodeViewDialog Class
SASCodeViewDialog Members
SAS.Tasks.Toolkit.Controls Namespace


ResumeLayout Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASCodeViewDialog..::.ResumeLayout Method
SASCodeViewDialog Class See Also

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

SASCodeViewDialog Class
SASCodeViewDialog Members
SAS.Tasks.Toolkit.Controls Namespace


RtlTranslateAlignment Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASCodeViewDialog..::.RtlTranslateAlignment Method
SASCodeViewDialog Class See Also

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

SASCodeViewDialog Class
SASCodeViewDialog Members
SAS.Tasks.Toolkit.Controls Namespace


Scale Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASCodeViewDialog..::.Scale Method
SASCodeViewDialog Class See Also

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

SASCodeViewDialog Class
SASCodeViewDialog Members
SAS.Tasks.Toolkit.Controls Namespace


Select Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASCodeViewDialog..::.Select Method
SASCodeViewDialog Class See Also

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next/previous control. (Inherited from Form.)

See Also

SASCodeViewDialog Class
SASCodeViewDialog Members
SAS.Tasks.Toolkit.Controls Namespace


SetBounds Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASCodeViewDialog..::.SetBounds Method
SASCodeViewDialog Class See Also

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

SASCodeViewDialog Class
SASCodeViewDialog Members
SAS.Tasks.Toolkit.Controls Namespace


Show Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASCodeViewDialog..::.Show Method
SASCodeViewDialog Class See Also

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

SASCodeViewDialog Class
SASCodeViewDialog Members
SAS.Tasks.Toolkit.Controls Namespace


ShowDialog Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASCodeViewDialog..::.ShowDialog Method
SASCodeViewDialog Class See Also

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner. (Inherited from Form.)

See Also

SASCodeViewDialog Class
SASCodeViewDialog Members
SAS.Tasks.Toolkit.Controls Namespace


UpdateBounds Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASCodeViewDialog..::.UpdateBounds Method
SASCodeViewDialog Class See Also

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

SASCodeViewDialog Class
SASCodeViewDialog Members
SAS.Tasks.Toolkit.Controls Namespace


Validate Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASCodeViewDialog..::.Validate Method
SASCodeViewDialog Class See Also

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

SASCodeViewDialog Class
SASCodeViewDialog Members
SAS.Tasks.Toolkit.Controls Namespace


ValidateChildren Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASCodeViewDialog..::.ValidateChildren Method
SASCodeViewDialog Class See Also

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

SASCodeViewDialog Class
SASCodeViewDialog Members
SAS.Tasks.Toolkit.Controls Namespace


SASCodeViewDialog Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASCodeViewDialog Properties
SASCodeViewDialog Class See Also

The SASCodeViewDialog type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

See Also

SASCodeViewDialog Class
SAS.Tasks.Toolkit.Controls Namespace


SASCodeViewDialog Events

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASCodeViewDialog Events
SASCodeViewDialog Class See Also

The SASCodeViewDialog type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

SASCodeViewDialog Class
SAS.Tasks.Toolkit.Controls Namespace


SASCodeViewDialog.CodeChangedEventArgs Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASCodeViewDialog..::.CodeChangedEventArgs Class
SASCodeViewDialog Class Members See Also

Special EventArgs class to deal with the code-changed event.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class CodeChangedEventArgs _
    Inherits EventArgs
C#
public sealed class CodeChangedEventArgs : EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
SAS.Tasks.Toolkit.Controls..::.SASCodeViewDialog..::.CodeChangedEventArgs

See Also

SASCodeViewDialog..::.CodeChangedEventArgs Members
SAS.Tasks.Toolkit.Controls Namespace


SASCodeViewDialog.CodeChangedEventArgs Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASCodeViewDialog..::.CodeChangedEventArgs Members
SASCodeViewDialog..::.CodeChangedEventArgs Class Constructors Methods Properties See Also

A dialog that can show the contents of a SAS program, color coded.

The SASCodeViewDialog..::.CodeChangedEventArgs type exposes the following members.

Constructors

Name | Description
SASCodeViewDialog..::.CodeChangedEventArgs | Constructor

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
NewCode | New code that triggered the event.

See Also

SASCodeViewDialog..::.CodeChangedEventArgs Class
SAS.Tasks.Toolkit.Controls Namespace


SASCodeViewDialog.CodeChangedEventArgs Constructor

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASCodeViewDialog..::.CodeChangedEventArgs Constructor
SASCodeViewDialog..::.CodeChangedEventArgs Class See Also

Constructor

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    newCode As String _
)
C#
public CodeChangedEventArgs(
    string newCode
)

Parameters

newCode
Type: System..::.String
New code that triggered the event.

See Also

SASCodeViewDialog..::.CodeChangedEventArgs Class
SAS.Tasks.Toolkit.Controls Namespace


SASCodeViewDialog.CodeChangedEventArgs Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASCodeViewDialog..::.CodeChangedEventArgs Methods
SASCodeViewDialog..::.CodeChangedEventArgs Class See Also

The SASCodeViewDialog..::.CodeChangedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SASCodeViewDialog..::.CodeChangedEventArgs Class
SAS.Tasks.Toolkit.Controls Namespace


SASCodeViewDialog.CodeChangedEventArgs Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASCodeViewDialog..::.CodeChangedEventArgs Properties
SASCodeViewDialog..::.CodeChangedEventArgs Class See Also

The SASCodeViewDialog..::.CodeChangedEventArgs type exposes the following members.

Properties

Name | Description
NewCode | New code that triggered the event.

See Also

SASCodeViewDialog..::.CodeChangedEventArgs Class
SAS.Tasks.Toolkit.Controls Namespace


NewCode Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASCodeViewDialog..::.CodeChangedEventArgs..::.NewCode Property
SASCodeViewDialog..::.CodeChangedEventArgs Class See Also

New code that triggered the event.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property NewCode As String
C#
public string NewCode { get; set; }

See Also

SASCodeViewDialog..::.CodeChangedEventArgs Class
SAS.Tasks.Toolkit.Controls Namespace


SASCodeViewDialog.CodeChangedEventHandler Delegate

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASCodeViewDialog..::.CodeChangedEventHandler Delegate
SASCodeViewDialog Class See Also

Delegate for the Code-changed event

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub CodeChangedEventHandler ( _
    sender As Object, _
    ea As SASCodeViewDialog..::.CodeChangedEventArgs _
)
C#
public delegate void CodeChangedEventHandler(
    Object sender,
    SASCodeViewDialog..::.CodeChangedEventArgs ea
)

Parameters

sender
Type: System..::.Object
object that raised the event
ea
Type: SAS.Tasks.Toolkit.Controls..::.SASCodeViewDialog..::.CodeChangedEventArgs
event args object that contains the new code

See Also

SAS.Tasks.Toolkit.Controls Namespace


SASLogViewDialog Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASLogViewDialog Class
Members See Also

A modal dialog that can show the contents of a SAS log, color coded.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SASLogViewDialog _
    Inherits Form
C#
public sealed class SASLogViewDialog : Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
SAS.Tasks.Toolkit.Controls..::.SASLogViewDialog

See Also

SASLogViewDialog Members
SAS.Tasks.Toolkit.Controls Namespace


SASLogViewDialog Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASLogViewDialog Members
SASLogViewDialog Class Constructors Methods Properties Events Explicit Interface Implementations See Also

The SASLogViewDialog type exposes the following members.

Constructors

Name | Description
SASLogViewDialog | Create the dialog with the text of the SAS log.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

SASLogViewDialog Class
SAS.Tasks.Toolkit.Controls Namespace


SASLogViewDialog Constructor

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASLogViewDialog Constructor
SASLogViewDialog Class See Also

Create the dialog with the text of the SAS log.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    windowTitle As String, _
    labelText As String, _
    log As String _
)
C#
public SASLogViewDialog(
    string windowTitle,
    string labelText,
    string log
)

Parameters

windowTitle
Type: System..::.String
Title of the dialog
labelText
Type: System..::.String
Text of the label to show above the log view. If you specify an empty string, the label field will not be displayed.
log
Type: System..::.String
Text of the log to display. This should be a SAS log complete with the color-coding format characters.

See Also

SASLogViewDialog Class
SAS.Tasks.Toolkit.Controls Namespace


SASLogViewDialog Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASLogViewDialog Methods
SASLogViewDialog Class See Also

The SASLogViewDialog type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

SASLogViewDialog Class
SAS.Tasks.Toolkit.Controls Namespace


AccessibilityNotifyClients Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASLogViewDialog..::.AccessibilityNotifyClients Method
SASLogViewDialog Class See Also

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

SASLogViewDialog Class
SASLogViewDialog Members
SAS.Tasks.Toolkit.Controls Namespace


BeginInvoke Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASLogViewDialog..::.BeginInvoke Method
SASLogViewDialog Class See Also

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

SASLogViewDialog Class
SASLogViewDialog Members
SAS.Tasks.Toolkit.Controls Namespace


Dispose Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASLogViewDialog..::.Dispose Method
SASLogViewDialog Class See Also

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Disposes of the resources (other than memory) used by the Form. (Inherited from Form.)

See Also

SASLogViewDialog Class
SASLogViewDialog Members
SAS.Tasks.Toolkit.Controls Namespace


GetChildAtPoint Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASLogViewDialog..::.GetChildAtPoint Method
SASLogViewDialog Class See Also

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

SASLogViewDialog Class
SASLogViewDialog Members
SAS.Tasks.Toolkit.Controls Namespace


Invalidate Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASLogViewDialog..::.Invalidate Method
SASLogViewDialog Class See Also

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

SASLogViewDialog Class
SASLogViewDialog Members
SAS.Tasks.Toolkit.Controls Namespace


Invoke Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASLogViewDialog..::.Invoke Method
SASLogViewDialog Class See Also

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

SASLogViewDialog Class
SASLogViewDialog Members
SAS.Tasks.Toolkit.Controls Namespace


MemberwiseClone Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASLogViewDialog..::.MemberwiseClone Method
SASLogViewDialog Class See Also

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

SASLogViewDialog Class
SASLogViewDialog Members
SAS.Tasks.Toolkit.Controls Namespace


PerformLayout Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASLogViewDialog..::.PerformLayout Method
SASLogViewDialog Class See Also

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

SASLogViewDialog Class
SASLogViewDialog Members
SAS.Tasks.Toolkit.Controls Namespace


ResumeLayout Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASLogViewDialog..::.ResumeLayout Method
SASLogViewDialog Class See Also

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

SASLogViewDialog Class
SASLogViewDialog Members
SAS.Tasks.Toolkit.Controls Namespace


RtlTranslateAlignment Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASLogViewDialog..::.RtlTranslateAlignment Method
SASLogViewDialog Class See Also

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

SASLogViewDialog Class
SASLogViewDialog Members
SAS.Tasks.Toolkit.Controls Namespace


Scale Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASLogViewDialog..::.Scale Method
SASLogViewDialog Class See Also

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

SASLogViewDialog Class
SASLogViewDialog Members
SAS.Tasks.Toolkit.Controls Namespace


Select Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASLogViewDialog..::.Select Method
SASLogViewDialog Class See Also

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next/previous control. (Inherited from Form.)

See Also

SASLogViewDialog Class
SASLogViewDialog Members
SAS.Tasks.Toolkit.Controls Namespace


SetBounds Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASLogViewDialog..::.SetBounds Method
SASLogViewDialog Class See Also

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

SASLogViewDialog Class
SASLogViewDialog Members
SAS.Tasks.Toolkit.Controls Namespace


Show Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASLogViewDialog..::.Show Method
SASLogViewDialog Class See Also

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

SASLogViewDialog Class
SASLogViewDialog Members
SAS.Tasks.Toolkit.Controls Namespace


ShowDialog Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASLogViewDialog..::.ShowDialog Method
SASLogViewDialog Class See Also

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner. (Inherited from Form.)

See Also

SASLogViewDialog Class
SASLogViewDialog Members
SAS.Tasks.Toolkit.Controls Namespace


UpdateBounds Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASLogViewDialog..::.UpdateBounds Method
SASLogViewDialog Class See Also

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

SASLogViewDialog Class
SASLogViewDialog Members
SAS.Tasks.Toolkit.Controls Namespace


Validate Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASLogViewDialog..::.Validate Method
SASLogViewDialog Class See Also

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

SASLogViewDialog Class
SASLogViewDialog Members
SAS.Tasks.Toolkit.Controls Namespace


ValidateChildren Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASLogViewDialog..::.ValidateChildren Method
SASLogViewDialog Class See Also

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

SASLogViewDialog Class
SASLogViewDialog Members
SAS.Tasks.Toolkit.Controls Namespace


SASLogViewDialog Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASLogViewDialog Properties
SASLogViewDialog Class See Also

The SASLogViewDialog type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

See Also

SASLogViewDialog Class
SAS.Tasks.Toolkit.Controls Namespace


SASLogViewDialog Events

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASLogViewDialog Events
SASLogViewDialog Class See Also

The SASLogViewDialog type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

SASLogViewDialog Class
SAS.Tasks.Toolkit.Controls Namespace


SasServerDropListCtl Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasServerDropListCtl Class
Members See Also

A Windows combobox (dropdown list style) that displays the available SAS workspace servers for the current environment.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SasServerDropListCtl _
    Inherits UserControl
C#
public sealed class SasServerDropListCtl : UserControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
SAS.Tasks.Toolkit.Controls..::.SasServerDropListCtl

See Also

SasServerDropListCtl Members
SAS.Tasks.Toolkit.Controls Namespace


SasServerDropListCtl Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasServerDropListCtl Members
SasServerDropListCtl Class Constructors Methods Properties Events Explicit Interface Implementations See Also

The SasServerDropListCtl type exposes the following members.

Constructors

Name | Description
SasServerDropListCtl | Default constructor for this control.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetSelectedServerName | Set the selected server on the drop list by providing its name.
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
SelectedServer | Sets or gets the selected SAS server as a SasServer object.
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

SasServerDropListCtl Class
SAS.Tasks.Toolkit.Controls Namespace


SasServerDropListCtl Constructor

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasServerDropListCtl Constructor
SasServerDropListCtl Class See Also

Default constructor for this control.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SasServerDropListCtl()

See Also

SasServerDropListCtl Class
SAS.Tasks.Toolkit.Controls Namespace


SasServerDropListCtl Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasServerDropListCtl Methods
SasServerDropListCtl Class See Also

The SasServerDropListCtl type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetSelectedServerName | Set the selected server on the drop list by providing its name.
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

SasServerDropListCtl Class
SAS.Tasks.Toolkit.Controls Namespace


AccessibilityNotifyClients Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasServerDropListCtl..::.AccessibilityNotifyClients Method
SasServerDropListCtl Class See Also

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

SasServerDropListCtl Class
SasServerDropListCtl Members
SAS.Tasks.Toolkit.Controls Namespace


BeginInvoke Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasServerDropListCtl..::.BeginInvoke Method
SasServerDropListCtl Class See Also

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

SasServerDropListCtl Class
SasServerDropListCtl Members
SAS.Tasks.Toolkit.Controls Namespace


Dispose Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasServerDropListCtl..::.Dispose Method
SasServerDropListCtl Class See Also

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | (Inherited from ContainerControl.)

See Also

SasServerDropListCtl Class
SasServerDropListCtl Members
SAS.Tasks.Toolkit.Controls Namespace


GetChildAtPoint Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasServerDropListCtl..::.GetChildAtPoint Method
SasServerDropListCtl Class See Also

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

SasServerDropListCtl Class
SasServerDropListCtl Members
SAS.Tasks.Toolkit.Controls Namespace


Invalidate Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasServerDropListCtl..::.Invalidate Method
SasServerDropListCtl Class See Also

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

SasServerDropListCtl Class
SasServerDropListCtl Members
SAS.Tasks.Toolkit.Controls Namespace


Invoke Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasServerDropListCtl..::.Invoke Method
SasServerDropListCtl Class See Also

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

SasServerDropListCtl Class
SasServerDropListCtl Members
SAS.Tasks.Toolkit.Controls Namespace


MemberwiseClone Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasServerDropListCtl..::.MemberwiseClone Method
SasServerDropListCtl Class See Also

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

SasServerDropListCtl Class
SasServerDropListCtl Members
SAS.Tasks.Toolkit.Controls Namespace


PerformLayout Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasServerDropListCtl..::.PerformLayout Method
SasServerDropListCtl Class See Also

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

SasServerDropListCtl Class
SasServerDropListCtl Members
SAS.Tasks.Toolkit.Controls Namespace


ResumeLayout Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasServerDropListCtl..::.ResumeLayout Method
SasServerDropListCtl Class See Also

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

SasServerDropListCtl Class
SasServerDropListCtl Members
SAS.Tasks.Toolkit.Controls Namespace


RtlTranslateAlignment Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasServerDropListCtl..::.RtlTranslateAlignment Method
SasServerDropListCtl Class See Also

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

SasServerDropListCtl Class
SasServerDropListCtl Members
SAS.Tasks.Toolkit.Controls Namespace


Scale Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasServerDropListCtl..::.Scale Method
SasServerDropListCtl Class See Also

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

SasServerDropListCtl Class
SasServerDropListCtl Members
SAS.Tasks.Toolkit.Controls Namespace


Select Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasServerDropListCtl..::.Select Method
SasServerDropListCtl Class See Also

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

SasServerDropListCtl Class
SasServerDropListCtl Members
SAS.Tasks.Toolkit.Controls Namespace


SetBounds Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasServerDropListCtl..::.SetBounds Method
SasServerDropListCtl Class See Also

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

SasServerDropListCtl Class
SasServerDropListCtl Members
SAS.Tasks.Toolkit.Controls Namespace


SetSelectedServerName Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasServerDropListCtl..::.SetSelectedServerName Method
SasServerDropListCtl Class See Also

Set the selected server on the drop list by providing its name.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetSelectedServerName ( _
    serverName As String _
)
C#
public void SetSelectedServerName(
    string serverName
)

Parameters

serverName
Type: System..::.String
The name of the SAS server to select.

See Also

SasServerDropListCtl Class
SAS.Tasks.Toolkit.Controls Namespace


UpdateBounds Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasServerDropListCtl..::.UpdateBounds Method
SasServerDropListCtl Class See Also

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

SasServerDropListCtl Class
SasServerDropListCtl Members
SAS.Tasks.Toolkit.Controls Namespace


Validate Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasServerDropListCtl..::.Validate Method
SasServerDropListCtl Class See Also

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

SasServerDropListCtl Class
SasServerDropListCtl Members
SAS.Tasks.Toolkit.Controls Namespace


ValidateChildren Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasServerDropListCtl..::.ValidateChildren Method
SasServerDropListCtl Class See Also

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

SasServerDropListCtl Class
SasServerDropListCtl Members
SAS.Tasks.Toolkit.Controls Namespace


SasServerDropListCtl Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasServerDropListCtl Properties
SasServerDropListCtl Class See Also

The SasServerDropListCtl type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
SelectedServer | Sets or gets the selected SAS server as a SasServer object.
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

SasServerDropListCtl Class
SAS.Tasks.Toolkit.Controls Namespace


SelectedServer Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasServerDropListCtl..::.SelectedServer Property
SasServerDropListCtl Class See Also

Sets or gets the selected SAS server as a SasServer object.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedServer As SasServer
C#
public SasServer SelectedServer { get; set; }

See Also

SasServerDropListCtl Class
SAS.Tasks.Toolkit.Controls Namespace


SasServerDropListCtl Events

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasServerDropListCtl Events
SasServerDropListCtl Class See Also

The SasServerDropListCtl type exposes the following members.

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

SasServerDropListCtl Class
SAS.Tasks.Toolkit.Controls Namespace


SASTextEditorCtl Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTextEditorCtl Class
Members See Also

A text editor/viewer control that supports syntax coloring for SAS logs and SAS programs.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SASTextEditorCtl _
    Inherits UserControl
C#
public sealed class SASTextEditorCtl : UserControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
SAS.Tasks.Toolkit.Controls..::.SASTextEditorCtl

See Also

SASTextEditorCtl Members
SAS.Tasks.Toolkit.Controls Namespace


SASTextEditorCtl Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTextEditorCtl Members
SASTextEditorCtl Class Constructors Methods Properties Events Explicit Interface Implementations See Also

The SASTextEditorCtl type exposes the following members.

Constructors

Name | Description
SASTextEditorCtl | Constructor for the control

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContentType | Specifies the type of content to be displayed in this control
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
EditorText | The text to display in the editor view
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
ReadOnly | Whether the editor view is read-only.
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

SASTextEditorCtl Class
SAS.Tasks.Toolkit.Controls Namespace


SASTextEditorCtl Constructor

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTextEditorCtl Constructor
SASTextEditorCtl Class See Also

Constructor for the control

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SASTextEditorCtl()

See Also

SASTextEditorCtl Class
SAS.Tasks.Toolkit.Controls Namespace


SASTextEditorCtl Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTextEditorCtl Methods
SASTextEditorCtl Class See Also

The SASTextEditorCtl type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

SASTextEditorCtl Class
SAS.Tasks.Toolkit.Controls Namespace


AccessibilityNotifyClients Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTextEditorCtl..::.AccessibilityNotifyClients Method
SASTextEditorCtl Class See Also

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

SASTextEditorCtl Class
SASTextEditorCtl Members
SAS.Tasks.Toolkit.Controls Namespace


BeginInvoke Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTextEditorCtl..::.BeginInvoke Method
SASTextEditorCtl Class See Also

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

SASTextEditorCtl Class
SASTextEditorCtl Members
SAS.Tasks.Toolkit.Controls Namespace


Dispose Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTextEditorCtl..::.Dispose Method
SASTextEditorCtl Class See Also

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | (Inherited from ContainerControl.)

See Also

SASTextEditorCtl Class
SASTextEditorCtl Members
SAS.Tasks.Toolkit.Controls Namespace


GetChildAtPoint Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTextEditorCtl..::.GetChildAtPoint Method
SASTextEditorCtl Class See Also

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

SASTextEditorCtl Class
SASTextEditorCtl Members
SAS.Tasks.Toolkit.Controls Namespace


Invalidate Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTextEditorCtl..::.Invalidate Method
SASTextEditorCtl Class See Also

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

SASTextEditorCtl Class
SASTextEditorCtl Members
SAS.Tasks.Toolkit.Controls Namespace


Invoke Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTextEditorCtl..::.Invoke Method
SASTextEditorCtl Class See Also

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

SASTextEditorCtl Class
SASTextEditorCtl Members
SAS.Tasks.Toolkit.Controls Namespace


MemberwiseClone Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTextEditorCtl..::.MemberwiseClone Method
SASTextEditorCtl Class See Also

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

SASTextEditorCtl Class
SASTextEditorCtl Members
SAS.Tasks.Toolkit.Controls Namespace


PerformLayout Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTextEditorCtl..::.PerformLayout Method
SASTextEditorCtl Class See Also

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

SASTextEditorCtl Class
SASTextEditorCtl Members
SAS.Tasks.Toolkit.Controls Namespace


ResumeLayout Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTextEditorCtl..::.ResumeLayout Method
SASTextEditorCtl Class See Also

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

SASTextEditorCtl Class
SASTextEditorCtl Members
SAS.Tasks.Toolkit.Controls Namespace


RtlTranslateAlignment Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTextEditorCtl..::.RtlTranslateAlignment Method
SASTextEditorCtl Class See Also

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

SASTextEditorCtl Class
SASTextEditorCtl Members
SAS.Tasks.Toolkit.Controls Namespace


Scale Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTextEditorCtl..::.Scale Method
SASTextEditorCtl Class See Also

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

SASTextEditorCtl Class
SASTextEditorCtl Members
SAS.Tasks.Toolkit.Controls Namespace


Select Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTextEditorCtl..::.Select Method
SASTextEditorCtl Class See Also

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

SASTextEditorCtl Class
SASTextEditorCtl Members
SAS.Tasks.Toolkit.Controls Namespace


SetBounds Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTextEditorCtl..::.SetBounds Method
SASTextEditorCtl Class See Also

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

SASTextEditorCtl Class
SASTextEditorCtl Members
SAS.Tasks.Toolkit.Controls Namespace


UpdateBounds Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTextEditorCtl..::.UpdateBounds Method
SASTextEditorCtl Class See Also

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

SASTextEditorCtl Class
SASTextEditorCtl Members
SAS.Tasks.Toolkit.Controls Namespace


Validate Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTextEditorCtl..::.Validate Method
SASTextEditorCtl Class See Also

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

SASTextEditorCtl Class
SASTextEditorCtl Members
SAS.Tasks.Toolkit.Controls Namespace


ValidateChildren Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTextEditorCtl..::.ValidateChildren Method
SASTextEditorCtl Class See Also

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

SASTextEditorCtl Class
SASTextEditorCtl Members
SAS.Tasks.Toolkit.Controls Namespace


SASTextEditorCtl Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTextEditorCtl Properties
SASTextEditorCtl Class See Also

The SASTextEditorCtl type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContentType | Specifies the type of content to be displayed in this control
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
EditorText | The text to display in the editor view
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
ReadOnly | Whether the editor view is read-only.
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

SASTextEditorCtl Class
SAS.Tasks.Toolkit.Controls Namespace


ContentType Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTextEditorCtl..::.ContentType Property
SASTextEditorCtl Class See Also

Specifies the type of content to be displayed in this control

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property ContentType As SASTextEditorCtl..::.eContentType
C#
public SASTextEditorCtl..::.eContentType ContentType { get; set; }

See Also

SASTextEditorCtl Class
SAS.Tasks.Toolkit.Controls Namespace


EditorText Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTextEditorCtl..::.EditorText Property
SASTextEditorCtl Class See Also

The text to display in the editor view

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property EditorText As String
C#
public string EditorText { get; set; }

See Also

SASTextEditorCtl Class
SAS.Tasks.Toolkit.Controls Namespace


ReadOnly Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTextEditorCtl..::.ReadOnly Property
SASTextEditorCtl Class See Also

Whether the editor view is read-only.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property ReadOnly As Boolean
C#
public bool ReadOnly { get; set; }

See Also

SASTextEditorCtl Class
SAS.Tasks.Toolkit.Controls Namespace


SASTextEditorCtl Events

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTextEditorCtl Events
SASTextEditorCtl Class See Also

The SASTextEditorCtl type exposes the following members.

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

SASTextEditorCtl Class
SAS.Tasks.Toolkit.Controls Namespace


SASTextEditorCtl.eContentType Enumeration

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SASTextEditorCtl..::.eContentType Enumeration
SASTextEditorCtl Class See Also

Enumeration of the content types that this control supports: programs and logs.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration eContentType
C#
public enum eContentType

Members

Member name | Description
SASProgram | A SAS program (DATA steps, PROC steps, macro code)
SASLog | A SAS log (output from running a SAS program)

See Also

SAS.Tasks.Toolkit.Controls Namespace


SelectServerDataCtl Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SelectServerDataCtl Class
Members See Also

A control to select a collection of data from a SAS server to use as input to a task.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Class SelectServerDataCtl _
    Inherits UserControl
C#
public class SelectServerDataCtl : UserControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
SAS.Tasks.Toolkit.Controls..::.SelectServerDataCtl

See Also

SelectServerDataCtl Members
SAS.Tasks.Toolkit.Controls Namespace


SelectServerDataCtl Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SelectServerDataCtl Members
SelectServerDataCtl Class Constructors Methods Properties Events Explicit Interface Implementations See Also

The SelectServerDataCtl type exposes the following members.

Constructors

Name | Description
SelectServerDataCtl | Constructor

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Override for OnLoad to add current data items to the list (Overrides UserControl..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Consumer | The application ISASTaskConsumer interface.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestrictToSingleServer | Whether to restrict this control to a single server (all data comes from one server) or allow data from multiple servers within the selected list.
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
DataListChanged | Raised when data sets are added or removed from the displayed list.
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

SelectServerDataCtl Class
SAS.Tasks.Toolkit.Controls Namespace


SelectServerDataCtl Constructor

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SelectServerDataCtl Constructor
SelectServerDataCtl Class See Also

Constructor

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SelectServerDataCtl()

See Also

SelectServerDataCtl Class
SAS.Tasks.Toolkit.Controls Namespace


SelectServerDataCtl Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SelectServerDataCtl Methods
SelectServerDataCtl Class See Also

The SelectServerDataCtl type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Override for OnLoad to add current data items to the list (Overrides UserControl..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

SelectServerDataCtl Class
SAS.Tasks.Toolkit.Controls Namespace


AccessibilityNotifyClients Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SelectServerDataCtl..::.AccessibilityNotifyClients Method
SelectServerDataCtl Class See Also

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

SelectServerDataCtl Class
SelectServerDataCtl Members
SAS.Tasks.Toolkit.Controls Namespace


BeginInvoke Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SelectServerDataCtl..::.BeginInvoke Method
SelectServerDataCtl Class See Also

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

SelectServerDataCtl Class
SelectServerDataCtl Members
SAS.Tasks.Toolkit.Controls Namespace


Dispose Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SelectServerDataCtl..::.Dispose Method
SelectServerDataCtl Class See Also

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControl..::.Dispose(Boolean).)

See Also

SelectServerDataCtl Class
SelectServerDataCtl Members
SAS.Tasks.Toolkit.Controls Namespace


Dispose Method (Boolean)

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SelectServerDataCtl..::.Dispose Method (Boolean)
SelectServerDataCtl Class See Also

Clean up any resources being used.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean

See Also

SelectServerDataCtl Class
Dispose Overload
SAS.Tasks.Toolkit.Controls Namespace


GetChildAtPoint Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SelectServerDataCtl..::.GetChildAtPoint Method
SelectServerDataCtl Class See Also

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

SelectServerDataCtl Class
SelectServerDataCtl Members
SAS.Tasks.Toolkit.Controls Namespace


Invalidate Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SelectServerDataCtl..::.Invalidate Method
SelectServerDataCtl Class See Also

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

SelectServerDataCtl Class
SelectServerDataCtl Members
SAS.Tasks.Toolkit.Controls Namespace


Invoke Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SelectServerDataCtl..::.Invoke Method
SelectServerDataCtl Class See Also

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

SelectServerDataCtl Class
SelectServerDataCtl Members
SAS.Tasks.Toolkit.Controls Namespace


MemberwiseClone Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SelectServerDataCtl..::.MemberwiseClone Method
SelectServerDataCtl Class See Also

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

SelectServerDataCtl Class
SelectServerDataCtl Members
SAS.Tasks.Toolkit.Controls Namespace


OnLoad Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SelectServerDataCtl..::.OnLoad Method
SelectServerDataCtl Class See Also

Override for OnLoad to add current data items to the list

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnLoad ( _
    e As EventArgs _
)
C#
protected override void OnLoad(
    EventArgs e
)

Parameters

e
Type: System..::.EventArgs

See Also

SelectServerDataCtl Class
SAS.Tasks.Toolkit.Controls Namespace


PerformLayout Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SelectServerDataCtl..::.PerformLayout Method
SelectServerDataCtl Class See Also

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

SelectServerDataCtl Class
SelectServerDataCtl Members
SAS.Tasks.Toolkit.Controls Namespace


ResumeLayout Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SelectServerDataCtl..::.ResumeLayout Method
SelectServerDataCtl Class See Also

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

SelectServerDataCtl Class
SelectServerDataCtl Members
SAS.Tasks.Toolkit.Controls Namespace


RtlTranslateAlignment Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SelectServerDataCtl..::.RtlTranslateAlignment Method
SelectServerDataCtl Class See Also

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

SelectServerDataCtl Class
SelectServerDataCtl Members
SAS.Tasks.Toolkit.Controls Namespace


Scale Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SelectServerDataCtl..::.Scale Method
SelectServerDataCtl Class See Also

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

SelectServerDataCtl Class
SelectServerDataCtl Members
SAS.Tasks.Toolkit.Controls Namespace


Select Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SelectServerDataCtl..::.Select Method
SelectServerDataCtl Class See Also

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

SelectServerDataCtl Class
SelectServerDataCtl Members
SAS.Tasks.Toolkit.Controls Namespace


SetBounds Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SelectServerDataCtl..::.SetBounds Method
SelectServerDataCtl Class See Also

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

SelectServerDataCtl Class
SelectServerDataCtl Members
SAS.Tasks.Toolkit.Controls Namespace


UpdateBounds Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SelectServerDataCtl..::.UpdateBounds Method
SelectServerDataCtl Class See Also

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

SelectServerDataCtl Class
SelectServerDataCtl Members
SAS.Tasks.Toolkit.Controls Namespace


Validate Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SelectServerDataCtl..::.Validate Method
SelectServerDataCtl Class See Also

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

SelectServerDataCtl Class
SelectServerDataCtl Members
SAS.Tasks.Toolkit.Controls Namespace


ValidateChildren Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SelectServerDataCtl..::.ValidateChildren Method
SelectServerDataCtl Class See Also

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

SelectServerDataCtl Class
SelectServerDataCtl Members
SAS.Tasks.Toolkit.Controls Namespace


SelectServerDataCtl Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SelectServerDataCtl Properties
SelectServerDataCtl Class See Also

The SelectServerDataCtl type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Consumer | The application ISASTaskConsumer interface.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestrictToSingleServer | Whether to restrict this control to a single server (all data comes from one server) or allow data from multiple servers within the selected list.
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

SelectServerDataCtl Class
SAS.Tasks.Toolkit.Controls Namespace


Consumer Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SelectServerDataCtl..::.Consumer Property
SelectServerDataCtl Class See Also

The application ISASTaskConsumer interface.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property Consumer As ISASTaskConsumer3
C#
public ISASTaskConsumer3 Consumer { get; set; }

See Also

SelectServerDataCtl Class
SAS.Tasks.Toolkit.Controls Namespace


RestrictToSingleServer Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SelectServerDataCtl..::.RestrictToSingleServer Property
SelectServerDataCtl Class See Also

Whether to restrict this control to a single server (all data comes from one server) or allow data from multiple servers within the selected list.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property RestrictToSingleServer As Boolean
C#
public bool RestrictToSingleServer { get; set; }

See Also

SelectServerDataCtl Class
SAS.Tasks.Toolkit.Controls Namespace


SelectServerDataCtl Events

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SelectServerDataCtl Events
SelectServerDataCtl Class See Also

The SelectServerDataCtl type exposes the following members.

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
DataListChanged | Raised when data sets are added or removed from the displayed list.
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

SelectServerDataCtl Class
SAS.Tasks.Toolkit.Controls Namespace


DataListChanged Event

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SelectServerDataCtl..::.DataListChanged Event
SelectServerDataCtl Class See Also

Raised when data sets are added or removed from the displayed list.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Event DataListChanged As EventHandler
C#
public event EventHandler DataListChanged

See Also

SelectServerDataCtl Class
SAS.Tasks.Toolkit.Controls Namespace


ServerFoldersDialog Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ServerFoldersDialog Class
Members See Also

A dialog to allow the selection of a folder from the file system of a SAS server.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ServerFoldersDialog _
    Inherits Form
C#
public sealed class ServerFoldersDialog : Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
SAS.Tasks.Toolkit.Controls..::.ServerFoldersDialog

See Also

ServerFoldersDialog Members
SAS.Tasks.Toolkit.Controls Namespace


ServerFoldersDialog Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ServerFoldersDialog Members
ServerFoldersDialog Class Constructors Methods Properties Events Explicit Interface Implementations See Also

The ServerFoldersDialog type exposes the following members.

Constructors

Name | Description
ServerFoldersDialog | Constructor for the ServerFoldersDialog.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
SelectedFolder | The name of the selected folder on the server file system.
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

ServerFoldersDialog Class
SAS.Tasks.Toolkit.Controls Namespace


ServerFoldersDialog Constructor

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ServerFoldersDialog Constructor
ServerFoldersDialog Class See Also

Constructor for the ServerFoldersDialog.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    sasServerName As String _
)
C#
public ServerFoldersDialog(
    string sasServerName
)

Parameters

sasServerName
Type: System..::.String
The name of the SAS server whose file system you want to display.

See Also

ServerFoldersDialog Class
SAS.Tasks.Toolkit.Controls Namespace


ServerFoldersDialog Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ServerFoldersDialog Methods
ServerFoldersDialog Class See Also

The ServerFoldersDialog type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

ServerFoldersDialog Class
SAS.Tasks.Toolkit.Controls Namespace


AccessibilityNotifyClients Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ServerFoldersDialog..::.AccessibilityNotifyClients Method
ServerFoldersDialog Class See Also

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ServerFoldersDialog Class
ServerFoldersDialog Members
SAS.Tasks.Toolkit.Controls Namespace


BeginInvoke Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ServerFoldersDialog..::.BeginInvoke Method
ServerFoldersDialog Class See Also

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ServerFoldersDialog Class
ServerFoldersDialog Members
SAS.Tasks.Toolkit.Controls Namespace


Dispose Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ServerFoldersDialog..::.Dispose Method
ServerFoldersDialog Class See Also

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Disposes of the resources (other than memory) used by the Form. (Inherited from Form.)

See Also

ServerFoldersDialog Class
ServerFoldersDialog Members
SAS.Tasks.Toolkit.Controls Namespace


GetChildAtPoint Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ServerFoldersDialog..::.GetChildAtPoint Method
ServerFoldersDialog Class See Also

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ServerFoldersDialog Class
ServerFoldersDialog Members
SAS.Tasks.Toolkit.Controls Namespace


Invalidate Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ServerFoldersDialog..::.Invalidate Method
ServerFoldersDialog Class See Also

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ServerFoldersDialog Class
ServerFoldersDialog Members
SAS.Tasks.Toolkit.Controls Namespace


Invoke Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ServerFoldersDialog..::.Invoke Method
ServerFoldersDialog Class See Also

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ServerFoldersDialog Class
ServerFoldersDialog Members
SAS.Tasks.Toolkit.Controls Namespace


MemberwiseClone Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ServerFoldersDialog..::.MemberwiseClone Method
ServerFoldersDialog Class See Also

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ServerFoldersDialog Class
ServerFoldersDialog Members
SAS.Tasks.Toolkit.Controls Namespace


PerformLayout Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ServerFoldersDialog..::.PerformLayout Method
ServerFoldersDialog Class See Also

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ServerFoldersDialog Class
ServerFoldersDialog Members
SAS.Tasks.Toolkit.Controls Namespace


ResumeLayout Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ServerFoldersDialog..::.ResumeLayout Method
ServerFoldersDialog Class See Also

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ServerFoldersDialog Class
ServerFoldersDialog Members
SAS.Tasks.Toolkit.Controls Namespace


RtlTranslateAlignment Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ServerFoldersDialog..::.RtlTranslateAlignment Method
ServerFoldersDialog Class See Also

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ServerFoldersDialog Class
ServerFoldersDialog Members
SAS.Tasks.Toolkit.Controls Namespace


Scale Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ServerFoldersDialog..::.Scale Method
ServerFoldersDialog Class See Also

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

ServerFoldersDialog Class
ServerFoldersDialog Members
SAS.Tasks.Toolkit.Controls Namespace


Select Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ServerFoldersDialog..::.Select Method
ServerFoldersDialog Class See Also

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next/previous control. (Inherited from Form.)

See Also

ServerFoldersDialog Class
ServerFoldersDialog Members
SAS.Tasks.Toolkit.Controls Namespace


SetBounds Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ServerFoldersDialog..::.SetBounds Method
ServerFoldersDialog Class See Also

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ServerFoldersDialog Class
ServerFoldersDialog Members
SAS.Tasks.Toolkit.Controls Namespace


Show Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ServerFoldersDialog..::.Show Method
ServerFoldersDialog Class See Also

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

ServerFoldersDialog Class
ServerFoldersDialog Members
SAS.Tasks.Toolkit.Controls Namespace


ShowDialog Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ServerFoldersDialog..::.ShowDialog Method
ServerFoldersDialog Class See Also

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner. (Inherited from Form.)

See Also

ServerFoldersDialog Class
ServerFoldersDialog Members
SAS.Tasks.Toolkit.Controls Namespace


UpdateBounds Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ServerFoldersDialog..::.UpdateBounds Method
ServerFoldersDialog Class See Also

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ServerFoldersDialog Class
ServerFoldersDialog Members
SAS.Tasks.Toolkit.Controls Namespace


Validate Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ServerFoldersDialog..::.Validate Method
ServerFoldersDialog Class See Also

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ServerFoldersDialog Class
ServerFoldersDialog Members
SAS.Tasks.Toolkit.Controls Namespace


ValidateChildren Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ServerFoldersDialog..::.ValidateChildren Method
ServerFoldersDialog Class See Also

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

ServerFoldersDialog Class
ServerFoldersDialog Members
SAS.Tasks.Toolkit.Controls Namespace


ServerFoldersDialog Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ServerFoldersDialog Properties
ServerFoldersDialog Class See Also

The ServerFoldersDialog type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
SelectedFolder | The name of the selected folder on the server file system.
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

See Also

ServerFoldersDialog Class
SAS.Tasks.Toolkit.Controls Namespace


SelectedFolder Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ServerFoldersDialog..::.SelectedFolder Property
ServerFoldersDialog Class See Also

The name of the selected folder on the server file system.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SelectedFolder As String
C#
public string SelectedFolder { get; }

See Also

ServerFoldersDialog Class
SAS.Tasks.Toolkit.Controls Namespace


ServerFoldersDialog Events

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ServerFoldersDialog Events
ServerFoldersDialog Class See Also

The ServerFoldersDialog type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ServerFoldersDialog Class
SAS.Tasks.Toolkit.Controls Namespace


TaskForm Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskForm Class
Members See Also

A base class for task dialogs/forms.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Class TaskForm _
    Inherits Form
C#
public class TaskForm : Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
SAS.Tasks.Toolkit.Controls..::.TaskForm

See Also

TaskForm Members
SAS.Tasks.Toolkit.Controls Namespace


TaskForm Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskForm Members
TaskForm Class Constructors Methods Properties Events Explicit Interface Implementations See Also

The TaskForm type exposes the following members.

Constructors

Name | Description
TaskForm | Default constructor

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Overloaded.
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Consumer | The handle to the consumer application
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

TaskForm Class
SAS.Tasks.Toolkit.Controls Namespace


TaskForm Constructor

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskForm Constructor
TaskForm Class See Also

Default constructor

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public TaskForm()

See Also

TaskForm Class
SAS.Tasks.Toolkit.Controls Namespace


TaskForm Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskForm Methods
TaskForm Class See Also

The TaskForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Overloaded.
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

TaskForm Class
SAS.Tasks.Toolkit.Controls Namespace


AccessibilityNotifyClients Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskForm..::.AccessibilityNotifyClients Method
TaskForm Class See Also

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

TaskForm Class
TaskForm Members
SAS.Tasks.Toolkit.Controls Namespace


BeginInvoke Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskForm..::.BeginInvoke Method
TaskForm Class See Also

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

TaskForm Class
TaskForm Members
SAS.Tasks.Toolkit.Controls Namespace


Dispose Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskForm..::.Dispose Method
TaskForm Class See Also

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Disposes of the resources (other than memory) used by the Form. (Inherited from Form.)

See Also

TaskForm Class
TaskForm Members
SAS.Tasks.Toolkit.Controls Namespace


GetChildAtPoint Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskForm..::.GetChildAtPoint Method
TaskForm Class See Also

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

TaskForm Class
TaskForm Members
SAS.Tasks.Toolkit.Controls Namespace


Invalidate Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskForm..::.Invalidate Method
TaskForm Class See Also

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

TaskForm Class
TaskForm Members
SAS.Tasks.Toolkit.Controls Namespace


Invoke Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskForm..::.Invoke Method
TaskForm Class See Also

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

TaskForm Class
TaskForm Members
SAS.Tasks.Toolkit.Controls Namespace


MemberwiseClone Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskForm..::.MemberwiseClone Method
TaskForm Class See Also

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

TaskForm Class
TaskForm Members
SAS.Tasks.Toolkit.Controls Namespace


OnFormClosing Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskForm..::.OnFormClosing Method
TaskForm Class See Also

Overload List

Name | Description
OnFormClosing(FormClosingEventArgs) | Raises the FormClosing event. (Inherited from Form.)
OnFormClosing(Object, FormClosingEventArgs) | Handler for the FormClosing event, which can be canceled if the user selects cancel when prompted to Replace Results

See Also

TaskForm Class
TaskForm Members
SAS.Tasks.Toolkit.Controls Namespace


OnFormClosing Method (Object, FormClosingEventArgs)

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskForm..::.OnFormClosing Method (Object, FormClosingEventArgs)
TaskForm Class See Also

Handler for the FormClosing event, which can be canceled if the user selects cancel when prompted to Replace Results

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnFormClosing ( _
    sender As Object, _
    e As FormClosingEventArgs _
)
C#
protected virtual void OnFormClosing(
    Object sender,
    FormClosingEventArgs e
)

Parameters

sender
Type: System..::.Object
e
Type: System.Windows.Forms..::.FormClosingEventArgs

See Also

TaskForm Class
OnFormClosing Overload
SAS.Tasks.Toolkit.Controls Namespace


PerformLayout Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskForm..::.PerformLayout Method
TaskForm Class See Also

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

TaskForm Class
TaskForm Members
SAS.Tasks.Toolkit.Controls Namespace


ResumeLayout Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskForm..::.ResumeLayout Method
TaskForm Class See Also

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

TaskForm Class
TaskForm Members
SAS.Tasks.Toolkit.Controls Namespace


RtlTranslateAlignment Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskForm..::.RtlTranslateAlignment Method
TaskForm Class See Also

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

TaskForm Class
TaskForm Members
SAS.Tasks.Toolkit.Controls Namespace


Scale Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskForm..::.Scale Method
TaskForm Class See Also

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

TaskForm Class
TaskForm Members
SAS.Tasks.Toolkit.Controls Namespace


Select Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskForm..::.Select Method
TaskForm Class See Also

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next/previous control. (Inherited from Form.)

See Also

TaskForm Class
TaskForm Members
SAS.Tasks.Toolkit.Controls Namespace


SetBounds Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskForm..::.SetBounds Method
TaskForm Class See Also

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

TaskForm Class
TaskForm Members
SAS.Tasks.Toolkit.Controls Namespace


Show Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskForm..::.Show Method
TaskForm Class See Also

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

TaskForm Class
TaskForm Members
SAS.Tasks.Toolkit.Controls Namespace


ShowDialog Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskForm..::.ShowDialog Method
TaskForm Class See Also

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner. (Inherited from Form.)

See Also

TaskForm Class
TaskForm Members
SAS.Tasks.Toolkit.Controls Namespace


UpdateBounds Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskForm..::.UpdateBounds Method
TaskForm Class See Also

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

TaskForm Class
TaskForm Members
SAS.Tasks.Toolkit.Controls Namespace


Validate Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskForm..::.Validate Method
TaskForm Class See Also

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

TaskForm Class
TaskForm Members
SAS.Tasks.Toolkit.Controls Namespace


ValidateChildren Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskForm..::.ValidateChildren Method
TaskForm Class See Also

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

TaskForm Class
TaskForm Members
SAS.Tasks.Toolkit.Controls Namespace


TaskForm Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskForm Properties
TaskForm Class See Also

The TaskForm type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Consumer | The handle to the consumer application
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

See Also

TaskForm Class
SAS.Tasks.Toolkit.Controls Namespace


Consumer Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskForm..::.Consumer Property
TaskForm Class See Also

The handle to the consumer application

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property Consumer As ISASTaskConsumer3
C#
public ISASTaskConsumer3 Consumer { get; set; }

See Also

TaskForm Class
SAS.Tasks.Toolkit.Controls Namespace


TaskForm Events

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskForm Events
TaskForm Class See Also

The TaskForm type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

TaskForm Class
SAS.Tasks.Toolkit.Controls Namespace


TaskPropertiesPanelControl Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskPropertiesPanelControl Class
Members See Also

A panel to show/control the current properties of the task. The properties include information about the environment in which this task is run, including ODS styles, run time, last modified, etc.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TaskPropertiesPanelControl _
    Inherits UserControl
C#
public sealed class TaskPropertiesPanelControl : UserControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
SAS.Tasks.Toolkit.Controls..::.TaskPropertiesPanelControl

See Also

TaskPropertiesPanelControl Members
SAS.Tasks.Toolkit.Controls Namespace


TaskPropertiesPanelControl Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskPropertiesPanelControl Members
TaskPropertiesPanelControl Class Constructors Methods Properties Events Explicit Interface Implementations See Also

The TaskPropertiesPanelControl type exposes the following members.

Constructors

Name | Description
TaskPropertiesPanelControl | Default constructor

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

TaskPropertiesPanelControl Class
SAS.Tasks.Toolkit.Controls Namespace


TaskPropertiesPanelControl Constructor

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskPropertiesPanelControl Constructor
TaskPropertiesPanelControl Class See Also

Default constructor

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public TaskPropertiesPanelControl()

See Also

TaskPropertiesPanelControl Class
SAS.Tasks.Toolkit.Controls Namespace


TaskPropertiesPanelControl Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskPropertiesPanelControl Methods
TaskPropertiesPanelControl Class See Also

The TaskPropertiesPanelControl type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

TaskPropertiesPanelControl Class
SAS.Tasks.Toolkit.Controls Namespace


AccessibilityNotifyClients Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskPropertiesPanelControl..::.AccessibilityNotifyClients Method
TaskPropertiesPanelControl Class See Also

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

TaskPropertiesPanelControl Class
TaskPropertiesPanelControl Members
SAS.Tasks.Toolkit.Controls Namespace


BeginInvoke Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskPropertiesPanelControl..::.BeginInvoke Method
TaskPropertiesPanelControl Class See Also

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

TaskPropertiesPanelControl Class
TaskPropertiesPanelControl Members
SAS.Tasks.Toolkit.Controls Namespace


Dispose Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskPropertiesPanelControl..::.Dispose Method
TaskPropertiesPanelControl Class See Also

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | (Inherited from ContainerControl.)

See Also

TaskPropertiesPanelControl Class
TaskPropertiesPanelControl Members
SAS.Tasks.Toolkit.Controls Namespace


GetChildAtPoint Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskPropertiesPanelControl..::.GetChildAtPoint Method
TaskPropertiesPanelControl Class See Also

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

TaskPropertiesPanelControl Class
TaskPropertiesPanelControl Members
SAS.Tasks.Toolkit.Controls Namespace


Invalidate Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskPropertiesPanelControl..::.Invalidate Method
TaskPropertiesPanelControl Class See Also

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

TaskPropertiesPanelControl Class
TaskPropertiesPanelControl Members
SAS.Tasks.Toolkit.Controls Namespace


Invoke Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskPropertiesPanelControl..::.Invoke Method
TaskPropertiesPanelControl Class See Also

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

TaskPropertiesPanelControl Class
TaskPropertiesPanelControl Members
SAS.Tasks.Toolkit.Controls Namespace


MemberwiseClone Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskPropertiesPanelControl..::.MemberwiseClone Method
TaskPropertiesPanelControl Class See Also

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

TaskPropertiesPanelControl Class
TaskPropertiesPanelControl Members
SAS.Tasks.Toolkit.Controls Namespace


PerformLayout Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskPropertiesPanelControl..::.PerformLayout Method
TaskPropertiesPanelControl Class See Also

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

TaskPropertiesPanelControl Class
TaskPropertiesPanelControl Members
SAS.Tasks.Toolkit.Controls Namespace


ResumeLayout Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskPropertiesPanelControl..::.ResumeLayout Method
TaskPropertiesPanelControl Class See Also

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

TaskPropertiesPanelControl Class
TaskPropertiesPanelControl Members
SAS.Tasks.Toolkit.Controls Namespace


RtlTranslateAlignment Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskPropertiesPanelControl..::.RtlTranslateAlignment Method
TaskPropertiesPanelControl Class See Also

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

TaskPropertiesPanelControl Class
TaskPropertiesPanelControl Members
SAS.Tasks.Toolkit.Controls Namespace


Scale Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskPropertiesPanelControl..::.Scale Method
TaskPropertiesPanelControl Class See Also

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

TaskPropertiesPanelControl Class
TaskPropertiesPanelControl Members
SAS.Tasks.Toolkit.Controls Namespace


Select Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskPropertiesPanelControl..::.Select Method
TaskPropertiesPanelControl Class See Also

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

TaskPropertiesPanelControl Class
TaskPropertiesPanelControl Members
SAS.Tasks.Toolkit.Controls Namespace


SetBounds Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskPropertiesPanelControl..::.SetBounds Method
TaskPropertiesPanelControl Class See Also

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

TaskPropertiesPanelControl Class
TaskPropertiesPanelControl Members
SAS.Tasks.Toolkit.Controls Namespace


UpdateBounds Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskPropertiesPanelControl..::.UpdateBounds Method
TaskPropertiesPanelControl Class See Also

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

TaskPropertiesPanelControl Class
TaskPropertiesPanelControl Members
SAS.Tasks.Toolkit.Controls Namespace


Validate Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskPropertiesPanelControl..::.Validate Method
TaskPropertiesPanelControl Class See Also

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

TaskPropertiesPanelControl Class
TaskPropertiesPanelControl Members
SAS.Tasks.Toolkit.Controls Namespace


ValidateChildren Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskPropertiesPanelControl..::.ValidateChildren Method
TaskPropertiesPanelControl Class See Also

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

TaskPropertiesPanelControl Class
TaskPropertiesPanelControl Members
SAS.Tasks.Toolkit.Controls Namespace


TaskPropertiesPanelControl Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskPropertiesPanelControl Properties
TaskPropertiesPanelControl Class See Also

The TaskPropertiesPanelControl type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

TaskPropertiesPanelControl Class
SAS.Tasks.Toolkit.Controls Namespace


TaskPropertiesPanelControl Events

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskPropertiesPanelControl Events
TaskPropertiesPanelControl Class See Also

The TaskPropertiesPanelControl type exposes the following members.

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

TaskPropertiesPanelControl Class
SAS.Tasks.Toolkit.Controls Namespace


TaskSelectedDataControl Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskSelectedDataControl Class
Members See Also

Displays current selected data and filter for the task, and allows the user to change these with an Edit button. This control is meant for use on tasks with a dialog or panel form factor.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Class TaskSelectedDataControl _
    Inherits BaseSelectedDataControl
C#
public class TaskSelectedDataControl : BaseSelectedDataControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
SAS.Tasks.Toolkit.Controls..::.BaseSelectedDataControl
SAS.Tasks.Toolkit.Controls..::.TaskSelectedDataControl

See Also

TaskSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


TaskSelectedDataControl Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskSelectedDataControl Members
TaskSelectedDataControl Class Constructors Methods Properties Events Explicit Interface Implementations See Also

The TaskSelectedDataControl type exposes the following members.

Constructors

Name | Description
TaskSelectedDataControl | Default constructor

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FireEnterControl | (Inherited from BaseSelectedDataControl.)
FireKeyUpControl | (Inherited from BaseSelectedDataControl.)
FireLeaveControl | (Inherited from BaseSelectedDataControl.)
FireMouseEnteredControl | This event is not supported for outside consumers. (Inherited from BaseSelectedDataControl.)
FireMouseLeftControl | (Inherited from BaseSelectedDataControl.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
HideEditButtonPropChanged | Updates the state of the edit button. (Overrides BaseSelectedDataControl..::.HideEditButtonPropChanged()()().)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Override of OnLoad method to initialize the data and filter labels. (Overrides UserControl..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
ShowDataSelection | Shows the data and filter selection dialog. (Inherited from BaseSelectedDataControl.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDataLabels | Update the data labels displayed in the control. (Overrides BaseSelectedDataControl..::.UpdateDataLabels()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateFilterLabel | Update the filter label displayed in the control. (Overrides BaseSelectedDataControl..::.UpdateFilterLabel()()().)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowEditing | Indicates whether or not the Edit button should be shown. (Inherited from BaseSelectedDataControl.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Consumer | The ISASTaskConsumer3 interface from the main application. (Inherited from BaseSelectedDataControl.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FilterSettings | Represents the current filter settings. (Inherited from BaseSelectedDataControl.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HideEditButton | Hides Edit Button if user doesn't want edit button and filter to show. (Inherited from BaseSelectedDataControl.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
TaskData | The ISASTaskData2 interface for the input data. (Inherited from BaseSelectedDataControl.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseLabelsForVarNames | Indicates whether column names or labels should be shown in the query builder (Inherited from BaseSelectedDataControl.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
DataSelectionChanged | Raised when the data selection or filter changes. Handle this event when you want your task to be able to react when the data source or filter definition is changed by the end user. (Inherited from BaseSelectedDataControl.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
EnterControl | This event is not supported for outside consumers. (Inherited from BaseSelectedDataControl.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
KeyUpControl | This event is not supported for outside consumers. (Inherited from BaseSelectedDataControl.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LeaveControl | This event is not supported for outside consumers. (Inherited from BaseSelectedDataControl.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseEnteredControl | This event is not supported for outside consumers. (Inherited from BaseSelectedDataControl.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseLeftControl | This event is not supported for outside consumers. (Inherited from BaseSelectedDataControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

TaskSelectedDataControl Class
SAS.Tasks.Toolkit.Controls Namespace


TaskSelectedDataControl Constructor

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskSelectedDataControl Constructor
TaskSelectedDataControl Class See Also

Default constructor

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public TaskSelectedDataControl()

See Also

TaskSelectedDataControl Class
SAS.Tasks.Toolkit.Controls Namespace


TaskSelectedDataControl Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskSelectedDataControl Methods
TaskSelectedDataControl Class See Also

The TaskSelectedDataControl type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FireEnterControl | (Inherited from BaseSelectedDataControl.)
FireKeyUpControl | (Inherited from BaseSelectedDataControl.)
FireLeaveControl | (Inherited from BaseSelectedDataControl.)
FireMouseEnteredControl | This event is not supported for outside consumers. (Inherited from BaseSelectedDataControl.)
FireMouseLeftControl | (Inherited from BaseSelectedDataControl.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
HideEditButtonPropChanged | Updates the state of the edit button. (Overrides BaseSelectedDataControl..::.HideEditButtonPropChanged()()().)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Override of OnLoad method to initialize the data and filter labels. (Overrides UserControl..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
ShowDataSelection | Shows the data and filter selection dialog. (Inherited from BaseSelectedDataControl.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDataLabels | Update the data labels displayed in the control. (Overrides BaseSelectedDataControl..::.UpdateDataLabels()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateFilterLabel | Update the filter label displayed in the control. (Overrides BaseSelectedDataControl..::.UpdateFilterLabel()()().)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

TaskSelectedDataControl Class
SAS.Tasks.Toolkit.Controls Namespace


AccessibilityNotifyClients Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskSelectedDataControl..::.AccessibilityNotifyClients Method
TaskSelectedDataControl Class See Also

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

TaskSelectedDataControl Class
TaskSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


BeginInvoke Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskSelectedDataControl..::.BeginInvoke Method
TaskSelectedDataControl Class See Also

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

TaskSelectedDataControl Class
TaskSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


Dispose Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskSelectedDataControl..::.Dispose Method
TaskSelectedDataControl Class See Also

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControl..::.Dispose(Boolean).)

See Also

TaskSelectedDataControl Class
TaskSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


Dispose Method (Boolean)

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskSelectedDataControl..::.Dispose Method (Boolean)
TaskSelectedDataControl Class See Also

Clean up any resources being used.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

TaskSelectedDataControl Class
Dispose Overload
SAS.Tasks.Toolkit.Controls Namespace


GetChildAtPoint Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskSelectedDataControl..::.GetChildAtPoint Method
TaskSelectedDataControl Class See Also

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

TaskSelectedDataControl Class
TaskSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


HideEditButtonPropChanged Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskSelectedDataControl..::.HideEditButtonPropChanged Method
TaskSelectedDataControl Class See Also

Updates the state of the edit button.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub HideEditButtonPropChanged
C#
protected override void HideEditButtonPropChanged()

See Also

TaskSelectedDataControl Class
SAS.Tasks.Toolkit.Controls Namespace


Invalidate Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskSelectedDataControl..::.Invalidate Method
TaskSelectedDataControl Class See Also

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

TaskSelectedDataControl Class
TaskSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


Invoke Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskSelectedDataControl..::.Invoke Method
TaskSelectedDataControl Class See Also

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

TaskSelectedDataControl Class
TaskSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


MemberwiseClone Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskSelectedDataControl..::.MemberwiseClone Method
TaskSelectedDataControl Class See Also

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

TaskSelectedDataControl Class
TaskSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


OnLoad Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskSelectedDataControl..::.OnLoad Method
TaskSelectedDataControl Class See Also

Override of OnLoad method to initialize the data and filter labels.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnLoad ( _
    e As EventArgs _
)
C#
protected override void OnLoad(
    EventArgs e
)

Parameters

e
Type: System..::.EventArgs

See Also

TaskSelectedDataControl Class
SAS.Tasks.Toolkit.Controls Namespace


PerformLayout Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskSelectedDataControl..::.PerformLayout Method
TaskSelectedDataControl Class See Also

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

TaskSelectedDataControl Class
TaskSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


ResumeLayout Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskSelectedDataControl..::.ResumeLayout Method
TaskSelectedDataControl Class See Also

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

TaskSelectedDataControl Class
TaskSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


RtlTranslateAlignment Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskSelectedDataControl..::.RtlTranslateAlignment Method
TaskSelectedDataControl Class See Also

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

TaskSelectedDataControl Class
TaskSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


Scale Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskSelectedDataControl..::.Scale Method
TaskSelectedDataControl Class See Also

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

TaskSelectedDataControl Class
TaskSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


Select Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskSelectedDataControl..::.Select Method
TaskSelectedDataControl Class See Also

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

TaskSelectedDataControl Class
TaskSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


SetBounds Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskSelectedDataControl..::.SetBounds Method
TaskSelectedDataControl Class See Also

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

TaskSelectedDataControl Class
TaskSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


UpdateBounds Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskSelectedDataControl..::.UpdateBounds Method
TaskSelectedDataControl Class See Also

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

TaskSelectedDataControl Class
TaskSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


UpdateDataLabels Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskSelectedDataControl..::.UpdateDataLabels Method
TaskSelectedDataControl Class See Also

Update the data labels displayed in the control.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub UpdateDataLabels
C#
protected override void UpdateDataLabels()

See Also

TaskSelectedDataControl Class
SAS.Tasks.Toolkit.Controls Namespace


UpdateFilterLabel Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskSelectedDataControl..::.UpdateFilterLabel Method
TaskSelectedDataControl Class See Also

Update the filter label displayed in the control.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub UpdateFilterLabel
C#
protected override void UpdateFilterLabel()

See Also

TaskSelectedDataControl Class
SAS.Tasks.Toolkit.Controls Namespace


Validate Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskSelectedDataControl..::.Validate Method
TaskSelectedDataControl Class See Also

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

TaskSelectedDataControl Class
TaskSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


ValidateChildren Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskSelectedDataControl..::.ValidateChildren Method
TaskSelectedDataControl Class See Also

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

TaskSelectedDataControl Class
TaskSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


TaskSelectedDataControl Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskSelectedDataControl Properties
TaskSelectedDataControl Class See Also

The TaskSelectedDataControl type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowEditing | Indicates whether or not the Edit button should be shown. (Inherited from BaseSelectedDataControl.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Consumer | The ISASTaskConsumer3 interface from the main application. (Inherited from BaseSelectedDataControl.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FilterSettings | Represents the current filter settings. (Inherited from BaseSelectedDataControl.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HideEditButton | Hides Edit Button if user doesn't want edit button and filter to show. (Inherited from BaseSelectedDataControl.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
TaskData | The ISASTaskData2 interface for the input data. (Inherited from BaseSelectedDataControl.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseLabelsForVarNames | Indicates whether column names or labels should be shown in the query builder (Inherited from BaseSelectedDataControl.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

TaskSelectedDataControl Class
SAS.Tasks.Toolkit.Controls Namespace


TaskSelectedDataControl Events

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskSelectedDataControl Events
TaskSelectedDataControl Class See Also

The TaskSelectedDataControl type exposes the following members.

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
DataSelectionChanged | Raised when the data selection or filter changes. Handle this event when you want your task to be able to react when the data source or filter definition is changed by the end user. (Inherited from BaseSelectedDataControl.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
EnterControl | This event is not supported for outside consumers. (Inherited from BaseSelectedDataControl.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
KeyUpControl | This event is not supported for outside consumers. (Inherited from BaseSelectedDataControl.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LeaveControl | This event is not supported for outside consumers. (Inherited from BaseSelectedDataControl.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseEnteredControl | This event is not supported for outside consumers. (Inherited from BaseSelectedDataControl.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseLeftControl | This event is not supported for outside consumers. (Inherited from BaseSelectedDataControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

TaskSelectedDataControl Class
SAS.Tasks.Toolkit.Controls Namespace


WizardForm Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardForm Class
Members See Also

A simple wizard container form.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
<CLSCompliantAttribute(False)> _
Public Class WizardForm _
    Inherits Wizard2
C#
[CLSCompliantAttribute(false)]
public class WizardForm : Wizard2

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
Wizard2
SAS.Tasks.Toolkit.Controls..::.WizardForm

See Also

WizardForm Members
SAS.Tasks.Toolkit.Controls Namespace


WizardForm Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardForm Members
WizardForm Class Constructors Methods Properties Events Explicit Interface Implementations See Also

The WizardForm type exposes the following members.

Constructors

Name | Description
WizardForm |

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddControlToButtonPanel | (Inherited from Wizard2.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AddPage | (Inherited from Wizard2.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
DisableButtons | (Inherited from Wizard2.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EnableButtons | (Inherited from Wizard2.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
FocusButton | (Inherited from Wizard2.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPage | Overloaded.
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBack | (Inherited from Wizard2.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | (Inherited from Wizard2.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCreateTemplate | (Inherited from Wizard2.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFinish | Handling for OnFinish to call back to the application and verify that the task should close at this time, replacing existing results in the project. The end user can cancel this operation. (Overrides Wizard2OnFinish()()().)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelp | (Inherited from Wizard2.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | (Inherited from Wizard2.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | (Inherited from Wizard2.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNext | (Inherited from Wizard2.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPageStateChanged | (Inherited from Wizard2.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnSave | (Inherited from Wizard2.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
ShowWizard | (Inherited from Wizard2.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
ActivePage | (Inherited from Wizard2.)
ActivePageIndex | (Inherited from Wizard2.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoMinSize | (Inherited from Wizard2.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Wizard2.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BannerPictureBox | (Inherited from Wizard2.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
ButtonBack | (Inherited from Wizard2.)
ButtonCancel | (Inherited from Wizard2.)
ButtonFinish | (Inherited from Wizard2.)
ButtonHelp | (Inherited from Wizard2.)
ButtonNext | (Inherited from Wizard2.)
ButtonSave | (Inherited from Wizard2.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Consumer | The handle to the consumer application
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HelpText | (Inherited from Wizard2.)
HelpTextBox | (Inherited from Wizard2.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeepFinishButtonDisabled | (Inherited from Wizard2.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
PageCount | (Inherited from Wizard2.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowContextHelp | (Inherited from Wizard2.)
ShowDropBackButton | (Inherited from Wizard2.)
ShowDropFinishButton | (Inherited from Wizard2.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseSaveButton | (Inherited from Wizard2.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CreateTemplate | (Inherited from Wizard2.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

WizardForm Class
SAS.Tasks.Toolkit.Controls Namespace


WizardForm Constructor

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardForm Constructor
WizardForm Class See Also

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public WizardForm()

See Also

WizardForm Class
SAS.Tasks.Toolkit.Controls Namespace


WizardForm Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardForm Methods
WizardForm Class See Also

The WizardForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddControlToButtonPanel | (Inherited from Wizard2.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AddPage | (Inherited from Wizard2.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
DisableButtons | (Inherited from Wizard2.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EnableButtons | (Inherited from Wizard2.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
FocusButton | (Inherited from Wizard2.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPage | Overloaded.
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBack | (Inherited from Wizard2.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | (Inherited from Wizard2.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCreateTemplate | (Inherited from Wizard2.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFinish | Handling for OnFinish to call back to the application and verify that the task should close at this time, replacing existing results in the project. The end user can cancel this operation. (Overrides Wizard2OnFinish()()().)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelp | (Inherited from Wizard2.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | (Inherited from Wizard2.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | (Inherited from Wizard2.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNext | (Inherited from Wizard2.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPageStateChanged | (Inherited from Wizard2.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnSave | (Inherited from Wizard2.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
ShowWizard | (Inherited from Wizard2.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

WizardForm Class
SAS.Tasks.Toolkit.Controls Namespace


AccessibilityNotifyClients Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardForm..::.AccessibilityNotifyClients Method
WizardForm Class See Also

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

WizardForm Class
WizardForm Members
SAS.Tasks.Toolkit.Controls Namespace


BeginInvoke Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardForm..::.BeginInvoke Method
WizardForm Class See Also

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

WizardForm Class
WizardForm Members
SAS.Tasks.Toolkit.Controls Namespace


Dispose Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardForm..::.Dispose Method
WizardForm Class See Also

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | (Inherited from Wizard2.)

See Also

WizardForm Class
WizardForm Members
SAS.Tasks.Toolkit.Controls Namespace


GetChildAtPoint Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardForm..::.GetChildAtPoint Method
WizardForm Class See Also

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

WizardForm Class
WizardForm Members
SAS.Tasks.Toolkit.Controls Namespace


GetPage Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardForm..::.GetPage Method
WizardForm Class See Also

Overload List

Name | Description
GetPage(String) | (Inherited from Wizard2.)
GetPage(Int32) | (Inherited from Wizard2.)

See Also

WizardForm Class
WizardForm Members
SAS.Tasks.Toolkit.Controls Namespace


Invalidate Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardForm..::.Invalidate Method
WizardForm Class See Also

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

WizardForm Class
WizardForm Members
SAS.Tasks.Toolkit.Controls Namespace


Invoke Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardForm..::.Invoke Method
WizardForm Class See Also

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

WizardForm Class
WizardForm Members
SAS.Tasks.Toolkit.Controls Namespace


MemberwiseClone Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardForm..::.MemberwiseClone Method
WizardForm Class See Also

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

WizardForm Class
WizardForm Members
SAS.Tasks.Toolkit.Controls Namespace


OnFinish Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardForm..::.OnFinish Method
WizardForm Class See Also

Handling for OnFinish to call back to the application and verify that the task should close at this time, replacing existing results in the project. The end user can cancel this operation.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnFinish
C#
protected override void OnFinish()

See Also

WizardForm Class
SAS.Tasks.Toolkit.Controls Namespace


PerformLayout Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardForm..::.PerformLayout Method
WizardForm Class See Also

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

WizardForm Class
WizardForm Members
SAS.Tasks.Toolkit.Controls Namespace


ResumeLayout Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardForm..::.ResumeLayout Method
WizardForm Class See Also

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

WizardForm Class
WizardForm Members
SAS.Tasks.Toolkit.Controls Namespace


RtlTranslateAlignment Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardForm..::.RtlTranslateAlignment Method
WizardForm Class See Also

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

WizardForm Class
WizardForm Members
SAS.Tasks.Toolkit.Controls Namespace


Scale Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardForm..::.Scale Method
WizardForm Class See Also

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

WizardForm Class
WizardForm Members
SAS.Tasks.Toolkit.Controls Namespace


Select Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardForm..::.Select Method
WizardForm Class See Also

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next/previous control. (Inherited from Form.)

See Also

WizardForm Class
WizardForm Members
SAS.Tasks.Toolkit.Controls Namespace


SetBounds Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardForm..::.SetBounds Method
WizardForm Class See Also

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

WizardForm Class
WizardForm Members
SAS.Tasks.Toolkit.Controls Namespace


Show Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardForm..::.Show Method
WizardForm Class See Also

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

WizardForm Class
WizardForm Members
SAS.Tasks.Toolkit.Controls Namespace


ShowDialog Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardForm..::.ShowDialog Method
WizardForm Class See Also

Overload List

Name | Description
ShowDialog()()() | Obsolete. (Inherited from Wizard2.)
ShowDialog(IWin32Window) | (Inherited from Wizard2.)

See Also

WizardForm Class
WizardForm Members
SAS.Tasks.Toolkit.Controls Namespace


UpdateBounds Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardForm..::.UpdateBounds Method
WizardForm Class See Also

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

WizardForm Class
WizardForm Members
SAS.Tasks.Toolkit.Controls Namespace


Validate Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardForm..::.Validate Method
WizardForm Class See Also

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

WizardForm Class
WizardForm Members
SAS.Tasks.Toolkit.Controls Namespace


ValidateChildren Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardForm..::.ValidateChildren Method
WizardForm Class See Also

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

WizardForm Class
WizardForm Members
SAS.Tasks.Toolkit.Controls Namespace


WizardForm Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardForm Properties
WizardForm Class See Also

The WizardForm type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
ActivePage | (Inherited from Wizard2.)
ActivePageIndex | (Inherited from Wizard2.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoMinSize | (Inherited from Wizard2.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Wizard2.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BannerPictureBox | (Inherited from Wizard2.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
ButtonBack | (Inherited from Wizard2.)
ButtonCancel | (Inherited from Wizard2.)
ButtonFinish | (Inherited from Wizard2.)
ButtonHelp | (Inherited from Wizard2.)
ButtonNext | (Inherited from Wizard2.)
ButtonSave | (Inherited from Wizard2.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Consumer | The handle to the consumer application
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HelpText | (Inherited from Wizard2.)
HelpTextBox | (Inherited from Wizard2.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeepFinishButtonDisabled | (Inherited from Wizard2.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
PageCount | (Inherited from Wizard2.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowContextHelp | (Inherited from Wizard2.)
ShowDropBackButton | (Inherited from Wizard2.)
ShowDropFinishButton | (Inherited from Wizard2.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseSaveButton | (Inherited from Wizard2.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

See Also

WizardForm Class
SAS.Tasks.Toolkit.Controls Namespace


Consumer Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardForm..::.Consumer Property
WizardForm Class See Also

The handle to the consumer application

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property Consumer As ISASTaskConsumer3
C#
public ISASTaskConsumer3 Consumer { get; set; }

See Also

WizardForm Class
SAS.Tasks.Toolkit.Controls Namespace


WizardForm Events

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardForm Events
WizardForm Class See Also

The WizardForm type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CreateTemplate | (Inherited from Wizard2.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

WizardForm Class
SAS.Tasks.Toolkit.Controls Namespace


WizardSelectedDataControl Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardSelectedDataControl Class
Members See Also

Displays current selected data and filter for the task, and allows the user to change these with an Edit button. This control is meant for use on tasks with a wizard form factor.

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class WizardSelectedDataControl _
    Inherits BaseSelectedDataControl
C#
public sealed class WizardSelectedDataControl : BaseSelectedDataControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
SAS.Tasks.Toolkit.Controls..::.BaseSelectedDataControl
SAS.Tasks.Toolkit.Controls..::.WizardSelectedDataControl

See Also

WizardSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


WizardSelectedDataControl Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardSelectedDataControl Members
WizardSelectedDataControl Class Constructors Methods Properties Events Explicit Interface Implementations See Also

The WizardSelectedDataControl type exposes the following members.

Constructors

Name | Description
WizardSelectedDataControl | Default constructor

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FireEnterControl | (Inherited from BaseSelectedDataControl.)
FireKeyUpControl | (Inherited from BaseSelectedDataControl.)
FireLeaveControl | (Inherited from BaseSelectedDataControl.)
FireMouseEnteredControl | This event is not supported for outside consumers. (Inherited from BaseSelectedDataControl.)
FireMouseLeftControl | (Inherited from BaseSelectedDataControl.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
HideEditButtonPropChanged | Handle this in a derived class by updating the label that shows the current filter. (Inherited from BaseSelectedDataControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
ShowDataSelection | Shows the data and filter selection dialog. (Inherited from BaseSelectedDataControl.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDataLabels | Handle this in a derived class by updating the data label with the current data settings. (Inherited from BaseSelectedDataControl.)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateFilterLabel | Handle this in a derived class by updating the label that shows the current filter. (Inherited from BaseSelectedDataControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowEditing | Indicates whether or not the Edit button should be shown. (Inherited from BaseSelectedDataControl.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Consumer | The ISASTaskConsumer3 interface from the main application. (Inherited from BaseSelectedDataControl.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FilterSettings | Represents the current filter settings. (Inherited from BaseSelectedDataControl.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HideEditButton | Hides Edit Button if user doesn't want edit button and filter to show. (Inherited from BaseSelectedDataControl.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
TaskData | The ISASTaskData2 interface for the input data. (Inherited from BaseSelectedDataControl.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseLabelsForVarNames | Indicates whether column names or labels should be shown in the query builder (Inherited from BaseSelectedDataControl.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
DataSelectionChanged | Raised when the data selection or filter changes. Handle this event when you want your task to be able to react when the data source or filter definition is changed by the end user. (Inherited from BaseSelectedDataControl.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
EnterControl | This event is not supported for outside consumers. (Inherited from BaseSelectedDataControl.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
KeyUpControl | This event is not supported for outside consumers. (Inherited from BaseSelectedDataControl.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LeaveControl | This event is not supported for outside consumers. (Inherited from BaseSelectedDataControl.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseEnteredControl | This event is not supported for outside consumers. (Inherited from BaseSelectedDataControl.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseLeftControl | This event is not supported for outside consumers. (Inherited from BaseSelectedDataControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

WizardSelectedDataControl Class
SAS.Tasks.Toolkit.Controls Namespace


WizardSelectedDataControl Constructor

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardSelectedDataControl Constructor
WizardSelectedDataControl Class See Also

Default constructor

Namespace: SAS.Tasks.Toolkit.Controls
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public WizardSelectedDataControl()

See Also

WizardSelectedDataControl Class
SAS.Tasks.Toolkit.Controls Namespace


WizardSelectedDataControl Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardSelectedDataControl Methods
WizardSelectedDataControl Class See Also

The WizardSelectedDataControl type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FireEnterControl | (Inherited from BaseSelectedDataControl.)
FireKeyUpControl | (Inherited from BaseSelectedDataControl.)
FireLeaveControl | (Inherited from BaseSelectedDataControl.)
FireMouseEnteredControl | This event is not supported for outside consumers. (Inherited from BaseSelectedDataControl.)
FireMouseLeftControl | (Inherited from BaseSelectedDataControl.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
HideEditButtonPropChanged | Handle this in a derived class by updating the label that shows the current filter. (Inherited from BaseSelectedDataControl.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
ShowDataSelection | Shows the data and filter selection dialog. (Inherited from BaseSelectedDataControl.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDataLabels | Handle this in a derived class by updating the data label with the current data settings. (Inherited from BaseSelectedDataControl.)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateFilterLabel | Handle this in a derived class by updating the label that shows the current filter. (Inherited from BaseSelectedDataControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Explicit Interface Implementations

Name | Description
IContainerControl..::.ActivateControl | (Inherited from ContainerControl.)
IDropTarget..::.OnDragDrop | (Inherited from Control.)
IDropTarget..::.OnDragEnter | (Inherited from Control.)
IDropTarget..::.OnDragLeave | (Inherited from Control.)
IDropTarget..::.OnDragOver | (Inherited from Control.)

See Also

WizardSelectedDataControl Class
SAS.Tasks.Toolkit.Controls Namespace


AccessibilityNotifyClients Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardSelectedDataControl..::.AccessibilityNotifyClients Method
WizardSelectedDataControl Class See Also

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

WizardSelectedDataControl Class
WizardSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


BeginInvoke Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardSelectedDataControl..::.BeginInvoke Method
WizardSelectedDataControl Class See Also

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

WizardSelectedDataControl Class
WizardSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


Dispose Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardSelectedDataControl..::.Dispose Method
WizardSelectedDataControl Class See Also

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | (Inherited from ContainerControl.)

See Also

WizardSelectedDataControl Class
WizardSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


GetChildAtPoint Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardSelectedDataControl..::.GetChildAtPoint Method
WizardSelectedDataControl Class See Also

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

WizardSelectedDataControl Class
WizardSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


Invalidate Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardSelectedDataControl..::.Invalidate Method
WizardSelectedDataControl Class See Also

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

WizardSelectedDataControl Class
WizardSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


Invoke Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardSelectedDataControl..::.Invoke Method
WizardSelectedDataControl Class See Also

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

WizardSelectedDataControl Class
WizardSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


MemberwiseClone Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardSelectedDataControl..::.MemberwiseClone Method
WizardSelectedDataControl Class See Also

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

WizardSelectedDataControl Class
WizardSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


PerformLayout Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardSelectedDataControl..::.PerformLayout Method
WizardSelectedDataControl Class See Also

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

WizardSelectedDataControl Class
WizardSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


ResumeLayout Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardSelectedDataControl..::.ResumeLayout Method
WizardSelectedDataControl Class See Also

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

WizardSelectedDataControl Class
WizardSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


RtlTranslateAlignment Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardSelectedDataControl..::.RtlTranslateAlignment Method
WizardSelectedDataControl Class See Also

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

WizardSelectedDataControl Class
WizardSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


Scale Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardSelectedDataControl..::.Scale Method
WizardSelectedDataControl Class See Also

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

WizardSelectedDataControl Class
WizardSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


Select Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardSelectedDataControl..::.Select Method
WizardSelectedDataControl Class See Also

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

WizardSelectedDataControl Class
WizardSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


SetBounds Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardSelectedDataControl..::.SetBounds Method
WizardSelectedDataControl Class See Also

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

WizardSelectedDataControl Class
WizardSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


UpdateBounds Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardSelectedDataControl..::.UpdateBounds Method
WizardSelectedDataControl Class See Also

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

WizardSelectedDataControl Class
WizardSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


Validate Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardSelectedDataControl..::.Validate Method
WizardSelectedDataControl Class See Also

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

WizardSelectedDataControl Class
WizardSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


ValidateChildren Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardSelectedDataControl..::.ValidateChildren Method
WizardSelectedDataControl Class See Also

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

WizardSelectedDataControl Class
WizardSelectedDataControl Members
SAS.Tasks.Toolkit.Controls Namespace


WizardSelectedDataControl Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardSelectedDataControl Properties
WizardSelectedDataControl Class See Also

The WizardSelectedDataControl type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowEditing | Indicates whether or not the Edit button should be shown. (Inherited from BaseSelectedDataControl.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Consumer | The ISASTaskConsumer3 interface from the main application. (Inherited from BaseSelectedDataControl.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FilterSettings | Represents the current filter settings. (Inherited from BaseSelectedDataControl.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HideEditButton | Hides Edit Button if user doesn't want edit button and filter to show. (Inherited from BaseSelectedDataControl.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
TaskData | The ISASTaskData2 interface for the input data. (Inherited from BaseSelectedDataControl.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseLabelsForVarNames | Indicates whether column names or labels should be shown in the query builder (Inherited from BaseSelectedDataControl.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

WizardSelectedDataControl Class
SAS.Tasks.Toolkit.Controls Namespace


WizardSelectedDataControl Events

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
WizardSelectedDataControl Events
WizardSelectedDataControl Class See Also

The WizardSelectedDataControl type exposes the following members.

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
DataSelectionChanged | Raised when the data selection or filter changes. Handle this event when you want your task to be able to react when the data source or filter definition is changed by the end user. (Inherited from BaseSelectedDataControl.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
EnterControl | This event is not supported for outside consumers. (Inherited from BaseSelectedDataControl.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
KeyUpControl | This event is not supported for outside consumers. (Inherited from BaseSelectedDataControl.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LeaveControl | This event is not supported for outside consumers. (Inherited from BaseSelectedDataControl.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseEnteredControl | This event is not supported for outside consumers. (Inherited from BaseSelectedDataControl.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseLeftControl | This event is not supported for outside consumers. (Inherited from BaseSelectedDataControl.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

WizardSelectedDataControl Class
SAS.Tasks.Toolkit.Controls Namespace


SAS.Tasks.Toolkit.Data Namespace

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SAS.Tasks.Toolkit.Data Namespace

Classes

Class | Description
SasCatalog | A SAS catalog reference. SAS catalogs reside in SAS libraries, and contain entries of various types. They work similar to folders in a file system.
SasCatalogEntry | A SAS catalog entry. This is a logical file that resides inside a SAS catalog. The full reference for an entry is: LIBREF.CATALOG.ENTRY.TYPE.
SasColumn | A SAS column, or variable, within a SAS data source
SasData | A SAS data reference, pointing to either a SAS table or view -- any data member within a SAS library
SasDataException | Thrown when there is an error accessing the SasData object
SasLibrary | A SAS library that contains data members

Enumerations

Enumeration | Description
SasColumn..::.eCategory | SAS data categories are inferred from the formats applied: Date, Currency, DateTime, and Georef. Or just plain Character or Numeric.
SasColumn..::.eType | SAS has two fundamental data types: Character and Numeric


SasCatalog Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasCatalog Class
Members See Also

A SAS catalog reference. SAS catalogs reside in SAS libraries, and contain entries of various types. They work similar to folders in a file system.

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Class SasCatalog
C#
public class SasCatalog

Inheritance Hierarchy

System..::.Object
SAS.Tasks.Toolkit.Data..::.SasCatalog

See Also

SasCatalog Members
SAS.Tasks.Toolkit.Data Namespace


SasCatalog Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasCatalog Members
SasCatalog Class Constructors Methods Properties See Also

The SasCatalog type exposes the following members.

Constructors

Name | Description
SasCatalog | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetSasCatalogEntries | Returns a list of SAS catalog entries that reside in this catalog.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Libref | The library reference name (libref) for this catalog
Member | The member name for this catalog.
Name | Gets the name of the catalog. You can set/get this in the Member property as well.
Server | The SAS server associated with this catalog.

See Also

SasCatalog Class
SAS.Tasks.Toolkit.Data Namespace


SasCatalog Constructor

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasCatalog Constructor
SasCatalog Class See Also

Overload List

Name | Description
SasCatalog()()() | Default constructor for a SasCatalog.
SasCatalog(String, String, String) | Construct from a known server, libref, and member.

See Also

SasCatalog Class
SasCatalog Members
SAS.Tasks.Toolkit.Data Namespace


SasCatalog Constructor

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasCatalog Constructor
SasCatalog Class See Also

Default constructor for a SasCatalog.

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SasCatalog()

See Also

SasCatalog Class
SasCatalog Overload
SAS.Tasks.Toolkit.Data Namespace


SasCatalog Constructor (String, String, String)

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasCatalog Constructor (String, String, String)
SasCatalog Class See Also

Construct from a known server, libref, and member.

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    server As String, _
    libref As String, _
    member As String _
)
C#
public SasCatalog(
    string server,
    string libref,
    string member
)

Parameters

server
Type: System..::.String
The name of the SAS server.
libref
Type: System..::.String
The libref of the SAS library.
member
Type: System..::.String
The member name for the catalog.

See Also

SasCatalog Class
SasCatalog Overload
SAS.Tasks.Toolkit.Data Namespace


SasCatalog Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasCatalog Methods
SasCatalog Class See Also

The SasCatalog type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetSasCatalogEntries | Returns a list of SAS catalog entries that reside in this catalog.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SasCatalog Class
SAS.Tasks.Toolkit.Data Namespace


GetSasCatalogEntries Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasCatalog..::.GetSasCatalogEntries Method
SasCatalog Class See Also

Returns a list of SAS catalog entries that reside in this catalog.

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSasCatalogEntries As IList(Of SasCatalogEntry)
C#
public IList<SasCatalogEntry> GetSasCatalogEntries()

Return Value

SAS catalog entry objects (SasCatalogEntry objects)

Exceptions

Exception | Condition
SAS.Tasks.Toolkit.Data..::.SasDataException | Thrown if the server or library does not exist

See Also

SasCatalog Class
SAS.Tasks.Toolkit.Data Namespace


SasCatalog Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasCatalog Properties
SasCatalog Class See Also

The SasCatalog type exposes the following members.

Properties

Name | Description
Libref | The library reference name (libref) for this catalog
Member | The member name for this catalog.
Name | Gets the name of the catalog. You can set/get this in the Member property as well.
Server | The SAS server associated with this catalog.

See Also

SasCatalog Class
SAS.Tasks.Toolkit.Data Namespace


Libref Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasCatalog..::.Libref Property
SasCatalog Class See Also

The library reference name (libref) for this catalog

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property Libref As String
C#
public string Libref { get; set; }

See Also

SasCatalog Class
SAS.Tasks.Toolkit.Data Namespace


Member Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasCatalog..::.Member Property
SasCatalog Class See Also

The member name for this catalog.

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property Member As String
C#
public string Member { get; set; }

See Also

SasCatalog Class
SAS.Tasks.Toolkit.Data Namespace


Name Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasCatalog..::.Name Property
SasCatalog Class See Also

Gets the name of the catalog. You can set/get this in the Member property as well.

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name { get; }

See Also

SasCatalog Class
SAS.Tasks.Toolkit.Data Namespace


Server Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasCatalog..::.Server Property
SasCatalog Class See Also

The SAS server associated with this catalog.

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property Server As String
C#
public string Server { get; set; }

See Also

SasCatalog Class
SAS.Tasks.Toolkit.Data Namespace


SasCatalogEntry Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasCatalogEntry Class
Members See Also

A SAS catalog entry. This is a logical file that resides inside a SAS catalog. The full reference for an entry is: LIBREF.CATALOG.ENTRY.TYPE.

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Class SasCatalogEntry
C#
public class SasCatalogEntry

Inheritance Hierarchy

System..::.Object
SAS.Tasks.Toolkit.Data..::.SasCatalogEntry

See Also

SasCatalogEntry Members
SAS.Tasks.Toolkit.Data Namespace


SasCatalogEntry Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasCatalogEntry Members
SasCatalogEntry Class Constructors Methods Properties See Also

The SasCatalogEntry type exposes the following members.

Constructors

Name | Description
SasCatalogEntry | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Created | Date the entry was created.
Description | The description field for this catalog entry.
Entry | The Entry name for this catalog entry.
LastModified | Date the entry was last modified.
Libref | The library reference name (libref) for this catalog
Member | The member name for the catalog that holds this entry.
Name | Gets the name of the catalog entry. You can set/get this in the Entry property as well.
ObjectType | The string representation of the entry type.
SasReference | The full four-level name for this catalog entry.
Server | The SAS server associated with this catalog entry.

See Also

SasCatalogEntry Class
SAS.Tasks.Toolkit.Data Namespace


SasCatalogEntry Constructor

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasCatalogEntry Constructor
SasCatalogEntry Class See Also

Overload List

Name | Description
SasCatalogEntry()()() | Default constructor
SasCatalogEntry(String, String, String, String) | Constructor for the SasCatalogEntry object. It takes the basic fields and initializes the rest with default values.
SasCatalogEntry(String, String, String, String, String, DateTime, DateTime) | Constructor for a SasCatalogEntry object that takes all attributes.

See Also

SasCatalogEntry Class
SasCatalogEntry Members
SAS.Tasks.Toolkit.Data Namespace


SasCatalogEntry Constructor

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasCatalogEntry Constructor
SasCatalogEntry Class See Also

Default constructor

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SasCatalogEntry()

See Also

SasCatalogEntry Class
SasCatalogEntry Overload
SAS.Tasks.Toolkit.Data Namespace


SasCatalogEntry Constructor (String, String, String, String)

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasCatalogEntry Constructor (String, String, String, String)
SasCatalogEntry Class See Also

Constructor for the SasCatalogEntry object. It takes the basic fields and initializes the rest with default values.

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    libref As String, _
    member As String, _
    entry As String, _
    type As String _
)
C#
public SasCatalogEntry(
    string libref,
    string member,
    string entry,
    string type
)

Parameters

libref
Type: System..::.String
The SAS libref for the catalog entry.
member
Type: System..::.String
The SAS catalog name.
entry
Type: System..::.String
The name of the entry.
type
Type: System..::.String
The object type (SCL, SOURCE, FRAME, etc.)

See Also

SasCatalogEntry Class
SasCatalogEntry Overload
SAS.Tasks.Toolkit.Data Namespace


SasCatalogEntry Constructor (String, String, String, String, String, DateTime, DateTime)

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasCatalogEntry Constructor (String, String, String, String, String, DateTime, DateTime)
SasCatalogEntry Class See Also

Constructor for a SasCatalogEntry object that takes all attributes.

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    libref As String, _
    member As String, _
    entry As String, _
    type As String, _
    description As String, _
    created As DateTime, _
    modified As DateTime _
)
C#
public SasCatalogEntry(
    string libref,
    string member,
    string entry,
    string type,
    string description,
    DateTime created,
    DateTime modified
)

Parameters

libref
Type: System..::.String
The SAS libref for this entry.
member
Type: System..::.String
The SAS catalog name.
entry
Type: System..::.String
The entry name.
type
Type: System..::.String
The object type (SCL, SOURCE, FRAME, etc.)
description
Type: System..::.String
A text description for the entry.
created
Type: System..::.DateTime
The date/time that the entry was created.
modified
Type: System..::.DateTime
The data/time that the entry was last modified.

See Also

SasCatalogEntry Class
SasCatalogEntry Overload
SAS.Tasks.Toolkit.Data Namespace


SasCatalogEntry Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasCatalogEntry Methods
SasCatalogEntry Class See Also

The SasCatalogEntry type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SasCatalogEntry Class
SAS.Tasks.Toolkit.Data Namespace


SasCatalogEntry Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasCatalogEntry Properties
SasCatalogEntry Class See Also

The SasCatalogEntry type exposes the following members.

Properties

Name | Description
Created | Date the entry was created.
Description | The description field for this catalog entry.
Entry | The Entry name for this catalog entry.
LastModified | Date the entry was last modified.
Libref | The library reference name (libref) for this catalog
Member | The member name for the catalog that holds this entry.
Name | Gets the name of the catalog entry. You can set/get this in the Entry property as well.
ObjectType | The string representation of the entry type.
SasReference | The full four-level name for this catalog entry.
Server | The SAS server associated with this catalog entry.

See Also

SasCatalogEntry Class
SAS.Tasks.Toolkit.Data Namespace


Created Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasCatalogEntry..::.Created Property
SasCatalogEntry Class See Also

Date the entry was created.

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property Created As DateTime
C#
public DateTime Created { get; set; }

See Also

SasCatalogEntry Class
SAS.Tasks.Toolkit.Data Namespace


Description Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasCatalogEntry..::.Description Property
SasCatalogEntry Class See Also

The description field for this catalog entry.

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }

See Also

SasCatalogEntry Class
SAS.Tasks.Toolkit.Data Namespace


Entry Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasCatalogEntry..::.Entry Property
SasCatalogEntry Class See Also

The Entry name for this catalog entry.

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property Entry As String
C#
public string Entry { get; set; }

See Also

SasCatalogEntry Class
SAS.Tasks.Toolkit.Data Namespace


LastModified Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasCatalogEntry..::.LastModified Property
SasCatalogEntry Class See Also

Date the entry was last modified.

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property LastModified As DateTime
C#
public DateTime LastModified { get; set; }

See Also

SasCatalogEntry Class
SAS.Tasks.Toolkit.Data Namespace


Libref Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasCatalogEntry..::.Libref Property
SasCatalogEntry Class See Also

The library reference name (libref) for this catalog

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property Libref As String
C#
public string Libref { get; set; }

See Also

SasCatalogEntry Class
SAS.Tasks.Toolkit.Data Namespace


Member Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasCatalogEntry..::.Member Property
SasCatalogEntry Class See Also

The member name for the catalog that holds this entry.

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property Member As String
C#
public string Member { get; set; }

See Also

SasCatalogEntry Class
SAS.Tasks.Toolkit.Data Namespace


Name Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasCatalogEntry..::.Name Property
SasCatalogEntry Class See Also

Gets the name of the catalog entry. You can set/get this in the Entry property as well.

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name { get; }

See Also

SasCatalogEntry Class
SAS.Tasks.Toolkit.Data Namespace


ObjectType Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasCatalogEntry..::.ObjectType Property
SasCatalogEntry Class See Also

The string representation of the entry type.

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property ObjectType As String
C#
public string ObjectType { get; set; }

See Also

SasCatalogEntry Class
SAS.Tasks.Toolkit.Data Namespace


SasReference Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasCatalogEntry..::.SasReference Property
SasCatalogEntry Class See Also

The full four-level name for this catalog entry.

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SasReference As String
C#
public string SasReference { get; }

See Also

SasCatalogEntry Class
SAS.Tasks.Toolkit.Data Namespace


Server Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasCatalogEntry..::.Server Property
SasCatalogEntry Class See Also

The SAS server associated with this catalog entry.

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property Server As String
C#
public string Server { get; set; }

See Also

SasCatalogEntry Class
SAS.Tasks.Toolkit.Data Namespace


SasColumn Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasColumn Class
Members See Also

A SAS column, or variable, within a SAS data source

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Class SasColumn
C#
public class SasColumn

Inheritance Hierarchy

System..::.Object
SAS.Tasks.Toolkit.Data..::.SasColumn

See Also

SasColumn Members
SAS.Tasks.Toolkit.Data Namespace


SasColumn Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasColumn Members
SasColumn Class Constructors Methods Properties See Also

The SasColumn type exposes the following members.

Constructors

Name | Description
SasColumn | Constructor for SAS column object.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Category | SAS category, based on data type and format.
Format | SAS column display format
Informat | SAS column informat (read-in format style)
Label | SAS column label
Length | SAS column length (or precision)
Name | SAS column name
Type | SAS data type

See Also

SasColumn Class
SAS.Tasks.Toolkit.Data Namespace


SasColumn Constructor

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasColumn Constructor
SasColumn Class See Also

Constructor for SAS column object.

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    label As String, _
    length As Integer, _
    type As SasColumn..::.eType, _
    format As String, _
    informat As String _
)
C#
public SasColumn(
    string name,
    string label,
    int length,
    SasColumn..::.eType type,
    string format,
    string informat
)

Parameters

name
Type: System..::.String
Column name
label
Type: System..::.String
Column label
length
Type: System..::.Int32
Column length (or precision)
type
Type: SAS.Tasks.Toolkit.Data..::.SasColumn..::.eType
Column type
format
Type: System..::.String
Column format (for display)
informat
Type: System..::.String
Column informat (for reading in values)

See Also

SasColumn Class
SAS.Tasks.Toolkit.Data Namespace


SasColumn Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasColumn Methods
SasColumn Class See Also

The SasColumn type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SasColumn Class
SAS.Tasks.Toolkit.Data Namespace


SasColumn Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasColumn Properties
SasColumn Class See Also

The SasColumn type exposes the following members.

Properties

Name | Description
Category | SAS category, based on data type and format.
Format | SAS column display format
Informat | SAS column informat (read-in format style)
Label | SAS column label
Length | SAS column length (or precision)
Name | SAS column name
Type | SAS data type

See Also

SasColumn Class
SAS.Tasks.Toolkit.Data Namespace


Category Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasColumn..::.Category Property
SasColumn Class See Also

SAS category, based on data type and format.

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Category As SasColumn..::.eCategory
C#
public SasColumn..::.eCategory Category { get; }

See Also

SasColumn Class
SAS.Tasks.Toolkit.Data Namespace


Format Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasColumn..::.Format Property
SasColumn Class See Also

SAS column display format

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property Format As String
C#
public string Format { get; set; }

See Also

SasColumn Class
SAS.Tasks.Toolkit.Data Namespace


Informat Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasColumn..::.Informat Property
SasColumn Class See Also

SAS column informat (read-in format style)

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property Informat As String
C#
public string Informat { get; set; }

See Also

SasColumn Class
SAS.Tasks.Toolkit.Data Namespace


Label Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasColumn..::.Label Property
SasColumn Class See Also

SAS column label

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property Label As String
C#
public string Label { get; set; }

See Also

SasColumn Class
SAS.Tasks.Toolkit.Data Namespace


Length Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasColumn..::.Length Property
SasColumn Class See Also

SAS column length (or precision)

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property Length As Integer
C#
public int Length { get; set; }

See Also

SasColumn Class
SAS.Tasks.Toolkit.Data Namespace


Name Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasColumn..::.Name Property
SasColumn Class See Also

SAS column name

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }

See Also

SasColumn Class
SAS.Tasks.Toolkit.Data Namespace


Type Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasColumn..::.Type Property
SasColumn Class See Also

SAS data type

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As SasColumn..::.eType
C#
public SasColumn..::.eType Type { get; set; }

See Also

SasColumn Class
SAS.Tasks.Toolkit.Data Namespace


SasColumn.eCategory Enumeration

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasColumn..::.eCategory Enumeration
SasColumn Class See Also

SAS data categories are inferred from the formats applied: Date, Currency, DateTime, and Georef. Or just plain Character or Numeric.

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration eCategory
C#
public enum eCategory

Members

Member name | Description
Character | Character column
Numeric | Numeric column, based on a numeric format
Currency | Numeric column using a currency format
Date | Numeric column using a date format
DateTime | Numeric column using a datetime format
Georef | A column that uses a special GEOREF format

See Also

SAS.Tasks.Toolkit.Data Namespace


SasColumn.eType Enumeration

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasColumn..::.eType Enumeration
SasColumn Class See Also

SAS has two fundamental data types: Character and Numeric

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration eType
C#
public enum eType

Members

Member name | Description
Character | Character type
Numeric | Numeric type

See Also

SAS.Tasks.Toolkit.Data Namespace


SasData Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasData Class
Members See Also

A SAS data reference, pointing to either a SAS table or view -- any data member within a SAS library

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Class SasData
C#
public class SasData

Inheritance Hierarchy

System..::.Object
SAS.Tasks.Toolkit.Data..::.SasData

See Also

SasData Members
SAS.Tasks.Toolkit.Data Namespace


SasData Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasData Members
SasData Class Constructors Methods Properties See Also

The SasData type exposes the following members.

Constructors

Name | Description
SasData | Overloaded.

Methods

Name | Description
ContainsColumn | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColumns | Get a list of SAS columns in this data source.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLibrary | Get the SAS library object for this particular data source.
GetSasCodeReference | Get the SAS-syntax-ready string for this data source, including any additional data set options such as password, obs, and firstobs settings.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RefreshColumns | Refresh the list of columns, in case there have been changes since the collection was first accessed.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DataTypesImageListSmall | An ImageList that contains indexed images for the SAS column types.
Libref | The library reference name (libref) for this data source
Member | The member name for this data set or view.
Server | The SAS server associated with this data.

See Also

SasData Class
SAS.Tasks.Toolkit.Data Namespace


SasData Constructor

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasData Constructor
SasData Class See Also

Overload List

Name | Description
SasData(ISASTaskData2) | Constructor that takes ISASTaskData2 reference, which you can get from the application's ISASTaskConsumer3 interface.
SasData(String, String, String) | Constructor that takes the traditional SAS libref (library reference) and member name, along with the name of the SAS server (for example, "SASMain").

See Also

SasData Class
SasData Members
SAS.Tasks.Toolkit.Data Namespace


SasData Constructor (ISASTaskData2)

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasData Constructor (ISASTaskData2)
SasData Class See Also

Constructor that takes ISASTaskData2 reference, which you can get from the application's ISASTaskConsumer3 interface.

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    data As ISASTaskData2 _
)
C#
public SasData(
    ISASTaskData2 data
)

Parameters

data
Type: SAS.Shared.AddIns..::.ISASTaskData2
The data reference from the application

See Also

SasData Class
SasData Overload
SAS.Tasks.Toolkit.Data Namespace


SasData Constructor (String, String, String)

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasData Constructor (String, String, String)
SasData Class See Also

Constructor that takes the traditional SAS libref (library reference) and member name, along with the name of the SAS server (for example, "SASMain").

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    server As String, _
    libref As String, _
    member As String _
)
C#
public SasData(
    string server,
    string libref,
    string member
)

Parameters

server
Type: System..::.String
Name of the SAS server where the data resides
libref
Type: System..::.String
SAS library reference (libref)
member
Type: System..::.String
SAS member name

See Also

SasData Class
SasData Overload
SAS.Tasks.Toolkit.Data Namespace


SasData Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasData Methods
SasData Class See Also

The SasData type exposes the following members.

Methods

Name | Description
ContainsColumn | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColumns | Get a list of SAS columns in this data source.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLibrary | Get the SAS library object for this particular data source.
GetSasCodeReference | Get the SAS-syntax-ready string for this data source, including any additional data set options such as password, obs, and firstobs settings.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RefreshColumns | Refresh the list of columns, in case there have been changes since the collection was first accessed.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SasData Class
SAS.Tasks.Toolkit.Data Namespace


ContainsColumn Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasData..::.ContainsColumn Method
SasData Class See Also

Overload List

Name | Description
ContainsColumn(String) | Returns whether a column of a given name is in the SAS data set. The comparison is case-insensitive.
ContainsColumn(String, SasColumn..::.eType) | Returns whether a column of a given name and type is in the SAS data set. The comparison is case-insensitive.

See Also

SasData Class
SasData Members
SAS.Tasks.Toolkit.Data Namespace


ContainsColumn Method (String)

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasData..::.ContainsColumn Method (String)
SasData Class See Also

Returns whether a column of a given name is in the SAS data set. The comparison is case-insensitive.

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Function ContainsColumn ( _
    columnName As String _
) As Boolean
C#
public bool ContainsColumn(
    string columnName
)

Parameters

columnName
Type: System..::.String
Name of the column

Return Value

true if found in the list, otherwise false.

See Also

SasData Class
ContainsColumn Overload
SAS.Tasks.Toolkit.Data Namespace


ContainsColumn Method (String, SasColumn.eType)

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasData..::.ContainsColumn Method (String, SasColumn..::.eType)
SasData Class See Also

Returns whether a column of a given name and type is in the SAS data set. The comparison is case-insensitive.

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Function ContainsColumn ( _
    columnName As String, _
    type As SasColumn..::.eType _
) As Boolean
C#
public bool ContainsColumn(
    string columnName,
    SasColumn..::.eType type
)

Parameters

columnName
Type: System..::.String
Name of the column
type
Type: SAS.Tasks.Toolkit.Data..::.SasColumn..::.eType
Type of the column to match

Return Value

true if found in the list, otherwise false.

See Also

SasData Class
ContainsColumn Overload
SAS.Tasks.Toolkit.Data Namespace


GetColumns Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasData..::.GetColumns Method
SasData Class See Also

Get a list of SAS columns in this data source.

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Function GetColumns As IList(Of SasColumn)
C#
public IList<SasColumn> GetColumns()

Return Value

A list of SasColumn objects with the detailed column information.

Exceptions

Exception | Condition
SAS.Tasks.Toolkit.Data..::.SasDataException | Thrown if there is an error reading the column information.

See Also

SasData Class
SAS.Tasks.Toolkit.Data Namespace


GetLibrary Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasData..::.GetLibrary Method
SasData Class See Also

Get the SAS library object for this particular data source.

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Function GetLibrary As SasLibrary
C#
public SasLibrary GetLibrary()

Return Value

A SasLibrary object.

See Also

SasData Class
SAS.Tasks.Toolkit.Data Namespace


GetSasCodeReference Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasData..::.GetSasCodeReference Method
SasData Class See Also

Get the SAS-syntax-ready string for this data source, including any additional data set options such as password, obs, and firstobs settings.

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetSasCodeReference ( _
    taskData As ISASTaskData2 _
) As String
C#
public static string GetSasCodeReference(
    ISASTaskData2 taskData
)

Parameters

taskData
Type: SAS.Shared.AddIns..::.ISASTaskData2
The ISASTaskData2 reference from the application.

Return Value

a string with the data reference

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown if taskData argument is null.

See Also

SasData Class
SAS.Tasks.Toolkit.Data Namespace


RefreshColumns Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasData..::.RefreshColumns Method
SasData Class See Also

Refresh the list of columns, in case there have been changes since the collection was first accessed.

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub RefreshColumns
C#
public void RefreshColumns()

Exceptions

Exception | Condition
SAS.Tasks.Toolkit.Data..::.SasDataException | Thrown if there is an error reading the column information.

See Also

SasData Class
SAS.Tasks.Toolkit.Data Namespace


SasData Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasData Properties
SasData Class See Also

The SasData type exposes the following members.

Properties

Name | Description
DataTypesImageListSmall | An ImageList that contains indexed images for the SAS column types.
Libref | The library reference name (libref) for this data source
Member | The member name for this data set or view.
Server | The SAS server associated with this data.

See Also

SasData Class
SAS.Tasks.Toolkit.Data Namespace


DataTypesImageListSmall Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasData..::.DataTypesImageListSmall Property
SasData Class See Also

An ImageList that contains indexed images for the SAS column types.

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property DataTypesImageListSmall As ImageList
C#
public static ImageList DataTypesImageListSmall { get; }

See Also

SasData Class
SAS.Tasks.Toolkit.Data Namespace


Libref Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasData..::.Libref Property
SasData Class See Also

The library reference name (libref) for this data source

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property Libref As String
C#
public string Libref { get; set; }

See Also

SasData Class
SAS.Tasks.Toolkit.Data Namespace


Member Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasData..::.Member Property
SasData Class See Also

The member name for this data set or view.

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property Member As String
C#
public string Member { get; set; }

See Also

SasData Class
SAS.Tasks.Toolkit.Data Namespace


Server Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasData..::.Server Property
SasData Class See Also

The SAS server associated with this data.

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property Server As String
C#
public string Server { get; set; }

See Also

SasData Class
SAS.Tasks.Toolkit.Data Namespace


SasDataException Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasDataException Class
Members See Also

Thrown when there is an error accessing the SasData object

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Class SasDataException _
    Inherits Exception
C#
public class SasDataException : Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
SAS.Tasks.Toolkit.Data..::.SasDataException

See Also

SasDataException Members
SAS.Tasks.Toolkit.Data Namespace


SasDataException Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasDataException Members
SasDataException Class Constructors Methods Properties See Also

The SasDataException type exposes the following members.

Constructors

Name | Description
SasDataException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SasDataException Class
SAS.Tasks.Toolkit.Data Namespace


SasDataException Constructor

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasDataException Constructor
SasDataException Class See Also

Overload List

Name | Description
SasDataException(String) | Constructor with message
SasDataException(String, Exception) | Constructor with message and inner exception

See Also

SasDataException Class
SasDataException Members
SAS.Tasks.Toolkit.Data Namespace


SasDataException Constructor (String)

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasDataException Constructor (String)
SasDataException Class See Also

Constructor with message

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public SasDataException(
    string message
)

Parameters

message
Type: System..::.String

See Also

SasDataException Class
SasDataException Overload
SAS.Tasks.Toolkit.Data Namespace


SasDataException Constructor (String, Exception)

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasDataException Constructor (String, Exception)
SasDataException Class See Also

Constructor with message and inner exception

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
C#
public SasDataException(
    string message,
    Exception innerException
)

Parameters

message
Type: System..::.String
innerException
Type: System..::.Exception

See Also

SasDataException Class
SasDataException Overload
SAS.Tasks.Toolkit.Data Namespace


SasDataException Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasDataException Methods
SasDataException Class See Also

The SasDataException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

SasDataException Class
SAS.Tasks.Toolkit.Data Namespace


SasDataException Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasDataException Properties
SasDataException Class See Also

The SasDataException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SasDataException Class
SAS.Tasks.Toolkit.Data Namespace


SasLibrary Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasLibrary Class
Members See Also

A SAS library that contains data members

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Class SasLibrary
C#
public class SasLibrary

Inheritance Hierarchy

System..::.Object
SAS.Tasks.Toolkit.Data..::.SasLibrary

See Also

SasLibrary Members
SAS.Tasks.Toolkit.Data Namespace


SasLibrary Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasLibrary Members
SasLibrary Class Constructors Methods Properties See Also

The SasLibrary type exposes the following members.

Constructors

Name | Description
SasLibrary | Constructor that takes a server name and a SAS libref

Methods

Name | Description
Assign | Assign the library, if not assigned.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetSasCatalogMembers | Returns a list of SAS catalogs that reside inside this library.
GetSasDataMembers | Returns a list of SAS data members that reside in this library
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Engine | SAS library engine used to access the library contents.
IsAssigned | Whether the library is currently assigned
Libref | The SAS libref associated with this library.
Name | Library name as registered in metadata, if applicable. This might be a different value than Libref. Use Libref when referring to this library in SAS syntax.
Options | Options associated with the library, if any.
Path | Path associated with the library, if any.
ReadOnly | Whether this library is read-only (ACCESS=READ).
Server | The name of the SAS server that hosts this library definition.

See Also

SasLibrary Class
SAS.Tasks.Toolkit.Data Namespace


SasLibrary Constructor

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasLibrary Constructor
SasLibrary Class See Also

Constructor that takes a server name and a SAS libref

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    server As String, _
    libref As String _
)
C#
public SasLibrary(
    string server,
    string libref
)

Parameters

server
Type: System..::.String
Name of the SAS server
libref
Type: System..::.String
SAS libref (syntax name)

Exceptions

Exception | Condition
SAS.Tasks.Toolkit.Data..::.SasDataException | Thrown if the server or library does not exist

See Also

SasLibrary Class
SAS.Tasks.Toolkit.Data Namespace


SasLibrary Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasLibrary Methods
SasLibrary Class See Also

The SasLibrary type exposes the following members.

Methods

Name | Description
Assign | Assign the library, if not assigned.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetSasCatalogMembers | Returns a list of SAS catalogs that reside inside this library.
GetSasDataMembers | Returns a list of SAS data members that reside in this library
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SasLibrary Class
SAS.Tasks.Toolkit.Data Namespace


Assign Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasLibrary..::.Assign Method
SasLibrary Class See Also

Assign the library, if not assigned.

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub Assign
C#
public void Assign()

Exceptions

Exception | Condition
SAS.Tasks.Toolkit.Data..::.SasDataException | Thrown if the library assignment failed, or if the library is already assigned.

See Also

SasLibrary Class
SAS.Tasks.Toolkit.Data Namespace


GetSasCatalogMembers Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasLibrary..::.GetSasCatalogMembers Method
SasLibrary Class See Also

Returns a list of SAS catalogs that reside inside this library.

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSasCatalogMembers As IList(Of SasCatalog)
C#
public IList<SasCatalog> GetSasCatalogMembers()

Return Value

SAS catalog member objects (SasCatalog objects)

Exceptions

Exception | Condition
SAS.Tasks.Toolkit.Data..::.SasDataException | Thrown if the server or library does not exist

See Also

SasLibrary Class
SAS.Tasks.Toolkit.Data Namespace


GetSasDataMembers Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasLibrary..::.GetSasDataMembers Method
SasLibrary Class See Also

Returns a list of SAS data members that reside in this library

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSasDataMembers As IList(Of SasData)
C#
public IList<SasData> GetSasDataMembers()

Return Value

SAS data member objects (SasData objects)

Exceptions

Exception | Condition
SAS.Tasks.Toolkit.Data..::.SasDataException | Thrown if the server or library does not exist

See Also

SasLibrary Class
SAS.Tasks.Toolkit.Data Namespace


SasLibrary Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasLibrary Properties
SasLibrary Class See Also

The SasLibrary type exposes the following members.

Properties

Name | Description
Engine | SAS library engine used to access the library contents.
IsAssigned | Whether the library is currently assigned
Libref | The SAS libref associated with this library.
Name | Library name as registered in metadata, if applicable. This might be a different value than Libref. Use Libref when referring to this library in SAS syntax.
Options | Options associated with the library, if any.
Path | Path associated with the library, if any.
ReadOnly | Whether this library is read-only (ACCESS=READ).
Server | The name of the SAS server that hosts this library definition.

See Also

SasLibrary Class
SAS.Tasks.Toolkit.Data Namespace


Engine Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasLibrary..::.Engine Property
SasLibrary Class See Also

SAS library engine used to access the library contents.

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property Engine As String
C#
public string Engine { get; set; }

See Also

SasLibrary Class
SAS.Tasks.Toolkit.Data Namespace


IsAssigned Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasLibrary..::.IsAssigned Property
SasLibrary Class See Also

Whether the library is currently assigned

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsAssigned As Boolean
C#
public bool IsAssigned { get; }

See Also

SasLibrary Class
SAS.Tasks.Toolkit.Data Namespace


Libref Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasLibrary..::.Libref Property
SasLibrary Class See Also

The SAS libref associated with this library.

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property Libref As String
C#
public string Libref { get; set; }

See Also

SasLibrary Class
SAS.Tasks.Toolkit.Data Namespace


Name Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasLibrary..::.Name Property
SasLibrary Class See Also

Library name as registered in metadata, if applicable. This might be a different value than Libref. Use Libref when referring to this library in SAS syntax.

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }

See Also

SasLibrary Class
SAS.Tasks.Toolkit.Data Namespace


Options Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasLibrary..::.Options Property
SasLibrary Class See Also

Options associated with the library, if any.

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property Options As String
C#
public string Options { get; set; }

See Also

SasLibrary Class
SAS.Tasks.Toolkit.Data Namespace


Path Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasLibrary..::.Path Property
SasLibrary Class See Also

Path associated with the library, if any.

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property Path As String
C#
public string Path { get; set; }

See Also

SasLibrary Class
SAS.Tasks.Toolkit.Data Namespace


ReadOnly Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasLibrary..::.ReadOnly Property
SasLibrary Class See Also

Whether this library is read-only (ACCESS=READ).

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property ReadOnly As Boolean
C#
public bool ReadOnly { get; set; }

See Also

SasLibrary Class
SAS.Tasks.Toolkit.Data Namespace


Server Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SasLibrary..::.Server Property
SasLibrary Class See Also

The name of the SAS server that hosts this library definition.

Namespace: SAS.Tasks.Toolkit.Data
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property Server As String
C#
public string Server { get; set; }

See Also

SasLibrary Class
SAS.Tasks.Toolkit.Data Namespace


SAS.Tasks.Toolkit.Helpers Namespace

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
SAS.Tasks.Toolkit.Helpers Namespace

Classes

Class | Description
ColumnsToSASVarNames | Utility class to map a collection of column names to valid SAS names -- names that comply with SAS column naming conventions (no spaces, special characters, etc.).
FormattedLogWriter | Write formatted (colored) lines to the log. Use this class to write formatted lines to the ISASTaskTextWriter interface that is supplied when implementing ISASTaskExecution.
StreamAdapter | Implement the ISASTaskStream interface that is used with ISASTaskExecution.
TaskAddInHelpers | A helper class that implements some of the commonly needed interface methods for custom tasks.
TaskDataHelpers | Contains helper methods to assist with task data sources from the application.
TaskOptions | Helper class to interpret the ISASTaskOptions interface
UtilityFunctions | Contains a number of utilities to aid in generating useful and valid SAS programs from within a custom task.

Structures

Structure | Description
ResultInfo | Simple structure to hold results of various types. For use with StreamAdapter.


ColumnsToSASVarNames Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ColumnsToSASVarNames Class
Members See Also

Utility class to map a collection of column names to valid SAS names -- names that comply with SAS column naming conventions (no spaces, special characters, etc.).

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ColumnsToSASVarNames
C#
public sealed class ColumnsToSASVarNames

Inheritance Hierarchy

System..::.Object
SAS.Tasks.Toolkit.Helpers..::.ColumnsToSASVarNames

See Also

ColumnsToSASVarNames Members
SAS.Tasks.Toolkit.Helpers Namespace


ColumnsToSASVarNames Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ColumnsToSASVarNames Members
ColumnsToSASVarNames Class Methods See Also

The ColumnsToSASVarNames type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MapToSASVarNames | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ColumnsToSASVarNames Class
SAS.Tasks.Toolkit.Helpers Namespace


ColumnsToSASVarNames Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ColumnsToSASVarNames Methods
ColumnsToSASVarNames Class See Also

The ColumnsToSASVarNames type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MapToSASVarNames | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ColumnsToSASVarNames Class
SAS.Tasks.Toolkit.Helpers Namespace


MapToSASVarNames Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ColumnsToSASVarNames..::.MapToSASVarNames Method
ColumnsToSASVarNames Class See Also

Overload List

Name | Description
MapToSASVarNames(StringCollection) | Create a string collection to map current names to valid SAS names
MapToSASVarNames(StringCollection, StringCollection) | Create a string collection to map current names to valid SAS names

See Also

ColumnsToSASVarNames Class
ColumnsToSASVarNames Members
SAS.Tasks.Toolkit.Helpers Namespace


MapToSASVarNames Method (StringCollection)

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ColumnsToSASVarNames..::.MapToSASVarNames Method (StringCollection)
ColumnsToSASVarNames Class See Also

Create a string collection to map current names to valid SAS names

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function MapToSASVarNames ( _
    originalNames As StringCollection _
) As StringCollection
C#
public static StringCollection MapToSASVarNames(
    StringCollection originalNames
)

Parameters

originalNames
Type: System.Collections.Specialized..::.StringCollection
string collection of original names in the data source

Return Value

StringCollection with SAS names as values

See Also

ColumnsToSASVarNames Class
MapToSASVarNames Overload
SAS.Tasks.Toolkit.Helpers Namespace


MapToSASVarNames Method (StringCollection, StringCollection)

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ColumnsToSASVarNames..::.MapToSASVarNames Method (StringCollection, StringCollection)
ColumnsToSASVarNames Class See Also

Create a string collection to map current names to valid SAS names

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function MapToSASVarNames ( _
    originalNames As StringCollection, _
    excludeNames As StringCollection _
) As StringCollection
C#
public static StringCollection MapToSASVarNames(
    StringCollection originalNames,
    StringCollection excludeNames
)

Parameters

originalNames
Type: System.Collections.Specialized..::.StringCollection
string collection of original names in the data source
excludeNames
Type: System.Collections.Specialized..::.StringCollection
string collection of names to be avoided

Return Value

StringCollection with SAS names as values

See Also

ColumnsToSASVarNames Class
MapToSASVarNames Overload
SAS.Tasks.Toolkit.Helpers Namespace


FormattedLogWriter Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
FormattedLogWriter Class
Members See Also

Write formatted (colored) lines to the log. Use this class to write formatted lines to the ISASTaskTextWriter interface that is supplied when implementing ISASTaskExecution.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class FormattedLogWriter
C#
public sealed class FormattedLogWriter

Inheritance Hierarchy

System..::.Object
SAS.Tasks.Toolkit.Helpers..::.FormattedLogWriter

See Also

FormattedLogWriter Members
SAS.Tasks.Toolkit.Helpers Namespace


FormattedLogWriter Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
FormattedLogWriter Members
FormattedLogWriter Class Methods See Also

The FormattedLogWriter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteEmptyLine | Write an empty (blank) line to the log, including line feed.
WriteErrorLine | Write an ERROR line to the log. The "ERROR:" prefix is not included.
WriteFormattedLogLine | This is an internal utility method which performs the actual writing of lines to the SAS log using the specified format and text. A string may contain multiple lines delimited by either "\r\n" or "\n" character code sequences. Each logical line will be extracted and written to the log, prefixed with the specified format code.
WriteNormalLine | Write a normal (non-colored) line to the log, including line feed.
WriteNoteLine | Write a NOTE line to the log, including line feed. The "NOTE:" prefix is not included.
WriteWarningLine | Write a WARNING line to the log, including line feed. The "WARNING:" prefix is not included.

See Also

FormattedLogWriter Class
SAS.Tasks.Toolkit.Helpers Namespace


FormattedLogWriter Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
FormattedLogWriter Methods
FormattedLogWriter Class See Also

The FormattedLogWriter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteEmptyLine | Write an empty (blank) line to the log, including line feed.
WriteErrorLine | Write an ERROR line to the log. The "ERROR:" prefix is not included.
WriteFormattedLogLine | This is an internal utility method which performs the actual writing of lines to the SAS log using the specified format and text. A string may contain multiple lines delimited by either "\r\n" or "\n" character code sequences. Each logical line will be extracted and written to the log, prefixed with the specified format code.
WriteNormalLine | Write a normal (non-colored) line to the log, including line feed.
WriteNoteLine | Write a NOTE line to the log, including line feed. The "NOTE:" prefix is not included.
WriteWarningLine | Write a WARNING line to the log, including line feed. The "WARNING:" prefix is not included.

See Also

FormattedLogWriter Class
SAS.Tasks.Toolkit.Helpers Namespace


WriteEmptyLine Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
FormattedLogWriter..::.WriteEmptyLine Method
FormattedLogWriter Class See Also

Write an empty (blank) line to the log, including line feed.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub WriteEmptyLine ( _
    writer As ISASTaskTextWriter _
)
C#
public static void WriteEmptyLine(
    ISASTaskTextWriter writer
)

Parameters

writer
Type: SAS.Shared.AddIns..::.ISASTaskTextWriter
interface to the log writer supplied in the Run method for ISASTaskExecution.

See Also

FormattedLogWriter Class
SAS.Tasks.Toolkit.Helpers Namespace


WriteErrorLine Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
FormattedLogWriter..::.WriteErrorLine Method
FormattedLogWriter Class See Also

Write an ERROR line to the log. The "ERROR:" prefix is not included.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub WriteErrorLine ( _
    writer As ISASTaskTextWriter, _
    message As String _
)
C#
public static void WriteErrorLine(
    ISASTaskTextWriter writer,
    string message
)

Parameters

writer
Type: SAS.Shared.AddIns..::.ISASTaskTextWriter
interface to the log writer supplied in the Run method for ISASTaskExecution.
message
Type: System..::.String
the text for the log line

See Also

FormattedLogWriter Class
SAS.Tasks.Toolkit.Helpers Namespace


WriteFormattedLogLine Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
FormattedLogWriter..::.WriteFormattedLogLine Method
FormattedLogWriter Class See Also

This is an internal utility method which performs the actual writing of lines to the SAS log using the specified format and text. A string may contain multiple lines delimited by either "\r\n" or "\n" character code sequences. Each logical line will be extracted and written to the log, prefixed with the specified format code.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub WriteFormattedLogLine ( _
    writer As ISASTaskTextWriter, _
    code As String, _
    message As String _
)
C#
public static void WriteFormattedLogLine(
    ISASTaskTextWriter writer,
    string code,
    string message
)

Parameters

writer
Type: SAS.Shared.AddIns..::.ISASTaskTextWriter
interface to the log writer supplied in the Run method for ISASTaskExecution.
code
Type: System..::.String
the formatting code to be used when writing the text to the log
message
Type: System..::.String
the text for the log line

See Also

FormattedLogWriter Class
SAS.Tasks.Toolkit.Helpers Namespace


WriteNormalLine Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
FormattedLogWriter..::.WriteNormalLine Method
FormattedLogWriter Class See Also

Write a normal (non-colored) line to the log, including line feed.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub WriteNormalLine ( _
    writer As ISASTaskTextWriter, _
    message As String _
)
C#
public static void WriteNormalLine(
    ISASTaskTextWriter writer,
    string message
)

Parameters

writer
Type: SAS.Shared.AddIns..::.ISASTaskTextWriter
interface to the log writer supplied in the Run method for ISASTaskExecution.
message
Type: System..::.String
the text for the log line

See Also

FormattedLogWriter Class
SAS.Tasks.Toolkit.Helpers Namespace


WriteNoteLine Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
FormattedLogWriter..::.WriteNoteLine Method
FormattedLogWriter Class See Also

Write a NOTE line to the log, including line feed. The "NOTE:" prefix is not included.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub WriteNoteLine ( _
    writer As ISASTaskTextWriter, _
    message As String _
)
C#
public static void WriteNoteLine(
    ISASTaskTextWriter writer,
    string message
)

Parameters

writer
Type: SAS.Shared.AddIns..::.ISASTaskTextWriter
interface to the log writer supplied in the Run method for ISASTaskExecution.
message
Type: System..::.String
the text for the log line

See Also

FormattedLogWriter Class
SAS.Tasks.Toolkit.Helpers Namespace


WriteWarningLine Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
FormattedLogWriter..::.WriteWarningLine Method
FormattedLogWriter Class See Also

Write a WARNING line to the log, including line feed. The "WARNING:" prefix is not included.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub WriteWarningLine ( _
    writer As ISASTaskTextWriter, _
    message As String _
)
C#
public static void WriteWarningLine(
    ISASTaskTextWriter writer,
    string message
)

Parameters

writer
Type: SAS.Shared.AddIns..::.ISASTaskTextWriter
interface to the log writer supplied in the Run method for ISASTaskExecution.
message
Type: System..::.String
the text for the log line

See Also

FormattedLogWriter Class
SAS.Tasks.Toolkit.Helpers Namespace


ResultInfo Structure

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ResultInfo Structure
Members See Also

Simple structure to hold results of various types. For use with StreamAdapter.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Structure ResultInfo
C#
public struct ResultInfo

See Also

ResultInfo Members
SAS.Tasks.Toolkit.Helpers Namespace


ResultInfo Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ResultInfo Members
ResultInfo Structure Methods Fields See Also

The ResultInfo type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FormatStringToUtf8Result | Convert a string to a UTF8-encoded byte stream, complete with byte-order mark preamble.
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

Name | Description
Bytes | byte array of the results content.
MimeType | mime type of the result content (for example, text/html or application/x-xml)
OriginalFileName | The original file name of the content. Used only for annotation.

See Also

ResultInfo Structure
SAS.Tasks.Toolkit.Helpers Namespace


ResultInfo Fields

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ResultInfo Fields
ResultInfo Structure See Also

The ResultInfo type exposes the following members.

Fields

Name | Description
Bytes | byte array of the results content.
MimeType | mime type of the result content (for example, text/html or application/x-xml)
OriginalFileName | The original file name of the content. Used only for annotation.

See Also

ResultInfo Structure
SAS.Tasks.Toolkit.Helpers Namespace


Bytes Field

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ResultInfo..::.Bytes Field
ResultInfo Structure See Also

byte array of the results content.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Bytes As Byte()
C#
public byte[] Bytes

See Also

ResultInfo Structure
SAS.Tasks.Toolkit.Helpers Namespace


MimeType Field

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ResultInfo..::.MimeType Field
ResultInfo Structure See Also

mime type of the result content (for example, text/html or application/x-xml)

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public MimeType As String
C#
public string MimeType

See Also

ResultInfo Structure
SAS.Tasks.Toolkit.Helpers Namespace


OriginalFileName Field

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ResultInfo..::.OriginalFileName Field
ResultInfo Structure See Also

The original file name of the content. Used only for annotation.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public OriginalFileName As String
C#
public string OriginalFileName

See Also

ResultInfo Structure
SAS.Tasks.Toolkit.Helpers Namespace


ResultInfo Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ResultInfo Methods
ResultInfo Structure See Also

The ResultInfo type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FormatStringToUtf8Result | Convert a string to a UTF8-encoded byte stream, complete with byte-order mark preamble.
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

ResultInfo Structure
SAS.Tasks.Toolkit.Helpers Namespace


FormatStringToUtf8Result Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
ResultInfo..::.FormatStringToUtf8Result Method
ResultInfo Structure Example See Also

Convert a string to a UTF8-encoded byte stream, complete with byte-order mark preamble.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function FormatStringToUtf8Result ( _
    result As String _
) As Byte()
C#
public static byte[] FormatStringToUtf8Result(
    string result
)

Parameters

result
Type: System..::.String
The string of results to format.

Return Value

A byte-array that contains the results with a UTF8 byte-order mark (BOM)

Examples

To return a result stream that fits into the SAS program format:
Copy Code
            // this is the result that will be returned in OpenResultStream().
            SAS.Tasks.Toolkit.Helpers.ResultInfo _resultInfo;

            // build this value up during the Run() method.
            _resultInfo = new SAS.Tasks.Toolkit.Helpers.ResultInfo();
            _resultInfo.Bytes = SAS.Tasks.Toolkit.Helpers.ResultInfo.FormatStringToUtf8Result(_code);
            _resultInfo.MimeType = "application/x-sas";
            _resultInfo.OriginalFileName = string.Format("{0}.sas", tableName);

See Also

ResultInfo Structure
SAS.Tasks.Toolkit.Helpers Namespace


StreamAdapter Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
StreamAdapter Class
Members Example See Also

Implement the ISASTaskStream interface that is used with ISASTaskExecution.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class StreamAdapter _
    Implements ISASTaskStream
C#
public sealed class StreamAdapter : ISASTaskStream

Examples

// setting up the ResultInfo structure in your Run() method.
// fileContent is the string that contains the content to stream back

SAS.Tasks.Toolkit.Helpers.ResultInfo _resultInfo;
_resultInfo = new SAS.Tasks.Toolkit.Helpers.ResultInfo();
_resultInfo.Bytes = System.Text.Encoding.ASCII.GetBytes(code.ToCharArray());
_resultInfo.MimeType = "text/html";
_resultInfo.OriginalFileName = "result.html";

// then in the OpenResultStream method:
public ISASTaskStream OpenResultStream(int Index)
{
   if (Index == 0)
   {
       return new SAS.Tasks.Toolkit.Helpers.StreamAdapter(new MemoryStream(_resultInfo.Bytes),
           _resultInfo.MimeType,
           _resultInfo.OriginalFileName);
   }
   else return null;
}

Inheritance Hierarchy

System..::.Object
SAS.Tasks.Toolkit.Helpers..::.StreamAdapter

See Also

StreamAdapter Members
SAS.Tasks.Toolkit.Helpers Namespace


StreamAdapter Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
StreamAdapter Members
StreamAdapter Class Constructors Methods Properties See Also

The StreamAdapter type exposes the following members.

Constructors

Name | Description
StreamAdapter | Constructor to initialize this stream adapter.

Methods

Name | Description
Close | Close the stream handle.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Read | Reads bytes from the stream.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Length | Gets the length in bytes of the content.
MimeType | Gets the mime type of the content.
OriginalName | Gets the original file name of the content.

See Also

StreamAdapter Class
SAS.Tasks.Toolkit.Helpers Namespace


StreamAdapter Constructor

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
StreamAdapter Constructor
StreamAdapter Class See Also

Constructor to initialize this stream adapter.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    stream As Stream, _
    mimeType As String, _
    originalName As String _
)
C#
public StreamAdapter(
    Stream stream,
    string mimeType,
    string originalName
)

Parameters

stream
Type: System.IO..::.Stream
A stream, such as a MemoryStream, that contains the content.
mimeType
Type: System..::.String
mime type of the content
originalName
Type: System..::.String
original file name of the content.

See Also

StreamAdapter Class
SAS.Tasks.Toolkit.Helpers Namespace


StreamAdapter Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
StreamAdapter Methods
StreamAdapter Class See Also

The StreamAdapter type exposes the following members.

Methods

Name | Description
Close | Close the stream handle.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Read | Reads bytes from the stream.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StreamAdapter Class
SAS.Tasks.Toolkit.Helpers Namespace


Close Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
StreamAdapter..::.Close Method
StreamAdapter Class See Also

Close the stream handle.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub Close
C#
public void Close()

Implements

ISASTaskStream..::.Close()()()

See Also

StreamAdapter Class
SAS.Tasks.Toolkit.Helpers Namespace


Read Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
StreamAdapter..::.Read Method
StreamAdapter Class See Also

Reads bytes from the stream.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Function Read ( _
    buffer As Byte(), _
    count As Integer _
) As Integer
C#
public int Read(
    byte[] buffer,
    int count
)

Parameters

buffer
Type: array< System..::.Byte >[]()[]
read buffer to populate
count
Type: System..::.Int32
number of bytes to read.

Return Value

Implements

ISASTaskStream..::.Read(array<Byte>[]()[], Int32)

See Also

StreamAdapter Class
SAS.Tasks.Toolkit.Helpers Namespace


StreamAdapter Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
StreamAdapter Properties
StreamAdapter Class See Also

The StreamAdapter type exposes the following members.

Properties

Name | Description
Length | Gets the length in bytes of the content.
MimeType | Gets the mime type of the content.
OriginalName | Gets the original file name of the content.

See Also

StreamAdapter Class
SAS.Tasks.Toolkit.Helpers Namespace


Length Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
StreamAdapter..::.Length Property
StreamAdapter Class See Also

Gets the length in bytes of the content.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Length As Long
C#
public long Length { get; }

Implements

ISASTaskStream..::.Length

See Also

StreamAdapter Class
SAS.Tasks.Toolkit.Helpers Namespace


MimeType Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
StreamAdapter..::.MimeType Property
StreamAdapter Class See Also

Gets the mime type of the content.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MimeType As String
C#
public string MimeType { get; }

Implements

ISASTaskStream..::.MimeType

See Also

StreamAdapter Class
SAS.Tasks.Toolkit.Helpers Namespace


OriginalName Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
StreamAdapter..::.OriginalName Property
StreamAdapter Class See Also

Gets the original file name of the content.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OriginalName As String
C#
public string OriginalName { get; }

Implements

ISASTaskStream..::.OriginalName

See Also

StreamAdapter Class
SAS.Tasks.Toolkit.Helpers Namespace


TaskAddInHelpers Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskAddInHelpers Class
Members See Also

A helper class that implements some of the commonly needed interface methods for custom tasks.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TaskAddInHelpers
C#
public sealed class TaskAddInHelpers

Inheritance Hierarchy

System..::.Object
SAS.Tasks.Toolkit.Helpers..::.TaskAddInHelpers

See Also

TaskAddInHelpers Members
SAS.Tasks.Toolkit.Helpers Namespace


TaskAddInHelpers Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskAddInHelpers Members
TaskAddInHelpers Class Constructors Methods See Also

The TaskAddInHelpers type exposes the following members.

Constructors

Name | Description
TaskAddInHelpers |

Methods

Name | Description
CreateTaskTemplate | Create a task template for this task. A task template is a version of the task that is saved with specific options preset, making it easier for an end user to reuse tasks without having to select all of the options each time. You can call this method from within your implementation of ISASTaskTemplate.CreateTaskTemplate().
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeTaskDisplaySettings | Initialize a task form with its save location and size. This method also ensures that the form is positioned to be visible on the screen.
Languages | Discover which languages are available by detecting the localized files that are installed with the application.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RetrieveTaskDisplaySettings | Overloaded.
StoreTaskDisplaySettings | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TaskAddInHelpers Class
SAS.Tasks.Toolkit.Helpers Namespace


TaskAddInHelpers Constructor

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskAddInHelpers Constructor
TaskAddInHelpers Class See Also

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public TaskAddInHelpers()

See Also

TaskAddInHelpers Class
SAS.Tasks.Toolkit.Helpers Namespace


TaskAddInHelpers Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskAddInHelpers Methods
TaskAddInHelpers Class See Also

The TaskAddInHelpers type exposes the following members.

Methods

Name | Description
CreateTaskTemplate | Create a task template for this task. A task template is a version of the task that is saved with specific options preset, making it easier for an end user to reuse tasks without having to select all of the options each time. You can call this method from within your implementation of ISASTaskTemplate.CreateTaskTemplate().
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeTaskDisplaySettings | Initialize a task form with its save location and size. This method also ensures that the form is positioned to be visible on the screen.
Languages | Discover which languages are available by detecting the localized files that are installed with the application.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RetrieveTaskDisplaySettings | Overloaded.
StoreTaskDisplaySettings | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TaskAddInHelpers Class
SAS.Tasks.Toolkit.Helpers Namespace


CreateTaskTemplate Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskAddInHelpers..::.CreateTaskTemplate Method
TaskAddInHelpers Class See Also

Create a task template for this task. A task template is a version of the task that is saved with specific options preset, making it easier for an end user to reuse tasks without having to select all of the options each time.

You can call this method from within your implementation of ISASTaskTemplate.CreateTaskTemplate().

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub CreateTaskTemplate ( _
    templateName As String, _
    templateDesc As String, _
    category As String, _
    clsid As String, _
    taskName As String, _
    procsUsed As String, _
    xml As String _
)
C#
public static void CreateTaskTemplate(
    string templateName,
    string templateDesc,
    string category,
    string clsid,
    string taskName,
    string procsUsed,
    string xml
)

Parameters

templateName
Type: System..::.String
Name of the template, as supplied by the end user.
templateDesc
Type: System..::.String
Description of the template, as supplied by the end user.
category
Type: System..::.String
Category (or folder) for organizing the template among other templates. This is selected by the end user.
clsid
Type: System..::.String
The class ID (unique identifier) for this type of task. This comes from the ISASTaskDescription.Clsid property in your task.
taskName
Type: System..::.String
The name of this type of task, as it might be displayed in the application menu.
procsUsed
Type: System..::.String
List of SAS procedures used within the task. This is simply for display purposes, and corresponds to the ISASTaskDescription.ProcsUsed property.
xml
Type: System..::.String
The XML representation of the task settings (or options). Your task must be able to read this XML content when set on the ISASTask.XmlState property, and restore all of the task options based on the settings.

Exceptions

Exception | Condition
System.Xml..::.XmlException | Thrown if the xml parameter is not valid XML.

See Also

TaskAddInHelpers Class
SAS.Tasks.Toolkit.Helpers Namespace


InitializeTaskDisplaySettings Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskAddInHelpers..::.InitializeTaskDisplaySettings Method
TaskAddInHelpers Class See Also

Initialize a task form with its save location and size. This method also ensures that the form is positioned to be visible on the screen.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub InitializeTaskDisplaySettings ( _
    taskID As String, _
    form As Control _
)
C#
public static void InitializeTaskDisplaySettings(
    string taskID,
    Control form
)

Parameters

taskID
Type: System..::.String
unique identifier for the task
form
Type: System.Windows.Forms..::.Control
the form object to position

See Also

TaskAddInHelpers Class
SAS.Tasks.Toolkit.Helpers Namespace


Languages Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskAddInHelpers..::.Languages Method
TaskAddInHelpers Class See Also

Discover which languages are available by detecting the localized files that are installed with the application.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Languages ( _
    <OutAttribute> ByRef Items As String() _
) As Integer
C#
public static int Languages(
    out string[] Items
)

Parameters

Items
Type: array< System..::.String >[]()[] %
string array of culture codes, returned as an out parameter

Return Value

the number of languages detected

See Also

TaskAddInHelpers Class
SAS.Tasks.Toolkit.Helpers Namespace


RetrieveTaskDisplaySettings Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskAddInHelpers..::.RetrieveTaskDisplaySettings Method
TaskAddInHelpers Class See Also

Overload List

Name | Description
RetrieveTaskDisplaySettings(String, Int32%, Int32%, Int32%, Int32%, Boolean%, Int32%, Int32%, Int32%, Int32%) |
RetrieveTaskDisplaySettings(String, Int32%, Int32%, Int32%, Int32%) |

See Also

TaskAddInHelpers Class
TaskAddInHelpers Members
SAS.Tasks.Toolkit.Helpers Namespace


RetrieveTaskDisplaySettings Method (String, Int32, Int32, Int32, Int32, Boolean, Int32, Int32, Int32, Int32)

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskAddInHelpers..::.RetrieveTaskDisplaySettings Method (String, Int32%, Int32%, Int32%, Int32%, Boolean%, Int32%, Int32%, Int32%, Int32%)
TaskAddInHelpers Class See Also

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function RetrieveTaskDisplaySettings ( _
    taskID As String, _
    <OutAttribute> ByRef top As Integer, _
    <OutAttribute> ByRef left As Integer, _
    <OutAttribute> ByRef height As Integer, _
    <OutAttribute> ByRef width As Integer, _
    <OutAttribute> ByRef showCode As Boolean, _
    <OutAttribute> ByRef codeTop As Integer, _
    <OutAttribute> ByRef codeLeft As Integer, _
    <OutAttribute> ByRef codeHeight As Integer, _
    <OutAttribute> ByRef codeWidth As Integer _
) As Boolean
C#
public static bool RetrieveTaskDisplaySettings(
    string taskID,
    out int top,
    out int left,
    out int height,
    out int width,
    out bool showCode,
    out int codeTop,
    out int codeLeft,
    out int codeHeight,
    out int codeWidth
)

Parameters

taskID
Type: System..::.String
top
Type: System..::.Int32 %
left
Type: System..::.Int32 %
height
Type: System..::.Int32 %
width
Type: System..::.Int32 %
showCode
Type: System..::.Boolean %
codeTop
Type: System..::.Int32 %
codeLeft
Type: System..::.Int32 %
codeHeight
Type: System..::.Int32 %
codeWidth
Type: System..::.Int32 %

Return Value

See Also

TaskAddInHelpers Class
RetrieveTaskDisplaySettings Overload
SAS.Tasks.Toolkit.Helpers Namespace


RetrieveTaskDisplaySettings Method (String, Int32, Int32, Int32, Int32)

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskAddInHelpers..::.RetrieveTaskDisplaySettings Method (String, Int32%, Int32%, Int32%, Int32%)
TaskAddInHelpers Class See Also

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function RetrieveTaskDisplaySettings ( _
    taskID As String, _
    <OutAttribute> ByRef top As Integer, _
    <OutAttribute> ByRef left As Integer, _
    <OutAttribute> ByRef height As Integer, _
    <OutAttribute> ByRef width As Integer _
) As Boolean
C#
public static bool RetrieveTaskDisplaySettings(
    string taskID,
    out int top,
    out int left,
    out int height,
    out int width
)

Parameters

taskID
Type: System..::.String
top
Type: System..::.Int32 %
left
Type: System..::.Int32 %
height
Type: System..::.Int32 %
width
Type: System..::.Int32 %

Return Value

See Also

TaskAddInHelpers Class
RetrieveTaskDisplaySettings Overload
SAS.Tasks.Toolkit.Helpers Namespace


StoreTaskDisplaySettings Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskAddInHelpers..::.StoreTaskDisplaySettings Method
TaskAddInHelpers Class See Also

Overload List

Name | Description
StoreTaskDisplaySettings(String, Int32, Int32, Int32, Int32, Boolean, Int32, Int32, Int32, Int32) | Store the window location and size for a task dialog.
StoreTaskDisplaySettings(String, Form) | Store the display settings for the task form
StoreTaskDisplaySettings(String, Int32, Int32, Int32, Int32) | Store the window location and size for a task dialog.

See Also

TaskAddInHelpers Class
TaskAddInHelpers Members
SAS.Tasks.Toolkit.Helpers Namespace


StoreTaskDisplaySettings Method (String, Int32, Int32, Int32, Int32, Boolean, Int32, Int32, Int32, Int32)

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskAddInHelpers..::.StoreTaskDisplaySettings Method (String, Int32, Int32, Int32, Int32, Boolean, Int32, Int32, Int32, Int32)
TaskAddInHelpers Class See Also

Store the window location and size for a task dialog.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub StoreTaskDisplaySettings ( _
    taskID As String, _
    top As Integer, _
    left As Integer, _
    height As Integer, _
    width As Integer, _
    showCode As Boolean, _
    codeTop As Integer, _
    codeLeft As Integer, _
    codeHeight As Integer, _
    codeWidth As Integer _
)
C#
public static void StoreTaskDisplaySettings(
    string taskID,
    int top,
    int left,
    int height,
    int width,
    bool showCode,
    int codeTop,
    int codeLeft,
    int codeHeight,
    int codeWidth
)

Parameters

taskID
Type: System..::.String
Unique ID for the task
top
Type: System..::.Int32
Top screen position
left
Type: System..::.Int32
Left screen position
height
Type: System..::.Int32
Height of the form
width
Type: System..::.Int32
Width of the form
showCode
Type: System..::.Boolean
codeTop
Type: System..::.Int32
codeLeft
Type: System..::.Int32
codeHeight
Type: System..::.Int32
codeWidth
Type: System..::.Int32

See Also

TaskAddInHelpers Class
StoreTaskDisplaySettings Overload
SAS.Tasks.Toolkit.Helpers Namespace


StoreTaskDisplaySettings Method (String, Form)

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskAddInHelpers..::.StoreTaskDisplaySettings Method (String, Form)
TaskAddInHelpers Class See Also

Store the display settings for the task form

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub StoreTaskDisplaySettings ( _
    taskID As String, _
    form As Form _
)
C#
public static void StoreTaskDisplaySettings(
    string taskID,
    Form form
)

Parameters

taskID
Type: System..::.String
unique identifier for the task
form
Type: System.Windows.Forms..::.Form
the form object whose position we're storing

See Also

TaskAddInHelpers Class
StoreTaskDisplaySettings Overload
SAS.Tasks.Toolkit.Helpers Namespace


StoreTaskDisplaySettings Method (String, Int32, Int32, Int32, Int32)

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskAddInHelpers..::.StoreTaskDisplaySettings Method (String, Int32, Int32, Int32, Int32)
TaskAddInHelpers Class See Also

Store the window location and size for a task dialog.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub StoreTaskDisplaySettings ( _
    taskID As String, _
    top As Integer, _
    left As Integer, _
    height As Integer, _
    width As Integer _
)
C#
public static void StoreTaskDisplaySettings(
    string taskID,
    int top,
    int left,
    int height,
    int width
)

Parameters

taskID
Type: System..::.String
Unique ID for the task
top
Type: System..::.Int32
Top screen position
left
Type: System..::.Int32
Left screen position
height
Type: System..::.Int32
Height of the form
width
Type: System..::.Int32
Width of the form

See Also

TaskAddInHelpers Class
StoreTaskDisplaySettings Overload
SAS.Tasks.Toolkit.Helpers Namespace


TaskDataHelpers Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskDataHelpers Class
Members See Also

Contains helper methods to assist with task data sources from the application.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TaskDataHelpers
C#
public sealed class TaskDataHelpers

Inheritance Hierarchy

System..::.Object
SAS.Tasks.Toolkit.Helpers..::.TaskDataHelpers

See Also

TaskDataHelpers Members
SAS.Tasks.Toolkit.Helpers Namespace


TaskDataHelpers Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskDataHelpers Members
TaskDataHelpers Class Constructors Methods See Also

The TaskDataHelpers type exposes the following members.

Constructors

Name | Description
TaskDataHelpers |

Methods

Name Description
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
GetDistinctValues
Fetch the distinct values for a SAS data column. This process submits a SAS program to discover the distinct values for a named column in the data set that you specify.

Remarks

This method can take a while to process depending on the size and type of SAS data.
GetHashCode
Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table.
(Inherited from Object.)
GetSasCodeReference
Get the SAS-syntax-ready string for this data source, including any additional data set options such as password, obs, and firstobs settings.
GetType
Gets the Type of the current instance.
(Inherited from Object.)
MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

TaskDataHelpers Class
SAS.Tasks.Toolkit.Helpers Namespace


TaskDataHelpers Constructor

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskDataHelpers Constructor
TaskDataHelpers Class See Also

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public TaskDataHelpers()

See Also

TaskDataHelpers Class
SAS.Tasks.Toolkit.Helpers Namespace


TaskDataHelpers Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskDataHelpers Methods
TaskDataHelpers Class See Also

The TaskDataHelpers type exposes the following members.

Methods

Name Description
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
GetDistinctValues
Fetch the distinct values for a SAS data column. This process submits a SAS program to discover the distinct values for a named column in the data set that you specify.

Remarks

This method can take a while to process depending on the size and type of SAS data.
GetHashCode
Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table.
(Inherited from Object.)
GetSasCodeReference
Get the SAS-syntax-ready string for this data source, including any additional data set options such as password, obs, and firstobs settings.
GetType
Gets the Type of the current instance.
(Inherited from Object.)
MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

TaskDataHelpers Class
SAS.Tasks.Toolkit.Helpers Namespace


GetDistinctValues Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskDataHelpers..::.GetDistinctValues Method
TaskDataHelpers Class See Also

Fetch the distinct values for a SAS data column. This process submits a SAS program to discover the distinct values for a named column in the data set that you specify.

Remarks

This method can take a while to process depending on the size and type of SAS data.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetDistinctValues ( _
    consumer As ISASTaskConsumer3, _
    taskData As ISASTaskData2, _
    columnName As String, _
    format As String _
) As IList(Of String)
C#
public static IList<string> GetDistinctValues(
    ISASTaskConsumer3 consumer,
    ISASTaskData2 taskData,
    string columnName,
    string format
)

Parameters

consumer
Type: SAS.Shared.AddIns..::.ISASTaskConsumer3
The ISASTaskConsumer3 handle to the application.
taskData
Type: SAS.Shared.AddIns..::.ISASTaskData2
The ISASTaskData2 interface to the selected data.
columnName
Type: System..::.String
The name of the column to analyze.
format
Type: System..::.String
The name of a SAS format to apply to the column for this operation. If null or empty, the SAS format assigned within the data set is used.

Return Value

A list of the distinct values for the column.

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown if any of the key arguments are null.
SAS.Tasks.Toolkit.Data..::.SasDataException | Thrown if the SAS server (the server where the data resides) is already busy processing SAS program jobs.

See Also

TaskDataHelpers Class
SAS.Tasks.Toolkit.Helpers Namespace


GetSasCodeReference Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskDataHelpers..::.GetSasCodeReference Method
TaskDataHelpers Class See Also

Get the SAS-syntax-ready string for this data source, including any additional data set options such as password, obs, and firstobs settings.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetSasCodeReference ( _
    taskData As ISASTaskData2 _
) As String
C#
public static string GetSasCodeReference(
    ISASTaskData2 taskData
)

Parameters

taskData
Type: SAS.Shared.AddIns..::.ISASTaskData2
The ISASTaskData2 reference from the application.

Return Value

a string with the data reference

Exceptions

Exception | Condition
System..::.ArgumentNullException | Thrown if taskData argument is null.

See Also

TaskDataHelpers Class
SAS.Tasks.Toolkit.Helpers Namespace


TaskOptions Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskOptions Class
Members See Also

Helper class to interpret the ISASTaskOptions interface

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TaskOptions
C#
public sealed class TaskOptions

Inheritance Hierarchy

System..::.Object
SAS.Tasks.Toolkit.Helpers..::.TaskOptions

See Also

TaskOptions Members
SAS.Tasks.Toolkit.Helpers Namespace


TaskOptions Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskOptions Members
TaskOptions Class Constructors Methods Properties See Also

The TaskOptions type exposes the following members.

Constructors

Name | Description
TaskOptions | Create TaskOptions object for the current task, given its consumer handle.

Methods

Name | Description
DefaultOutputLibraryForServer | The default SAS library (libref) to use for output on a particular SAS server. Typical values might be WORK, SASUSER, or EGTASK. If the SAS server of interest is the AssignedServer for this task, then you can use the DefaultOutputLibrary property instead. This keys off of an application option that the end user can control.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDefaultFootnoteText | Get the default text to use in a FOOTNOTE statement, as specified in the application options.
GetDefaultTitleText | Get the default text to use in a TITLE statement, as specified in the application options.
GetEffectiveGraphDevice | Get the graph device for the current task, considering application options and task-level results options that might override them.
GetEffectiveStyle | Get the ODS style that will be used for the active ODS destination, considering application options and task-level results options that might override them.
GetEffectiveStylesheet | Get the stylesheet that will be used for the active ODS destination, considering application options and task-level results options that might override them.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MapDeviceToSASKeyword | Given a SasGraphDevice value, map the value to a SAS keyword for use in GOPTIONS DEV= code.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DefaultOutputLibrary | The default SAS library (libref) to use for output. Typical values might be WORK, SASUSER, or EGTASK. This keys off of an application option that the end user can control.
FirstObsSetting | FIRSTOBS= setting -- the starting record to process in this task.
IsHtmlActive | Returns true if HTML is an active ODS destination for this task.
IsListingActive | Returns true if Listing (text) is an active ODS destination for this task.
IsPdfActive | Returns true if PDF is an active ODS destination for this task.
IsRtfActive | Returns true if RTF is an active ODS destination for this task.
IsSasReportActive | Returns true if SAS Report is an active ODS destination for this task.
NObsSetting | OBS= setting - the maximum number of records to process in this task.
ShowColumnLabels | Whether to display the friendly full label or the syntax-ready column name when showing data columns. This keys off of an application option that the end user can control.
ShowColumnsInAlphaOrder | Whether to show a list of data columns in alphabetical order (versus using the order in which they appear in the data set). This keys off of an application option that the end user can control.
UseApplicationDefaults | Should the options for this task override the global options set within the application?

See Also

TaskOptions Class
SAS.Tasks.Toolkit.Helpers Namespace


TaskOptions Constructor

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskOptions Constructor
TaskOptions Class See Also

Create TaskOptions object for the current task, given its consumer handle.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    consumer As ISASTaskConsumer _
)
C#
public TaskOptions(
    ISASTaskConsumer consumer
)

Parameters

consumer
Type: SAS.Shared.AddIns..::.ISASTaskConsumer
The ISASTaskConsumer value passed to the task in its Connect() call.

Exceptions

Exception | Condition
System..::.ArgumentNullException | thrown if consumer argument is null
System..::.NotSupportedException | thrown if consumer does not support ISASTaskConsumer3.

See Also

TaskOptions Class
SAS.Tasks.Toolkit.Helpers Namespace


TaskOptions Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskOptions Methods
TaskOptions Class See Also

The TaskOptions type exposes the following members.

Methods

Name | Description
DefaultOutputLibraryForServer | The default SAS library (libref) to use for output on a particular SAS server. Typical values might be WORK, SASUSER, or EGTASK. If the SAS server of interest is the AssignedServer for this task, then you can use the DefaultOutputLibrary property instead. This keys off of an application option that the end user can control.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDefaultFootnoteText | Get the default text to use in a FOOTNOTE statement, as specified in the application options.
GetDefaultTitleText | Get the default text to use in a TITLE statement, as specified in the application options.
GetEffectiveGraphDevice | Get the graph device for the current task, considering application options and task-level results options that might override them.
GetEffectiveStyle | Get the ODS style that will be used for the active ODS destination, considering application options and task-level results options that might override them.
GetEffectiveStylesheet | Get the stylesheet that will be used for the active ODS destination, considering application options and task-level results options that might override them.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MapDeviceToSASKeyword | Given a SasGraphDevice value, map the value to a SAS keyword for use in GOPTIONS DEV= code.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TaskOptions Class
SAS.Tasks.Toolkit.Helpers Namespace


DefaultOutputLibraryForServer Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskOptions..::.DefaultOutputLibraryForServer Method
TaskOptions Class See Also

The default SAS library (libref) to use for output on a particular SAS server. Typical values might be WORK, SASUSER, or EGTASK. If the SAS server of interest is the AssignedServer for this task, then you can use the DefaultOutputLibrary property instead.

This keys off of an application option that the end user can control.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Function DefaultOutputLibraryForServer ( _
    server As String _
) As String
C#
public string DefaultOutputLibraryForServer(
    string server
)

Parameters

server
Type: System..::.String
Name of the server.

Return Value

Name of the libref

See Also

TaskOptions Class
SAS.Tasks.Toolkit.Helpers Namespace


GetDefaultFootnoteText Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskOptions..::.GetDefaultFootnoteText Method
TaskOptions Class See Also

Get the default text to use in a FOOTNOTE statement, as specified in the application options.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDefaultFootnoteText As String
C#
public string GetDefaultFootnoteText()

Return Value

a string with the footnote text

See Also

TaskOptions Class
SAS.Tasks.Toolkit.Helpers Namespace


GetDefaultTitleText Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskOptions..::.GetDefaultTitleText Method
TaskOptions Class See Also

Get the default text to use in a TITLE statement, as specified in the application options.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDefaultTitleText As String
C#
public string GetDefaultTitleText()

Return Value

a string with the title text

See Also

TaskOptions Class
SAS.Tasks.Toolkit.Helpers Namespace


GetEffectiveGraphDevice Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskOptions..::.GetEffectiveGraphDevice Method
TaskOptions Class See Also

Get the graph device for the current task, considering application options and task-level results options that might override them.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Function GetEffectiveGraphDevice As SasGraphDevice
C#
public SasGraphDevice GetEffectiveGraphDevice()

Return Value

The effective graph device option.

See Also

TaskOptions Class
SAS.Tasks.Toolkit.Helpers Namespace


GetEffectiveStyle Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskOptions..::.GetEffectiveStyle Method
TaskOptions Class See Also

Get the ODS style that will be used for the active ODS destination, considering application options and task-level results options that might override them.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Function GetEffectiveStyle ( _
    destType As OdsDestination _
) As String
C#
public string GetEffectiveStyle(
    OdsDestination destType
)

Parameters

destType
Type: SAS.Shared.AddIns..::.OdsDestination
The ODS destination that the style will apply to.

Return Value

Name of the ODS style. Empty string if not found.

See Also

TaskOptions Class
SAS.Tasks.Toolkit.Helpers Namespace


GetEffectiveStylesheet Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskOptions..::.GetEffectiveStylesheet Method
TaskOptions Class See Also

Get the stylesheet that will be used for the active ODS destination, considering application options and task-level results options that might override them.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Function GetEffectiveStylesheet ( _
    destType As OdsDestination _
) As String
C#
public string GetEffectiveStylesheet(
    OdsDestination destType
)

Parameters

destType
Type: SAS.Shared.AddIns..::.OdsDestination
The ODS destination that the stylesheet should apply to -- must be Html or Report. (Other types -- such as Rtf, Pdf, and Listing -- do not support stylesheets.)

Return Value

Path to the stylesheet. Empty string if not found.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | thrown if OdsDestination is not Html or Report

See Also

TaskOptions Class
SAS.Tasks.Toolkit.Helpers Namespace


MapDeviceToSASKeyword Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskOptions..::.MapDeviceToSASKeyword Method
TaskOptions Class See Also

Given a SasGraphDevice value, map the value to a SAS keyword for use in GOPTIONS DEV= code.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function MapDeviceToSASKeyword ( _
    device As SasGraphDevice _
) As String
C#
public static string MapDeviceToSASKeyword(
    SasGraphDevice device
)

Parameters

device
Type: SAS.Shared.AddIns..::.SasGraphDevice
The device

Return Value

SAS keyword value for the device

See Also

TaskOptions Class
SAS.Tasks.Toolkit.Helpers Namespace


TaskOptions Properties

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskOptions Properties
TaskOptions Class See Also

The TaskOptions type exposes the following members.

Properties

Name | Description
DefaultOutputLibrary | The default SAS library (libref) to use for output. Typical values might be WORK, SASUSER, or EGTASK. This keys off of an application option that the end user can control.
FirstObsSetting | FIRSTOBS= setting -- the starting record to process in this task.
IsHtmlActive | Returns true if HTML is an active ODS destination for this task.
IsListingActive | Returns true if Listing (text) is an active ODS destination for this task.
IsPdfActive | Returns true if PDF is an active ODS destination for this task.
IsRtfActive | Returns true if RTF is an active ODS destination for this task.
IsSasReportActive | Returns true if SAS Report is an active ODS destination for this task.
NObsSetting | OBS= setting - the maximum number of records to process in this task.
ShowColumnLabels | Whether to display the friendly full label or the syntax-ready column name when showing data columns. This keys off of an application option that the end user can control.
ShowColumnsInAlphaOrder | Whether to show a list of data columns in alphabetical order (versus using the order in which they appear in the data set). This keys off of an application option that the end user can control.
UseApplicationDefaults | Should the options for this task override the global options set within the application?

See Also

TaskOptions Class
SAS.Tasks.Toolkit.Helpers Namespace


DefaultOutputLibrary Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskOptions..::.DefaultOutputLibrary Property
TaskOptions Class See Also

The default SAS library (libref) to use for output. Typical values might be WORK, SASUSER, or EGTASK. This keys off of an application option that the end user can control.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DefaultOutputLibrary As String
C#
public string DefaultOutputLibrary { get; }

See Also

TaskOptions Class
SAS.Tasks.Toolkit.Helpers Namespace


FirstObsSetting Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskOptions..::.FirstObsSetting Property
TaskOptions Class See Also

FIRSTOBS= setting -- the starting record to process in this task.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property FirstObsSetting As Integer
C#
public int FirstObsSetting { get; set; }

See Also

TaskOptions Class
SAS.Tasks.Toolkit.Helpers Namespace


IsHtmlActive Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskOptions..::.IsHtmlActive Property
TaskOptions Class See Also

Returns true if HTML is an active ODS destination for this task.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsHtmlActive As Boolean
C#
public bool IsHtmlActive { get; }

See Also

TaskOptions Class
SAS.Tasks.Toolkit.Helpers Namespace


IsListingActive Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskOptions..::.IsListingActive Property
TaskOptions Class See Also

Returns true if Listing (text) is an active ODS destination for this task.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsListingActive As Boolean
C#
public bool IsListingActive { get; }

See Also

TaskOptions Class
SAS.Tasks.Toolkit.Helpers Namespace


IsPdfActive Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskOptions..::.IsPdfActive Property
TaskOptions Class See Also

Returns true if PDF is an active ODS destination for this task.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsPdfActive As Boolean
C#
public bool IsPdfActive { get; }

See Also

TaskOptions Class
SAS.Tasks.Toolkit.Helpers Namespace


IsRtfActive Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskOptions..::.IsRtfActive Property
TaskOptions Class See Also

Returns true if RTF is an active ODS destination for this task.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsRtfActive As Boolean
C#
public bool IsRtfActive { get; }

See Also

TaskOptions Class
SAS.Tasks.Toolkit.Helpers Namespace


IsSasReportActive Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskOptions..::.IsSasReportActive Property
TaskOptions Class See Also

Returns true if SAS Report is an active ODS destination for this task.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSasReportActive As Boolean
C#
public bool IsSasReportActive { get; }

See Also

TaskOptions Class
SAS.Tasks.Toolkit.Helpers Namespace


NObsSetting Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskOptions..::.NObsSetting Property
TaskOptions Class See Also

OBS= setting - the maximum number of records to process in this task.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property NObsSetting As Integer
C#
public int NObsSetting { get; set; }

See Also

TaskOptions Class
SAS.Tasks.Toolkit.Helpers Namespace


ShowColumnLabels Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskOptions..::.ShowColumnLabels Property
TaskOptions Class See Also

Whether to display the friendly full label or the syntax-ready column name when showing data columns. This keys off of an application option that the end user can control.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ShowColumnLabels As Boolean
C#
public bool ShowColumnLabels { get; }

See Also

TaskOptions Class
SAS.Tasks.Toolkit.Helpers Namespace


ShowColumnsInAlphaOrder Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskOptions..::.ShowColumnsInAlphaOrder Property
TaskOptions Class See Also

Whether to show a list of data columns in alphabetical order (versus using the order in which they appear in the data set). This keys off of an application option that the end user can control.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ShowColumnsInAlphaOrder As Boolean
C#
public bool ShowColumnsInAlphaOrder { get; }

See Also

TaskOptions Class
SAS.Tasks.Toolkit.Helpers Namespace


UseApplicationDefaults Property

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
TaskOptions..::.UseApplicationDefaults Property
TaskOptions Class See Also

Should the options for this task override the global options set within the application?

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Property UseApplicationDefaults As Boolean
C#
public bool UseApplicationDefaults { get; set; }

See Also

TaskOptions Class
SAS.Tasks.Toolkit.Helpers Namespace


UtilityFunctions Class

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
UtilityFunctions Class
Members See Also

Contains a number of utilities to aid in generating useful and valid SAS programs from within a custom task.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class UtilityFunctions
C#
public sealed class UtilityFunctions

Inheritance Hierarchy

System..::.Object
SAS.Tasks.Toolkit.Helpers..::.UtilityFunctions

See Also

UtilityFunctions Members
SAS.Tasks.Toolkit.Helpers Namespace


UtilityFunctions Members

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
UtilityFunctions Members
UtilityFunctions Class Methods See Also

The UtilityFunctions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetSasDateFromDateTimeValue | Calculates a SAS date (number of days since January 1, 1960) from a .NET System.DateTime value.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValidSasName | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadFileFromAssembly | Reads an embedded text file from an assembly.
SASValidLiteral | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UtilityFunctions Class
SAS.Tasks.Toolkit.Helpers Namespace


UtilityFunctions Methods

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
UtilityFunctions Methods
UtilityFunctions Class See Also

The UtilityFunctions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetSasDateFromDateTimeValue | Calculates a SAS date (number of days since January 1, 1960) from a .NET System.DateTime value.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValidSasName | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadFileFromAssembly | Reads an embedded text file from an assembly.
SASValidLiteral | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UtilityFunctions Class
SAS.Tasks.Toolkit.Helpers Namespace


GetSasDateFromDateTimeValue Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
UtilityFunctions..::.GetSasDateFromDateTimeValue Method
UtilityFunctions Class See Also

Calculates a SAS date (number of days since January 1, 1960) from a .NET System.DateTime value.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetSasDateFromDateTimeValue ( _
    dv As DateTime _
) As Double
C#
public static double GetSasDateFromDateTimeValue(
    DateTime dv
)

Parameters

dv
Type: System..::.DateTime
the DateTime value

Return Value

a double that represents the SAS date

See Also

UtilityFunctions Class
SAS.Tasks.Toolkit.Helpers Namespace


GetValidSasName Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
UtilityFunctions..::.GetValidSasName Method
UtilityFunctions Class See Also

Overload List

Name | Description
GetValidSasName(String) | Replaces any character that is invalid for use within a standard SAS identifier with underscores. NOTE: There is a possibilty that the returned string will be one character longer than the supplied string. This situation occurs if the first character of the supplied string is a numeric digit.
GetValidSasName(String, Int32) | Replaces any character that is invalid for use within a standard SAS identifier with underscores. NOTE: There is a possibilty that the returned string will be one character longer than the supplied string. This situation occurs if the first character of the supplied string is a numeric digit.

See Also

UtilityFunctions Class
UtilityFunctions Members
SAS.Tasks.Toolkit.Helpers Namespace


GetValidSasName Method (String)

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
UtilityFunctions..::.GetValidSasName Method (String)
UtilityFunctions Class See Also

Replaces any character that is invalid for use within a standard SAS identifier with underscores. NOTE: There is a possibilty that the returned string will be one character longer than the supplied string. This situation occurs if the first character of the supplied string is a numeric digit.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetValidSasName ( _
    name As String _
) As String
C#
public static string GetValidSasName(
    string name
)

Parameters

name
Type: System..::.String
The name to be turned into a vaild SAS name.

Return Value

The modified variable name, which will be no longer that 32 characters in length

See Also

UtilityFunctions Class
GetValidSasName Overload
SAS.Tasks.Toolkit.Helpers Namespace


GetValidSasName Method (String, Int32)

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
UtilityFunctions..::.GetValidSasName Method (String, Int32)
UtilityFunctions Class See Also

Replaces any character that is invalid for use within a standard SAS identifier with underscores. NOTE: There is a possibilty that the returned string will be one character longer than the supplied string. This situation occurs if the first character of the supplied string is a numeric digit.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetValidSasName ( _
    name As String, _
    maxLength As Integer _
) As String
C#
public static string GetValidSasName(
    string name,
    int maxLength
)

Parameters

name
Type: System..::.String
The name to be turned into a vaild SAS name.
maxLength
Type: System..::.Int32
The maximum length of the string that you want returned.

Return Value

The modified variable name.

See Also

UtilityFunctions Class
GetValidSasName Overload
SAS.Tasks.Toolkit.Helpers Namespace


ReadFileFromAssembly Method

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
UtilityFunctions..::.ReadFileFromAssembly Method
UtilityFunctions Class See Also

Reads an embedded text file from an assembly.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ReadFileFromAssembly ( _
    filename As String _
) As String
C#
public static string ReadFileFromAssembly(
    string filename
)

Parameters

filename
Type: System..::.String
The filename to read.

Return Value

The contents of the file.

See Also

UtilityFunctions Class
SAS.Tasks.Toolkit.Helpers Namespace


SASValidLiteral Method

[image] [image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
UtilityFunctions..::.SASValidLiteral Method
UtilityFunctions Class See Also

Overload List

Name | Description
SASValidLiteral(String) | Wraps the string (a SAS variable) in literal syntax if necessary.
SASValidLiteral(String, Boolean) | Wraps the string (a SAS variable) in literal syntax if necessary and optionally includes the SAS literal suffix character ('n').
SASValidLiteral(String, Boolean, Boolean) | Wraps the string (a SAS variable) in literal syntax if necessary and optionally includes the SAS literal suffix character ('n').

See Also

UtilityFunctions Class
UtilityFunctions Members
SAS.Tasks.Toolkit.Helpers Namespace


SASValidLiteral Method (String)

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
UtilityFunctions..::.SASValidLiteral Method (String)
UtilityFunctions Class See Also

Wraps the string (a SAS variable) in literal syntax if necessary.

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function SASValidLiteral ( _
    text As String _
) As String
C#
public static string SASValidLiteral(
    string text
)

Parameters

text
Type: System..::.String
Variable name to be converted to a valid SAS literal with trailing SAS literal suffix character ('n').

Return Value

The variable name in the form of a quoted SAS literal.

See Also

UtilityFunctions Class
SASValidLiteral Overload
SAS.Tasks.Toolkit.Helpers Namespace


SASValidLiteral Method (String, Boolean)

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
UtilityFunctions..::.SASValidLiteral Method (String, Boolean)
UtilityFunctions Class See Also

Wraps the string (a SAS variable) in literal syntax if necessary and optionally includes the SAS literal suffix character ('n').

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function SASValidLiteral ( _
    text As String, _
    noTrailingN As Boolean _
) As String
C#
public static string SASValidLiteral(
    string text,
    bool noTrailingN
)

Parameters

text
Type: System..::.String
Variable name to be converted to a valid SAS literal.
noTrailingN
Type: System..::.Boolean
A flag indicating whether the trailing 'N' should be placed at the end of the string.

Return Value

The variable name in the form of a quoted SAS literal.

See Also

UtilityFunctions Class
SASValidLiteral Overload
SAS.Tasks.Toolkit.Helpers Namespace


SASValidLiteral Method (String, Boolean, Boolean)

[image]

SAS Enterprise Guide 4.2 and SAS Add-In 4.2 for Microsoft Office: Custom Tasks API
UtilityFunctions..::.SASValidLiteral Method (String, Boolean, Boolean)
UtilityFunctions Class See Also

Wraps the string (a SAS variable) in literal syntax if necessary and optionally includes the SAS literal suffix character ('n').

Namespace: SAS.Tasks.Toolkit.Helpers
Assembly: SAS.Tasks.Toolkit (in SAS.Tasks.Toolkit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function SASValidLiteral ( _
    text As String, _
    noTrailingN As Boolean, _
    useDoubleQuotes As Boolean _
) As String
C#
public static string SASValidLiteral(
    string text,
    bool noTrailingN,
    bool useDoubleQuotes
)

Parameters

text
Type: System..::.String
Variable name to be converted to a valid SAS literal.
noTrailingN
Type: System..::.Boolean
A flag indicating whether the trailing 'N' should be placed at the end of the string.
useDoubleQuotes
Type: System..::.Boolean
A flag indicating whether to use single quotes or double quotes. If true, double quotes are used.

Return Value

The variable name in the form of a quoted SAS literal.

See Also

UtilityFunctions Class
SASValidLiteral Overload
SAS.Tasks.Toolkit.Helpers Namespace