SAS® Activity-Based Management 6.1 Tutorial
Contents

Introduction .............................................................................................................. 1
  Tutorial conventions ................................................................................................. 1
  Fonts ......................................................................................................................... 1
  Procedures ................................................................................................................. 1
  Notes and Tips .......................................................................................................... 2
  Illustrations .............................................................................................................. 2
  Terminology ............................................................................................................. 2
  Online Help ............................................................................................................... 2
  Technical support ..................................................................................................... 2
  Additional training and tutorials ............................................................................. 3

Activity-Based Management ..................................................................................... 4
  The ABC model and CAM-I methodology ............................................................... 4
    The Cost Assignment View ...................................................................................... 5
    The Process View ................................................................................................... 5
  SAS Activity-Based Management models ............................................................... 6
    Modules ................................................................................................................... 6
    Dimensions ............................................................................................................. 6
  Basic steps to building a model .............................................................................. 7
  Parcel Express ........................................................................................................ 7

Getting Started ......................................................................................................... 8
  Logging in ............................................................................................................... 8
  The home page ....................................................................................................... 9
  Model home page .................................................................................................. 10
  Model mode and module pages ............................................................................. 10
  Assignments panes ............................................................................................... 11
  Column layouts ..................................................................................................... 12
    Properties, attributes, and dimensions in layouts ............................................... 13
  Reports .................................................................................................................... 13
  OLAP cubes .......................................................................................................... 13
## Contents

**Fixed and variable quantities**.........................................................................................................................55
  Variable quantities...................................................................................................................................................55
  Fixed quantities.........................................................................................................................................................55
**Creating external units and bills of costs**............................................................................................................55

### Entering Output, Sales, and Revenue Data

**Entering output quantities**........................................................................................................................................59
**Entering sales volumes**............................................................................................................................................60
**Entering revenue and calculating profit**...........................................................................................................62

### Adding Attributes

**Types of attributes**................................................................................................................................................64
  Text attributes..........................................................................................................................................................64
  Numeric attributes..................................................................................................................................................65
  Dimension and dimension member attributes....................................................................................................65
  Boolean attributes..................................................................................................................................................65
**Creating attributes**...............................................................................................................................................65
**Entering attribute quantities**....................................................................................................................................66

### Generating Reports

**Report templates**................................................................................................................................................68
**Creating a report**..................................................................................................................................................69
**Working with reports**............................................................................................................................................71
  Navigating reports................................................................................................................................................71
  Saving report data................................................................................................................................................71
  Configuring reports...............................................................................................................................................72

### Using OLAP Cubes for Analysis

**Cube overview**....................................................................................................................................................74
**Types of cubes**...................................................................................................................................................74
  Multi-stage contributions cube.............................................................................................................................74
  Resource contributions cube..............................................................................................................................75
  Single-stage contributions cube..........................................................................................................................75
**Generating cubes**...............................................................................................................................................75
**Creating OLAP views**.........................................................................................................................................76
**Analyzing OLAP cubes**......................................................................................................................................77
  Selecting and displaying dimensions in cubes....................................................................................................77
  Using measures in cubes.......................................................................................................................................81
  Using the Decomposition Tree..........................................................................................................................84
**Saving OLAP views and exporting cubes**..........................................................................................................87

### Finishing Up

**Parcel Express conclusions**...............................................................................................................................88

---

*SAS Activity-Based Management 6.1 Tutorial*

Copyright © 2003 SAS Institute Inc. All Rights Reserved.
<table>
<thead>
<tr>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>Additional features .......................................................................... 88</td>
</tr>
<tr>
<td>What to do next ............................................................................. 89</td>
</tr>
<tr>
<td>Index ........................................................................................... 90</td>
</tr>
</tbody>
</table>
Introduction

This tutorial is intended to familiarize you with the basic modeling concepts that are used in SAS Activity-Based Management software. To complete the model-building process, move through this tutorial from beginning to end, exactly as it is presented.

If you are new to the discipline of activity-based management (ABM), you might benefit more from this tutorial by first learning about the concept. A number of books and articles present excellent overviews. Even without this background, you will learn some basic ABM concepts by completing this tutorial.

Even though you might know ABM, work through this tutorial to become familiar with the SAS Activity-Based Management software—the concepts, terminology, commands, and dialog boxes.

Tutorial conventions

This section discusses the conventions that are used throughout this tutorial.

**Fonts**

<table>
<thead>
<tr>
<th>This Font</th>
<th>Represents</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Monospace</strong></td>
<td>Files, folders, and path names</td>
<td>Open the model named <em>Parcel Express</em>.</td>
</tr>
<tr>
<td><strong>Bold</strong></td>
<td>Menu &gt; Command</td>
<td>Select <strong>File &gt; Save Model As.</strong></td>
</tr>
<tr>
<td></td>
<td>User Input</td>
<td>Type <em>Parcel Express</em>.</td>
</tr>
<tr>
<td></td>
<td>User interface elements such as menus, dialog boxes, buttons, or list items</td>
<td>Select <strong>Calculate Specific Modules.</strong></td>
</tr>
</tbody>
</table>

**Procedures**

A procedure is a task that includes a set of numbered step-by-step instructions. Some steps are followed by a comment or an explanation. A section that has the following format convention indicates a procedure:

- ![Begin this tutorial](image)
  1. Perform step one.
     
     Explanatory comments and illustrations, which explain and display results of proper completion of preceding steps, are included between steps when necessary.
  2. Perform step two.
Notes and Tips
A note indicates additional information. This is the convention for indicating a note:

Note: Text that is set off in this manner presents important information.

The format for a tip is similar.

Illustrations
Depending upon your display settings, and the number of times that you perform a step or procedure, the information in the windows might differ slightly from the illustrations that are presented in this tutorial. If you enter, then delete, then re-create accounts and cost elements, the reference number might differ from the illustration. The displayed order of accounts might differ if you close and reopen the model. Consider the illustrations to be guides.

Illustrations will usually show only the pertinent portions of the screen that are being discussed.

Terminology
This tutorial refers to both the discipline of activity-based management (ABM) and the SAS Activity-Based Management solution. References to the discipline appear in lowercase or by abbreviation. The SAS solution is always capitalized.

The discipline of activity-based management has a set of specialized terms. Some are used in this tutorial precisely because of their specialized meaning to the theory and practice of ABM. As these terms are introduced, this tutorial provides brief definitions. More complete definitions can be found in the CAM-I Glossary of Activity-Based Management.

Online Help
The online Help is a comprehensive information system that has full text search capabilities. It includes:

- Detailed step-by-step instructions to complete specific tasks
- Information about features
- Reference material

Technical support
If you encounter problems that you cannot solve by reading the online Help or this tutorial, refer to the Worldwide Technical Support topic in the online Help.
Additional training and tutorials

Additional training and tutorials can be found at the SAS Web site and companion Web site, http://www.bettermanagement.com. BetterManagement.com offers in-depth content about selected management concepts that are aimed at improving an organization’s performance. The Web site is a comprehensive source for performance management information and resources including training and tutorial materials.

Topics that are covered on the Web include value-based management, profitability analysis, strategic enterprise management, activity-based costing/management, business intelligence, performance measurement.
Activity-Based Management

Activity-based management (ABM) is a discipline that allows companies to manage activities and processes as a means of improving organizational performance and the value received by its customer. By applying direct and indirect business costs to activities, the SAS Activity-Based Management solution enables managers to get a true understanding of the costs and profits that are associated with a product, customer, service, or business process. It supports ongoing profitability analysis, cost-management initiatives, shared services management, planning and budgeting efforts, and capacity optimization.

The basic tool of ABM is activity-based costing (ABC), which more accurately tracks costs than traditional methods. Two critical limitations of traditional cost accounting systems are:

- The inability to report individual product, service, customer, or process costs to a reasonable level of accuracy
- The inability to provide useful feedback to management for the purpose of operational control

Often, managers of complex organizations make important decisions about pricing, product and customer mix, resource allocations, and budgeting based on inaccurate and inappropriate cost and profitability information.

Using SAS Activity-Based Management, you build one or more models that apply direct and indirect organizational costs to specific activities and processes. As a result, managers are able to see actual cost assignments and their bottom-line impacts from an operational perspective. Managers get a true understanding of the cause-and-effect relationships that link resources and processes to outputs. Thus, business planners can easily forecast resource requirements, create budgets, and optimize capacity usage.

The ABC model and CAM-I methodology

ABC assumes that activities cause expenditure of resources and that cost objects—the results of activities or products and services produced—create the demand for activities.

The Consortium for Advanced Manufacturing International (CAM-I) develops methods to define critical business issues and to model effective strategies and solutions that resolve cost and resource management issues. SAS Activity-Based Management uses the CAM-I methodology for activity-based model development.
The Cost Assignment View

An ABM system enables you to identify the activities that are performed, associate resources (expenditures) with those activities, and flow the cost of activities to cost objects. Resource drivers (typically, general ledger entries such as payroll, utilities, or materials) drive expenditures to activities. Activity drivers (such as the number of parts or setups) drive activity consumption to cost objects. Types of cost objects are: products, services, markets, distribution channels, engineering projects, or customers.

The Process View

An ABM system enables you to expose the relationship between why work is done and the results of that work. In ABM terms, cost drivers drive the reason for activities and the effort that is needed to engage in the activities. Performance measures drive the achieved results of activities—the efficiency, the required completion time, and the quality of the activities that were performed.

SAS Activity-Based Management models

The basic container for ABM information in SAS Activity-Based Management software is the model. A meaningful ABM model reflects the organization that it is modeling and uses terms that are familiar to the people who work there. The structural elements of a model should be named after elements that are present in the organizational environment. For example, a company’s general ledger account names, such as Wages and Depreciation, can be used to name and reference the Resource accounts in the ABM model; the hierarchy of processes in a company can be applied to the Activity accounts in the model.

Modules

A model consists of three basic modules, which reflect the CAM-I definitions:

- **Resource**: Contains the expenses (or costs), such as salaries, materials, and depreciation, for the organization being modeled.
- **Activity**: Contains activities. Activities have accounts with cost elements. Costs might be assigned to activities from resource accounts or from other activity accounts.
- **Cost Object**: Contains cost objects (products, services, channels, customers). These cost objects are assigned costs from resources, activities, other cost objects, or any combination of the three.

These modules constitute the main structure of a model. A fourth module, External Units, provides support for external costs. An external unit is an item, such as a part purchased from a supplier, whose cost is maintained outside of a SAS Activity-Based Management model but which needs to be accounted for in the model. You will build each of these modules with the use of dimensions.

Dimensions

A dimension is a category by which data will be analyzed. For example, it might be useful to see sales figures when they are broken down by region, by customer, and by product. Each of these categories (region, customer, and product) represents a single dimension. Common dimensions are products, time, geography, customers, promotions, and sales channels.

To break information into a manageable or useful form, you can group items within a dimension to create a hierarchical structure. Each member of the hierarchy is then at a specific level in the hierarchy. You can name a dimension level as needed. Dimension levels are a powerful modeling tool because they allow you to ask questions at a high level and then expand a dimension to reveal more detail.

Types of dimensions

There are two types of dimensions in a model: structural and attribute.

Structural dimensions are the building blocks of modules. For example, the typical structural dimensions of the Resource module are region, organization, or general ledger; the Activity module might also be structured according to the region or organization dimension, along with an activity dimension.

Dimension attributes provide information that is useful, but not required, to uniquely identify the model structure. Using dimension attributes, you can classify or organize information in ways that will help you analyze model results. The SAS Activity-Based Management OLAP tool makes no distinction between dimension attributes and structural dimensions.
Basic steps to building a model

The following list of steps summarizes the method that you will use in this tutorial for setting up and analyzing information in SAS Activity-Based Management models. This method is described completely in the lessons and exercises that follow.

1. Create a paper plan
   Collect resource (expenditure), activity, and cost object (products and services) information to design your model. Determine the goal of the model (what kind of information you want to get from it), and determine the appropriate dimensions, periods, and scenarios to achieve that goal.

2. Create periods and scenarios
   Create the periods and scenarios to be used by your model. (Periods and scenarios are shared by all models on a server.)

3. Create dimensions, modules, and accounts
   Create the dimensions and dimension members that you will use to build the modules. Build the resource, activity, and cost object modules by defining the accounts (dimension intersections) of each module.

4. Define drivers
   Define drivers that measure the consumption of expenses and activities.

5. Make assignments
   Select the relevant driver for each source account. Make cost assignments from source accounts to destination accounts.

6. Calculate costs
   Calculate costs and display the results.

7. Add bills of costs
   Define and link external unit costs to accounts.

8. Enter output, sales, and revenue data
   Enter output quantities, determine unit costs, enter sales volumes, and calculate profit.

9. Add attributes
   Define and add attributes to the appropriate accounts.

Parcel Express

Parcel Express is a fictitious organization that is using activity-based management to determine whether this method more clearly conveys costs and profitability information than traditional costing methods.

A later chapter will outline the main business activities of Parcel Express and the company’s goals in using SAS Activity-Based Management.
Getting Started

The SAS Activity-Based Management solution is Web-enabled. Its server typically resides on your company’s intranet and the client software resides on your computer. This tutorial assumes that you have installed the software on your computer and that you are familiar with basic software usage techniques, such as using menus, dialog boxes, and other Windows and Web controls.

Logging in

You log in to SAS Activity-Based Management from the Start menu.

Log in to SAS Activity-Based Management

1. Select Start > Programs > SAS > Activity-Based Management 6.x > Activity-Based Management Solution.
   
   You see the Connect dialog box. The software version number might vary.

2. If your current network log in information is not valid for the server, clear the Log in using my current credentials option.

3. From the Server drop-down list, select a server, or type the server name.

4. If you cleared the Log in using my current credentials option:
   
   a. Type your domain and User name.
For example, HQ\JohnD.

b. Type your **Password**.

As you enter each character, an asterisk (*) appears in its place.

5. Click **OK**.

You see the SAS Activity-Based Management home page.

### The home page

The following figure illustrates the SAS Activity-Based Management home page.

![The SAS Activity-Based Management home page](image)

The Workspace Manager is your view into the SAS Activity-Based Management server.

You can initiate common tasks from this area.

Read the online Help (click ![Help](image)) for descriptions of the Home Page and Workspace Manager. Any existing models to which you have access rights appear in the Models folder or its subfolders. You can also create shortcuts to your models in the My Shortcuts folder.

**Change to Model mode**

1. On the home page, click ![Model](image)
You see a model page. If have just started SAS Activity-Based management, you will see the Model home page. If you have been working with a model, you will see the model page you were working on last.

**Model home page**

The Model home page lists the models to which you have access rights. From this page, you can open, create, or delete models.

![Model home page](image)

**Model mode and module pages**

When you open a model, you usually go to the Resource module, which is just one page among many that constitute Model mode. If you change to a different mode, such as OLAP or Reports mode, and return to Model mode, you go to the page of the model that you were on last.

You perform all of the tasks that are associated with building a model, entering data, and calculating costs in Model mode. Many of the tasks rely on the use of dialog boxes (which allow you to manage specific aspects of the model) and wizards (which guide you through certain procedures). In many cases, you will enter data directly into a column on one of the Model mode pages.

The following figure shows the Resource module of the model that you will be building in this tutorial.
You can initiate most tasks from the menus or by using tool bar buttons and icons.

A module’s structure comes from its dimensions. The accounts, represented by the layered cube icons, are intersections of dimensions.

You can close the task bar to allow more space for the model.

In this tutorial, you will be directed to use the menus most of the time. Occasionally, you will be instructed to use a button or an icon. As you become more familiar with the software, you can choose whichever method you prefer to initiate tasks. Read the online Help for a complete description of tool bar buttons and icons.

Assignments panes

One of the main objectives of activity-based management is to accurately assess how company costs are consumed; for example, how costs flow from general ledger accounts to activities to products and services. SAS Activity-Based Management provides you with several graphical tools to help you see and manage this flow. Among these tools are the Left and Right assignments panes, which allow you to view and assign costs from one module to another and within a single module.

By default, each module opens in a single-pane view, the Primary pane. The Primary pane contains the structure of a module, which includes the dimension intersections (accounts) and each account’s cost elements. You can open the Left assignments pane to see the accounts from which costs flow (sometimes called source accounts). You can open the Right assignments pane to see the accounts to which costs flow (accounts are sometimes called destination accounts).
The following display shows the Activity module of the model that you will be building. All three panes are open in the example.

In the example above, the arrows that point from the Left assignments pane to the Primary pane indicate costs that are flowing into the Beaverton Inspection account in the Activity module. The arrows that point from the Primary pane to the Right assignments pane show how costs then flow from the Beaverton Inspection account to other accounts.

In this tutorial, you will use the Right assignments pane to assign costs from one account to another.

**Column layouts**

A column layout is a collection of displayed columns, column formats, and the column order on the module pages. You can customize a column layout to display various information, such as properties, attributes, periods, and scenarios. When you have customized it, you can save a column layout by name so that you can retrieve it later. You see saved column layouts in the Workspace Manager and in the Column Layout list on the Resource, Activity, Cost Object, and External Units module pages.

When you save a column layout, the following information is saved:

- Description
- Column headings
- Information that is displayed in each column and the period/scenario association to which it applies
- Format for each column and order of the columns from left to right
- Model
- Column widths

The following items are not saved:

- Number of assignments panes that appear in the page
Tip: All column layouts that are saved by all users on the same server are listed in the Workspace Manager. Therefore, your organization might want to set up some guidelines for saving and naming column layouts.

Properties, attributes, and dimensions in layouts

The columns of a column layout are derived from the following model elements:

- **Properties:** A property is a model item that holds values that are entered by a user or calculated by the software. Examples of properties are: Cost, Unit Cost, Output Quantity, Sold Quantity, and Profit. The more familiar you become with SAS Activity-Based Management modeling, the more you will be able to use properties creatively to achieve your analysis goals.

- **Attributes:** An attribute is a user-defined label or numeric value that is attached to an account. Each attribute is a particular characteristic that is used for analysis. An attribute conveys information about the item to which it is attached.

- **Dimensions:** A dimension is a category by which data will be or is analyzed. You define the dimensions of your model when you use the New Model wizard.

Reports

SAS Activity-Based Management allows you to use predefined report templates or to create your own reports.

Change to Reports mode

1. From the home page, click [Reports].
   
   You see the Reports home page.

OLAP cubes

A cube is the main object in online analytic processing (OLAP), a technology that provides fast access to data in a model. A cube contains a set of data that is constructed from a subset of model data and that is organized and summarized into a multi-dimensional structure. SAS Activity-Based Management cubes are standard OLAP cubes.

You use SAS Activity-Based Management software to connect to and interact with the cubes on a SAS Activity-Based Management server. For each model, you can generate cubes that you can manipulate on the OLAP page to interactively analyze business data.

Change to OLAP mode

1. From the home page, click [OLAP].
   
   You see the OLAP home page.
Creating a Paper Plan

Activity-based management projects begin with a plan. After you have determined the analysis goals of the model and defined the dimensions that will enable that analysis, you can begin data collection. Information concerning resources (expenditures), activities (tasks), and cost objects (products and services produced) provides the basis for building an ABM model.

Building by design

Before beginning to build a model, evaluate and make preliminary decisions about the design of the model. Just as a building contractor needs a plan before beginning to build a house, a model builder needs a plan for the structure of a model before beginning to build.

Factors that influence a model’s design include the:

- Goal of the model—the operational or strategic questions the activity-based management program is intended to answer
- Data already collected and its format
- Data needed that is not being collected
- Types of reports and OLAP cubes that will be needed

This tutorial uses a simple design and focuses on the steps for building a model. The design of the model and the effort that it takes can be simple or complex. The model builder will need to understand these factors, and others that are unique to each modeling situation, to arrive at a design.

The Parcel Express model

Company background

Parcel Express began operations in Beaverton, Oregon, in 1990 as a ground parcel delivery service. In 1995, with 125 employees and $1 million in sales, the company began expanding to overnight delivery and 2nd day delivery.

In the first quarter of 2003, total sales revenue was approximately $5.5 million. Costs for the same period were about $3.8 million, for a profit of about $1.7 million.
ABM goals
Parcel Express hopes to use SAS Activity-Based Management to trace operating costs to individual products and services so that the overall costs and profit of each can be determined and improved. They are concerned that the current accounting system, which divides the business into about 10 product groupings, might not accurately reflect the different costs of doing business for the two express services: Overnight Express and 2\textsuperscript{nd} Day Guaranteed.

Management wants to know how each product is performing. The company’s competitors have dominated in the 2\textsuperscript{nd} Day market, and management has recently slashed prices on that product. Sales volumes have increased as a result, but it’s unclear how much profit they’re making, if any. They would like to meet a target profit margin of at least 10% on the 2\textsuperscript{nd} Day Guaranteed product and at least 25% on all others. They are willing to adjust pricing or modify processes to reach that goal.

Model structure
Parcel Express has assembled a SAS Activity-Based Management modeling team whose members have become familiar with ABM concepts and the structure of ABM models. Together they have determined that the following module structure most accurately reflects the way Parcel Express conducts its operations.

Resource module
Resources will be structured by region and general ledger account. The two main processing plants are Beaverton and Eugene, Oregon. General ledger accounts include:

- Wages (salary and overtime)
- Operating expenses and supplies
- Equipment depreciation

Activity module
Activities will be structured by region and activity. The activities Parcel Express has chosen to model are:

- Branch collection
- Sorting and inspection
- Air and land distribution
- Resolution of customer complaints

The Eugene facility does not have an air distribution function, so it will have one fewer account than Beaverton.

Cost Object module
Parcel Express needs to be able to track not only the costs of products but of their channels as well. Therefore, they will organize the Cost Object module by channel and products and services.

The three channels are:

- Drop Box
- Walk In
- Commercial Pick Up
Creating a Paper Plan

The three products and services are:
- Standard Ground
- 2nd Day Guaranteed
- Overnight Express

External Units module
Each product has packaging costs that must be accounted for. Materials for packaging will be tracked as external units, including:
- Envelopes
- Flats
- Boxes

Data collection
The following information will be collected for entry into the ABM model:
- Wages: Wage information, including salaries and overtime, will come from the general ledger system. Wages will be entered as dollar amounts and assigned to activities according to the number of full-time employees, or FTEs (Full-Time Equivalents), who are associated with an activity.
- Operating expenses: Operating expenses and supply costs will come from the general ledger. These costs will be assigned to activities in dollar amounts.
- Equipment expenses: Equipment expenses, including depreciation, will come from the general ledger. These costs will be assigned by percentage.
- Collection and distribution: Branch managers will collect data from their control systems regarding the number of packages collected, moved to warehouses, sorted, inspected, and distributed by land and air. Accurate numbers here are critical to the success of the modeling effort. Activity accounts will assign costs by number of packages.
- Complaints: The number of customer complaints will be collected by branch managers. Costs that are associated with complaint resolution will be assigned according to the number of complaints received.
- Revenue: Revenue will come from the sales accounting system. Revenue will be associated with cost objects according to the sales quantity for each product.
Creating Periods and Scenarios

A period is an interval of time in which activity-based management data is maintained. A period can represent any unit of time: a month, a quarter, a year, and so on. For example, if your organization chooses to enter data each month, the marketing payroll cost is the amount of payroll for one month. A model can hold data for different periods but only one period at a time is active. The default periods are 2002 and 2003. You can create a hierarchy of periods, such as FY2003 > Q1 > January. By default, each level is given a name, such as Period L1.

You can compare model data that you have entered for different periods. For example, you can enter costs into a model on a month-by-month basis and examine the costs for March vs. the costs for February.

Scenarios are generally used to manage different variations of data within a period. A scenario can be any set of data: actual, budget, aggressive plan, conservative plan, and so on. The default scenarios are Actual and Budget. You can create a hierarchy of scenarios, such as Budget > Aggressive. By default, each level is given a name, such as Scenario L1. However, these names aren't descriptive when you generate cubes. So, you can rename a default scenario level.

Creating a period

Parcel Express analyzes costs by quarters, so the model will be structured to analyze quarter-on-quarter costs. The period that you will create is 2003 Q1. You will create the period on the level below 2003.

Create a period

1. Select Tools > Manage Periods.
Creating Periods and Scenarios

You see the Manage Periods dialog box.

2. Select the 2003 period, and click New.
   You see the New Period dialog box.

3. For the Name, replace New Period with 2003 Q1.
4. For the Reference, type 03Q1.
   Note: SAS Activity-Based Management enables you to enter descriptions for the items that you create. In this tutorial, you will not enter descriptions.
7. Click OK.
   You see the new period added to the list below the 2003 period.
8. Create three more periods that are called 2003 Q2, 2003 Q3, and 2003 Q4. Specify appropriate date ranges and references for each period. All period references must be unique.
   When you are done, you should see the following periods in the Manage Periods dialog box:
Creating a scenario

Parcel Express wants to compare actual costs that it incurred on a quarterly basis. It will analyze the profit and loss trends in these costs to make decisions regarding resource allocation, process control, and pricing. For this purpose, the default scenario called Actual will be adequate.

However, so that you gain experience, assume that the company had specific profit targets that it wanted to model in SAS Activity-Based Management. You could create a scenario called Target.

Create a scenario

1. Select Tools > Manage Scenarios.

You see the Manage Scenarios dialog box.

2. Select All Scenarios, and click New.

You see the New Scenario dialog box.
Creating Periods and Scenarios

3. For the Name, replace New Scenario with Target.

4. For the Reference, type TARGET.

5. Click OK.

You see the new scenario added to the list below the Actual scenario.

6. Click OK.

Deleting periods and scenarios

You can delete a period or scenario from the Manage Periods or Manage Scenarios dialog boxes, respectively. Select the period or scenario and click Delete. You are prompted to confirm the deletion.
Creating Dimensions and Dimension Members

Before creating the structure of a module, you must define the dimensions that you will use to build that structure. As defined in the paper plan, the dimensions that you will define for the Parcel Express model are:

<table>
<thead>
<tr>
<th>Module</th>
<th>Dimensions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource</td>
<td>Region</td>
</tr>
<tr>
<td></td>
<td>General Ledger</td>
</tr>
<tr>
<td>Activity</td>
<td>Region</td>
</tr>
<tr>
<td></td>
<td>Activities</td>
</tr>
<tr>
<td>Cost Object</td>
<td>Channel</td>
</tr>
<tr>
<td></td>
<td>Products and Services</td>
</tr>
<tr>
<td>External Unit</td>
<td>Materials</td>
</tr>
<tr>
<td>Profit Analysis</td>
<td>Channel</td>
</tr>
<tr>
<td></td>
<td>Products and Services</td>
</tr>
</tbody>
</table>

Creating dimensions with the New Model wizard

The main purpose of the New Model wizard is to establish the dimensions of your model. These are the dimensions that you will use to create accounts and the structure of the modules. Most important, these are the dimensions that will eventually enable you to generate meaningful cubes and to analyze the profits and losses that result from your business activities.

Now, you will create the model named Parcel Express. The model’s monetary data will be in U.S. dollars.

➤ Start the New Model wizard

1. Select File > New > Model.
You see Step 1 of the New Model wizard.

The wizard contains 10 steps. If you accept the default dimensions for your model, you will not perform every step. For this tutorial, you will define your own dimensions and perform every step in the wizard.

2. Enter the name as **Parcel Express**.
   
   **Note:** Each model name must be unique on a SAS Activity-Based Management server.

3. Verify that the base currency is **US Dollar ($)**.

4. Click **Next**.

   You see Step 2 of the wizard.

   ➢ **Select a starting period and scenario**

   1. Expand the **2003** level of the period hierarchy, and select the **2003 Q1** period.

   2. Click **Next**.
You see Step 3 of the wizard.

3. Select the Actual scenario.

You see a change in the period/scenario association at the bottom of the window. The scenario changes to 2003 Q1/Actual. A period/scenario association identifies a specific period and scenario combination; in this case, 2003 Q1/Actual. All model data must reside in a period and must apply to a scenario. An association represents a period-scenario pair.

4. Click OK.

You see Step 4 of the wizard.

Select the method for defining dimensions

1. Verify that the Select or define the dimensions for each module option is selected.

This option enables you to create new dimensions, rearrange dimensions, or use the default dimensions for some modules but not others.

Note: The default dimensions are:

<table>
<thead>
<tr>
<th>Module</th>
<th>Dimensions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource</td>
<td>Organization</td>
</tr>
<tr>
<td></td>
<td>General Ledger</td>
</tr>
<tr>
<td>Activity</td>
<td>Organization</td>
</tr>
<tr>
<td></td>
<td>Activities</td>
</tr>
<tr>
<td>Cost Object</td>
<td>Customer</td>
</tr>
<tr>
<td></td>
<td>Products and Services</td>
</tr>
<tr>
<td>External Unit</td>
<td>Materials</td>
</tr>
<tr>
<td>Profit Analysis</td>
<td>Customer</td>
</tr>
<tr>
<td></td>
<td>Products and Services</td>
</tr>
</tbody>
</table>

2. Click Next.

You see Step 5 of the wizard.

Define the Resource module dimensions

1. In the Selected dimensions list, select the Organization dimension.

   Next, you will remove this dimension from the Selected dimensions list.

2. Click <.

   You see the Organization dimension move from the Selected dimensions list to the Available dimensions list.

3. Click New.

   You see the Dimension Name dialog box.
4. For **Dimension Name**, type *Region*.

5. For **Reference**, type *Reg*.

6. Click **OK**.

The Dimension Name dialog box closes, and you see that the Region dimension has been added to the Available dimensions list.

7. Select the **Region** dimension, and click ➡.

You see the Region dimension move from the Available dimensions list to the Selected dimensions list, below the General Ledger dimension. The order of dimensions in the list determines the hierarchy of dimensions in the module. In this case, Parcel Express wants to organize its resources by Region and then by General Ledger. So, you will have to move Region above General Ledger.

8. Select the **Region** dimension, and click ⬅.

9. Click **Next**.

You see Step 6 of the wizard.

Now, you will define the dimensions for the Activity module by using these same techniques. Refer to the above procedure if you need clarification on a step.

- **Define the Activity module dimensions**

  1. Move the **Organization** dimension to **Available dimensions**.
  
  2. Move the **Region** dimension to **Selected dimensions**.
  
  3. Move **Region** above **Activities**.

    The Selected dimensions list should appear as follows:

    ```
    Selected dimensions:
    Region (Reg)
    Activities (Act)
    ```

  4. Click **Next**.

    You see Step 7 of the wizard.

- **Define the Cost Object module dimensions**

  1. Move the **Customers** dimension to **Available dimensions**.
2. Create a new dimension called **Channel** that has a reference of **Chnl**.

3. Move the **Channel** dimension to **Selected dimensions**.

4. Move **Channel** above **Products and Services**.

   The Selected dimensions list should appear as follows:

   ![Selected dimensions table]

5. Click **Next**.

   You see Step 8 of the wizard.

   ➤ **Define the External Units module dimensions**

1. Verify that **Materials** is the only dimension in the **Selected dimensions** list.

2. Click **Next**.

   You see Step 9 of the wizard.

   ➤ **Define the Profit Analysis dimensions**

1. Move the **Channel** dimension from **Available dimensions** to **Selected dimensions**.

2. Move **Channel** above **Products and Services**.

   The Selected dimensions list should appear as follows:

   ![Selected dimensions table]

3. Click **Next**.

   You see Step 10 of the wizard.

   ➤ **Review the summary and finish the wizard**

1. Review the **Summary of information** and **Dimensions in each module**, as shown below:
Creating Dimensions and Dimension Members

If any of the information in the summary is incorrect, click Back to move to the page that requires changes. After making the corrections, click Next to return to the summary.

2. Click Finish.

You see the Dimensions page that now has the following dimensions:

These dimensions are the basic building blocks that you will use to construct the modules of your model. First, however, you must create the members of each dimension.

Creating dimension members

Dimension members are the unique elements of a dimension level. For example, the Region dimension of the Parcel Express model will have levels that include countries, states, and cities. Beaverton and Eugene are dimension members at the same level of the Region dimension.

Create dimension members

1. On the Dimensions page, select Region.
2. Select Edit > New Dimension Member.

You see the New Dimension Member dialog box.
3. For **Name**, type **USA**.
   
   **Tip:** You see that the Reference field is automatically set to the name that you type. In this tutorial, you will not change the references of dimensions; however, for the models that you create for your company, you might want to devise a standard referencing methodology.

4. Click **OK**.
   
   You see that the USA dimension member has been added below Region.

5. Select the **USA** dimension member.

6. Create a new dimension member named **Oregon**.
   
   Note that the Level is Level2. The reason is that you are adding a dimension member below a Level1 dimension member.

7. Using the techniques that you have learned, create the dimension members that are shown below.

```
<table>
<thead>
<tr>
<th>Name</th>
<th>Reference</th>
<th>DimLevelName</th>
</tr>
</thead>
<tbody>
<tr>
<td>Region</td>
<td>USA</td>
<td>Level1</td>
</tr>
<tr>
<td></td>
<td>Oregon</td>
<td>Level2</td>
</tr>
<tr>
<td></td>
<td>Borington</td>
<td>Level3</td>
</tr>
<tr>
<td></td>
<td>Eugene</td>
<td>Level3</td>
</tr>
<tr>
<td>General Ledger</td>
<td>OR</td>
<td>Level1</td>
</tr>
<tr>
<td></td>
<td>Wages</td>
<td>Level1</td>
</tr>
<tr>
<td>Operating Expenses</td>
<td>Operating Expenses</td>
<td>Level1</td>
</tr>
<tr>
<td>Equipment Expenses</td>
<td>Equipment Expenses</td>
<td>Level1</td>
</tr>
<tr>
<td>Activities</td>
<td>Act</td>
<td>Level1</td>
</tr>
<tr>
<td>Personnel</td>
<td>Personnel</td>
<td>Level1</td>
</tr>
<tr>
<td></td>
<td>Resolve Customer</td>
<td>Level2</td>
</tr>
<tr>
<td></td>
<td>Complaints</td>
<td>Level2</td>
</tr>
<tr>
<td></td>
<td>Branch Collection</td>
<td>Level1</td>
</tr>
<tr>
<td></td>
<td>Move to Warehouse</td>
<td>Level2</td>
</tr>
<tr>
<td></td>
<td>Regional Sorting</td>
<td>Level1</td>
</tr>
<tr>
<td></td>
<td>Inspection</td>
<td>Level2</td>
</tr>
<tr>
<td></td>
<td>Sort</td>
<td>Level2</td>
</tr>
<tr>
<td></td>
<td>Distribution</td>
<td>Level1</td>
</tr>
<tr>
<td></td>
<td>Air Distribution</td>
<td>Level2</td>
</tr>
<tr>
<td></td>
<td>Land Distribution</td>
<td>Level2</td>
</tr>
<tr>
<td>Channel</td>
<td>Core</td>
<td>Level1</td>
</tr>
<tr>
<td></td>
<td>Drop Box</td>
<td>Level1</td>
</tr>
<tr>
<td></td>
<td>Walk In</td>
<td>Level1</td>
</tr>
<tr>
<td></td>
<td>Commercial Pick Up</td>
<td>Level1</td>
</tr>
<tr>
<td></td>
<td>Products and Services</td>
<td>Prod_Serv</td>
</tr>
<tr>
<td></td>
<td>2nd Day Guaranteed</td>
<td>Level1</td>
</tr>
<tr>
<td></td>
<td>Overnight Express</td>
<td>Level1</td>
</tr>
<tr>
<td></td>
<td>Standard Ground</td>
<td>Level1</td>
</tr>
<tr>
<td>Materials</td>
<td>Misc</td>
<td></td>
</tr>
</tbody>
</table>
```
**Note:** You will not create dimension members for the Materials dimension yet. You will add those when you create bills of costs.
Creating Modules and Accounts

An account is the basic repository of cost in a model. You create an account in the SAS Activity-Based Management software by defining an intersection between dimension members. For example, in the Parcel Express model, you will create an account for tracking the costs of inspecting packages in Beaverton, OR. You create this account by defining an intersection between Region and Activity dimension members, as shown below:

Region > USA > Oregon > Beaverton
   x
Activity > Regional Sorting > Inspection

A shorthand for the resulting account, or dimension intersection, is Beaverton x Inspection.

The costs of an account are derived from cost elements, which can either be added directly to the account or assigned from other accounts.

Building the Resource module structure

Start by creating a structure to hold the resource costs in the model.

Create resource accounts

1. To open the Resource module, select Model > Resource Module.
2. Select Edit > New Account.
   You see Step 1 of the New Account wizard.
Here, you will select the dimension intersections for each account of the Resource module.

The Dimensions area contains the dimensions of the Resource module. The Accounts area will contain the accounts that you create.

3. Expand the Region hierarchy to display all of its dimension members.

4. In the Dimensions list, select the following dimension members:
   - Beaverton
   - Eugene
   - Wages
   - Operating Expenses
   - Equipment Expenses

5. Click Add.

You see that the following accounts have been added to the Accounts list:
6. Click Next. You see Step 2 of the wizard. Here, you will add the cost elements and costs of each account.

![Image of the New Account Wizard](image)

**Tip:** The system has automatically generated a unique name and reference for each account. The names and references you see will be different than those shown in the display. These names and references are used in reports and operational summaries but do not appear elsewhere on a page, unless you add columns to display them. Your company can decide whether to use the default names or to employ a naming and referencing methodology. If your models are extremely large, it will probably be more convenient to use system-generated account names and references.

**Add cost elements and costs**

1. Select the **Beaverton x Wages** account, and click **Add Cost Element** twice.
You see that two cost elements have been added to the account table. The names and references of these cost elements are system-generated. In the account table, you can add costs and change the names and references of cost elements.

2. Change the names and references of the two cost elements that you added, and enter their costs, as follows:

<table>
<thead>
<tr>
<th>Name</th>
<th>Reference</th>
<th>Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>Salaries</td>
<td>BS</td>
<td>1,563,000.00</td>
</tr>
<tr>
<td>Overtime</td>
<td>BOT</td>
<td>75,600.00</td>
</tr>
</tbody>
</table>

**Note:** In large models, costs might be imported from other sources, such as a database. In that case, you could define the cost elements, but leave the costs empty.

3. Using the techniques that you have learned, create cost elements and enter costs as follows:

<table>
<thead>
<tr>
<th>Account</th>
<th>Cost Elements</th>
<th>Cost Element Reference</th>
<th>Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beaverton x Operating Expenses</td>
<td>Operating Expenses</td>
<td>BOE</td>
<td>228,000.00</td>
</tr>
<tr>
<td></td>
<td>Office Supplies</td>
<td>BOS</td>
<td>10,000.00</td>
</tr>
<tr>
<td>Beaverton X Equipment Expenses</td>
<td>Equipment Depreciation</td>
<td>BED</td>
<td>54,300.00</td>
</tr>
<tr>
<td>Eugene X Wages</td>
<td>Salaries</td>
<td>ES</td>
<td>1,298,000.00</td>
</tr>
<tr>
<td></td>
<td>Overtime</td>
<td>EOT</td>
<td>110,000.00</td>
</tr>
<tr>
<td>Eugene x Operating Expenses</td>
<td>Operating Expenses</td>
<td>EOE</td>
<td>263,000.00</td>
</tr>
<tr>
<td></td>
<td>Office Supplies</td>
<td>EOS</td>
<td>8,000.00</td>
</tr>
<tr>
<td>Eugene x Equipment Expenses</td>
<td>Equipment Depreciation</td>
<td>EED</td>
<td>38,000.00</td>
</tr>
</tbody>
</table>

4. Click **Next**.

You see Step 3 of the wizard. This step contains a summary of the accounts, cost elements, and costs you are about to create.

5. Click **Finish**.

You see that the accounts have been added to the Resource module.
Creating Modules and Accounts

The system automatically rolls up costs from cost elements, to accounts, to higher dimension levels.

Building the Activity module structure

An activity is a task that consumes resources. Examples of activities include setting up a machine to produce a particular part, scheduling production of a certain number of products, and inspecting a batch of parts. In a model, you identify activities and calculate their costs.

Creating activity accounts

In the Activity module, you will create activity accounts.

Create activity accounts

1. To open the Activity module, select Model > Activity Module.
2. Select Edit > New Account.
   
   You see the New Account wizard.
3. Using the wizard, create the following accounts:
   
   Note: Do not create cost elements. Costs will be assigned to these accounts from other accounts.

   Note: After creating the accounts in Step 1 of the wizard, click Finish. Because you are not creating cost elements, there is no need perform Steps 2 and 3.
Creating Modules and Accounts

Dimension Intersection
Beaverton x Resolve Customer Complaints
Beaverton x Move to Warehouse
Beaverton x Inspection
Beaverton x Sort
Beaverton x Air Distribution
Beaverton x Land Distribution
Eugene x Resolve Customer Complaints
Eugene x Move to Warehouse
Eugene x Inspection
Eugene x Sort
Eugene x Land Distribution

Note: There is no air distribution from Eugene.

After completing the steps of the wizard, you see the following Activity module structure:

<table>
<thead>
<tr>
<th>Display Name</th>
<th>Display Reference</th>
<th>Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>USA</td>
<td>USA</td>
<td>$0.00</td>
</tr>
<tr>
<td>Oregon</td>
<td>Oregon</td>
<td>$0.00</td>
</tr>
<tr>
<td>Beaverton</td>
<td>Beaverton</td>
<td>$0.00</td>
</tr>
<tr>
<td>Personnel</td>
<td>Personnel</td>
<td>$0.00</td>
</tr>
<tr>
<td>Resolve Customer Complaints</td>
<td>Resolve Customer Complaints</td>
<td>$0.00</td>
</tr>
<tr>
<td>Branch Collection</td>
<td>Branch Collection</td>
<td>$0.00</td>
</tr>
<tr>
<td>Move to Warehouse</td>
<td>Move to Warehouse</td>
<td>$0.00</td>
</tr>
<tr>
<td>Regional Sorting</td>
<td>Regional Sorting</td>
<td>$0.00</td>
</tr>
<tr>
<td>Inspection</td>
<td>Inspection</td>
<td>$0.00</td>
</tr>
<tr>
<td>Sort</td>
<td>Sort</td>
<td>$0.00</td>
</tr>
<tr>
<td>Distribution</td>
<td>Distribution</td>
<td>$0.00</td>
</tr>
<tr>
<td>Air Distribution</td>
<td>Air Distribution</td>
<td>$0.00</td>
</tr>
<tr>
<td>Land Distribution</td>
<td>Land Distribution</td>
<td>$0.00</td>
</tr>
<tr>
<td>Eugene</td>
<td>Eugene</td>
<td>$0.00</td>
</tr>
<tr>
<td>Personnel</td>
<td>Personnel</td>
<td>$0.00</td>
</tr>
<tr>
<td>Resolve Customer Complaints</td>
<td>Resolve Customer Complaints</td>
<td>$0.00</td>
</tr>
<tr>
<td>Branch Collection</td>
<td>Branch Collection</td>
<td>$0.00</td>
</tr>
<tr>
<td>Move to Warehouse</td>
<td>Move to Warehouse</td>
<td>$0.00</td>
</tr>
<tr>
<td>Regional Sorting</td>
<td>Regional Sorting</td>
<td>$0.00</td>
</tr>
<tr>
<td>Inspection</td>
<td>Inspection</td>
<td>$0.00</td>
</tr>
<tr>
<td>Sort</td>
<td>Sort</td>
<td>$0.00</td>
</tr>
<tr>
<td>Distribution</td>
<td>Distribution</td>
<td>$0.00</td>
</tr>
<tr>
<td>Land Distribution</td>
<td>Land Distribution</td>
<td>$0.00</td>
</tr>
</tbody>
</table>

Note: You have not entered cost elements for these accounts and no costs have been assigned yet, so their cost is $0.00.

Building the Cost Object module structure

The Cost Object module will hold information about Parcel Express’s products and services. Its dimensions are Channel and Products and Services.
Omitting a dimension from an account

You can create accounts that omit one or more dimensions of a module. In the Cost Object module of the Parcel Express model, you will create accounts that have a Channel dimension member but no Products and Services dimension member, and vice versa. The purpose of these omissions is to track the unique costs of a channel that are unassociated with any product, and to track the unique costs of a product that are unassociated with any channel. To omit a dimension from an account, you select the No option in the New Account wizard.

Examples of accounts that omit a dimension are:

- **Drop Box x No <Products and Services>**
  (tracks unique costs that are associated with the Drop Box channel)

- **No <Channel> x 2nd Day Guaranteed**
  (tracks unique costs that are associated with the 2nd Day Guaranteed product)

Creating cost objects accounts

- **Create cost object accounts**

  1. Using the techniques that you have learned, create the following accounts in the Cost Object module:

     **Note:** Do not enter cost elements. Costs will be assigned to these accounts from other accounts.

     | Dimension Intersection                  |
     |-----------------------------------------|
     | Drop Box x 2nd Day Guaranteed           |
     | Drop Box x Overnight Express            |
     | Drop Box x Standard Ground              |
     | Drop Box x No <Products and Services>   |
     | Walk In x 2nd Day Guaranteed            |
     | Walk In x Overnight Express             |
     | Walk In x Standard Ground               |
     | Walk In x No <Products and Services>    |
     | Commercial Pick Up x 2nd Day Guaranteed |
     | Commercial Pick Up x Overnight Express  |
     | Commercial Pick Up x Standard Ground    |
     | Commercial Pick Up x No <Products and Services> |
     | No <Channel> x 2nd Day Guaranteed       |
     | No <Channel> x Overnight Express        |
     | No <Channel> x Standard Ground          |

After you have created these accounts, you see the following Cost Object module structure:
<table>
<thead>
<tr>
<th>Display Name</th>
<th>Display Reference</th>
<th>Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drop Box</td>
<td>Drop Box</td>
<td>$0.00</td>
</tr>
<tr>
<td>2nd Day Guaranteed</td>
<td>2nd Day Guaranteed</td>
<td>$0.00</td>
</tr>
<tr>
<td>Overnight Express</td>
<td>Overnight Express</td>
<td>$0.00</td>
</tr>
<tr>
<td>Standard Ground</td>
<td>Standard Ground</td>
<td>$0.00</td>
</tr>
<tr>
<td>No Products and Services</td>
<td>No Products and Services</td>
<td>$0.00</td>
</tr>
<tr>
<td>Walk In</td>
<td>Walk In</td>
<td>$0.00</td>
</tr>
<tr>
<td>2nd Day Guaranteed</td>
<td>2nd Day Guaranteed</td>
<td>$0.00</td>
</tr>
<tr>
<td>Overnight Express</td>
<td>Overnight Express</td>
<td>$0.00</td>
</tr>
<tr>
<td>Standard Ground</td>
<td>Standard Ground</td>
<td>$0.00</td>
</tr>
<tr>
<td>No Products and Services</td>
<td>No Products and Services</td>
<td>$0.00</td>
</tr>
<tr>
<td>Commercial Pick Up</td>
<td>Commercial Pick Up</td>
<td>$0.00</td>
</tr>
<tr>
<td>2nd Day Guaranteed</td>
<td>2nd Day Guaranteed</td>
<td>$0.00</td>
</tr>
<tr>
<td>Overnight Express</td>
<td>Overnight Express</td>
<td>$0.00</td>
</tr>
<tr>
<td>Standard Ground</td>
<td>Standard Ground</td>
<td>$0.00</td>
</tr>
<tr>
<td>No Products and Services</td>
<td>No Products and Services</td>
<td>$0.00</td>
</tr>
<tr>
<td>No Channel</td>
<td>No Channel</td>
<td>$0.00</td>
</tr>
<tr>
<td>2nd Day Guaranteed</td>
<td>2nd Day Guaranteed</td>
<td>$0.00</td>
</tr>
<tr>
<td>Overnight Express</td>
<td>Overnight Express</td>
<td>$0.00</td>
</tr>
<tr>
<td>Standard Ground</td>
<td>Standard Ground</td>
<td>$0.00</td>
</tr>
</tbody>
</table>
Defining Drivers

An important aspect of activity-based management is understanding how activities in an organization consume expenses and how products consume activities. These consumptions are governed by relevant drivers, which measure the frequency or intensity of the cost demands placed on resources and activities. A driver specifies how costs are assigned.

This tutorial uses both system-defined and user-defined drivers.

Drivers for the model

The first step in assigning resource costs to activities and activity costs to cost objects is building a list of drivers.

The Parcel Express model uses several system-defined drivers. Additionally, you will create the following drivers:

<table>
<thead>
<tr>
<th>User-defined Driver</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>FTEs</td>
<td>Tracks the cost of wages from the Resource module to the Activity module.</td>
</tr>
<tr>
<td>Dollars</td>
<td>Tracks the cost of operating expenses from the Resource module to the Activity module.</td>
</tr>
<tr>
<td># of Customer Complaints</td>
<td>Tracks the number of customer complaints per channel.</td>
</tr>
<tr>
<td># of Packages</td>
<td>Tracks the number of packages that were collected, sorted, and distributed.</td>
</tr>
</tbody>
</table>

Define drivers

1. Select Model > Drivers Page.

   You see the list of system-defined drivers:

   ![Drives List](image)

2. Select Edit > New Driver.

   You see the New Driver dialog box.
3. For **Name**, type **FTEs**.
4. Verify that the **Driver type** is **Basic**.
5. Verify that the **This driver's quantities are unique** option is checked.
6. Click **OK**.

You that see FTEs has been added to the list of drivers.

7. Add the following **Basic** drivers:

<table>
<thead>
<tr>
<th>Driver</th>
<th>Dollars</th>
</tr>
</thead>
<tbody>
<tr>
<td># of Customer Complaints</td>
<td># of Packages</td>
</tr>
</tbody>
</table>
Making Assignments

An assignment links source accounts to destination accounts. Costs flow along this path from resources to activities to cost objects—from expenses to activities to products, services, or customers. A source account is the source of a cost assignment. A destination account receives the results of a cost assignment.

As shown above, the possible assignments, as indicated by a letter, are:

A  From a resource account to another resource account
B  From a resource account to an activity account
C  From a resource account to a cost object account
D  From an activity account to another activity account
E  From an activity account to a cost object account
F  From a cost object account to another cost object account

Creating a column layout

For the Parcel Express model, you will create a column layout that is named Cost Assignment. Initially, you will define the layout for the Resource module. Later, you will add columns to the layout for the other modules.

While building the model structure, you have been working in the Single Pane view. To make assignments, you need to open an Assignments pane. When the Primary pane and an Assignments pane are open, you can see source accounts, destination accounts, assignments, driver names, and driver quantities. To assign resource costs to activity accounts, you will open the Right Assignments pane.
Making Assignments

Open the Right Assignments pane and Column Layout dialog box

1. In the Resource module, click **Model > Assignments > Show Right Assignments Pane**.

   You see the Right assignments pane (to the right of the Resource module Primary pane). The default columns are IntsctnName (Intersection Name), Reference, and Cost.

   **Tip:** You might want to hide the task bar on the left side of the window to display more data. To do this, click the X in the upper right corner of the task bar. You can also make columns wider or narrower by clicking on the line between column headings and dragging the edge of the column to the width that you want.

2. Select **Model > Column Layout > Edit Columns**.

   You see the Column Layout dialog box.

   ![Column Layout dialog box](image)

   The columns that you see in the Displayed Columns list refer to the layout for a specific pane in a specific module. In the illustration, you see the column layout for the Primary pane of the Resource module. To change the column layout for a different pane or module, select that pane or module. The Cost Assignment column layout that you create in this tutorial will ultimately contain layouts for several modules and panes.

Define the column layout for two panes

1. Verify that the **Primary pane** tab is selected.
2. From the **Displayed Columns** list, select **Display Reference**.
3. Click **Remove**.
You see that Display Reference has been removed from the list of Displayed Columns. Removing this column from the layout will provide more screen space for columns relevant to making driver assignments.

4. In Properties, Attributes, and Dimensions, select Driver Name (DrvName).
   Tip: To find Driver Name, scroll down to Driver and expand the node.

5. Click Add.
   You see that DrvName has been added to the Displayed Columns list.

6. Click the Right tab.
   You see the default columns of the Right pane in Displayed Columns.

7. Remove the Reference column from Displayed Columns.

8. Add the Driver Quantity Fixed (DQF) property to the Displayed Columns list.

➢ Save the column layout

1. Click Save As.
   You see the Save Column Layout As dialog box.

![Save Column Layout As dialog box]

2. Verify that the New column layout option is selected, and type Cost Assignment.

3. Click OK.
   You see that the column layout Name has been changed to Cost Assignment.

4. Click OK.
   You see the changes that you made to the column layout. Cost Assignment appears in the Column Layout list.

You have just created a column layout that will enable you to make assignments from Resource module accounts to other accounts. Later, you will further define the Cost Assignment layout for other modules.

**Making assignments from resources to activities**

The first assignments you make will be inter-modular; that is, assignments from the Resource module to the Activity module.
Add accounts for assignments

1. Select Model > Assignments > Add Accounts in Right Pane.

You see the Add Accounts for Assignments dialog box.

2. Verify that the Activity module is selected.
3. Expand the Activity hierarchy so that you can see the Beaverton and Eugene roll-up accounts.
4. Select the Beaverton roll-up account, and click Add Accounts.

You see that the Beaverton Activity accounts have been added to the Right pane.
5. Add the Eugene Activity accounts to the Right pane.
6. Click Close.

Making assignments

Now that the intended destination accounts are displayed, you can make assignments from Resource accounts to Activity accounts.

Make assignments

1. In the Primary pane, expand the Resource tree to display all its accounts.

Tip: In this tutorial, you do not need to expand the module hierarchies to display the cost elements of each account. If the cost elements are displayed in the Resource module, collapse the hierarchy to hide them.
2. Select the **Wages** account under **Beaverton**.

You see that arrows appear next to each account in the Right pane. These arrows indicate that you can make assignments from Beaverton Wages to any of the listed accounts. Logically, the cost of wages in Beaverton would only be assigned to Beaverton activities, not Eugene activities.

3. Click the **DrvName** cell in the **Beaverton Wages** row.

You see a list of available drivers, including system-defined and user-defined drivers.

4. Select **FTEs**.

5. Make assignments to all the **Beaverton** accounts in the Right pane by clicking the arrow next to each account.

You see that a line now connects Beaverton Wages to each of the arrows that you clicked.

6. Type the following values in the DQF (Driver Quantity Fixed) column on the Right pane (the order of accounts might be different than that shown below; be careful to assign values to the correct accounts):

<table>
<thead>
<tr>
<th>Display Name</th>
<th>Cost</th>
<th>DQF column</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beaverton x Resolve Customer Complaints</td>
<td>$0.00</td>
<td>3.00</td>
</tr>
<tr>
<td>Beaverton x Move to Warehouse</td>
<td>$0.00</td>
<td>6.00</td>
</tr>
<tr>
<td>Beaverton x Inspection</td>
<td>$0.00</td>
<td>3.00</td>
</tr>
<tr>
<td>Beaverton x Sort</td>
<td>$0.00</td>
<td>4.00</td>
</tr>
<tr>
<td>Beaverton x Air Distribution</td>
<td>$0.00</td>
<td>9.00</td>
</tr>
<tr>
<td>Beaverton x Land Distribution</td>
<td>$0.00</td>
<td>12.00</td>
</tr>
</tbody>
</table>

   **Note:** The total cost of Beaverton Wages ($1,638,600.00) will be consumed by these six Activity accounts according to the number of FTEs (Full-Time Equivalents) that you have entered. The software performs the math for you when you calculate costs in a later lesson.
Make other assignments

1. In the Primary pane, select Operating Expenses for Beaverton and make the following assignments:

<table>
<thead>
<tr>
<th>Resource Account</th>
<th>Driver</th>
<th>Activity Account</th>
<th>Driver Quantity (DQF)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beaverton x Operating Expenses</td>
<td>Dollars</td>
<td>Beaverton x Resolve Customer Complaints</td>
<td>6,500.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Beaverton x Move to Warehouse</td>
<td>15,000.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Beaverton x Inspection</td>
<td>54,000.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Beaverton x Sort</td>
<td>23,000.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Beaverton x Air Distribution</td>
<td>83,000.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Beaverton x Land Distribution</td>
<td>56,500.00</td>
</tr>
</tbody>
</table>

2. In the Primary pane, select Equipment Expenses for Beaverton and make the following assignments:

<table>
<thead>
<tr>
<th>Resource Account</th>
<th>Driver</th>
<th>Activity Account</th>
<th>Driver Quantity (DQF)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beaverton x Equipment Expenses</td>
<td>Percentage</td>
<td>Beaverton x Resolve Customer Complaints</td>
<td>5</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Beaverton x Move to Warehouse</td>
<td>10</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Beaverton x Inspection</td>
<td>25</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Beaverton x Sort</td>
<td>20</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Beaverton x Air Distribution</td>
<td>25</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Beaverton x Land Distribution</td>
<td>15</td>
</tr>
</tbody>
</table>

3. In the Primary pane, select Wages for Eugene and make the following assignments:

<table>
<thead>
<tr>
<th>Resource Account</th>
<th>Driver</th>
<th>Activity Account</th>
<th>Driver Quantity (DQF)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Eugene x Wages</td>
<td>FTEs</td>
<td>Eugene x Resolve Customer Complaints</td>
<td>2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Eugene x Move to Warehouse</td>
<td>5</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Eugene x Inspection</td>
<td>2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Eugene x Sort</td>
<td>3</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Eugene x Land Distribution</td>
<td>12</td>
</tr>
</tbody>
</table>
4. In the Primary pane, select **Operating Expenses** for Eugene and make the following assignments:

<table>
<thead>
<tr>
<th>Resource Account</th>
<th>Driver</th>
<th>Activity Account</th>
<th>Driver Quantity (DQF)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Eugene x Operating Expenses</td>
<td>Dollars</td>
<td>Eugene x Resolve Customer Complaints</td>
<td>7,700.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Eugene x Move to Warehouse</td>
<td>69,000.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Eugene x Inspection</td>
<td>58,300.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Eugene x Sort</td>
<td>38,000.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Eugene x Land Distribution</td>
<td>98,000.00</td>
</tr>
</tbody>
</table>

5. In the Primary pane, select **Equipment Expenses** for Eugene and make the following assignments:

<table>
<thead>
<tr>
<th>Resource Account</th>
<th>Driver</th>
<th>Activity Account</th>
<th>Driver Quantity (DQF)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Eugene x Equipment Expenses</td>
<td>Percentage</td>
<td>Eugene x Resolve Customer Complaints</td>
<td>5</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Eugene x Move to Warehouse</td>
<td>10</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Eugene x Inspection</td>
<td>25</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Eugene x Sort</td>
<td>20</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Eugene x Land Distribution</td>
<td>40</td>
</tr>
</tbody>
</table>

### Making assignments from activities to other activities

The costs of some activities flow to other activities. For example, at Parcel Express, when packages are moved to a warehouse, they must then be sorted or inspected. Therefore, in the Parcel Express model, the costs of the Move to Warehouse activity flow to the Inspection and Sort activities. These are known as intra-modular, or reciprocal, assignments.

**Modify the Cost Assignment column layout**

1. Select **Model > Activity Module**.
2. If it is not already open, open the Right assignments pane.
3. If the **Cost Assignment** layout is not already selected, select it from the **Column Layout** list, and click the arrow.

   ![Column Layout](image)

   The Primary and Right panes display the default columns. The reason for this is that you have not yet changed the Cost Assignment column layout for the Activity module.

4. Open the **Column Layout** dialog box.
5. Modify the column layout as follows:
Making Assignments

a. In the Primary pane, remove Display Reference and add Driver Name.

b. In the Right pane, remove Reference and add Driver Quantity Fixed.

6. Click Save, and then click OK.

You see that the column layout has changed as you specified.

Add accounts for assignment

1. Open the Add Accounts for Assignments dialog box.

2. Select the Activity module.

3. Add the following accounts to the Right pane:

   Tip: To see these accounts, expand the hierarchy in the Add Accounts for Assignments dialog box. You can add the accounts individually or select them all at once by using the Ctrl key, and then clicking Add Accounts.

<table>
<thead>
<tr>
<th>Activity Account</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beaverton x Inspection</td>
</tr>
<tr>
<td>Beaverton x Sort</td>
</tr>
<tr>
<td>Beaverton x Air Distribution</td>
</tr>
<tr>
<td>Beaverton x Land Distribution</td>
</tr>
<tr>
<td>Eugene x Inspection</td>
</tr>
<tr>
<td>Eugene x Sort</td>
</tr>
<tr>
<td>Eugene x Land Distribution</td>
</tr>
</tbody>
</table>

4. Click Close.

Make assignments

1. In the Primary pane, select Move to Warehouse for Beaverton and make the following assignments:

<table>
<thead>
<tr>
<th>Activity Account (Primary pane)</th>
<th>Driver</th>
<th>Activity Account (Right pane)</th>
<th>Driver Quantity (DQF)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beaverton x Move to Warehouse</td>
<td># of Packages</td>
<td>Beaverton x Sort</td>
<td>203,000</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Beaverton x Inspection</td>
<td>50,000</td>
</tr>
</tbody>
</table>

2. In the Primary pane, select Inspection for Beaverton and make the following assignments:

<table>
<thead>
<tr>
<th>Activity Account (Primary pane)</th>
<th>Driver</th>
<th>Activity Account (Right pane)</th>
<th>Driver Quantity (DQF)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beaverton x Inspection</td>
<td># of Packages</td>
<td>Beaverton x Sort</td>
<td>44,000</td>
</tr>
</tbody>
</table>
3. In the Primary pane, select **Sort** for **Beaverton** and make the following assignments:

<table>
<thead>
<tr>
<th>Activity Account (Primary pane)</th>
<th>Driver</th>
<th>Activity Account (Right pane)</th>
<th>Driver Quantity (DQF)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beaverton x Sort</td>
<td># of Packages</td>
<td>Beaverton x Land Distribution</td>
<td>107,000</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Beaverton x Air Distribution</td>
<td>140,000</td>
</tr>
</tbody>
</table>

4. In the Primary pane, select **Move to Warehouse** for **Eugene** and make the following assignments:

<table>
<thead>
<tr>
<th>Activity Account (Primary pane)</th>
<th>Driver</th>
<th>Activity Account (Right pane)</th>
<th>Driver Quantity (DQF)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Eugene x Move to Warehouse</td>
<td># of Packages</td>
<td>Eugene x Sort</td>
<td>117,000</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Eugene x Inspection</td>
<td>18,000</td>
</tr>
</tbody>
</table>

5. In the Primary pane, select **Inspection** for **Eugene** and make the following assignments:

<table>
<thead>
<tr>
<th>Activity Account (Primary pane)</th>
<th>Driver</th>
<th>Activity Account (Right pane)</th>
<th>Driver Quantity (DQF)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Eugene x Inspection</td>
<td># of Packages</td>
<td>Eugene x Sort</td>
<td>16,000</td>
</tr>
</tbody>
</table>

6. In the Primary pane, select **Sort** for **Eugene** and make the following assignments:

<table>
<thead>
<tr>
<th>Activity Account (Primary pane)</th>
<th>Driver</th>
<th>Activity Account (Right pane)</th>
<th>Driver Quantity (DQF)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Eugene x Sort</td>
<td># of Packages</td>
<td>Eugene x Land Distribution</td>
<td>133,000</td>
</tr>
</tbody>
</table>

---

### Making assignments from activities to cost objects

Now you will make more inter-modular assignments from activity accounts to cost object accounts. Remember that some cost object accounts are single-dimension accounts. These accounts hold unique costs for individual channels or products. Some Parcel Express activities, such as Resolve Customer Complaints, apply uniquely to a channel, regardless of the packages that are being processed through the channel. Similarly, some costs apply only to products, as you will see in the following procedures.

> **Add accounts for assignment**

1. If there are accounts in the Right pane, clear the accounts as follows:
   a. Select the highest branch of the Activity hierarchy in the Primary pane.
   b. Select **Model > Assignments > Clear Right**.
      You see that the Right pane has been cleared of accounts.

2. Open the **Add Accounts for Assignments** dialog box.
3. Verify that the **Cost Object** module is selected.
4. Add all of the **Cost Object** accounts to the Right pane.
5. Click **Close**.

➤ **Make assignments**

1. In the Primary pane, select **Resolve Customer Complaints** for **Beaverton** and make the following assignments:

<table>
<thead>
<tr>
<th>Activity Account</th>
<th>Driver</th>
<th>Cost Object Account</th>
<th>Driver Quantity (DQF)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beaverton x Resolve Customer Complaints</td>
<td># of Customer Complaints</td>
<td>Commercial Pick Up x No &lt;Products and Services&gt;</td>
<td>25</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Walk In x No &lt;Products and Services&gt;</td>
<td>85</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Drop Box x No &lt;Products and Services&gt;</td>
<td>15</td>
</tr>
</tbody>
</table>

2. In the Primary pane, select **Inspection** for **Beaverton** and create the following assignments:

<table>
<thead>
<tr>
<th>Activity Account</th>
<th>Driver</th>
<th>Cost Object Account</th>
<th>Driver Quantity (DQF)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beaverton x Inspection</td>
<td># of Packages</td>
<td>No &lt;Channel&gt; x Standard Ground</td>
<td>500</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No &lt;Channel&gt; x Overnight Express</td>
<td>4,500</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No &lt;Channel&gt; x 2nd Day Guaranteed</td>
<td>1,000</td>
</tr>
</tbody>
</table>

3. In the Primary pane, select **Air Distribution** for **Beaverton** and make the following assignments:

<table>
<thead>
<tr>
<th>Activity Account</th>
<th>Driver</th>
<th>Cost Object Account</th>
<th>Driver Quantity (DQF)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beaverton x Air Distribution</td>
<td># of Packages</td>
<td>No &lt;Channel&gt; x Standard Ground</td>
<td>50,000</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No &lt;Channel&gt; x Overnight Express</td>
<td>65,000</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No &lt;Channel&gt; x 2nd Day Guaranteed</td>
<td>25,000</td>
</tr>
</tbody>
</table>
4. In the Primary pane, select **Land Distribution** for **Beaverton** and make the following assignments:

<table>
<thead>
<tr>
<th>Activity Account</th>
<th>Driver</th>
<th>Cost Object Account</th>
<th>Driver Quantity (DQF)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beaverton x Land Distribution</td>
<td># of Packages</td>
<td>No &lt;Channel&gt; x Standard Ground</td>
<td>67,000</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No &lt;Channel&gt; x Overnight Express</td>
<td>15,000</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No &lt;Channel&gt; x 2&lt;sup&gt;nd&lt;/sup&gt; Day Guaranteed</td>
<td>25,000</td>
</tr>
</tbody>
</table>

5. In the Primary pane, select **Resolve Customer Complaints** for **Eugene** and make the following assignments:

<table>
<thead>
<tr>
<th>Activity Account</th>
<th>Driver</th>
<th>Cost Object Account</th>
<th>Driver Quantity (DQF)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Eugene x Resolve Customer Complaints</td>
<td># of Customer Complaints</td>
<td>Commercial Pick Up x No &lt;Products and Services&gt;</td>
<td>10</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Walk In x No &lt;Products and Services&gt;</td>
<td>32</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Drop Box x No &lt;Products and Services&gt;</td>
<td>25</td>
</tr>
</tbody>
</table>

6. In the Primary pane, select **Inspection** for **Eugene** and create the following assignments:

<table>
<thead>
<tr>
<th>Activity Account</th>
<th>Driver</th>
<th>Cost Object Account</th>
<th>Driver Quantity (DQF)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Eugene x Inspection</td>
<td># of Packages</td>
<td>No &lt;Channel&gt; x Standard Ground</td>
<td>1,000</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No &lt;Channel&gt; x Overnight Express</td>
<td>500</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No &lt;Channel&gt; x 2&lt;sup&gt;nd&lt;/sup&gt; Day Guaranteed</td>
<td>500</td>
</tr>
</tbody>
</table>

7. In the Primary pane, select **Land Distribution** for **Eugene** and make the following assignments:

<table>
<thead>
<tr>
<th>Activity Account</th>
<th>Driver</th>
<th>Cost Object Account</th>
<th>Driver Quantity (DQF)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Eugene x Land Distribution</td>
<td># of Packages</td>
<td>No &lt;Channel&gt; x Standard Ground</td>
<td>75,000</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No &lt;Channel&gt; x Overnight Express</td>
<td>16,000</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No &lt;Channel&gt; x 2&lt;sup&gt;nd&lt;/sup&gt; Day Guaranteed</td>
<td>42,000</td>
</tr>
</tbody>
</table>
Calculating Costs

Typically, costs are entered in a model at the end of a defined period. These costs come from an organization’s general ledger accounts and from external bills of costs. Additional cost information can come from a Materials Requirements Planning (MRP) system. Production data is also entered into a model at the end of a period.

At any time during the development of a model, you can calculate the cost of each account according to its driver and driver quantities.

Calculating costs

You entered Parcel Express cost and quantities for the 2003 Q1 period, so calculations will be performed for this period.

➢ Calculate costs

1. Select Model > Calculate Costs and Generate Cubes.

   You see the Calculate Costs and Generate Cubes dialog box. This dialog box also enables you to generate cubes for analysis, but you will not do that now.
2. Under **Perform this action**, verify that the **Calculate costs, but do not generate cubes** option is selected.

3. Click **OK**.

   You see a message in the status bar, at the bottom of the window, indicating that the calculation is in progress.

   ![Status Bar Message]

   Depending on the speed of your SAS Activity-Based Management server and your connection to it, the calculation might take several seconds. When the calculation is complete, you will see the Operation Summary window. You should have zero fatal errors, zero errors, and nine warnings.

4. Click **Show Details**.

   You see the details of the warnings.

   **Note:** The names of your accounts will differ from those shown below.
Calculating Costs

Note:
These warnings have occurred because the accounts that are listed have no cost elements or costs assigned to them. You will assign costs to these accounts in a later lesson.

Interpreting the operation summary

An operation summary can show fatal errors, errors, and warnings. Fatal errors are rare during a model calculation. If a fatal error occurred, the calculation would have been terminated by the server and the results would be incomplete. Errors could result from data or a module structure that is incomplete, inconsistent, or invalid. Warnings indicate that a potential problem exists with the model, but that processing was completed.

The operation summary for the Parcel Express model indicates that some accounts of the Cost Object module have no costs. In a later lesson, you will add costs to these accounts based on the sales quantities of each product.

Viewing and verifying calculation results

Experienced activity-based costing users frequently calculate a model after they create accounts, assignments, and driver quantities, or entering cost data, as a validation and quality assurance technique.
The following table shows the total costs for the Resource, Activity, and Cost Object modules, along with the key roll-up accounts in each module. Verify that the modules and accounts in your model match the costs below.

<table>
<thead>
<tr>
<th>Module</th>
<th>Roll up Account</th>
<th>Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource</td>
<td></td>
<td>$3,647,900.00</td>
</tr>
<tr>
<td></td>
<td>Beaverton</td>
<td>$1,930,900.00</td>
</tr>
<tr>
<td></td>
<td>Eugene</td>
<td>$1,717,000.00</td>
</tr>
<tr>
<td>Activity</td>
<td></td>
<td>$3,647,900.00</td>
</tr>
<tr>
<td></td>
<td>Beaverton x Personnel</td>
<td>$135,261.15</td>
</tr>
<tr>
<td></td>
<td>Beaverton x Branch Collection</td>
<td>$356,553.08</td>
</tr>
<tr>
<td></td>
<td>Beaverton x Regional Sorting</td>
<td>$752,095.77</td>
</tr>
<tr>
<td></td>
<td>Beaverton x Distribution</td>
<td>$1,763,948.50</td>
</tr>
<tr>
<td></td>
<td>Eugene x Personnel</td>
<td>$126,933.33</td>
</tr>
<tr>
<td></td>
<td>Eugene x Branch Collection</td>
<td>$366,133.33</td>
</tr>
<tr>
<td></td>
<td>Eugene x Regional Sorting</td>
<td>$772,866.67</td>
</tr>
<tr>
<td></td>
<td>Eugene x Distribution</td>
<td>$1,564,072.10</td>
</tr>
<tr>
<td>Cost Object</td>
<td></td>
<td>$3,647,900.00</td>
</tr>
<tr>
<td></td>
<td>Drop Box</td>
<td>$63,594.52</td>
</tr>
<tr>
<td></td>
<td>Walk In</td>
<td>$152,602.46</td>
</tr>
<tr>
<td></td>
<td>Commercial Pick Up</td>
<td>$45,997.50</td>
</tr>
<tr>
<td></td>
<td>No &lt;Channel&gt;</td>
<td>$3,385,705.51</td>
</tr>
</tbody>
</table>
Adding Bills of Costs

A bill of costs provides a convenient mechanism for adding material and unit costs directly to accounts, for bidding on jobs, or for implementing activity accounting.

Use a bill of costs when:

- Costs outside the general ledger need to be introduced into a model. Not all costs that are assigned through a model come from the general ledger. For example, material costs (the cost of purchased components) can be additional product cost information that often comes from a Materials Requirements Planning (MRP) system.
- A model’s unit cost elements that are associated with product families need to be tracked.

Steps for building bills of costs

To build bills of costs:

1. Define a dimension in the External Units module.
   You did this for the Parcel Express model when you completed the New Model wizard. The dimension is Materials.

2. Create dimension members.
   For Parcel Express, the Materials dimension members will represent packaging materials.

3. Create accounts in the External Units module.
   You will use the New Account wizard to add external units to the model.

4. Create an assignment from the external unit to an account, using the Bill of Cost driver.
   Packaging materials in the Parcel Express model contribute to the unique costs of a product. You will make assignments from accounts in the External Units module to accounts in the Cost Object module.

5. Enter a fixed or variable driver quantity.
   You will enter both types of quantities.

6. If you enter a variable driver quantity, you must also enter an output quantity.
   You will enter output quantities in a later lesson.
Internal and external units

An external unit is a unit, such as a part purchased from a supplier, whose cost is maintained outside a SAS Activity-Based Management model, but which needs to be accounted for in the model. SAS Activity-Based Management treats external units like accounts. When an external unit’s cost is flowed to an account, you see the flowed cost listed as an external unit cost element.

An internal unit is a unit, such as a part produced within a company, whose cost is already represented in the model. The cost flows from one account to another's bill of costs.

In the Parcel Express model, you will use only external units.

Fixed and variable quantities

A bill of costs quantity can include variable or fixed quantities or both.

Variable quantities

In a variable quantity, the cost that flows to the account from the bill of costs depends on the output quantity: the bill of costs' unit cost is multiplied by the driver quantity and the output quantity (either a system-calculated output quantity or a user-entered output quantity).

For example, assume that a company manufactures bicycles. The rubber tires are purchased from another company for $5 each. Because each bicycle requires two tires, the unit cost of the bill of costs is $10. If the company produces 100 bicycles, the total cost is $1,000 (100 X $5 X 2).

Fixed quantities

In a fixed quantity, the cost that flows to the account from the bill of costs does not depend on the output quantity: the bill of costs' unit cost is multiplied by the driver quantity.

For example, assume that the bicycle manufacturer that was mentioned previously buys 1,000 tires at the beginning of each year. The tires might be used in any model of bicycle that the manufacturer produced. In this case, the bill of costs' unit cost does not vary with the number of bicycles produced; it's always $5,000 (1,000 x $5).

Creating external units and bills of costs

Parcel Express buys the following components from outside vendors:

- Standard envelopes
- 2nd Day flats
- Overnight flats
- Large boxes
- Small boxes

These costs must be accounted for in the model. To do so, you will create external units and assign them to cost object accounts, thereby creating bills of costs.
Create the Materials dimension members
1. Select Model > Dimensions Page.
2. Using the techniques that you have learned, create the following Materials dimension members:

- Standard Envelope
- 2nd Day Flat
- Overnight Flat
- Large Box
- Small Box

<table>
<thead>
<tr>
<th>Name</th>
<th>Reference</th>
<th>DimLevelName</th>
</tr>
</thead>
<tbody>
<tr>
<td>Envelopes</td>
<td>ENV</td>
<td>Level1</td>
</tr>
<tr>
<td>Standard Envelope</td>
<td>SENV</td>
<td>Level1</td>
</tr>
<tr>
<td>Flats</td>
<td>PTS</td>
<td>Level1</td>
</tr>
<tr>
<td>2nd Day Flat</td>
<td>2DF</td>
<td>Level2</td>
</tr>
<tr>
<td>Overnight Flat</td>
<td>ONF</td>
<td>Level2</td>
</tr>
<tr>
<td>Boxes</td>
<td>BX</td>
<td>Level1</td>
</tr>
<tr>
<td>Large Box</td>
<td>LBX</td>
<td>Level2</td>
</tr>
<tr>
<td>Small Box</td>
<td>SBX</td>
<td>Level2</td>
</tr>
</tbody>
</table>

Tip: Select Edit > New Dimension Member to open the New Dimension Member dialog box.

Create External Units accounts
1. Select Model > External Units Module.
   - You see the External Units module, which has no structure yet.
2. Select Edit > New Account.
   - You see the New Account wizard.
3. Select the following dimension members:
   - Standard Envelope
   - 2nd Day Flat
   - Overnight Flat
   - Large Box
   - Small Box
4. Click Add and then click Next.
   - You see Step 2 of the wizard.
5. Enter the following unit costs:

<table>
<thead>
<tr>
<th>Account</th>
<th>Unit Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>Standard Envelope</td>
<td>.06</td>
</tr>
<tr>
<td>2nd Day Flat</td>
<td>.14</td>
</tr>
<tr>
<td>Overnight Flat</td>
<td>.14</td>
</tr>
<tr>
<td>Large Box</td>
<td>.95</td>
</tr>
<tr>
<td>Small Box</td>
<td>.75</td>
</tr>
</tbody>
</table>

6. Click Finish.

You see the following external unit structure:

<table>
<thead>
<tr>
<th>Display Name</th>
<th>Display Reference</th>
<th>Unit Cost</th>
<th>Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>External Units</td>
<td>ENV</td>
<td>$0.00</td>
<td></td>
</tr>
<tr>
<td>Standard Envelope</td>
<td>SENV</td>
<td>$0.00</td>
<td></td>
</tr>
<tr>
<td>Flats</td>
<td>FTS</td>
<td>$0.00</td>
<td></td>
</tr>
<tr>
<td>2nd Day Flat</td>
<td>2DF</td>
<td>$0.14</td>
<td></td>
</tr>
<tr>
<td>Overnight Flat</td>
<td>ONF</td>
<td>$0.14</td>
<td></td>
</tr>
<tr>
<td>Large Box</td>
<td>LBOX</td>
<td>$0.05</td>
<td></td>
</tr>
<tr>
<td>Small Box</td>
<td>SBOX</td>
<td>$0.75</td>
<td></td>
</tr>
</tbody>
</table>

**Modify the Cost Assignment column layout**

1. In the External Units module, show the Right assignments pane.
2. Select the Cost Assignment column layout, and click the arrow beside the Column Layout list.
3. In the Primary pane, remove Display Reference.
4. Modify the Right pane as follows:
   c. Remove Reference.
   d. Add Driver Quantity Fixed (DQF) and Driver Quantity Variable (DQV).
5. Click Save and OK.

**Add accounts for assignments**

1. Open the Add Accounts for Assignments dialog box.
2. Add the following Cost Object accounts to the Right pane:

<table>
<thead>
<tr>
<th>Cost Object Account</th>
</tr>
</thead>
<tbody>
<tr>
<td>No &lt;Channel&gt; x 2nd Day Guaranteed</td>
</tr>
<tr>
<td>No &lt;Channel&gt; x Overnight Express</td>
</tr>
<tr>
<td>No &lt;Channel&gt; x Standard Ground</td>
</tr>
</tbody>
</table>
Adding Bills of Costs

Make assignments

1. Make assignments that have the following driver quantities:

<table>
<thead>
<tr>
<th>External Unit Account</th>
<th>Cost Object Account</th>
<th>DQF</th>
<th>DQV</th>
</tr>
</thead>
<tbody>
<tr>
<td>Standard Envelope</td>
<td>No &lt;Channel&gt; x Overnight Express</td>
<td>26,000</td>
<td></td>
</tr>
<tr>
<td>2nd Day Flat</td>
<td>No &lt;Channel&gt; x 2nd Day Guaranteed</td>
<td></td>
<td>1.00</td>
</tr>
<tr>
<td>Overnight Flat</td>
<td>No &lt;Channel&gt; x Overnight Express</td>
<td>130,000</td>
<td></td>
</tr>
<tr>
<td>Large Box</td>
<td>No &lt;Channel&gt; x Standard Ground</td>
<td>125,000</td>
<td></td>
</tr>
<tr>
<td>Small Box</td>
<td>No &lt;Channel&gt; x Standard Ground</td>
<td>76,500</td>
<td></td>
</tr>
</tbody>
</table>

Note: When you make assignments from External Units, the software automatically applies the Bill of Cost driver.

2. Select Model > Assignments > Show Single Pane.

3. Calculate the model, and close the Operation Summary.

You see the following external units costs:

<table>
<thead>
<tr>
<th>Display Name</th>
<th>Unit Cost</th>
<th>Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>External Units</td>
<td>$1,560.00</td>
<td>$15,660.00</td>
</tr>
<tr>
<td>Envelopes</td>
<td>$0.08</td>
<td>$1,560.00</td>
</tr>
<tr>
<td>Large Box</td>
<td>$0.95</td>
<td>$11,975.00</td>
</tr>
<tr>
<td>Small Box</td>
<td>$0.75</td>
<td>$57,775.00</td>
</tr>
</tbody>
</table>

Note: The 2nd Day Flat external unit does not have a cost yet because you assigned a variable driver quantity of 1. Until you enter an output quantity for the 2nd Day Guaranteed product, the system cannot calculate the cost of 2nd Day Flats.
Entering Output, Sales, and Revenue Data

Some of the most critical calculations in a model rely on the number of products that are produced and sold, as well as sales revenue. From these quantities, you can determine unit costs and profit. SAS Activity-Based Management provides properties for the input and calculation of these numbers.

Entering output quantities

In SAS Activity-Based Management models, output quantity can be derived from a number of user-entered quantities. In this model you will enter data into the Output Quantity UE (User Entered) property and the Sold Quantity property, both of which will be used to calculate the Sold Quantity of an account. The software uses Output Quantity to calculate Unit Cost also.

➤ Create a new column layout
1. Select Model > Cost Object Module.
2. Select the Default column layout.
3. Expand the No <Channel> roll-up account.
4. Create a new column layout called Unit Cost by modifying the Primary pane as follows:
   a. Remove the Display Reference column.
   b. Add the Unit Cost, Output Quantity UE, and Output Quantity properties.

➤ Enter output quantities and calculate costs
1. In the OutQtyUE (Output Quantity User Entered) column, enter the following quantities:

<table>
<thead>
<tr>
<th>Account</th>
<th>Quantity (OutQtyUE)</th>
</tr>
</thead>
<tbody>
<tr>
<td>No &lt;Channel&gt; x 2&lt;sup&gt;nd&lt;/sup&gt; Day Guaranteed</td>
<td>93,500</td>
</tr>
<tr>
<td>No &lt;Channel&gt; x Overnight Express</td>
<td>101,000</td>
</tr>
<tr>
<td>No &lt;Channel&gt; x Standard Ground</td>
<td>193,500</td>
</tr>
</tbody>
</table>

2. Calculate the model, and close the Operation Summary.
You see the unit cost for each product. Output quantities have been generated for each product.

<table>
<thead>
<tr>
<th>Display Name</th>
<th>Cost</th>
<th>UnitCost</th>
<th>OutQtyUE</th>
<th>OutQty</th>
</tr>
</thead>
<tbody>
<tr>
<td>COST OBJECT (PRIMARY PANE)</td>
<td>$3,856,875.00</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Drop Box</td>
<td>$83,594.52</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Walk In</td>
<td>$152,002.46</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Commercial Pick Up</td>
<td>$95,997.30</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>No &lt;Channel&gt;</td>
<td>$3,054,880.01</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2nd Day Guaranteed</td>
<td>$892,283.31</td>
<td>9.44</td>
<td>82,500.00</td>
<td>82,500.00</td>
</tr>
<tr>
<td>Overnight Express</td>
<td>$771,880.38</td>
<td>7.84</td>
<td>101,000.00</td>
<td>101,000.00</td>
</tr>
<tr>
<td>Standard Ground</td>
<td>$1,840,726.62</td>
<td>10.03</td>
<td>183,500.00</td>
<td>183,500.00</td>
</tr>
</tbody>
</table>

**Note:** If you return to the External Units module, you will see that a cost has now been generated for the 2nd Day Flat account. The reason for this is that you assigned cost by using the Driver Quantity Variable (DQV) property, which requires an output quantity for calculation. Now that you have entered the 2nd Day Guaranteed output quantity, the 2nd Day Flat external unit account can be calculated.

## Entering sales volumes

You enter sales volumes in the Sold Quantity property.

**Modify the Cost Assignment column layout**

1. In the Cost Object module, show the Right assignments pane.
2. Select the Cost Assignment column layout and click the arrow beside the Column Layout list.
3. In the Column Layout dialog box, modify the Primary pane as follows:
   a. Remove Display Reference.
   b. Add Driver Name.
4. Modify the Right pane as follows:
   a. Remove Reference.
   b. Add Sold Quantity.
5. Click Save and OK.

**Add accounts to the Right pane**

1. Open the Add Accounts for Assignments dialog box.
2. Add the following Cost Object accounts to the Right pane for assignment:
3. Click **Close**.

➤ **Enter sales volumes**

1. In the Primary pane, select the **Sales Volume** driver for the following accounts:

<table>
<thead>
<tr>
<th>Cost Object Account</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drop Box x 2&lt;sup&gt;nd&lt;/sup&gt; Day Guaranteed</td>
</tr>
<tr>
<td>Drop Box x Overnight Express</td>
</tr>
<tr>
<td>Drop Box x Standard Ground</td>
</tr>
<tr>
<td>Walk In x 2&lt;sup&gt;nd&lt;/sup&gt; Day Guaranteed</td>
</tr>
<tr>
<td>Walk In x Overnight Express</td>
</tr>
<tr>
<td>Walk In x Standard Ground</td>
</tr>
<tr>
<td>Commercial Pick Up x 2&lt;sup&gt;nd&lt;/sup&gt; Day Guaranteed</td>
</tr>
<tr>
<td>Commercial Pick Up x Overnight Express</td>
</tr>
<tr>
<td>Commercial Pick Up x Standard Ground</td>
</tr>
</tbody>
</table>

2. In the Right pane, enter the following **SoldQty** for the following accounts:

<table>
<thead>
<tr>
<th>Account</th>
<th>SoldQty</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drop Box x 2&lt;sup&gt;nd&lt;/sup&gt; Day Guaranteed</td>
<td>13,500</td>
</tr>
<tr>
<td>Drop Box x Overnight Express</td>
<td>6,000</td>
</tr>
<tr>
<td>Drop Box x Standard Ground</td>
<td>32,500</td>
</tr>
<tr>
<td>Walk In x 2&lt;sup&gt;nd&lt;/sup&gt; Day Guaranteed</td>
<td>50,000</td>
</tr>
<tr>
<td>Walk In x Overnight Express</td>
<td>56,000</td>
</tr>
<tr>
<td>Walk In x Standard Ground</td>
<td>110,000</td>
</tr>
<tr>
<td>Commercial Pick Up x 2&lt;sup&gt;nd&lt;/sup&gt; Day Guaranteed</td>
<td>30,000</td>
</tr>
<tr>
<td>Commercial Pick Up x Overnight Express</td>
<td>39,000</td>
</tr>
<tr>
<td>Commercial Pick Up x Standard Ground</td>
<td>51,000</td>
</tr>
</tbody>
</table>
Note: At this point in other modules, you would make assignments from the accounts in the Primary pane to the accounts in the Right pane. However, the Sales Volume driver automatically assigns costs based on the sales volumes (SoldQty) that you entered.

3. While the Primary and Right panes are still open, calculate the model and close the Operation Summary.
   You see that costs are now assigned to the nine accounts that previously did not have costs.

4. In the Primary pane, click the Drop Box x No <Products and Services> account.
   You see that assignments have automatically been made to three accounts in the Right pane.

**Entering revenue and calculating profit**

Profit and loss can be calculated after you enter sales data in the Revenue property.

➤ Create a new column layout
1. Select Model > Cost Object Module.
2. Select the Default column layout.
3. Select Model > Assignments > Show Single Pane.
4. Open the Column Layout dialog box.
5. Modify the Primary pane as follows:
   a. Remove the Display Reference column.
   b. Add the Unit Cost, Sold Quantity, Revenue, and Profit columns.
6. Save the layout as Profit.
7. Close the Column Layout dialog box.

➤ Enter revenue and calculate profit
1. In the Revenue column, type the following values:
## Entering Output, Sales, and Revenue Data

### Cost Object Account

<table>
<thead>
<tr>
<th>Cost Object Account</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drop Box x 2&lt;sup&gt;nd&lt;/sup&gt; Day Guaranteed</td>
<td>93,825</td>
</tr>
<tr>
<td>Drop Box x Overnight Express</td>
<td>89,700</td>
</tr>
<tr>
<td>Drop Box x Standard Ground</td>
<td>568,750</td>
</tr>
<tr>
<td>Walk In x 2&lt;sup&gt;nd&lt;/sup&gt; Day Guaranteed</td>
<td>347,500</td>
</tr>
<tr>
<td>Walk In x Overnight Express</td>
<td>837,200</td>
</tr>
<tr>
<td>Walk In x Standard Ground</td>
<td>1,925,000</td>
</tr>
<tr>
<td>Commercial Pick Up x 2&lt;sup&gt;nd&lt;/sup&gt; Day Guaranteed</td>
<td>208,500</td>
</tr>
<tr>
<td>Commercial Pick Up x Overnight Express</td>
<td>583,050</td>
</tr>
<tr>
<td>Commercial Pick Up x Standard Ground</td>
<td>892,500</td>
</tr>
</tbody>
</table>

2. Calculate the model, and close the **Operation Summary**.

You see the following profit (and loss) information:

<table>
<thead>
<tr>
<th>Display Name</th>
<th>Cost</th>
<th>Unit Cost</th>
<th>Sold Qty</th>
<th>Revenue</th>
<th>Profit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total Cost</td>
<td>$3,856,875,00</td>
<td>$10.82</td>
<td>$375,275</td>
<td>$3,856,875,00</td>
<td>$198,487,44</td>
</tr>
<tr>
<td>Drop Box</td>
<td>$562,787,56</td>
<td>$10.82</td>
<td>$50,000</td>
<td>$562,787,56</td>
<td>$18,487,44</td>
</tr>
<tr>
<td>Drop Box x 2&lt;sup&gt;nd&lt;/sup&gt; Day Guaranteed</td>
<td>$143,000,00</td>
<td>$10.86</td>
<td>13,500</td>
<td>$93,825,00</td>
<td>($90,075,06)</td>
</tr>
<tr>
<td>Drop Box x Overnight Express</td>
<td>$53,179,03</td>
<td>$10.86</td>
<td>6,000</td>
<td>$89,700,00</td>
<td>$36,520,97</td>
</tr>
<tr>
<td>Drop Box x Standard Ground</td>
<td>$365,708,46</td>
<td>$11.25</td>
<td>32,500</td>
<td>$892,750,00</td>
<td>$220,041,54</td>
</tr>
<tr>
<td>Walk In x 2&lt;sup&gt;nd&lt;/sup&gt; Day Guaranteed</td>
<td>$30,594,53</td>
<td>$1.12</td>
<td>27,000</td>
<td>$30,594,53</td>
<td>$71,500,07</td>
</tr>
<tr>
<td>Walk In x Overnight Express</td>
<td>$155,520,00</td>
<td>$10.99</td>
<td>21,000</td>
<td>$2,155,520</td>
<td>$1,956,170,02</td>
</tr>
<tr>
<td>Walk In x Standard Ground</td>
<td>$1,159,960,53</td>
<td>$10.74</td>
<td>110,000</td>
<td>$1,159,960,53</td>
<td>$74,200,17</td>
</tr>
<tr>
<td>No. Products and Services</td>
<td>$1,925,002,46</td>
<td>$4.71</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Commercial Pick Up x 2&lt;sup&gt;nd&lt;/sup&gt; Day Guaranteed</td>
<td>$1,138,563,52</td>
<td>$9.49</td>
<td>120,000</td>
<td>$1,138,563,52</td>
<td>$54,168,48</td>
</tr>
<tr>
<td>Commercial Pick Up x Overnight Express</td>
<td>$254,508,14</td>
<td>$9.02</td>
<td>30,000</td>
<td>$254,508,14</td>
<td>$254,000,17</td>
</tr>
<tr>
<td>Commercial Pick Up x Standard Ground</td>
<td>$521,082,36</td>
<td>$10.47</td>
<td>50,000</td>
<td>$521,082,36</td>
<td>$351,444,64</td>
</tr>
<tr>
<td>No. Products and Services</td>
<td>$75,997,58</td>
<td>$0.38</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>No. Channel</td>
<td>$3,364,000,51</td>
<td>$9.44</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2&lt;sup&gt;nd&lt;/sup&gt; Day Guaranteed</td>
<td>$882,293,31</td>
<td>$9.44</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Overnight Express</td>
<td>$771,600,29</td>
<td>$17.64</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Standard Ground</td>
<td>$1,940,725,82</td>
<td>$10.03</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Adding Attributes

An attribute is a label or identification tag that is attached to a roll-up account, an account, or an entered cost element. The attribute conveys information about the object to which it is attached.

Attributes have many purposes. You can use them to:

- Group activity-based management data to simplify report preparation and interpretation
- Create different dimensions of data
- Report similar cost categories across cost centers
- Classify cost components as fixed or variable, value-added or non-value-added

Types of attributes

There are four attributes types:

- Text
- Numeric
- Dimension
- Boolean

Text attributes

A text attribute describes model information and enables you to categorize, select, and subtotal information in a report. Activities can be grouped by summary-level processes, such as detailed manufacturing activities rolling up to “manufacturing,” and detailed distribution activities rolling up to “distribution.” The names of these higher-level processes are defined as text attributes and are attached to their respective activities.

Other examples of text attributes include:

- Value-added categories (high, medium, low) that are attached to activities
- Fixed cost/variable cost that is attached to resources—enables you to group activity or cost object costs by fixed and variable cost components
- Cost object groupings that are used to roll up products by product family, brand, market segment, or package type or to group customers by region, channel, or salesperson
**Adding Attributes**

**Numeric attributes**
A numeric attribute enables you to enter data that is not entered or otherwise generated in a model.

Typically, numeric attributes are measures or quantities of units that contribute to the total cost of an activity, such as number of cases, number of pounds, number of orders, or number of times an activity is performed.

You can establish numeric attributes as performance measures for special reporting purposes, such as tracking productivity (number of inputs or rejects, cycle time, and quality), or classifying information (level of complexity or number of sub-assemblies).

**Dimension and dimension member attributes**
A dimension attribute reflects a dimension, and a dimension member attribute reflects a dimension member.

**Boolean attributes**
A boolean attribute stores a Boolean value (True or False).

**Creating attributes**
You will create a numeric attribute and a dimension attribute.

- Create a numeric attribute
  1. Select **Model > Attributes Page**.
  2. Select **Edit > New Attribute**.
     
     You see the New Attribute dialog box.

     ![New Attribute dialog box](image)

     3. For **Name**, type **Inspections Passed**.

     ![New Attribute dialog box](image)
Adding Attributes

4. Type a Reference of IP.
5. Select an Attribute type of Numeric.
6. For Unit of Measure, type Number of Inspections Passed.
7. Click OK.
   You see that the Inspections Passed attribute has been added to the list.

Create a dimension attribute
1. Select Edit > New Attribute.
2. Type a Name of Fixed_Variable
3. Type a Reference of FV.
4. Select a Type of Dimension.
5. Click OK.
6. Select the Fixed_Variable attribute.
7. Create the following two dimension attributes:

<table>
<thead>
<tr>
<th>Name</th>
<th>Reference</th>
<th>Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fixed</td>
<td>F</td>
<td>Dimension Value</td>
</tr>
<tr>
<td>Variable</td>
<td>V</td>
<td>Dimension Value</td>
</tr>
</tbody>
</table>

8. Select Model > Dimensions Page.
   You see that the Fixed_Variable dimension and its two dimension members have been added to the list of your model’s dimensions.

Entering attribute quantities
Now, you will display a column to enter attribute quantities.

Add a column to show an attribute
1. Select Model > Activity Module.
2. Select the Default column layout and display the module in Single Pane view.
3. Add the Inspections Passed attribute to the Primary pane.
   Tip: Look in the Attributes folder at the bottom of the list.
4. Expand the hierarchy to show all Activity accounts.
   You see that Inspections Passed has been added to the layout.
Enter attribute quantities

1. In the Inspections Passed column for the Beaverton x Inspection account, type 43400.
2. In the Inspections Passed column for the Eugene x Inspection account, type 1100.
Generating Reports

When the information has been entered into the activity-based management model, the costs have been calculated, and the data has been reviewed, the next step in analyzing the data is generating reports.

The benefits of generating reports include:

- Validating the model
- Producing printouts that present an overall view of the data
- Analyzing costs on the screen
- Producing files for inclusion in other programs, such as spreadsheets or word processors
- Focusing on a specific area of interest

Report templates

A report template is a file that specifies the layout of a report and the fields of data in a report (but not the data itself). When you create a report, you first select a report template.

SAS Activity-Based Management has pre-defined report templates that provide formats and that permit great flexibility in the amount and type of information to include in a report. The following pre-defined templates are included:

- Destination Furthest
- Dimensional Attribute Cost
- Dimensional Attribute Unit Cost
- Dimensional View
- Driver—Cost and Rate
- Idle Capacity
- Module Hierarchy
- Multi-level Contributions
- Profit and Loss
- Profit Cliff
- Resource Contributions
- Resource Contributions by attribute
Generating Reports

- Single-stage Assignments
- Single-stage Contributions
- Unassigned Costs
- Unit Cost

Creating a report

You will create a report and view the results on-screen. The report is for the 2003 Q1/Actual period/scenario association, and includes information about resource contributions.

To create a new report, you use the New Report wizard. The wizard has six steps.

1. Select a model and template

   1. Click [Reports].
      
      You see the Reports home page.
      
      You see Step 1 of the New Report wizard.


   4. Click Next.
      
      You see Step 2 of the wizard.
Generating Reports

5. Select 2003 Q1/Actual, and click Next.
   You see Step 3 of the wizard.
6. Select Use all modules, and click Next.
   You see Step 4 of the wizard.
7. Verify that no dimensions are selected, and click Next.
   You see Step 5 of the wizard.
8. Verify that Suppress zero costs, Single currency, and the SAS report tool are selected.
   **Note:** If the Crystal Reports tool is installed on your server, you can select that option.
9. For Step 6, select Save configuration.
10. Type a Name of PX Single-stage Assignments.
11. Click Finish.
    You see the finished report in Portable Document Format (PDF).

The data that is contained in this report reflects the current model. If you make changes to the model and re-open the report, the report data reflects the changes.
Generating Reports

Each report has a header that lists pertinent information for that report. All or some of the following information can be listed in a report's header:

<table>
<thead>
<tr>
<th>Information</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Model Name</td>
<td>The model that is selected for the report.</td>
</tr>
<tr>
<td>Module</td>
<td>One or more modules that are selected for the report. Each module starts on a new page</td>
</tr>
<tr>
<td>Period</td>
<td>The period that is selected for the report.</td>
</tr>
<tr>
<td>Scenario</td>
<td>The scenario that is selected for the report.</td>
</tr>
<tr>
<td>View Perspective</td>
<td>The structural dimension that is selected for the report.</td>
</tr>
<tr>
<td>Filtered</td>
<td>Indicates that one or more attributes were used to select items for the report. Attributes that are used to select report data is listed on a report's last page.</td>
</tr>
</tbody>
</table>

Working with reports

All saved report configurations that are on the same server are listed in the Workspace Manager. Your company might want to set up some guidelines for saving and naming report configurations. You can open a report configuration from the Workspace Manager or from the Reports home page.

On the Reports home page, you can open, publish, configure, or delete a report configuration.

Navigating reports

You can navigate the pages of a report by using the standard Adobe Acrobat paging and search tools on the toolbar.

Saving report data

When you save a report configuration, you are saving only the parameters of the report but not the data. To save the data in a report, you must publish or export the report.

Publishing report data

If you want other users to see the report results along with the data that reflects a specific time period, you can publish the report. Publishing the report enables others to see the report data without having to re-run the report. In cases where a report requires considerable time to run, publishing the report can save other users time.
Generating Reports

- **Publish report data**

  1. On the Reports home page, click the Publish link next to the desired report configuration.
     
     You see the Publish a Report dialog box.

     ![Publish a Report dialog box](image)

     - **Name:**
     - **Description:**
     - **Format:**

  2. Type a Name.

     **Note:** You cannot enter a path. Published reports are stored on the SAS Activity-Based Management server.

  3. (Optional) Type a Description.

  4. Select a Format.

     The available publishing formats are:

     - Portable Document Format (PDF)
     - Rich Text Format (RTF)

  5. Click OK.

     The report is added to the Workspace Manager in the Published Reports folder.

- **Exporting report data**

  If you want to manipulate a report after running it, you can export the report. Data that you export from SAS Activity-Based Management can be used by other reporting tools, such as Enterprise Guide. To export a report, select File > Export > Report Data, and follow the instructions in the Report Data wizard.

- **Configuring reports**

  By running the New Report wizard, you are configuring a report. Note that you can reconfigure a report as follows.

  - **Reconfigure a report**

    1. On the Reports home page, click the Configure link next to the saved configuration.

Using OLAP Cubes for Analysis

A cube is the basic unit of analysis in online analytic processing (OLAP), a technology that provides fast, interactive access to data in a model. A cube is a storage unit that combines a number of dimensions and the measures they contain into one unit. You use SAS Activity-Based Management to connect to and interact with the cubes on a SAS Activity-Based Management server. For each model, you can generate cubes and manipulate them on the OLAP page to interactively analyze business data.

The SAS Activity-Based Management OLAP tool provides three views from which to analyze data:

- Grid View
- Chart View
- Decomposition Tree View

You can select the view that presents the data in the most meaningful format for your purposes.

Cube overview

A cube is a data set that is constructed from a subset of model data and that is organized and summarized into a multi-dimensional structure. SAS Activity-Based Management cubes are standard OLAP cubes.

It does not matter how many dimensions a cube has; the storage unit is still called a cube, which represents any number of dimensions of data.

Types of cubes

SAS Activity-Based Management provides the following types of cubes:

- Multi-stage contributions
- Resource contributions
- Single-stage contributions

Each one helps you to analyze data in different ways and to answer different kinds of questions.

Multi-stage contributions cube

Use this cube to answer questions such as:

- Product A is not profitable. You want to trace the costs back through activities and then to resources that contribute costs to this product.
What are the costs for Product B that originate in salary resources and that are assigned through the Inspection activity to this product?

The Multi-stage Contributions cube enables you to analyze cost contributions into and out of stages that are defined in a model. The Decomposition Tree View enables you to visually trace cost contributions through all the stages.

**Resource contributions cube**

Use the Resource Contributions cube to analyze resource accounts that contribute costs to other accounts. Or, use this cube to analyze the accounts that receive costs from resources.

The Resource Contributions cube enables you to study cost contributions from original accounts (where costs were entered) to final accounts that do not assign costs to other accounts. Generally, these contributions are from resource accounts to cost object accounts, but it does not matter where the original or final accounts reside.

**Single-stage contributions cube**

Use this cube to answer questions such as:

- Which activity costs contribute to product, customer, service costs, and so on?
- When costs are assigned within the Cost Object module, which sub-assembly costs contribute to product costs?
- What are the costs of resources that contribute to activities?

The Single-stage Contributions cube enables you to analyze the cost contributions from one assignment level back. It does not matter where the costs originate or end. Typically, cost is contributed from:

- Activities to cost objects
- Resources to activities

**Generating cubes**

Before you can use OLAP cubes to analyze model data, you must generate cube data. Then you can select the type of cube that meets your analysis objectives.

1. In Model mode, select **Model > Calculate Costs and Generate Cubes**.
   - You see the Calculate Costs and Generate Cubes dialog box.
2. Select **Calculate costs and generate cubes**.
3. Verify that the three types of cubes in the **Generate these cubes** list are all selected.
4. Click **OK**.
   - You see the Operation Summary.
5. Close the **Operation Summary**, and change to OLAP mode.
Creating OLAP views

Create an OLAP view

1. Select **File > New > OLAP View**.
   
   You see Step 1 of the New OLAP View wizard. The OLAP wizard has only one step.

   ![New OLAP View Wizard](image)

   - **What model do you want to use?**
     - [Select Model]
   - **What cube do you want to base the view on?**
     - [Select Cube]
     - Do not select any dimensions by default.
     - Select this option when the cube contains a large amount of data, and the default dimensions are not the dimension you want to examine. This can save time when first creating an OLAP view. You can select other dimensions later.

2. Select the **Parcel Express** model.
3. Select the **Resource Contributions** cube.
4. Click **Finish**.

   You see the Resource Contributions cube for the Parcel Express model.
Using OLAP Cubes for Analysis

By default, the Chart View contains a bar chart and grid. You can change the style of chart.

The Decomposition Tree View enables you to drill down through the model to view the flow of costs.

So far, the only information that the cube has provided is the costs for periods and scenarios. To perform an interactive analysis of the cube, you will select specific dimensions for analysis.

5. Close the Decomposition Tree View window.
6. Maximize the Chart View window.

Analyzing OLAP cubes

You use the Dimension Control to select dimensions for analysis in OLAP cubes.

Selecting and displaying dimensions in cubes

- Select dimensions
  1. Select OLAP > Show/Hide Dimension List.
     You see the Dimension Control.
2. Drag **All Period** from the **Rows** list and **All Scenario** from the **Columns** list to the **Background** list.

3. From **Background**, drag **Src Region** and **Src General Ledger** to the **Rows** list.

4. From **Background**, drag **Dst Products and Services** to the **Columns** list.

   Rows and Columns should look like the following:

5. Move the mouse pointer to the **Chart View**.

   You see that the Chart View has changed slightly. The data in the Chart View has been updated according to the dimensions that you have selected, but to see the details, you must drill through the dimensions.

6. Close the **Dimension Control**.
Drill through dimensions

1. Move the mouse pointer to the All column in the grid.
   The pointer changes to a drill, which indicates that you can drill down on this dimension.

2. Click the All column.
   You see the Products and Services dimension expand, showing the costs for each product.

3. To eliminate empty rows and columns, select OLAP > Filter Data.
   You see the Filtering dialog box.

4. Select the Empty rows and Empty columns options and click OK.
   You see that the empty columns have been removed from the grid and chart.

5. Drill down on the two cells that are labeled All until you see the general ledger expenses for Eugene and Beaverton.
   Both the grid and bar chart show the contribution of resource accounts to each product.
6. In the Dimension Control, add **Dst Channel** to **Columns** and drill down on the added column in the grid.

You see that the Channel dimension has been added to the grid and chart.

![Chart View - USD ($)](image)

**Cost for Cost Object (Level 01 in All)**

<table>
<thead>
<tr>
<th></th>
<th>2nd Day Guaranteed</th>
<th>Overnight Express</th>
<th>Standard Ground</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Beaverton</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Equipment Expenses</td>
<td>10,937.52</td>
<td>18,959.14</td>
<td>24,783.92</td>
</tr>
<tr>
<td>Operating Expenses</td>
<td>47,952.24</td>
<td>50,825.28</td>
<td>109,222.95</td>
</tr>
<tr>
<td>Wages</td>
<td>342,146.23</td>
<td>452,369.61</td>
<td>804,655.66</td>
</tr>
<tr>
<td><strong>Eugene</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Equipment Expenses</td>
<td>11,791.85</td>
<td>4,896.30</td>
<td>21,311.84</td>
</tr>
<tr>
<td>Operating Expenses</td>
<td>24,530.45</td>
<td>24,306.43</td>
<td>152,155.39</td>
</tr>
<tr>
<td>Wages</td>
<td>435,152.26</td>
<td>152,725.01</td>
<td>750,052.74</td>
</tr>
</tbody>
</table>

**Cost for Children of All, Cost Object**

<table>
<thead>
<tr>
<th></th>
<th>2nd Day Guaranteed</th>
<th>Commercial Pick Up</th>
<th>Drop Box</th>
<th>Walk In</th>
<th>Overnight Express</th>
<th>Commercial Pick Up</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Beaverton</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Equipment Expenses</td>
<td>5,443.72</td>
<td>1,573.17</td>
<td></td>
<td>5,940.64</td>
<td>7,075.38</td>
<td></td>
</tr>
<tr>
<td>Operating Expenses</td>
<td>15,213.14</td>
<td>5,002.15</td>
<td></td>
<td>25,836.72</td>
<td>30,991.80</td>
<td></td>
</tr>
<tr>
<td>Wages</td>
<td>106,413.53</td>
<td>48,085.92</td>
<td></td>
<td>185,726.13</td>
<td>185,897.68</td>
<td></td>
</tr>
<tr>
<td><strong>Eugene</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Equipment Expenses</td>
<td>3,705.15</td>
<td>1,819.46</td>
<td></td>
<td>5,267.30</td>
<td>1,824.79</td>
<td></td>
</tr>
<tr>
<td>Operating Expenses</td>
<td>26,607.30</td>
<td>12,679.90</td>
<td></td>
<td>45,051.27</td>
<td>12,980.13</td>
<td></td>
</tr>
<tr>
<td>Wages</td>
<td>134,785.17</td>
<td>70,049.42</td>
<td></td>
<td>230,317.25</td>
<td>66,517.14</td>
<td></td>
</tr>
</tbody>
</table>
Using measures in cubes

A measure is a property or an attribute that you can use to analyze OLAP information. The default measure is Cost. Now, you will select different measures and create a custom measure.

➢ Working with measures in OLAP

1. Select OLAP > Grid.

You see that the Chart View has changed to Grid View.

2. Using the Dimension Control, select the following dimensions:

<table>
<thead>
<tr>
<th>Row</th>
<th>Column</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dst Products and Services</td>
<td>Measures</td>
</tr>
</tbody>
</table>


You see the Measures tab. This is a list of measures by which you can analyze the cube.

You can select any combination of measures to view. To select more than one measure, hold the Ctrl key while selecting. The order in which you select measures determines the order of rows in the grid.

4. Select the following measures in the order that they are listed:

<table>
<thead>
<tr>
<th>Measure</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost</td>
</tr>
<tr>
<td>UnitCost</td>
</tr>
<tr>
<td>Revenue</td>
</tr>
<tr>
<td>UnitRevenue</td>
</tr>
<tr>
<td>Profit</td>
</tr>
<tr>
<td>UnitProfit</td>
</tr>
</tbody>
</table>

You see that the 2nd Day Guaranteed product is losing money, while the other two products are profitable.
5. To see whether this trend is similar across all channels, add Dst Channel to Rows.

One of management’s goals was to make a profit of at least 10% on the 2nd Day Guaranteed product and at least 25% on all others. SAS Activity-Based Management has shown that the company’s profit picture is not what management expected. Competitive pressures forced them to lower the price of their 2nd Day product, but they did not know that they were losing money on every unit sold.

Now, you will create a custom measure to calculate gross margin.

➤ Create a custom measure

1. On the Dimension Control, click .

You see Step 1 of the New Measure wizard.

2. Select Custom formula, and click Next.

You see the next step of the wizard.
3. Type a Name of Gross Margin.

4. To create the formula:
   a. In Measures, select Profit, and click Insert.
   b. On the key pad, click the division symbol (/).
   c. In Measures, select Revenue, and click Insert.
      The formula should appear as follows:

      ![Diagram showing the formula]

      
      Formula: 
      
      \[ \frac{[\text{Measures}][\text{Profit}]}{[\text{Measures}][\text{Revenue}]} \]

      d. Select a Format String of 0%.
      e. Click Finish.

      You see that the Gross Margin measure has been added to My Items in Measures.

5. Move the mouse pointer to the Grid View.

      You see the profit margin of each product.

      | Gross Margin         |       |
      |----------------------|-------|
      | 2nd Day Guaranteed   | -44%  |
      | Overnight Express    | 46%   |
      | Standard Ground      | 44%   |

      Based on the stated goals of the company, the 2nd Day Guaranteed is under-performing, while the other two products are over-performing.
Now, you will analyze the model by using the Decomposition Tree to get more information about the costs that are associated with each product. This information will help management decide whether costs are too high or pricing is too low for the 2\textsuperscript{nd} Day Guaranteed product.

**Using the Decomposition Tree**

The management of Parcel Express has learned that margins on the 2\textsuperscript{nd} Day Guaranteed product fall well below expectations. The SAS Activity-Based Management OLAP tool will help them assess how costs for that product compare with the costs of other products.

You will create a Multi-Stage Contributions cube and use the Decomposition Tree View to compare Parcel Express products.

➤ **Create a Multi-Stage Contributions cube**

1. Select File > New > OLAP View.
   
   You see the New OLAP View wizard.

2. Select the Parcel Express model.

3. Select the Multi Stage Contributions cube.

4. Click Finish.

   You see the Multi-Stage Contributions cube for the Parcel Express model.

5. Close the Chart View, and maximize the Decomposition Tree View.

6. Move the mouse pointer over the All box.

   You see the cost of the entire model.

[Image showing the Decomposition Tree View with All box highlighted]

➤ **Run the Decomposition Tree wizard**

1. Right-click the background of the Decomposition Tree View.

2. Select Decomposition Tree Wizard.

   You see the first page of the Decomposition Tree wizard.

3. Click Next.

   You see the next page of the wizard.
4. From the For items in list, select Cost Object Products and Services.
5. Click Finish.

➤ Analyze the model in Decomposition Tree View

1. To see the Products and Services dimension members, click All.

   ![Decomposition Tree Wizard]

   **Note:** Dimension member names, such as 2nd Day Guaranteed, are truncated when they are too long to fit in the space that is allotted to them by the software.

2. Right-click 2nd Day Guaranteed.
   
   You see the activities that contribute cost to the 2nd Day Guaranteed product.
Using OLAP Cubes for Analysis

4. To compare the costs of 2nd Day Guaranteed to another product, drill down to the activities that contribute to the cost of Overnight Express.

You see that the cost percentages from each activity are almost identical.


You see the General Ledger accounts that contribute cost to 2nd Day Guaranteed.

6. Compare these figures with the General Ledger costs of Overnight Express.

Again, on a percentage basis, the costs of 2nd Day Guaranteed appear to be comparable to those of other products.
Saving OLAP views and exporting cubes

During the analysis, changes that you make to Grid View, Chart View, and Decomposition Tree View are retained during a session, even when you return to the OLAP page after viewing other tabs. However, when you close the client software or when you close Grid View, Chart View, or Decomposition Tree View, your changes are lost.

To save these changes so that they will be available later, you must save the OLAP view. When you save an OLAP view, you save the layout and contents of the views. However, the window positions and states are not saved.

At any point during OLAP analysis, you can export the displayed data to an Excel spreadsheet. When you export to Excel, you are exporting only the data that is currently displayed and not the entire cube.

➤ Save an OLAP view

1. Select OLAP > Save View.

You see the Save OLAP View As dialog box.

2. Type a name of **PX Multi-Stage Contributions**.
3. Click OK.
4. On the toolbar, click the OLAP Home link.

You see a link to PX Multi Stage Contributions in the OLAP Views list.

➤ Export an OLAP cube

1. Display the OLAP data that you want to export to an Excel spreadsheet.
2. Select OLAP > Export to Excel.

You see an Excel spreadsheet that contains the data that is currently displayed in the cube.
Finishing Up

Now that you have created a SAS Activity-Based Management model and learned the basics of model analysis, you can begin designing and implementing your own models.

Parcel Express conclusions

Using SAS Activity-Based Management, Parcel Express was able to see how costs flowed out of resource accounts to activities, and from activities to cost objects. In modeling the flow of costs through its business processes, the company learned that the 2nd Day Guaranteed product, which managers had assumed was not performing as well as the other products, was performing far worse than expected and was actually losing money across all channels.

An OLAP analysis of the model showed that the percentages of costs that flowed from resource and activity accounts to cost object accounts was consistent across all product categories. Therefore, pricing seemed to be the primary reason for the underperformance. Another revelation was the amount of profit that was being made on the other two products.

Management must now decide how much of a loss, if any, is acceptable on the 2nd Day Guaranteed product. How will a price change affect volume? Is the higher profit on other products enough to offset the loss on 2nd Day Guaranteed?

To assess the impact of changes to the pricing structure, Parcel Express can use SAS Activity-Based Management to model possible future scenarios.

Additional features

Many SAS Activity-Based Management features are not covered in this tutorial or are covered only briefly. These include:

- Importing data from other information systems
- Importing models from databases, XML, or Oros
- Exporting models to databases or XML
- Sharing models
- Managing the ownership and permissions for items
- Publishing period/scenario associations
- Managing item properties
- Working with large models
Finishing Up

- Selecting currencies and exchange rates
- Working with internal units
- Creating stage attributes
- Creating custom report templates
- Using the SAS Services API

To build effective and complete models for your organization, you will want to use some of these additional features. Because your models will be much larger than the Parcel Express model, you might want to read about model size and performance in the online Help.

What to do next

If you felt comfortable using the basic tools and techniques to build the Parcel Express model, use them on a simple project of your own.

SAS has a variety of products, including videotapes and training classes, that can help you learn more about activity-based costing, management, and budgeting. We can also help you build models for your organization. If you need additional information, contact your SAS support consultant.
Index

A

account
creating, 29
single-dimension, 35
activity driver, 5
Activity module, 33
activity-based costing, 4
Activity-Based Management
overview, 4
Add Accounts for Assignments dialog box, 42
assignment
making, 41–49
overview, 39
assignments pane, 11
attribute, 13
boolean, 65
creating, 66
dimension, 65
entering quantities, 66
numeric, 65
overview, 64
text, 64
types, 64
attributes
use and benefits, 64

B

bill of costs
creating, 55–59
overview, 54
steps for building, 54

C

Calculate Costs and Generate Cubes dialog box, 50
calculating costs, 50
CAM-I
basic modules, 6
Cost Assignment view, 5
Process view, 5
standards, 4
column layout, 12
creating, 39
Column Layout dialog box, 40
Connect dialog box, 8
cost
calculating, 50
cost driver, 5
Cost Object module, 34
costs
create external units, 56
create
external units, 56
credentials, 8
cube
analyzing, 77
exporting, 87
generating, 75
Multi-stage Contributions, 74
overview, 13, 74
Resource Contributions, 75
Single-stage Contributions, 75
types, 74

D

Decomposition Tree
using, 84
Decomposition Tree wizard, 84
dialog box
Add Accounts for Assignments, 42
Calculate Costs and Generate Cubes, 50
Column Layout, 40
Connect, 8
Dimension Name, 23
Filtering, 79
Manage Period, 18
Manage Scenarios, 19
New Attribute, 65
New Dimension Member, 26
New Driver, 37
Index

New Period, 18
New Scenario, 19
Save Column Layout As, 41
dimension
creating, 21
defining, 23–25
overview, 6
types, 6
Dimension Control, 77
dimension member
creating, 26–29
overview, 26
Dimension Name dialog box, 23
driver
activity, 5
cost, 5
defining, 37
resource, 5

E
external unit, 55

F
Filtering dialog box, 79
fixed quantities, 55

H
Help
online, 2
home page
model, 10
SAS Activity-Based Management, 9

I
internal unit, 55

L
layout, 12

M
Manage Periods dialog box, 18
Manage Scenarios dialog box, 19
measure
custom, 82
in cubes, 81
mode
model, 9
OLAP, 13
Reports, 13
model
build drivers, 37
home page, 10
overview, 6
planning, 14
steps to building, 7
model mode, 9
module
Activity, 33
Cost Object, 34
creating, 29
pages, 10
Resource, 29
types, 6
Multi-stage Contributions cube, 74

N
New Account wizard, 29
New Attribute dialog box, 65
New Dimension Member dialog box, 26
New Driver dialog box, 37
New Measure wizard, 82
New Model wizard, 21
New OLAP View wizard, 76
New Period dialog box, 18
New Report wizard, 69
New Scenario dialog box, 19

O
OLAP cube
overview, 13, 74
OLAP view
creating, 76
saving, 87
online Help, 2
operation summary, 52
output quantity
entering, 59
overview, 59

P
pane
assignments, 11
paper plan
creating, 14
Parcel Express
conclusions, 88
overview, 14
password, 9
period
Index

creating, 17
deleting, 20
overview, 17
planning a model, 14
profit
calculating, 62
property, 13
Q
quantity
fixed, 55
variable, 55
R
report
configuring, 72
generating, 69
navigating, 71
overview, 68
publishing, 71
saving, 71
templates, 68
Resource Contributions cube, 75
resource driver, 5
Resource module, 29
revenue
entering, 62
S
sales volume, 60
entering, 61
SAS Activity-Based Management
additional features, 88
home page, 9
starting, 8
Save Column Layout As dialog box, 41
scenario
creating, 19
deleting, 20
overview, 17
single-dimension account, 35
Single-stage Contributions cube, 75
sold quantity, 60
T
Technical Support
contacting, 2
training, 3, 89
tutorial
tutorials, 1
V
variable quantities, 55
W
wizard
Decomposition Tree, 84
New Account, 29
New Measure, 82
New Model, 21
New OLAP View, 76
New Report, 69