SAS® Activity-Based Management Tutorial
Contents

Introduction ........................................................................................................... 1
   Tutorial conventions ....................................................................................... 1
   Fonts ............................................................................................................. 1
   Procedures .................................................................................................... 1
   Notes .......................................................................................................... 2
   Illustrations ................................................................................................. 2
   Terminology ............................................................................................... 2
   Online Help ................................................................................................ 2
   Technical support ....................................................................................... 2
   Additional training and tutorials ................................................................ 2
   In the next lesson ....................................................................................... 3

Activity-Based Management ............................................................................... 4
   The ABC model and CAM-I methodology .................................................. 4
   The Cost Assignment View ......................................................................... 5
   The Process View ....................................................................................... 5
   SAS Activity-Based Management models .................................................. 6
   Modules ....................................................................................................... 6
   Dimensions ................................................................................................. 6
   Basic steps to building a model .................................................................. 7
   Parcel Express ............................................................................................. 7
   In the next lesson ....................................................................................... 8

Using the Application ......................................................................................... 9
   Starting the application ............................................................................... 9
   The home page ........................................................................................... 10
   Model home page ...................................................................................... 11
   Opening a model ...................................................................................... 11
   Model mode and module pages .................................................................. 12
   Assignments panes .................................................................................... 13
   Column layouts ......................................................................................... 14
Introduction

This tutorial is intended to familiarize you with the basic modeling concepts used in SAS Activity-Based Management. To complete the model-building process, move through this tutorial from beginning to end, exactly as it is presented.

If you are new to activity-based management (ABM), you might benefit more from this tutorial by first learning about the concept. A number of books and articles present excellent overviews of this methodology. Even without this background, you will learn some basic ABM concepts by completing this tutorial.

Even though you might know ABM, work through this tutorial to become familiar with the SAS Activity-Based Management application—the concepts, commands, and dialog boxes.

Tutorial conventions

This section discusses the conventions used throughout this tutorial.

Fonts

<table>
<thead>
<tr>
<th>This Font</th>
<th>Represents</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Typewriter</td>
<td>Files, folders, and path names</td>
<td>Open the model named Parcel Express.</td>
</tr>
<tr>
<td>Bold</td>
<td>Menu &gt; Command</td>
<td>Select File &gt; Save Model As.</td>
</tr>
<tr>
<td></td>
<td>User Input</td>
<td>Type Parcel Express.</td>
</tr>
<tr>
<td></td>
<td>User interface elements such as menus, dialog boxes, buttons, or list items</td>
<td>Select Calculate Specific Modules.</td>
</tr>
</tbody>
</table>

Procedures

A procedure is a task that includes a set of numbered step-by-step instructions. Some steps are followed by a comment or an explanation. A section with the following format convention indicates a procedure:

➢ **Begin this tutorial**

1. Perform step one.

   Explanatory comments and illustrations, explaining and displaying results of proper completion of preceding steps, are included between steps when necessary.

2. Perform step two.
Notes
A note indicates additional information. This is the convention for indicating a note:

Note: Text set off in this manner presents important information.

Illustrations
Depending upon your display settings, and the number of times you perform a step or procedure, the information in the windows might differ slightly from the illustrations presented in this tutorial. If you enter, then delete, then re-create accounts and cost elements, the reference number might differ from the illustration. The displayed order of accounts might differ if you close and reopen the model. Consider the illustrations to be guides.

Illustrations will usually show only the pertinent portions of the screen being discussed.

Terminology
The discipline of activity-based cost management (ABM) has a set of specialized terms. Some are used in this tutorial precisely because of their specialized meaning to the theory and practice of ABM. As these terms are introduced, this tutorial provides brief definitions. More complete definitions can be found in the CAM-I Glossary of Activity-Based Management.

Online Help
The online Help is a comprehensive information system with full text search capabilities containing a wealth of knowledge about the application. It includes:

- Detailed step-by-step instructions to complete specific tasks
- Information about features
- Reference material

Technical support
If you encounter problems that you cannot solve by reading the online Help or this tutorial, refer to the Worldwide Technical Support topic in the online Help.

Additional training and tutorials
Additional training and tutorials can be found at the SAS Web site and companion Web site, http://www.bettermanagement.com. BetterManagement.com offers in-depth content on selected management concepts aimed at improving an organization’s performance. The web site is a comprehensive source for performance management information and resources including training and tutorial materials.

Topics covered include value-based management, profitability analysis, strategic enterprise management, activity-based costing/management, business intelligence, performance measurement.
In the next lesson

Now, you are ready to get acquainted with activity-based management.
Activity-Based Management

Activity-based management (ABM) is a discipline that allows companies to manage activities and processes as a means of improving organizational performance and the value received by its customer. By applying direct and indirect business costs to activities, the SAS Activity-Based Management application enables managers to get a true understanding of the costs and profits associated with a product, customer, service, or business process. It supports ongoing profitability analysis, cost-management initiatives, shared services management, planning and budgeting efforts, and capacity optimization.

The basic tool of ABM is activity-based costing (ABC), which more accurately tracks costs than traditional methods. Two critical limitations of traditional cost accounting systems are:

- The inability to report individual product, service, customer, or process costs to a reasonable level of accuracy
- The inability to provide useful feedback to management for the purpose of operational control

Often, managers of complex organizations make important decisions about pricing, product and customer mix, resource allocations, and budgeting based on inaccurate and inappropriate cost and profitability information.

Using the SAS Activity-Based Management application, you build one or more models that apply direct and indirect organizational costs to specific activities and processes. As a result, managers are able to see actual cost assignments and their bottom-line impacts from an operational perspective. Managers get a true understanding of the cause-and-effect relationships that link resources and processes to outputs. This allows business planners to easily forecast resource requirements, create budgets, and optimize capacity usage.

The ABC model and CAM-I methodology

ABC assumes that activities cause expenditure of resources and that cost objects—the results of activities or products and services produced—create the demand for activities.

The Consortium for Advanced Manufacturing International (CAM-I) develops methods to define critical business issues and to model effective strategies and solutions that resolve cost and resource management issues. The SAS Activity-Based Management application uses the CAM-I methodology for activity-based model development.
The Cost Assignment View

An ABM system allows you to identify the activities performed, associate resources (expenditures) with those activities, and flow the cost of activities to cost objects. Resource drivers (typically, general ledger entries such as payroll, utilities, or materials) drive expenditures to activities. Activity drivers (such as the number of parts or setups) drive activity consumption to cost objects. This includes information about costs of objects, such as products, services, markets, distribution channels, engineering projects, or customers.

The Process View

An ABM system allows you to expose the relationship between why work is done and the results of that work. In ABM terms, cost drivers drive the reason for activities and the effort needed to engage in the activities. Performance measures drive the achieved results of activities—the efficiency, the required completion time, and the quality of the activities performed.
SAS Activity-Based Management models

The basic container for ABM information in the SAS Activity-Based Management application is the model. A meaningful ABM model reflects the organization it is modeling and uses terms familiar to the people who work there. The structural elements of a model should be named after elements in the organizational environment. For example, a company’s general ledger accounts, such as Wages and Depreciation, can be used to name and reference the Resource accounts in the ABM model; the hierarchy of processes in a company can be applied to the Activity accounts in the model.

Modules

A model consists of three basic modules, which reflect the CAM-I definitions:

- **Resource:** Contains the expenses (or costs), such as salaries, materials, and depreciation, for the organization being modeled.
- **Activity:** Contains activities. Activities have accounts with cost elements. Costs might be assigned to activities from resource accounts or from other activity accounts.
- **Cost Object:** Contains cost objects (products, services, channels, customers). These cost objects are assigned costs from resources, activities, other cost objects, or any combination of the three.

These modules constitute the main structure of a model. A fourth module, External Units, provides support for external costs. An external unit is an item, such as a part purchased from a supplier, whose cost is maintained outside of a SAS Activity-Based Management model but which needs to be accounted for in the model.

You will build each of these modules with the use of dimensions.

Dimensions

A dimension is a category by which data will be analyzed. For example, it might be useful to see sales figures broken down by region, by customer, and by product. Each of these categories (region, customer, and product) represents a single dimension. Common dimensions are products, time, geography, customers, promotions, and sales channels.

To break information into a manageable or useful form, you can group items within a dimension to create a hierarchical structure. Each member of the hierarchy is then at a specific level in the hierarchy. You can name a dimension level as needed. Dimension levels are a powerful modeling tool because they allow you to ask questions at a high level and then expand a dimension to reveal more detail.

Types of dimensions

There are two types of dimensions in a model: structural and attribute.

Structural dimensions are the building blocks of modules. For example, the typical structural dimensions of the Resource module are region, organization, or general ledger; the Activity module might also be structured using the region or organization dimension, along with an activity dimension.
Dimension attributes provide information that is useful, but not required, to uniquely identify the model structure. This can be additional classification or organizational information that will help you analyze model results. The SAS Activity-Based Management OLAP tool makes no distinction between dimension attributes and structural dimensions.

**Basic steps to building a model**

The following list of steps summarizes the method you will use in this tutorial for setting up and analyzing information in SAS Activity-Based Management models. This method is described completely in the lessons and exercises that follow.

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td><strong>Create a paper plan</strong>&lt;br&gt;Collect resource (expenditure), activity, and cost object (products and services) information to design your model. Determine the goal of the model (what kind of information you want to get out of it), and determine the appropriate dimensions, periods, and scenarios to achieve that goal.</td>
</tr>
<tr>
<td>2</td>
<td><strong>Create periods and scenarios</strong>&lt;br&gt;Create the periods and scenarios to be used by your model. (Periods and scenarios are shared by all models on a server.)</td>
</tr>
<tr>
<td>3</td>
<td><strong>Create dimensions, modules, and accounts</strong>&lt;br&gt;Create the dimensions and dimension members that you will use to build the modules. Build the resource, activity, and cost object modules by defining the accounts (dimension intersections) of each module.</td>
</tr>
<tr>
<td>4</td>
<td><strong>Define drivers</strong>&lt;br&gt;Define drivers that measure the consumption of expenses and activities.</td>
</tr>
<tr>
<td>5</td>
<td><strong>Create assignments</strong>&lt;br&gt;Create the paths used to assign costs among accounts and select the driver for each source account.</td>
</tr>
<tr>
<td>6</td>
<td><strong>Calculate costs</strong>&lt;br&gt;Calculate costs and display the results.</td>
</tr>
<tr>
<td>7</td>
<td><strong>Add bills of costs</strong>&lt;br&gt;Define and link external unit costs to accounts.</td>
</tr>
<tr>
<td>8</td>
<td><strong>Enter output and sales data</strong>&lt;br&gt;Enter output quantities, determine unit costs, and enter sales volumes.</td>
</tr>
<tr>
<td>9</td>
<td><strong>Add attributes and performance measures</strong>&lt;br&gt;Define and add attributes and performance measures to the appropriate accounts.</td>
</tr>
</tbody>
</table>

**Parcel Express**

Parcel Express is a fictitious organization using activity-based management to determine whether this method more clearly conveys costs and profitability information than traditional costing methods.

A later chapter will outline the main business activities of Parcel Express and the company’s goals in using SAS Activity-Based Management.
In the next lesson

Next, you will learn how to start and navigate the SAS Activity-Based Management application.
Using the Application

The SAS Activity-Based Management application is Web-enabled. Its server typically resides on your company’s intranet and the application resides on your computer. This tutorial assumes that you have installed the application on your computer and that you are familiar with basic software usage techniques, such as using menus, dialog boxes, and other Windows and Web controls.

Starting the application

You start the SAS Activity-Based Management application from the Start menu.

Start SAS Activity-Based Management

1. Select Start > Programs > SAS > Activity-Based Management 6.x > Activity-Based Management Solution.

   You see the Connect dialog box. The software version number might vary.

2. If your current network log in information is not valid for the server, clear the Log in using my current credentials option.

3. From the Server drop-down list, select a server, or type the server name.

4. If you cleared the Log in using my current credentials option:
   a. Type your domain and User name.
      For example, HQ\JohnD.
b. Type your **Password**.
As you enter each character, an asterisk (*) appears in its place. If you do not have a password, leave this empty. Not all organizations use passwords.

5. Click **OK**.
You see the SAS Activity-Based Management home page.

**The home page**
The following figure illustrates the SAS Activity-Based Management home page.

Read the online Help (click ![Help](image)) for a full description of the Home Page and Workspace Manager. Any existing models to which you have access rights appear in the Models folder or its subfolders. You can also create shortcuts to your models in the My Shortcuts folder.

**Switch to Model mode**

1. On the home page, click ![Model](image)
You see a model page. If you have just started the system, you will see the Model home page. If you have been working with a model, you will see the model page you were working on last.

**Model home page**

The Model home page lists the models to which you have access rights. From this page, you can open, create, or delete models.

![Image of Model home page]

**Opening a model**

There are a number of ways to open a model. It might take several sessions for you to build the model in this tutorial. Most of the procedures assume that you are in Model mode and that your model is open. So familiarize yourself with the procedure for opening a model.

**Note:** The Parcel Express model will not exist in the application until you or another modeler creates it. Use the following instructions only after you have created the model.

- **Open a model from the Home Page**
  1. In Workspace Manager, expand the Models folder hierarchy to the level of your model.
  2. Double-click the model.
You see the Resource module of the model.

**Note:** The model you want to open might be listed under the Model tasks, as shown below:

<table>
<thead>
<tr>
<th>Model</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open : Parcel Express</td>
</tr>
<tr>
<td>New model</td>
</tr>
<tr>
<td>Import an Orcs model</td>
</tr>
</tbody>
</table>

If this is the case, you can click **Open : model name** to open your model.

➤ **Open a model from the Model home page**

1. If necessary, expand the **Folders** hierarchy to the level of your model.
2. Click the link to the model you want to open.

   ![Parcel Express](image)

   **Delete**

   Created on 3/26/2003 10:33:53 AM

**Warning:** The Delete link allows you to delete the model. There is no way to retrieve a model after you delete it. Use this feature with caution. If you want to start over at any point during this tutorial, you can use this link to delete what you have, and then start again.

**Model mode and module pages**

When you open a model using one of the above methods, you usually go to the Resource module, which is just one page among many that constitute Model mode. If you switch to a different mode, such as OLAP or Reports mode, and return to Model mode, you go to the page of the model you were on last.

You perform all of the tasks associated with building a model, entering data, and calculating costs in Model mode. Many of the tasks rely on the use of dialog boxes (which allow you to manage specific aspects of the model) and wizards (which guide you through certain procedures). In many instances, you will enter data directly into a column on one of the Model mode pages.

Below is the Resource module of the model you will be building in this tutorial.
You can initiate most tasks from the menus or by using tool bar buttons and icons.

A module’s structure comes from its dimensions. The accounts, represented by the layered cube icons, are intersections of dimensions.

You can close the task bar to allow more space for the model.

In this tutorial, you will be directed to use the menus most of the time. Occasionally, you will be instructed to use a button or an icon. As you become more familiar with the application, you can choose whichever method you prefer to initiate tasks. Read the online Help for a complete description of tool bar buttons and icons.

Assignments panes

One of the main objectives of activity-based management is to accurately assess how company costs are consumed; for example, how costs flow from general ledger accounts to activities to products and services. SAS Activity-Based Management provides you with several graphical tools to help you see and manage this flow. Among these tools are the left and Right assignments panes, which allow you to view and assign costs from one module to another and within a single module.

By default, each module opens in a single-pane view, the Primary pane. The Primary pane contains the structure of a module, which includes the dimension intersections (accounts) and each account’s cost elements. You can open the Left assignments pane to see the accounts from which costs flow (sometimes called source accounts). You can open the Right assignments pane to see the accounts to which costs flow (sometimes called destination accounts).

Below is the Activity module of the model you will be building with all three panes open.
Using the Application

In the example above, the arrows pointing from the Left assignments pane to the Primary pane indicate costs flowing into the Beaverton Inspection account in the Activity module. The arrows pointing from the Primary pane to the Right assignments pane show how costs then flow from the Beaverton Inspection account to other accounts.

In this tutorial, you will use the Right assignments pane to flow costs out of accounts and into others.

**Column layouts**

A column layout is a collection of displayed columns, column formats, and the column order on the module pages. You can customize a column layout to display various information, such as properties, attributes, periods, and scenarios. Once customized, you can save a column layout by name so that you can retrieve it later. You see saved column layouts in Workspace Manager and in the Column Layout list on the Resource, Activity, Cost Object, and External Units module pages.

When you save a column layout, the following information is saved:

- Description
- Column headings
- Information displayed in each column and the period/scenario association to which it applies
- Format for each column and order of the columns from left to right
- Model
- Column widths

The following items are not saved:

- Number of assignment panes showing

All column layouts saved by all users on the same server are listed in Workspace Manager. Therefore, your organization might want to set up some guidelines for saving and naming column layouts.
Properties, attributes, and dimensions in layouts

The columns of a column layout are derived from the following model elements:

- **Properties:** A property is a general name used to refer to any model item that holds the values entered by a user or calculated by the software. Examples of properties are: Cost, Unit Cost, Output Quantity, Sold Quantity, and Profit. The more familiar you become with SAS Activity-Based Management modeling, the more you will be able to use properties creatively to achieve your analysis goals.

- **Attributes:** An attribute is a user-defined label or numeric value that is attached to an account. Each attribute is a particular characteristic used for analysis. An attribute conveys information about the item to which it is attached.

- **Dimensions:** A dimension is a category by which data will be or is analyzed. You define the dimensions of your model when you use the New Model wizard.

Reports

SAS Activity-Based Management allows you to use pre-defined report templates or to create your own reports.

- **Switch to Reports mode**
  1. From the home page, click [Reports].
    You see the Reports home page.

OLAP cubes

A cube is the main object in online analytic processing (OLAP), a technology that provides fast access to data in a model. A cube contains a set of data that is constructed from a subset of model data and is organized and summarized into a multi-dimensional structure. SAS Activity-Based Management cubes are standard OLAP cubes.

You use the SAS Activity-Based Management application to connect to and interact with the cubes on an SAS Activity-Based Management Server. For each model, you can generate cubes that you can manipulate on the OLAP page to interactively analyze business data.

- **Switch to OLAP mode**
  1. From the home page, click [OLAP].
    You see the OLAP home page.

In the next lesson

Next, you will create a paper plan for the Parcel Express model.
Creating a Paper Plan

Activity-based management projects begin with a plan. After you have determined the analysis goals of the model and defined the dimensions that will enable that analysis, you can begin data collection. Information concerning resources (expenditures), activities (tasks), and cost objects (products and services produced) provides the basis for building an ABM model.

Building by design

Before beginning to build a model, evaluate and make preliminary decisions about the design of the model. Just as a building contractor needs a plan before beginning to build a house, a model builder needs a plan for the structure of a model before beginning to build.

Factors that influence a model’s design include the:

- Goal of the model—the operational or strategic questions the activity-based management program is intended to answer
- Data already collected and their format
- Data needed that are not being collected
- Types of reports and OLAP cubes that will be needed

This tutorial uses a simple design and focuses on the steps for building a model. The design of the model and the effort it takes can be simple or complex. The model builder will need to understand these factors, and others that are unique to each modeling situation, to arrive at a design.

The Parcel Express model

Company background

Parcel Express began operations in Beaverton, Oregon, in 1990 as a ground parcel delivery service. In 1995, with 125 employees and $1 million in sales, the company began expanding to overnight delivery and 2nd day delivery.

In the first quarter of 2003, total sales revenue was approximately $5.5 million. Costs for the same period were about $3.8 million, for a profit of about $1.7 million.
**ABM goals**

Parcel Express hopes to use SAS Activity-Based Management to trace operating costs to individual products and services so that the overall costs and profit of each can be determined and improved. They are concerned that the current accounting system, which divides the business into about 10 product groupings, might not accurately reflect the different costs of doing business for the two express services: Overnight Express and 2nd Day Guaranteed.

Management wants to know how each product is performing. The company’s competitors have dominated in the 2nd Day market, and management has recently slashed prices on that product. Sales volumes have increased as a result, but it’s unclear how much profit they’re making, if any. They would like to meet a target profit margin of at least 10% on the 2nd Day Guaranteed product and at least 25% on all others. They are willing to adjust pricing or modify processes to reach that goal.

**Model structure**

Parcel Express has assembled a SAS Activity-Based Management modeling team whose members have become familiar with ABM concepts and the structure of ABM models. Together they have determined that the following module structure most accurately reflects the way Parcel Express conducts its operations.

**Resource module**

Resources will be structured by region and general ledger account. The two main processing plants are Beaverton and Eugene, Oregon. General ledger accounts include:

- Wages (salary and overtime)
- Operating expenses and supplies
- Equipment depreciation

**Activity module**

Activities will be structured by region and activity. The activities Parcel Express has chosen to model are:

- Branch collection
- Sorting and inspection
- Air and land distribution
- Resolution of customer complaints

The Eugene facility does not have an air distribution function, so it will have one less account than Beaverton.

**Cost Object module**

Parcel Express needs to be able to track not only the costs of products but of their channels as well. Therefore, they will organize the Cost Object module by channel and products and services.

The three channels are:

- Drop Box
- Walk In
- Commercial Pick Up
The three products and services are:
- Standard Ground
- 2nd Day Guaranteed
- Overnight Express

**External Units module**
Each product has packaging costs that must be accounted for. Materials for packaging will be tracked as external units, including:
- Envelopes
- Flats
- Boxes

**Data collection**
The following information will be collected for entry into the ABM model:
- **Wages:** Wage information, including salaries and overtime, will come from the general ledger system. Wages will be entered as dollar amounts and assigned to activities according to the number of full-time employees, or FTEs (Full-Time Equivalents), associated with an activity.
- **Operating expenses:** Operating expenses and supply costs will come from the general ledger. These costs will be assigned to activities in dollar amounts.
- **Equipment expenses:** Equipment expenses, including depreciation, will come from the general ledger. These costs will be assigned by percentage.
- **Collection and distribution:** Branch managers will collect data from their control systems regarding the number of packages collected, moved to warehouses, sorted, inspected, and distributed by land and air. Accurate numbers here are critical to the success of the modeling effort. Activity accounts will assign costs by number of packages.
- **Complaints:** The number of customer complaints will be collected by branch managers. Costs associated with complaint resolution will be assigned according to number of complaints received.
- **Revenue:** Revenue will come from the sales accounting system. Revenue will be associated with cost objects according to the sales quantity for each product.

**In the next lesson**
In the next lesson, you will create the period and scenario required for the Parcel Express model.
Creating Periods and Scenarios

A period is an interval of time in which activity-based management data is maintained. A period can represent any unit of time: a month, a quarter, a year, and so on. For example, if your organization chooses to enter data each month, the marketing payroll cost is the amount of payroll for one month. A model can hold data for different periods but only one period at a time is active. The default periods are 2002 and 2003. You can create a hierarchy of periods, such as FY2003 > Q1 > January. By default, each level is given a name, such as Period L1.

The value of model periods is the ability they give you to compare model data between different periods. For example, you can enter costs into a model on a month-by-month basis and examine the costs for March vs. the costs for February.

Scenarios are generally used to manage different variations of data within a period. A scenario can be any set of data: actual, budget, aggressive plan, conservative plan, and so on. The default scenarios are Actual and Budget. You can create a hierarchy of scenarios, such as Budget > Aggressive. By default, each level is given a name, such as Scenario L1. However, these names aren't descriptive when you generate cubes. So, you can name a scenario level.

Creating a period

Parcel Express analyzes costs by quarters, so the model will be structured to analyze quarter-on-quarter costs. The period you will create is 2003 Q1. You will create the period on the level below 2003.

Create a period

1. Select Tools > Manage Periods.
Creating Periods and Scenarios

You see the Manage Periods dialog box.

2. Select the 2003 period, and click New.
   You see the New Period dialog box.

3. For the Name, replace New Period with 2003 Q1.
4. For the Reference, type 03Q1.
7. Click OK.
   You see the new period added to the list below the 2003 period.
8. Create three more periods called 2003 Q2, 2003 Q3, and 2003 Q4. Specify appropriate date ranges and references for each period. All period references must be unique.
   When you are done, you should see the following periods in the Manage Periods dialog box:
Creating a scenario

Parcel Express wants to compare actual costs incurred on a quarterly basis. It will analyze the profit and loss trends in these costs to make decisions regarding resource allocation, process control, and pricing. For this purpose, the default scenario called Actual will be adequate.

However, so that you gain experience, assume that the company had specific profit targets it wanted to model in SAS Activity-Based Management, you could create a scenario called Target.

Create a scenario

1. Select Tools > Manage Scenarios.

You see the Manage Scenarios dialog box.

2. Select All Scenarios, and click New.

You see the New Scenario dialog box.

9. Click OK.
Creating Periods and Scenarios

3. For the Name, replace New Scenario with Target.

4. For the Reference, type TARGET.

5. Click OK.

   You see the new scenario added to the list below the Actual scenario.

6. Click OK.

Deleting periods and scenarios

You can delete a period or scenario from the Manage Periods or Manage Scenarios dialog boxes, respectively. Select the period or scenario and click Delete. You are prompted to confirm the deletion.

If you are performing this tutorial on the same SAS Activity-Based Management server you will be using for actual ABM models, you might want to delete the Parcel Express period and scenario after completing the tutorial. This will ensure an uncluttered activity-based management environment.

In the next lesson

In the next lesson, you will build the underlying structure of the Parcel Express model: dimensions, modules, and accounts.
Creating Dimensions and Dimension Members

Before creating the structure of a module, you must define the dimensions you will use to build that structure. As defined in the paper plan, the dimensions you will define for the Parcel Express model are:

<table>
<thead>
<tr>
<th>Module</th>
<th>Dimensions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource</td>
<td>Region</td>
</tr>
<tr>
<td></td>
<td>General Ledger</td>
</tr>
<tr>
<td>Activity</td>
<td>Region</td>
</tr>
<tr>
<td></td>
<td>Activities</td>
</tr>
<tr>
<td>Cost Object</td>
<td>Channel</td>
</tr>
<tr>
<td></td>
<td>Products and Services</td>
</tr>
<tr>
<td>External Unit</td>
<td>Materials</td>
</tr>
</tbody>
</table>

You can also define dimensions to use for profitability analysis. The Parcel Express model will use the same dimensions for profitability as it does for the Cost Object module.

Creating dimensions with the New Model wizard

The main purpose of the New Model wizard is to establish the dimensions of your model. These are the dimensions you will use to create accounts and the structure of the modules. Eventually, and most importantly, these are the dimensions that will allow you to generate meaningful cubes and to analyze the profits and losses resulting from your business activities.

Now, you will create the model named Parcel Express. The model’s monetary data will be in U.S. dollars.

➢ Start the New Model wizard
1. Select File > New > Model.
You see Step 1 of the New Model wizard.

The wizard contains 10 steps. If you accept the default dimensions for your model, you will not perform every step. For this tutorial, you will define your own dimensions and perform every step in the wizard.

2. Enter the name as **Parcel Express**.
   
   **Note:** Each model name must be unique on a SAS Activity-Based Management server.

3. Verify that the base currency is **US Dollar ($)**.
4. Click **Next**.
   
   You see Step 2 of the wizard.

**Select a starting period and scenario**

1. Expand the **2003** level of the period hierarchy, and select the **2003 Q1** period.

2. Click **Next**.
You see Step 3 of the wizard.

3. Select the Actual scenario.

You see the period/scenario association at the bottom of the window change to 2003 Q1/Actual. A period/scenario association identifies a specific period and scenario combination; in this case, 2003 Q1/Actual. All model data must reside in a period and must apply to a scenario. An association represents a period-scenario pair.

4. Click OK.

You see Step 4 of the wizard.

➤ **Select the method for defining dimensions**

1. Verify that the Select or define the dimensions for each module option is selected.

This option allows you to create new dimensions, rearrange dimensions, or use the default dimensions for some modules but not others.

   **Note:** The default dimensions are:

<table>
<thead>
<tr>
<th>Module</th>
<th>Dimensions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource</td>
<td>Organization, General Ledger</td>
</tr>
<tr>
<td>Activity</td>
<td>Organization, Activities</td>
</tr>
<tr>
<td>Cost Object</td>
<td>Customer, Products and Services</td>
</tr>
<tr>
<td>External Unit</td>
<td>Materials</td>
</tr>
<tr>
<td>Profit Analysis</td>
<td>Customer, Products and Services</td>
</tr>
</tbody>
</table>

2. Click Next.

You see Step 5 of the wizard.

➤ **Define the Resource module dimensions**

1. In the Selected dimensions list, select the Organization dimension.

Next, you will remove this dimension from the Selected dimensions list.

2. Click .

You see the Organization dimension move from the Selected dimensions list to the Available dimensions list.

3. Click New.

You see the Dimension Name dialog box.
4. For **Dimension Name**, type **Region**.
5. For **Reference**, type **Reg**.
6. Click **OK**.
   The Dimension Name dialog box closes, and you see the Region dimension added to the Available dimensions list.

7. Select the **Region** dimension, and click ➔.
   You see the Region dimension move from the Available dimension list to the Selected dimension list, below the General Ledger dimension. The order of dimensions in the list determines the hierarchy of dimensions in the module. In this case, Parcel Express wants to organize its resources by Region and then by General Ledger. So, you will have to move Region above General Ledger.

8. Select the **Region** dimension, and click  
9. Click **Next**.
   You see Step 6 of the wizard.

Now, you will define the dimensions for the Activity module using these same techniques. Refer to the above procedure if you need clarification on a step.

➢ **Define the Activity module dimensions**

1. Move the **Organization** dimension to **Available dimensions**.
2. Move the **Region** dimension to **Selected dimensions**.
3. Move **Region** above **Activities**.
   The Selected dimensions list should appear as follows:

   ![](selected_dimensions.png)

4. Click **Next**.
   You see Step 7 of the wizard.

➢ **Define the Cost Object module dimensions**

1. Move the **Customers** dimension to **Available dimensions**.
2. Create a new dimension called **Channel** with a reference of **Chnl**.
3. Move the **Channel** dimension to **Selected dimensions**.
4. Move **Channel** above **Products and Services**.
   The Selected dimensions list should appear as follows:
5. Click **Next**.

You see Step 8 of the wizard.

➢ **Define the External Units module dimensions**

1. Verify that **Materials** is the only dimension in the **Selected dimensions** list.
2. Click **Next**.

You see Step 9 of the wizard.

➢ **Define the Profit Analysis dimensions**

1. Move the **Channel** dimension from **Available dimensions** to **Selected dimensions**.
2. Move **Channel** above **Products and Services**.

The Selected dimensions list should appear as follows:

<table>
<thead>
<tr>
<th>Selected dimensions:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Channel (Chnl)</td>
</tr>
<tr>
<td>Products and Services (Prod_Serv)</td>
</tr>
</tbody>
</table>

3. Click **Next**.

You see Step 10 of the wizard.

➢ **Review the summary and finish the wizard**

1. Review the **Summary of information** and **Dimensions in each module**, as shown below:

<table>
<thead>
<tr>
<th>Summary of information:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Your new model will be created with the specified dimensions. However, you will not be able to create accounts or enter costs until you define some dimension members. Once you have defined dimension members, you can proceed to the Resource, Activity, Cost Object, or External Units pages to create accounts and enter costs.</td>
</tr>
<tr>
<td>Model name: Parcel Express</td>
</tr>
<tr>
<td>Model base currency: USD</td>
</tr>
<tr>
<td>Period: 2003 Q1</td>
</tr>
<tr>
<td>Scenario: Actual</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Dimensions in each module:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource: Region, General Ledger</td>
</tr>
<tr>
<td>Activity: Region, Activities</td>
</tr>
<tr>
<td>Cost Object: Channel, Products and Services</td>
</tr>
<tr>
<td>External Unit: Materials</td>
</tr>
<tr>
<td>Profit Analysis: Channel, Products and Services</td>
</tr>
</tbody>
</table>

If any of the information in the summary is incorrect, click Back to move to the page requiring changes. After making the corrections, click Next to return to the summary.
2. Click **Finish**.

You see the Dimensions page with the following dimensions:

![Dimensions page: Parcel Express](image)

These dimensions are the basic building blocks you will use to construct the modules of your model. First, you must create the members of each dimension.

**Creating dimension members**

Dimension members are the unique elements of a dimension level. For example, the Region dimension of the Parcel Express model will have levels that include countries, states, and cities. Beaverton and Eugene are dimension members at the same level of the Region dimension.

- **Create dimension members**
  1. On the **Dimensions** page, select **Region**.
  2. Select **Edit > New Dimension Member**.

You see the New Dimension Member dialog box.

![New Dimension Member](image)

3. Type a **Name** of **USA**.

   You see the Reference field automatically set to the name you type. In this instance, you will not change the reference; however, for the models you create for your company, you might want to devise a standard referencing methodology.

4. Click **OK**.

   You see the USA dimension member added below Region.

5. Select the **USA** dimension.
6. Create a new dimension member named **Oregon**. 
   Note that the Level is Level2. This is because you are adding a dimension member below a Level1 dimension member.

7. Using the above techniques, create the dimension members shown below.

<table>
<thead>
<tr>
<th>Name</th>
<th>Reference</th>
<th>DimLevelName</th>
</tr>
</thead>
<tbody>
<tr>
<td>Region</td>
<td></td>
<td></td>
</tr>
<tr>
<td>USA</td>
<td>Oregon</td>
<td>Level1</td>
</tr>
<tr>
<td>Oregon</td>
<td></td>
<td>Level2</td>
</tr>
<tr>
<td>Eugene</td>
<td></td>
<td>Level3</td>
</tr>
<tr>
<td>General Ledger</td>
<td>GL</td>
<td>Level1</td>
</tr>
<tr>
<td>Wages</td>
<td>Wages</td>
<td>Level1</td>
</tr>
<tr>
<td>Operating Expenses</td>
<td>Operating Expenses</td>
<td>Level1</td>
</tr>
<tr>
<td>Equipment Expenses</td>
<td>Equipment Expenses</td>
<td>Level1</td>
</tr>
<tr>
<td>Activities</td>
<td>Act</td>
<td></td>
</tr>
<tr>
<td>Personnel</td>
<td>Personnel</td>
<td>Level1</td>
</tr>
<tr>
<td>Resolve Customer Complaints</td>
<td>Resolve Customer Complaints</td>
<td>Level2</td>
</tr>
<tr>
<td>Branch Collection</td>
<td>Branch Collection</td>
<td>Level1</td>
</tr>
<tr>
<td>Move to Warehouse</td>
<td>Move to Warehouse</td>
<td>Level2</td>
</tr>
<tr>
<td>Regional Sorting</td>
<td>Regional Sorting</td>
<td>Level1</td>
</tr>
<tr>
<td>Inspection</td>
<td>Inspection</td>
<td>Level2</td>
</tr>
<tr>
<td>Sort</td>
<td>Sort</td>
<td>Level2</td>
</tr>
<tr>
<td>Distribution</td>
<td>Distribution</td>
<td>Level1</td>
</tr>
<tr>
<td>Air Distribution</td>
<td>Air Distribution</td>
<td>Level2</td>
</tr>
<tr>
<td>Land Distribution</td>
<td>Land Distribution</td>
<td>Level2</td>
</tr>
<tr>
<td>Channel</td>
<td>Civ</td>
<td></td>
</tr>
<tr>
<td>Drop Box</td>
<td>Drop Box</td>
<td>Level1</td>
</tr>
<tr>
<td>Walk In</td>
<td>Walk In</td>
<td>Level1</td>
</tr>
<tr>
<td>Commercial Pick Up</td>
<td>Commercial Pick Up</td>
<td>Level1</td>
</tr>
<tr>
<td>Products and Services</td>
<td>Food_Serv</td>
<td></td>
</tr>
<tr>
<td>2nd Day Guaranteed</td>
<td>2nd Day Guaranteed</td>
<td>Level1</td>
</tr>
<tr>
<td>Overnight Express</td>
<td>Overnight Express</td>
<td>Level1</td>
</tr>
<tr>
<td>Standard Ground</td>
<td>Standard Ground</td>
<td>Level1</td>
</tr>
<tr>
<td>Materials</td>
<td>Mat</td>
<td></td>
</tr>
</tbody>
</table>

**Note:** You will not create dimension members for the Materials dimension yet. You will add those when you create bills of costs.

**In the next lesson**

In the next lesson, you will use the dimension members you just created to build the Resource, Activity, and Cost Object modules.
Creating Modules and Accounts

An account is the basic repository of cost in a model. You create an account in SAS Activity-Based Management by defining an intersection between dimension members. For example, in the Parcel Express model, you will create an account for tracking the costs of inspecting packages in Beaverton, OR. You create this account by defining an intersection between Region and Activity dimension members, as shown below:

Region > USA > Oregon > Beaverton
  x
Activity > Regional Sorting > Inspection

A shorthand for the resulting account, or dimension intersection, is Beaverton x Inspection. The costs of an account are derived from cost elements, which can be added directly to the account or assigned from other accounts.

Building the Resource module structure

Start by creating a structure to hold the resource costs in the model.

Create resource accounts

1. To open the Resource module, select Mode > Resource Module.
2. Select Edit > New Account.

You see Step 1 of the New Account wizard. Here, you will select the dimension members of the first account of the Resource module. To do this, you will use the interface shown below:

<table>
<thead>
<tr>
<th>Dimension</th>
<th>Dimension Member</th>
</tr>
</thead>
<tbody>
<tr>
<td>Region</td>
<td></td>
</tr>
<tr>
<td>General Ledger</td>
<td></td>
</tr>
</tbody>
</table>

The left column lists the dimensions of the Resource module. The right column provides controls to select members of those dimensions.

3. In the Region row, select the Beaverton Dimension Member.
   Tip: You will have to expand the Region hierarchy to select Beaverton.
4. In the General Ledger row, select the Wages dimension member.
5. Click **Next**.

You see Step 2 of the wizard.

The main controls of this step are shown below:

The system has automatically generated a unique name and reference for this account. (The numbers you see might be different than those shown above.) This name and reference are used in reports and operational summaries but do not appear elsewhere in the application, unless you add columns to display them. Your company can decide whether to use the default names or to employ a naming and referencing methodology. If your models are extremely large, it will probably be more convenient to use system-generated account names and references.

6. Click **Add** twice.

This adds two undefined cost elements to the Beaverton/Wages account.

7. Define the two cost elements of the account as follows:

<table>
<thead>
<tr>
<th>Name</th>
<th>Reference</th>
<th>Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>Salaries</td>
<td>BS</td>
<td>1,563,000.00</td>
</tr>
<tr>
<td>Overtime</td>
<td>BOT</td>
<td>75,600.00</td>
</tr>
</tbody>
</table>

**Note:** In large models, costs might be imported from other sources, such as a database. In that case, you could define the cost elements, but leave the costs empty.

8. Click **Next**.

You see Step 3 of the wizard, containing a summary of the account you are about to create.
9. Check the box to add other accounts, and click **Next**.

   You see Step 1 of the wizard again.

10. Using the wizard, create the following accounts:

<table>
<thead>
<tr>
<th>Dimension Intersection</th>
<th>Cost Elements</th>
<th>Cost Element Reference</th>
<th>Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beaverton x Operating Expenses</td>
<td>Operating Expenses</td>
<td>BOE</td>
<td>228,000.00</td>
</tr>
<tr>
<td></td>
<td>Office Supplies</td>
<td>BOS</td>
<td>10,000.00</td>
</tr>
<tr>
<td>Beaverton X Equipment Expenses</td>
<td>Equipment Depreciation</td>
<td>BED</td>
<td>54,300.00</td>
</tr>
<tr>
<td>Eugene X Wages</td>
<td>Salaries</td>
<td>ES</td>
<td>1,298,000.00</td>
</tr>
<tr>
<td></td>
<td>Overtime</td>
<td>EOT</td>
<td>110,000.00</td>
</tr>
<tr>
<td>Eugene x Operating Expenses</td>
<td>Operating Expenses</td>
<td>EOE</td>
<td>263,000.00</td>
</tr>
<tr>
<td></td>
<td>Office Supplies</td>
<td>EOS</td>
<td>8,000.00</td>
</tr>
<tr>
<td>Eugene x Equipment Expenses</td>
<td>Equipment Depreciation</td>
<td>EED</td>
<td>38,000.00</td>
</tr>
</tbody>
</table>

11. After you have created all the accounts, click **Finish**.

   You see the accounts added to the Resource module.
Creating Modules and Accounts

The system automatically rolls up costs from cost elements, to accounts, to higher dimension levels.

Building the Activity module structure

An activity is a task that consumes resources. Examples of activities include setting up a machine to produce a particular part, scheduling production of a certain number of products, and inspecting a batch of parts. In a model, you identify activities and calculate their costs.

Creating activity accounts

In the Activity module, you will create activity accounts.

Create activity accounts

1. In the Activity module, select Edit > New Account.
   You see the New Account wizard.

2. Using the wizard, create the following accounts:
   Note: Do not create cost elements. Costs will be assigned to these accounts from other accounts.

The system automatically rolls up costs from cost elements, to accounts, to higher dimension levels.
3. After creating these accounts, click **Finish**.

You see the following Activity module structure:

<table>
<thead>
<tr>
<th>Display Name</th>
<th>Display Reference</th>
<th>Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>USA</td>
<td></td>
<td>$0.00</td>
</tr>
<tr>
<td>Oregon</td>
<td></td>
<td>$0.00</td>
</tr>
<tr>
<td>Beaverton</td>
<td>Beaverton</td>
<td>$0.00</td>
</tr>
<tr>
<td>Personnel</td>
<td>Personnel</td>
<td>$0.00</td>
</tr>
<tr>
<td>Resolve Customer Complaints</td>
<td>Resolve Customer Complaints</td>
<td>$0.00</td>
</tr>
<tr>
<td>Branch Collection</td>
<td>Branch Collection</td>
<td>$0.00</td>
</tr>
<tr>
<td>Move to Warehouse</td>
<td>Move to Warehouse</td>
<td>$0.00</td>
</tr>
<tr>
<td>Regional Sorting</td>
<td>Regional Sorting</td>
<td>$0.00</td>
</tr>
<tr>
<td>Inspection</td>
<td>Inspection</td>
<td>$0.00</td>
</tr>
<tr>
<td>Sort</td>
<td>Sort</td>
<td>$0.00</td>
</tr>
<tr>
<td>Distribution</td>
<td>Distribution</td>
<td>$0.00</td>
</tr>
<tr>
<td>Air Distribution</td>
<td>Air Distribution</td>
<td>$0.00</td>
</tr>
<tr>
<td>Land Distribution</td>
<td>Land Distribution</td>
<td>$0.00</td>
</tr>
<tr>
<td>Eugene</td>
<td>Eugene</td>
<td>$0.00</td>
</tr>
<tr>
<td>Personnel</td>
<td>Personnel</td>
<td>$0.00</td>
</tr>
<tr>
<td>Resolve Customer Complaints</td>
<td>Resolve Customer Complaints</td>
<td>$0.00</td>
</tr>
<tr>
<td>Branch Collection</td>
<td>Branch Collection</td>
<td>$0.00</td>
</tr>
<tr>
<td>Move to Warehouse</td>
<td>Move to Warehouse</td>
<td>$0.00</td>
</tr>
<tr>
<td>Regional Sorting</td>
<td>Regional Sorting</td>
<td>$0.00</td>
</tr>
<tr>
<td>Inspection</td>
<td>Inspection</td>
<td>$0.00</td>
</tr>
<tr>
<td>Sort</td>
<td>Sort</td>
<td>$0.00</td>
</tr>
<tr>
<td>Distribution</td>
<td>Distribution</td>
<td>$0.00</td>
</tr>
<tr>
<td>Land Distribution</td>
<td>Land Distribution</td>
<td>$0.00</td>
</tr>
</tbody>
</table>

**Note:** You did not enter cost elements for these accounts and no costs have been assigned yet, so their cost is $0.00.
Building the Cost Object module structure

The Cost Object module will hold information about Parcel Express’s products and services. Its dimensions are Channel and Products and Services.

Single-dimension accounts

When you create a new account in a multiple-dimension module, you have the option of selecting just one dimension. To do this, you select None for the dimension or dimensions not included in the account. The purpose of this is to track the costs of a single dimension member by itself. For example, in the Parcel Express model, many of the accounts in the Cost Object module will be intersections of the Channel and Product dimensions. But each channel has unique costs not associated with any product, and each product has unique costs not associated with any channel. When you select None for either the Channel or Product dimension, you are creating an account to track unique costs.

Examples of single-dimension accounts are:

- Drop Box x No <Products and Services>
- No <Channel> x 2nd Day Guaranteed

Creating cost objects accounts

- Create cost object accounts
  1. Using the techniques you have learned, create the following accounts in the Cost Object module:
     
     Note: Do not enter cost elements. Costs will be assigned to these accounts from other accounts.
Creating Modules and Accounts

<table>
<thead>
<tr>
<th>Dimension Intersection</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drop Box x 2nd Day Guaranteed</td>
</tr>
<tr>
<td>Drop Box x Overnight Express</td>
</tr>
<tr>
<td>Drop Box x Standard Ground</td>
</tr>
<tr>
<td>Drop Box x None</td>
</tr>
<tr>
<td>Walk In x 2nd Day Guaranteed</td>
</tr>
<tr>
<td>Walk In x Overnight Express</td>
</tr>
<tr>
<td>Walk In x Standard Ground</td>
</tr>
<tr>
<td>Walk In x None</td>
</tr>
<tr>
<td>Commercial Pick Up x 2nd Day Guaranteed</td>
</tr>
<tr>
<td>Commercial Pick Up x Overnight Express</td>
</tr>
<tr>
<td>Commercial Pick Up x Standard Ground</td>
</tr>
<tr>
<td>Commercial Pick Up x None</td>
</tr>
<tr>
<td>None x 2nd Day Guaranteed</td>
</tr>
<tr>
<td>None x Overnight Express</td>
</tr>
<tr>
<td>None x Standard Ground</td>
</tr>
</tbody>
</table>

After you have created these accounts, you should see the following Cost Object module structure:

<table>
<thead>
<tr>
<th>Display Name</th>
<th>Display Reference</th>
<th>Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>COST OBJECT (PRIMARY PAND)</td>
<td></td>
<td>$0.00</td>
</tr>
<tr>
<td>Drop Box</td>
<td>Drop Box</td>
<td>$0.00</td>
</tr>
<tr>
<td>2nd Day Guaranteed</td>
<td>2nd Day Guaranteed</td>
<td>$0.00</td>
</tr>
<tr>
<td>Overnight Express</td>
<td>Overnight Express</td>
<td>$0.00</td>
</tr>
<tr>
<td>Standard Ground</td>
<td>Standard Ground</td>
<td>$0.00</td>
</tr>
<tr>
<td>None x Products and Services</td>
<td>None x Prod_Serve</td>
<td>$0.00</td>
</tr>
<tr>
<td>Walk In</td>
<td>Walk In</td>
<td>$0.00</td>
</tr>
<tr>
<td>2nd Day Guaranteed</td>
<td>2nd Day Guaranteed</td>
<td>$0.00</td>
</tr>
<tr>
<td>Overnight Express</td>
<td>Overnight Express</td>
<td>$0.00</td>
</tr>
<tr>
<td>Standard Ground</td>
<td>Standard Ground</td>
<td>$0.00</td>
</tr>
<tr>
<td>None x Products and Services</td>
<td>None x Prod_Serve</td>
<td>$0.00</td>
</tr>
<tr>
<td>Commercial Pick Up</td>
<td>Commercial Pick Up</td>
<td>$0.00</td>
</tr>
<tr>
<td>2nd Day Guaranteed</td>
<td>2nd Day Guaranteed</td>
<td>$0.00</td>
</tr>
<tr>
<td>Overnight Express</td>
<td>Overnight Express</td>
<td>$0.00</td>
</tr>
<tr>
<td>Standard Ground</td>
<td>Standard Ground</td>
<td>$0.00</td>
</tr>
<tr>
<td>None x Products and Services</td>
<td>None x Prod_Serve</td>
<td>$0.00</td>
</tr>
<tr>
<td>Commercial Pick Up</td>
<td>Commercial Pick Up</td>
<td>$0.00</td>
</tr>
<tr>
<td>2nd Day Guaranteed</td>
<td>2nd Day Guaranteed</td>
<td>$0.00</td>
</tr>
<tr>
<td>Overnight Express</td>
<td>Overnight Express</td>
<td>$0.00</td>
</tr>
<tr>
<td>Standard Ground</td>
<td>Standard Ground</td>
<td>$0.00</td>
</tr>
<tr>
<td>None x Products and Services</td>
<td>None x Prod_Serve</td>
<td>$0.00</td>
</tr>
</tbody>
</table>

In the next lesson

Now that you have built the three basic modules, you need to add resource and activity drivers to the model. These drivers allocate resources to activities and activities to cost objects. In the next lesson, you will learn about drivers and create drivers for the model.
Defining Drivers

An important aspect of activity-based management is understanding how activities in an organization consume expenses and how products consume activities. These consumptions are governed by relevant drivers, which measure the frequency or intensity of the cost demands placed on resources and activities. A driver specifies how costs are assigned.

This tutorial uses both system-defined and user-defined drivers.

Drivers for the model

The first step in assigning resource costs to activities and activity costs to cost objects is building a list of drivers.

The Parcel Express model will use several system-defined drivers. Additionally, you will create the following drivers:

<table>
<thead>
<tr>
<th>User-defined Driver</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>FTEs</td>
<td>Tracks the cost of wages from the Resource module to the Activity module.</td>
</tr>
<tr>
<td>Dollars</td>
<td>Tracks the cost of operating expenses from the Resource module to the Activity module.</td>
</tr>
<tr>
<td># of Customer Complaints</td>
<td>Tracks the number of customer complaints per channel.</td>
</tr>
<tr>
<td># of Packages</td>
<td>Tracks the number of packages collected, sorted, and distributed.</td>
</tr>
</tbody>
</table>

Define drivers

1. Select Model > Drivers Page.

You see the list of system-defined drivers:

2. Select Edit > New Driver.

You see the New Driver dialog box.
3. Type a Name of FTEs.
4. Verify that the Driver type is Basic.
5. Verity that the This driver's quantities are unique option is checked.
6. Click OK.
   You see FTEs added to the list of drivers.
7. Add the following Basic drivers:

<table>
<thead>
<tr>
<th>Driver</th>
<th>Dollars</th>
<th># of Customer Complaints</th>
<th># of Packages</th>
</tr>
</thead>
</table>

**In the next lesson**

Now that you have built the drivers, you can assign costs from resources to activities and from activities to cost objects. In the next lesson, you will create assignments.
Creating Assignments

An assignment links source accounts to destination accounts. Costs flow along this path from resources to activities to cost objects—from expenses to activities to products, services, or customers. A source account is the source of a cost assignment. A destination account receives the results of a cost assignment.

As shown in the above diagram, the possible assignments, as indicated by a letter, are:

- **A** From a resource account to another resource account
- **B** From a resource account to an activity account
- **C** From a resource account to a cost object account
- **D** From an activity account to another activity account
- **E** From an activity account to a cost object account
- **F** From a cost object account to another cost object account

Creating a column layout

For the Parcel Express model, you will create a column layout named Cost Assignment. Initially, you will define the layout for the Resource module. Later, you will add columns to the layout for the other modules.

While building the model structure, you have been working in the Single Pane view. To create assignments, you must open an Assignments pane. With the Primary pane and an Assignments pane open, you can see source accounts, destination accounts, assignments, driver names, and driver quantities. To assign resource costs to activity accounts, you will open the Right Assignments pane.

1. Open the Right Assignments pane and Column Layout dialog box
   - In the Resource module, click **Model > Assignments > Show Right Assignments Pane**.
You see the Right assignments pane (to the right of the Resource module Primary pane). The default columns are IntsctnName (Intersection Name), Reference, and Cost.

**Tip:** You might want to hide the task bar on the left side of the window to display more data. To do this, click the X in the upper right corner of the task bar. You can also make columns wider or narrower by clicking on the line between column headings and dragging the edge of the column to the desired width.

2. **Select** **Model > Column Layout > Edit Columns.**

You see the Column Layout dialog box.

The columns you see in the Displayed Columns list refer to the layout for a specific pane in a specific module. In the above illustration, you see the column layout for the Primary pane of the Resource module. To change the column layout for a different pane or module, you must select that pane or module. The Cost Assignment column layout you create in this tutorial will ultimately contain layouts for several modules and panes.

➤ **Define the column layout for two panes**

1. Verify that the Primary pane tab is selected.
2. From the list of **Displayed Columns**, select **Display Reference**.
3. Click **Remove**.

You see that Display Reference is removed from the list of Displayed Columns. Removing this column from the layout will provide more screen space for columns relevant to making driver assignments.
Creating Assignments

4. In Properties, Attributes, and Dimensions, select Driver Name (DrvName).
   Tip: To find Driver Name, scroll down to Driver and expand the node.
5. Click Add.
   You see DrvName added to the list of Displayed Columns.
6. Click the Right tab.
   You see the default columns of the Right pane in Displayed Columns.
7. Remove the Reference column from Displayed Columns.
8. Add the Driver Quantity Fixed (DQF) property to the list of Displayed Columns.

➢ Save the column layout
1. Click Save As.
   You see the Save Column Layout As dialog box.
   2. Verify that the New column layout option is selected, and type Cost Assignment.
   3. Click OK.
      You see the column layout Name change to Cost Assignment.
   4. Click OK.
      You see the changes you made to the column layout. Cost Assignment appears in the Column Layout list.

You have just created a column layout that will allow you to make assignments from Resource module accounts to other accounts. Later, you will further define the Cost Assignment layout for other modules.

Creating assignments from resources to activities

The first assignments you create will be inter-modular; that is, assignments from the Resource module to the Activity module.

➢ Add accounts for assignments
1. Select Model > Assignments > Add Accounts in Right Pane.
Creating Assignments

You see the Add Accounts for Assignments dialog box.

2. Verify that the Activity module is selected.
3. Expand the Activity module structure so you can see all of its accounts.
   Tip: To see the entire list of accounts, you can resize the dialog box.
4. Hold down the <Ctrl> key, and select all the accounts, as shown below:

5. Click Add Accounts.

   You see the accounts added to the Right pane.
6. Click Close.

Creating assignments

Now that the intended destination accounts are displayed, you can create assignments from Resource accounts to Activity accounts.

Create assignments

1. In the Primary pane, expand the Resource tree to display all its accounts. Do not expand the accounts to display the cost elements of each account.

<table>
<thead>
<tr>
<th>Display Name</th>
<th>Cost</th>
<th>DrvName</th>
</tr>
</thead>
<tbody>
<tr>
<td>RESOURCE PRIMARY PANE</td>
<td>$3,247,900.00</td>
<td></td>
</tr>
<tr>
<td>USA</td>
<td>$3,247,900.00</td>
<td></td>
</tr>
<tr>
<td>Oregon</td>
<td>$3,247,900.00</td>
<td></td>
</tr>
<tr>
<td>Beaverton</td>
<td>$1,530,000.00</td>
<td></td>
</tr>
<tr>
<td>Wages</td>
<td>$1,638,650.00</td>
<td></td>
</tr>
<tr>
<td>Operating Expenses</td>
<td>$230,000.00</td>
<td></td>
</tr>
<tr>
<td>Equipment Expenses</td>
<td>$54,300.00</td>
<td></td>
</tr>
<tr>
<td>Eugene</td>
<td>$1,717,000.00</td>
<td></td>
</tr>
<tr>
<td>Wages</td>
<td>$1,408,000.00</td>
<td></td>
</tr>
<tr>
<td>Operating Expenses</td>
<td>$271,000.00</td>
<td></td>
</tr>
<tr>
<td>Equipment Expenses</td>
<td>$358,000.00</td>
<td></td>
</tr>
</tbody>
</table>

2. Select the Wages account under Beaverton.

You see arrowheads appear next to each account in the Right pane. These arrowheads indicate that you can create assignments from Beaverton Wages to any of the listed accounts. Logically, the cost of wages in Beaverton would only be assigned to Beaverton activities, not Eugene activities.

3. Click the DrvName cell in the Beaverton Wages row.

You see a list of available drivers, including system-defined and user-defined drivers.

4. Select FTEs.

5. Create assignments to all the Beaverton accounts in the Right pane by clicking the arrowhead next to each account.

You see a line connect Beaverton Wages to each of the arrowheads you clicked.

6. Type the following values in the DQF (Driver Quantity Fixed) column on the Right pane:

   - Beaverton x Resolve Customer Complaints: $0.00  3.00
   - Beaverton x Move to Warehouse: $0.00  8.00
   - Beaverton x Inspection: $0.00  3.00
   - Beaverton x Sort: $0.00  4.00
   - Beaverton x Air Distribution: $0.00  9.00
   - Beaverton x Land Distribution: $0.00  12.00
**Note:** The total cost of Beaverton Wages ($1,638,600.00) will be consumed by these five Activity accounts according to the number of FTEs (Full-Time Equivalents) you have entered. The application performs the math for you when you calculate costs in a later lesson.

### Create other assignments

1. In the left pane, select **Operating Expenses** for **Beaverton** and make the following assignments:

<table>
<thead>
<tr>
<th>Resource Account</th>
<th>Driver</th>
<th>Activity Account</th>
<th>Driver Quantity (DQF)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beaverton x Operating Expenses</td>
<td>Dollars</td>
<td>Beaverton x Land Distribution</td>
<td>56,500.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Beaverton x Air Distribution</td>
<td>83,000.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Beaverton x Sort</td>
<td>23,000.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Beaverton x Inspection</td>
<td>54,000.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Beaverton x Move to Warehouse</td>
<td>15,000.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Beaverton x Resolve Customer Complaints</td>
<td>6,500.00</td>
</tr>
</tbody>
</table>

2. In the left pane, select **Equipment Expenses** for **Beaverton** and make the following assignments:

<table>
<thead>
<tr>
<th>Resource Account</th>
<th>Driver</th>
<th>Activity Account</th>
<th>Driver Quantity (DQF)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beaverton x Equipment Expenses</td>
<td>Percentage</td>
<td>Beaverton x Land Distribution</td>
<td>15</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Beaverton x Air Distribution</td>
<td>25</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Beaverton x Sort</td>
<td>20</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Beaverton x Inspection</td>
<td>25</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Beaverton x Move to Warehouse</td>
<td>10</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Beaverton x Resolve Customer Complaints</td>
<td>5</td>
</tr>
</tbody>
</table>

3. In the left pane, select **Wages** for **Eugene** and make the following assignments:

<table>
<thead>
<tr>
<th>Resource Account</th>
<th>Driver</th>
<th>Activity Account</th>
<th>Driver Quantity (DQF)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Eugene x Wages</td>
<td>FTEs</td>
<td>Eugene x Land Distribution</td>
<td>12</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Eugene x Sort</td>
<td>3</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Eugene x Inspection</td>
<td>2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Eugene x Move to Warehouse</td>
<td>5</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Eugene x Resolve Customer Complaints</td>
<td>2</td>
</tr>
</tbody>
</table>
4. In the left pane, select **Operating Expenses** for **Eugene** and make the following assignments:

<table>
<thead>
<tr>
<th>Resource Account</th>
<th>Driver</th>
<th>Activity Account</th>
<th>Driver Quantity (DQF)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Eugene x Operating Expenses</td>
<td>Dollars</td>
<td>Eugene x Land Distribution</td>
<td>98,000.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Eugene x Sort</td>
<td>38,000.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Eugene x Inspection</td>
<td>58,300.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Eugene x Move to Warehouse</td>
<td>69,000.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Eugene x Resolve Customer Complaints</td>
<td>7,700.00</td>
</tr>
</tbody>
</table>

5. In the left pane, select **Equipment Expenses** for **Eugene** and make the following assignments:

<table>
<thead>
<tr>
<th>Resource Account</th>
<th>Driver</th>
<th>Activity Account</th>
<th>Driver Quantity (DQF)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Eugene x Equipment Expenses</td>
<td>Percentage</td>
<td>Eugene x Land Distribution</td>
<td>40</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Eugene x Sort</td>
<td>20</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Eugene x Inspection</td>
<td>25</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Eugene x Move to Warehouse</td>
<td>10</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Eugene x Resolve Customer Complaints</td>
<td>5</td>
</tr>
</tbody>
</table>

### Creating assignments from activities to other activities

The costs of some activities flow to other activities. For example, at Parcel Express, when packages are moved to a warehouse, they must then be sorted or inspected. Therefore, in the Parcel Express model, the costs of the Move to Warehouse activity flow to the Inspection and Sort activities. These are known as intra-modular assignments.

- Modify the Cost Assignment column layout
  1. Select **Model > Activity Module**.
  2. Select **Model > Assignments > Show Right Assignments Pane**.
  3. From the Column Layout list, select **Cost Assignment** and click the arrow.

  ![Column Layout](image)

  The columns of the Primary and Right panes do not change. This is because you have not yet changed the Cost Assignment column layout for the Activity module.

  4. Open the Column Layout dialog box.
  5. Modify the column layout as follows:
Creating Assignments

1. In the Primary pane, remove Display Reference and add Driver Name.
2. In the Right pane, remove Reference and add Driver Quantity Fixed.
3. Click Save and then OK.
4. You see the column layout change as you specified.

Adding accounts for assignment
1. Open the Add Accounts for Assignments dialog box.
2. Select the Activity module.
3. Add the following accounts to the Right pane:
   - Activity Account
     - Beaverton x Inspection
     - Beaverton x Sort
     - Beaverton x Air Distribution
     - Beaverton x Land Distribution
     - Eugene x Inspection
     - Eugene x Sort
     - Eugene x Land Distribution
4. Click Close.

Creating assignments
1. In the left pane, select Move to Warehouse for Beaverton and make the following assignments:

<table>
<thead>
<tr>
<th>Activity Account (Primary pane)</th>
<th>Driver</th>
<th>Activity Account (Right pane)</th>
<th>Driver Quantity (DQF)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beaverton x Move to Warehouse</td>
<td># of Packages</td>
<td>Beaverton x Sort</td>
<td>203,000</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Beaverton x Inspection</td>
<td>50,000</td>
</tr>
</tbody>
</table>

2. In the left pane, select Inspection for Beaverton and make the following assignments:

<table>
<thead>
<tr>
<th>Activity Account (Primary pane)</th>
<th>Driver</th>
<th>Activity Account (Right pane)</th>
<th>Driver Quantity (DQF)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beaverton x Inspection</td>
<td># of Packages</td>
<td>Beaverton x Sort</td>
<td>44,000</td>
</tr>
</tbody>
</table>

3. In the left pane, select Sort for Beaverton and make the following assignments:
Creating Assignments

<table>
<thead>
<tr>
<th>Activity Account (Primary pane)</th>
<th>Driver</th>
<th>Activity Account (Right pane)</th>
<th>Driver Quantity (DQF)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beaverton x Sort</td>
<td># of Packages</td>
<td>Beaverton x Land Distribution</td>
<td>107,000</td>
</tr>
<tr>
<td>Beaverton x Air Distribution</td>
<td></td>
<td></td>
<td>140,000</td>
</tr>
</tbody>
</table>

4. In the left pane, select **Move to Warehouse** for **Eugene** and make the following assignments:

<table>
<thead>
<tr>
<th>Activity Account (Primary pane)</th>
<th>Driver</th>
<th>Activity Account (Right pane)</th>
<th>Driver Quantity (DQF)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Eugene x Move to Warehouse</td>
<td># of Packages</td>
<td>Eugene x Sort</td>
<td>117,000</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Eugene x Inspection</td>
<td>18,000</td>
</tr>
</tbody>
</table>

5. In the left pane, select **Inspection** for **Eugene** and make the following assignments:

<table>
<thead>
<tr>
<th>Activity Account (Primary pane)</th>
<th>Driver</th>
<th>Activity Account (Right pane)</th>
<th>Driver Quantity (DQF)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Eugene x Inspection</td>
<td># of Packages</td>
<td>Eugene x Sort</td>
<td>16,000</td>
</tr>
</tbody>
</table>

6. In the left pane, select **Sort** for **Eugene** and make the following assignments:

<table>
<thead>
<tr>
<th>Activity Account (Primary pane)</th>
<th>Driver</th>
<th>Activity Account (Right pane)</th>
<th>Driver Quantity (DQF)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Eugene x Sort</td>
<td># of Packages</td>
<td>Eugene x Land Distribution</td>
<td>133,000</td>
</tr>
</tbody>
</table>

Creating assignments from activities to cost objects

Now you will create more inter-modular assignments from activity accounts to cost object accounts. Remember that some cost object accounts are single-dimension accounts. These accounts hold unique costs for individual channels or products. Some Parcel Express activities, such as Resolve Customer Complaints, apply uniquely to a channel, regardless of the packages being processed through the channel. Similarly, some costs apply only to products, as you will see in the following procedures.

- **Add accounts for assignment**

1. If there are accounts in the Right pane, select **Model > Assignments > Clear Right**.
   
   You see the Right pane cleared of accounts.
2. Open the **Add Accounts for Assignments** dialog box.
3. Verify that the **Cost Object** module is selected.
4. Add all of the **Cost Object** accounts to the Right pane.
5. Click **Close**.
Create assignments

1. In the left pane, select **Resolve Customer Complaints** for **Beaverton** and make the following assignments:

<table>
<thead>
<tr>
<th>Activity Account</th>
<th>Driver</th>
<th>Cost Object Account</th>
<th>Driver Quantity (DQF)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beaverton x Resolve Customer Complaints</td>
<td># of Customer Complaints</td>
<td>Commercial Pick Up x No &lt;Products and Services&gt;</td>
<td>25</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Walk In x No &lt;Products and Services&gt;</td>
<td>85</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Drop Box x No &lt;Products and Services&gt;</td>
<td>15</td>
</tr>
</tbody>
</table>

2. In the left pane, select **Inspection** for **Beaverton** and create the following assignments:

<table>
<thead>
<tr>
<th>Activity Account</th>
<th>Driver</th>
<th>Cost Object Account</th>
<th>Driver Quantity</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beaverton x Inspection</td>
<td># of Packages</td>
<td>No &lt;Channel&gt; x Standard Ground</td>
<td>500</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No &lt;Channel&gt; x Overnight Express</td>
<td>4,500</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No &lt;Channel&gt; x 2nd Day Guaranteed</td>
<td>1,000</td>
</tr>
</tbody>
</table>

3. In the left pane, select **Air Distribution** for **Beaverton** and make the following assignments:

<table>
<thead>
<tr>
<th>Activity Account</th>
<th>Driver</th>
<th>Cost Object Account</th>
<th>Driver Quantity</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beaverton x Air Distribution</td>
<td># of Packages</td>
<td>No &lt;Channel&gt; x Standard Ground</td>
<td>50,000</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No &lt;Channel&gt; x Overnight Express</td>
<td>65,000</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No &lt;Channel&gt; x 2nd Day Guaranteed</td>
<td>25,000</td>
</tr>
</tbody>
</table>

4. In the left pane, select **Land Distribution** for **Beaverton** and make the following assignments:

<table>
<thead>
<tr>
<th>Activity Account</th>
<th>Driver</th>
<th>Cost Object Account</th>
<th>Driver Quantity</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beaverton x Land Distribution</td>
<td># of Packages</td>
<td>No &lt;Channel&gt; x Standard Ground</td>
<td>67,000</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No &lt;Channel&gt; x Overnight Express</td>
<td>15,000</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No &lt;Channel&gt; x 2nd Day Guaranteed</td>
<td>25,000</td>
</tr>
</tbody>
</table>
5. In the left pane, select **Resolve Customer Complaints** for **Eugene** and make the following assignments:

<table>
<thead>
<tr>
<th>Activity Account</th>
<th>Driver</th>
<th>Cost Object Account</th>
<th>Driver Quantity (DQF)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Eugene x Resolve Customer Complaints</td>
<td># of Customer Complaints</td>
<td>Commercial Pick Up x No &lt;Products and Services&gt;</td>
<td>10</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Walk In x No &lt;Products and Services&gt;</td>
<td>32</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Drop Box x No &lt;Products and Services&gt;</td>
<td>25</td>
</tr>
</tbody>
</table>

6. In the left pane, select **Inspection** for **Eugene** and create the following assignments:

<table>
<thead>
<tr>
<th>Activity Account</th>
<th>Driver</th>
<th>Cost Object Account</th>
<th>Driver Quantity (DQF)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Eugene x Inspection</td>
<td># of Packages</td>
<td>No &lt;Channel&gt; x Standard Ground</td>
<td>1,000</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No &lt;Channel&gt; x Overnight Express</td>
<td>500</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No &lt;Channel&gt; x 2nd Day Guaranteed</td>
<td>500</td>
</tr>
</tbody>
</table>

7. In the left pane, select **Land Distribution** for **Eugene** and make the following assignments:

<table>
<thead>
<tr>
<th>Activity Account</th>
<th>Driver</th>
<th>Cost Object Account</th>
<th>Driver Quantity (DQF)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Eugene x Land Distribution</td>
<td># of Packages</td>
<td>No &lt;Channel&gt; x Standard Ground</td>
<td>75,000</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No &lt;Channel&gt; x Overnight Express</td>
<td>16,000</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No &lt;Channel&gt; x 2nd Day Guaranteed</td>
<td>42,000</td>
</tr>
</tbody>
</table>

In the next lesson

In the next lesson, you will calculate the costs of the Parcel Express model. After you calculate the model, the Activity and Cost Object modules will show costs based on the assignments you just created.
Calculating Costs

Typically, costs are entered in a model at the end of a defined period. These costs come from an organization’s general ledger accounts and from external bills of costs. Additional cost information can come from a Materials Requirements Planning (MRP) system. Production data are also entered into a model at the end of a period.

At any time during the development of a model, you can calculate the cost of each account according to its driver and driver quantities.

Calculating costs

You entered Parcel Express cost and quantities for the 2003 Q1 period, so calculations will be performed for this period.

1. **Calculate costs**
   1. Select **Model > Calculate Costs and Generate Cubes**.

   You see the Calculate Costs and Generate Cubes dialog box. With this dialog box, you can also generate cubes for analysis, but you will not do that now.
2. Under **Perform this action**, verify that the **Calculate costs, but do not generate cubes** option is selected.

3. Click **OK**.

   You see a message in the status bar, at the bottom of the window, indicating that the calculation is in progress.

   | Not published | Working... 1 operation(s). | Tasks... |

   Depending on the speed of your SAS Activity-Based Management server and your connection to it, the calculation might take several seconds. When the calculation is complete, you will see the Operation Summary window. You should have zero fatal errors, zero errors, and nine warnings.

4. Click **Show Details**.

   You see the details of the warnings.

   ![Operation Summary](image)

<table>
<thead>
<tr>
<th>Fatal Errors</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total Number of Fatal Errors: 0</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Errors</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total Number of Errors: 0</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Warnings</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total Number of Warnings: 9</td>
</tr>
</tbody>
</table>

   **Description**: The following account(s) have zero cost:

   1. [C] Drop Box-2nd Day Guaranteed: 9001
   2. [C] Drop Box-Overnight Express: 9003
   3. [C] Drop Box-Standard Ground: 9004
   4. [C] Walk In-2nd Day Guaranteed: 9006
   5. [C] Walk In-Overnight Express: 9008
   6. [C] Walk In-Standard Ground: 9009
   7. [C] Commercial Pick Up-2nd Day Guaranteed: 9011
   8. [C] Commercial Pick Up-Overnight Express: 9013
   9. [C] Commercial Pick Up-Standard Ground: 9014

   **Note**: These warnings have occurred because the accounts listed have no cost elements or costs assigned to them. You will assign costs to these accounts in a later lesson.

### Interpreting the operation summary

An operation summary can show fatal errors, errors, and warnings. Fatal errors are rare during calculation. If a fatal error occurred, the calculation would have been terminated by the application and the results would be incomplete. Errors could result from data or structure that is incomplete, inconsistent, or invalid. Warnings indicate that a potential problem exists with the model, but processing was completed.
Calculating Costs

The operation summary for the Parcel Express model indicates that some accounts of the Cost Object module have no costs. In a later lesson, you will add costs to these accounts based on the sales quantities of each product.

Viewing and verifying calculation results

Experienced activity-based costing users frequently calculate a model after creating accounts, assignments, and driver quantities, or entering cost data, as a validation and quality assurance technique.

The following table shows the total costs for the Resource, Activity, and Cost Object modules, along with the key rollup accounts in each module. Verify that the modules and accounts in your model match the figures below.

<table>
<thead>
<tr>
<th>Module</th>
<th>Roll up Account</th>
<th>Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource</td>
<td></td>
<td>$3,647,900.00</td>
</tr>
<tr>
<td></td>
<td>Beaverton</td>
<td>$1,930,900.00</td>
</tr>
<tr>
<td></td>
<td>Eugene</td>
<td>$1,717,000.00</td>
</tr>
<tr>
<td>Activity</td>
<td></td>
<td>$3,647,900.00</td>
</tr>
<tr>
<td></td>
<td>Beaverton x Personnel</td>
<td>$135,261.15</td>
</tr>
<tr>
<td></td>
<td>Beaverton x Branch Collection</td>
<td>$356,553.08</td>
</tr>
<tr>
<td></td>
<td>Beaverton x Regional Sorting</td>
<td>$752,095.77</td>
</tr>
<tr>
<td></td>
<td>Beaverton x Distribution</td>
<td>$1,763,948.50</td>
</tr>
<tr>
<td></td>
<td>Eugene x Personnel</td>
<td>$126,933.33</td>
</tr>
<tr>
<td></td>
<td>Eugene x Branch Collection</td>
<td>$366,133.33</td>
</tr>
<tr>
<td></td>
<td>Eugene x Regional Sorting</td>
<td>$772,866.67</td>
</tr>
<tr>
<td></td>
<td>Eugene x Distribution</td>
<td>$1,564,072.10</td>
</tr>
<tr>
<td>Cost Object</td>
<td></td>
<td>$3,647,900.00</td>
</tr>
<tr>
<td></td>
<td>Drop Box</td>
<td>$63,594.52</td>
</tr>
<tr>
<td></td>
<td>Walk In</td>
<td>$152,602.46</td>
</tr>
<tr>
<td></td>
<td>Commercial Pick Up</td>
<td>$45,997.50</td>
</tr>
<tr>
<td></td>
<td>No &lt;Channel&gt;</td>
<td>$3,385,705.51</td>
</tr>
</tbody>
</table>

In the next lesson

Next, you will add bills of costs to the model.
Adding Bills of Costs

A bill of costs provides a convenient mechanism for adding material and unit costs directly to accounts, for bidding on jobs, or for implementing activity accounting.

Use a bill of costs when:

- Costs outside of the general ledger need to be introduced into a model. Not all costs assigned through a model come from the general ledger. For example, material costs (the cost of purchased components) can be additional product cost information that often comes from a Materials Requirements Planning (MRP) system.
- Unit cost elements in a model that are associated with product families need to be tracked.

Steps for building bills of costs

Building bills of costs consists of the following steps:

1. **Define a dimension in the External Units module.**
   You did this for the Parcel Express model when you completed the New Model wizard. The dimension is Materials.

2. **Create dimension members.**
   For Parcel Express, the Materials dimension members will represent packaging materials.

3. **Create accounts in the External Units module.**
   You will use the New Account wizard to add external units to the model.

4. **Create an assignment from the external unit to an account using the Bill of Cost driver.**
   Packaging materials in the Parcel Express model contribute to the unique costs of a product. You will make assignments from accounts in the External Units module to accounts in the Cost Object module.

5. **Enter a fixed or variable driver quantity.**
   You will enter both types of quantities.

6. **If you enter a variable driver quantity, you must also enter an output quantity.**
   You will enter output quantities in a later lesson.

Internal and external units

An external unit is a unit, such as a part purchased from a supplier, whose cost is maintained outside of a SAS Activity-Based Management model, but which needs to be accounted for in the model. SAS Activity-
Based Management treats external units like accounts. When an external unit’s cost is flowed to an account, you see the flowed cost listed as an external unit cost element.

An internal unit is a unit, such as a part produced within a company, whose cost is already represented in the model. It is the cost that flows from one account to another’s bill of costs.

In the Parcel Express model, you will use only external units.

**Fixed and variable quantities**

A bill of costs quantity can include variable or fixed quantities or both.

**Variable quantities**

In a variable quantity, the cost that flows to the account from the bill of costs depends on the output quantity: the bill of costs’ unit cost is multiplied by the driver quantity and the output quantity (either a system-calculated output quantity or a user-entered output quantity).

For example, assume that a company manufactures bicycles. The rubber tires are purchased from another company for $5 each. Because each bicycle requires two tires, the unit cost of the bill of costs is $10. If the company produces 100 bicycles, the total cost is $1,000 (100 X $5 X 2).

**Fixed quantities**

In a fixed quantity, the cost that flows to the account from the bill of costs does not depend on the output quantity: the bill of costs’ unit cost is multiplied by the driver quantity.

For example, assume that the bicycle manufacturer mentioned previously buys 1,000 tires at the beginning of each year. The tires might be used in any model of bicycle produced. In this case, the bill of costs’ unit cost does not vary with the number of bicycles produced; it’s always $5,000 (1,000 X $5).

**Creating external units and bills of costs**

Parcel Express buys the following components from outside vendors:

- Standard envelopes
- 2nd Day flats
- Overnight flats
- Large boxes
- Small boxes

These costs must be accounted for in the model. To do so, you will create external units and assign them to cost object accounts, thereby creating bills of costs.

1. **Create the Materials dimension members**
   1. Select **Model > Dimensions Page**.
   2. Select **Edit > New Dimension Member**.
You see the New Dimension Member dialog box.

3. Create the dimension members shown below:

<table>
<thead>
<tr>
<th>Name</th>
<th>Reference</th>
<th>DmLevelName</th>
</tr>
</thead>
<tbody>
<tr>
<td>Region</td>
<td>Reg</td>
<td></td>
</tr>
<tr>
<td>General Ledger</td>
<td>GL</td>
<td></td>
</tr>
<tr>
<td>Activities</td>
<td>Act</td>
<td></td>
</tr>
<tr>
<td>Channel</td>
<td>Chl</td>
<td></td>
</tr>
<tr>
<td>Products and Services</td>
<td>Prod_Serv</td>
<td></td>
</tr>
<tr>
<td>Envelopes</td>
<td>ENV</td>
<td>Level1</td>
</tr>
<tr>
<td>Flats</td>
<td>FTS</td>
<td>Level1</td>
</tr>
<tr>
<td>2nd Day Flat</td>
<td>2DF</td>
<td>Level2</td>
</tr>
<tr>
<td>Overnight Flat</td>
<td>ONF</td>
<td>Level2</td>
</tr>
<tr>
<td>Boxes</td>
<td>BX</td>
<td>Level1</td>
</tr>
<tr>
<td>Large Box</td>
<td>LBX</td>
<td>Level2</td>
</tr>
<tr>
<td>Small Box</td>
<td>SBX</td>
<td>Level2</td>
</tr>
</tbody>
</table>

**Tip:** Select Edit > New Dimension Member to open the New Dimension Member dialog box.

➢ Create External Units accounts

1. Select **Model > External Units Module**.

   You see the External Units module, which has no structure yet.

2. Select **Edit > New Account**.

   You see the New Account wizard.

3. Select the **Standard Envelope** dimension member and click **Next**.

   You see Step 2 of the wizard. For the External Units module only, the wizard contains a field for entering the unit cost.

   - What do you want to call this account?
     - Standard Envelope : 10171

   - What is the account's reference?
     - ENV : 10171

   - The account name and reference cannot be blank. The name and reference are automatically created by the system, however, you can change them. These names appear in reports and in the summaries for operations such as calculate.

   - What is the unit cost?

4. Type a unit cost of **.06**, and click **Next**.

5. Create the following accounts:
Adding Bills of Costs

<table>
<thead>
<tr>
<th>Account</th>
<th>Unit Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>2nd Day Flat</td>
<td>.14</td>
</tr>
<tr>
<td>Overnight Flat</td>
<td>.14</td>
</tr>
<tr>
<td>Large Box</td>
<td>.95</td>
</tr>
<tr>
<td>Small Box</td>
<td>.75</td>
</tr>
</tbody>
</table>

When you have created the accounts, the External Units module should have the following structure:

1. In the External Units module, show the Right assignments pane.
2. Select the Cost Assignment column layout, and click the arrow beside the Column Layout list.
   - **Note:** The layout does not change because you have not defined the column layout for this module yet.
3. In the Primary pane, remove Display Reference.
4. Modify the Right pane as follows:
   - c. Remove Reference.
   - d. Add Driver Quantity Fixed (DQF) and Driver Quantity Variable (DQV).
5. Click Save and OK.

- **Modify the Cost Assignment column layout**

- **Add accounts for assignments**

1. Open the Add Accounts for Assignments dialog box.
2. Add the following Cost Object accounts to the Right pane:

<table>
<thead>
<tr>
<th>Cost Object Account</th>
</tr>
</thead>
<tbody>
<tr>
<td>No &lt;Channel&gt; x 2 nd Day Guaranteed</td>
</tr>
<tr>
<td>No &lt;Channel&gt; x Overnight Express</td>
</tr>
<tr>
<td>No &lt;Channel&gt; x Standard Ground</td>
</tr>
</tbody>
</table>
Create assignments

1. Create the following assignments with the driver quantities shown:

<table>
<thead>
<tr>
<th>External Unit Account</th>
<th>Cost Object Account</th>
<th>DQF</th>
<th>DQV</th>
</tr>
</thead>
<tbody>
<tr>
<td>Standard Envelope</td>
<td>No &lt;Channel&gt; x Overnight Express</td>
<td>26,000</td>
<td></td>
</tr>
<tr>
<td>2nd Day Flat</td>
<td>No &lt;Channel&gt; x 2nd Day Guaranteed</td>
<td></td>
<td>1.00</td>
</tr>
<tr>
<td>Overnight Flat</td>
<td>No &lt;Channel&gt; x Overnight Express</td>
<td>130,000</td>
<td></td>
</tr>
<tr>
<td>Large Box</td>
<td>No &lt;Channel&gt; x Standard Ground</td>
<td>125,000</td>
<td></td>
</tr>
<tr>
<td>Small Box</td>
<td>No &lt;Channel&gt; x Standard Ground</td>
<td>76,500</td>
<td></td>
</tr>
</tbody>
</table>

*Note:* When making assignments from External Units, the application automatically applies the Bill of Cost driver.

2. Select Model > Assignments > Show Single Pane.

3. Calculate the model, and close the Operation Summary.

You see the following external units costs:

<table>
<thead>
<tr>
<th>Display Name</th>
<th>UnitCost</th>
<th>Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>EXTERNAL UNITS</td>
<td></td>
<td>$155,550.00</td>
</tr>
<tr>
<td>Envelopes</td>
<td>$1,560.00</td>
<td></td>
</tr>
<tr>
<td>Standard Envelope</td>
<td>$0.00</td>
<td>$1,560.00</td>
</tr>
<tr>
<td>Pads</td>
<td>$15,000.00</td>
<td></td>
</tr>
<tr>
<td>2nd Day Flat</td>
<td>$0.14</td>
<td>$3.00</td>
</tr>
<tr>
<td>Overnight Flat</td>
<td>$0.14</td>
<td>$15,000.00</td>
</tr>
<tr>
<td>Large Box</td>
<td>$175,125.00</td>
<td></td>
</tr>
<tr>
<td>Small Box</td>
<td>$75,275.00</td>
<td></td>
</tr>
</tbody>
</table>

*Note:* The 2nd Day Flat external unit does not have a cost yet because you assigned a variable driver quantity of 1. Until you enter an output quantity for the 2nd Day Guaranteed product, the system cannot calculate the cost of 2nd Day Flats.

**In the next lesson**

In the next lesson, you will enter periodic data critical to evaluating costs and profits.
Entering Output, Sales, and Revenue Data

Some of the most critical calculations in a model rely on the number of products produced and sold, as well as sales revenue. From these quantities, you can determine unit costs and profit. SAS Activity-Based Management provides properties for the input and calculation of these numbers.

Entering output quantities

In SAS Activity-Based Management models, output quantity can be derived from a number of user-entered quantities. In this model you will enter data into the Output Quantity UE (User Entered) property and the Sold Quantity property, both of which will be used to calculate the Sold Quantity of an account. Using the Output Quantity, the system can also calculate Unit Cost.

Create a new column layout

1. Select Model > Cost Object Module.
2. Expand the No <Channels> roll up account.
3. Create a new column layout called Unit Cost by modifying the Primary pane of the Default column layout as follows:
   a. Remove the Display Reference column.
   b. Add the Unit Cost, Output Quantity UE, and Output Quantity properties.

Enter output quantities and calculate costs

1. In the OutQtyUE (Output Quantity User Entered) column, enter the following quantities:

<table>
<thead>
<tr>
<th>Account</th>
<th>Quantity</th>
</tr>
</thead>
<tbody>
<tr>
<td>No &lt;Channel&gt; x 2&quot; Day Guaranteed</td>
<td>93,500</td>
</tr>
<tr>
<td>No &lt;Channel&gt; x Overnight Express</td>
<td>101,000</td>
</tr>
<tr>
<td>No &lt;Channel&gt; x Standard Ground</td>
<td>193,500</td>
</tr>
</tbody>
</table>

2. Calculate the model, and close the Operation Summary.

You see the unit cost for each product. The system has generated output quantities for each product.
Entering Output, Sales, and Revenue Data

You enter sales volumes in the Sold Quantity property.

➤ **Modify the Cost Assignment column layout**

1. In the Cost Object module, show the Right assignments pane.
2. Select the Cost Assignment column layout and click the arrow beside the Column Layout list.
   
   **Note:** The layout does not change because you have not defined the column layout for this module yet.
3. Modify the Primary pane as follows:
   a. Remove Display Reference.
   b. Add Driver Name.
4. Modify the Right pane as follows:
   a. Remove Reference.
   b. Add Sold Quantity.
5. Click Save and OK.

➤ **Add accounts to the Right pane**

1. Open the Add Accounts for Assignments dialog box.
2. Add the following Cost Object accounts to the Right pane for assignment:

<table>
<thead>
<tr>
<th>Display Name</th>
<th>Cost</th>
<th>Unit Cost</th>
<th>Out qtyUE</th>
<th>Out Qty</th>
</tr>
</thead>
<tbody>
<tr>
<td>etal Drop Box</td>
<td>$6.35</td>
<td>$5.94</td>
<td>52</td>
<td>52</td>
</tr>
<tr>
<td>ial In</td>
<td>$123,600.46</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ommercial Pick Up</td>
<td>$65,997.50</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>No - Channel</td>
<td>$3,924,630.51</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2nd Day Guaranteed</td>
<td>$814,450.27</td>
<td>$6.71</td>
<td>93,500.00</td>
<td>93,500.00</td>
</tr>
<tr>
<td>rnight Express</td>
<td>$24,714.27</td>
<td>$8.17</td>
<td>101,000.00</td>
<td>101,000.00</td>
</tr>
<tr>
<td>andard Ground</td>
<td>$1,955,515.87</td>
<td>$10.11</td>
<td>183,500.00</td>
<td>193,500.00</td>
</tr>
</tbody>
</table>

**Note:** If you return to the External Units module, you will see that a cost has been generated for the 2nd Day Flat account. This is because you assigned cost using the Driver Quantity Variable (DQV) property, which requires an output quantity for calculation. Now that you have entered the 2nd Day Guaranteed output quantity, the 2nd Day Flat external unit account can be calculated.
Entering Output, Sales, and Revenue Data

<table>
<thead>
<tr>
<th>Cost Object Account</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drop Box x 2nd Day Guaranteed</td>
</tr>
<tr>
<td>Drop Box x Overnight Express</td>
</tr>
<tr>
<td>Drop Box x Standard Ground</td>
</tr>
<tr>
<td>Walk In x 2nd Day Guaranteed</td>
</tr>
<tr>
<td>Walk In x Overnight Express</td>
</tr>
<tr>
<td>Walk In x Standard Ground</td>
</tr>
<tr>
<td>Commercial Pick Up x 2nd Day Guaranteed</td>
</tr>
<tr>
<td>Commercial Pick Up x Overnight Express</td>
</tr>
<tr>
<td>Commercial Pick Up x Standard Ground</td>
</tr>
</tbody>
</table>

➢ Enter sales volumes

1. In the Primary pane, select the **Sales Volume** driver for the following accounts:

<table>
<thead>
<tr>
<th>Cost Object Account</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drop Box x No Products and Services</td>
</tr>
<tr>
<td>Walk In x No Products and Services</td>
</tr>
<tr>
<td>Commercial Pick Up x No Products and Services</td>
</tr>
<tr>
<td>No Channel x 2nd Day Guaranteed</td>
</tr>
<tr>
<td>No Channel x Overnight Express</td>
</tr>
<tr>
<td>No Channel x Standard Ground</td>
</tr>
</tbody>
</table>

2. In the Right pane, enter the following **SoldQty** for the accounts shown:

<table>
<thead>
<tr>
<th>Account</th>
<th>SoldQty</th>
</tr>
</thead>
<tbody>
<tr>
<td>Commercial Pick Up x Standard Ground</td>
<td>51,000</td>
</tr>
<tr>
<td>Commercial Pick Up x Overnight Express</td>
<td>39,000</td>
</tr>
<tr>
<td>Commercial Pick Up x 2nd Day Guaranteed</td>
<td>30,000</td>
</tr>
<tr>
<td>Walk In x Standard Ground</td>
<td>110,000</td>
</tr>
<tr>
<td>Walk In x Overnight Express</td>
<td>56,000</td>
</tr>
<tr>
<td>Walk In x 2nd Day Guaranteed</td>
<td>50,000</td>
</tr>
<tr>
<td>Drop Box x Standard Ground</td>
<td>32,500</td>
</tr>
<tr>
<td>Drop Box x Overnight Express</td>
<td>6,000</td>
</tr>
<tr>
<td>Drop Box x 2nd Day Guaranteed</td>
<td>13,500</td>
</tr>
</tbody>
</table>

**Note:** At this point in other modules, you would make assignments from the accounts in the Primary pane to the accounts in the Right pane. However, the Sales...
Entering Output, Sales, and Revenue Data

Volume driver automatically assigns costs based on the sales volumes (SoldQty) you entered.

3. With the Primary and Right panes still open, calculate the model and close the Operation Summary.
   You see costs assigned to the nine accounts previously without costs.

4. In the Primary pane, click the Drop Box x No <Products and Services> account.
   You see that assignments have automatically been made to three accounts in the Right pane.

Entering revenue and calculating profit

Profit and loss can be calculated after you enter sales data in the Revenue property.

➢ Create a new column layout
1. Select Model > Cost Object Module.
2. Select the Default column layout and click the arrow next to the Column Layout list.
3. Open the Column Layout dialog box.
4. Modify the Primary pane as follows:
   a. Remove the Display Reference column.
   b. Add the Unit Cost, Sold Quantity, Revenue, and Profit columns.
5. Save the layout as Profit.

➢ Enter revenue and calculate profit
1. In the Revenue column, type the following values:

<table>
<thead>
<tr>
<th>Cost Object Account</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drop Box x 2nd Day Guaranteed</td>
<td>93,825</td>
</tr>
<tr>
<td>Drop Box x Overnight Express</td>
<td>89,700</td>
</tr>
<tr>
<td>Drop Box x Standard Ground</td>
<td>568,750</td>
</tr>
<tr>
<td>Walk In x 2nd Day Guaranteed</td>
<td>347,500</td>
</tr>
<tr>
<td>Walk In x Overnight Express</td>
<td>837,200</td>
</tr>
<tr>
<td>Walk In x Standard Ground</td>
<td>1,925,000</td>
</tr>
<tr>
<td>Commercial Pick Up x 2nd Day Guaranteed</td>
<td>208,500</td>
</tr>
<tr>
<td>Commercial Pick Up x Overnight Express</td>
<td>583,050</td>
</tr>
<tr>
<td>Commercial Pick Up x Standard Ground</td>
<td>892,500</td>
</tr>
</tbody>
</table>

2. Calculate the model, and close the Operation Summary.
   You see the following profit (and loss) information:
Entering Output, Sales, and Revenue Data

<table>
<thead>
<tr>
<th>Display Name</th>
<th>Cost</th>
<th>UnitCost</th>
<th>SoldQty</th>
<th>Revenue</th>
<th>Profit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drop Box</td>
<td>$552,787.56</td>
<td></td>
<td></td>
<td>$752,275.00</td>
<td>$189,487.44</td>
</tr>
<tr>
<td>2nd Day Guaranteed</td>
<td>$143,900.06</td>
<td>$10.66</td>
<td>13,000.00</td>
<td>$193,225.00</td>
<td>($50,375.06)</td>
</tr>
<tr>
<td>Overnight Express</td>
<td>$53,179.03</td>
<td>$8.86</td>
<td>6,000.00</td>
<td>$93,700.00</td>
<td>$36,520.97</td>
</tr>
<tr>
<td>Standard Ground</td>
<td>$365,708.46</td>
<td>$11.25</td>
<td>32,500.00</td>
<td>$558,750.00</td>
<td>$203,041.54</td>
</tr>
<tr>
<td>No &lt;Products and Services&gt;</td>
<td>$63,594.52</td>
<td>$1.22</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Walk In</td>
<td>$2,155,523.92</td>
<td></td>
<td></td>
<td>$3,109,700.00</td>
<td>$854,176.08</td>
</tr>
<tr>
<td>2nd Day Guaranteed</td>
<td>$507,139.25</td>
<td>$10.14</td>
<td>50,000.00</td>
<td>$347,500.00</td>
<td>($159,639.25)</td>
</tr>
<tr>
<td>Overnight Express</td>
<td>$467,414.85</td>
<td>$8.35</td>
<td>55,000.00</td>
<td>$837,200.00</td>
<td>$369,785.15</td>
</tr>
<tr>
<td>Standard Ground</td>
<td>$1,190,869.63</td>
<td>$10.74</td>
<td>110,000.00</td>
<td>$1,925,000.00</td>
<td>$744,030.17</td>
</tr>
<tr>
<td>No &lt;Products and Services&gt;</td>
<td>$152,502.45</td>
<td>$0.71</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Commercial Pick Up</td>
<td>$1,138,563.52</td>
<td></td>
<td></td>
<td>$1,684,050.00</td>
<td>$545,486.48</td>
</tr>
<tr>
<td>2nd Day Guaranteed</td>
<td>$294,588.14</td>
<td>$9.82</td>
<td>30,000.00</td>
<td>$208,500.00</td>
<td>($86,088.14)</td>
</tr>
<tr>
<td>Overnight Express</td>
<td>$312,917.02</td>
<td>$8.02</td>
<td>39,000.00</td>
<td>$533,050.00</td>
<td>$270,132.98</td>
</tr>
<tr>
<td>Standard Ground</td>
<td>$531,258.36</td>
<td>$10.41</td>
<td>51,000.00</td>
<td>$592,500.00</td>
<td>$361,441.54</td>
</tr>
<tr>
<td>No &lt;Products and Services&gt;</td>
<td>$45,997.50</td>
<td>$0.38</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>No &lt;Channel&gt;</td>
<td>$3,594,080.51</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2nd Day Guaranteed</td>
<td>$652,283.31</td>
<td>$9.44</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Overnight Express</td>
<td>$771,580.29</td>
<td>$7.64</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Standard Ground</td>
<td>$1,940,726.92</td>
<td>$10.03</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

In the next lesson

Next, you will add attributes to the model, which will allow you to further categorize and analyze data.
Adding Attributes

An attribute is a label or identification tag attached to a rollup account, account, or entered cost element. The attribute conveys information about the object to which it is attached.

Attributes have many purposes. You can use them to:
- Group ABM data to simplify report preparation and interpretation
- Create different dimensions of data
- Report similar cost categories across cost centers
- Classify cost components as fixed or variable, value-added or non value-added

Types of attributes

There are four attributes types:
- Text
- Numeric
- Dimension
- Boolean

Text attributes

A text attribute describes model information and enables you to categorize, select, and subtotal information in a report. Activities can be grouped by summary-level processes, such as detailed manufacturing activities rolling up to “manufacturing,” and detailed distribution activities rolling up to “distribution.” The names of these higher-level processes are defined as text attributes and are attached to their respective activities. You can then generate a report that groups and totals detailed activity cost by text attribute.

Other examples of text attributes include:
- Value-added categories (high, medium, low) attached to activities
- Fixed cost/variable cost attached to resources—allows activity or cost object costs to be grouped by fixed and variable cost components
- Cost object groupings to roll up products by product family, brand, market segment, or package type or to group customers by region, channel, or salesperson
**Adding Attributes**

**Numeric attributes**
A numeric attribute enables you to enter data not entered or otherwise generated in a model. Typically, numeric attributes are measures or quantities of units contributing to the total cost of an activity, such as number of cases, number of pounds, number of orders, or number of times an activity is performed. You can establish numeric attributes as performance measures for special reporting purposes, such as tracking productivity (number of inputs or rejects, cycle time, and quality), or classifying information (level of complexity or number of sub-assemblies).

**Dimension and dimension member attributes**
A dimension attribute reflects a dimension, and a dimension member attribute reflects a dimension member.

**Boolean attributes**
A boolean attribute stores a boolean value (True or False).

**Creating attributes**
You will create a numeric attribute and a dimension attribute.

- **Create a numeric attribute**
  1. Select Model > Attributes Page.
  2. Select Edit > New Attribute.

You see the New Attribute dialog box.

![New Attribute dialog box](image)

3. Type a Name of Inspections Passed.
4. Type a Reference of IP.

SAS Activity-Based Management Tutorial 64
5. Select an **Attribute type** of **Numeric**.

6. For **Unit of Measure**, type **Number of Inspections Passed**.

7. Click **OK**.

   You see the Inspections Passed attribute added to the list.

---

Create a dimension attribute

1. Select **Edit > New Attribute**.

2. Type a **Name** of **Fixed_Variable**

3. Type a **Reference** of **FV**.

4. Select a **Type** of **Dimension**.

5. Click **OK**.

6. Select the **Fixed_Variable** attribute.

7. Create the following two attributes:

<table>
<thead>
<tr>
<th>Name</th>
<th>Reference</th>
<th>Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fixed</td>
<td>F</td>
<td>Dimension Value</td>
</tr>
<tr>
<td>Variable</td>
<td>V</td>
<td>Dimension Value</td>
</tr>
</tbody>
</table>

8. Select **Model > Dimensions Page**.

   You see that the Fixed_Variable dimension and its two dimension members have been added to the list of your model’s dimensions.

---

### Entering attribute quantities

Now, you will display a column to enter attribute quantities.

---

**Add a column to show an attribute**

1. Select **Model > Activity Module**.

2. Select the **Default** column layout and display the module in **Single Pane** view.

3. Expand the structure to reveal all Activity accounts.

4. Add a column to the Primary pane for **Inspections Passed**.

   **Tip:** Look in the Attributes folder at the bottom of the list.

   You see Inspections Passed added to the layout.

---

**Enter attribute quantities**

1. In the **Inspections Passed** column for the **Beaverton x Inspection** account, type **43400**.

2. In the **Inspections Passed** column for the **Eugene x Inspection** account, type **1100**.
In the next lesson

Next, you will learn about the reporting features of SAS Activity-Based Management.
Generating Reports

Once the information has been entered into the activity-based management model, the costs calculated, and the data reviewed, the next step in analyzing the data is generating reports.

The benefits of generating reports include:

- Validating the model
- Producing printouts that present an overall view of the data
- Analyzing costs on the screen
- Producing files for inclusion in other programs, such as spreadsheets or word processors
- Focusing on a specific area of interest

Report templates

A report template is a file that specifies the layout of a report and the fields of data in a report (but not the data itself). When you create a report, you first select a report template.

Pre-defined report templates

SAS Activity-Based Management has pre-defined report templates that provide formats and that permit great flexibility in the amount and type of information to include in a report. The following pre-defined templates are included in the system:

- Destination Furthest
- Dimensional Attribute Cost
- Dimensional Attribute Unit Cost
- Dimensional View
- Driver - Cost and Rate
- Idle Capacity
- Module Hierarchy
- Multi-level Contributions
- Profit and Loss
- Profit Cliff
- Resource Contributions
- Resource Contributions by attribute
Generating Reports

- Single-stage Assignments
- Single-stage Contributions
- Unassigned Costs
- Unit Cost

Custom report templates

You can create report templates that fit your needs. You have complete control over the report design, layout, and data. You access the data in a model through Crystal Reports Data Definition files, which are provided with SAS Activity-Based Management.

In addition to SAS Activity-Based Management model data, you can access data contained in another database, such as a general ledger. Accessing such non-SAS Activity-Based Management data requires advanced knowledge of Crystal Reports and data sources.

Creating a report

You will create a report and view the results on-screen. The report is for the 2003 Q1/Actual period/scenario association and includes information about resource contributions.

To create a new report, you use the New Report wizard. The wizard has six steps.

- **Select a model and template**
  1. Click Reports
     - You see the Reports home page.
     - You see Step 1 of the New Report wizard.
3. Under **Select a standard report**, select the **Parcel Express** model and the **Resource Contributions** report.

4. Click **Next**.
   
   You see Step 2 of the wizard.

5. Select **2003 Q1/Actual**.

6. Complete Steps 3 through 5, accepting the default settings:

<table>
<thead>
<tr>
<th>Step</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>3</td>
<td>Use all modules</td>
</tr>
<tr>
<td>4</td>
<td>no dimensions selected</td>
</tr>
<tr>
<td>5</td>
<td>Suppress zero costs</td>
</tr>
<tr>
<td></td>
<td>Single currency</td>
</tr>
</tbody>
</table>

7. For Step 6, select **Save configuration**.

8. Type a **Name** of **PX Resource Contributions**.

9. Click **Finish**.
   
   You see the finished report.
Generating Reports

The data contained in this report reflects the current model. If you make changes to the model and re-open the report, the report data reflects the changes.

Each report has a header that lists pertinent information for that report. All or some of the following information can be listed in a report’s header:

<table>
<thead>
<tr>
<th>Information</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Model Name</td>
<td>The model selected for the report.</td>
</tr>
<tr>
<td>Module</td>
<td>One or more modules selected for the report. Each module starts on a new page</td>
</tr>
<tr>
<td>Period</td>
<td>The period selected for the report.</td>
</tr>
<tr>
<td>Scenario</td>
<td>The scenario selected for the report.</td>
</tr>
<tr>
<td>View Perspective</td>
<td>The dimension selected for the report.</td>
</tr>
<tr>
<td>Filtered</td>
<td>Indicates that one or more attributes were used to select items for the report. Attributes used to select report data are listed on a report's last page.</td>
</tr>
</tbody>
</table>

Working with reports

All saved report configurations on the same server are listed in Workspace Manager. Your organization might want to set up some guidelines for saving and naming report configurations. You may open a report configuration from the Workspace Manager or from the Reports home page.
On the Reports home page, you can open, publish, configure, or delete a report configuration.

**Navigating reports**

You can navigate the pages of a report using paging and search tools on the toolbar.

The Preview tab allows you to navigate to any page of the report by expanding the hierarchy and selecting a node.

**Saving report data**

When you save a report configuration, you are saving only the parameters of the report and not the data. To save the data in a report, you have these options: exporting and publishing.

**Exporting report data**

If you want to manipulate a report after running it, such as add a company logo, export the report.

1. On the report toolbar, click Export report data.
   
   You see the Export Report dialog box.
Generating Reports

2. Select a **File Format**.
   The available export formats are:

   - **Report Export Formats**
     - Crystal Reports
     - Microsoft Excel
     - Microsoft Excel (Data Only)
     - Microsoft Word
     - Rich Text Format
     - Adobe Acrobat

3. Type a **File name**. You can optionally **Browse** to a location.
4. Click **OK**.
   You see the Report Viewer Export dialog box.

   You can open the export file now or view it later.

**Publishing report data**

If you want other users to see the report results with the data reflecting a specific point in time, you can publish the report. Publishing the report allows others to see the report data without the need to re-run the report. For a report that requires considerable time to run, publishing the report can save other users time.
Publish report data

1. On the Reports home page, click the Publish link next to the desired report configuration.
   You see the Publish a Report dialog box.

2. Type a Name.
   Note: You cannot enter a path. Published reports are stored on the SAS Activity-Based Management server.

3. (Optional) Type a Description.

4. Select a Format.
   The available publishing formats are:

<table>
<thead>
<tr>
<th>Report Publishing Formats</th>
</tr>
</thead>
<tbody>
<tr>
<td>Crystal Reports</td>
</tr>
<tr>
<td>Microsoft Excel</td>
</tr>
<tr>
<td>Microsoft Word</td>
</tr>
<tr>
<td>PDF</td>
</tr>
</tbody>
</table>

5. Click OK.
   The report is added to the Workspace Manager in the Published Reports folder.

Configuring reports

By running the New Report wizard, you are configuring a report. You can reconfigure a report.

Reconfigure a report

1. On the Reports home page, click the Configure link next to the saved configuration.

2. Complete the Report Wizard, selecting the new configuration settings.
In the next lesson

In the next lesson, you will work with OLAP cubes.
Using OLAP Cubes for Analysis

A cube is the basic unit of analysis in online analytic processing (OLAP), a technology that provides fast, interactive access to data in a model. A cube is a storage unit that combines a number of dimensions and the measures they contain into one unit. You use SAS Activity-Based Management to connect to and interact with the cubes on a SAS Activity-Based Management server. For each model, you can generate cubes and manipulate them on the OLAP page to interactively analyze business data.

The SAS Activity-Based Management OLAP tool provides three views in which to analyze data:

- Grid View
- Chart View
- Decomposition Tree View

You can select the view that presents the data in the most meaningful format for your purposes.

Cube overview

A cube is a set of data that is constructed from a subset of model data and is organized and summarized into a multi-dimensional structure. SAS Activity-Based Management cubes are standard OLAP cubes.

It does not matter how many dimensions a cube has; the storage unit is still called a cube, which represents any number of dimensions of data.

Types of cubes

SAS Activity-Based Management provides the following types of cubes:

- Multi-stage contributions
- Resource contributions
- Single-stage contributions

Each one helps you analyze data in different ways and answer different kinds of questions.

Multi-stage contributions cube

Use this cube to answer questions such as:

- Product A is not profitable. I want to trace the costs back through activities and then to resources that contribute costs to this product.
Using OLAP Cubes for Analysis

What are the costs for Product B that originate in salary resources and are assigned through the Inspection activity to this product?

The Multi-stage Contributions cube allows you to analyze cost contributions into and out of stages defined in a model. The Decomposition Tree View allows you to visually trace cost contributions through all the stages.

Resource contributions cube

Use the Resource Contributions cube to analyze resource costs that contribute to a product, customer, service cost, and so on. Or, use this cube to analyze the products, customers, service costs, and so on, that receive costs from resources.

The Resource Contributions cube allows you to study cost contributions from original accounts where costs were entered to final accounts that do not assign costs to other accounts. Generally, these contributions are from resource accounts to cost object accounts, but it does not matter where the original or final accounts reside.

Single-stage contributions cube

Use this cube to answer questions such as:

- Which activity costs contribute to product, customer, service costs, and so on?
- When costs are assigned within the Cost Object module, which sub-assembly costs contribute to product costs?
- What are the costs of resources that contribute to activities?

The Single-stage Contributions cube allows you to analyze the cost contributions from one assignment level back. It does not matter where the costs originate or end. Typically, cost is contributed from:

- Activities to cost objects
- Resources to activities

Generating cubes

Before you can use OLAP cubes to analyze model data, you must generate cube data. Then you can select the type of cube that meets your analysis objectives.

1. In Model mode, select Model > Calculate Costs and Generate Cubes.
   You see the Calculate Costs and Generate Cubes dialog box.
2. Select Calculate costs and generate cubes.
3. Verify that the three types of cubes in the Generate these cubes list are all selected.
4. Click OK.
   You see the Operation Summary.
5. Close the Operation Summary, and switch to OLAP mode.
Creating OLAP views

Create an OLAP view

1. Select File > New > OLAP View.

You see Step 1 of the New OLAP View wizard. The OLAP wizard has only one step.

2. Select the *Parcel Express* model.

3. Select the *Resource Contributions* cube.

4. Click Finish.

You see the Resource Contributions cube for the Parcel Express model.
Using OLAP Cubes for Analysis

By default, the Chart View contains a bar chart and grid. You can change the style of chart.

The Decomposition Tree View allows you to drill down through the model to view the flow of costs.

So far, the only information the cube provides is the costs for periods and scenarios. To perform an interactive analysis of the cube, you will select specific dimensions for analysis.

5. Close the Decomposition Tree View window.
6. Maximize the Chart View window.

Analyzing OLAP cubes

You use the Dimension Control to select dimensions for analysis in OLAP cubes.

Selecting and displaying dimensions in cubes

➢ Select dimensions
1. Select OLAP > Show/Hide Dimension List.
   You see the Dimension Control.
Using OLAP Cubes for Analysis

2. Drag **All Period** from the **Rows** list and **All Scenario** from the **Columns** list to the **Background** list.

3. From **Background**, drag **Src Region** and **Src General Ledger** to the **Rows** list.

4. From **Background**, drag **Dst Products and Services** to the **Columns** list.

Rows and Columns should look like the following:

5. Move the mouse pointer to the **Chart View**.

You see Chart View change slightly. The data in the Chart View has been updated according to the dimensions you have selected, but to see the details, you must drill through the dimensions.

6. Close the **Dimension Control**.

**Drill through dimensions**

1. Move the mouse pointer to the **All** column in the grid.
The pointer changes to a drill, which indicates that you can drill down on this dimension.

2. Click the **All** column.
   
   You see the Products and Services dimension expand, showing the costs for each product.

3. To eliminate empty rows and columns, select **OLAP > Filter Data**.
   
   You see the Filtering dialog box.

4. Select the **Empty rows** and **Empty columns** options and click **OK**.
   
   You see the empty columns removed from the grid and chart.

5. Drill down on the two cells labeled **All** until you see the general ledger expenses for Eugene and Beaverton.
   
   Both the grid and bar chart show the contribution of resource accounts to each product.
6. In the Dimension Control, add **Src Channel** to **Columns** and drill down on the added column in the grid.

You see the Channel dimension added to the grid and chart.

You can move the pointer over any bar or any account to see specific cost information.
Using measures in cubes

The default measure is Cost. You viewed model data using other measures, such as Unit Cost or Profit. Now, you will view OLAP information using different measures, and you will create a custom measure.

Working with measures in OLAP

1. Select OLAP > Grid.
   
   You see the Chart View change to Grid View.

2. Using the Dimension Control, select the following dimensions:

<table>
<thead>
<tr>
<th>Row</th>
<th>Column</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dst Products and Services</td>
<td>Measures</td>
</tr>
</tbody>
</table>

3. In Rows, double-click Measures.

   You see the Measures tab. This is a list of measures by which you can analyze the cube.

   ![Measures Tab]

   You can select any combination of measures to view. To select more than one measure, hold the Ctrl key while selecting. The order in which you select measures determines the order of rows on the grid.

4. Select the following measures in the order listed:

   - Cost
   - UnitCost
   - Revenue
   - UnitRevenue
   - Profit
   - UnitProfit
You see that the 2nd Day Guaranteed product is losing money, while the other two products are profitable.

<table>
<thead>
<tr>
<th></th>
<th>Cost</th>
<th>UnitCost</th>
<th>Revenue</th>
<th>UnitRevenue</th>
<th>Profit</th>
<th>UnitProfit</th>
</tr>
</thead>
<tbody>
<tr>
<td>2nd Day Guaranteed (All data)</td>
<td>932,538.56</td>
<td>9.97</td>
<td>649,825.00</td>
<td>6.95</td>
<td>-282,713.56</td>
<td>-3.02</td>
</tr>
<tr>
<td>None</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
<td></td>
</tr>
<tr>
<td>Overnight Express</td>
<td>813,751.96</td>
<td>8.06</td>
<td>1,509,950.00</td>
<td>14.95</td>
<td>596,198.04</td>
<td>6.89</td>
</tr>
<tr>
<td>Standard Ground</td>
<td>1,901,611.92</td>
<td>9.83</td>
<td>3,386,250.00</td>
<td>17.50</td>
<td>1,484,538.08</td>
<td>7.67</td>
</tr>
</tbody>
</table>

5. To see whether this trend is similar across all channels, add Dst Channel to Rows.

One of management’s goals was to make a profit of at least 10% on the 2nd Day Guaranteed product and at least 25% on all others. SAS Activity-Based Management has shown that the company’s profit picture is not what management expected. Competitive pressures forced them to lower the price of their 2nd Day product, but they had no idea they were losing money on every unit sold.

Now, you will create a custom measure to calculate gross margin.

Create a custom measure

1. On the Dimension Control, click . You see Step 1 of the New Measure wizard.

2. Select Custom formula, and click Next. You see the next step of the wizard.
3. Type a Name of Gross Margin.

4. To create the formula:
   a. In Measures, select Profit, and click Insert.
   b. On the key pad, click the division symbol (/).
   c. In Measures, select Revenue, and click Insert.
      The formula should appear as follows:
      
      \[
      \text{Formula:} \quad \frac{[\text{Measures}][\text{Profit}]}{[\text{Measures}][\text{Revenue}]}
      \]
      
      d. Select a Format String of 0%.
   e. Click Finish.
      You see the Gross Margin measure added to My Items in Measures.

5. Move the mouse pointer to the Grid View.
   You see the profit margin of each product.
Using OLAP Cubes for Analysis

<table>
<thead>
<tr>
<th>Product</th>
<th>Gross Margin</th>
</tr>
</thead>
<tbody>
<tr>
<td>2nd Day Guaranteed</td>
<td>-41%</td>
</tr>
<tr>
<td>Commercial Pick Up</td>
<td>-53%</td>
</tr>
<tr>
<td>Drop Box</td>
<td>-46%</td>
</tr>
<tr>
<td>Overnight Express</td>
<td>46%</td>
</tr>
<tr>
<td>Commercial Pick Up</td>
<td>41%</td>
</tr>
<tr>
<td>Drop Box</td>
<td>44%</td>
</tr>
<tr>
<td>Standard Ground</td>
<td>40%</td>
</tr>
<tr>
<td>Commercial Pick Up</td>
<td>36%</td>
</tr>
<tr>
<td>Drop Box</td>
<td>39%</td>
</tr>
</tbody>
</table>

Based on the stated goals of the company, the 2nd Day Guaranteed is under-performing, while the other two products are over-performing.

Now, you will analyze the model using the Decomposition Tree to get more information about the costs associated with each product. This information will help management decide whether costs are too high or pricing is too low for the 2nd Day Guaranteed product.

**Using the Decomposition Tree**

The management of Parcel Express has learned that margins on their 2nd Day Guaranteed product fall well below expectations. The SAS Activity-Based Management OLAP tool will help them assess whether or not costs for that product are out of line with other products.

You will create a Multi-Stage Contributions cube and use the Decomposition Tree View to compare Parcel Express products.

1. **Create a Multi-Stage Contributions cube**
   1. Select File > New > OLAP View.
      
   You see the New OLAP View wizard.
   2. Select the Parcel Express model.
   3. Select the Multi Stage Contributions cube.
   4. Click Finish.
      
   You see the Multi-Stage Contributions cube for the Parcel Express model.
   5. Close the Chart View, and maximize the Decomposition Tree View.
   6. Move the mouse pointer over the All box.
      
   You see the cost of the entire model.
Run the Decomposition Tree wizard

1. Right-click the background of the Decomposition Tree View.
2. Select Decomposition Tree Wizard.
   You see the Decomposition Tree wizard splash screen.
3. Click Next.
   You see the next page of the wizard.

4. From the For items in list, select Cost Object Products and Services.
5. Click Finish.

Analyze the model in Decomposition Tree View

1. To see the Products and Services dimension members, click All.

2. Right-click 2nd Day Guaranteed.
3. Select Drill Down > Activity Activities > Level2.
   You see the activities that contribute cost to the 2nd Day Guaranteed product.
Using OLAP Cubes for Analysis

4. To compare the costs of 2nd Day Guaranteed to another product, drill down to the activities that contribute cost of **Overnight Express**.

   You see that the cost percentages from each activity are almost identical.

5. Right-click 2nd Day Guaranteed and select **Drill Down > Resource General Ledger > Level1 01**.

   You see the General Ledger accounts that contribute cost to 2nd Day Guaranteed.

6. Compare these figures with the General Ledger costs of Overnight Express.

   Again, on a percentage basis, the costs of 2nd Day Guaranteed do not appear to be out of line with those of other products.
Saving OLAP views and exporting cubes

During analysis, changes you make to Grid View, Chart View, and Decomposition Tree View are retained during a session, even when you return to the OLAP page after viewing other tabs. However, when you close the application or you close Grid View, Chart View, or Decomposition Tree View, your changes are lost.

To have these changes always available, you must save the OLAP view. When you save a OLAP view, you save the layout and contents of the views. However, the window positions and states are not saved.

At any point during OLAP analysis, you can export the displayed data to an Excel spreadsheet. When you export to Excel, you are exporting only the data currently displayed and not the entire cube.

➢ Save an OLAP view

1. Select OLAP > Save View.

   You see the Save OLAP View As dialog box.

2. Type a name of PX Multi-Stage Contributions.
3. Click OK.
4. On the toolbar, click the OLAP Home link.

   You see PX Multi Stage Contributions in the OLAP Views list.

➢ Export an OLAP cube

1. Display the OLAP data you want to export to an Excel spreadsheet.
2. Select OLAP > Export to Excel.

   You see an Excel spreadsheet containing currently displayed in the cube.
Finishing Up

Now that you have created a SAS Activity-Based Management model and learned the basics of model analysis, you can begin designing and implementing your own models. SAS Activity-Based Management contains many more features than were discussed in this tutorial. To build effective and complete models for your organization, you might have to employ some of these additional features, such as importing data from other information systems. Your models will be much larger than the Parcel Express model. You should learn about the application’s capabilities for creating, handling, and sharing large models.

Parcel Express conclusions

Using SAS Activity-Based Management, Parcel Express was able to see how costs flowed out of resource accounts to activities, and from activities to cost objects. In modeling the flow of costs through its business processes, the company learned that the 2nd Day Guaranteed product, which managers had assumed was not performing as well as the other products, was performing far worse than expected and was actually losing money across all channels.

An OLAP analysis of the model showed that the percentages of costs flowing from resource and activity accounts to cost object accounts was consistent across all product categories. Therefore, pricing seemed to be the primary reason for the underperformance. Another revelation was the amount of profit being made on the other two products.

Management must now decide how much of a loss, if any, is acceptable on the 2nd Day Guaranteed product. How will a price change affect volume? Is the higher profit on other products enough to offset the loss on 2nd Day Guaranteed?

To assess the impact of changes to the pricing structure, Parcel Express can use SAS Activity-Based Management to model possible future scenarios.

Additional features

Many SAS Activity-Based Management features are not covered in this tutorial or are covered only briefly. These include:

- Importing data from other information systems
- Importing models from databases, XML, or Oros
- Exporting models to databases or XML
- Sharing models
- Managing the ownership and permissions for items
- Publishing period/scenario associations
Finishing Up

- Managing item properties
- Working with large models
- Selecting currencies and exchange rates
- Working with internal units
- Creating stage attributes
- Creating custom report templates
- Using the SAS Services API

What to do next

If you felt comfortable using the basic tools and techniques to build the Parcel Express model, use them on a simple project of your own.

SAS has a variety of products, including videotapes and training classes, that can help you learn more about activity-based costing, management, and budgeting. We can also help you build models for your organization. If you need additional information, contact your SAS representative.
**Index**

### A

- account  
  - creating, 30  
  - single-dimension, 35  
- activity driver, 5  
- Activity module, 33  
- activity-based costing, 4  
- Activity-Based Management  
  - overview, 4  
- Add Accounts for Assignments dialog box, 42  
  - assignment  
    - creating, 41–49  
    - overview, 39  
- assignments pane, 13  
- attribute, 15  
  - boolean, 64  
  - creating, 65  
  - dimension, 64  
  - entering quantities, 65  
  - numeric, 64  
  - overview, 63  
  - text, 63  
  - types, 63  
- attributes  
  - use and benefits, 63

### B

- bill of costs  
  - creating, 54–57  
  - overview, 53  
  - steps for building, 53

### C

- Calculate Costs and Generate Cubes dialog box, 50  
- calculating costs, 50  
- CAM-I  
  - basic modules, 6  
  - Cost Assignment view, 5  
- Process view, 5  
- standards, 4  
- column layout, 14  
  - creating, 39  
- Column Layout dialog box, 39  
- Connect dialog box, 9  
- cost  
  - calculating, 50  
- cost driver, 5  
- Cost Object module, 35  
- costs  
  - create external units, 55  
- create  
  - assignment paths, 48  
  - external units, 55  
- credentials, 9  
- cube  
  - analyzing, 78  
  - exporting, 88  
  - generating, 76  
  - Multi-stage Contributions, 75  
  - overview, 15, 75  
  - Resource Contributions, 76  
  - Single-stage Contributions, 76  
  - types, 75

### D

- Decomposition Tree  
  - using, 85  
- Decomposition Tree wizard, 86  
- dialog box  
  - Add Accounts for Assignments, 42  
  - Calculate Costs and Generate Cubes, 50  
- Column Layout, 39  
- Connect, 9  
- Dimension Name, 25  
- Filtering, 80  
- Manage Period, 20  
- Manage Scenarios, 21  
- New Attribute, 64  
- New Dimension Member, 28
password, 10
period
  creating, 19
deleting, 22
overview, 19
planning a model, 16
profit
  calculating, 61
property, 15
Q
quantity
  fixed, 54
  variable, 54
R
report
  configuring, 73
exporting, 71
generating, 68
navigating, 71
overview, 67
publishing, 72
saving, 71
templates, 67
Resource Contributions cube, 76
resource driver, 5
Resource module, 30
revenue
  entering, 61
S
sales volume, 59
entering, 60
SAS Activity-Based Management
  additional features, 89
  home page, 10
  starting, 9
Save Column Layout As dialog box, 41
scenario
  creating, 21
deleting, 22
overview, 19
single-dimension account, 35
Single-stage Contributions cube, 76
sold quantity, 59
T
Technical Support
  contacting, 2
  training, 2, 90
tutorial
  conventions, 1
V
variable quantities, 54
W
wizard
  Decomposition Tree, 86
  New Account, 30
  New Measure, 83
  New Model, 23
  New OLAP View, 77
  New Report, 68